Subject: [netatalk-admins] Routing Problems between LocalTalk and EtherTalk

From: Patrik Schindler <[email-masked]>
Date: Fri, 10 Oct 1997 11:52:41 +0200

Hi, out there!

Bradford W. Johnson, the holy keeper of the one and only driver for a LocalTalk ISA Card couldn't fix this Problem, I now have. Will this Problem be fixed in 2.0.31? I'm now running 2.0.29 and won't move to 30 because of some ISDN difficulties.

leela:/root # cat /usr/local/etc/atalkd.conf
eth0 -seed -phase 2 -net 13-20 -addr 19.1 -zone "Ether"
ltalk0 -seed -phase 1 -net 21 -addr 21.1 -zone "Local"
leela:/root # nbplkup
                          leela:AFPServer                          21.1:130
                    Nullprinter:LaserWriter                        21.1:128
                          leela:netatalk                           21.1:4
                          leela:Workstation                        21.1:4
                       Powermac:Power Macintosh 7100/66            15.224:253
                       Powermac:Arbeitsplatz                       15.224:4
                   Performa 630:  Macintosh                        19.22:253
                   Performa 630:Arbeitsplatz                       19.22:4
leela:/root # cat /proc/net/atalk_iface
Interface         Address   Networks   Status
ltalk0           0015:01  0015-0015  0
eth0             0013:01  000D-0014  0
lo               0000:00  0000-0000  0
leela:/root # cat /proc/net/atalk_route
Target        Router  Flags Dev
0015:01     0000:00  5     lo
0015:00     0015:01  1     ltalk0
0013:01     0000:00  5     lo
0014:00     0013:01  1     eth0
0013:00     0013:01  1     eth0
0012:00     0013:01  1     eth0
0011:00     0013:01  1     eth0
0010:00     0013:01  1     eth0
000F:00     0013:01  1     eth0
000E:00     0013:01  1     eth0
000D:00     0013:01  1     eth0
0000:00     0000:00  5     lo

I can see all devices from the view of leela. Nullprinter is -as you can see by the address- a printqueue on leela. I've tested to connect to the SE/30 with FileSharing, but my Powermac says "no answer from the fileserver". I tried to print from Powermac, but I get errors "the printer could not be found" or similar. Connecting to leela from SE/30 works *very* fine and without any errors! On the other hand, I cannot see Powermac or any other devices on Ethernet from LocalTalk. It seems as if there's a "backward route" missing.
I hope, I haven't forgot any detail you may need.
Can anyone help?

:wq! PoC

---

From: Patrik Schindler <[email-masked]>
Date: Fri, 10 Oct 1997 22:05:18 +0200

>The popular wisdom
>seems to be that this will not be fixed in the 2.0.X series of
>kernels.

So this is a kernel problem (DDP-Support)?

This is VERY bad to read. I thought, I could workaround it, if I print over the spoolsystem. But I couldn't get this to work. I read doco and FAQs, set my printcap up right. A job send by lpr will be processed but never gets through to the printer.
/usr/local/etc/psf < testtextfile |pap -p "QMS-PS 410:LaserWriter@Local" prints out successfully. The lpr job never, but ps says pap is running and some ofpap status information appears in the syslog, they all state success (1.4b2 unpatched).

[Printcap:]
lp|qms:\
        :sd=/var/spool/lpd/qms:\
        :lp=/dev/null:\
        :if=/usr/local/printerfilter/ifpap:\
        :of=/usr/local/printerfilter/ofpap:\
        :tf=/usr/local/printerfilter/tfpap:\
        :df=/usr/local/printerfilter/dfpap:\
        :mx#0:sh:

[/var/spool/lpd/qms/.paprc]
QMS-PS 410:LaserWriter@Local

I tried this in various escapes and quotes, but it won't work. If I call pap from within this directory, it finds the printer and prints, so I don't suspect the error here. I tested printing over /dev/lp and this works fine!
Can anybody guess, what I'm doing wrong? 
If you need more information, I'll supply this.

:wq! PoC