Subject: [netatalk-admins] two port problem

From: John Barry -Technician <[email-masked]>
Date: Tue, 2 Sep 97 14:24:53 BST

I've just compiled up netatalk-1.4b2+asun2.0a15, and apart from a little glitch
with the des library it worked out just fine.
However, I'm having problems getting it to run properly on a SPARC station 2
with 2 network cards.
in 'discovery' mode I get an atalkd.conf like this:

le0 -phase 2 -net 65280-65534 -addr 65280.32
le1 -phase 2 -net 65280-65534 -addr 0.0

and then I get this:

+ etc/rc.atalk 
loading netatalk: module loaded; id = 2
starting appletalk daemons: atalkdnbp_rgstr: Connection timed out
Can't register hector:Workstation@*
nbp_rgstr: Connection timed out
Can't register hector:netatalk@*
 nbprgstretc/rc.atalk: 987 Memory fault
 papd afpd.

(I got that from sh -x , but at boot I get much the same thing.)

I'm vaguely worried about le1 having an address of 0.0
Ideas?
later
jb

---

From: Gregor Retti <[email-masked]>
Date: Tue, 2 Sep 1997 17:15:51 +0200

>le1 -phase 2 -net 65280-65534 -addr 0.0

what is connected to the ports? the net 65280-65534 information must come
somewhere from - most proberably a router. but what about le1? if your
sparc is to connect this segment to the rest of the net, you have to
provide some seed-information. I think, that is where the 0.0 comes from ...

greetings
gregor

-----------------------------------------------------------------------
 gregor retti ---------------- http://germ2.uibk.ac.at/germ/retti.html
-----------------------------------------------------------------------

---

From: a sun <[email-masked]>
Date: Tue, 2 Sep 1997 23:35:02 -0700 (PDT)

sigh. please don't use a15. i screwed up, and it doesn't do things the
right way in a couple cases. i'll make a new patch available which
should do a better job.

-a