Subject: [netatalk-admins] I'm missing something. [long]

From: Andrew Brennan <[email-masked]>
Date: Mon, 15 Sep 1997 22:05:09 -0400 (EDT)

Ok.  I have here a Pentium/90 running Linux (kernel is a freshly-
   compiled 2.0.30 with Appletalk in the kernel, not modularized).
   3Com Etherlink III card inside.  I also have a clean network -- 
   courtesy of an 8 port hub with only the Linux box and a portable
   Mac connected.

   I have had nothing but difficulty with the Debian install of the
   netatalk package (mildly untrue, but you'll find out where I'm 
   going momentarily) and decided to get the 1.4b2 source and load 
   it in by hand.  Installed it, rebooted and ran rc.atalk with the
   zones I need in the /usr/local/atalk/etc/atalkd.conf file.

   eth0 -seed -phase 2 -net 500-502 -addr 500.133 -zone SanAndreas

   ... and once again, I see no zone information and my atalkd.conf
   has been rewritten to:

   eth0 -seed -phase 2 -net 0-65534 -addr 500.133

   Looking at the tips sheet, I see possible reasons for problems.

   o non-multicast Ethernet cards.
     ... but the card works fine for afpd and appears to advertise
     the system correctly, so this one isn't(?) it.
   o Large range of defined networks on cable segment.
     ... I tested with a disconnected hub and a single Mac portable
     (even had it disconnected for a few tries).  Not this one.
   o No router on network, atalkd can't assign it's own number.
     ... it's *never* had difficulty assigning itself an address.
   o No DDP support in kernel.
     ... (above) fresh kernel, shouldn't be the problem.
   o Second start of atalkd.
     ... I'm rebooting between tries, so this one isn't it.

   I'm out of ideas.  Possibly the card doesn't support multicast
   completely?  IFCONFIG reports it as having MULTICAST enabled,
   but maybe it's lying?  It also reports "Ethertalk Phase 2 addr
   500/133", so I don't think it's my card.  (also visible afpd 
   activity from the portable Mac)

   This is probably related ... getzones -l, getzones -m and even
   getzones 500.133 (above - the netatalk box itself) all respond
   with a "atp_rresp: Connection timed out" error.  At the same 
   time, aecho 500.133 reports a 0% packet loss (and can echo the
   other Mac w/o any loss as well).

   I would really like to have this system act as an AppleTalk 
   router (we need one on this segment) but it's refusing me at 
   every turn.  Anyone see something obvious that I've missed??

   andrew.  ([email-masked])

---

From: Patrick Scott Pierce <[email-masked]>
Date: Tue, 16 Sep 1997 07:18:02 -0400 (EDT)

I had difficulty at one point until I realized I didn't have multicasting
either compiled into the kernel or as a module.  So the card could support
it but the kernel couldn't.  You will want to check your kernel for that
and of course the ddp.  If not, recompile.  I would compile multicasting
support vs. a module.

Patrick Scott Pierce
[email-masked]
CGI Programming
Mindspring Enterprises

On Mon, 15 Sep 1997, Andrew Brennan wrote:

> Date: Mon, 15 Sep 1997 22:05:09 -0400 (EDT)
> From: Andrew Brennan <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Subject: [netatalk-admins] I'm missing something. [long]
>

---

From: Gregor Retti <[email-masked]>
Date: Tue, 16 Sep 1997 15:11:03 +0200

>   andrew.  ([email-masked])

you need more than 1 device (eg. eth0, eth1 oder eth0, dummy) to have zones
defined and to have an appletalk router you need at least to segments to
route from one to the other.

cheers
gregor

-----------------------------------------------------------------------
 gregor retti ---------------- http://germ2.uibk.ac.at/germ/retti.html
-----------------------------------------------------------------------

---

From: Alistair Riddell <[email-masked]>
Date: Tue, 16 Sep 1997 17:22:57 +0100 (BST)

> route from one to the other.

Not true - you can have a router with only one interface (it won't do much
routing though) and having zones defined is dependent only on having a
at least one seed router on the network.

--
Alistair Riddell - BOFH
IT Support Department, George Watson's College, Edinburgh
Tel: +44 131 447 7931 Ext 176       Fax: +44 131 452 8594

---

From: "Steven N. Hirsch" <[email-masked]>
Date: Tue, 16 Sep 1997 18:42:04 -0400 (EDT)

> and of course the ddp.  If not, recompile.  I would compile multicasting

Argh.  I was just bitten by this last evening.  The original pre-2.0.30
kernels which I ran for netatalk hacking had 'dummy' drivers with
multicasting functionality active.  I knew that the 2.1.x kernels ifdef'ed
this out (never understood why), but I _didn't_ realize that the change
propogated back to the 2.0 series! 

Quick Patch (thanks to Brad Johnson):

--- linux/drivers/net/dummy.c.2126	Sun Feb  2 07:18:39 1997
+++ linux/drivers/net/dummy.c	Thu Feb 20 12:24:20 1997
@@ -29,7 +29,7 @@
 */
 
 /* To have statistics (just packets sent) define this */
-#undef DUMMY_STATS
+#define DUMMY_STATS 1
 
 #include <linux/module.h>
 
@@ -70,6 +70,9 @@
 	return 0;
 }
 
+static void dummy_set_multicast_list(struct device *dev)
+{
+}
 
 int dummy_init(struct device *dev)
 {
@@ -95,6 +98,7 @@
 	ether_setup(dev);
 	dev->tx_queue_len = 0;
 	dev->flags |= IFF_NOARP;
+	dev->set_multicast_list = &dummy_set_multicast_list;
 
 	return 0;
 }

This applies to 2.0.31-pre9 with some minor fuzz.

Does anyone have hardware and/or jumper information on the COPS/DayStar
Digital LT200?  COPS' website had the port addressing settings, but
nothing on the IRQ jumpers.

Steve