Subject: [netatalk-admins] does netatalk handle filelocking? (and vs. Windows NT)

From: Jeff Wiegley <[email-masked]>
Date: Thu, 02 Oct 1997 17:57:20 -0700

I'm trying to pitch to my employers that linnux/netatalk is the
way to go for solving our windows/mac filesharing problems.

I've gotten netatalk up and running without too much trouble and
I've got a meeting set to discuss using linux as the server 
operating system versus using Windows NT.

Two questions I have:

   1) Does netatalk support any sort of file locking mechanisms?
      using the mac server that we now use locking seems to happen
      but under my installation of netatalk on a temporary machine
      file locking doesn't seem to happen.

   2) Can everyone give me some good reasons why we should use
      linux as the operating system of choice instead of
      Windows NT? I have one supervisor who is not real keen on
      using linux because NT is a well-known commercial product.
      (I say "big deal"...)

any how any answer to these questions or any other topics that
might be of interest to note about using netatalk/samba and linux
together would be greatly appreciated.

- Jeff Wiegley

-- 
<html><head><title>
J E F F  W I E G L E Y
</title></head><body><a href="http://www.w3-design.com/">
W 3 - d e s i g n,  I n c.
<p> phone: (310) 815-1177 x 307 fax:(310) 815-1133 </p>
</a></body></html>

---

From: Patrick Scott Pierce <[email-masked]>
Date: Fri, 3 Oct 1997 07:02:36 -0400 (EDT)

Money for one.  NT with all of its licensing can get super expensive.
Flexibility. Generally, you have full access to source code. Remote
administration, if my boss calls at 3:00 AM to say something is up I don't
have to put on clothes to fix it (though recommended for colder regions).

Patrick Scott Pierce
[email-masked]
CGI Programming
Mindspring Enterprises

On Thu, 2 Oct 1997, Jeff Wiegley wrote:

> Date: Thu, 02 Oct 1997 17:57:20 -0700
> From: Jeff Wiegley <[email-masked]>
> To: [email-masked], [email-masked]
> Subject: [netatalk-admins] does netatalk handle filelocking? (and vs. Windows NT)
>

---

From: Alistair Riddell <[email-masked]>
Date: Fri, 3 Oct 1997 10:30:24 +0100 (BST)

Q1: AFAIK file locking has yet to be added to Netatalk.

Q2: Linux/Netatalk is free, and is also way faster than NT on the
same hardware.
Also, I think you would be hard pushed to find an NT box with an uptime of
more than a couple of months, let alone the 400 days + that I have heard
of with linux...

--
Alistair Riddell - BOFH
IT Support Department, George Watson's College, Edinburgh
Tel: +44 131 447 7931 Ext 176       Fax: +44 131 452 8594

---

From: Ken Weiss <[email-masked]>
Date: Fri, 3 Oct 1997 08:35:15 -0700

At 5:57 PM -0700 10/2/97, Jeff Wiegley wrote:
>      Windows NT?

You can manage a Linux (or other UNIX) server remotely. To do anything to
an NT server you need to attach a monitor, keyboard and mouse, and sit down
in front of the box. This can be really inconvenient when you get paged at
9:00 at night, when you're at home and the server is locked in a machine
room, in a locked building, on a campus that's 18 miles from where you are
sitting.

---------------------------------------------------------------------------
Ken Weiss                                               [email-masked]
Distributed Computing Analysis & Support               916/752-5554 (voice)
2323 Academic Surge                                      916/752-9616 (fax)
U.C. Davis
Davis, CA 95616                        http://dcas.ucdavis.edu/kenhome.html

---

From: Julian Elischer <[email-masked]>
Date: Fri, 03 Oct 1997 10:21:35 -0700

> >       file locking doesn't seem to happen.

netatalk doesn't yet really support full locking yet.. 
We use it in our product together with SAMBA, and are adding
compatibility code to both for this. Common locking is something
we're looking at. The Guy presently in charge of Samba works here,
where his job includes working on netatalk, so they do work together
well, but locking is a bit harder.

> >       using linux because NT is a well-known commercial product.
We use FreeBSD in our product. The arguments are the same as Linux.
1/ They are stable
2/ they can be fully managed remotely.
3/ They are fast.
4/ the price is right.
5/ The support is better.

BTW, see www.whistle.com for the product..