Subject: Netatalk software on r/o file system

From: Georg Schwarz <[email-masked]>
Date: Mon, 30 Jun 1997 18:17:57 +0200 (MEST)

I've installed netatalk 1.4b2 on Linux 2.0.29 with DESTDIR=/usr/local.
However, on one of the machines I run it /usr is mounted read-only.

Now when I launch atalkd I get the following messages:

Jun 30 18:04:19 helena atalkd[93]: restart (1.4b2)
Jun 30 18:04:20 helena atalkd[93]: zip_getnetinfo for eth0
Jun 30 18:04:39 helena last message repeated 2 times
Jun 30 18:04:49 helena atalkd[93]: config for no router
Jun 30 18:04:50 helena atalkd[93]: /usr/local/etc/atalkd.tmp: Read-only file system
Jun 30 18:04:50 helena atalkd[93]: ready 0/0/0

it looks like atalkd assumes that the directory where it is located
is writable.
Can I explicitely tell atalkd not to and to use some different
directory for temp files?
Also, it looks like atalkd modifies its atald.conf file (or at least
tries to).
Both I think are bad practise. Such files, IMHO, should be located
on either /tmp or /var. Maybe one could even call this a bug?
Anyway, I tried to search trough the code but were unable to
find out where exactly those tmp files are created.
Any suggestions to overcome this problem short of relocating atalk
to some locally writable directory?
I'd like to mount one copy of netatalk to different machines.
Thanks.

-- 
Georg Schwarz                             [email-masked]
Institut für Theoretische Physik    Tel. +49 30 314-24254, FAX -21130
Technische Universität Berlin          http://home.pages.de/~schwarz/
Sekr. PN 7-1, Hardenbergstr. 36, D-10623 Berlin            IRC: kuroi

---

From: Patrik Schindler <[email-masked]>
Date: Tue, 1 Jul 1997 10:35:48 +0200 (MET DST)

> Also, it looks like atalkd modifies its atald.conf file (or at least

Yep, it does, 'cause it tries to write down it's actual configuration. 
This may change, because Macs adresses arent static.

PoC