Subject: [netatalk-admins] no login except as guest

From: [email-masked] (Stefan Barth)
Date: Mon, 15 Dec 1997 11:48:30 +0100

Hi!
I´ve installed netatalk 1.4b2 on two PCs, a 486 and a 133 MHz Pentium w/ 16 MB RAM.
Linux is from a SuSE 5.0 distribution, the kernel says it´s 2.0.30.

After setting up various accounts the following problem persists: No matter under which name and from which 
Mac (Sys 7.6 on a II fx or 8.0 on different PowerMacs), any attempt to log in as user results in a message 
"Wrong password...". Logging in as guest works fine.
This is an excerpt of /var/log/messages:
--

Dec 15 11:16:47 Beelzebub atalkd[281]: restart (1.4b2)
Dec 15 11:16:48 Beelzebub atalkd[281]: zip_getnetinfo for eth0
Dec 15 11:17:07 Beelzebub last message repeated 2 times
Dec 15 11:17:17 Beelzebub atalkd[281]: config for no router
Dec 15 11:17:18 Beelzebub atalkd[281]: ready 0/0/0
Dec 15 11:17:31 Beelzebub papd[291]: restart (1.4b2)
Dec 15 11:17:37 Beelzebub papd[291]: register Beelzebub:LaserWriter@*
Dec 15 11:17:37 Beelzebub afpd[293]: Beelzebub:AFPServer@* started on 65280.115:130 (1.4b2)

-- This is where I log in as guest --

Dec 15 11:20:42 Beelzebub afpd[300]: session from 65280.13:244 on 65280.115:129
Dec 15 11:20:42 Beelzebub afpd[300]: login noauth

-- The linux volume is removed from the mac´s desktop --

Dec 15 11:21:08 Beelzebub afpd[300]: done
Dec 15 11:21:08 Beelzebub afpd[293]: asp_chld 300 done

-- Here I try with different names and passwords to log in --

Dec 15 11:21:20 Beelzebub afpd[301]: session from 65280.13:244 on 65280.115:129
Dec 15 11:21:20 Beelzebub afpd[301]: done
Dec 15 11:21:20 Beelzebub afpd[293]: asp_chld 301 done
Dec 15 11:21:26 Beelzebub afpd[302]: session from 65280.13:244 on 65280.115:129
Dec 15 11:21:26 Beelzebub afpd[302]: done
Dec 15 11:21:26 Beelzebub afpd[293]: asp_chld 302 done
Dec 15 11:21:32 Beelzebub afpd[303]: session from 65280.13:244 on 65280.115:129
Dec 15 11:21:32 Beelzebub afpd[303]: done
Dec 15 11:21:32 Beelzebub afpd[293]: asp_chld 303 done

--

In a netatalk.faq I found a reference to this problem, with one explanation concerning "illegal shells", the 
other with shadow passwords. I did grep on all the log files I could think of and didn´t get an entry for 
illegal.
As for shadow passwords, I presume it´s a default of this distribution to use them, there is an /etc/shadow 
file. I don´t know how this ties in with netatalk, however.

Can anybody help?

Sincerely, Stefan Barth

---

From: Brian Bergstrand <[email-masked]>
Date: Mon, 15 Dec 1997 08:25:57 -0600

>This is an excerpt of /var/log/messages:
[log snip]
>
>In a netatalk.faq I found a reference to this problem, with one
>explanation concerning "illegal shells", the

Seth, you need to turn on support for shadow passwords. In your netatalk
src directory, cd to etc/afpd. Open the makefile for that directory with
your favorite editor, and add the following to the CFLAGS option:
-DSHADOWPW

Save the change, and cd back to the root of your netatalk src dir, and do a
make clean, then make. You should be set to go.

Brian

Brian Bergstrand
Network Specialist
Northern Illinois University
815-753-8547
[email-masked]

---

From: Kevin Violette <[email-masked]>
Date: Mon, 15 Dec 1997 16:05:31 -0500

> Northern Illinois University

I am having the same problem however when trying to recompile afpd I get
this ERROR:

main.c:255  'TIOCNOTTY' undeclared (first use this function).....

I am now using REDHAT 5.0 (Hurricane).  I was using Builtmore and
netatalk was working great.  Now All I can do is get in as guest.  
Thanks for the help.

Kevin Violette
Computer Consultant
University of North Carolina at Wilmington
[email-masked]