Subject: [netatalk-admins] Problems with netatalk and novel-server

From: Stephan Bauer <[email-masked]>
Date: Sat, 06 Sep 1997 14:04:29 +0200

Hi,

I´m trying to include a linux netatalkserver into an net with 
MACs and a NOVEL-server.

The selfconfiguration of atalkd failed (without atalk.conf):

Sep  6 13:05:23 gaby atalkd[271]: restart (1.4b2)
Sep  6 13:05:24 gaby atalkd[271]: zip_getnetinfo for eth0
Sep  6 13:05:24 gaby atalkd[271]: zip gnireply from 5.234 (eth0 12)
Sep  6 13:05:25 gaby kernel: Too many routes/iface.
Sep  6 13:05:25 gaby atalkd[271]: setifaddr: eth0: Invalid argument

There are two zones but no router

SaM_MAC_ZONE and SaM_NOVEL_Zone

Selfconfiguration of eth0 without the NOVEL-server shows:

Sep  6 13:21:06 gaby atalkd[203]: restart (1.4b2)
Sep  6 13:21:07 gaby atalkd[203]: zip_getnetinfo for eth0
Sep  6 13:21:26 gaby last message repeated 2 times
Sep  6 13:21:36 gaby atalkd[203]: config for no router
Sep  6 13:21:37 gaby atalkd[203]: ready 0/0/0
                                                                               
atalk.conf:

eth0 -phase 2 -net 0-65534 -addr 65280.30    
                                                                               
If I try to start netatalk with this configuration:

Sep  6 13:30:48 gaby atalkd[213]: zip gnireply from 5.234 (eth0 12)
Sep  6 13:30:49 gaby kernel: Too many routes/iface.
Sep  6 13:30:49 gaby atalkd[213]: setifaddr: eth0: Invalid argument

rc.atalk:

echo -n 'starting appletalk daemons:'
if [ -f /usr/local/atalk/etc/atalkd ]; then
	/usr/local/atalk/etc/atalkd;		echo -n ' atalkd'
fi

if [ -f /usr/local/atalk/bin/nbprgstr ]; then
	/usr/local/atalk/bin/nbprgstr -p 4 `hostname|sed
's/\..*$//'`:Workstation
	/usr/local/atalk/bin/nbprgstr -p 4 `hostname|sed 's/\..*$//'`:netatalk
					echo -n ' nbprgstr'
fi

if [ -f /usr/local/atalk/etc/papd ]; then
	/usr/local/atalk/etc/papd;		echo -n ' papd'
fi

if [ -f /usr/local/atalk/etc/afpd ]; then
	/usr/local/atalk/etc/afpd -c 20;		echo -n ' afpd'
fi
            
Kernel-version is 2.0.30, netatalk is 1.4b2 without patches

Thanks
Stephan

---

From: [email-masked]
Date: Sat, 06 Sep 1997 10:45:02 -0400

> From:    Stephan Bauer <[email-masked]>
> To:      [email-masked]

> Sep  6 13:05:25 gaby atalkd[271]: setifaddr: eth0: Invalid argument

Even tho you have no router, the novell server will look like one on
the network.  To get this to work, you should re-configure the novell
server to have a smaller netrange for your ethernet.  I'm not 100%
certain why there's a limit in the AppleTalk module for Linux...

:wes