Subject: [netatalk-admins] Re: afp/tcp patch release a11

From: John Barry -Technician <[email-masked]>
Date: Wed, 9 Jul 97 11:42:30 BST

Hi folks,

Well I've just compiled up netatalk-1.4b2+asun2.0a11, it complied clean first
time, (with the exception that our system: SunOS 4.1.4, doesn't seem to have
bitypes.h or cdefs.h installed, so I downloaded them and patched the source...)
I've yet to test it on a "live" system, but I'll get to that this afternoon.
(11:28am local) 

I spent several hours last night building a reasonably complete list of file
mappings for the AppleVolumes.system file (included below) enjoy:

(Note: as noted in an earlier post I have problems printing to a lineprinter
via ghostscript and the laserwriter8 driver with simpletext, so most text
file are assigned to BBedit, similarly my choice of GFX prog is
GraphicConverter, Sound = SoundApp, Mpeg = quicktime)
later
jb

#
# This file is read before (after if -u is specified) the user's
# AppleVolume file.  Add extension mappings and volumes here.
#
 
# default translation -- note that CR <-> LF translation is done on all
# files of type TEXT.  The first line turns off translation for files of
# unknown type, the second turns this translation on.
.       BINA    UNIX
# .       TEXT    UNIX
 
# sounds
.8med   STrk    SCPL
.8svx   8SVX    SCPL
.svx    8SVX    SCPL
.hcom   FSSD    SCPL
.mod    STrk    SCPL
.midi   Midi    SCPL
.mid    Midi    SCPL
.med    STrk    SCPL
.nst    STrk    SCPL
.otk    OKTA    SCPL
.mp2    MPEG    SCPL
.mpa    MPEG    SCPL
.m1a    MPEG    SCPL
.aif    AIFF    SCPL
.aiff   AIFF    SCPL
.aifc   AIFF    SCPL
.snd    BINA    SCPL
.wve    BINA    SCPL
.wav    WAVE    SCPL
.au     ULAW    SCPL
.ul     ULAW    SCPL
.al     ALAW    SCPL
.voc    VOC     SCPL
.ra     PRNA    PNst
.rm     PRNA    PNst
.ram    PNRM    PNst
 
# video
.moov   MooV    TVOD
.qt     MooV    TVOD
.mov    MooV    TVOD
.mpg    MPEG    TVOD
.mpeg   MPEG    TVOD
.mpe    MPEG    TVOD
.m1s    MPEG    MPsp
.m1v    MPEG    mMPG
.m2v    MPG2    MPG2
 
# formatted text
.html   TEXT    MOSS
.htm    TEXT    MOSS
.url    AURL    Arch
.rtf    TEXT    MSWD
.doc    WDBN    MSWD
.rxt    TEXT    R*ch
.txt    TEXT    R*ch
.tx8    TEXT    R*ch
.text   TEXT    R*ch
.asc    TEXT    R*ch
.ascii  TEXT    R*ch
.bas    TEXT    R*ch
.bat    TEXT    R*ch
.cmd    TEXT    R*ch
.diz    TEXT    R*ch
.faq    TEXT    R*ch
.ini    TEXT    R*ch
.mak    TEXT    R*ch
.me     TEXT    R*ch
.pl     TEXT    R*ch
.prn    TEXT    R*ch
.1st    TEXT    R*ch
.readme TEXT    R*ch
.rme    TEXT    R*ch
.read   TEXT    R*ch
readme  TEXT    R*ch
README  TEXT    R*ch
INSTALL TEXT    R*ch
.rtx    TEXT    R*ch
.uue    TEXT    R*ch
.uu     TEXT    R*ch
.ai     EPSF    vgrd
.eps    EPSF    vgrd
.ps     EPSF    vgrd
.epsf   EPSF    vgrd
.pdf    PDF     CARO
 
# compressed archives
.bin    BINA    SIT!
.zip    ZIP     ZIP 
.tar    TARF    TAR!
.gz     Gzip    SIT!
.Z      ZIVM    SIT!
.sea    APPL    aust
.cpt    PACT    CPCT
.sit    SITD    SIT!
.hqx    TEXT    SIT!
.img    rohd    ddsk
.image  dlmg    dCpy
 
# graphics
.psd    8BPS    8BIM
.iff    ILBM    GKON
.ilbm   ILBM    GKON
.lbm    ILBM    GKON
.xbm    XBM     GKON
.xpm    XPM     GKON
.pbm    PPGM    GKON
.ppm    PPGM    GKON
.pgm    PPGM    GKON
.png    PNG     GKON
.ptng   PNTG    GKON
.pm     PMpm    GKON
.plt    HPGL    GKON
.qdv    QDVf    GKON
.raw    BINA    GKON
.pcs    PICS    GKON
.targa  TPIC    GKON
.tga    TPIC    GKON
.pac    STAD    GKON
.rle    RLE     GKON
.six    SIXE    GKON
.sup    SCRN    GKON
.ras    SUNn    GKON
.sr     SUNn    GKON
.sun    SUNn    GKON
.scg    RIX3    GKON
.sci    RIX3    GKON
.scp    RIX3    GKON
.scr    RIX3    GKON
.scu    RIX3    GKON
.wmf    WMF     GKON
.sgi    SGI     GKON
.rgb    SGI     GKON
.rgba   SGI     GKON
.riff   RIFF    GKON
.tiff   TIFF    GKON
.tif    TIFF    GKON
.vff    VFFf    GKON
.bmp    BMPp    GKON
.bga    BMPp    GKON
.vga    BMPp    GKON
.dcx    DCXx    GKON
.pcx    PCXx    GKON
.mac    PICT    GKON
.pct    PICT    GKON
.pic    PICT    GKON
.pict   PICT    GKON
.jpeg   JPEG    GKON
.jfif   JPEG    GKON
.jpe    JPEG    GKON
.jpg    JPEG    GKON
.gif    GIFf    GKON

---

From: Georg Schwarz <[email-masked]>
Date: Wed, 9 Jul 1997 12:46:43 +0200 (MEST)

> mappings for the AppleVolumes.system file (included below) enjoy:

Thanks.
BTW, does Netatalk treat extensions case insensitively? (i.e. are .htm and
.HTM equivalent by definition?)

-- 
Georg Schwarz                             [email-masked]
Institut für Theoretische Physik    Tel. +49 30 314-24254, FAX -21130
Technische Universität Berlin          http://home.pages.de/~schwarz/
Sekr. PN 7-1, Hardenbergstr. 36, D-10623 Berlin            IRC: kuroi

---

From: Patrik Schindler <[email-masked]>
Date: Wed, 9 Jul 1997 13:29:11 +0200 (MET DST)

> mappings for the AppleVolumes.system file (included below) enjoy:

Ugh, what a mess! Thank you *VERY* much!

PoC

---

From: Patrik Schindler <[email-masked]>
Date: Wed, 9 Jul 1997 13:31:07 +0200 (MET DST)

> .HTM equivalent by definition?)

No as of my knowing and at last, it shouldn't, 'cause Unix-FS are case 
sensitive.

PoC

---

From: Georg Schwarz <[email-masked]>
Date: Wed, 9 Jul 1997 13:33:28 +0200 (MEST)

> No as of my knowing and at last, it shouldn't, 'cause Unix-FS are case 

still it might make sense to treat extension resolving case insensitively.

---

From: [email-masked]
Date: Wed, 09 Jul 1997 09:52:12 -0400

> From:    Georg Schwarz <[email-masked]>
> To:      [email-masked] (Patrik Schindler)

> > > BTW, does Netatalk treat extensions case insensitively? (i.e. are .htm
> > > and .HTM equivalent by definition?)

> still it might make sense to treat extension resolving case insensitively.

They are.  See etc/afpd/volume.c.  The function in question is
getextmap().  The check is done with strdiacasecmp(), a diacritically
sensative, case insensative, string compare.  Which is found in
libatalk/util/strdicasecmp.c.  The file name is funny because "ar"
truncates the expected name.

:wes