Subject: Re: [netatalk-admins] character set mapping

From: Jeremy Allison <[email-masked]>
Date: Thu, 21 Aug 1997 11:16:05 -0700

[email-masked] wrote:

> I'd be happy if Netatalk could translate filenames from the Mac coding
> scheme to ISO-Latin1 (and vice-versa). That would help me a lot in
> having my samba and netatalk servers cooperate. (We speak french here
> in Tahiti, so we have to deal with those weird accentuated chars ;)

David,

	I have done a lot of work here at Whistle on
getting Samba and netatalk to cooperate. I am the primary
maintainer of Samba, so the Samba changes I have checked directly
into the Samba code, but I need to feed my netatalk changes
back into the main source stream.

Essentially, I have changed netatalk so that you can specify
a dos client code page that netatalk will translate the MAC
roman character set into before storing on the unix drive.

Now this means that the files are stored as dos code page
characters on the unix drive, netatalk needs a mechanism
adding similar to Samba that would allow a translation
to a unix character set before storage - but this code
does the job of allowing accented characters to be seen
correctly between windows and mac clients (we need this
for the Whistle product). The code is somewhat primitive
at the moment as it uses static tables built into netatalk
but I will be extending it to allow dynamic loading of
code page tables based on the client code page set in
a config variable.

I should have all this finished in a couple of months,
could someone tell me how to submit this stuff back ?
I have been meaning to do this for a while, but have
been rather busy with writing it :-).

Regards,

	Jeremy Allison,
	Whistle Communications.

-- 
--------------------------------------------------------
Buying an operating system without source is like buying
a self-assembly Space Shuttle with no instructions.
--------------------------------------------------------

---

From: Stephan Bauer <[email-masked]>
Date: Wed, 24 Sep 1997 15:45:23 +0200

Bon jour, David!

I have fiddled a bit with the same thought, and found some good spots in
the netatalk code to insert translation code into. My time is limited,
however :(. It shouldn't be too hard to do a straight translation, but
there might be problems in defining when to translate, i.e. for which
documents. All this is available with CAP, but CAP has other drawbacks,
which made us move over to netatalk. For now, we live with the problem.
   Also, is anyone else looking into this?

Best regards,
Palle

Hello,

this is just what I am looking for.

Stephan