Subject: Re: [netatalk-admins] routing problem

From: "Mike Durian" <[email-masked]>
Date: Fri, 25 Jul 1997 18:22:35 -0600

On Fri, 25 Jul 1997 17:20:27 MDT, Miles Nordin <[email-masked]> wrote:
>1. Shut off _every_ mac on all four subnets.  NO EXCEPTIONS.  maybe use
>   nbplkup starting atalkd one net at a time to ensure this.
>2. Start atalkd on the FreeBSD machine with Bill's suggested atalkd.conf
>3. Restart all the Mac's.

  A little experimentation on my part showed this to be the case.
(The one powered on Mac didn't switch over until I rebooted it).
This is easy enough for us to do since we don't have many AppleTalk
machines, but what about the power failure case?  Do the Macs remember
their last used address and try to reconfigure to it, or is it a
crap shoot as to which machine comes up first?

mike

---

From: Julian Elischer <[email-masked]>
Date: Fri, 25 Jul 1997 22:03:19 -0700

> crap shoot as to which machine comes up first?

Be aware that htere is a bug in FreeBSD's appletalk
stack..
it is not possible to add a route to a net that has a router  on a
differnt 'net' than your interface..
e.g.

ed0 is net-range 110-115, with address 111.21
teh router to net 116 is 110.23

the command 
route add -atalk 116.0 110.23
will fail

if the router had an address starting with 111, it would succeed.

I will try fix this bug when I get back from 
vacation in 10 days..
(since I did the port)

julian