Subject: no user logins to afpd - guest works fine

From: "lars" <[email-masked]>
Date: Fri, 13 Jun 1997 01:41:42 +0000

Hi all!
Okay, this is probably an old but good one:

Guest login to afpd on the linux box runs ok....
BUT: User logins (registered users on the linux) do not work.
I have included the messages file from the linux below (add 2 comments after the "#"):

---------START MESSAGES-------------
Jun  9 22:48:46 HOME1 syslogd 1.3-0: restart.
Jun  9 22:48:49 HOME1 kernel: klogd 1.3-0, log source = /proc/kmsg started.
Jun  9 22:48:50 HOME1 kernel: Loaded 3601 symbols from /System.map.
Jun  9 22:48:50 HOME1 kernel: Symbols match kernel version.
Jun  9 22:48:51 HOME1 /usr/sbin/cron[118]: (CRON) STARTUP (fork ok) 
Jun  9 22:48:54 HOME1 sendmail[130]: starting daemon (8.8.5): SMTP+queueing@00:30:00
Jun  9 22:49:00 HOME1 login[137]: ROOT LOGIN on `tty1' 
Jun  9 22:49:51 HOME1 atalkd[169]: restart (1.4b2)        #manually started server
Jun  9 22:49:52 HOME1 atalkd[169]: zip_getnetinfo for eth0
Jun  9 22:50:11 HOME1 last message repeated 2 times
Jun  9 22:50:21 HOME1 atalkd[169]: config for no router
Jun  9 22:50:22 HOME1 atalkd[169]: ready 0/0/0
Jun  9 22:50:35 HOME1 papd[179]: restart (1.4b2)
Jun  9 22:50:41 HOME1 afpd[181]: HOME1:AFPServer@* started on 66.230:128 (1.4b2)
Jun  9 22:53:25 HOME1 afpd[195]: session from 65503.1:236 on 66.230:129
Jun  9 22:53:25 HOME1 afpd[195]: done
Jun  9 22:53:25 HOME1 afpd[181]: asp_chld 195 done
Jun  9 22:53:29 HOME1 afpd[196]: session from 65503.1:236 on 66.230:129
Jun  9 22:53:29 HOME1 afpd[196]: login noauth
Jun  9 22:53:29 HOME1 afpd[196]: afp_getsrvrparms: stat /~: No such file or directory  #problem 
here? 
Jun  9 22:53:54 HOME1 afpd[196]: done Jun  9 22:53:54 HOME1 afpd[181]: asp_chld 196 done
---------STOP MESSAGES-------------

Does anyone have an idea? The linux box is also running SAMBA - with no probs at all.
Is my error in the marked line? I have allready tried "Users can't log into afpd, but guest works fine. "
on http://www.umich.edu/~rsug/netatalk/trouble.html - does not seem to work.
Would "shadowed passwords" be another posibility?

With no idea at all - anymore,
seeking help,

Lars

---

From: Sak Wathanasin <[email-masked]>
Date: Fri, 13 Jun 1997 13:33:26 +0100

In reply to Andreas Pieper's message of the 13/06/97 at 12:49 +0200,

> On Fri, 13 Jun 1997, Andres Petralli wrote:
> >
> > ______________________________________________________
> > From: "lars" <[email-masked]>
> > Date: 13.06.97 02:41
> > Subject: no user logins to afpd - guest works fine
> >
> > Hi all!
> > I got exactly the same problem, if somebody has a solution, please post! I
>noticed that on older distributions it worked fine, but on newer it doesn't.
>(slackware 3.2; suse 4.4 ...)
>
> Do you have a shadow password system? If yes, there is a patch for
> netatalk available at
>
> http://artoo.hitchcock.org/~flowerpt/projects/linux-netatalk/
>

As I remember it, the patch is already included in netatalk 1.4b2. All you have
to do is add

DEFS=-DSHADOWPW

to the appr makefile (.../sys/linux/makefile in my case) and rebuild.

Sak Wathanasin
Network Analysis Limited
178 Wainbody Ave South, Coventry CV3 6BX, UK

Internet: [email-masked]
uucp:     ...!britain.eu.net!nan!sw
Phone: (+44) 1203 419996                    Fax: (+44) 1203 690690