Subject: [netatalk-admins] purging .AppleDouble directories

From: John Barry -Technician <[email-masked]>
Date: Thu, 9 Oct 97 18:52:36 BST

Hi,
I've just cleaned out my .AppleDouble directories and it occured to me that
others might like to do the same. So here's how I did it:

%cd
%find . -name .AppleDouble -print >purge-list
%purge_appledouble.pl purge-list

The purge_appledouble.pl script looks like this:

#!/apps/perl5/bin/perl
 
open FILE, $ARGV[0];
while ($line = <FILE>) {
chomp $line;
print "$line\n";
system <<END;
rm -rf $line
END
}

The only thing you might have to change is the first line, which contains the
path to the perl executable. If you wish the program to do anything else for
each directory it deletes, add the command after the 'rm -rf' line.

Doubtless it could be expanded to do multiple users etc. But it took all of 5
mins to write and run, so I'm happy with it.
later
jb

---

From: "Aaron M. Gowatch " <[email-masked]>
Date: Thu, 9 Oct 1997 11:01:51 -0700 (PDT)

> The purge_appledouble.pl script looks like this:

I wouldnt delete my .AppleDouble directories because our users like the
types and creators of the files they create preserved.  :) But if you
really want to, theres an easier way: 

% find . \( -type d -name .AppleDouble \) -print -exec rm -rf {} \;

Aa.

---

From: Mark Donnelly <[email-masked]>
Date: Thu, 09 Oct 1997 13:24:57 +0000

>% find . \( -type d -name .AppleDouble \) -print -exec rm -rf {} \;

Here's another good reason not to delete your .AppleDouble directories:  If you
want to store anything with resources (PICTs, programs, etc.), then killing the
.AppleDouble will more or less erase the file...

--Mark
   "I think so Brain, but if they called them sad meals, then 
    no one would buy them."