Subject: [netatalk-admins] Problem w. Netatalk in a Ethershare Environment

From: Fuldaer Verlagsanstalt <[email-masked]>
Date: Wed, 03 Sep 1997 11:11:28 -0700

Hello, i have a Problem with Netatalk V1.4b2

My Linux is Kernel Version 2.0.30 (SuSE 5.0) on a i486.
I am runnig three NE2000 and want to integrate the Linux into
the whole Net. The Net that are two Sun running Solaris 2.4
with the Software Ethershare, which enables them to Talk Appletalk.
Ethershare is from Helios and we use V2.2.0 Updt<=u0066.
If I pull out the plug to the rest of the net (eth0, 10mbps) everything
works really fine. In my Room the Routing and even printing from a Mac
goes very well. I was surprised and i like NetAtalk very much.
But everytime i am connected to the "rest" 
(At Startup of Netatalk, or if i plug eth0 in)
netatalk stopped and the Message "rtmp_packet gateway 400:140 up"
showed up. The rest of the net (the sun´s)  still goes well, 
only the zones and the functionality of netatalk stops.

Start of Netatalk with rc.atalk:
Aug 29 16:43:53 gr-router atalkd[206]: restart (1.4b2)
Aug 29 16:43:54 gr-router atalkd[206]: zip_getnetinfo for eth1
Aug 29 16:44:13 gr-router last message repeated 2 times
Aug 29 16:44:23 gr-router atalkd[206]: as_timer configured eth1 phase 2
from seed
Aug 29 16:44:24 gr-router atalkd[206]: zip_getnetinfo for eth2
Aug 29 16:44:33 gr-router last message repeated 2 times
Aug 29 16:44:43 gr-router atalkd[206]: as_timer configured eth2 phase 2
from seed
Aug 29 16:44:44 gr-router atalkd[206]: zip_getnetinfo for eth0
Aug 29 16:44:44 gr-router atalkd[206]: zip_getnetinfo for eth0
Aug 29 16:44:44 gr-router atalkd[206]: rtmp_packet interface mismatch
Aug 29 16:44:44 gr-router atalkd[206]: zip gnireply from 400.140 (eth0
1a)
Aug 29 16:44:44 gr-router atalkd[206]: zip_packet configured eth0 from
400.140
Aug 29 16:44:44 gr-router atalkd[206]: zip gnireply from 400.140 (eth0
ba)
Aug 29 16:44:44 gr-router atalkd[206]: zip ignoring gnireply
Aug 29 16:44:53 gr-router atalkd[206]: rtmp_packet gateway 400.140 up
                                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
The actual atalkd.conf:
eth1 -seed -phase 2 -net 398-399 -addr 398.41 -zone "Buero"
eth2 -seed -phase 2 -net 396-397 -addr 396.220 -zone "Buero"
eth0 -seed -phase 2 -net 400-410 -addr 400.5 -zone "Satz"
There are no conflicts with the zones on the sun´s.
The Zone "Satz" (which have to be shared by both)
is exactly the same way configured at linux and the sun.

I tried eth0 to start in first place and last place.
I tried eth0 to start without any -seed or -net, but
no changes. Atalkd.conf is read-write-enabled.
I even tried it without atalkd.conf.

Does anybody knows a "Workaround" or bug fix?

In my personal opinion Netatalk is still very good.
With best wishes, and Many Thanks
   OLAF 

-----------SCHNITT-------------
FVA-Fuldaer Verlagsanstalt GmbH
      Rangstrasse 3-7
       D-36037 Fulda
          GERMANY
    E-Mail [email-masked]
-------------EOT---------------

---

From: Stefan Bethke <[email-masked]>
Date: Wed, 3 Sep 1997 13:52:57 +0200

>Aug 29 16:44:53 gr-router atalkd[206]: rtmp_packet gateway 400.140 up

Most probably, EtherShare's configuration is different. The configuration
(in conf/atalk.conf) should look like
atalkd: if="le0:400-410:140:Satz", if=... [further interfaces]

If there is only one interface listed, this would be the culprit as the
only valid configuration then would be
atalkd: if="le0"

Double-check that the net range and the zone list are *exactly* identical
for the common network. I've had no problems running EtherShare and
netatalk, both as a router and a non-router, albeit on FreeBSD, not Linux.

You might consider talking to your Helios dealer, or ask your system
administrator about the AppleTalk configuration at your site.

Stefan

--
Stefan Bethke
Promo Datentechnik      |  Tel. +49-40-851744-0
+ Systemberatung GmbH   |  Fax. +49-40-851744-44
Eduardstrasse 46-48     |  e-mail: [email-masked]
D-20257 Hamburg         |  http://www.Promo.DE/

---

From: [email-masked]
Date: Wed, 03 Sep 1997 10:32:13 -0400

> From:    Fuldaer Verlagsanstalt <[email-masked]>
> To:      [email-masked]

> Aug 29 16:44:44 gr-router atalkd[206]: rtmp_packet interface mismatch

This seems like a problem.

I suggest you run a test.  Set your atalkd.conf to look like this:

#eth1 -seed -phase 2 -net 398-399 -addr 398.41 -zone "Buero"
#eth2 -seed -phase 2 -net 396-397 -addr 396.220 -zone "Buero"
eth0

atalkd will rewrite it, preserving your comments, with a configuration
of eth0 that will make the rest of your network happy.  While it's
running in this mode, send atalkd a USR1 signal.  This will cause
atalkd to create the file /tmp/atalkd.debug, with a complete routing
table.  Review this table, it will tell you all of the network numbers
that are in use.

:wes