Subject: [netatalk-admins] how to ..?

From: [email-masked] (John Ostrowick)
Date: Thu, 21 Aug 1997 23:58:26 +0200

hi everyone

i'm running netatalk 1.4b2 under redhat, and wonder if anyone else here has
observed that it drops connections very impolitely after a certain timeout.

if so, does anyone know how to prevent this behaviour (eg hack the code?)

TIA!! :-)

sample syslog follows:

Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 31673 timed out
Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 32010 timed out
Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 31880 timed out
Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 31685 timed out
Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 31980 timed out
Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 31686 timed out
Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 31254 timed out
Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 31678 timed out
Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 31679 timed out
Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 31687 timed out
Aug 19 11:21:23 colossus afpd[189]: asp_alrm: 31983 timed out
Aug 19 11:21:33 colossus afpd[32010]: afp_die: asp_shutdown: Connection
timed out
Aug 19 11:21:33 colossus afpd[31880]: afp_die: asp_shutdown: Connection
timed out
Aug 19 11:21:33 colossus afpd[31687]: afp_die: asp_shutdown: Connection
timed out
Aug 19 11:21:33 colossus afpd[31254]: afp_die: asp_shutdown: Connection
timed out
Aug 19 11:21:33 colossus afpd[31980]: afp_die: asp_shutdown: Connection
timed out
Aug 19 11:21:33 colossus afpd[31983]: afp_die: asp_shutdown: Connection
timed out
Aug 19 11:21:33 colossus afpd[31673]: afp_die: asp_shutdown: Connection
timed out
Aug 19 11:21:33 colossus afpd[31685]: afp_die: asp_shutdown: Connection
timed out
Aug 19 11:21:33 colossus afpd[31686]: afp_die: asp_shutdown: Connection
timed out
Aug 19 11:21:33 colossus afpd[31679]: afp_die: asp_shutdown: Connection
timed out
Aug 19 11:21:33 colossus afpd[31678]: afp_die: asp_shutdown: Connection timed ou

________________________________________________________________
John Ostrowick
Computer Science Department,   University of the Witwatersrand
1 Jan Smuts Ave, Johannesburg, South Africa. Senate House 1012
Phone: +27 11 716-3783         Fax: +27 11 339-3513
[email-masked]              [email-masked]
My web page: http://macaroni.cs.wits.ac.za/more/jon/aboutme.html
My ftp site: ftp://macaroni.cs.wits.ac.za
My listserv: http://macaroni.cs.wits.ac.za/listservs.html

---

From: [email-masked] (Thomas Nintemann)
Date: Mon, 25 Aug 1997 19:18:26 +0200

Hi,
I'm running netatalk-1.4b2 under Linux on an Pentium 133 with
128 MB Ram and 2 9GB SCSI Harddisk's.
I use it as an Fileserver for my 9500-Mac.
The Mac is running OSystem 7.5.
On the Mac I use 4 DTP-Programm's
1. -  Pagemaker 6.0 > work's fine.
2. -  Quark Express > works's fine.
3. -  Photoshop 3.0 > work's fine.
4. -  Freehand 7.0  > load an old file and save it is O.K.
		      load the saveing file again: The Mac 
		      throw a Bomb and restart!

Does anyone now about this bug?
Is this a Macromedia Freehand bug? On the local Mac-HD it work's!

Thank's for you interesting.
_
+++++++++++++++++++++++++++++++++++++++++++++++++
+	Thomas Nintemann			+
+	Kleine Straße 5				+
+	26892 Dörpen/Germany			+
+	E-Mail: [email-masked]		+
+++++++++++++++++++++++++++++++++++++++++++++++++

---

From: "Christopher C. Chimelis" <[email-masked]>
Date: Mon, 25 Aug 1997 15:47:39 -0400 (EDT)

> 		      throw a Bomb and restart!

I tried this and it works fine for me (PM9600 System 7.5.5 with older
AppleShare client software).  I haven't tried it with my PM9500 running
the 3.7 AppleShare client, but will try it shortly.  By any chance do you
have the ASCII translation enabled on your installation of netatalk?  If
so, that may be the source of your problem....

Chris
------------------------------------------------------------------
 Christopher C. Chimelis          [email-masked]
 Systems Supervisor
 Division of Biomedical Communications
 University of Miami School of Medicine
 --> finger [email-masked] for PGP public key <--

---

From: [email-masked] (Thomas Nintemann)
Date: Tue, 26 Aug 1997 01:51:54 +0200

Christopher C. Chimelis wrote:
> By any chance do you
> have the ASCII translation enabled on your installation of netatalk?  > If so, that may be the source of your problem....

I don't now that I have the ASCII translation enabled on my 
installation of netatalk.
Where can I check this?

Thank's
-- 
+++++++++++++++++++++++++++++++++++++++++++++++++
+	Thomas Nintemann			+
+	Kleine Straße 5				+
+	26892 Dörpen/Germany			+
+	E-Mail:[email-masked]		+
+++++++++++++++++++++++++++++++++++++++++++++++++

---

From: "Christopher C. Chimelis" <[email-masked]>
Date: Mon, 25 Aug 1997 19:52:12 -0400 (EDT)

> installation of netatalk.

It's a compile-time option I believe.  I initially had the translation on
which screwed up alot of things.  Oh, one quick way to check is to copy a
small binary to your shared volume and try to run it.  If it doesn't run
and gives you some strange error, then it's probably enabled.

Chris

---

From: [email-masked] (Thomas Nintemann)
Date: Tue, 26 Aug 1997 13:18:27 +0200

Christopher C. Chimelis wrote:
> Oh, one quick way to check is to copy a

Hi Chris

I have run a small binary from my shared volume: It seems to be work
fine.
So I think that I haven't enabled the ASCII translation.
Can it be that I have to edit the AppleVolumes.system for my use of
Programms Fileendings?

The default translation in my AppleVolumes.system look's like this:
#
.	BINA	UNIX
#.	TEXT	UNIX

Thomas

---

From: Patrik Schindler <[email-masked]>
Date: Tue, 26 Aug 1997 13:33:14 +0200 (MET DST)

> and gives you some strange error, then it's probably enabled.

This is WRONG. When the afpd recognizes the file as binary (with it's 
filetype), then it will be treated as binary.
The true way to test:

Copy a GIF or a JPEG onto the suspect netatalk machine. Delete the entry 
in .AppleDouble and remove .gif or .jpg extensions from the filename (in 
case you have corresponding entries in your AppleVolumes*). Then copy 
back the file to your harddisk or try to open it (with Graphicconverter 
e.g.).  If it looks scrambled, you'll have to remove -DCRLF from the 
defines in etc/apfd/Makefile. make it new and install (you'll have to 
shut down afpd before).

Afpd can no more recognize this File as binary, 'cause it has no way to 
determine (no .AppleDouble entry, no entry in AppleVolumes*) . So it 
defaults to text, one thing I'd be happy to see it changed to binary in 
futher releases. ;-)

:wq! PoC

---

From: "Christopher C. Chimelis" <[email-masked]>
Date: Tue, 26 Aug 1997 07:49:20 -0400 (EDT)

> So I think that I haven't enabled the ASCII translation.

Yeah, it sounds like the translation is disabled.  You'd be surprised how
many people have problems related to that, btw...

> The default translation in my AppleVolumes.system look's like this:

You could probably go without any extension mapping since it doesn't look
like you're really using it.  I have a rather extensive set of extension
maps on my system, but only because we share the same volumes between PC's
and Macs.  If you only need Macs to get to that shared volume, then you
would only really need the mapping if you really wanted a specific
translation.

In short, I would try it without any extension mapping....
Let me know how it goes :)

Chris

---

From: "Christopher C. Chimelis" <[email-masked]>
Date: Tue, 26 Aug 1997 08:51:35 -0400 (EDT)

> filetype), then it will be treated as binary.

Hmmm....this is interesting since I had problems running binaries off of
my shared volumes when I had the translation enabled.  Then again, I'm no
netatalk or Mac expert....just trying to help :P

Chris

---

From: [email-masked] (Thomas Nintemann)
Date: Tue, 26 Aug 1997 18:47:48 +0200

> Let me know how it goes :)

Hi,
I have made the changes in etc/afpd/Makefile (comment out -DCRLF)
and now erverything works great! (thanks Patrik Schindler) :-)

I think that I need the extensions mapping because I share the volumes
whit Samba and an PC whit Win95.
Please let me  now how it works whitout a extensions map.

Now there are two little problems more...
My Mac tells me that the free diskspace on the volume is only 1,5GB??
This can not be, because I have mounted an 9GB SCSI HD as Macvolume.
I have heard that this is an Network-bug of the OS7.5.Is this so?
What can I do to make the Mac show's the right information about free
diskspace?
Have anyone an idea how I can make a mirroring of my Mac shared volume?

Thanks to all who interresting my problems whit netatalk.

Thomas