Subject: Re: [netatalk-admins] afp_alarm ?

From: John Barry -Technician <[email-masked]>
Date: Wed, 8 Oct 97 17:58:14 BST

> > >    For the past couple of days I've been getting these occasionally:
> > >    >afpd[739]: afp_alarm: child timed out
> > > 
> > >    At which point all my connections die.
> > > 
> > > This wouldn't be related to people entering in the wrong password,
> > > would it?  
> > 
> > Well, it might be. But at the moment there's only me using the system, it's
> > supposed to go live next week...  It doesn't complain about wrong passwords
> > when I log in and the filesystems mount properly, etc. 
> 
> What distribution are you using?

1.4b2+asun2.0a15

> 
> I've had some trouble with the netatalk that I'm running, with asp_alarms.
> Too many times with the wrong password and afpd hangs and
> refuses all future connections.  atalkd, afpd, and the appletalk.o module
> all have to be shutdown and then restarted.

Nope, mine doesn't do that, even when all my connections die I can simply
reconnect via the chooser, it's never locked up on me, just every once in 
a while, I get an afp_alarm and I lose my connection to the server. It's
happened once today so far, otherwise it's been as solid as a rock.
later
jb

---

From: a sun <[email-masked]>
Date: Wed, 8 Oct 1997 12:27:42 -0700 (PDT)

> all have to be shutdown and then restarted.

this is fixed in my pre-a17 snapshot.

this should have been fixed in a16.

-a