Subject: Netatalk routing

From: Fernan Rodriguez Cespedes <[email-masked]>
Date: Sat, 28 Jun 1997 00:26:49 -0300

First, I would like to tell you that you are doing a great job. Thanks
for giving me such a powerful tool for linux.

After this introduction to the list, I am writing as a last
resource. I did download the huge archive and searched for a solution
to my problem but I found none. I have been at it for almost 12 hours
now... literature on the appletalkk protocol is really scarce.

The worst part of it is I *know* my question is really stupid because
the problem is that I have no clue about the appletalk protocol, let 
alone routing.

First, I have 2 servers with 2 ethernets each. Thay are linux
2.0.30. I have a backbone in one ethernet of the servers and on the
other segment there are the client machines (now I have all the macs
in one such segment). Now they ask me to move some macs to the other
server. (as a matter of fact I have six servers...)

My version of netatalk is 1.4b2.

Here is a diagram:

                 backbone
      ---------------------------------
     |                                 |
 _________                          _________
|         |                        |         |
| Server1 |                        | Server2 |
|         |                        |         |
 ---------                          ---------
     |                                 |
     | segment 1                       | segment 2
     |                                 |
 _________                          _________
|         |                        |         |
|  mac 1  |                        |  mac 2  |
|         |                        |         |
 ---------                          ---------

Now, lets say the backbone is in eth0 for both servers...

Note there are no routers or any other equipment.

So on server1:

eth0 -seed -phase 2 -net 100-110 -addr 100.227
eth1 -seed -phase 2 -net 100-110 -addr 101.156

And on server2:

eth0 -seed -phase 2 -net 100-110 -addr 100.122
eth1 -seed -phase 2 -net 100-110 -addr 102.156 

But it just won't work. I cannot aecho anything out of the servers (ie
cannot pinng 100.227 from server2, much less 101.156).

The routing tables look like this:

Server1

server1:/proc/net# cat atalk_route
Target        Router  Flags Dev
0066:9C     0000:00  5     lo
0064:7A     0000:00  5     lo
006E:00     0066:9C  1     eth1
006D:00     0066:9C  1     eth1
006C:00     0066:9C  1     eth1
006B:00     0066:9C  1     eth1
006A:00     0066:9C  1     eth1
0069:00     0066:9C  1     eth1
0068:00     0066:9C  1     eth1
0067:00     0066:9C  1     eth1
0066:00     0066:9C  1     eth1
0065:00     0066:9C  1     eth1
0064:00     0066:9C  1     eth1
0000:00     0000:00  5     lo

Server 2:
server2:/proc/net# cat atalk_route
Target        Router  Flags Dev
0065:9C     0000:00  5     lo
0064:E3     0000:00  5     lo
006E:00     0065:9C  1     eth1
006D:00     0065:9C  1     eth1
006C:00     0065:9C  1     eth1
006B:00     0065:9C  1     eth1
006A:00     0065:9C  1     eth1
0069:00     0065:9C  1     eth1
0068:00     0065:9C  1     eth1
0067:00     0065:9C  1     eth1
0066:00     0065:9C  1     eth1
0065:00     0065:9C  1     eth1
0064:00     0065:9C  1     eth1
0000:00     0000:00  5     lo

Now for the logging:

Server1:

Jun 27 23:45:11 server4 atalkd[10368]: restart (1.4b2)
Jun 27 23:45:13 server4 atalkd[10368]: zip_getnetinfo for eth0
Jun 27 23:45:32 server4 last message repeated 2 times
Jun 27 23:45:42 server4 atalkd[10368]: as_timer configured eth0 phase2 from seed
Jun 27 23:45:43 server4 atalkd[10368]: zip_getnetinfo for eth1
Jun 27 23:45:52 server4 last message repeated 2 times
Jun 27 23:46:02 server4 atalkd[10368]: as_timer configured eth1 phase 2 from seed
Jun 27 23:46:02 server4 atalkd[10368]: ready 0/0/0
Jun 27 23:46:12 server4 atalkd[10368]: rtmp_packet gateway 100.227 up
Jun 27 23:46:14 server4 papd[10381]: restart (1.4b2)

Anyone can help, please? II have tried everything on the -net... no luck. I 
suppose the routing should be done on the other interfarce (eth0) but
I don't really know.

-- 

Saludos - Pastito

Save As                         Linux
http://www.saveas.com.ar        http://www.linux.com.ar
ftp://ftp.saveas.com.ar         ftp://ftp.linux.com.ar
[email-masked]           [email-masked]

---

From: Bill Studenmund <[email-masked]>
Date: Sat, 28 Jun 1997 11:59:08 -0700 (PDT)

> for giving me such a powerful tool for linux.

Just for the record, it's not just for Linux. :-) I'm using it on NetBSD.
It runs on FreeBSD, suns, ultrix, and lots more.

> But it just won't work. 

No, it won't. :-)

The net number(s) must be unique for a wire. Also, you don't really need a
range unless you have a LOT of computers. We have 200 macs living off of
one net number.

Try something like (assuming eth0 is the backbone):

eth0 -seed -phase 2 -net 100 -addr 100.1 -zone "Backbone"
eth1 -seed -phase 2 -net 101 -addr 101.1 -zone "Zone 1"

and
eth0 -seed -phase 2 -net 100 -addr 100.2 -zone "Backbone" (must match
	other backbone line, and doesn't need to be -seed if server 1 fires up
	first always)
eth1 -seed -phase 2 -net 102 -addr 102.1 -zone "Zone 2"

Take care,

Bill