Subject: [netatalk-admins] papd NBP Type Selection

From: Patrik Schindler <[email-masked]>
Date: Sat, 11 Oct 1997 00:43:19 +0200

Hi,

are there any plans to make the nbptype of a papd-printerspooler user selectable in papd.conf?

:wq! PoC

---

From: [email-masked]
Date: Sat, 11 Oct 1997 00:59:17 -0400

> From:    Patrik Schindler <[email-masked]>
> To:      [email-masked]

> are there any plans to make the nbptype of a papd-printerspooler user

In 1.4b2, it already is.

:wes

---

From: Patrik Schindler <[email-masked]>
Date: Sat, 11 Oct 1997 12:21:16 +0200

Hi wes!

>> are there any plans to make the nbptype of a papd-printerspooler user

Oh? Where can I read more about it?

[excerpt from manpage]
       Name   Type   Default        Descripton
        pd    str    ``.ppd''       Pathname to PPD file
        pr    str    ``lp''         LPD printer name
        op    str    ``operator''   Operator name for LPD spooling

There's no Tag for the nbptype described.

:wq! PoC

---

From: [email-masked]
Date: Sat, 11 Oct 1997 10:03:22 -0400

> There's no Tag for the nbptype described.

The salient paragraph:

    papd is typically started at boot time, out of  /etc/rc.  It
    first     reads     from     its     configuration     file,
    /usr/local/atalk/etc/papd.conf.  The file  is  in  the  same
    format  as /etc/printcap.  See printcap(5) for details.  The
    name of  the  entry  is  registered  with  NBP.

If you name the entry something like:

	Printer Spooler\072NotALaserWriter:\
		:etc:

you'll register the name "Printer Spooler" with the type
"NotALaserWriter".  The \072 is the octal value for ascii ':'.  Since
':' is interpreted by the termcap libraries, it must be escaped in this
way.  I guess you could say that's a little obfuscated...

:wes

---

From: Patrik Schindler <[email-masked]>
Date: Sat, 11 Oct 1997 16:10:14 +0200

>way.  I guess you could say that's a little obfuscated...

Oh yes, it is :-) But thank you anyway!

:wq! PoC

---

From: Patrik Schindler <[email-masked]>
Date: Sat, 11 Oct 1997 17:21:37 +0200

>way.

I just tested it and it's OK if you escape it this way:

DW-Spool\:DeskWriter:pr=dw:pd=/dev/null:op=poc:

If anyone will test this with a DeskWriter or DeskJet, he may fail. The Driver (6.03) says "Waiting for printer" then locks the whole machine, including cursor. Really good work from HP...

:wq! PoC

---

From: Andrew Solmssen <[email-masked]>
Date: Sun, 12 Oct 1997 12:14:10 -0700 (PDT)

I've just experienced the same problem using the 9.3 HP driver, and I
think the issue is that the driver is attempting to interrogate the
printer, and papd is without a ppd to use to form a reply that the driver
is looking for.  I don't know what to do here except use the postscript
emulation provided by ghostscript. 

Any thoughts?

---- Andrew

On Sat, 11 Oct 1997, Patrik Schindler wrote:

> If anyone will test this with a DeskWriter or DeskJet, he may fail. The
> Driver (6.03) says "Waiting for printer" then locks the whole machine,
> including cursor. Really good work from HP... 
> 
> :wq! PoC
> 
> 
>