Subject: [netatalk-admins] byte-range locks and afpd

From: a sun <[email-masked]>
Date: Sat, 29 Nov 1997 15:37:46 -0800 (PST)

i've just added byte-range locks to my patchset. however, before i
release it to the masses, i would like people to test it to make sure
it works properly. basically, it does the following:
	
	1) set fcntl()-style locks. as a consequence, these will only
	   work on nfs mounts if you run lockd. 

	2) before each read/write/truncate, attempt to set a
	   temporary lock. if the region is locked against the user,
	   this should fail. release the lock after the operation has
	   been completed.

as an added side effect, afp_read/afp_write/afp_setforkparams should
now be completely protected from stepping upon each other. 

so, if you have programs which could benefit from byte locks and you
want to test it out, send me email.

oh yeah, if you have a better idea for an interface, let me
know. it's currently in the form of ad_lock and ad_tmplock with a
whole string of arguments. i think it looks pretty ugly, but i wanted
to retain locking as an appledouble level call.

-adrian
[email-masked]

---

From: "Randall S. Winchester" <[email-masked]>
Date: Sun, 30 Nov 1997 23:48:11 -0500 (EST)

I hope these changes are inside "#ifndef AFS", as byte-range lock do *not*
work in AFS.

Randall

On Sat, 29 Nov 1997, a sun wrote:

: 
: i've just added byte-range locks to my patchset. however, before i
: release it to the masses, i would like people to test it to make sure
: it works properly. basically, it does the following:
: 	
: 	1) set fcntl()-style locks. as a consequence, these will only
: 	   work on nfs mounts if you run lockd. 
: 
: 	2) before each read/write/truncate, attempt to set a
: 	   temporary lock. if the region is locked against the user,
: 	   this should fail. release the lock after the operation has
: 	   been completed.
: 
: as an added side effect, afp_read/afp_write/afp_setforkparams should
: now be completely protected from stepping upon each other. 
: 
: so, if you have programs which could benefit from byte locks and you
: want to test it out, send me email.
: 
: oh yeah, if you have a better idea for an interface, let me
: know. it's currently in the form of ad_lock and ad_tmplock with a
: whole string of arguments. i think it looks pretty ugly, but i wanted
: to retain locking as an appledouble level call.
: 
: -adrian
: [email-masked]	
: