Subject: [netatalk-admins] netatalk & Linux Kernel 2.0.30

From: [email-masked] (Thomas Pierre Schweikle)
Date: Tue, 29 Jul 1997 08:00:56 +0200

Hi!

> I´ve gota problem launching netatalk on my linux box. It gives me the message:

>> pan:/usr/lib/atalk/etc # ./rc.atalk
>> starting appletalk daemons:socket: Invalid argument
>> atalkd nbprgstr papd afpd.

> The kernel was compiled with DDP-support as module.

> Now I heared that with kernel 2.0.30 the DDP-support is broken. Shall I be
> better of using kernel 2.0.29? Or is there a patch available from someone?

This was my question. Here some aditional info:

Modules are loaded dynamicaly using the kernel daemon. This works with all
other network modules.

Here is the services file (sniped) I use:

#
# Appletalk
#
rtmp            1/ddp           # Routing Table Maintenance Protocol
nbp             2/ddp           # Name Binding Protocol
echo            4/ddp           # AppleTalk Echo Protocol
zip             6/ddp           # Zone Information Protocol

and here the protocols file (sniped):

ip      0       IP      # internet protocol, pseudo protocol number
icmp    1       ICMP    # internet control message protocol
igmp    2       IGMP    # internet group multicast protocol
ggp     3       GGP     # gateway-gateway protocol
tcp     6       TCP     # transmission control protocol
pup     12      PUP     # PARC universal packet protocol
udp     17      UDP     # user datagram protocol
idp     22      IDP     # WhatsThis?
raw     255     RAW     # RAW IP interface

I hope this aditional Information is helpfull! Seems I missed something
somwhere.

-- Thomas Schweikle

-- Thomas Schweikle

---

From: Michael Stone <[email-masked]>
Date: Tue, 29 Jul 1997 14:09:59 -0400

> Modules are loaded dynamicaly using the kernel daemon. This works with all

<snip>

> I hope this aditional Information is helpfull! Seems I missed something

Hmm. When you were sniping the protocols file, did you maybe
snipe out the line that says:
ddp     37      DDP             # Datagram Delivery Protocol

I don't know if that will make a difference.

-- 
Michael Stone, Sysadmin, ITRI     PGP: key 1024/76556F95 from mit keyserver,
[email-masked]            finger, or email with "Subject: get pgp key"