Subject: update on afp/tcp patches to netatalk-1.4b2

From: a sun <[email-masked]>
Date: Fri, 27 Jun 1997 14:19:19 -0700 (PDT)

to prevent any confusion about my patches, i've renamed them to
1.4b2+asun2.0ax. here are the appropriate urls:

<ftp://ftp.u.washington.edu/public/asun/1.4b2-asun2.0a9.diff.gz>
<ftp://ftp.u.washington.edu/public/asun/netatalk-1.4b2+asun2.0a9.tar.gz>

these also fix a couple of minor things w/ bsd4.4 machines.

-a

---

From: [email-masked] (Paul M. Lambert)
Date: Sun, 29 Jun 1997 17:25:29 -0700 (PDT)

> these also fix a couple of minor things w/ bsd4.4 machines.

Has anyone successfully compiled this under Linux 2.0.30?

I'm failing utterly.  And I don't understand these things well enough to
fix this.  *sigh*

It fails every time, with what looks like simple header problems.  It doesn't
like some of the definitions, I guess.

Here's what happens:

---------------------------------------------------------------------------
pinky.plambert ~/netatalk-1.4b2+asun2.0a9 > make
Making all for linux...
make[1]: Entering directory `/aux2/home/plambert/netatalk-1.4b2+asun2.0a9/sys/linux'
cd ../../libatalk; make -w CC="gcc -I/usr/include " \
    ADDLIBS="" DEFS="-DTCPWRAP -DNEED_QUOTACTL_WRAPPER" OPTOPTS="-O5 -fomit-frame-pointer -fsigned-char -Wunused" \
    SBINDIR="/home/plambert/atalk/etc" BINDIR="/home/plambert/atalk/bin" RESDIR="/home/plambert/atalk/etc" \
    ETCDIR="/home/plambert/atalk/etc" LIBDIR="/home/plambert/atalk/lib" INCDIR="/home/plambert/atalk/include" \
    DESTDIR="/home/plambert/atalk" AFSDIR="" KRBDIR="" \
    AFPLIBS="-lcrypt -lwrap" all
make[2]: Entering directory `/aux2/home/plambert/netatalk-1.4b2+asun2.0a9/libatalk'
cd asp; make -w CC="gcc -I/usr/include " DEFS="-DTCPWRAP -DNEED_QUOTACTL_WRAPPER" \
    OPTOPTS="-O5 -fomit-frame-pointer -fsigned-char -Wunused"
make[3]: Entering directory `/aux2/home/plambert/netatalk-1.4b2+asun2.0a9/libatalk/asp'
gcc -I/usr/include  -p -DTCPWRAP -DNEED_QUOTACTL_WRAPPER -O5 -fomit-frame-pointer -fsigned-char -Wunused -I../../include -c asp_attn.c
In file included from asp_attn.c:12:
/usr/include/atalk/atp.h:74: field `atpxo_tv' has incomplete type
/usr/include/atalk/atp.h:82: field `atpbuf_addr' has incomplete type
/usr/include/atalk/atp.h:91: field `atph_saddr' has incomplete type
/usr/include/atalk/atp.h:103: field `atph_reqtv' has incomplete type
In file included from asp_attn.c:13:
/usr/include/atalk/asp.h:26: field `asp_sat' has incomplete type
asp_attn.c:18: parse error before `AFPUserBytes'
asp_attn.c: In function `asp_attention':
asp_attn.c:20: `ASP_HDRSIZ' undeclared (first use this function)
asp_attn.c:20: (Each undeclared identifier is reported only once
asp_attn.c:20: for each function it appears in.)
asp_attn.c:21: storage size of `sat' isn't known
asp_attn.c:26: `asp' undeclared (first use this function)
asp_attn.c:27: `flags' undeclared (first use this function)
asp_attn.c:21: warning: unused variable `sat'
asp_attn.c:20: warning: unused variable `data'
asp_attn.c:20: warning: unused variable `cmds'
make[3]: *** [asp_attn.o] Error 1
make[3]: Leaving directory `/aux2/home/plambert/netatalk-1.4b2+asun2.0a9/libatalk/asp'
make[2]: *** [asp] Error 2
make[2]: Leaving directory `/aux2/home/plambert/netatalk-1.4b2+asun2.0a9/libatalk'
make[1]: *** [../../libatalk] Error 2
make[1]: Leaving directory `/aux2/home/plambert/netatalk-1.4b2+asun2.0a9/sys/linux'
make: *** [all] Error 2

---

From: "James R. Leu" <[email-masked]>
Date: Sun, 29 Jun 1997 19:51:13 -0500 (CDT)

Yes.

I needed to dl the tcp_wrappers package. (to get tcpd.h and libwrap.a)
Also you need to blow away your old /usr/include/atalk /usr/include/netatalk
directories.

Then it should compile fine.

-- 
James R. Leu
Network Administrator
CORE Digital Communication Services
[email-masked]

---

From: a sun <[email-masked]>
Date: Mon, 30 Jun 1997 06:37:54 -0700 (PDT)

[...]

you're using the wrong headers. get rid of /usr/include/atalk and
/usr/include/netatalk. the newer glibc and libc-5 have they're own
/usr/include/netatalk/at.h. you'll want to use that if
SIOCATALKDIFADDR is in the kernel. anyways, i screwed up 
netatalk/endian.h a little which also causes a few problems as well as
the defines for tcp wrappers. you'll need to change LIBWRAP in
dsi_tcp.c to TCPWRAP if you actually want to use them. i'll have a
patch out in a little bit which fixes those problems as well as fixing
a fairly stupid one i made w/ signal handling.

-a