Subject: $USER variable in AppleVolumes.system?

From: [email-masked]
Date: Wed, 2 Jul 97 20:51:13 CDT

>(A copy of this message has also been posted to the following newsgroups:
>comp.protocols.appletalk)
>
>I'm wondering if this kind of thing is possible with netatalk:
>
>Say I've got lots of users, so many that I don't want to be creating a
>..AppleVolumes file in each of their home directories.  For the sake of
>argument, let's pretend that five is such a large number.
>
>Now, I want every user, when s/he connects, to see two things in the
>chooser -- the user's home directory, an the user's personal web
>directory.  (Again, for the sake of argument, linking the web directory
>into the home directory isn't possible, due to a hypothetical complicated
>nfsmount issue.)
>
>Say I have the real directories:
>
>/www/users/andrea
>/www/users/bob
>/www/users/chris
>/www/users/deanna
>/www/users/effie
>
>Can I do something like this in AppleVolumes.system or 
AppleVolumes.default?:
>
>/www/users/$USER     "User WWW Directory"
>
>
>I know I can't do that exactly, because I tried it and it didn't work.  Is
>there another way?
>
>-Bill
>
>-- 
> _________________________________________________________________________
> William R. Dickson - Technical Support               [email-masked]
> Northwest Nexus - Professional Internet Services         Bellevue, WA USA
> Voice: 425 455-3505  Web: http://www.nwnexus.com/  Info: [email-masked]

Bill --

I know you can't use "$USER", but I think you can use "~/".  Of course,
that only gets you the user's home directory, but at least that's half
of what you wanted.

	   -- Mark

Mark Tomory
Carthage College

---

From: Bill Studenmund <[email-masked]>
Date: Wed, 2 Jul 1997 18:37:27 -0700 (PDT)

> >into the home directory isn't possible, due to a hypothetical complicated

Can't you just have a sym link in each user's home directory pointing out
to the web directory? Just do something like:

(in sh)
for i in `cat a_list_of_users`
do
cd $i
ln -s /www/users/$i WWW
done

> that only gets you the user's home directory, but at least that's half

But then ~/WWW would point to a symlink which would point to the right
place.

Take care,

Bill

---

From: "William R. Dickson" <[email-masked]>
Date: Wed, 2 Jul 1997 20:14:49 -0700

>for i in `cat a_list_of_users`

That's certainly an option, and it's currently the fallback plan, but being
able to use a $USER variable just seemed like a cleaner options.  But if it
can't be done, it's not a huge deal.

-Bill

--
 William R. Dickson -- Consuming the Earth's limited resources since 1968
 [email-masked]  <>  http://www.halcyon.com/wrd/  <>  VNB3T, VSC1T, VSX1T

  Neither of the people in the room paid any attention to
  the way I came in, although only one of them was dead.

                     Raymond Chandler, "The Big Sleep"