Subject: Re: [netatalk-admins] HELP: nbprgstr problems with Linux

From: [email-masked] (John Sutton)
Date: Thu, 9 Oct 1997 23:19:37 +0100

Sounds like the same problem I had earlier today!  I copied over a netatalk
config from one box to a second, _including_ the /etc/atalk.conf file.
Consequently both machines try to grab the same numeric id (that's probably
the wrong term -  I mean the second of the two numbers in the output of
nbplkup).  Fix is simple - delete the line from the conf file of one
machine and then start up netatalk.  It will poll the network and allocate
itself a new unique id and then write that to the conf file for future use.

If this is the explanation, the corollary is that you must ensure that all
existing appletalk machines are active (in a given zone?) when you first
start up a new one.  Otherwise there can be no guarantee than it won't
allocate itself an id which is the same as that of a machine which doesn't
happen to be switched on.  Huh?  Sounds pretty messy if the zone gets big
enough...

>I have a rather strange situation.  For almost a year I've been running
>netatalk on a Linux box,
>and it works pretty much flawlessly.  To protect the innocent, let's call
>it machine A.
>
>We recently purchased another machine running Linux (machine B).  I
>basically just copied
>over all of the already working stuff to machine B.
>
>Now the symptoms:
>
>        1) machine B doesn't appear in the chooser, nor if you use
>AppleTalk polling
>programs such Trawl and LanSatellite
>
>        2) machine A appears fine in all of the above
>
>        3) AFP over TCP/IP works fine over both machines A and B.
>
>        4) nbplkup returns nothing when run on machine B
>
>        5) nbplkup on machine A doesn't report itself (feature/bug?) but
>does report machine B!
>
>        6) when nbprgstr is run on machine B, it responds with a connection
>timed out message
>
>
>I tried -seed in atalkd.conf to no avail.
>
>Machine B has different Ethernet hardware than machine A.
>Machine B kernel is 2.0.30; machine A is 2.0.27
>
>The netatalk version is netatalk-1.4b2+asun2.0a14
>
>Any help would be GREATLY appreciated.
>
>*************************************************************************
>        Geoff Ghose
>        Div. of Neuroscience            One Baylor Plaza S603
>        Baylor College of Medicine      Houston, TX 77030
>        (713) 798-3277                  Fax:(713) 798-3282
>
>        Internet:  [email-masked]
>                           [email-masked]
>                http://dna.neusc.bcm.tmc.edu/~geoff
>
>        PGP key: http://dna.neusc.bcm.tmc.edu/~geoff/pub-pgp-key
>
>        And what is more, I agree with everything I have just said.
>                        -       Piet Koornhoff

***********************
John Sutton
SCL Computer Services
http://www.scl.co.uk
Tel +44 (0) 1239 621021
***********************

---

From: Alistair Riddell <[email-masked]>
Date: Fri, 10 Oct 1997 11:51:25 +0100 (BST)

> happen to be switched on.  Huh?  Sounds pretty messy if the zone gets big

This is not quite right - a mac will by defualt check its address when
first switched on to make sure it doesn't conflict with a device already
on the network. If it does then it chooses another address.

Problems can aries when the netatalk box is switched off. Another machine
can take its address, and when the netatalk machine is switched back on,
it does not check AFAIK to see if the address is already in use.

--
Alistair Riddell - BOFH
IT Support Department, George Watson's College, Edinburgh
Tel: +44 131 447 7931 Ext 176       Fax: +44 131 452 8594

---

From: Geoff Ghose <[email-masked]>
Date: Fri, 10 Oct 1997 09:55:05 -0500

> >I tried -seed in atalkd.conf to no avail.

I should have made this clearer.  Yes, I explicitly wiped out
atalkd.conf so that
it would get info from the router.  And, I edited atalkd.conf so that it
had a unassigned
number (and forced that number with seed).   And neither way worked!

What I really don't understand is how the working netatalk setup is able
to see
the non-working setup with nbplkup, but none of the Macs can.

        Geoff Ghose

        Internet:  [email-masked]
                           [email-masked]
         http://focus.neusc.bcm.tmc.edu/~geoff

        PGP key: http://focus.neusc.bcm.tmc.edu/~geoff/pub-pgp-key

---

From: [email-masked]
Date: Fri, 10 Oct 1997 11:04:57 -0400

> From:    Alistair Riddell <[email-masked]>

> it does not check AFAIK to see if the address is already in use.

There's code there to do it.  I don't know the current state, but it
worked the last time I checked.

:wes