Subject: [netatalk-admins] Re: NetPresenz mounting CAP vs. netatalk (fwd)

From: Valerie Caro <[email-masked]>
Date: Tue, 14 Oct 1997 11:34:52 -0400 (EDT)

---------- Forwarded message ----------
Date: Tue, 14 Oct 1997 09:27:00 -0500
From: John Greene <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Subject: Re: NetPresenz mounting CAP vs. netatalk

Hi --

Checking the "allow clear text passwords" didn't seem to help help....

>Date: Sun, 12 Oct 1997 20:22:38 -0700
>Reply-To: [email-masked]
>Originator: [email-masked]
>From: Peter N Lewis <[email-masked]>
>To: Multiple recipients of list <[email-masked]>
>Subject: Re: NetPresenz mounting CAP vs. netatalk
>
>At 11:47 -0700 10/10/97, John Greene wrote:
>
>>Today we moved our Public Server from a DEC Alpha running cap
>>to a linux box running netAtalk.... Now we can't successfully
>>mount volumes with smnt.
>
>It's possible that the new cap isn't supporting an acceptable
>authentication method (try turning on NetPresenz' "aloow clear text
>passwords" option.
>
>What error do you get it you manually try to smnt the volume after logging in?
>   Peter.
>
>--
><http://www.stairways.com/>
><ftp://ftp.stairways.com/stairways/>
><mailto:[email-masked]>
>

  We are able to mount the volume as guest when going through the
chooser. But when we try from NetPresenz it gets an error. I
logged the afpd output on the netatalk side:

 When mounting from the chooser we get:
command: 18
12 0E 41 46 50 56 65 72 73 69 6F 6E 20 32 2E 30         ..AFPVersion 2.0
0F 4E 6F 20 55 73 65 72 20 41 75 74 68 65 6E 74         .No User Authent
(end)
reply: 0, 0
(end)
command: 16
10                                                      .
(end)
reply: 0, 1
34 43 78 25 01 00 09 4D 61 63 50 75 62 6C 69 63         4Cx%...MacPublic
(end)
command: 24
18 00 00 20 09 4D 61 63 50 75 62 6C 69 63               ... .MacPublic
(end)
reply: 0, 2
00 20 00 00                                             . ..
(end)

  When mounting from NetPresenz:
command: 18
12 0E 41 46 50 56 65 72 73 69 6F 6E 20 32 2E 30         ..AFPVersion 2.0
0F 4E 6F 20 55 73 65 72 20 41 75 74 68 65 6E 74         .No User Authent
(end)
reply: 0, 0
(end)
command: 24
18 00 00 23 09 4D 61 63 50 75 62 6C 69 63               ...#.MacPublic
(end)
reply: -5019, 1
(end)

  The only difference seems to be in command 24, with NetPresenz it
has a '#' (18 00 00 23) and with the chooser it has a ' ' (18 00 00 20)
Any ideas?

Valerie Caro
[email-masked]

---

From: a sun <[email-masked]>
Date: Wed, 15 Oct 1997 10:26:49 -0700 (PDT)

i'm pretty sure i know what's happening here as i encountered this
with os8 and mounting an alias of a volume. what you're getting is a
request to open a volume without an initial request for server
params. 1.4b2 assumes that that just doesn't happen. my patches to
1.4b2 fix this, and i believe i informed wes of this when i noticed
it.

-a