• | Table of Contents
Essential Guide to Semiconductors, The
By Jim Turley
Publisher | : Prentice Hall PTR
Date Published | : December 19, 2002
ISBN | : 0-13-046404-X
Pages | : 239

The Essential Guide to Semiconductors is a complete professional's guide to the business andtechnology of semiconductor design and manufacturing. Leading semiconductor industry analystand editor Jim Turley illuminates every facet of the industry, explaining its fast-changingtechnologies, markets, and business models simply, clearly, and without unnecessary jargon.

  • Covers a wide range of semiconductor applications: cellphones, cars, computers, gaming systems, and much more

  • Conceptual enough for laypeople and nontechnical investors—and sufficiently detailed for technical readers

  • Includes a wide range of diagrams and flowcharts to promote understanding

  • Presents accessible explanations of how silicon chips are designed and built

  • Shows how the entire industry fits together, helping readers understand key niches, market segments, and opportunities


• | Table of Contents
Essential Guide to Semiconductors, The
By Jim Turley
Publisher | : Prentice Hall PTR
Date Published | : December 19, 2002
ISBN | : 0-13-046404-X
Pages | : 239

Copyright
Prentice Hall PTR Essential Guide Series
About Prentice Hall Professional Technical Reference
Acknowledgments
Chapter 1. Running Start
 | About This Book
 | Some Words To Know
Chapter 2. Semiconductor Family Tree
 | Semiconductor Family Tree
 | Simple Analog Components
 | Advanced Analog Components
 | A/D and D/A Converters
 | MEMS
 | Medium-Scale Digital Chips
 | Highly Integrated Digital Chips
Chapter 3. How Chips Are Designed
 | Old-Style Design Process
 | New-Style Design Process
 | Verifying the Design Works
 | Using Outside IP
 | Getting to Tape Out and Film
 | Current Problems and Future Trends
Chapter 4. How Chips Are Made
 | Clean Rooms and Fabs
 | Developing Technology: Chips and Photography
 | Silicon Ingots to Start
 | Polishing the Wafer Smooth
 | Building the Layer Cake
 | Laser Surgery: Etching Away the Transistors
 | Step and Repeat
 | Etching Bath
 | Ready For the Metal Round
 | Testing Phase I
 | Bringing Out the Diamonds
 | Sorting the Fast from the Merely Good
 | Wrap it Up
 | How Many Nanometers in a Micron?
 | Let' s Get Small
Chapter 5. Business and Markets
 | Worldwide Production of Semiconductors
 | Worldwide Consumption of Semiconductors
 | Military Electronics
 | The Business of Making Semiconductors
Chapter 6. Essential Guide to Microprocessors
 | Overview of Microprocessors
 | Microprocessor History and Evolution
 | What's a Processor Architecture?
 | Microprocessor Anatomy and Gazetteer
 | What do 4-Bit, 8-Bit, 16-Bit, and 32-Bit Mean?
 | Performance, Benchmarks, and Gigahertz
 | What Is Software?
 | Choosing Microprocessors
 | Microprocessor Future Trends
Chapter 7. Essential Guide to Memory
 | Overview of Memory Chips
 | Nonvolatile ROM
 | Volatile RAM
 | Memory Interfaces
 | Future Memories
Chapter 8. Essential Guide to Custom and Configurable Chips
 | Overview of Custom Chips
 | Field-Programmable Chips
 | Custom ASIC Chips
 | Dynamically Reconfigurable Chips
 | Intellectual Property Licensing
 | Future Outlook for Custom Chips
Chapter 9. Theory
 | Digital and Binary Concepts
 | Gates and Logic Functions
 | How Transistors Work
 | About Electrons and Electronics
Appendix Standards Bodies and Reference
 | Standards Bodies and Organizations
 | Conferences and Trade Shows
 | Other Resources
Glossary


Copyright

Library of Congress Cataloging-in-Publication Data

A CIP catalog record for this book can be obtained from the Library of Congress.

Editorial/production supervision: Patti Guerrieri

Cover design director: Jerry Votta

Cover design: Bruce Kenselaar

Art director: Gail Cocker-Bogusz

Interior design: Meg Van Arsdale

Manufacturing buyer: Maura Zaldivar

Publisher: Bernard Goodwin

Editorial assistant: Michelle Vincenti

Marketing manager: Dan DePasquale

© 2003 Pearson Education, Inc.

Publishing as Prentice Hall Professional Technical Reference

Upper Saddle River, New Jersey 07458

Prentice Hall books are widely used by corporations and government agencies for training, marketing, and resale.

For information regarding corporate and government bulk discounts please contact:

Corporate and Government Sales (800) 382-3419 or corpsales@pearsontechgroup.com

All company and product names mentioned herein are the trademarks or registered trademarks of their respective owners.

All rights reserved. No part of this book may be reproduced, in any form or by any means, without permission in writing from the publisher.

Printed in the United States of America

10 9 8 7 6 5 4 3 2 1

Pearson Education LTD.

Pearson Education Australia PTY, Limited

Pearson Education Singapore, Pte. Ltd.

Pearson Education North Asia Ltd.

Pearson Education Canada, Ltd

Pearson Educación de Mexico, S.A. de C.V.

Pearson Education — Japan

Pearson Education Malaysia, Pte. Ltd.

Dedication

To my parents, for a brain;
my wife, for courage;
and my children, for a heart.


Prentice Hall PTR Essential Guide Series

THE ESSENTIAL GUIDE TO DATA WAREHOUSING

Agosta

ESSENTIAL JAVASCRIPT FOR WEB PROFESSIONALS, SECOND EDITION
Barrett

THE ESSENTIAL GUIDE TO WEB STRATEGY FOR ENTREPRENEURS
Bergman

THE ESSENTIAL GUIDE TO THE BUSINESS OF U.S. MOBILE WIRELESS COMMUNICATIONS
Burnham

THE ESSENTIAL GUIDE TO TELECOMMUNICATIONS, THIRD EDITION
Dodd

THE ESSENTIAL GUIDE TO WIRELESS COMMUNICATIONS APPLICATIONS, SECOND EDITION
Dornan

THE ESSENTIAL GUIDE TO OPTICAL NETWORKS
Greenfield

THE ESSENTIAL GUIDE TO INTERNET BUSINESS TECHNOLOGY
Honda & Martin

THE ESSENTIAL GUIDE TO COMPUTER HARDWARE
Keogh

THE ESSENTIAL GUIDE TO NETWORKING
Keogh

THE ESSENTIAL GUIDE TO COMPUTER DATA STORAGE: FROM FLOPPY TO DVD

Khurshudov

THE ESSENTIAL GUIDE TO DIGITAL SET-TOP BOXES AND INTERACTIVE TV
O'Driscoll

THE ESSENTIAL GUIDE TO HOME NETWORKING TECHNOLOGIES
O'Driscoll

THE ESSENTIAL GUIDE TO KNOWLEDGE MANAGEMENT: E-BUSINESS AND CRM APPLICATIONS
Tiwana

THE ESSENTIAL GUIDE TO APPLICATION SERVICE PROVIDERS
Toigo

THE ESSENTIAL GUIDE TO SEMICONDUCTOR TECHNOLOGY
Turley

ESSENTIAL GUIDE TO XML TECHNOLOGIES
Turner

THE ESSENTIAL GUIDE TO STORAGE AREA NETWORKS
Vacca

THE ESSENTIAL GUIDE TO MOBILE BUSINESS
Vos & deKlein

THE ESSENTIAL GUIDE TO COMPUTING: THE STORY OF INFORMATION TECHNOLOGY
Walters

THE ESSENTIAL GUIDE TO RF AND WIRELESS, SECOND EDITION
Weisman


About Prentice Hall Professional Technical Reference

With origins reaching back to the industry's first computer science publishing program in the 1960s, Prentice Hall Professional Technical Reference (PH PTR) has developed into the leading provider of technical books in the world today. Formally launched as its own imprint in 1986, our editors now publish over 200 books annually, authored by leaders in the fields of computing, engineering, and business.

Our roots are firmly planted in the soil that gave rise to the technological revolution. Our bookshelf contains many of the industry's computing and engineering classics: Kernighan and Ritchie's C Programming Language, Nemeth's UNIX System Administration Handbook, Horstmann's Core Java, and Johnson's High-Speed Digital Design.

PH PTR acknowledges its auspicious beginnings while it looks to the future for inspiration. We continue to evolve and break new ground in publishing by providing today's professionals with tomorrow's solutions.


Acknowledgments

Who reads the credits at the end of a movie?

The people who are named, of course. They worked hard and all they get is some small print. Lots of people spent nearly as much time on this book as I did, but probably enjoyed it less. I'm indebted to them because all of their efforts made it better. If any errors or omissions remain, that's all my work.

Many of the images and photographs throughout the book came courtesy of Nick Tredennick (Dynamic Silicon); Lindsay Okamoto and Phil Bourekas at Integrated Device Technology; Susanna Jakubik, Gary Silcott, and Henry Wiechman at Texas Instruments; P. F. Domanis and Akiko Ishiyama at Hitachi; Nancy Snyder, Rosalind Yeh, and Martin Chorich at Sun Microsystems; and Michelle Herrick at ASM Lithography. Thanks for coming to work on such short notice.

The big gray parts between the photos were vastly improved through the talents and efforts of Patti Guerrieri, Teresa Horton, Lance Leventhal, and Bernard Goodwin, all of Prentice Hall. They work with words and ideas, and there are few better callings.

It's important to thank Michael Slater, Linley Gwennap, and Keith Diefendorff (Microprocessor Report) for patient on-the-job training; Tracy Kidder (Soul of a New Machine) for inspiration; Irritus and Lileks (James) for amusement; and the builders of Highway 1 for diversion.

And of course, Kathy, Caroline, and David who were neglected for the duration.

—Jim Turley
Pacific Grove, California


Chapter 1. Running Start

In this chapter...

  • About This Book

  • Some Words to Know

Few things have altered modern life as much as the discovery of semiconductors, and certainly none in living memory. Modern electronics have completely changed the way we talk with each other and who we talk with. It has changed medical research, entertainment, record keeping, travel, and exploration. There's almost no business, profession, or industry that hasn't changed since the introduction of solid-state electronics in the last 50 years.

Computers are only the beginning of it. PCs and other types of computers are often made the figurehead for the entire electronics industry, but less than half of the world's electronics are used in computers of any kind. Most of them go into more mundane, but probably more useful products like thermostats, automobile antilock brake systems, air conditioning, televisions, x-ray scanners, radios, and cellular telephones. It's the everyday, little-seen effects of modern electronics that make it so ubiquitous and so much a part of our lives.

One of the basic building blocks of modern electronics is the transistor, a device that became a household word in the 1960s with the introduction of transistor radios. In 2001, the semiconductor industry manufactured about 60 million transistors for every man, woman, and child on Earth. By 2010, this number is expected to be about 1 billion transistors per capita. Once scientific marvels, these tiny flakes of silicon have now become more plentiful than rice.


About This Book

It's normal to be curious about something that so fundamentally separates our daily lives from those of our grandparents. However, the nature of electronics, semiconductors, and chip making is inherently technical and, to be honest, pretty dull to the nonengineer. How can we keep up with this fast-moving business without becoming a nerd?

Plenty of people fly in airplanes without being pilots. Lots of people sail on ships or ride ferries without nautical experience. You can drive a car without being a mechanic. By the same token, plenty of people work in the massive electronics and semiconductor industries without first earning engineering degrees. This book is intended for them: the curious, intelligent adults who want a primer on the terms, words, and concepts behind this endlessly fascinating business, science, and technology.

Although this book is organized logically into a progression of chapters, it's not necessary to read them in order, or even to read them all. Some chapters are paired and might be best read together, such as Chapters 3 and 4, which deal with how silicon chips are designed and built. In general, feel free to browse and let your curiosity take you where it may.

I have made a deliberate attempt to avoid jargon, buzzwords, and acronyms through this book. In the back you'll find a glossary that defines many of the three-letter acronyms (TLAs) common to this business, even if those terms are never used in this book. If nothing else, keep a bookmark in the glossary so you can turn to it quickly in time of need.


Some Words To Know

Most businesses have their own specialized vocabulary that's impenetrable to outsiders. Plumbers, doctors, miners, and pilots all use words and phrases that the rest of us don't understand. It's the same with chip makers and designers. Most of their professional lingo isn't of interest to us here, but some of these words have leaked into general usage. I'll define others throughout this book as we need them.

What's a Chip?

The most common word you've undoubtedly already heard related to semiconductors is chip, as in silicon chip, memory chip, or computer chip. Chips are little flakes of silicon that have been carefully worked on in such a way that they do amazing things. There are millions of different kinds of chips made for cell phones, antilock brake systems, televisions, radios, and innumerable other devices. Memory chips and microprocessors are both examples of chips. Big or small, all chips are made in more or less the same way, from the same basic materials, namely silicon and aluminum.

What's Silicon?

Silicon is a perfectly normal substance: It's sand. Believe it or not, all the world's advanced silicon chips are basically made out of sand. Whether the chips are used in computers, satellites, cell phones, video games, or household thermostats, they all have the same humble beginnings on a beach somewhere. (Technically, industrial-grade silicon is specially manufactured, not scooped off the beach with a pail, but it's the same stuff either way.)

Here is one important point to remember: silicon is not the same as silicone. Silicon rhymes with "drawn" and is the sandy stuff chips are made of. Silicone rhymes with "throne" and is the stuff that cosmetic surgeons use. You can also find silicone grease at the hardware store; it makes good weatherproofing and stops squeaky hinges. It's an unfortunate trick of the English language that these two words are so close together. They really have nothing in common and are not related at all. You're sure to mark yourself as an amateur if you accidentally mention "silicone chips."

Silicon Valley, of course, is the nickname for the Santa Clara Valley of California. It's a roughly 50-mile stretch between San Francisco (at the north end) and San Jose (at the south end). There's no natural silicon there, although judging from some of the inhabitants, there is a fair amount of silicone.

What's a Semiconductor?

Semiconductor is a word that only chemists should really be using. It means a chemical or a substance that conducts electricity, but not very well. Some materials, like copper, conduct electricity quite well. That's why houses are built with copper wires. Other materials, like rubber and plastic, don't conduct electricity at all. That's why power cords are plastic on the outside: to protect us from the electricity inside. Finally, there's a third class of materials, the semiconductors, that conduct electricity better than plastic but not as well as copper. For reasons it's not important to explain, this makes semiconductors great materials for building chips, and silicon is one of the best semiconductors available.

We also use the word semiconductor to refer to things made from silicon (see Figure 1.1). For example, in this book you'll read about computer chips "and other semiconductors." That doesn't mean materials other than silicon. It means manufactured items that are made from silicon. In that sense, semiconductor is basically the same as chip or component.

Figure 1.1. Practically all electronic devices are made from purified silicon: sand. The silicon is processed into a number of different shapes and designs to create chips and other components. There are millions of different kinds of chips, as well other types of components.

Not all semiconductors are chips; casino operators might say not all chips are semiconductors, either. The only other good joke in this category involves a railroad conductor who had his hours cut back: He became a semiconductor.

What's a Transistor?

Everybody has heard of a transistor radio (at least, everyone of a certain age), but how many know what a transistor really is? Is it a big thing or a little thing? Good or bad? The answers to these questions are little and good.

Transistors are the smallest, most basic building blocks in most electronics. They are the bricks from which the soaring towers are made. Transistors can be combined to make nearly anything an electrical engineer can imagine. An electrical engineer might describe a day's work as a 5,000-transistor circuit the way a cook might enthuse over a three-egg omelet.

Transistors can be made as big or as small as you like, but the overwhelming trend is to make them smaller. The first transistors, created in the 1950s, were as big as your thumb. Modern transistors are—hold your breath—about one-millionth of an inch across. You could easily inhale a thousand transistors and not know it. You can also fit more than 10 million transistors on your fingernail, and in Chapter 4 we'll see exactly how these modern miracles are put together.

What's an IC?

IC (integrated circuit) is just another term for a chip. You can use the terms IC and chip interchangeably.

What's a Component?

A component is similar to a chip, but the term is a little broader. All chips are components, but not all components are chips. Pretty much any electrical type of device you might make from silicon is a component. Chips are the most common type of component, but there are other types of electrical components, too, like resistors and capacitors.

What's a Circuit?

Circuit is a medium-strength technical word to describe an electronic design. Architects create blueprints; electrical engineers create circuits. To these people, electricity always travels in a circle, like horses around a track. Therefore, any electronic design is called a circuit. Whether it's a big design (like an entire television) or a small design (like a single chip), it's still called a circuit. In this book, you'll see circuit used as a catch-all term for many different kinds of electrical designs.


Chapter 2. Semiconductor Family Tree

In this chapter...

  • Semiconductor Family Tree

  • Simple Analog Components

  • Advanced Analog Components

  • A/D and D/A Converters

  • MEMS

  • Medium-Scale Digital Chips

  • Highly Integrated Digital Chips

The term semiconductor covers a lot of territory, from big famous chips like Pentium microprocessors down to little tiny components that are almost too small to see. No single company makes or sells all these different kinds of semiconductors, and no engineer, programmer, or purchasing manager can keep them all straight. Everyone specializes in just one small aspect of semiconductors.

Just as with the medical profession, no one in the semiconductor industry can stay current with—or even fully understand—the whole industry at once. Doctors might specialize in podiatry, surgery, oncology, or pediatrics. Likewise, business managers and engineers might specialize in memory chips, semiconductors for radio and television broadcasting, or high-voltage components. There are entire trade groups and professional conferences devoted solely to tiny and arcane niches within the larger semiconductor industry. Market research firms sift and sort revenue and shipment data by categories that might make little sense to outsiders.

For our purposes, we'll divide semiconductors into a few big categories in this chapter, and then delve into some of the more interesting ones in more detail, both here and in later chapters. These divisions are well accepted in the industry; we're not being arbitrary. You'll find that professionals working in one major division generally don't understand (or care) very much about how semiconductors in the other divisions work, how they're sold, or who uses them. Like doctors at a large medical convention, they might be able to discuss some basic ideas, but the detailed conversations are intelligible only to others in the same specialized field.


Semiconductor Family Tree

Figure 2.1 shows an overall "family tree" for all types of semiconductors. It starts with raw silicon (and other natural materials) on the left and moves to progressively more elaborate types of manufactured semiconductors on the right. Each box along the way represents a different type of semiconductor unit, or component, that you can buy today. (In this chapter we use the word component to refer to all different types of semiconductor products. Later on, we'll fine-tune our terminology.)

Figure 2.1. Semiconductor family tree. Silicon can be processed to make a number of useful, small, mostly analog, discrete components. Combinations of these can be made into simple digital circuits, combinations of which can form larger, more complex digital circuits such as microprocessors.

Figure 2.1 is also a kind of evolutionary chart. Components on the left are more primitive and basic, whereas those on the right are more sophisticated or have been built up from the simpler components. The older components haven't been replaced by any means. They're all alive and well and selling millions or billions of units per year. (You can see a lot more detail on the actual sales volumes and revenue in Chapter 5, "Business and Markets.") As a rule of thumb, the components on the left are the cheapest, but sell in the greatest numbers. As you move to the right, the components become more expensive but sell in lower volumes.

From Little Acorns to Great Oak Trees

Simple electronic components like resistors and capacitors are fundamental building blocks for all electronic products. They're made from simple natural materials, such as silicon, carbon, or aluminum. These simple components are tiny, cost just pennies each, and are manufactured in huge volumes for customers around the world. A resistor, capacitor, or diode might be about as big as a grain of rice.

Transistors are also pretty elementary components, but they represented a major leap forward when they were invented in 1947. Two Bell Labs engineers, John Bardeen and Walter Brattain, and their boss, William Shockley, invented the first transistor, which opened the doors to further evolution in electronics. Transistors turned out to be the key component in a wave of innovation through the 1950s and 1960s. Transistors helped define "digital" electronics, ultimately ushering in the era of digital computers and other modern conveniences. Transistors also played a role in the invention of integrated circuits (ICs), which represented another leap forward in semiconductor manufacturing.

If you combine these basic electronic components—resistors, capacitors, diodes, inductors, and transistors—you can create just about any electronic or computer-controlled device in the world today. These humble components are the bricks and mortar of all modern electronics. Like bricks and mortar, it's generally only a matter of combining these in the right order or the correct proportions that determines what grand structure you create. Electrical engineers are experts at combining these basic components to make wondrous devices.

Figure 2.1 shows that resistors, capacitors, diodes, inductors, and transistors can be combined to create more complex components such as logic gates, converters, and sensors. Mixing these basic components together into one larger component is called "integrating" them. This is where the term integrated circuit comes from. An IC is a mixture of simpler components combined to create a more complex component. A typical IC might sell for less than a dollar and be about the size of a postage stamp.

Building on these components, engineers create ever more highly integrated components. Some examples are memory chips, microprocessors, programmable logic, or network ICs—complex and sophisticated components that contain more than 1 million basic components within them. These ICs would typically sell for several dollars and be as big as a matchbook.

This sequence of integration on top of more integration can go on more or less forever. Electrical engineers constantly combine the components their predecessors created and integrate still more components into them. This leads to ever more complex ICs with more features and more power. This continual up ward spiral has given us components that have more than 50 million constituent components inside them. It would be impossible to re-create a Pentium 4 processor, for example, out of 50 million individual transistors, yet the real thing fits on a slice of silicon no bigger than your fingernail.

As you can see, components can be integrated to create new, bigger components, and so on. Each generation of this process has been given a name. When the four basic electronic components are integrated to make an IC, it's sometimes called small-scale integration (SSI). When SSI components are integrated still further to create a second-generation IC, it's called medium-scale integration (MSI). After MSI comes large-scale integration (LSI), and then very large-scale integration (VLSI). After this point, the terminology kind of runs out, so VLSI is a now blanket term covering any moderately large chip.

Integrated Circuits versus Discrete Components

Not all electronic components are ICs, as you can see from Figure 2.1. Any nonintegrated component is called a discrete, or separate, component. When people discuss semiconductors it's usually ICs they're talking about. In the popular imagination, all electronic components are ICs, when in reality only about 20 percent are ICs. The rest are discrete components.

ICs are also called chips. All three terms are synonymous and you can use them interchangeably. You might also hear people say "computer chip" or "microchip," but the cognoscenti frown on these terms. Throughout this book you can transpose "chip" with "integrated circuit" or "IC" and no one will complain.

Discrete components tend to be very small, about the size of a grain of rice. ICs are generally bigger, rectangular, and black with small silver "legs" sticking out, as shown in Figure 2.2. Some ICs are fairly small (these are the first-generation SSI chips). Some ICs are comparatively huge, such as a 50-million-transistor microprocessor chip. If a chip looks big on the outside, it's a safe bet there are millions of basic components integrated on the inside.

Figure 2.2. These three typical ICs all contain a tiny silicon chip housed in a black plastic package for easy handling. The sixteen metal "legs" allow outside wires to connect to the actual chip inside. Courtesy of STMicroelectronics, Inc. Used with permission.

Jack Kilby and Robert Noyce, two engineers working independently and unbeknownst to each other, both developed the first ICs in 1958. (Noyce received the patent for it, but Kilby received a Nobel Prize in 2000.) Kilby created his IC during his 1958–1959 Christmas break from Texas Instruments. Robert Noyce, then at Fairchild Semiconductor, developed a similar chip using similar materials at the same time.

Digital versus Analog Components

You might have noticed from Figure 2.1 that some of the components are labeled as analog components, others are called digital components, and transistors seem to be a little of both. What does this mean? Not a lot, unless you're planning a career in electronics. Analog and digital describe differences inside the component and how it handles electricity.

Digital components treat electricity as either on or off, with no in between. Digital components deal in black and white, true and false, and yes and no. They're also sometimes called logic components because they see everything as neat and logical, with no gray areas. Computers are made up mostly of these digital, or logical, components.

Analog components treat electricity as a steadily flowing stream. They deal in smooth variations of gray, so to speak. Analog components smooth, shape, and modify the electricity passing through them. If you like, you can think of digital components as the ordered, left-brained, rules-oriented components and analog components as the changeable, artistic types. (Chapter 9, "Theory," explains a lot more about the difference between digital and analog components.) Figure 2.3 represents how electricity passes through digital and analog components.

Figure 2.3. Digital components such as logic gates and memory chips treat electricity as either on or off, like a light switch. Analog components like resistors and diodes handle electricity in varying levels, or voltages.

Digital and analog components are often used together in the same product, such as televisions. Computers, cell phones, and microwave ovens also include both digital and analog components. Like yin and yang or hardware and software, they are two fundamentally different things that complement each other.


Simple Analog Components

Discrete analog components tend to be physically small because they're fundamentally simple creations (see Figure 2.4). In the early days of electronics, all components were simple analog components. Since about 1960, engineers have been combining these discrete building blocks to create ever more elaborate, integrated components that tend to be physically larger.

Figure 2.4. These analog components, scattered across two silicon wafers, show the variety of shapes and sizes these components can take. Courtesy of Texas Instruments. Used with permission.

Some analog components are sold as small discrete components; others are combined into larger integrated analog components, seen later. Engineers designing analog products (e.g., radios and some stereo gear) sometimes like to fine-tune their designs by hand-picking each individual analog component. In contrast, engineers designing computers and other large digital products are happy to use ICs, taking their components in bulk. There's a fair amount of finesse required to design and build complex products from discrete analog components, and engineers gifted with that talent are rare and valuable.

Resistors, capacitors, diodes, and other common analog discrete components are smaller than a penny and cost even less. These analog components are like the insects of the semiconductor world: They are amazingly plentiful and almost totally ignored.

You might sometimes hear electronics aficionados discussing linear components, especially if they're into short-wave radios or high-end stereo gear. Linear components are a subclass of analog components. Some analog components are linear, and some are nonlinear. Linear describes how these components can take electricity and amplify (increase) or attenuate (decrease) it very smoothly without adding any "coloring" to it. In stereo gear, for example, it's important to play the music exactly as it was recorded without adding artificial distortion.

Resistors

Let's start our tour of the analog kingdom with resistors, probably the simplest and most common type of electrical component (see Figure 2.5). Resistors do pretty much what their name implies: They resist the passage of electricity. Resistors are electronic speed bumps, bleeding off voltage and slowing the electric flow.

Figure 2.5. Resistors are among the simplest electronic components. These three resistors are smaller than a pencil eraser and the wires on them are thinner than pencil lead. The colored stripes identify the amount of electrical resistance each resistor provides. Courtesy of Hitachi Semiconductor America. Used with permission.

Tech Talk

If you're a fan of Newton's Third Law of motion and Einstein's E = mc2, you know that energy can't be created or destroyed, only converted. Resistors convert the electricity they're resisting into heat; the bigger the value of the resistor, the warmer it gets. Tiny resistors like those you'd find in a portable radio generate so little heat it's not even noticeable. Some big resistors, though, need metal cooling fins to keep from overheating. In the extreme case, the whole purpose of a resistor is to generate heat. A car's rear-window defogger or burners on an electric range are both examples of resistors that get hot on purpose.

Although slowing down electric current seems pretty pointless, clever combinations of resistors can adjust voltages to specific and desirable levels. Technically speaking, resistors aren't really semiconductors because they're not made from silicon. Most resistors are just powdered carbon stuffed into a hollow tube, like a tiny pencil. Big, high-voltage resistors use coils of heavy wire in place of the carbon, making them essentially electric space heaters.

Resistors are so small that it's hard to print any markings on them, so they're identified with colored bands. The colors are a special code that electrical engineers memorize early in their careers. Each color stands for a different number, from nine to zero: black, brown, red, orange, yellow, green, blue, violet, gray, and white.

Capacitors

The next-most common type of analog component is capacitors (see Figure 2.6). Again, the name gives you a hint about its function. Capacitors store small amounts of electricity, like electric shoeboxes. Electricity flows in one end of a capacitor, where it gets stored indefinitely or until the capacitor "overflows." The bigger the capacity of a capacitor, the more electricity it holds until it overflows.

Figure 2.6. Capacitors have just two wires, like resistors. The larger "can" capacitors contain rolled-up foil and plastic in layers. The smaller capacitor uses a small amount of insulating material to separate its two wires. Courtesy of Hitachi Semiconductor America. Used with permission.

Capacitors are simply two metal plates separated by a small gap. Electricity can't jump across this gap, so it builds up at one end of the capacitor. Finally, after enough electricity builds up on one side, the sheer force of all that juice pushes electricity away from the metal plate toward the other side. The net result is a brief time delay in the electric flow. If you're used to repairing cars, you might remember replacing the condenser, which is just another word for capacitor. The condenser is a big capacitor that stores enough electricity to create a spark in the spark plugs.

Capacitors, like resistors, aren't technically semiconductors because they aren't made from silicon. Capacitors usually include two metal plates separated by a piece of plastic, paper, or sometimes just air. To make the capacitors small and compact the plates are wound up into a cylinder like cinnamon rolls.

Inductors

Inductors are peculiar components that take advantage of magnetic fields to control the flow of electricity. They are basically coils of very fine wire looped around and around a tiny central core. The whole inductor might be only as big as a pencil eraser, but it contains yards and yards of wire. They're useful to engineers designing radio and cellular equipment, but inductors don't show up much in computers and other digital products. From the outside, inductors look much like capacitors.

Transistors

Transistors are a major step up the evolutionary ladder from resistors, capacitors, diodes, and inductors. They're also the first real semiconductor in our tour of the family tree. (Resistors, capacitors, and inductors are electronic components but they aren't made from semiconducting materials.) The invention of the transistor in 1947 was a landmark event in semiconductor physics. Transistors changed the way electronic systems are built and paved the way for everything from transistor radios to microprocessors.

Transistors were once called valves, which is a pretty fair description of what they do. A transistor, like a water valve or a spigot, has a place where current flows in, a place where it flows out, and some way to control the flow. Electrically speaking, transistors adjust the "water pressure" of a flowing electric current. They allow one electrical circuit to control another, like hands on valves. You'll find more discussion of how transistors work in Chapter 9, "Theory."

Like a water valve, transistors can adjust the flow of electricity in variable amounts. This makes them analog components because they adjust electricity in a continuous stream. Also like a valve, transistors can turn the flow on or off completely, which would make them digital components. The fact is, they're both. Transistors bridge the gap between analog and digital. They can be used like analog components, smoothly adjusting electrical flow, or they can be used as digital components, acting as on/off switches.

Figure 2.7 shows the first transistor ever made. The electricity flows in through the curly wire on the left and flows out through the wire on the right. The thick wire in the middle controls the flow; it's the hand on the spigot. The triangular object attached to the wires is a chunk of semiconducting material. In this case, it's not silicon but a different natural material called germanium. After some experimentation, silicon was found to be a better material and virtually all semiconductors today are made from silicon.

Figure 2.7. The first semiconductor transistor, created in 1947 by John Bardeen, Walter Brattain, and William Shockley while working for Bell Laboratories. Courtesy of Lucent Technologies. Used with permission.

Tech Talk

Moore's Law—a comment made 40 years ago by one of the industry's early pioneers—has turned out to be a surprisingly accurate prediction of how fast the entire semiconductor industry races forward.

Fairchild Semiconductor's head of research and development, Gordon Moore, wrote an article in 1965 speculating that his company, and other electronic makers, would be able to squeeze twice as many transistors onto a silicon chip every year. Ten years later, in 1975, his prediction was right on the money. He reduced his estimate going forward, however, forecasting 18 months for each doubling. This became unofficially known as Moore's Law, and after 30 years, his prediction is still uncannily accurate.

Moore's Law is often misquoted or misunderstood. Moore said nothing about computer speed, microprocessors, or prices. He restricted his comments to packing transistors onto silicon. Happily, all the other benefits have come about because of the continual advances he projected.

Over the years a number of people, including Moore himself, have unsuccessfully predicted the end of Moore's Law. Despite many informed prophecies to the contrary, semiconductor progress continues at an astounding pace.

Transistors are still sold individually like resistors and other discrete components (see Figure 2.8). It's much more common, however, to see transistors grouped together, often by the millions, to create larger and more elaborate integrated components.

Figure 2.8. Transistors always have three wires, although the metal case is sometimes used as the third wire. Electricity flows in and out of a transistor, with the amount of flow controlled by the third wire. These transistors are each about the size of a pencil eraser. Courtesy of Hitachi Semiconductor America. Used with permission.

Transistors have more or less replaced vacuum tubes in radios and televisions. Like transistors, vacuum tubes used electricity to control the flow of electricity. Linking these together you could make elaborately interrelated electronic circuits. The problems with vacuum tubes were their large size, the frailty of their glass containers, the amount of electricity they used, and the heat they gave off. Transistors perform all the same functions without any of these drawbacks. Except for a few fanatical hi-fi stereo enthusiasts, nobody mourns the passing of vacuum tubes.

Strangely, transistors lead us into the world of digital electronics. This is strange because transistors are analog devices just like resistors or diodes. Electricity passes through them in smoothly varying amounts, like water through a spigot that's being gradually opened. Yet transistors' ability to turn the electric flow on and off—like shutting off the spigot completely—opened the door to a new kind of electronics and a new way of thinking. Digital electronics owes its existence to transistors and to the many different and unexpected things transistors can do when they're used in large numbers.

Diodes

Diodes make one-way streets for electricity. Electricity can flow through a diode in one direction but not the other. This makes diodes good for controlling the flow of electricity, directing it to where it's needed. From the outside, diodes look very much like resistors but without the colored bands.

LEDs

There's a special kind of diode that gives off light, so it's called, obviously enough, a light-emitting diode (LED), shown in Figure 2.9. Although LEDs work just like normal diodes do, they're more interesting for their lighting ability than for their one-way electrical characteristics. When electricity tries to pass through an LED in the "wrong" direction, it is stopped, just like a normal diode. However, when electricity passes through in the right direction, the LED glows. (For you physicists, the energy of the electricity is converted to visible light.)

Figure 2.9. This collection of LEDs includes samples of many colors. Each has two wires and a plastic lens. The color of the light it gives off depends on the combination of chemicals used to make the LED; the lenses themselves are usually clear. Courtesy of Hitachi Semiconductor America. Used with permission.

LEDs come in a few different colors, but red is the most common by far. Most home electronics, like your VCR, microwave oven, television, or bedside clock probably use red LEDs. They glow red simply because the chemicals used to make LEDs happen to give off that color; it was not an intentional choice.

Tech Talk

You might see clear or "white" LEDs from time to time. These are actually special red LEDs that have a color-filtering lens that blocks the red light, like tiny sunglasses. Filtering out colors like that is inefficient, so clear LEDs waste more electricity than colored LEDs.

Researchers have tried to make blue LEDs for a long time, with little success until recently. Why the big deal over one color? The combination of red, green, and blue LEDs would allow manufacturers to make LED television sets and dispense with big, heavy, expensive glass picture tubes. The combination of red, green, and blue (RGB) lights can create any color the eye can see. Without blue, LED TV wouldn't be worth watching.

With different chemicals inside, LEDs can be made to glow in different colors. Yellow and green LEDs are popular, but blue LEDs are exceedingly rare and expensive. It's hard to find a natural substance that makes good diodes that can also give off light. There are infrared LEDs that glow in colors you can't see. These LEDs glow in "invisible light" in the infrared spectrum. The remote control for your TV probably uses one of these. Press a button on your remote control; do you see any lights blinking on the front? Probably not, because the LED in your remote emits a color of light your eye can't see but your television can.

Tech Talk

If you have a video camera or camcorder, try videotaping yourself as you operate the remote control for your TV. Even though you can't see the light coming out of the infrared LED in the remote control, your video camera probably can. Play back the tape to see your remote blinking its secret signals to your television. Other remote controls (for your VCR, etc.) probably work the same way.

LEDs are now being used in car taillights, brake lamps, and city traffic lights because they're smaller and more rugged than light bulbs. One or two LEDs in a cluster can burn out, but the traffic light will still work. LEDs also light up faster than bulbs do. Some sharp-eyed people report seeing traffic signals "flash" when they turn red because LEDs don't warm up the way traditional bulbs do.

Laser Diodes

At the extreme end of the LED family tree are laser diodes, which are tiny lasers, no bigger than a pencil eraser. We've all seen laser diodes used as high-tech pointers in business presentations—they're a kind of nerd chic—but they're also common in the home. Every stereo CD player, DVD movie player, portable CD player, in-dash car CD player, and CD-ROM drive or DVD-ROM in a computer uses a laser diode. Most home video game systems use one, too. These little components have enabled a whole wave of consumer electronics and toys. Who would've thought that lasers, the preferred weapon of James Bond villains, would become ubiquitous, harmless children's toys?

Laser diodes are different from simple LEDs because they give off a narrow beam of laser light instead of glowing in all directions. Laser light travels in a straight line and doesn't spread out. That's why laser pointers make a small red spot on the wall instead of lighting up the entire room the way a light bulb would. That's also why you can't see a laser unless it's pointed directly at you, as opposed to an LED that's visible from anywhere. Creating a laser requires some precision manufacturing, so laser diodes are more expensive than LEDs. The tight beam of a laser diode is just what you want for reading the tiny marks engraved on a music CD or DVD.

Optical Sensors

Optical sensors are like the reverse of LEDs. Instead of giving off light, they detect light. These look like LEDs on the outside put perform the opposite task. Your TV remote control will have an LED on it, but your TV will have an optical sensor somewhere on the front to detect the light given off by the LED.

Optical sensors can't really see or recognize images. They can only tell whether the light nearby is bright or dim. If the light flickers, they can tell that, too. That's how TV remote controls work: by blinking their light off and on in various patterns like an invisible version of Morse code.


Advanced Analog Components

Digital components aren't the only ones that are integrated into larger ICs. Analog components, too, have been combined in interesting ways. Some, like charge-coupled device (CCD) arrays, open up new kinds of markets and products once they're integrated. Others, like micro-electrical mechanical sensors (MEMS), seem just plain weird at first glance.

CCD Image Sensors

CCD image sensors form the basis of digital cameras and other interesting image-recognition products. A CCD image sensor is a chip with individual light sensors arranged in a square pattern, or array, like tiles on a bathroom floor. The image sensor might have 100 "tiles" across and 100 up and down, or it might have thousands in each direction. Each individual sensor in this tiled array can sense one dot, or pixel, of light. Together, they can "see" an entire image. The more sensors in the array, the sharper and clearer the image will be, which is why you'll hear camera experts bragging about how that 20-megapixel camera is better than a 3-megapixel camera.

There are other types of images sensors, such as CMOS image sensors, but they all work in basically the same way. Thousands or millions of individual light sensors are arranged in a square pattern on a chip to produce one large, clear image.

Other Sensors

Also under the heading of sensors are temperature sensors, pressure sensors, acceleration sensors, magnetic sensors, and many more. Temperature sensors are essentially electronic thermometers, useful for household thermostats as well as many industrial uses. They work by taking advantage of the way some materials behave when they get hot (or cold). Some materials conduct electricity better when they're warm or when they're cool. Engineers have discovered exactly how much their properties change and can determine the temperature of the chip by measuring how much electricity it conducts.

Magnetic sensors work in somewhat the same way. Some materials behave differently in the presence of magnetic fields, so chips built around these materials can detect slight differences in magnetism. This is useful in electronic compasses (detecting the Earth's magnetic field) or even for measuring flaws in bulk steel by sensing slight differences in its magnetic properties.

Chemistry labs and medical labs use small sensors that detect certain smells or gases. Like the temperature sensors, some materials behave differently when they're exposed to certain gases. Engineers have measured these differences and created chips that give off tell-tale electrical impulses in the presence of, say, oxygen. Like a canary in a coal mine, these chemical sensor chips can detect very minute amounts of gas or poison before laboratory technicians can.


A/D and D/A Converters

Converters bridge the world of analog and digital electronics. There are analog-to-digital converters (usually called A/D converters, or just ADCs) and digital-to-analog converters (called D/A converters, or DACs) that go the other way. Obscure as these components might seem, they're actually quite common. Every CD player, MP3 player, and portable music player has at least one D/A converter to convert the digital data stream into an analog signal for the headphones or speakers. Some will have two or more DACs, one for each speaker. Any "tapeless" digital telephone answering machine will include an A/D converter that records your greeting and converts it into digital data before storing it in memory chips. Any synthesized voices you might hear emanate from D/A converters.


MEMS

MEMS are truly the strangest type of semiconductor. Little understood even by industry insiders, MEMS have a devoted following and a greatly confused reputation. Neither digital nor analog, MEMS aren't even always semiconductors. They might be made of silicon but they don't always conduct electricity in any useful way. MEMS are basically tiny mechanical devices that just happen to be built using chip-manufacturing techniques.

The term MEMS has nothing to do with memory. It's short for micro-electrical mechanical sensor, an awkwardly technical description of how they function. MEMS use tiny gears and levers to move things or sense motion on a microscopic scale. MEMS can sniff chemicals, separate blood cells, or measure acceleration—all functions that require mechanical movement and not just electrical current. The fact that MEMS are built using silicon-processing equipment allows them to be incredibly small and relatively inexpensive (see Figure 2.10).

Figure 2.10. This tiny gear and chain drive is actually a silicon chip photographed with an electron microscope. The gears are smaller than an ant's head and each link in the chain is about the size of a large bacteria. The entire assembly runs at very high speed because MEMS have very little inertia.

Airbags are probably the most popular use of MEMS. These tiny sensors have microscopic mechanical levers etched into their silicon surface. The lever bends ever so slightly if the chip is knocked hard enough, as in a serious automobile accident. If the lever bends enough it completes an electrical circuit that isused to ignite an explosive charge and inflate the airbag. These miniature accelerometers are very reliable, very small, very inexpensive, and easy to manufacture in high volume, making them a perfect fit for auto industry mass production.


Medium-Scale Digital Chips

Once engineers discovered that transistors could be used as on/off switches for electricity, a whole new field of digital electronics was born. Digital components work by treating electricity as if it were Morse code. Instead of dots and dashes, digital components switch tiny amounts of electricity on and off. Other digital components receiving these transmissions can decode them, like a telegraph operator receiving a telegram. A string of digital components working together can create long chains of elaborate functions as each link adds its ability to that of the others. With enough of these links you can create seemingly intelligent electronic devices, such as computers.

Certain combinations of transistors were useful enough to prepackage them into the first digital ICs. These, in turn, led to more highly integrated ICs, and so on. Digital chips span the scale of complexity from a few hundred transistors per chip to tens of millions of transistors per chip, with many steps along the way.

Logic Gates

Logic gates are the starting point for digital electronics. They're one level up the evolutionary ladder from transistors and the fundamental building blocks for digital clocks, video games, personal computers, and a million other products. A logic gate consists of a few transistors, plus perhaps a few resistors or capacitors. As a general rule of thumb, one logic gate is equivalent to about six transistors.

Gates are so named because they gate, or control, the flow of electricity. Barnyard gates control the flow of cattle; logic gates control pulses of digital electronics. Logic gates aren't smart but they are logical. They make very simple decisions based on very simple inputs. For example, one type of logic gate is called an inverter. It simply passes its input to its output, but reversed. In Morse code, this would be like converting all the dots to dashes and all the dashes to dots. This is not spectacularly challenging, but it is useful for certain electronic functions.

Other types of logic gates are OR gates (that's the word "or," not the letters O-R); AND gates, and exclusive-OR gates. From these come variations such as the NAND (negative-AND) gate, the NOR (negative-OR) gate, and XNOR (exclusive-negative-OR) gate. Buffers, inverters, and the curiously named flip-flop round out the rogues' gallery of logic gates. If you'd like to know more about logic gates and what they do, take this as an invitation to skip ahead to Chapter 9, "Theory."

Tech Talk

There's a whole branch of mathematics devoted to the OR, AND, NOR, and other logic functions. Named after English mathematician George Boole, Boolean algebra underpins all computers and digital logic chips. Ask any computer programmer or engineer and they'll tell you that Boolean logic was the first thing they had to learn.

Boole's work was later enhanced by Claude Shannon, John Venn (he of the Venn diagram), and Charles Dodgson, an English deacon and part-time mathematician who also wrote children's books under the name Lewis Carroll.

Logic gates are simple and small so they're not sold individually. You can buy small chips with collections of AND, OR, XOR, or NAND gates in them for a few pennies (see Figure 2.11). Hobbyists and students often use these small chips to build simple electronic projects.

Figure 2.11. This typical IC contains a handful of simple logic gates. With 14 pins total, this chip probably contains about four separate logic functions, plus two pins for power. Electronic engineers and hobbyists can build large projects using these types of chips. Courtesy of Hitachi Semiconductor America. Used with permission.
    [ Team LiB ]


Highly Integrated Digital Chips

Once the trend toward integrating transistors and other discrete components into larger integrated components was under way, there was no stopping it. Today, big chips contain millions of gates of logic, which implies millions of transistors, resistors, diodes, capacitors, and other basic components all rolled together.

Such highly integrated chips are generically called VLSI components. There's no specific test for a chip to be considered a VLSI device; anything more than about a million transistors probably qualifies. By that measure, most new chips qualify as VLSI components.

These large-scale digital chips take many forms, from memory chips to microprocessor chips. These are the most complex and elaborate semiconductor components ever created, and their profitability reflects their advancements. Top-of-the-line microprocessor chips can sell for more than $1,000 each. They use the most advanced silicon manufacturing technology and take teams of engineers many years to design and develop.

Memory Chips

Memory chips are the most plentiful kind of large-scale digital chips because so many products use so many of them. Your PC probably has at least eight memory chips inside, but it could have 64 or more. Microwave ovens, CD players, alarm clocks, and nearly any other electronic device you can think of, probably all have at least one memory chip inside them.

The world's semiconductor makers produce about 10 billion memory chips every year. As complex as they are, memory chips are nearly commodities, priced very aggressively and sold in enormous volumes. Prices for memory chips fluctuate daily in electronics markets, and analysts track memory prices like treasured stock portfolios. Over the years, memory production gradually moved from the United States to Japan, and then to Korea, Taiwan, and Singapore. Because memory chips are so price sensitive, their production tends to shift to the cheapest labor pool able to manufacture them.

What do memory chips do? Obviously, they remember, or store, electrical information. That's not as eerie or as complicated as it sounds. Memory chips are basically arrays of tiny capacitors, those simple analog components for storing electricity. Because the capacitors are very small and arranged in very tight rows, memory chips can hold millions of separate electrical charges at once.

Memory chips come in many different subtypes, which are covered in Chapter 7, "Essential Guide to Memory." That chapter also explains more about how memory chips work. The two major memory classifications are RAM and ROM. RAM chips can be erased and reused to store different data, whereas ROM chips are permanent, holding data forever.

Communications Chips

Communications chips handle data communications between computers, satellites, and buildings. They were once simple "bit pumps" that had no intelligence of their own; they just squirted data down a wire under the control of a computer. Now communications chips have become like microprocessors in their own right, with the intelligence to format, buffer, and massage data before it's transmitted or unpacking data as it's received. As the world's desire for instant communication has increased, the newest generations of communications chips have risen to the challenge.

You'll find specialized communications chips atop telephone poles and in cellular base station antenna "trees." They compress and decompress voice conversations on the fly, converting our voices into densely packed (and sometimes encrypted) data packets before sending them down copper wire or optical fiber. On the return trip, these same chips decompress (and decrypt) our friends' voices and reconstitute them into audio form. As these communications chips get more advanced, telephone companies are able to squeeze more and more simultaneous conversations onto the same wires or fibers.

With the rise of the Internet and the Web, the market for communications chips has taken off. So much data is now transferred through the Internet that intelligent and specialized chips are required at several steps along the way to make sure your e-mail gets to the right place. Some chips perform a sort of Internet triage, separating the high-priority data traffic (e.g., a streaming video broadcast) from the low-priority ones (e.g., e-mail spam). Other chips are used for security, encrypting and decrypting credit card numbers as they pass through the network. The list of communications chips is almost endless and the business of creating them is volatile and fast moving.

Graphics Chips

Graphics and 3D chips have surged to become a major part of the PC components business since the 1990s. As PCs are used more and more for games, DVD video, and other television-like tasks, the importance of graphics chips has risen. The latest graphics chips are amazingly complex and powerful, using millions of transistors and rivaling some microprocessors for performance and intricacy. In many live-action computer games, the 3D graphics chip works harder than the microprocessor in the PC. Avid PC gamers agonize over what 3D graphics chip to buy and diligently read every product review that comes out.

Apart from PCs, graphics chips are used in home electronics, such as DVD players. High-end computer systems use graphics chips to render complex information for weather forecasting; aircraft design; stress analysis; jet simulation; or nuclear, chemical, and medical research.

The performance and capabilities of graphics chips have risen dramatically over the years. Early graphics chips were little more than a D/A converter and some memory. The computer put data into the memory and the D/A converter turned it into an analog electrical signal for the screen. Now 3D graphics chips rival the microprocessor they're serving. They render 3D images from mathematical models, generate millions of colors, calculate angles of refraction based on light sources and intensities, hide overlapping objects behind one another, and fade distant objects into the background. The mathematics involved in creating 3D scenes is complex and arcane, and the circuitry involved in making all this happen 60 times per second is impressive. It's a lot of technology all devoted to entertainment.

Peripherals

Peripheral chips are so named because they are used around the outside edges, or periphery, of computers. Peripheral chips are the gatekeepers or customs agents of a computer, channeling incoming data where it belongs and sending outgoing data on its way.

Peripheral chips control printers, keyboards, speakers, mice, joysticks, or anything else you might plug into your computer. Each peripheral chip specializes in one type of plug-in, so a well-equipped computer will include several different peripheral chips. In addition to computers, peripheral chips are also used in industrial and scientific systems, or anywhere there's a computer connected to something outside in the real world.

The number and type of peripheral chips change over time as people invent new ways to use computers. Keyboard chips have been available for a long time, but chips for controlling joysticks came later. A few years ago, chips for universal serial bus (USB) and FireWire, two new PC connections, entered the market. Although peripheral chips are fairly complicated, they're also pretty inexpensive. They're considered little better than commodities by computer makers, so their prices tend to be low and their life spans short.

Custom Chips: ASICs and ASSPs

Big teams of engineers working at huge semiconductor companies design most large-scale chips. Chip design is difficult work, and the costs are high. However, over the past 10 years or so, the barriers to chip design have crumbled, little by little. Designing a chip is still not easy by any means, but it's not the mysterious black art it once was. It's now within the realm of possibility for a medium-sized company to consider designing its very own chip.

Why would you want to? Well, maybe none of the major chip-making companies produce just the chip you're looking for. Maybe you want a memory chip with a certain capacity, or a communications chip that transmits data a certain way, or a security chip that encrypts information using your special password or code system. There are as many reasons for making a custom chip as there are companies considering it.

The term for these custom chips is application-specific integrated circuit (ASIC). An ASIC is a general term for any chip that is custom designed, as opposed to a chip that's mass-produced by one of the major chip companies. You don't have to sell your custom ASIC to anyone. In fact, that's usually the point. An ASIC gives a competitive advantage to the company that makes it; it's a secret weapon inside the television, microwave oven, or antilock brake system.

What does "application-specific" mean? The word application in this sense means product. It's another unfortunate case of a common English word that's been perverted somewhat by the technical community. Application-specific means the chip is intended for some particular type of product, like elevators or steam whistles. It also implies the chip isn't very useful outside of that specific market.

ASICs by their nature are custom, so every one is different. An ASIC can be big or small, complex or (relatively) simple. It might include any combination of components from the family tree near the beginning of this chapter. An ASIC might have one or more microprocessors inside, some memory, some analog components, some programmable logic, or nearly anything else.

Designing and building an ASIC isn't cheap, so companies don't undertake the task lightly. It can easily cost $1 million in engineering time, materials, and services before the first chip is ready. Companies want some guarantee that the benefits of their ASIC will outweigh the risks and costs of its development. For starters, that means ASICs are created only for high-volume products like digital cameras, cell phones, automobiles, and so forth.

When an ASIC is designed for sale, as opposed to internal use, it's called an application-specific standard product (ASSP). The "standard product" part implies that the chip is available to anyone who wants to buy it, a sort of noncustom custom chip. There's no technical difference at all between an ASIC and an ASSP; the distinction is purely economic.

In addition to ASIC and ASSP, custom chips are sometimes called a system-on-a-chip (SoC). This term doesn't have any specific meaning; it's used to vaguely describe a particularly large or complex ASIC that includes everything the final product will need, all in a single chip. The world of ASICs, ASSPs, and SoCs is mapped out in more detail in Chapter 8, "Essential Guide to Custom and Configurable Chips."

Programmable Logic Chips

Many companies would like to develop their own ASIC but don't have the stomach—or the deep pockets—for it. For them, there is a middle ground, a kind of semicustom chip. These chips are called programmable logic devices (PLDs). Different PLD companies use different terminology, so you'll also hear them called complex programmable logic devices (CPLDs) and field-programmable gate array (FPGA). These and other types of custom chips are covered in Chapter 8, "Essential Guide to Custom and Configurable Chips."

Programmable logic chips are like electronic Etch-a-Sketches, ready to use but not really finished. Customers imprint their own design onto them, making their own semicustom chips. Customizing a programmable logic chip is nowhere near as difficult as designing and building a "real" ASIC chip from scratch. Like an Etch-a-Sketch, you can erase the chip and start over any time you want, so there's no risk.

Programmable logic chips look like normal chips on the outside but they're "blank" on the inside. They give designers and engineers a chance to play "what if" with theoretical chip designs. In the space of an afternoon, you can create and test half a dozen different chip designs on the same programmable logic chip. PLDs provide a blank canvas for engineers to be creative, and a washable one, too, because a single programmable logic chip can be used over and over. When the design is finally complete, the chip can be permanently installed into a product, where it will operate like any other chip.

There are downsides to all this flexibility. For one, programmable logic chips are slower than other chips. The exact same chip design will run slower in a PLD than it would in an ASIC manufactured by the normal means. Programmable logic chips are also more expensive than their ASIC counterparts. Companies that expect to ship thousands and thousands of chips shy away from using PLDs because of their higher unit price. On the plus side, there's no million-dollar development cost for a PLD. So although PLDs are definitely cheaper in the beginning, they might be more expensive in the long run.

Microprocessors

Microprocessors are the pinnacle of semiconductor development, or at least that's what the microprocessor makers will tell you. They are the "computer on a chip" so beloved by the popular press. There's no denying that microprocessors are the most complex and elaborate of all semiconductors or that they've forever altered our economic, social, and scientific worlds.

Microprocessors have enabled cheap, anywhere, anytime computing. Computers used to be large, noisy machines owned by governments and tended by teams of scientists in white lab coats. Now they're in every modern home, car, and telephone, ubiquitous to the point of invisibility. Computers can be cheaper than the batteries they run on. All of this has happened in the span of one human generation.

The first microprocessor was invented in 1971; now 1 billion are sold every few months. Surprisingly, almost none of those microprocessor chips are used in computers. Most people equate microprocessors with PCs but that's far from the whole picture. Computers are just a tiny fraction of what microprocessor chips are used for. Microprocessors have made a far greater impact in totally unrelated household, entertainment, security, and industrial uses than anyone could have predicted. The computer on a chip actually has very little to do with computers anymore.

Microprocessors have shown themselves to be amazingly adaptable. Like tiny robots, they can be commanded (programmed) to do any number of chores from the mundane to the complex. Instead of predicting the weather or calculating missile trajectories, microprocessors are used more commonly to cook food, turn on the furnace, open garage doors, play music, or blast imaginary space aliens. The average household has about two dozen microprocessors or more, without even counting home computers. The average car includes another dozen microprocessors; some have more than 60. Nearly anything that plugs into the wall or uses batteries is likely to have a microprocessor chip in it.

Microprocessors come in all shapes and sizes, and not all of them are the big, fast chips we see advertised on television. In fact, few microprocessor chips cost more than $5. The overwhelming majority of microprocessor chips are squirreled away inside everyday household appliances and toys. Microprocessor makers have started to specialize, so some chips are good for home appliances, some are for automobiles, some are for video games, and so on. Each variation has its own name or abbreviation.

There are different types of microprocessors, and they all have three-letter abbreviations like CPU, MPU, MCU, DSP, or NPU. For now we'll treat them all the same and just call them microprocessors. For more in-depth information, turn to Chapter 6, "Essential Guide to Microprocessors," to see what these chips are all about.


Chapter 3. How Chips Are Designed

In this chapter...

  • Old-Style Design Process

  • New-Style Design Process

  • Verifying the Design Works

  • Using Outside IP

  • Getting to Tape Out and Film

  • Current Problems and Future Trends

Chip design has come a long way since the first semiconductor chips were assembled, literally, by hand. Rarely does a profession reinvent itself so often and so fundamentally. New chips today are designed in a completely different manner from those of just 10 years ago; it's almost certain that the job description will change again in another 10 years.

New chips are designed, naturally enough, with the help of computers. These computers (often called engineering workstations) and the chips inside them were themselves designed this way, providing a nice circular closure to the entire process. The computers that chip-design engineers use are not fundamentally different from a normal PC, and even the specialized software would not look too alien to a casual PC user.

That software is breathtakingly expensive, however, and supports a multibillion-dollar industry all by itself. Called electronic design automation (EDA), the business of creating and selling chip-design software supports thousands of computer programmers around the world. Chip-design engineers rely on their computers and their EDA software "tools" the way a carpenter relies on a collection of specialized tools. There are a handful of large EDA vendors, notably Synopsys (Mountain View, California), Mentor Graphics (Portland, Oregon), and Cadence Design Systems (San Jose, California) that are the equivalent of Craftsman, Stanley, and Black & Decker. There are also numerous smaller "boutique" EDA vendors that supply special-purpose software tools to chip designers in niche markets.

Regardless of the tools a chip designer uses, the goal is always the same: to create a working blueprint for a new chip and get it ready for manufacturing. In the chip-design world, that's called "getting to film," as film is the ultimate goal of a chip designer. The film (which is really not film any more, as we shall see) is used by chip makers in their factories to actually manufacture the chip, a process that's described in the next chapter.


Old-Style Design Process

Before personal computers, EDA, and automated tools, engineers originally used rubylith, a red plastic film sold by art-supply houses that is still used today by sign makers and graphic artists. Early chip designers would cut strips of rubylith with X-acto knives and tape them to large transparent sheets hanging on their wall. Each layer of silicon or aluminum in the final chip required its own separate sheet, covered with a criss-crossing pattern of taped-on stripes.

By laying two or more of these transparent sheets atop one another and lining them up carefully, you could check to make sure that the rubylith from one touched the rubylith from another at exactly the right points. Or, you'd make sure the tape strips didn't touch, creating an unwanted electrical short in the actual chip. This was painstaking work, to be sure, but such are the tribulations of the pioneers. The whole process was a bit like designing a tall building by drawing each floor on a separate sheet and stacking the sheets to be sure the walls, wiring, stairs, and plumbing all match up precisely.

This task was called taping out, for reasons that are fairly obvious. Tape out was (and still is) a big milestone in every chip-design project. Once you'd taped out, you were nearly done. All the preliminary design work was complete, all the calculations were checked and double-checked, and all the planning was finished. About the only thing left to do was to wait for the chip to be made.

One last step remained, however, before you could get excited about waiting for silicon. You had to make film from your oversized rubylith layers. This was a simple photographic reduction process. Each rubylith-covered layer was used as a mask, projecting criss-crossed shadows onto a small film negative. It works just like a slide projector showing vacation snapshots on a big screen, but instead of making the images bigger, the reduction process makes them smaller. Each separate rubylith layer is projected onto a different film negative that is exactly the size of the chip itself, less than one inch on a side. Now you have a film set that you can send for fabrication.


New-Style Design Process

Today the process is radically different, although no less painstaking or complex. Modern chip-design tools have done away with the error-prone manual work of taping up individual layers, but they only shift the workload. Modern multimillion-transistor chips supply more than enough new challenges to make up the difference.

EDA Design Tools

Modern chips are far too complex to design manually. No single engineer can personally understand everything that goes on inside a new chip. Even teams of engineers have no single member who truly understands all the details and nuances of the design. One person might manage the project and command the overall architecture of the chip, but individual engineers will be responsible for portions of the detailed design. They must work together as a team, and they must rely on and trust each other as well as their tools.

Those tools are all computer programs. Just as an experienced carpenter will accumulate a toolbox full of favored tools, chip designers develop a repertoire of computer programs that aid in various aspects of chip design. No single EDA tool can take a chip design from start to finish, just as no carpenter's tool can do every job. The assortment is important, and using a mixture of EDA tools is part of an engineer's craft.

Schematic Capture

Schematic diagrams are the time-honored way of representing electrical circuits. At least that's true for simple electrical circuits. Schematics, or wiring diagrams, are like subway maps. They draw, more or less realistically, the actual arrangement of wires and components (lines and stations). The diagram might be stylized a bit for easier understanding, like the classic route map for the London Underground, but for the most part, schematics are accurate, maps of circuit connections, as shown in Figure 3.1.

Figure 3.1. This typical schematic diagram shows how two ICs (rectangles near the center) connect by wires (straight lines) to other components. Resistors, capacitors, diodes, LEDs, and other components are all represented by standard symbols. Except for the ICs, the figures on a schematic don't look like the actual components in the circuit.

Drawing a schematic on paper doesn't do an engineer any good if the goal is to ultimately transfer that design into film to have a chip made. Instead, schematics are drawn on a computer screen using schematic-capture software. With this, you can drag and drop symbols for various electrical components (adders, resistors, etc.) across your screen and then connect them by drawing wires between them. The schematic-capture software takes care of the simpler annotation chores like labeling each function and making sure no wires are left dangling in midair. Schematic-capture software is a bit like word-processing software in that it won't provide inspiration or talent or create designs from nothing, but it will catch common mistakes and keep your workspace free from embarrassing erasure marks.

A number of companies supply schematic-capture software, but most vendors are small firms and their ranks are dwindling. Modern chips are too complex to be designed this way, not because the schematic-capture programs can't handle it, but because the engineers can't. Designing a multimillion-transistor chip using schematic-capture software would be like painting a bridge with a tiny artist's brush and palette. There's just far too much area to cover and not enough time.

Hardware Synthesis

To alleviate some of the tedium of designing a chip bit by bit, engineers have turned to a new method, called hardware synthesis. Synthesis is not quite as space-age as it might sound: Chips are not magically synthesized from thin air. Instead, engineers feed their computers instructions about the chip's organization and the computer generates the detailed circuit designs. (The exact method for doing this is described in the next section.) The engineer still has to design the chip, just not at such a detailed level. It's like the difference between describing a brick wall, brick by brick and inch by inch, or telling an assistant, "Build me a brick wall that's three feet high by 10 feet long." If you have an assistant you trust who is skilled in bricklaying, you should get the same result either way.

Theoretically, that's true of hardware synthesis as well, but the reality is somewhat different. Although today's chip designers have overwhelmingly adopted hardware synthesis for their work, they still grumble about the trade-offs. For example, synthesized designs tend to run about 20 to 30 percent slower than "handcrafted" chip designs. Instead of running at 500 MHz, a synthesized chip might run at only 400 MHz. That's fine if it's a low-cost chip that really only needs to run at, say, 250 MHz. However, it's a showstopper if you're selling prestigious high-end microprocessors for personal computers. There are a few types of chips, therefore, that are still not designed using hardware synthesis because the vendor can't afford the reduction in performance.

Another drawback of hardware synthesis is that the resulting chips are often about 30 to 50 percent larger in terms of silicon real estate. More silicon means more cost, both because they need more raw material and because fewer chips fit on a round silicon wafer. Bigger chips mean lower manufacturing yields. Once again, there are certain chip makers that don't use hardware synthesis because they're shaving every penny of cost possible.

Third, chips made from synthesized designs tend to use more electricity than do manually designed chips. That's a side effect of the larger silicon size previously mentioned. More silicon means more power drained, and the difference can be 20 percent or more. For extremely low-power chips, such as the ones used in cellular telephones, handcrafted chips are still popular.

Despite all these serious drawbacks, most new chips are created from synthesized designs simply because there's no other way. Even big engineering teams need the help of hardware-synthesis programs to finish a large chip in a reasonable amount of time. It takes a long time to finish a cathedral if you're laying every brick by hand.

Companies will often use both design styles, synthesis and handcrafting. The first generation of a new chip will usually be designed with hardware-synthesis languages (described later) to get the chip out the door and onto the market as quickly as possible. After the chip is released (assuming that it sells well), the company might order its engineers to revise or redesign the chip, this time using more labor-intensive methods to shrink the silicon size, reduce power consumption, and cut manufacturing costs. This "second spin" of the chip will often appear six to nine months after the first version. When microprocessor makers announce faster, upgraded versions of an existing chip, this is often how the new chip was created.

Hardware-Description Languages

Schematics are fine, up to a point, but they're too detail-oriented for large-scale designs, which modern chips have become. Instead, engineering teams need something that's more high-level and more abstract; something that allows them to think big and avoid getting bogged down in so many of the electrical details of what they're creating. What they'd like is some way to describe what they want, and have a tool magically produce it.

Enter hardware-description languages (HDLs), the next step up the evolutionary ladder from schematic-capture programs. HDLs also enable hardware synthesis. Using an HDL, engineering teams can design the behavior of a circuit without exactly designing the circuit itself in detail. The HDL tool will translate the engineers' wishes (albeit very specific and carefully defined wishes) into a circuit design. Instead of using schematic-capture software to draw an adder and all of its attendant wiring, an HDL user can simply specify that he or she wants two numbers added together. The HDL tool handles the detail work of selecting an adder and wiring it up.

HDLs are far from magical. Like all computer programs, they're very literal minded and can misinterpret their user's wishes. Engineers spend years learning to use HDLs effectively and have to be very methodical about defining what they want. The bigger the chip design, the greater the opportunity for failure, so the greater the pressure to make sure everything's right.

HDLs look nothing like schematic capture. Instead of drawing figures on a screen, using an HDL is more like writing. It's a hardware-description language, after all. Engineers use an HDL to tell their computer what kind of circuit they want, in the form of a step-by-step procedure. The computer then interprets the steps and produces an equivalent circuit diagram. If schematics are blueprints, HDLs are recipes.

For a large chip, this procedural description can be hundreds of thousands of lines long, as long as a novel. A sample of HDL code is shown in Figure 3.2. It has to describe absolutely everything the chip does under all circumstances.

If you're familiar with computer programming and software, you've probably already recognized the concept of HDLs; they're programming languages. Paradoxically, HDLs are a software approach to a hardware problem—they're a way to "write" new hardware.

Figure 3.2 This extract of HDL code describes how an adder circuit should work. An HDL compiler translates this detailed description into a schematic, which can then be given to an engineer to build or, more likely, will be combined with other HDL components to make a larger chip.
  variable n : integer := 0;
  variable failure : boolean := false;
begin
  assert (x'high - x'low + 1) <= 31
      report "Range of sulv_to_integer argunent exceeds integer range"
      severity error;
  for i in x'range loop
    n := n * 2;
    case x(i) is
      when '1' | 'H' => n := n + 1;
      when '0' | 'L' => null;
      when others =>
          -- failure := true;
          null;
    end case;
  end loop;

  assert not failure
    report "sulv_to_integer cannot convert indefinite std_ulogic_vector"
    severity error;
  if failure then
    return 0;
  else
    return n;
  end if;
end slv_to_integer;

function integer_to_slv(n, bits : integer)
    return std_logic_vector is
  variable x : std_logic_vector(bits-1 dowito 0) := (others => '0');
  variable tenpn : integer := n;
begin
  for i in x'reverse_range loop
    if (tempn mod 2) = 1 then
      x(i) := '1';
    end if;
    tempn := tempn / 2;
  end loop;

  return x;
end integer_to_slv;
The HDL Leaders: VHDL and Verilog

The two most common HDLs are called VHDL and Verilog. Practically all new chips are designed using one of these HDLs. The two languages are quite similar, but both have devoted practitioners who'd argue the merits of their chosen HDL with an uncommon zeal.

Both of these languages were developed in the United States, although both are used worldwide. Interestingly, there is a definite geographic division between VHDL users and Verilog users. Verilog aficionados seem to be clustered around the western United States and Canada, whereas VHDL holds sway in Europe and New England. Asian users seem to be evenly split. (Regardless of the local tongue, the VHDL and Verilog languages always use English words and phrases to describe hardware.)

Tech Talk

Verilog is a few years older than VHDL. First developed in 1983, Verilog was for some time a proprietary HDL belonging to Cadence Design Systems. VHDL, on the other hand, was created as an open language and became an Institute for Electrical and Electronics Engineering (IEEE) standard in 1987. Sensing that VHDL's standard status would jeopardize its investment in Verilog, Cadence put its HDL in the public domain in 1990 and applied for IEEE approval, which it gained in 1995. Since 2001, both sides have been working to unify the languages and add new features to address the challenges of next-generation chips.

Although neither the VHDL nor Verilog languages belong to anyone, as such, several EDA vendors do compete to sell the tool that converts engineers' HDL descriptions into working circuit designs. These are essentially translation programs, converting from one language (VHDL or Verilog) to another (circuit schematics). Like any translation program or service, there is fierce competition over nuances of how accurate or efficient those translations might be. Some engineers are interested in the most efficient (i.e., fastest) translation because they plan to do several translations per day. Others might be interested more in performance. In HDL terms, this means translating the original HDL into the fewest number of transistors possible, or something comparable to translating German into dense, terse English. Still other customers might want the opposite: a translator that produces long, flowing passages with lots of footnotes and annotations, corresponding to a circuit that's large and uses lots of transistors but is easy to understand and pick apart for future designs.

Tech Talk

Register-transfer level (RTL) is a generic term that covers both VHDL and Verilog. RTL is not a language; it's a "zoom level" that's not quite as detailed as individual transistors but not quite as high level as a complete chip. It's an intermediate level of detail that works well for today's electronics engineers. Looking at an RTL description (e.g., VHDL or Verilog), a good engineer can divine what a circuit is going to do, but not exactly how it will do it. Like courtroom shorthand, RTL conveys just enough information to get the message across.

Alternate HDLs

VHDL and Verilog are by no means the only HDLs available, although they are clearly the two top players in the HDL market. Because of their age and rapid increases in chip complexity, both languages have begun to crack a little bit under the strain of modern chip design. Some engineers argue that designing a 10-million-transistor chip using VHDL or Verilog is little better than the rubylith methods from the 1970s. These engineers turn to a number of alternative HDLs.

HDLs come and go, but a few that seem to have reached critical mass in the EDA market are Superlog, Handel-C, and SystemC. Superlog, as the name implies, is a pumped-up version of Verilog. It's a superset of the language that adds some higher lever, more abstract features to the language. Superlog allows designers experienced in Verilog to handle larger chip designs without going crazy with details.

Handel-C and SystemC are both examples of a more radical approach to HDLs. These take the heretical stance that, because popular HDLs like Verilog and VHDL are already programming languages, why not use an actual programming language in their place? In other words, they use the C programming language to define hardware as well as software. This has the advantage that millions of programmers already know C programming, and thousands more students learn it every year. Idealistically, it might also help close some of the traditional gap between hardware and software engineers.

The C-into-hardware approach has some philosophical appeal but has met with raucous resistance from precisely the hardware engineers it is meant to entice. Programming languages such as C, BASIC, Java, and the rest were never designed to create—or even adequately describe—hardware, the argument goes, so they would naturally do a terrible job at it. It's like composing love sonnets in Klingon, you might say. Some of the resistance to this approach might just be the natural impulse to protect one's livelihood, or it might really be a terrible idea. Time will tell.

Tech Talk

Even the strongest backers of the C-as-hardware-language movement realize that the original C programming language isn't well suited to the job. They've all added various extensions to the language to help express parallelism, the ability of electronic circuits to perform multiple functions simultaneously, which programming languages like C can't describe. Many have also added "libraries" of common hardware functions so that engineers don't have to create them from scratch. The results clearly do work, but opinions vary widely as to the efficiency and performance of the resulting design.

Producing a Netlist

Whether engineers use schematic capture or an HDL, their input will eventually be translated into something called a netlist. A netlist, or a list of nets, is a tangled list of which electrical circuits are connected to which other circuits. A netlist is generally only readable by a computer; it's too convoluted and condensed to be of any use to a person. The netlist is just an intermediate stop along the way to a new chip.

Floor Planning

After a chip's circuit design is created, it's time to start getting physical. Because the ultimate goal is to produce film, which will then be used to fabricate a chip, there comes a point when the design ceases being an abstract schematic or HDL description and starts to take on a real shape. It's the point where architecture becomes floor planning. In fact, that's what it's called: chip floor planning.

Here a whole new software tool comes out of the engineer's toolbox. A floor-planning program takes the netlist, counts the number of electronic functions and features that are in it, tallies up the wires needed to connect it all, and estimates how much silicon real estate the chip will cover. Naturally, the more complex the chip design, the bigger the chip will be. However, other factors influence the size of the chip, too, such as precisely what company will be manufacturing the chip and how fast it needs to run. (Slow-running chips can sometimes be packed more densely than high-performance chips, saving silicon area and cost.) Many factors affecting a chip's size and shape are hard to predict, even for the engineers who designed it. If a certain portion of the chip needs to connect all the other parts of the chip, all the wires, tiny as they are, will take up space and make the chip bigger.

The real job of the floor-planning program is to find the optimal arrangement for all the parts of the chip. Which circuits should be near which other circuits? What's the best way to shorten the wires? How will electricity be distributed among all the portions of the chip? Are there any sensitive radio receivers or optical sensors on the chip that need to be isolated from other areas? Of course, the floor planner also needs to pack this all into a rectangular (and ideally square) chip design. Square chips fit best on a round silicon wafer, yielding more useful chips per wafer and lowering overall manufacturing costs.

Place and Route

After the chip has been floor-planned (a new verb coined by chip engineers), it's time for the detail work: routing all the tiny wires that connect the chip's various parts. Floor-planning blocks out the rough shape of the chip and organizes its major components. Place and route (sometimes shortened to P&R) works out the messy details of exactly where every transistor, capacitor, wire, and resistor actually goes. It is as detailed a blueprint of the chip as will ever exist. If all goes well, place and route is the last step in designing the chip before its creators hand it off to be manufactured.

Unfortunately, very little often goes well when a chip is placed and routed for the first time. Place and route software is horribly expensive because its task is so difficult. These programs must manage millions of details, all interconnected with one another, and find the optimal physical arrangement of the pieces without disturbing any of the connections among them. Consider the child's puzzle of the three houses and three utilities shown in Figure 3.3.

Figure 3.3. In this classic puzzle, you have to draw lines connecting the three houses (above) with each of the three utility companies (below). The only rule is that you cannot cross over a line you've already drawn.

Can you draw a line from each of the three houses to each of the three utilities without crossing over any line? You can make the lines as long and twisty and roundabout as you like; you just can't cross over any of them. Take a look at Figure 3.4.

Figure 3.4. Here we've partially completed the puzzle, connecting two of the houses. But the third one presents some problems. How to connect the last few lines without crossing another line? This problem is similar to what all chip designers face on a much larger scale.

If you don't solve it after the first few days, don't feel too bad. The task has been mathematically proven to be impossible. To connect all the houses you'd need to change the rules and use two sheets of paper to build "overpasses" over some of your lines. Like freeway overpasses built over roads below them, coming off the paper and working in three dimensions is the only solution to the problem.

Now imagine the same puzzle with 1 million houses and 1 million utilities, and you begin to get an idea of the problem facing place and route programs. They will take hours, and often days, working on the problem of how to connect all the parts of a chip without dropping a single connection or making one wrong connection (crossed lines). They have to do all this while preserving the floor plan generated by the previous EDA tool.

Granted, place and route tools have more than two layers to work with, but the task is still not easy. Typical chips will have from four to seven "metal layers" used for routing wires. Adding more layers would obviously ease the routing congestion, but it also adds cost. Each additional metal layer adds about a day to the processing time for a chip, slowing down the production line. Each layer also adds hundreds of dollars to the cost of each silicon wafer, which must be divided among the chips that are on it. Throwing money (and time) at the problem will solve it, but not in an economically pleasing manner.

What typically happens after the first bout of placing and routing is that the EDA tool figuratively throws up its hands and says it cannot complete the task. There might be too many wire connections and not enough metal layers on which to route them. Or different portions of the chip might be too far apart to connect them efficiently, a sign that the floor-planning software has not done a good job. Furthermore, the engineering team might force some constraints on the place and route program, prohibiting it from routing any wire that would exceed a certain length, for example. In the world of chip design, if the chip successfully passes place and route the first time, you weren't trying hard enough.

The next step depends on the attitude of the engineering team, the company's goals, and the time they feel they have to finish the job. They might resubmit the chip design to the floor-planning tool and hope (or specify) that it gives them different results. They might decide to loosen some of the restrictions they placed on the place and route program. They might decide to spend the extra money on an additional metal layer to ease overcrowding. Or they might go all the way back to the beginning and change some of their original design, eliminating features or connecting them in different ways. Either way, it means repeating some or all of the steps leading up to place and route, and it usually means many sleepless nights bent over a flickering computer screen, waiting for an encouraging result.


Verifying the Design Works

Assuming the chip eventually makes it through place and route in one piece, it would normally be ready to send to the foundry for manufacturing. However, because the cost of tooling up a foundry to make a new chip is so expensive (in the neighborhood of $500,000), it's vitally important that everyone involved in its design convince themselves that there are no remaining bugs. There are few things more expensive—or more damaging to one's career—than a brand new chip that doesn't work, so verifying the design is the last, nail-biting step on the road to silicon.

The enormous costs of chip manufacturing have spawned a subindustry of companies providing tools and tests to verify complex chips without actually building them. The business opportunity for these companies lies in charging only slightly less than the cost of a bad chip.

All these verification tools work by simulating the chip before it's built. As with many things, the quality of the simulation depends on how much you're willing to spend. There are roughly three levels of simulation and some engineering teams make use of all three. Others make do with just the simplest verification, not because they want to but because they can't afford anything more complete.

C Modeling

The first and easiest type of simulation is called C modeling. As you might guess, this consists of writing a computer program in C that attempts to duplicate the features and functions of the chip's hardware design. The holes in this strategy are fairly obvious: If the program isn't really an accurate reflection of the chip design, then it won't accurately reflect any problems, either. This strategy also requires essentially two parallel projects: the actual chip design, and the separate task of writing a program that's as close to the chip as the programmer can make it. The major upside of this approach, and the reason so many engineering teams use it, is its speed. It's quick to compile a C program (a few minutes at most) and it's quick to run one. Within an hour or so, the engineers could have a good idea of whatever shortcomings their chip might have. Many chip-design teams create a new C model every day and run it overnight; the morning's results determine the hardware team's task for the rest of the day.

Tech Talk

There aren't really any commercial C verification tools. That would defeat the purpose. C verification models became popular because they don't require special tools or skills; they're simply standard computer programs that happen to model the behavior of a chip under development. They're written, compiled, and run on entirely normal PCs or workstations. There's nothing specific about the C language that makes it suitable for this technique, by the way. It's simply the most commonly used programming language among engineers.

Going back to HDLs for just a moment, easy verification is one of the strengths of the new C-into-hardware design languages such as SystemC and Handel-C. Because the hardware design is created using C (or a derivative of it) in the first place, it's trivial to use that same C program to verify its operation. This single-source approach also eliminates (or at least, reduces) the problems of matching the C verification model to the actual hardware design.

Hardware Simulation

A significant step up from software simulation of the chip is hardware simulation. Despite the name, hardware simulation doesn't usually require any special hardware. Instead, a computer picks through the original hardware description of the chip (usually written in VHDL or Verilog) and attempts to simulate its behavior. This process is painfully slow but quite accurate. Because it uses the very HDL description that will be used to create the chip, there's no quibbling over the fidelity of the model.

Unfortunately, hardware simulation is so slow that large chips are often simulated in chunks, instead of all at once, and this introduces errors. If there are problems when Part A of the chip communicates with Part B, and these two chunks are simulated separately, the hardware simulator won't find them. The alternatives are to let the simulation run for many days or to buy a faster computer. Regrettably, the larger the chip, the greater the need for accurate simulation, but the longer that simulation will take.

Hardware Emulation Boxes

The non plus ultra of chip verification is an emulator box. This is a relatively large box packed full of reprogrammable logic chips, row after row. (For a more complete description of what these chips are, see Chapter 8, "Essential Guide to Custom and Configurable Chips.") To emulate a new chip under development, you first download the complete netlist of the chip into the emulator box. The box then acts like a (much) larger and (much) slower version of the chip. The advantages of this system are many. First, the emulator is real hardware, not a simulation, so it behaves more or less like the new chip really will. The major exception is speed: Emulator boxes run at less than 1 percent of the speed of a real chip, but that's still much faster than a hardware simulator.

Second, emulator boxes generally emulate an entire chip, not just pieces of it. Naturally, emulating larger chips requires a larger box, and commensurately more expense, but at least it's possible. Because the emulator box is real hardware, you can connect it to other devices in the "real" world outside the box. For example, you can connect an emulated video chip to a real video camera to see how it works. Finally, the emulator can be used and reused at different stages in the chip's development, or even for different chips. In fact, the latter case is often true. Emulator boxes are so expensive that they generally are treated as company resources, shared among departments as the need arises.


Using Outside IP

One of the quickest ways to design a new chip is to not design it at all. Most big new chips include a fair amount of reused, borrowed, licensed, or recycled circuitry; not physically recycled silicon, of course, but recycled design ideas. Like a musician composing new variations on an old theme, it's often better to borrow and adapt than to create from scratch.

In engineering circles this is called design reuse or intellectual property (IP) reuse. IP is a high-sounding name for intangible assets that can be sold, borrowed, or traded. Lawyers use IP to refer to trademarks, logos, musical compositions, software, or nearly anything else that's valuable but insubstantial. Engineers use IP to refer to circuit designs.

Since the mid-1990s there has been a growing market for third-party IP: circuit designs created by an independent engineering company solely for the purpose of selling to other chip designers. As chip designs have grown ever more complex, the demand for this IP has grown and encouraged the supply. There are a few profitable "chip" companies that not only don't have their own factories, they don't even have their own chips. They license partial chip designs to others and collect a royalty.

To makers of large chips, it's an attractive alternative to buy parts of the design from outside IP suppliers. There are dozens of large IP vendors and hundreds of smaller ones. Some IP houses specialize in large (and valuable) types of circuit designs, such as entire 32-bit microprocessors, for which customers gladly pay more than $1 million in licensing fees, plus years of royalties down the road. Many smaller IP firms license their wares for $10,000 or less, sometimes without any royalties at all. There are also sources of free IP on the Internet, just as there are for free software.

Although outside IP is a great boon to productive chip design, it isn't all smooth sailing. First, customers often balk at the prices. Designing a new chip is an expensive undertaking already without paying large additional sums to an outside firm. Then there are technical problems. Outside IP is designed to appeal to the largest possible audience, so it's naturally somewhat generic. Potential customers might be looking for something more specific that outside IP doesn't offer. It's also possible that the IP won't be delivered in a form that the customer can use. If the bulk of the chip is being designed using Verilog, but the IP is delivered in VHDL, it's probably not usable. For IP firms that deliver their products as HDL, there's about a 50 percent chance of getting it wrong.

There's also the usual finger pointing when something goes wrong. If the chip design fails its final verification, does the fault lie with the licensed IP or with the original work surrounding it? Neither side will be eager to admit liability, but the IP vendor's entire business rides on delivering reliable circuitry. Usually these problems have their root in ambiguous or insufficient specifications or a misunderstanding between engineers on either side.

Hard and Soft IP Cores

Among IP vendors and customers, one of the first questions asked is, "Does this IP come in hard or soft form?" What the customer is asking is whether the circuit design will be delivered in a high-level HDL such as Verilog or VHDL, or as an already-synthesized "hard" design ready for manufacturing. There are pros and cons each way, and debate continually simmers over which way is better.

IP that's delivered in "soft" form (i.e., as an HDL description) is generally easier for the customer (the chip-design team) to work with, but it will have all the same drawbacks that all synthesized hardware suffers: larger size, slower speed, and higher cost when it's manufactured. That might be okay, but the customer will have to decide. On the plus side, the HDL is probably easier to integrate into the rest of the chip design, especially if the rest of the chip is also being designed with the same HDL.

IP vendors sometimes don't like to provide their wares in HDL form for two reasons. First, the usual drawbacks of synthesized hardware might make their product look bad. The IP vendor can't guarantee, for example, that its circuit will run at 500 MHz because it can't control the synthesis process. Consequently, the vendor winds up being very conservative and cagey about promising hard performance numbers. Unlike chip companies, IP companies rarely advertise MHz numbers (or power usage) in their literature.

Another aspect of soft IP that gives the vendors headaches is the possibility of piracy and IP theft. Soft IP is like sheet music, in that it's easy to duplicate and to pass copies around to others. As with sheet music, customers are supposed to pay royalties to the copyright holder in that event, but that's a tough law to enforce. Many IP vendors simply do not offer synthesizable IP cores for exactly that reason.

The alternative to soft IP is, of course, hard IP. A "hard" IP product (often called a core) isn't really hard. It's just the same as a soft core after it's been synthesized, placed, and routed. It's film, or the electronic equivalent of film. A hard core is nearly ready for manufacturing: All it needs is to be dropped into the rest of the chip design at the last minute.

There are good and bad aspects to using hard cores. They're generally faster, smaller, and use less power than synthesized soft cores because they've been extensively hand-tuned. For very high-performance or very low-power chips, hard cores are the only way to go. On the other hand, hard cores are much more difficult to incorporate into the rest of the chip, especially if that chip is being synthesized. Essentially, the chip's designers have to leave a rectangular hole in their design that exactly fits the hard core. Then, during the late stages of preparation before manufacturing, the hard core is inserted.

Hard cores prevent the customer's engineers from altering or modifying the core in any way, which is partially the point. IP vendors like delivering hard IP cores because they know their customers won't have access to the "recipe" for the IP. Hard cores also perform better than soft cores, as previously mentioned.

Early IP vendors in the mid-1990s almost always delivered hard IP cores. The trend has moved more toward soft IP in recent years, however. As more and more engineering teams use hardware-synthesis and HDLs for their own chips, they demand the same from their outside IP vendors. IP vendors might cringe because of the performance and security issues that soft IP raises, but the alternative is to lose business.

Various industry groups have looked at ways to protect soft IP by "watermarking" the circuit design or through public-key encryption of the data files, but so far these efforts have produced little. There might not be a need; the industry seems to be self-policing. The larger the customer, the more likely they are to regulate themselves. An infringement scandal in a public corporation would be a huge embarrassment, so they protect their suppliers' products very carefully. Smaller startups are likely to be a bit less conscientious, but they also represent a smaller economic threat to the IP vendor. In the end, an open and thriving IP market shows every sign of taking care of itself.

Physical Libraries

Another form of IP, although a much less glamorous one (if that's possible), is the physical library. These fit in toward the end of a chip's design, as it's being synthesized, placed, and routed. The physical libraries carry the arcane details of the production line that will be used to fabricate the part. As such, these libraries change from one semiconductor manufacturer to another, and often from one building or site to another within the same company. In the later stages of a chip's design, the EDA tools need to know exactly how thick, how wide, and how high each silicon transistor will be, and these characteristics vary slightly from maker to maker.

There used to be a thriving business in supplying these libraries (which are really just big data files) to chip designers, but no more. The foundries and other semiconductor manufacturers wised up to this business opportunity and began supplying libraries of their own. By supplying chip designers with their libraries for free, manufacturers provide a small incentive for a designer to choose that manufacturer. Soon it became de rigueur for any semiconductor manufacturer to supply a free library or risk being excluded when it came time to bid on manufacturing.


Getting to Tape Out and Film

After the design, synthesis, testing, simulation, and verification are all done, the final steps are almost anticlimactic. Once the engineering team is satisfied that the chip design will work, it's simply a matter of pressing a button to tape out the new chip. Far from the old days when each layer of silicon and metal was literally taped out by hand, tape out now consists of a few moments for a computer to produce a file and store it on a CD-ROM. Often engineers will print out these files and hang up the colorful poster-sized prints of the chip's design, but this is done more out of tradition and a sense of camaraderie than for any sound technical reasons.

Film is no longer really film anymore. The file produced by the EDA software is called a GDS-II database, and it takes the place of actual film. Transporting a film box to the foundry is passé; uploading the GDS-II database is as simple as sending an e-mail.


Current Problems and Future Trends

Imagine you're a little kid again, playing with Tinkertoys (or Lego bricks, Lincoln Logs, or Meccano pieces; pick your favorite). You have an eccentric uncle who believes your birthday comes once every 18 months. On each birthday, he gives you a gift of another complete set equal to what you already have. Your store of building blocks therefore doubles every 18 months. This is great fun; you can build bigger, better, and taller things all the time. Before long, you're making toy skyscrapers, and then entire cities.

Surprisingly soon, you run out ideas for things to build. Or, if you're very creative, you run out of time to build them before the next installment of parts is dumped in your lap. You simply can't snap pieces together fast enough to finish a really big project before it's time to start the next one. You have a few choices. You can ignore the new gift and steadfastly finish your current project, thus falling behind your more ambitious friends. Or you can start combining small pieces together into bigger pieces and use them as the building blocks.

So it is with modern chip design. The frequently heard (and often misquoted) Moore's Law provides us with a rich 58 percent compound annual interest rate on our transistor budgets. That's the same as doubling every 18 months. Given that it frequently takes more than 18 months to design a modern chip, chip designers are presented with a daunting challenge: Take the biggest chip the world has ever seen and design something that's twice that big. Do it using today's tools, skills, and personnel, knowing that nobody has ever done it before. When you're finished, rest assured your boss will ask you to do it again. Sisyphus had it easy.

The modern EDA process is running out of steam. Humans are not becoming noticeably more productive, but the tasks they are given (at least, those in the semiconductor engineering professions) get more difficult at a geometric rate. Either the tools have to change or the nature of the task has to be redefined. Otherwise, the Moore's Law treadmill we've come to enjoy for the past 30 years will start slowing down dramatically.

First, let's cover the easy stuff. Faster computers will help run the current EDA tools faster. Faster synthesis, simulation, modeling, and verification will all speed up chip design by a little bit. However, even if computers were to get 58 percent faster every year (they don't), that would only keep pace with the increasing complexity of the chips they're asked to design. At best, we'd be marking time. In reality, chip designers are falling behind.

A change to testing and verification would provide a small boost. The amount of time devoted to this unloved portion of chip design has grown faster than the other tasks. Testing now consumes more than half of some chips' project schedules. To cut this down to size, some companies have strict rules about how circuitry must be designed, in such a way that testing is simplified. Better still, these firms encourage their engineers to reuse as much as possible from previous designs, the assumption being that reused circuitry has already been validated. Unfortunately, reused circuitry has only been validated in a different chip; in new surroundings the same circuit might behave differently.

IP is another angle on the problem. Instead of helping designers design faster, this helps them design less. Reuse, renew, and recycle is the battle cry of many engineering managers. Using outside IP doesn't so much speed design, as it enables more ambitious designs. Engineers tend to design larger and more complex chips than they otherwise might have if they know they don't have to design every single piece of it themselves. Although that makes the resulting chips more powerful and feature-packed, it doesn't shorten the design cycle at all. It just packs more features into the same amount of time.

The most attention is devoted to new design tools. How can we make each individual engineer more productive? The great hope seems to be to make the chip-design tools more abstract or high level, submerging detail and focusing on the overall architecture of a large and complex chip. Many ideas are being tried, from free-form drawing tools that allow an engineer to sketch a rough outline of the design ("from napkin to chip" is one firm's advertising slogan) to procedural languages that an engineer can use to "write" a new chip.

There are two problems with these high-level approaches. For one, giving up detail-level control over a chip's design will necessarily produce sloppier designs that are slower and bulkier, wasting silicon area and power. These are not trends anyone looks forward to. On the other hand, the same Moore's Law that bedevils us also hides our sins: Silicon gets faster all the time, and that increased speed can hide the performance lost through the new tools. It might be a good bargain.

The second problem, and a thornier one to solve, is simple human inertia. People are loath to give up their familiar tools and abandon the professional skills they've developed. For an industry that thrives on the breakneck pace of innovation, ironically, semiconductor engineers drag their feet when it comes to changing and adapting their own profession. Hardware engineers criticize and malign the new software-into-hardware languages partly because using those languages would require skills the hardware engineers don't have and would marginalize the skills they do have. Nobody likes to anticipate the death of his or her own profession. Besides, solving a hardware problem by discarding all the hardware engineers seems a bit counterintuitive.

It's not that today's chip designers aren't trying to help solve the problem. After all, it is they who stand to benefit from whatever breakthrough comes. It's just that nobody knows quite which way to turn. On one hand, gradual evolutions of the current and familiar tools, such as Superlog, can leverage an engineer's skills and experience, but they're only a stopgap measure, buying a few years' grace at most. On the other hand, radically new tools like chip-level abstraction diagrams aren't familiar to anyone and take months or years to learn to use effectively. This would mean discarding years of hard-won experience doing it "the old way."

Each engineer must make his or her own decision, or have it forced on him or her by a supervisor or new employer. Left to themselves, most people will choose the path of gradual evolution. It's less threatening than a complete overhaul and still provides the excitement of learning something (a little bit) new.

With no clear winner and no clear direction to follow, the future of chip design will be determined largely by herd instinct. Engineers will choose what they feel most comfortable with, or what their friends and colleagues seem to be using. Most of all, they want to avoid being left out, choosing a path that will leave them stranded and isolated from the rest of the industry. Macintosh users seem to like this kind of iconoclasm; chip-design engineers dread it.


Chapter 4. How Chips Are Made

In this chapter...

  • Clean Rooms and Fabs

  • Developing Technology: Chips and Photography

  • Silicon Ingots to Start

  • Polishing the Wafer Smooth

  • Building the Layer Cake

  • Laser Surgery: Etching Away the Transistors

  • Step and Repeat

  • Etching Bath

  • Ready for the Metal Round

  • Testing Phase I

  • Bringing out the Diamonds

  • Sorting the Fast From the Merely Good

  • Wrap It Up

  • How Many Nanometers in a Micron?

  • Let' s Get Small

Silicon chips are made in a process that's a combination of the familiar and the bizarre. Some aspects are as familiar as developing a few photographs, whereas others resemble space exploration or subatomic physics. In the end, it's all of these and the process gets stranger and more fascinating the more you learn about it. In this chapter we take a brief tour as a hypothetical chip we've designed makes its two-month journey through a chip factory.

Chips might seem small and flat, but they're really three-dimensional sandwiches 10 or 20 layers thick. It takes more than two dozen steps to build up this silicon sandwich, and plenty of things can go wrong along the way. It's not until near the end, however, that you discover whether the chip is any good or not. Chips destined for the trash can cost just as much to manufacture as those headed for new PCs, so quality control is important, and manufacturing secrets are closely guarded.

Many chip-making companies are well known, and firms like Intel, Motorola, and Texas Instruments get plenty of credit for advancing the industry, but it's really the behind-the-scenes companies that develop the chip-making equipment that deserve the glory. Companies like ASM Lithography, Applied Materials, and Ultratech Stepper (to name just a few) are responsible for moving the semiconductor industry forward at such a rapid pace. To some extent, the Intels of the world are only using the tools they're given. Without these exotic and leading-edge tools, our world of computers, satellite communications, and consumer electronics would not be where it is today, or where it is headed tomorrow.


Clean Rooms and Fabs

Chip factories are called fabs, short for fabrication facilities. A fab looks like a normal two- or three-story office building from the outside. It's the inside that's special. Although most fab buildings do include some normal office space for the employees, most of the interior space is dedicated to one or more "clean rooms." It is inside these clean rooms that chips are made.

The term clean room understates the truth. These rooms are phenomenally, spectacularly, unbelievably clean. The best hospital operating room is filthy in comparison. Clean rooms are from 1,000 times to 10,000 times cleaner and more sanitary than any operating room. They are designed with fanatical attention to details that will keep the entire room immaculate and dust-free. Stainless steel is used everywhere; floors and ceilings are perforated with holes and the air conditioning keeps the air moving through them all the time. Surfaces are sloped and flat tabletops are avoided because they give dust a place to settle. Bright, slightly yellowish lighting prevents mildew from forming in the recessed corners of equipment or behind desks.

Even the workers in a clean room are kept astonishingly spotless. Everybody wears the now familiar "bunny suits," as shown in Figure 4.1. Looking like astronauts, the people working in the clean room are covered from head to toe, walking amid polished chip-making equipment like explorers in a science fiction movie. To enter the clean room you must pass through a series of air lock doors, pass through an "air shower" that blows dust off your clothes, and walk across a sticky floor mat that removes grime from the bottom of your shoes. Suiting up in the stainless steel locker room requires at least 10 minutes. Another pass through the air shower blows any remaining contamination off the outside of the bunny suit. Completely sealed in a bulky suit, helmet, battery pack, gloves, and boots you pass through another set of air lock doors into the clean room. Workers learn to identify each other by their eyes alone.

Figure 4.1. This silicon fab worker wears the puffy all-over "bunny suit" and gloves required in the clean room. He's holding a partially finished silicon wafer at the end of a vacuum wand. Because he's not working in the most sensitive part of the clean room, this worker isn't wearing a completely sealed suit with helmet and facemask. Notice how the countertop is perforated to avoid giving dust a place to settle. Courtesy of Texas Instruments. Used with permission.

Inside, the clean room is quite long and narrow, a bit like a corridor in a submarine. Tall stainless-steel equipment lines each side of the walkway. A constant breeze blows down from the ceiling to the open-grate floor to discourage dust particles from settling on flat surfaces. Occasional windows might let you see some of the offices near the clean room; there are no windows to the outside. Push-to-exit fire doors are to be used in case of dire emergency only.


Developing Technology: Chips and Photography

If you're an amateur photographer, you'll already understand most of what's involved in making silicon chips. The technique is amazingly similar to the process of developing prints from film negatives. In both cases you start with a sharp negative image on film, which is then projected onto light-sensitive paper resting in a bath of special chemicals. You control exposure, light, and the chemicals to produce just the image and effects you want. You can also enlarge or reduce the image, if desired. Once you've made the first print, it's relatively easy to produce several more just like it.

If you substitute silicon for paper, you've got a pretty accurate description of how chips are made, too. It's basically a photographic process, albeit an extremely accurate and precise one. It's so precise, in fact, that all the equipment must be kept 100 times cleaner than a surgeon's instruments and all the people involved in the process wear astronaut-like sealed spacesuits to prevent contamination. Whereas a photographer's darkroom must be kept dark, a chip factory is brightly lit. The "light" used to develop chips is invisible to the human eye.

Unlike a conventional photograph, though, each "print" of a chip is developed from several different film negatives. A typical chip might require 10 or 20 different layers of film. This is where chip making starts to resemble building a layer cake. Every chip is built of layer on layer of silicon, aluminum, and other chemicals stacked on top of each other like a layer cake or a three-dimensional puzzle. Each layer of this tasty product is developed using a separate piece of film.


Silicon Ingots to Start

The first step in making any silicon chip is getting the silicon, of course. Silicon is basically purified sand; it's one of nature's elements and, thankfully, one of the cheapest and most plentiful. For the chemists in the audience, silicon is element 14, right between aluminum and phosphorus on the periodic table of elements. For the nonchemists in the audience, silicon is not the same as silicone, the stuff that lubricates squeaky door hinges or maintains the business of cosmetic surgeons.

Silicon crystals are melted in a vat and purified to 99.9999 percent purity and grown into ingots, long sausage-like cylinders that are heavy and shiny, as shown in Figure 4.2. If you've ever grown sugar or salt crystals in a drinking glass as a science experiment, the process is exactly the same, just done on an industrial scale.

Figure 4.2. This pure silicon ingot is about six inches across and a few feet long. When it's sliced, it will make thousands of silicon wafers, ready for processing. Courtesy of Texas Instruments. Used with permission.

The ingot is cut into very thin slices called wafers, shown in Figure 4.3. Wafers are round, of course, and about as thick as a business card. Wafers come in a few standard sizes, usually 6 inches, 8 inches, or 300 millimeters (just under 12 inches) in diameter. One edge of the otherwise round wafer is traditionally cut off straight. That's partly to help the automated equipment handle the wafer, but also so the people operating the equipment can tell which way is "up." The flat edge also prevents the wafer from turning or spinning as it rests inside some of the equipment.

Figure 4.3. These wafers have been sawed from a solid ingot of silicon. Each wafer is six inches in diameter. One side of each wafer has already been polished smooth. Note the slight flat spot on the outside edge of each wafer to help hold it still during the polishing process. Courtesy of Texas Instruments. Used with permission.
    [ Team LiB ]


Polishing the Wafer Smooth

Before the real work begins, one side of each wafer must be polished absolutely smooth. These wafers will be so smooth after they're finished that you couldn't detect any imperfections on the surface even with a microscope. The process is called chemical-mechanical polishing (CMP). As the name implies, it involves bathing the wafers in special abrasive chemicals and gently grinding any imperfections away.

The wafers need to be smooth and flat because the features that will be projected onto them in the chip "darkroom" are extremely small and close together. In photography, it's important to keep the print lying flat as it develops because any warping or bending will throw the picture out of focus. Each part of the print must be the same distance from the projecting lens, and the principle is the same for chip making. Any variations in the surface of the silicon wafer will make the chip design out of focus, possibly causing shorts and other faults.


Building the Layer Cake

After a wafer is polished, it's time to start building up the layers of material that will become the transistors on our chip. A wafer is pure silicon, but it takes more than silicon to make a chip work. There are the metal wires, of course, but those will be added later. At this stage, we need to build up a few layers of silicon (which conducts electricity) alternating with a few layers of an insulator (which doesn't conduct electricity). These two types of material will be stacked, like layers of frosting between layers of cake. Later, we'll etch away some of this insulator (most of it, actually), leaving a carefully planned-out three-dimensional pattern of silicon and other materials that channel electricity in exactly the paths we want.

Engineers call this layering process deposition because chemicals are deposited on the supersmooth surface of our wafer. Deposition can be done in a couple of different ways. One way is to put the wafer in an oven along with pure oxygen gas and let the oxygen seep into the top of the wafer. (Oxygen doesn't conduct electricity; it is an insulator.) Another way is to spray the chemicals onto the wafer, called chemical vapor deposition (CVD). After we've built up the first layer of our chip, it will look like Figure 4.4.

Figure 4.4. Layers of material are sprayed or deposited on top of the base silicon wafer. Alternating layers of conducting and insulating material are built up. The number of layers depends on the complexity of the chip. After each pair of conducting/insulating layers is put down, some of it is removed to make intricate wires.

After we coat the wafer with insulating chemicals, there comes a second layer of special chemicals, this one called photoresist. Photoresist is like the coating on black-and-white print film before it's been developed. The stuff reacts to light, which we're depending on to make our chips work.


Laser Surgery: Etching Away the Transistors

Once the wafer is coated with photoresist, it's light sensitive and must be kept in the dark so that it doesn't accidentally get "developed" before it's ready. Fortunately for us, the photoresist is sensitive to light we can't see, so there's no need to shut off the lights in the clean room. The wafer still needs to be handled carefully, however, to avoid scratching its delicate and carefully prepared surface.

To develop the wafer, we put it into a machine called a stepper. Usually a robot arm takes a wafer off the top of a stack and places it in the stepper automatically. Mounted just a few inches above the wafer is a copy of the film negative that the chip designers created (which was described in the previous chapter). Engineers call this film the reticle, and it's usually made of quartz instead of normal camera film. Just above the film is a lens and behind that is a bright light. Basically, we're going to project an image of the film down onto our wafer, like projecting slides onto a wall (see Figure 4.5). The only real difference is the scale: The image we project will be tiny, only a fraction of an inch on a side, just big enough to make one copy of our chip.

Figure 4.5. After a few layers have been deposited on the silicon wafer, they're removed using a chemical etching process. Special lights shine through a photographic negative, or mask, onto the chip. The light makes some of the chemicals soft so they can be washed away. The remaining material stays in place and the process is repeated.

The other difference is in the light used in our "slide projector." It's not really light at all, in the usual sense. Human eyes can't see it, for example. Chip images are projected using light that's closer to lasers or x-rays than normal light. (Sometimes they really are x-rays.) The reasons for this are a bit complicated but have to do with wavelengths. Normal light has a tendency to bend around objects, making fuzzy shadows. Look outside and notice how the sun shining through a leafy tree casts slightly fuzzy shadows on the ground. The edges of the shadows aren't sharp. In fact, very thin objects, such as a thread or a spider web, often don't cast shadows at all because sunlight tends to bend around these small objects.

That kind of fuzziness won't work at all for making chips. We need to cast shadows that are razor sharp, especially for small objects because the transistors and wires on our silicon chip are going to be microscopically tiny. Steppers therefore use light sources that are a lot closer to x-ray machines than slide projectors. That's why these basically simple machines are 10 feet high and costs millions of dollars (see Figure 4.6). They are designed and calibrated to the nth degree to project extremely sharp, fine, focused images through the film onto our wafer.

Figure 4.6. This stepper works much like a one-hour photo lab, processing film negatives into pictures. Special laser light passes through several lenses and mirrors before finally striking the polished silicon wafer near the front of the machine. Courtesy of ASML US, Inc. Used with permission.

As the light shines through the film and onto the wafer below, it shines on the photoresist, which reacts to light and starts to harden. After a few moments of this illumination, all the photoresist that was exposed to light has "set up" and made a tough crust on top of our wafer. All the parts of the wafer that were in shadow, however, are still soft, and that's exactly what we want.


Step and Repeat

What good is it to make just one copy of a little chip onto a big wafer? Don't we need to fill the whole wafer with hundreds of copies of the chip? Indeed we do, and that's why these machines are called steppers. After projecting one image onto the wafer long enough for the photoresist to harden, the stepper moves the wafer slightly to the left and projects the image through the reticle again. After that chip is done, the wafer moves over one more position, and again the process is repeated. Like plowing a field from one corner to the other, a stepper passes from left to right, and top to bottom until the entire wafer has been exposed (see Figure 4.7). The entire process takes just a few minutes.

Figure 4.7. This wafer has been through several stages of the stepping and etching processes. The chips inscribed on it are clearly visible, making a grid pattern on the wafer's surface. Later, the wafer will be cut apart with a diamond-tipped saw, separating each of the square chips. Courtesy of Texas Instruments. Used with permission.

Why not use a bigger piece of film and expose the entire wafer at once? Wouldn't it take less time and cost less money to do all the chips in a single exposure? The reason is one of focus. As owners of big-screen TVs know, the sharpness of a picture deteriorates as it gets bigger. Photographers also know that big poster-size prints are blurrier than small 5 x 7 portraits. That's just the nature of photography and light. Steppers can't afford to sacrifice sharpness for speed. Each chip has to be absolutely sharp and perfect. It doesn't make sense to mass-expose an entire wafer if all the chips around the edges will be thrown away.

Amazingly, even the corners of normal chips are a bit blurry. Only the center of the chip is truly in focus. Intel produced an extraordinarily large chip in the early 1990s that was octagonal instead of square. The corners had to be cut off because they would have been too badly out of focus to work.


Etching Bath

Now that the entire wafer has been exposed with dozens of images of our little chip, it's time to use a little chemical wizardry to start cutting away the parts we don't want. If we bathe our wafer in a bath of just the right chemicals, all the soft parts of the photoresist (the parts that weren't exposed to light) will wash away, along with the insulating chemicals that were underneath. The hardened areas of photoresist, however, will protect the insulating material beneath them.

We've photographically carved away part of our layer cake, leaving tiny valleys in exactly the places we want. It's as if we'd taken a very sharp knife and carefully sliced away some parts of the chip, although no surgeon's scalpel is sharp enough (and no hands steady enough) to do this manually (see Figure 4.8). Even robots could not be made skillful enough. Ever since the first days of semiconductor manufacturing, chips have always been made using this photographic process.

Figure 4.8. After the silicon chip and its layers of extra material have been exposed, etched, and washed some material will remain on top, making three-dimensional wires. This process is repeated several times to make interlocking wires several stories high.

This cycle of depositing chemicals, covering the wafer with photoresist, exposing it to light through our film mask, and etching away the unexposed parts gets repeated more than a dozen times. Over and over, we'll build up layers of material in elaborate three-dimensional constructions to create the transistors that make up our chip.


Ready For the Metal Round

Although chips are made of many layers, the transistors are all near the bottom. The upper layers are for the metal connecting wires. That means the size of a chip is determined mostly by the number of transistors it has, not by the amount of wiring it requires. That's what pushes semiconductor manufacturers to constantly shrink the size of their transistors: The smaller the transistor, the smaller the chip (or the more transistors you can fit on a same-sized chip). The smaller the chip, the more you can fit on a wafer. The more chips on a wafer, the more you can sell for the same amount of work. Moore's Law is just good old capitalism at work.

After the transistors are built up on our chip, it will go through the same process several more times to build up the "metal layers." These are the copper or aluminum wires that connect the transistors together. The amount of wiring depends on the complexity of the chip. (Remember the houses-and-utilities puzzle from Chapter 3, "How Chips Are Designed"?) Some chips might have only three or four layers of wiring; complex chips might have eight or more.

The process of applying metal is the same as for the other layers that were put on earlier. First, the entire wafer is covered with an insulating material that runs into all the cracks and grooves of the chip (it won't be smooth anymore). Then a thin layer of metal, either aluminum or copper, is applied on top of that. Finally, a layer of photoresist covers the metal.

Tech Talk

Around 1996, the whole process of using copper wiring in chips got a lot of coverage in the press. It's not clear why this happened, because this abstruse facet of chip manufacturing was of little interest to the general public and of even less interest to those in the industry, who had known about it for some time. Copper certainly makes a better electrical conductor than does aluminum, as any electrician or homeowner will confirm.

The major reason copper wasn't adopted sooner was cost. Although chips use a tiny amount of copper, the billions of chips produced each year add up to a significant drain on this limited resource. Gold is an even better conductor than copper, and perhaps future "designer chips" will flaunt their gold wiring.

Now the wafer goes under another stepper with a different piece of film. Again the stepper exposes the photoresist, and again it sets up and protects the metal we just applied. After it's washed away, the net result is that some of the metal remains, although most of it will be eaten away, leaving very thin metal lines or wires. Depending on which company is making the chip, there might be gaps underneath the metal wires. Other companies use a slightly different process that leaves material under the wires for support.

This process will be repeated several more times, each time building up another layer of metal wires atop the previous layer. Each layer of this elaborate cake is separated by a layer of insulating material so that wires crossing over each other don't touch and short out.


Testing Phase I

After several passes through the deposition-expose-etch-repeat process, our chip is finished! It takes, on average, 20 to 30 individual steps to finish a chip of medium complexity. By this time, the chip has been in production for several weeks and has passed through dozens of people's hands and almost as many robotic handlers. In short, an enormous amount of expensive time and effort has been expended to produce this wafer full of chips. Now it's time to see how many of them actually work.

When a new fab is built, it's a sad reality that practically all of the chips it produces for the first few weeks will probably be bad. Hundreds of wafers will be processed, representing thousands of chips, and not one of them will work. Over time, the production yield will improve, but it's usually not until a fab has been operating nonstop for more than a year that production yields will surpass 90 percent. Some fabs never do; for whatever reasons, they will always throw out 20 percent or more of everything they produce.

One of the reasons for this high "mortality rate" is contamination in the clean rooms. A new fab necessarily has some dust left over and it takes time for the air filters and extractors to scrub the atmosphere in the clean room to the extraordinary levels required. Also, the new equipment needs to literally settle in to the new building. Minor shifts in the floor or walls as the building's foundation settles can wreak havoc on the sensitive steppers and other equipment. Companies have been known to reroute foot traffic around clean rooms to avoid upsetting sensitive equipment with heavy footsteps. Oddly, some equipment just never seems to acclimate; sometimes replacing a finicky machine is the only option.

For a variety of economic reasons, it's important for chip companies to test each chip as early as possible in its life span. The sooner you can identify a bad chip, the sooner you can stop spending money on it. The first step in this process is called wafer probing. While all the chips are still together side-by-side on a single wafer, the entire wafer is put under a tester. Like a mechanical spider, the tester lowers several delicate wire legs and places them gently on the edges of a chip. It applies a voltage and tests the chip's reaction. Does everything turn on and off when it's supposed to? Does the chip respond quickly enough, or perhaps too quickly? Any behavior out of the ordinary probably signals a fault and a chip that's doomed to the dustbin. Faulty, or even suspect, chips are quickly marked with a tiny dot of red paint. Later on they'll be cut away from their siblings and discarded. This is the source of many high-tech lapel pins, tie tacks, and paperweights.


Bringing Out the Diamonds

Assuming that at least some chips pass inspection and the entire wafer isn't bad, all the chips will be cut apart using a diamond-bladed saw. The stepper leaves a bit of space between each chip as it moves left to right and top to bottom. This blank area allows the saw to carefully cut in between the chips without damaging them. The diamond saw is very thin, as you might imagine, and is designed to kick up a minimum of "silicon sawdust." Contaminating an entire wafer at this late stage would be economically unpleasant.

After the chips are cut apart, the good chips are sorted from the bad chips by a robot that searches for the tell-tale red dot. Also, the cut-off fringes of the round wafer are discarded like high-tech cookie dough. Unfortunately, this material can't be recycled because it's been too heavily treated, exposed, and processed to be of any use as a raw material.

Chips that have been cut apart are called die. One chip is one die but several chips together are also called die, not dice. There's no particularly good reason for this grammatical inconsistency.


Sorting the Fast from the Merely Good

Once each chip is tested to see if it's functional, it'll often be tested again to see exactly how fast it is. Natural (although unwelcome) variations in manufacturing will make some chips work slightly faster than others. If the difference is significant (say, 20 percent faster) and if the numbers of these overachieving chips are also significant (about 20 percent or more) then it's probably worthwhile to sell them at a premium price. For highly profitable microprocessor chips for PCs and other computers, this extra financial gravy can be more than $100 per chip.

Other times, it's not worth the trouble to sort the chips by speed. If a good chip sells for only $1.25, a fast one is unlikely to command a premium of much more than 25 cents. For that amount, it's more cost-effective to skip the testing and sell all the parts at the same price. This means some enterprising customers or technicians might be able to discover a few chips in their monthly shipment that are faster than advertised, but that's for them to discover.

Even when faster than average chips do carry a price premium, chip companies will intentionally avoid selling them as such for marketing reasons. Early in a chip's product life, there might be relatively few that make the faster speed cut. Later on, as the manufacturing process matures and the yield improves, there might actually be too many faster parts. The chip maker can arbitrarily limit the number of such parts to, say, 15 percent of the total product offering to maintain the aura of exclusivity surrounding the higher priced part. Technically astute PC hobbyists call this "overclocking." They will test their computer's chips at home to see what the upper limit of performance is, fine-tuning their PC to extract the maximum possible performance from each chip. Half of the appeal is appearing to cheat the chip maker out of a few extra dollars.


Wrap it Up

Eventually each chip needs to be wrapped up in a package so it can be handled and shipped without damage. Most chips are housed in plastic packages that look like little black houses. (Chips are universally black; it's traditional.) The bare silicon is not simply dipped in melted plastic or sprayed with a covering because that would damage the delicate device. Instead, they're packaged clamshell style, as shown in Figure 4.9. First the chip is laid in the lower half of a plastic package, usually on a spot of glue to hold it still; then the upper half of the package is cemented to the bottom. A hollow cavity in the middle leaves room for the chip and avoids crushing it.

Figure 4.9. This plastic package contains one silicon chip. The chip is buried inside the plastic for protection. The seam along the edge shows where the two parts of the plastic package were sealed together. The eight metal "legs" lead to tiny wires that connect to the chip's own wiring. Courtesy of National Semiconductor Corporation. Used with permission.

Finally, the outside of the package is marked with some lettering, one or two identifying part numbers, a date code that indicates when the chip was manufactured, and, if there's enough room, a company logo. The lettering is usually just stamped on with ink, but large chips are sometimes marked with a laser that burns the letters onto the outside of the package. This latter process is fascinating to watch and makes good promotional video footage for the companies that use it.

After the chips are packaged, they'll be completely tested once again. A few chips are damaged during packaging so it's important to make one last check to be sure everything's in order. If any chips fail at this point, they're just thrown in the trash.

A few chips never get packaged. Some very high-volume customers prefer to receive their chips "naked." These are called known-good die (KGD). If a customer prefers to work with KGD it's usually because they're combining several bare chips together into something called a multichip module (MCM). MCMs are like chip apartment houses: several chips sharing a single package. An MCM package is comparatively large, about the size of a matchbox. Usually military contractors or aerospace companies build MCMs because they can pack the chips very densely together and shield the entire assembly against radiation, such as a spacecraft might encounter in orbit.


How Many Nanometers in a Micron?

It's hard to overhear any discussion of chip manufacturing for more than a few minutes without hearing about microns or nanometers. (Okay, it's hard to listen to any discussion of chip manufacturing at all, but that's not the issue here.) These two terms describe exactly how small the transistors and metal wires on a chip are. For clean room workers and manufacturing technicians, microns and nanometers are everything.

Both terms are simply measurements. In fact, they're measurements of the same thing. One micron is exactly one one-millionth of a meter (0.000001 meter). For fans of English measurement, that's about 25,000 microns to the inch (see Figure 4.10). For comparison, a human hair is about 50 microns thick, so we're talking about very small measurements here.

Figure 4.10. Silicon transistors can be made as big as you wish, but smaller transistors are usually the goal. A 90-nanometer transistor is barely three one-millionths of an inch across. That's about twice the size of a virus but smaller than a bacteria, smoke particle, human hair, or grain of sand. Single atoms measure about a quarter nanometer across, so today's transistors are only about 400 atoms thick.

Yet a micron is a vast distance to a chip manufacturer. Individual transistors are smaller than a single micron across, and have been since the early 1990s. Starting around 2001, manufacturers started producing the first transistors that were smaller than one-tenth of a micron (0.1 micron), leading to some tongue-twisting dimensions, even for engineers. So rather than continue to speak in fractions of a micron, silicon engineers began using the next smallest unit of measure, the nanometer.

A nanometer is one one-billionth of a meter (0.00000001 meter), or 1,000 times smaller than a micron. For comparison, a single hydrogen atom is only about 0.25 nanometers across (assuming one can measure these things). Amazing as it seems, we are rapidly approaching a time when the thickness of these materials will be measured by counting their atoms.


Let' s Get Small

What exactly are these engineers measuring with their very small rulers? They measure something they call effective length, often abbreviated Leff in engineering lingo. Broadly speaking, the effective length is the thickness of the thinnest thing that can be manufactured reliably. Effective length depends very much on the maturity of the fab and its equipment, the experience of the technicians in the clean room, the company's tolerance for risk versus aggressiveness, and the amount of money it's willing to invest in the process. The best (i.e., the smallest) effective length achievable varies from company to company, and even from fab to fab within a company. Some large companies operate a few fabs on the cutting edge of current technology while keeping a few other fabs one half-step back, running at more conservative dimensions. This allows them to produce both very fast chips (with risky yield profiles) and very reliable chips (with commensurately higher yields).

The state of the art in fab technology moves in distinct jumps every few years. In years past, the best companies were producing 0.25-micron transistors. Then these companies made a change to 0.18-micron processes, more or less all at once. Following the 0.18-micron generation came the 0.13-micron generation, and so on. The reason these firms—competitors all—adopted the same technology simultaneously is that they bought it from the same suppliers. With very few exceptions, chip manufacturers don't make their own chip-making equipment; they buy it on the open market. The situation is not dissimilar to warring countries buying weapons from the same small group of arms merchants.

The number of these silicon merchants is shrinking. It gets harder and harder to develop machines that can produce finer and finer slivers of silicon. Indeed, many well-informed industry observers predicted that we'd never get this far. Serious technical obstacles reared their heads in past years that threatened to put a stop to Moore's Law and halt the continual rate of improvement we've come to take for granted. Yet each time, semiconductor equipment suppliers have found more elaborate (and expensive) solutions to these problems. However, the staggering cost of research and development into these technologies weeds out a few suppliers at each process generation. Now former competitors are cooperating, sharing the multibillion-dollar development costs of reaching the next step in semiconductor evolution.

A big part of the challenge is finding sources of light with short wavelengths that are bright and strong enough to resolve small, sharp images into a wafer. As the effective length of film features gets smaller and smaller, it's harder and harder to project a sharp image onto a wafer's photoresist. Every process shrink, from 0.18 micron (180 nanometers), to 0.13 micron (130 nanometers), to 90 nanometers, and so on, makes projecting accurate images tougher. The light tends to bend around the microscopically small features on the film, blurring the image and ruining the chip.

Equipment makers have been experimenting with exotic-sounding techniques like i-beam lithography, e-beam epitaxy, x-ray sources, and extreme ultraviolet (EUV) lithography. Each approach has its pros and cons, and researchers are likely to develop at least two into working equipment. Despite the recurring cries of Chicken Little, the sky appears to stay firmly above the heads of the developers of this vital technology.


Chapter 5. Business and Markets

In this chapter...

  • Worldwide Production of Semiconductors

  • Worldwide Consumption of Semiconductors

  • Military Electronics

  • The Business of Making Semiconductors

Processed silicon is more valuable than gold, ounce for ounce.

The gross national product of the United States was $9.2 trillion in 2000; semiconductors accounted for $204 billion, or about 2.2 percent of that total. Semiconductor manufacturing is a bigger part of the U.S. economy than mining, communications, utilities, or agriculture, forestry, and fishing. The U.S. Bureau of Labor Statistics says 284,000 Americans are directly employed in the semiconductor industry; 52,000 of those are semiconductor processors, or people in the so-called "bunny suits."

The top 10 U.S. airlines put together made only half as much money as semiconductor makers. Intel and Texas Instruments sold more than Coca-Cola and Pepsi. Every one of the 15 corporations receiving the most patents in 2000 was in the semiconductor or computer business. San Jose, California—the capital of Silicon Valley—led the nation in highest average annual salary in 2000, outdistancing the second-ranked city (San Francisco) by a hefty 28 percent margin. Most important, the average Nintendo game has more computer power than NASA had for its moon landings.

Tech Talk

In 2001, there were about 60 million transistors built for every man, woman, and child on Earth. By 2010, the number should be close to 1 billion transistors per person.


Worldwide Production of Semiconductors

Excepting the annus horribilis of 2001, the worldwide market for semiconductors recently passed $200 billion per year. That's about the same as the national output of Saudi Arabia or Switzerland. Figure 5.1 shows month-by-month sales of semiconductors for 312 consecutive months (26 years), from the beginning of 1976 through the end of 2001. Note that these are monthly, not yearly, figures, so sales have been in the range of $10 billion to $15 billion per month—or $400 million per day—for several years.

Figure 5.1. Monthly sales of semiconductors worldwide (in thousands). Courtesy of World Semiconductor Trade Statistics. Used with permission.

Figure 5.2 shows the same data graphed yearly, so the vertical scale is 10 times higher. Although some years have been volatile, the overall growth in semiconductors is evident, and has been averaging about 15 percent compounded growth per year.

Figure 5.2. Annual sales of semiconductors worldwide (in thousands). Courtesy of World Semiconductor Trade Statistics. Used with permission.

Sales by Revenue

The year 2001 saw the worst downturn in the comparatively brief history of the industry, with total revenue falling by an astounding 32 percent from the previous year's level of over $204 billion. Memory chips led the decline, with sales falling by half, but all sectors suffered.

In good years and in bad, the proportion of revenue contributed by each type of component remains about the same. Microprocessors, microcontrollers, digital signal processors (DSPs), and peripheral chips account for about one-third of the total revenue (but not of the total unit volume). The next largest contributor to vendors' coffers is memory. DRAMs, SRAMs, and ROMs of all types account for 20 percent to 25 percent of the revenue share. Analog components and miscellaneous digital-logic devices each contribute 15 percent to 17 percent to the total. Discrete components, such as resistors and capacitors, and optoelectronic components, such as LEDs and optical sensors, both make single-digit contributions. These segments are summarized in Figure 5.3. Bear in mind that, barring the first few years of the 21st century, every percentage point represents about $2 billion in revenue. That's not small potatoes.

Figure 5.3. Total financial contribution by type of semiconductor. Courtesy of World Semiconductor Trade Statistics. Used with permission.

Sales by Unit

Using data from 2001 as our yardstick, the huge majority of unit sales are in discrete components. Like the insects of the semiconductor realm, these tiny devices are almost invisible, even to industry insiders. At an astounding 200 billion units per year, it's clear that diodes, transistors, rectifiers, and the like are ubiquitous. (See Figure 5.4.)

Figure 5.4. Total unit volume contribution by type of semiconductor. Courtesy of World Semiconductor Trade Statistics. Used with permission.

Next up, but almost an order of magnitude lower in unit sales, are the analog components. Analog amplifiers, D/A and A/D converters, voltage regulators, and numerous other nondigital components make up this category.

Optoelectronics are not far behind their analog cousins, including LEDs, laser diodes, CCD image sensors, and other things that light up. The majority of optoelectronic components are used in consumer electronics, making up the LED displays of alarm clocks, the laser diodes of CD players, and the "film" of digital cameras.

Miscellaneous digital logic components take fourth place. This category includes low-end logic chips such as AND gates and OR gates, but also much higher value devices such as programmable logic (CPLDs and FPGAs) and custom ASIC chips. These latter chips tend to be expensive so they give the logic segment a bigger slice of the revenue pie than they do of the unit-volume pie.

It's interesting that the number of microprocessors and microcontrollers sold is not much lower than the number of memory chips. Because every microprocessor typically requires several memory chips as "support" components, you'd expect this ratio to be more lopsided. Yet the number of chips in the CPU and DSP category is only about 20 percent smaller than the number of memory chips. In part, this is because the microprocessor category also includes some peripheral controllers, which aren't really microprocessors and don't require external memory chips. Many low-end microprocessors and microcontrollers have some memory of their own built in, so they often don't need extra memory chips, either. The high volume of these one-chip microcontrollers balances out the relatively few high-end microprocessors that need lots of extra memory.

Taking another big jump down the volume chart, we see the sensors. This category includes silicon acceleration sensors for automobile airbags, temperature sensors used in cars and industrial applications, magnetic sensors, and other specialized chips.

Bringing up the rear are the so-called bipolar components. Bipolar components aren't really a separate category from sensors, microprocessors, and so forth, but they are manufactured using a different process than all the other devices we've covered. Market research usually classifies them separately for that reason. As you can see, there are very few bipolar components made or sold, and their numbers are dwindling slowly.

Average Selling Prices

The average selling price (ASP) of a class of components can be both useful and misleading. It is useful because it gives us an idea of what the high-value components are and where the most value is being added. It is misleading because the statistics group many different types of components together, and not all chips within each category have similar selling prices. The mix of components can significantly skew the perception of the value of an entire segment.

Having said all that, the discrete components clearly have the lowest ASP, at about $0.06 per device. Some components, such as microwave or radio frequency (RF) transistors, raise this average while low-value components, such as diodes and rectifiers, lower it. Still, when discrete components account for nearly half of the unit volume but only about 8 percent of the revenue, you know you're dealing with inexpensive parts.

Optoelectronics are the only other major category of components with ASPs under half a dollar, at $0.37. Bipolar components and sensors both hover at about $0.50 each. Then there's a modest $0.75 for analog components, as Figure 5.5 shows.

Figure 5.5. Average selling price by major category of semiconductor. Courtesy of World Semiconductor Trade Statistics. Used with permission.

Large-scale digital chips clearly command a price premium. Part of this is perception and part is actual component cost. Some large-scale digital chips, such as FPGAs and ASICs, have huge development costs that must be amortized across comparatively few components. Other logic devices in this same category, such as individual logic gates, are commodities, sold almost by the pound. Overall, this category commands an ASP of $1.50.

Although memory chips are sometimes characterized as the semiconductor commodity, their prices suggest otherwise. The ASP for all memory chips in 2001 was $3.25, a fair number, but one that is very volatile. Because so many memory chips are interchangeable and demand is so cyclical, price competition is ferocious. Memory production might be unconscionably profitable one year and diabolically costly the next. Each downturn tends to shake out one or two memory vendors, slowly reducing their ranks.

At the top of the pricing chain are, of course, the microprocessors. Intel didn't get to its exalted position by making commodity components. Intel's well-known PC processors account for an increasingly small proportion of total microprocessor unit sales, but its success nonetheless pumps up the average for the whole category. The only thing preventing the $6.12 ASP from being contaminated by this anomaly is the enormous unit volume of the other components.

Average Microprocessor Prices

The ASP for microprocessors and related components is so lopsided that it warrants further examination. The data in Table 5.1 are once again taken from the World Semiconductor Trade Statistics (WSTS) organization for the calendar year 2001. Although overall semiconductor sales were badly depressed in that year, the ratio of ASPs and the relationship among components is the same in any year.

In Table 5.1, the top line (32-bit microprocessors) represents only a few vendors' components. Specifically, it is overwhelmingly Intel's latest generation Pentium processors used in PCs. This segment also includes AMD's PC-compatible processors and the PowerPC processors made by Motorola and IBM, primarily for Apple's Macintosh computers. Macintosh commands about a 4 percent market share of desktop computers compared to 95 percent for the "Wintel" PC, so the unit volume (and hence, the ASP) is comparatively unaffected by Macs.

Table 5.1. The average selling price for microprocessors, microcontrollers, and DSPs varies considerably. The top-end PC processors skew the ASP for the category with their abnormally high prices. Courtesy of World Semiconductor Trade Statistics. Used with permission.

Device Type

Average Selling Price

Microprocessor, 32-bit

$92.89

Microprocessor, 16-bit

$6.87

Microprocessor, 8-bit

$3.72

Microcontroller, 32-bit

$7.57

Microcontroller, 16-bit

$4.23

Microcontroller, 8-bit

$1.44

Microcontroller, 4-bit

$0.78

Peripherals

$6.08

Digital signal processor (DSP)

$6.44

Average price for category

$6.12

Other desktop computers, such as engineering workstations from Sun Microsystems, Silicon Graphics (SGI), Hewlett-Packard, and others merely represent rounding errors in this segment. Their unit volumes are "in the noise margin," as electrical engineers might say. As proud as these computer companies are of their high-end microprocessor technology, those processors have next to no effect on the economy of semiconductors.

With an ASP fully 13 times higher than the average for the rest of the category—which is itself the highest in the semiconductor industry—it's no wonder that Intel attracts so many imitators. Intel's processors are difficult to clone because of their aging, baroque design. Indeed, it's very likely Intel itself would have abandoned the product line years ago had not IBM serendipitously chosen it for its first IBM PC back in 1981. Intel's Pentium family has succeeded completely in spite of its technology, not because of it.

Geographic Breakdown of Production

For geographic and political purposes, semiconductor manufacturing is generally divided into four major regions: North America, Europe, Japan, and Asia and the Pacific region, as shown in Figure 5.6. Roughly speaking, production is evenly divided among these four areas, with North America (mostly the United States) maintaining a slight lead. Throughout the late 1980s and 1990s and into the following decade, the United States produced a little more than 30 percent of the world's semiconductors (measured by revenue), with the other three regions each accounting for about 20 percent to 24 percent of the total. During those two decades, Japan's share of production eroded gradually, losing ground mostly to vendors in Taiwan, Korea, and Singapore.

Figure 5.6. Percentage of production by geographic region, 1982–2000. Courtesy of World Semiconductor Trade Statistics. Used with permission.

Because these statistics measure revenue and not units, they're skewed toward higher priced parts. Thus, the United States is somewhat overrepresented because of its preponderance of microprocessor companies. Texas Instruments, Motorola, Intel, AMD, and the dozens of other microprocessor, DSP, and microcontroller companies based in the United States contribute revenue out of proportion to their impact in simple unit volume.

The United States consumes most of its own chips, swallowing three-quarters of its domestic production. Table 5.2 shows that Europe and the Far East show somewhat less provincialism, but Japan keeps a generous 82 percent of its chips within its borders.

The European and Far Eastern regions both ship about half of their semiconductors to the United States. The exception again is Japan, which gets only about 20 percent of its revenue from North American customers; the rest stays in the country.

Table 5.2. Average consum ption of domestic semiconductor production, 1992–2000. Courtesy of World Semiconductor Trade Statistics. Used with permission.

Region

Percent

Asia

28%

Europe

30%

Japan

82%

North America

74%

If we examine the data from the demand side, shown in Figure 5.7, North America buys about half of the world's production of semiconductors. Japanese consumption dropped in the late 1990s because of the country's economic recession, whereas other Far Eastern and European countries increased consumption slightly. The rise of the Asia and Pacific region vendors' percentage of consumption was not merely a statistical side effect of the Japanese reduction. These countries really did purchase more chips on an absolute revenue basis, not simply in relation to Japan's shrinking share.

Figure 5.7. Consumption of semiconductors by geographic region, 1982–2000. Courtesy of World Semiconductor Trade Statistics. Used with permission.
    [ Team LiB ]


Worldwide Consumption of Semiconductors

Where do all these chips, laser diodes, and sensors go? They end up in quite a few places, as you might imagine, and some that you probably can't. Semiconductors are used in many different kinds of systems, from the obvious ones like computers and televisions, to the obscure ones like dog collars, telephone wiring, and greeting cards. Here we'll take a look at some of the major categories, as shown in Figure 5.8.

Figure 5.8. Relative consumption of semiconductors by industry. Courtesy of In-Stat. Used with permission.

Computers and PCs

First and foremost among consumers of semiconductors are computers. Computers are almost all semiconductors, with a little metal or plastic wrapped around the outside. A 30-pound bag of electronics would not be an inappropriate description of the average PC. Because we're measuring consumption by revenue, not units, PCs are even more heavily represented in the total because of their expensive main microprocessor. PCs also have a lot of memory chips, the second-most expensive class of semiconductors. All this makes PC sales a good proxy for semiconductor sales, at least in that segment.

Tech Talk

Processor Pricing Battles

For years, AMD and Intel have battled over the PC-processor business. Intel has always commanded the lion's share of the market, yet AMD's chips are sometimes considered technically superior and are almost always cheaper. How can AMD build its chips so inexpensively, and why don't customers flock to the less expensive processors?

To answer the first question, it's important to understand that price and cost are not the same thing. They're only loosely related. Both Intel and AMD sell their PC processors for far more than they cost to make. Like perfume and luxury cars, the cost of the materials and labor is almost irrelevant. The price is set by market conditions, not by cost overhead.

The second question hinges on the small part the processor plays in the total PC price structure. Mainstream PCs generally sell for around $800 and laptop computers can easily be priced at double that amount. The cost of the microprocessor is only a small part of the cost of building a whole PC. A suicidal competitor could give its chips away for free, but the complete PC would only be about $35 less expensive, not enough to sway most customers.

Enter brand-name marketing. It's fair to say that most people buying a PC don't have the faintest idea of how they work or what all the specifications mean. This is the perfect environment for marketing tactics to flower. Years of "Intel Inside" ad campaigns never mentioned anything about the chip's technical features. They were pure brand-awareness ploys, imprinting a particular brand name on a largely na [image] ve public. Microprocessors are now sold like perfume.

It also explains why PCs are so price competitive. Virtually no PC makers also make chips. (IBM is one of the exceptions.) That means PC makers have to buy their chips from the same semiconductor vendors that are also supplying their competitors. Volume discounts are about the only concession PC makers can wring out of chip makers. With little value to add other than the color of the plastic box, PC makers fight for every penny, which depends on keeping their volumes up. The advantage to consumers is that prices keep going down as chips get cheaper and PC makers struggle to remain competitive.

Communications and Networking

After PCs, communications equipment is the biggest consumer of electronics. For our purposes, communications means telephones and telephone equipment, computer networking, cellular phones and their infrastructure, and anything to do with satellites, television, and radio transmissions (although not the TVs and radios themselves). This segment has been growing rapidly for a number of years. The actual percentage you hear depends on whom you ask and when you ask them. It dips and rises with market conditions, of course, as telephone companies and network companies first invest, then retrench, depending on regulatory and market conditions.

Networking equipment consumes high-end microprocessors and DSP chips, lots and lots of memory, and special-purpose communications chips developed especially for one or two customers. Network and telephone companies also buy lots of laser diodes and optical sensors for their fiber-optic networks. Cellular telephone makers consume vast quantities of DSP and microcontroller chips—there's typically one of each in every cell phone—as well as mountains of tiny RF components such as resistors, capacitors, and inductors.

Consumer Electronics

Consumer electronics gives communications systems a good run for the money, consuming about one-fifth of all the world's semiconductor value. Consumer items can be televisions, DVD players, electronic toys, and also "white goods" such as refrigerators, washers, and dryers, all of which now include microcontrollers to mange power consumption and add exotic features.

Tech Talk

Running Rings Around Sega Saturn

In the late 1990s one of the most popular home video game consoles was Sega's Saturn. The Saturn was an extraordinary system in many ways. The system was so advanced and high-end that, ironically, it led to Saturn's collapse and Sega's eventual withdrawal from the hardware market.

Saturn had no fewer than four 32-bit microprocessors, three from Hitachi and one from Motorola. These were partnered with six custom-designed ASIC chips and several megabytes of memory. The entire system was considerably more complex than the average PC of its day. It was so complex, in fact, that most game programmers couldn't exploit its features well. Under pressure to meet deadlines, most game programmers took shortcuts and used only one or two of Saturn's four processors. Although many Saturn games were good, few flexed its considerable hardware muscle. After it cratered, Saturn left a vacancy for Microsoft's Xbox and Sony's PlayStation 2.

Home video games are a big consumer of electronics in the home. Nintendo, Sony, and Microsoft (and Sega, Atari, and Commodore before them) have all created very high-end computers that sell for very little money. In fact, these companies sell their game consoles at a loss. A new PlayStation 2, for example, might cost Sony $350 or more to manufacture, yet sells for $200 to $300 when new. Sony makes up the money on game (software) sales. Unlike PC software, PlayStation software must be officially licensed and "approved" by Sony, and royalties apply. (The same is true for other game consoles.) In this razor-and-blade business model, the game console is merely an enticement for consumers to buy games. Each game brings in a royalty of a few dollars to the maker of the console, in this case, Sony. Over the life of the console, Sony will make more than enough money from software royalties to offset the cost of effectively taping a $100 bill to every PlayStation.

The problems with this business model are obvious, yet the concept itself is a very old one. If game players don't buy enough games, the game maker loses money. The break-even point for most video game systems comes after consumers buy three to five titles. That makes it a safe bet, as statistics show that most video game owners buy more than a dozen games over the useful life of the system.

The second problem is that of deferred revenue versus instant gratification. The game maker must spend the money up front to manufacture and market millions of game consoles, generating a huge financial loss. Only after several months have passed will software royalties begin to make up these losses. Companies must have deep pockets, or very patient investors, to enter the video game market.

Finally, the entire scheme hinges on licensed software. There must be no "shareware" game titles, no pirated or copied games, and no independent or unlicensed game developers. In short, it needs to be the exact opposite of the PC software industry. To prevent this, game consoles include obscure and undocumented hardware features that independent programmers are unlikely to figure out. Officially approved and licensed programmers, however, are taught the secrets of the system in return for a licensing fee and a promise to pay royalties on every game they sell. In some cases (e.g., Sony's original PlayStation), the game CDs themselves are mastered and duplicated by the game manufacturer, which brings in additional revenue and helps control inventory. As a last resort, video game manufacturers can exert legal pressure on unlicensed programmers producing "rogue" software that doesn't generate royalties.

Industrial Electronics

The industrial uses of semiconductors are many and varied. Chips show up in robots, vision-inspection systems, alarms and security systems, and power generators, to name but a few. Large, expensive, high-powered semiconductors are used in dams, nuclear plants, and oil plants to regulate and control the electricity these plants generate.

Robots are full of electronics, of course. Heavy industrial robots have a half-dozen motors to move their joints, and each motor is usually controlled by its own miniature computer. Then there's one main computer (the robot's "head") that controls all of these. Heavy robots are amazing for their ability to pick up and move heavy loads, then set them down accurately to within fractions of an inch. That kind of accuracy calls for some exotic mathematics, called kinematics, to predict how and when the robot arm needs to speed up and slow down. This is all handled by low-cost microprocessor chips, along with dozens of memory chips, communications chips (for talking to other robots on the assembly line), and high-voltage chips to power the whole thing.

Robots with vision systems combine CCD image sensors with more miniature computers to analyze what they see. Some robots are nothing but vision systems, with no moving arms at all. Either way, these electronic eyeballs can look at parts moving by on a conveyor belt and instantly recognize any flawed or damaged ones. Other robots can then throw the bad pieces into the trash. Robots can also sort and straighten scattered parts so they're all turned the same way in nice, neat rows, making the job easier for the next robot down the assembly line. Robots with vision can assemble anything from vacuum cleaners to chocolates. A popular brand of sandwich cookie is made by robots that deliberately assemble the two halves slightly off-center, to make the cookies look handmade.

Automotive Electronics

The semiconductor content of automobiles has been growing steadily for years and shows little sign of abating. The average new automobile now carries about $200 worth of electronics, including almost a dozen microprocessors or microcontrollers. Large, late-model luxury cars can have well over 60 microprocessors. Some electronics are added for safety (collision-avoidance detectors, airbags, night vision), some for comfort or entertainment (in-dash CD players, electrically adjustable seats, air conditioning), and some to just run the car, replacing older mechanical designs (electronic ignition, antilock brakes, or automatic transmission). That doesn't even include the bits that actually look like computers, such as satellite-guided navigation systems and rear-seat movie players.

The electronic systems in cars are starting to communicate and interact in unusual ways. For example, in some cars the electronics controlling the position of the side-view mirrors communicates with the electronics in the automatic transmission. Why? So the mirrors will automatically tilt down and inward whenever you put the car into reverse, the better for you to see the rear of your car while backing up.

Other cars connect the in-dash radio or CD player to the antilock brakes. This seemingly bizarre combination allows the radio to adjust its volume automatically to compensate for road speed. (The antilock brake system has the best gauge of current road speed.) Cars fitted with satellite navigation systems and cellular telephones often connect these two systems together with the airbag controller. The purpose is to detect whether the car is involved in an accident serious enough to deploy the airbags. If so, the car automatically phones for emergency services and, using the satellite navigation system, transmits the exact location of the accident. Often this system is tied to a fourth system, unlocking the car doors automatically.


Military Electronics

Military spending on semiconductors is relatively small, given the popular view about overspending on development and procurement. On the other hand, military procurement departments tend to be conservative in their use of new technology, often waiting several years before replacing mechanical devices with electronic ones or adopting new components over older ones. Ostensibly, this avoids teething problems with raw, untried technologies. In fact, it's sometimes counterproductive because older parts might be nearly obsolete or have undesirable features that are improved in newer chips. Since the 1980s, the U.S. military has made a concerted effort to avoid custom, one-off, and expensive "military specials" and stick to commercial, off-the-shelf (COTS) components wherever possible.

What semiconductors the military does buy can be excruciatingly expensive. Depending on the intended application, chips might have to undergo rigorous testing to prove their immunity to extremely high and low temperatures, dampness, harsh vibration, radio interference, and even nuclear radiation. So-called "rad hard" chips must be able to operate in space (for satellites) or in battlefield conditions (for weapons). Military-grade chips must be housed in special ceramic packages rather than the traditional, low-cost plastic. Semiconductor vendors supplying the military must often guarantee that the same exact parts, with no updates, modifications, or changes whatsoever, will remain in production for many years. In this fast-moving industry, that requirement alone drives up costs considerably.


The Business of Making Semiconductors

Semiconductor manufacturing is a multibillion-dollar business with hundreds of suppliers, large and small, playing their part. From raw silicon in one end to finished product out the other, every chip passes through a dozen different corporate hands. Nothing is small scale and even the smallest niches in the supply chain are multimillion-dollar markets employing thousands of people.

Some segments of the industry are labor intensive and have been gradually moving from country to country as taxes, wage rates, and educational levels change and shift. Others are capital intensive and tend to stay centered in industrialized countries. Copyrights, patents, and intellectual property laws also affect what business is best carried out where.

Semiconductor Food Chain

Like any big industry, the business of designing, making, and selling semiconductors has several steps and a lot of middlemen. The big all-under-one-roof manufacturers like Intel are fairly rare. Most of the world's big chip makers use outside contractors for some of their business, whereas some small (and not-so-small) chip companies don't manufacture anything at all.

Figure 5.9 provides a simplified illustration of how the entire semiconductor "food chain" works for a number of representative companies. The diagram flows from left to right and includes some of the interrelated players. It doesn't include the chip-design phase, which was covered in Chapter 3, "How Chips Are Designed." At this point, we're assuming that the chip design is finished and ready to go.

Figure 5.9. Chips can be manufactured in-house, by a fab partner, or by an independent foundry. In any case, the owner of the fab has to buy equipment and chemicals on the open market, and the final product will be sold through independent sales channels.

Independent Device Manufacturer

The simplest example is also the most well known. Intel is an example of an independent device manufacturer (IDM). Nearly everything about Intel's chips is done in-house. Its processors are designed by Intel engineering employees, they're manufactured on Intel's own fabs, and the chips are sold, obviously, under Intel's name. The only part that Intel outsources is the actual stocking, warehousing, and distribution of its chips. A worldwide network of independent third-party companies handles this final link in the value chain.

Fabless Chip Company

In our second example, IBM operates just like Intel does. IBM employees design the chips and IBM employees manufacture them using IBM's own factories. The chips are sold with IBM's name and logo on them. Where IBM differs from Intel is that IBM also makes chips for other companies. IBM rents out its factories to a select group of companies that do not own a fab. These "fabless" customers rely on IBM and companies like it to build their chips for them.

Xilinx is an example of a fabless chip company. Xilinx designs and sells its own FPGAs but doesn't actually build them. For years, Xilinx has used IBM (and a few other companies) to build its FPGA chips. The chips are labeled with Xilinx's name and logo and appear to be Xilinx-made chips. IBM only provides a service; the company can't sell Xilinx's chips, nor can it make any extra ones for its own use.

Pure-Play Foundries

Our third example is simply Brand X, a fabless chip company that uses a foundry instead of another chip company to manufacture its chips. Foundries are simply independently owned fabs, and they are covered in more detail near the end of this chapter. Unlike the Intel and IBM examples, foundries don't make any chips of their own; they simply provide manufacturing services to their clients. Part of a foundry's business is to keep all of its clients separate and anonymous. It's also a delicate juggling act to balance the production needs of several clients that are all demanding parts at once. TSMC is an example of a foundry, the largest one in Taiwan.

Materials In, Distributors Out

All chip companies share some things in common, regardless of which of these three business models they follow. Fabs and foundries need to buy their manufacturing tools and equipment from outside vendors. Whether it's Intel, IBM, or TSMC, they all buy their heavy equipment from a variety of American, European, and Asian tool suppliers. Likewise, all the manufacturers buy their chemicals and other consumable items from an assortment of competitive vendors.

Finally, few of the major chip companies actually sells its own chips. Instead, they refer the task to a components distributor or a manufacturers' representative firm, or both. Reps and disties, as they're often called, are the front-line sales force for almost all chip makers around the world. Like automobile dealers, they can carry more than one product line as long as those lines aren't directly competitive (i.e., Intel and AMD for microprocessors). Distributors tend to be bigger companies that deal in a greater volume of parts, and they specialize in quick delivery time and razor-thin margins. Rep firms, on the other hand, tend to be component "boutiques," representing smaller companies with esoteric or specialized chips. Manufacturers' reps always represent more than one company's products, and often more than a dozen, so avoiding conflicts of interest is a lot tougher.

Facilities and Equipment

Semiconductor manufacturing is a hugely capital-intensive business, right up there with steel mills, space programs, and automobile manufacturing. Erecting a new chip factory costs more than $1 billion, and it'll be obsolete in less than five years. The stakes are very high indeed, and national pride is often at stake. Labor costs add to the overhead, and shipping costs can be considerable if the plant is not located in the same country as its customers.

Even a back-of-the-napkin analysis shows that, with a startup cost of over $1 billion and a useful life of only a few years, you'd need to depreciate a mind-boggling $500,000 to $1 million per day. Let's hope you're manufacturing something the world wants!

Part of the cost of building a fab is, of course, the building itself (see Figure 5.10). Fabs might be as small as 50,000 square feet (4,500 square meters) or as large as 1 million square feet (90,000 square meters). They can be built almost anywhere because they don't require much in the way of natural resources. Lots of open space, stable soil, and solid bedrock are the most important factors, making the preponderance of fabs in California's Silicon Valley seem a little incongruous. A stable foundation is the most important thing because chip-making equipment is very delicate and sensitive to vibrations. Imagine a Swiss watchmaker trying to work on a wobbling Alpine train and you get the idea. These machines have to be kept very still.

Figure 5.10. This fab, or chip factory, looks like most fabs around the world. The large flat windowless building in the background houses the clean rooms where chips are actually produced. Other buildings contain offices and chemical storage. Fabs are always built low to the ground to give the delicate equipment a steady base to work on. Courtesy of Texas Instruments. Used with permission.

Tradition keeps a lot of fabs in California. Crowded, expensive, and prone to earthquakes, the Santa Clara Valley would seem the worst place to build a fab, and geologically speaking it is. However, this area is the sentimental heart of the semiconductor industry, the location of most companies' headquarters, and source of trained talent and graduate students. Most new fabs are now built elsewhere, but many of the industry's early fabs are still running at full capacity in the heart of Silicon Valley.

Construction firms specialize in building fabs and clean rooms. A fab looks like a conventional office building, and much of it is. Most of the workers will have their offices on the ground floor. The clean rooms will be on the upper floor, mounted on rubber shock absorbers, literally suspended in the middle of the building. Rubber bumpers and springs isolate the sensitive equipment from earth tremors and even from the disruptive footsteps of the workers downstairs. (For more on how chips are made in a clean room, turn to Chapter 4, "How Chips Are Made.")

It costs about $3,500 per square foot to build a clean room, versus $175 per square foot for the office space in the rest of the building. Annual maintenance costs per square foot are also higher for the clean room, because of the need to keep the air filters and other high-maintenance equipment in top condition.

Because fabs require lots of space but little in the way of natural resources (other than educated labor), they tend to be located near, but just outside of, major cities. Fabs employ thousands of well-trained and well-paid people who contribute to the local economy, making them desirable commercial neighbors. Finally, fabs are relatively clean industrial installations that require only a supply of fresh water and a way to contain the hazardous chemicals used in manufacturing.

Governments and municipalities quickly zeroed in on these positive aspects of the business and routinely offer compelling tax incentives for semiconductor companies to locate new fabs in their jurisdiction. Roads and water supplies are put in and even new universities are constructed to provide a ready supply of skilled labor. The government of Arizona was a particularly attentive suitor in the 1990s, which explains why so many fabs are located around the cities of Scottsdale and Phoenix. The governments of Ireland and Scotland were similarly generous, offering five- and 10-year tax waivers for companies that would build a fab on their shores and employ their citizens. Only now are some companies paying local, state, or national taxes on the business coming from facilities that were built in the early 1990s.

Manufacturing Equipment

Once the fab is built, it's time to outfit it with equipment. In the early days of the semiconductor industry, all the major players used to build their own equipment. Fairchild, Texas Instruments, Motorola, and others all designed their own manufacturing equipment on one floor, then dragged it upstairs to make chips. Nowadays, semiconductor-manufacturing equipment is a multibillion-dollar commercial industry in its own right.

The necessary equipment can be purchased from a number of different companies based in Japan, Europe, and the United States. Chief among these are Applied Materials, Tokyo Electron Limited (TEL), Nikon, KLA-Tencor, ASM Lithography, Teradyne, Lam Research, Canon, and a dozen others. Applied Materials of Santa Clara, California, has been the market leader in recent years, as Figure 5.11 shows. Before the industry downturn in 2001, the top 10 semiconductor-equipment manufacturers collected a total of $29.3 billion. That's about 14 percent of the size of the semiconductor market itself in that year ($204 billion), or more than all the DRAM makers combined. It's sometimes wiser to be the one supplying the picks and shovels than to be standing in the creek panning for gold.

Figure 5.11. Top 10 semiconductor-manufacturing equipment suppliers, by 2000 revenue. Courtesy of VLSI Research, Inc. Used with permission.

It's common for companies to build a new fab and then outfit only half of the building or less with manufacturing equipment. That's pretty normal for heavy manufacturing businesses; the first shovel of dirt is the most expensive part. After that, it's just capital expenditure.

There are currently about 1,000 working fabs around the world in a dozen different countries. Most of these are different from one another, although large companies such as Intel prefer to build identical facilities in separate locations. This strategy, which Intel calls "copy exact," allows the company to increase, reduce, or shift production of its components based on market demand or in the event of a plant failure.

It takes about 18 months to build and outfit a new fab, so planning ahead is crucial. Given that semiconductor product cycles and trends can shift suddenly and abruptly in just a few weeks or months, companies take a big gamble when they commit to a new fab. One billion dollars and a year or so later, it might turn out to have been a bad bet.

Fab Utilization

The most expensive thing in the world is a chip-making plant running at less than full capacity. Fabs depreciate at an alarming rate. If that manufacturing capacity isn't utilized while it's still valuable, the money sunk into building the fab is lost.

Figure 5.12 shows a snapshot of IC fab utilization worldwide for 12 quarters (three years) from the end of 1999 through mid-2002. Not surprisingly, utilization fell off in 2001 as vendors cut back production to meet diminishing demand. Unfortunately for them, their rent didn't decrease and the equipment didn't stop depreciating during that time. They merely invested $1 billion dollars in a fab that only produced two-thirds of the chips originally forecast.

Figure 5.12. The utilization for the world's fabs has seen ups and downs over the past few years. Courtesy of World Semiconductor Trade Statistics. Used with permission.

Nowhere is the urgency to run at full production more apparent than for DRAMs. DRAMs are nearly commodities, produced in huge volumes, technically interchangeable, and very price competitive. Maintaining tolerable profit margins depends on economies of scale. With only a few pennies' profit per chip (in normal times), every little bit of volume or percentage point of market share can make a big difference. The DRAM market is also very elastic: As prices go down, demand goes up. Furthermore, the efficiency of the DRAM manufacturing process depends largely on experience and volume. The more DRAMs you make, the better you get at it.

When you combine the financial risk of building and running a fab with the volatility and narrow profit margins of DRAMs, you conjure up the recipe for a seriously precarious business, and so it is with DRAMs. DRAM prices cycle up and down with such regularity that market researchers serenely predict downturns seven years in advance, and with some accuracy. Every boom-and-bust cycle shakes out a few DRAM manufacturers, and the survivors close ranks. If a DRAM company misjudges its manufacturing capacity by a few percentage points or is a few months late in bringing out the next new chip, its business might collapse in the next downturn. There are fewer DRAM makers today than there were five years ago, and fewer still than there were five years before that.

Microprocessor makers sometimes face the opposite problem. Microprocessor chips can be very profitable (sometimes more than $100 per chip), but there's a limited demand for them at any given price. Rather than optimize their fabs to run at 100 percent of capacity, microprocessor makers want to ensure they have some excess capacity in case demand suddenly surges. The opportunity cost lost by misjudging demand (and abdicating market share to a competitor) encourages CPU makers to keep a little fab capacity in reserve.

Full capacity means different things at different fabs. Not all fabs are created equal and some can process more wafers than others. For a new, high-capacity fab, 50,000 wafers per month is a good production target. Using this as a yardstick, Figure 5.13 shows how reducing production increases the cost per wafer. This is because fabs are fixed-cost assets where amortization of the equipment and the building don't change with volume. Although material costs might fall, and labor might be reduced a little bit, these are relatively minor expenses next to maintaining the fab itself. For a top-of-the-line fab processing 300-mm wafers, as much as 50 percent of the production cost is depreciation on the equipment.

Figure 5.13. Cost penalty for low wafer runs (normalized to 50,000 wafers per month). Courtesy of IC Knowledge. Used with permission.

Because of this, a semiconductor vendor's profit margins closely track utilization of its fabs. Graphing overall average utilization versus overall average profit margins for the world's semiconductor makers over the period of 1978 to 1995 (Figure 5.14), we see a strong correlation between the two. The break-even point comes at about 50 percent utilization; below that, companies lose money as their investment in their fabs evaporates.

Figure 5.14. Profit margins as a function of fab utilization. Courtesy of IC Knowledge. Used with permission.

Silicon Cost Model

Part of the cost of producing chips is, of course, the silicon itself, although not as much as you might think. There are a great many chips in which the silicon is actually the cheapest part. The plastic package sometimes outweighs the silicon it houses in the financial balance.

Let's look at an example of a medium-sized chip to see the factors that affect its cost. Figure 5.15 shows materials and processes that contribute to the $10.37 cost of manufacturing our chip. Our example chip measures 50 mm2 (about 7 mm, or a quarter of an inch, on a side), which is about the size of a pencil eraser. The number of transistors in the chip isn't relevant, but let's say it has about 8 million. The chip is manufactured in the United States (which is relevant) on 200-mm (8-inch) wafers using a 0.25-micron, four-layer metal process.

Figure 5.15. Cost factors contributing to die manufacturing cost. This example is a 50-mm2 chip built using 0.25-micron, four-layer-metal CMOS process on 200-mm wafers. Overhead and amortization of the fab is not included.

Bear in mind that our cost model does not include any of the overhead costs for the fab previously mentioned (depreciation, electricity, water, maintenance, etc.), nor does it include the cost of labor, photomasks, or consumable chemicals. We're only considering actual material costs for now.

Wafer Cost

For our example chip, the biggest material cost is the silicon wafer itself. The going rate for a 200-mm silicon wafer suitable for our purposes is about $3,100. (This is fully burdened and partially processed, factors that we'll ignore from here on.) If we were to use a more modern or aggressive process, say, 0.13-micron or 0.09-micron, the wafer would be more expensive. If we needed more than four layers of metal wiring to connect our 8 million transistors together, the wafer would be more expensive still. Finally, if we wanted to use copper instead of aluminum on any of the metal layers, the cost of the wafer would probably double. Naturally, going the other way and using smaller wafers and coarser design geometry could cut the cost of the wafer by half, or even less.

Figure 5.16 breaks down the worldwide market for semiconductor materials, including silicon wafers. Again using our benchmark year of 2000, this was a $16 billion market in raw materials and various hazardous chemicals. This is about half as much revenue as the equipment makers collected in that year, or about 8 percent of what the semiconductor makers themselves raked in.

Figure 5.16. Breakdown of the $16 billion market for semiconductor raw materials for 2000. Courtesy of Semiconductor Equipment and Materials International. Used with permission.

Because 47 percent of the raw materials market, or $7.5 billion, was for the magic stuff itself, let's take a quick look at who supplies the silicon to Silicon Valley and the rest of the world. Figure 5.17 breaks down the processed-silicon market, including the top vendors' market shares in 2000.

Figure 5.17. Processed silicon suppliers, 2000. Courtesy of World Semiconductor Trade Statistics. Used with permission.

Looking at the top half-dozen suppliers of silicon—the very stuff of modern technology and the basis of so much world industry—are any of the names familiar to you? Not even one? Don't feel bad, because these are companies that only a chemical engineer could love. Although they fulfill a vital role in the modern economy, they're largely unknown and unsung.

Gross Die per Wafer

Chip cost is basically the cost of processing the silicon wafer divided by the number of chips on the wafer, minus the cost of any chips that don't work—and there are always chips that don't work. Naturally, you want to get as many chips as possible from each wafer, but this isn't always easy. Chips are square (or rectangular) and wafers are round, so fitting them isn't easy. Here we need to call on some obscure mathematics called packaging theory. For any shape and size of chip, there is an ideal way to arrange them on a circular wafer to get the greatest number of chips.

You'll notice that around the edges of the wafer in Figure 5.18 there are some chips that go off the edge. Obviously these chips are no good, but it's easier for the equipment to put them there anyway. Sometimes engineers probe or measure these partial chips just to see how well the manufacturing equipment is working at the edge of the wafer.

Figure 5.18. A completely processed wafer makes dozens or hundreds of finished chips, all exactly the same. Courtesy of Texas Instruments. Used with permission.

Our example chip is square (as opposed to rectangular) so, without getting into the mathematics, we discover we can fit 575 whole chips onto a 200-mm wafer. Dozens more will overlap the edges but we won't count those because they'll be cut off and discarded.

Defects and Yield

Not every one of our 575 chips is likely to work after all is said and done. There will inevitably be some slight manufacturing defects here and there. Tiny particles of dust in the cleanest of clean rooms can settle on a wafer during processing and ruin some of the chips. Some particles stick and some can be dusted off, although at this microscopic scale, just the "impact" of a dust particle landing on the wafer usually craters the chip in question. Imperfections in the processing chemicals also cause defects, with contaminated water being a major culprit. Contaminated in this case means ultrapure water that has a few stray molecules of something other than hydrogen and oxygen. Every step in the complicated manufacturing process adds to the risk of contamination as stray particles are stirred up while the chip passes through each piece of equipment.

The ratio of good chips to bad chips is called the yield and it's never 100 percent. Chip companies very closely guard their actual yield numbers the way poker players guard their cards and for the same reason: They don't want to give competitors any inside information. Anything less than 100 percent yield is embarrassing, but every company knows that goal is impossible. Yields of 85 percent to about 97 percent are typical for midrange and high-end ICs. Simple chips will enjoy higher yields, whereas new or complex chips will have embarrassingly low yields.

The yield depends on two things: the defect density and the die area. The defect density is the average number of contaminating particles that land on every square centimeter of silicon. The fewer and farther apart these particles are, the better. Defect density is like the scatter pattern of a shotgun; die area is the size of the target.

Defect densities for good, clean, mature processes can range from 0.05/cm2 to 0.20/cm2. In the early stages of production, these figures will be much higher. As the equipment "settles in" and the production staff gains experience, the defect density goes down over time. Changing air filters in the fab can also make a difference.

Big chips make bigger targets, so their yield rate is lower. Also, some chips are more resistant to defects than others. For example, almost any defect on a microprocessor, DSP, or logic chip will ruin it. Memory chips, on the other hand, are designed with redundant memory cells for exactly this reason. If a few cells get damaged during manufacturing, alternate memory cells are used in their place. So although dust particles don't deliberately seek out logic chips and avoid memory chips, memory chips seem more immune to contamination because of their redundant nature.

Big chips are a big financial risk. Assuming dust and contaminants scatter themselves randomly over the wafer, and assuming there are more than a few particles to go around, it's likely that nearly every big chip will get hit with some contaminant or another. Intuitively, this makes sense. If the entire wafer were nothing but one big chip, it would definitely be ruined. If the wafer was covered with zillions of tiny chips, most of them could dodge the barrage. Figure 5.19 shows how this could happen. The bigger the chip, the worse the yield is going to be, making large chips disproportionately expensive to manufacture.

Figure 5.19. With the same pattern of defects on two identical wafers, larger chips are disproportionately affected by contaminants.

Yields generally improve dramatically over time, if you define dramatically as a 5 percent improvement. Experience counts for a lot in this business and process technicians spend agonizing hours and sacks of their employers' money to improve yields by 1 percent. For the first few days after a new fab comes online, virtually all of the chips are a total loss. It takes time for the heavy equipment to settle in, and for the environment to cleanse itself. Little details here and there can affect yield, and nothing escapes the process engineers' scrutiny. Four to six months into production, yields should be nearly optimal.

Getting back to our example chip, our 0.25-micron fab processes have a defect density of 0.50 defects per cm2 (pretty average) and the effective area of the chip is 85 percent, meaning 15 percent of the chip is not completely covered with transistors and therefore relatively insensitive to flaws. According to something called Dingwall's equation, we can expect about 81 percent of our chips to work. Another 19 percent, alas, won't make it out the door as working chips.

An 81 percent yield leaves us with 465 good chips out of 575 total chips on the wafer. The other 110 chips can be made into tie tacks or ground into sparkly scrap. Dividing the $3,100 cost of the wafer by the 465 good chips, we come up with a cost of $6.67 per chip. However, we're not done.

Packaging and Testing

At this point, our example chip is still just a bare square of silicon. We know it works but it's not ready to sell. We'll put this chip into a plastic housing that costs about $2.00 in volume. The labor to attach the bare chip to a lead frame (a collection of wires) and encapsulate it in plastic adds another $0.50 of cost. There are a number of package types we can choose from, and our customers might be very picky about the package they prefer. Small-outline, surface-mount packages have become very popular, as the statistics in Figure 5.20 show. Fortunately, these small-outline packages are among the cheapest. Packages made out of ceramic, such as the pin-grid array, are expensive in comparison to plastic, sometimes eclipsing the cost of the silicon itself.

Figure 5.20. The small-outline packages are by far the most common and are also among the cheapest. Courtesy of IC Knowledge. Used with permission.

Now our chip must be tested one last time before we ship it to a customer or a distributor. After all the handling and packaging, a few chips will fail their final test. Some might have been zapped by static electricity because a technician walked across a carpet or combed his or her hair. Some chips will be overly sensitive to heat and fail during the plastic encapsulation process. Others might work fine at slow speeds but do funny things at full speed. In this last case, we have the option of marking the chips down and selling them at a discount or scrapping them completely. Testing itself adds $1.00 to our cost (mostly labor), and the fallout from testing effectively adds $0.20 to each remaining part. At the end of the day, we've spent $10.37 to produce one chip.

Economics of Updating Fabs

Semiconductor fabs depreciate rapidly and the state of the art is never so for long. Top-end chip makers have to commit to getting on, and staying on, an as tonishingly expensive treadmill. Leading-edge production equipment is hideously expensive and needs to be upgraded or replaced every year or so. For major segments of the semiconductor market, there is no other way to stay in business. It's said that driving racecars for a living is like standing in a wind tunnel tearing up $100 bills. Making chips for a living is like buying a new Boeing 747 every week.

For some high-end chips like microprocessors, nothing but the very best will do. Nobody wants to buy a slow PC. These fabs need to be kept at the cutting edge of fabrication technology all the time. Falling behind your competitor, even for a few months, might doom all the chips your fab produces to the scrap bin, or they might become key chains, given away to bored attendees at the next trade show.

It isn't always so stressful, however. There are plenty of other types of chips that don't have to be particularly fast or especially advanced. In fact, most of the world's chips are built in relatively pedestrian semiconductor technologies that are one or two steps behind the current state of the art (e.g., making 150-nanometer transistors when 90-nanometer technology is the latest thing). Plenty of chips are built on fab lines that are a few generations behind the curve. Old fabs don't spontaneously explode or fall into the soil when they get out of date, but they don't necessarily get cheaper, either.

There are good reasons why companies want to leave older fabs in place, and good reasons why they wouldn't. It all depends on the segments of the market they are trying to serve. On the one hand, keeping an older fab in production makes perfect sense. It gives a company more time to amortize the crushing cost of building it. Maybe they won't be able to build leading-edge chips anymore, but the world buys lots of cheap and slow chips, too. Instead of making ultrafast microprocessors, the company could shift production to standard logic parts, and then to diodes and LEDs, and finally, to resistors. With this strategy, they could keep a fab running at full capacity for many years. As the depreciation overhead decreased, so would the need to wring profit from each component, which is good, because it's the leading-edge components that generate the most profits.

Although this strategy works well for a while, it is inherently self-defeating. By neglecting (or refusing) to upgrade a fab, a company is doomed to ride it into the ground. Eventually even the best process technology becomes so old that nothing it produces is saleable. Buggy whips, no matter how cheaply produced, just aren't in demand.

It is better to upgrade the fab at regular intervals, despite the expense. Paradoxically, this can be cheaper than letting it go. Newer process technologies inevitably shrink chip features, which reduces die size. A smaller die means more chips per wafer. More chips per wafer means more product to sell from the same amount of silicon. It is thus better to process 1,000 tiny chips than 350 larger ones. At the same time, each chip will get faster (because it's smaller) and more power-efficient (ditto). Whether these characteristics are valuable to your end market is irrelevant; you still get more chips per wafer than before. If you can charge extra for the smaller, faster, low-power chips, so much the better.

Economics of Larger Wafers

Semiconductor wafers have grown steadily in size over time, from the little 2-inch wafers of a few decades ago to the comparatively monstrous pizza-sized 300-mm (12-inch) wafers used in some high-end fabs today. By 2002, there were a few dozen fabs processing 300-mm wafers.

Apart from being more expensive in and of themselves, large wafers are more expensive to process. Like developing photographs into poster-sized prints, processing large wafers requires plenty of large-sized equipment. In a fab, nearly every piece of equipment at every stage of manufacturing has to be completely replaced to handle the new platters. What possible economic incentive is there to go through this trouble?

It's almost always more profitable to use the biggest wafers possible, that's why. There are direct and indirect effects that make bigger wafers appealing. First, the number of chips you can fit on a wafer increases with the square of its radius. In other words, 300-mm wafers don't just hold more chips; they hold a lot more chips. All other things being equal, a 200-mm wafer can produce 266 chips at 100 mm2 apiece, but a 300-mm wafer can hold 630 chips, well over twice as many chips for the same amount of work.

Second, the manufacturing equipment for 300-mm wafers is all brand new so it includes all the latest gadgets and gizmos for improving production efficiency. Transistor geometry gets smaller on the newer equipment, so more transistors fit on a chip, making each chip smaller. Much of the same effect could be had by replacing or refurbishing existing equipment, but if you're going to spend the money anyway, why not spend it on equipment that handles larger wafers, too? In effect, the ability to handle finer geometries on 300-mm equipment comes almost for free. Finer geometry means smaller chips, multiplying the beneficial effect of the larger wafer.

The cumulative effect of all this will increase the overhead burden, but will actually reduce the overhead burden per chip. Amortizing all the new fab equipment will still be a crushing burden, but you'll have a lot more chips—and more competitive chips—with which to do this.

Economic Summary

Semiconductor manufacturing suffers from an odd economic condition that other industries don't share. Almost all the cost of producing a chip comes from fixed overhead, specifically in the depreciation of the fab and its equipment. Unlike boats or telephones, the incremental cost of producing each chip is almost nothing. The very first chip out the door is extraordinarily expensive. After that, the next million chips are practically free.

The only other industry that compares to this is, coincidentally, software. Most of the cost is in development; the cost of delivering software is almost zero. Music distribution and movie making come close, but there are some material costs (and enormous marketing costs) associated with those businesses. The strange economics of chip production puts direct pressure on manufacturers to increase volume. Depreciation directly burdens every chip; the more chips they make, the smaller the burden per chip. Producing twice as many chips means you can sell them for half the price.

The grimmer side of this equation means that slow-selling chips carry an enormous cost burden. Chip makers have to think long and hard before committing to produce a new chip. They can't afford to take too long, though, or the market might pass them by.

The ever-increasing cost to build a fab might mean that fewer and fewer companies each year will be able to afford this luxury. The alternative is not to fold the tent and leave the semiconductor industry; it's to outsource production to an independent foundry. Foundries are becoming an increasingly important part of the semiconductor production chain. The number of companies building their own fabs is slowly collapsing; with each new technology generation fewer and fewer companies are able to invest the capital required.

Separating the fabrication business from the design business leads to a horizontal segmentation of the industry. Chip companies become design-and-marketing companies, outsourcing their actual production to foundries. Further down the road, some firms might become just marketing companies. Already there are firms that do only chip design, with no fabrication or marketing.

The rising cost of fabs and the shrinking number of companies operating them will consolidate the number of "recipes" for making advanced silicon. Chip manufacturing will become more alike, almost generic. Companies will no longer be able to compete on the same basis they used to. Silicon speed and performance will be the same, if they all use the same third-party foundry. That will move the emphasis to marketing, where it already is for more mature products like cars and microwave ovens.

For 30 years the semiconductor market grew an average of 14.8 percent per year, from about $800 million in 1970 to $200 billion in 2000. Naturally, there were some good years and some bad years, but the overall trend was remarkably constant. During those same 30 years the cost of semiconductor capital equipment rose by 16.3 percent per year, a bit faster than the growth in sales. This means that spending on capital equipment grew from being 17 percent of a company's sales back in 1980 to a heftier 22 percent of sales in 2000. This ratio also fluctuates from year to year, going as high as 34 percent in 1996 to as low as 16 percent just three years later.

Yet paradoxically the cost of the chips themselves keeps falling. Each year sees higher productivity and better technology that more than make up for the spiraling cost of producing new chips. Chips are getting cheaper faster than they're getting more expensive.

If you're in the business of selling chips, though, you don't want them to get cheaper. To keep up profit margins, chip makers continually design more elaborate and expensive chips. By constantly moving up-market, chip makers neatly offset the inexorable trends moving them down-market. The result is that consumers keep getting more and more features for the same amount of money. There are few products in the world you can say that about.

If you focus on a few arbitrary units of semiconductor production—one transistor, 1 million bits of memory, one MIPS of microprocessor performance, or whatever—and measure it over time, you'll see that the cost to make that unit has been falling at an exponential rate. As Figure 5.21 shows, the cost per unit function of semiconductor falls faster than the cost of semiconductor capital equipment rises.

Figure 5.21. The cost to manufacture a unit function of semiconductors falls faster than the cost of semiconductor equipment rises. Courtesy of IC Knowledge. Used with permission.

How do semiconductor makers reduce their costs so rapidly? There's no one silver bullet; it's a number of related technologies. Figure 5.22 shows the cumulative effect of larger wafers, finer process geometry, improvements in yield (lower defect density), and various other factors that drive down the cost to make a chip. Wafer sizes aren't increasing as often as they used to, so this effect is slowing down. On the other hand, process geometries shrink more frequently than they used to, neatly making up the difference.

Figure 5.22. Sources of the ever-declining cost of price-per-function. Courtesy of IC Knowledge. Used with permission.

This overall trend is popularly known as Moore's Law, the observation that we seem to be able to double the number of transistors packed into a given amount of silicon every 18 months. A two times return in 18 months works out to nearly 59 percent annual percentage rate: not a bad investment at all.

This is good news for manufacturers but even better news for consumers. The price (as opposed to the cost) for a unit function of semiconductor falls an average of 35 percent per year. Producing the same chip year after year will produce a steadily diminishing return on investment, so chip makers relentlessly improve their products. They add features to shore up the steadily shrinking die size, and then raise prices to cover the new features. In the end, consumers get more silicon goodness for their dollar.

For all-electronic products such as PCs and VCRs, a new and improved version comes along to replace the old one several times per year, something that would be unimaginable for more mature products like cars, refrigerators, or washing machines. Last year's top-of-the-line PC is this year's budget PC. A few months later, that same PC isn't worth selling at all. This constant upgrade treadmill means consumers always get the latest technology at the best price, but it also means rapid obsolescence. Electronic products have become disposable by their nature.

It's been said, "Speed, not yield, differentiates the leaders." Because prices spiral downward all the time, it's important to be early to market and enjoy the higher chip prices while you can, even if you pay for it in lower yields. By the time you've got your yield up to where you want it, market prices have eroded so much that the chip is barely profitable. Prices erode faster than yield improves. This race is for the swift.


Chapter 6. Essential Guide to Microprocessors

In this chapter...

  • Overview of Microprocessors

  • Microprocessor History and Evolution

  • What's a Processor Architecture?

  • Microprocessor Anatomy and Gazetteer

  • What Do 4-Bit, 8-Bit, 16-Bit, and 32-Bit Mean?

  • Performance, Benchmarks, and Gigahertz

  • What Is Software?

  • Choosing Microprocessors

  • Microprocessor Future Trends


Overview of Microprocessors

A musical greeting card has more computing power than the entire world did in 1950. Today even the cheapest microprocessor chips are more powerful than those big government computers from old science-fiction movies. A Palm Pilot is a better computer than the one in NASA's first lunar lander. Microprocessors have totally changed our society, culture, spending habits, and leisure time. They're incredibly cheap and ever-present and this trend shows no sign of letting up.

They're the peak, the top, the Mona Lisa. Microprocessors are the most complex, most expensive, and most innovative of all the semiconductors. They're also largely misunderstood, victims of mainstream journalism and stilted advertising claims. Of all the types of semiconductors we've covered in this book, microprocessors are the most likely to spark debate instead of yawns, both among engineers and normal people.

Microprocessors are called many things, so pick your favorite term. "Computer-on-a-chip" is much beloved by the popular press, and it's even partially correct. "Electronic brain" is another one. Microprocessors are essentially basic computer systems reduced to a single silicon chip. Microprocessors aren't exactly the same as computers, and the term will make engineers wince, but it's close enough for our purposes.

Central processing unit (CPU) and microprocessing (or microprocessor) unit (MPU) are technically accurate and interchangeable terms for microprocessors. Sometimes its name is shortened to "processor" and sometimes even just to "micro." "Microcontroller" is also popular, although that term has slight shades of meaning to industry insiders and might not always be strictly accurate.

No matter what you call them, microprocessors sit at the top of the semiconductor hierarchy. Among engineers, designing microprocessors is a plum job, a career goal, and a primo adornment for your résumé. Manufacturing microprocessor chips is a status symbol among semiconductor companies, sometimes even a mark of national pride. "Real companies build microprocessors," avowed one Silicon Valley chairman.

So just what are these things? Basically, microprocessors are chips that run software. If it runs a program, it's a microprocessor; if it doesn't, it's not. Microprocessors are the only type of chip that follows instructions. Those instructions, called either programs or software, might calculate equations, open garage doors, or zap space aliens on your TV screen. The biggest and fastest microprocessors run our computers, predict our weather, and guide our spacecraft.

Microprocessors are traditionally named with unfriendly and inscrutable four- or five-digit numbers. As with German sports cars, the model numbers are meaningful to the cognoscenti but are pretty meaningless to the rest of us. As an example, some popular microprocessors of the recent past are the 68000, the 80386, and the 29020. For the less technically inclined, these happen to be the processor chips inside the first Apple Macintosh, the IBM PCs of the early 1990s, and several Hewlett-Packard laser printers.

Microprocessor companies have recently started giving their chips made-up names, such as Pentium, Athlon, or UltraSPARC. These names are easier to remember than numbers, and when microprocessors and PCs started to become household products, that was an important marketing consideration. In Intel's case, the name Pentium was created to prevent rivals from making competitive chips with the same part number. It's easier to trademark "Pentium" than the number "80586." (By the way, IBM attempted to trademark "/2" shortly after it created its PS/2 line of computers. Fortunately, the trademark office decided the number 2 was in the public domain.)

Microprocessors Everywhere

Every year the world's microprocessor vendors produce and sell about 10 billion microprocessor chips (give or take). That's well over one new microprocessor for every man, woman, and child living on Earth. Or if you prefer, that's about 35 microprocessors for every U.S. resident, every year

Who could possibly be consuming all these shiny new chips?

It's probably you. The average middle-class Western household contains about 30 to 40 microprocessors, including chips in the television, VCR, microwave oven, thermostat, garage-door opener, each remote control, washer, dryer, sprinkler timer, and a dozen other everyday items. The average car has about a dozen microprocessors; a 2001 Mercedes-Benz S-Class has 65. You might be carrying or wearing a number of microprocessors in your cellular telephone, pager, personal digital assistant (PDA), digital watch, electronic organizer, or wireless e-mail gadget.

Do you have a personal computer? It probably has a dozen different microprocessors in it, in addition to the big one you see in the advertisements. There are separate microprocessor chips for the floppy disk drive, the CD-ROM or DVD-ROM drive, the network, the modem, the graphics, the keyboard, the mouse, the monitor, and still more features that are buried inside. Microprocessors are everywhere and their ubiquity has changed our world.

As the chart in Figure 6.1 shows, microprocessor sales grew pretty steadily all through the decade of the 1990s. (Again, only a small fraction of this was because of the growth of PCs and other personal computers.) As you can see, the vast majority of microprocessors sold are low-end 8-bit processors (more about the nn-bits terminology later). Annual sales of microprocessors surpassed the world population back around 1995. Ever since then we've been effectively doubling the population of the world every year in new microprocessor chips.

Figure 6.1. Microprocessor and microcontroller unit sales have grown steadily, led by the inexpensive 8-bit chips. Courtesy of World Semiconductor Trade Statistics. Used with permission.

The average selling price for microprocessor chips is about $5. There are a lot of low-end chips in that volume to make up for the few very expensive microprocessors that go into PCs. The vast majority of microprocessor chips do not go into PCs; they're used in everyday items and they are called embedded processors.

What Are Embedded Processors?

If you shout "microprocessor" in a crowded theater, most people will think of Pentium or of Intel, the company that manufactures the chip by that name. In fact, Intel and its Pentium processor line have become household names, an odd turn of events for such a technical product. Yet at no point in its history did Pentium ever have more than a 2 percent share of the microprocessor market. This is because only about 2 percent of the world's microprocessors are used in PCs at all. Even if Intel (or any other company) cornered the market for microprocessors powering personal computers, it would still only have about 2 percent of total world microprocessor volume.

The lion's share of the microprocessor market is called, oddly, the embedded market. Embedded in this sense means the chips are embedded into electronic products like an ancient insect embedded in amber. The metaphor is an odd one but unfortunately it has stuck. Engineers, managers, executives, and public relations professionals constantly have to explain, or apologize for, the "embedded" moniker.

It's also frustrating that the 98 percent of the market that's not involved in PCs should have to explain itself to the comparatively insignificant 2 percent that is. It's a bit like labeling the majority of the population "people who aren't astronauts."

A somewhat more mellifluous description of embedded processors is "the invisible computer," a term coined by Donald A. Norman in his 1998 book by the same name. As Norman pointed out, the embedded processors in our toys, games, and appliances have affected modern living conditions more than PCs.

What makes a microprocessor an embedded microprocessor? Nothing, other than the fact that it's not driving a PC. There is nothing technical or objective that separates an embedded processor from a nonembedded processor (i.e., one that drives a computer). Embedded processors are not faster or slower, cheaper or more expensive, or bigger or smaller than other microprocessors. PCs and Macintoshes have more than one microprocessor inside. One is famous and expensive; the others are embedded processors.

If there's nothing technically separating embedded and nonembedded (computer) processors, the difference is all a matter of context. Embedded describes how a chip is used, not the chip itself. Any microprocessor can be an embedded microprocessor if it's used that way. A single chip could occupy both camps. When Intel's 386 processor was giving way to newer PCs with the 486 chip, many engineers put 386 chips into embedded systems, a case where the 386 was both an embedded processor and a computer processor.


Microprocessor History and Evolution

The first microprocessor chip ever invented is regarded to be the 4004, which Intel first sold to Busicom in February 1971 for use in the latter's calculator. The 4004 was pitifully slow and simple by today's standards: It had only 2,300 transistors and ran at a pedestrian 750 KHz (that's 0.000075 GHz). Over the next five years, Intel updated the 4004 chip with the 8008, the 4040, the 8080, and then the 8086, which is still in use today (albeit heavily modified and updated). The 4004 microprocessor was simple enough that you could actually see the transistors and wires, and even a tiny logo in the (enlarged) photograph shown in Figure 6.2.

Figure 6.2. This photograph of the Intel 4004 silicon chip shows the microprocessor's transistors laid out on a rectangular chip. The wires at the edge of the chip connect the silicon to the chip's package. A small Intel logo can be seen in the lower right corner. The actual size of this chip was 12 mm2, or about one-eighth of an inch on a side. Courtesy of Intel Corporation. Used with permission.

At about the same time Intel's 4004 chip debuted, Texas Instruments released its TMC1795 chip. It, too, led to other better chips throughout the early 1970s, but the family eventually died off. Rockwell, RCA, Data General, MOS Technology, Motorola, and other companies also entered the nascent microprocessor market during this period, although few of those companies are still active (or even in existence) today.

The first microprocessors were not created for computers. The very idea was ludicrous in the 1970s, like making rockets in your garage and selling them to NASA. Instead, the first microprocessors were intended for very humble tasks such as running early digital calculators. (Digital calculators existed before 1971, but they used many separate logic chips rather than a single programmable microprocessor chip.)

Around 1980, both Intel and Motorola radically redesigned their microprocessors and came up with the i432 chip and the 68000 chip, respectively. Motorola's new processor was a success but Intel's i432 failed miserably. Although it was a fine design from an engineering perspective, it wasn't successful in the market. Intel quickly resurrected one of its older processors, the 8086, and freshened it up to create the 80186 and the 80286. Also about this time, a small IBM facility in Boca Raton, Florida, selected Intel's 8088 processor (yet another variation on the 8086 chip) to use in its Model 5150 Personal Computer: the first IBM PC. That single decision eventually made Intel the most profitable semiconductor maker in the world as it rode wave after wave of personal computers patterned after IBM's machines.

Motorola and Intel have extended, enhanced, and enlarged their two chip families many times over the years. Intel is still at it: The 386, 486, Pentium I, II, III, and 4 are all direct descendants of the original 4004 microprocessor, circa 1971. Motorola let its 68000 dynasty peter out in the mid-1990s, making another radical redesign to a new chip family called PowerPC.

The 1980s saw a number of old microprocessor companies drop out and new ones join in. National Semiconductor, Western Electric, Digital Equipment Corporation (DEC), Fairchild, Inmos, and others all joined the fray. This decade also saw the rise of the RISC design philosophy from the University of California at Berkeley and at Stanford University, located just across San Francisco Bay from each other. Berkeley's RISC-I and RISC-II chips eventually metamorphosed into Sun Microsystems's SPARC processors, which are still used today. Stanford's MIPS project begat MIPS Computer Systems, later Silicon Graphics.

This period also saw the rise of the x86 clones like AMD, Centaur, Cyrix, NexGen, Rise, Transmeta, UMC, and others too numerous to mention. Intel was enjoying such a bonanza as the PC market skyrocketed that it was inevitable the company would attract imitators. Throughout the late 1980s and early 1990s several companies did their level best to clone, or copy (legally or not) the Intel chip that was used in almost all PCs of the period. These were collectively called x86 processors because Intel's model numbers all ended with the digits 86 (i.e., 8086, 80386, 80486, etc.). Most of these x86 clones were quite good—some were even technically superior to Intel's own processors. However, the clone makers never made a significant dent in Intel's PC-processor monopoly (or, as the U.S. Federal Trade Commission called it in a 1999 consent decree, a "dominant market share," narrowly avoiding the dreaded and legally binding M-word). Most of the clone makers eventually went out of business, unable to compete against Intel's vast legal, financial, and marketing resources.

The later 1990s saw fewer new companies enter the microprocessor market and some old ones drop off. Cyrix, Centaur, and NexGen were absorbed by other companies, Rise and UMC exited the market, and Hewlett-Packard abandoned its own PA-RISC processor design and began collaborating with Intel on a project code-named Tahoe that would eventually become IA-64 (Itanium). Digital's ultra-fast Alpha processors pegged out in 2001, after leading the performance race for nearly 10 years.

Strangely, nearly all the world's significant microprocessors have come from American companies. Although the European and Japanese semiconductor companies were robust, healthy, and active, very few of them ever introduced a successful microprocessor. Some exceptions were the ARM processors (from England) and the V800 and SuperH families (from Japan). Despite the fact that England and Japan were both leaders in computer science and design, neither country made much of a dent in microprocessors.


What's a Processor Architecture?

Architecture is the slightly pretentious word engineers use to describe how a microprocessor is designed. For simple semiconductor chip like AND-gates or inverters, there aren't many different ways to make one work. A brick is a brick is a brick. However, when you get to more complex and elaborate chips like microprocessors, there are thousands of different ways to design one, and the differences have a big effect on the chip's performance, cost, and power usage. All bricks might be the same, but brick buildings can be firehouses, palaces, or skyscrapers. Hence, the microprocessor architecture describes these differences.

RISC and CISC Architecture

The two most common schools of processor architecture are called complex instruction-set computer (CISC) and reduced instruction-set computer (RISC). Like WWI and WWII, the first term didn't become popular until the second term provided something to compare it to.

Neither RISC nor CISC is fundamentally faster or better than the other, all marketing claims to the contrary. RISC is the newer style of the two, but it has been much less successful in commercial terms. Until RISC came along, all microprocessor chips were CISC designs. Even today, CISC chips outsell RISC chips by a hefty margin. RISC is newer, flashier, and sexier (to an engineer, perhaps), but not necessarily better. (For reference, CISC is pronounced like the penultimate syllable in San Francisco; RISC is just what it looks like.)

Briefly, CISC chips include complex circuitry that allows them to calculate complex instructions (hence the name), such as adding several numbers together at the same time. RISC chips, on the other hand, have a much simpler set of instructions. Anything that's not absolutely necessary is jettisoned from the chip design, streamlining the chip and making it smaller, faster, and cheaper to manufacture (because it uses less silicon). The trade-off is that it takes several RISC instructions to do the same work as one CISC instruction, almost exactly offsetting the advantage of the faster chip.

Microprocessor designers argue like cooks in a kitchen. You might design or remodel a kitchen to include every modern appliance and gadget known to humankind. The kitchen would be expensive and large, but no recipe would be beyond your ability. You could also go to the opposite extreme and design only the most rudimentary and spartan kitchen. You'd spend a lot less money on hardware and the kitchen would be smaller (and easier to clean). Theoretically, you could prepare the same dishes in both kitchens, but in the "reduced" kitchen you'd have to put in more manual labor (e.g., no automatic pureeing of egg whites) and the recipes in your cookbook would have to be longer and more detailed. Is one better than the other? That depends on your taste and personal style. RISC promotes simple hardware and detailed instructions; CISC endorses complex hardware and fewer instructions.

DSP Architecture

A third major category of microprocessor designs is called digital signal processor (DSP). Like RISC and CISC, DSP is a design style, a way of organizing a chip to efficiently accomplish certain tasks. In the case of DSP chips, those tasks generally involve handling audio, video, and wireless information.

DSPs are like other microprocessors in most respects, but they are more adept at certain complex mathematical equations. In particular, DSPs are good at compressing and decompressing digitized audio, which is useful in cellular telephones and other wireless products. They're also good at compressing and decompressing video, such as for cable or satellite TV receivers. Finally, DSPs are good at converting these forms of digital information into a form suitable for high-speed transmission, which makes them good for cellular, terrestrial, and satellite communications.

Programming a DSP chip is a bit different than programming a RISC or CISC chip. DSP programmers tend to have a background in mathematics and understand arcane subjects like information theory, signal-to-noise ratios, and Shannon's Law. DSP programmers and RISC/CISC programmers often find little in common to talk about, even at technical gatherings.

Superscalar Architecture

Superscalar is the microprocessor equivalent of having several cooks in the kitchen. A superscalar microprocessor can run two or more instructions at the same time, like two or more cooks working on different recipes. Just as in a crowded kitchen, there are often resource constraints or other conflicts that reduce efficiency. Two cooks do not necessarily work twice as fast as one.

Some superscalar microprocessors can handle two instructions at a time, some can handle five or six, and some can do even more. The more instructions a chip can handle (the more "massively superscalar," in computer parlance), the less efficient the whole operation becomes. The point of diminishing returns generally comes after about six simultaneous instructions on one chip.

VLIW Architecture

A microprocessor technique that's related to superscalar is called very long instruction word (VLIW), which doesn't say very much about how it works. All VLIW processors are superscalar but not all superscalar processors use VLIW.

To reuse our cooks-and-kitchens analogy, a VLIW processor works by splitting the instructions from a recipe into perhaps six different subrecipes, one for each cook. Six different cooks would all read from their part of the same cookbook and cooperate on the recipe together. This would be a strange arrangement, but it might avoid some of the haphazard confusion of six different cooks all running in different directions with no cooperation. The writer of this six-part cookbook would, we hope, organize the cooking instructions to maximize cooperation and avoid six-way squabbles over the paring knife.

In theory, VLIW microprocessors avoid many of the diminishing-return problems that plague other superscalar microprocessors. However, they put a great burden on computer programmers to maximize efficiency. Unless the programmers can find ways to gracefully orchestrate multiple "cooks," they're no better off than before.


Microprocessor Anatomy and Gazetteer

Without becoming a computer scientist or microprocessor engineer, it's useful to know some of the terms for various parts of a microprocessor chip. Don't feel you need to memorize these; use them as reference if you get cornered at a party.

Figure 6.3 shows a simplified block diagram of a microprocessor. This could be anything from a simple 4-bit processor to a big 64-bit machine; the fundamentals are the same for all processor chips.

Figure 6.3. This simplified diagram of a microprocessor shows how instructions come into the chip, are decoded, and then dispatched to one of three (in this example) execution units. The execution units take data from the microprocessor's registers, work some function on it, and store the result back into the registers. Results might also be stored in the data cache or sent to other chips over the data bus.

Decoder

Instructions come into the chip from the top of the diagram. Each microprocessor understands a different set of binary patterns called its instruction set. Like people, different processors speak different languages, and even though all languages express the same concepts and ideas, they use different words.

No matter what instruction set the microprocessor "speaks," those instructions need to be decoded. The instruction decoder decides what the instruction is telling the microprocessor to do. It might be instructing the microprocessor to add two numbers together, subtract one number from another, compare two numbers to see which is larger, or any of a hundred or so other instructions. Most microprocessors understand 100 to 200 different instructions. Any unintelligible instructions are either ignored or cause the microprocessor chip to enter a failsafe mode until it's given good instructions.

In our example microprocessor, the decoder decides that the current instruction should be handled by one of the three execution units. Some microprocessors have only one execution unit; others have a dozen or more.

Execution Unit

Execution unit is a grisly-sounding term that simply means that all the instructions are executed, or carried out, in this part of the processor. It's the part of the chip where all the heavy lifting takes place. There might be more than one execution unit in a microprocessor chip (our example in Figure 6.3 has three). Having more execution units is like adding more hamsters to the wheel: It goes faster, but you also have to feed it more (instructions) to make it go.

If there are multiple execution units in a microprocessor, they're probably designed to specialize on certain instructions. One execution unit might be built to perform arithmetic (adding, subtracting, multiplying, and dividing numbers) whereas another makes logical comparisons (is this number bigger than that number?).

Some execution units are big and some are small because some instructions are harder to execute than others. Multiplication, for example, is harder than addition (just like it is for people), so the multiplier unit will have more transistors than the adder unit. It will take up more space on the microprocessor's silicon chip and use more electricity when it runs. In the early days, engineers could actually get a microprocessor chip to melt by giving it just the "right" combination of math problems to figure out.

Floating-Point Unit

A floating-point unit (FPU) is just one of many different kinds of execution units. Microprocessors have no trouble working with numbers, as long as they're round numbers. Like a typical third-grade student, microprocessors get a headache from fractions.

Numbers with fractions or decimal values are called floating-point numbers. Don't worry about where this term came from; just treat it as nerd-speak for fractions. Fractions are so hard for microprocessors to deal with that some chips don't do it at all. They completely avoid fractions or decimal values and treat everything as an integer (a counting number with no fractions). Unfortunately for computer programmers, the world is full of fractions, so this presents a problem.

One approach is to round all numbers off and drop the fractions. A few bank robbery movies have been based on this premise. Another approach is to multiply all numbers by, say, 1 million, and shift the decimal point to the right six places. The third, and best, approach is to use a chip that can actually handle floating-point numbers.

An FPU takes up a large amount of silicon space on the chip because it requires a lot of electronic circuitry. It's also often the slowest part of the chip, sometimes to the point of slowing down the rest of the microprocessor. Like a typical adventure story, the egghead in the white lab coat is often the slowest person in the party. Finally, FPUs are complicated to design and complex to manufacture. This makes them error-prone, as Intel discovered to its everlasting misery when its famous Pentium processor was discovered to have a bug in its FPU.

Registers

Each microprocessor contains little cubbyholes for it to store numbers as it works on them. These are called registers (after the electrical circuit used to build them) and there might be anywhere from 4 to 500 registers, depending on the particular microprocessor. Registers are small and they take up almost no space on the microprocessor's silicon chip.

Execution units take data from the registers to do their work. When they're done, the execution units store their results back into the registers. Registers are like a busy executive's desk: a place to store a few often-needed items close at hand. Like desk space, the number of registers is limited, so computer programmers prefer microprocessors with lots of registers. It's like having a big desk to work on.

Cache

Like Robinson Crusoe, a secret cache can help get a microprocessor through lean times. A cache is a memory, pure and simple, but a memory that's built onto the microprocessor chip instead of being outside in another chip. Caches speed up the processor by keeping often-used bits of data close by. If registers are the programmer's desktop, caches are the programmer's file drawer: close, but not quite as close as the registers. Without a cache (or sometimes even multiple caches), the microprocessor might have to go looking for data it needs, slowing down the program.

Caches started appearing on microprocessor chips in the late 1980s when engineers noticed that microprocessor chips were speeding up faster than memory chips were. (This is still going on, and the gap is getting wider.) Making the microprocessor wait for comparatively slow memory chips is like making a highly paid chef wait around for the grocery-delivery boy to show up on his bicycle.

In the kitchen we alleviate this problem by keeping a cache, or store, of food in the cupboards and refrigerator. Occasional trips to the grocery store replenish this local cache. Without them, we'd be making trips to the grocery store (or worse, the farm) for every meal. Caches work by keeping some data physically close to the processor's execution units so it doesn't have to go "shopping" for data quite so often.

There's some serious magic involved in designing caches so they hold the most useful data. A cache isn't big enough to hold everything, so it's important to make the best use of the limited space. That sort of design magic is beyond our scope here, but it's an area of microprocessor design that's closely watched by insiders.

Bus

Sometimes an execution unit won't store the result of a calculation in a register; instead, it will be instructed to send the result to another chip. In that case, the data will be sent off the microprocessor over a set of wires called the data bus. In our example microprocessor, the data bus is at the bottom of Figure 6.3, on the far side of the data cache. This means that any time our microprocessor sends data to another chip over the data bus, it also stores a copy of that data in its local data cache. If our processor ever needs to refer to that data again, it'll have a local copy close at hand. It's much faster to refer to the cache than to request the data from another chip.

The data bus connects the microprocessor chip to all the other chips that need to share data with it. At a minimum, that would include a few memory chips and maybe a communications chip or a graphics chip. The microprocessor might also be connected to other microprocessors so they can share the workload. There could be several chips attached to the same set of bus wires, or only a few.

Because these chips all need to communicate with each other over the same set of wires, some standards need to be established. Like cars sharing the same streets, there need to be some rules of the road that all participants can agree to. In the electronics business, there are several such bus standards, each one incompatible with the others. Engineers therefore need to choose their chips carefully, making sure that all the chips are designed to adhere to the same bus standards. Otherwise, they won't be able to communicate with each other.

Tech Talk

One Little, Two Little Endians

Suppose someone wrote a very big number on a piece of paper to mail it to you. However, the paper is too big to fit in an envelope, so your friend cuts the paper in half and sends the pieces in two different envelopes. When the two envelopes arrive, how do you know which way the papers go back together? If you tape them together backwards, you'll get the wrong number.

Computers solve this problem by sending large numbers either "big end first" or "little end first." Big end first, or big-endian, means the first envelope to arrive holds the big end of the number (first or leftmost part) and that subsequent parts should be pasted on after (to the right of) that one. Little-endian computers work just the opposite way.

There's no advantage or disadvantage to either method. Unfortunately, most microprocessors (and therefore, most computers) are permanently fixed one way or the other. One of the original challenges of creating the Internet was getting different computers to exchange data without endian problems.

Before you ask, the words for big- and little-endian come from Gulliver's Travels, the book by Jonathan Swift in which the fictional hero encounters the folk of Brobdingnag, who are warring over whether to break open their hard-boiled eggs from the big end or the little end.

Pipeline

Although Figure 6.3 doesn't explicitly show it, every microprocessor has a pipeline. Each individual step that a microprocessor performs, such as decoding, accessing registers, and executing instructions, is one stage of the pipeline. Three stages make a very simple pipeline. Complex microprocessors have pipelines that are more than a dozen stages long. Longer pipelines allow a microprocessor to break up its work into smaller stages. The smaller stages, in turn, allow the microprocessor to run faster.

Pipelines are like assembly lines. If it takes four hours to assemble a television, and the assembly line is broken up into four one-hour tasks, then four different workers can be working on four different TVs at once. A new TV rolls off the assembly line every hour, even though it still takes four hours to make each TV. In the same way, a microprocessor with a four-stage pipeline will have four different instructions in various stages of completion at once. The chip only finishes one instruction at a time, but the next three instructions will be ready right behind it.


What do 4-Bit, 8-Bit, 16-Bit, and 32-Bit Mean?

The "bittedness" of a microprocessor tells you how fast and powerful it is in very broad terms. If you're a car buff, the number of bits is like the number of cylinders in the engine. A 4-bit processor is the very low end and 64-bit processors (for today, at least) are at the very high end. Most microprocessor chips fall somewhere in between. A PC or Macintosh has a 32-bit microprocessor; microwave ovens generally have an 8-bit processor, and a TV remote control is likely to use a 4-bit processor. The average late-model car includes about a dozen 16-bit microprocessors spread throughout the engine, the transmission, and the dashboard.

More technically, these numbers describe the size, or width, of the processor's data bus. A 16-bit processor can digest 16 bits of data at once. (For more background on data bits, bytes, and related buzzwords, turn to Chapter 9, "Theory.") Having a wider data bus (e.g., 16 bits compared to 8 bits) is like drinking through a wider straw: You can get more through in the same amount of time.

In microprocessors, as in engines, the number of bits (or engine cylinders) doesn't tell the whole story—it only gives a rough idea of performance. A 32-bit processor doesn't necessarily solve complex equations faster than a 16-bit processor. The only thing for sure is that bigger numbers make for better advertising, for cars as well as microprocessor chips. When Sony introduced its PlayStation 2 video game, the company trumpeted the game's 128-bit processor. Despite the fact that few potential customers had any idea what that meant, or that it was only marginally true, it sounded good in the ads.

Figure 6.4 illustrates the difference between an 8-bit processor and a 16-bit processor. As you can see, the 8-bit processor has eight wires that bring it data from (and send data to) other chips, like eight fire hoses pumping water from a fire truck. The 16-bit processor has twice as many wires so it can move twice as much data in the same amount of time.

Figure 6.4. Eight-bit processors generally have only eight wires connected to the chip to bring it data. A 16-bit processor, right, has twice as many connection points for twice as much data.

Twice as many wires not only means faster data, it means bigger data. A 16-bit processor can crunch bigger numbers than an 8-bit processor. Imagine you had a calculator that was so small it could show only four digits on the screen. You couldn't work with any numbers bigger than 9,999, so you'd have to be careful not to add too many numbers together. A calculator with a bigger display is more useful because you aren't so limited. By the same token, 4-bit processors are limited to working only with small numbers, lest they "overflow" and cut off part of the answer. Table 6.1 shows what the limits are for 4-bit, 8-bit, 16-bit, 32-bit, and 64-bit processors. The bigger processors have much more headroom, making them useful for a bigger class of computing tasks.

Table 6.1. The more bits a microprocessor chip handles at once, the bigger the numbers it can calculate. Programmers have ways to overcome these limits, but such methods are awkward.

Number of Bits

Largest Number Possible

4

16

8

256

16

65,536

32

4,294,967,296

64

18,446,744,073,709,551,616

Some processors can also "split their bits." If a 16-bit processor doesn't need to calculate numbers as big as 65,536 it might be able to do two 8-bit calculations at once, as long as neither one generates an answer bigger than 256. This double-barreled approach allows the chip to do twice as much work in the same amount of time. For 32-bit processors, and especially 64-bit processors, this is actually very common. Even your neighborhood nuclear physicist hardly ever needs 64-bit arithmetic. There just aren't that many atoms in the universe. Today's 64-bit microprocessors are more often used for doing four 16-bit calculations (or eight 8-bit calculations, or two 32-bit calculations) at once.

Tech Talk

If you're mathematically inclined, you might have noticed the pattern in Table 6.1. The number on the right is 2 raised to the power of the number on the left. So, a 4-bit processor can handle values up to 24, which is 16; 28 equals 256; and so on. The reasons for this are detailed in Chapter 9, "Theory," but it has to do with the fact that computers use binary, or base 2, arithmetic.


Performance, Benchmarks, and Gigahertz

It's said in the computer world that there are lies, damn lies, and benchmarks. Like Mark Twain's original observation about statistics, the numbers don't tell the whole story, or even the half of it. Measuring the speed of a microprocessor chip might seem to be a simple, straightforward task, but it's anything but.

As an example of the problem, try defining the world's best car. Do you measure top speed? Trunk space? Fuel efficiency? Price? Resale value? You could combine and weight all these factors, but other people will inevitably argue that you've given too much importance to speed and not enough to passenger comfort, for example. You can't please everyone with a single score. This is the problem with measuring microprocessor chips (and computers). Everyone would like to see a single score for microprocessor "goodness," but nobody agrees on what that should measure.

Tech Talk

Megahertz, Gigahertz, and Beyond

The speed of microprocessors (or any type of digital chip) is often measured in hertz. One hertz means one "change per second." If you flip a coin every second, that coin is changing at the rate of 1 hertz. If you can somehow do that trick 1,000 times per second you'd be flipping a coin at 1,000 hertz, or 1 kilohertz(KHz). One million hertz is a megahertz (MHz) and 1 billion hertz is a gigahertz (GHz).

Inexpensive microprocessors might run at 20 MHz or so; more expensive processors for PCs run at more than 1 GHz. The unit of measurement is named after Heinrich Hertz, a German scientist who began measuring the frequency of radio waves back in 1883.

There is no theoretical limit to how high these chip frequencies can go; it's been creeping up year after year with advances in silicon manufacturing technology. If you're a radio operator, you might recognize some of these frequencies from the radio spectrum. Today's microprocessors do indeed broadcast tiny radio signals in the megahertz and gigahertz bands, which is why computers are shielded in metal boxes to minimize interference with TVs and radios.

The easiest thing to measure is the clock speed of a microprocessor, also called its frequency. A chip might run at 5 MHz, 500 MHz, or 5,000 MHz, but at least it's a verifiable number. Unfortunately, it's also pretty meaningless. The clock speed of a microprocessor is like the revolutions per minute (RPM) of a car's engine; it makes a nice "zoom, zoom" noise when you rev it up, but it doesn't tell you anything about real horsepower. Big frequency numbers add sizzle to advertisements and marketing literature, but they're not the steak.

To try to bring order to this chaos, a number of people have created special computer programs called benchmarks. Benchmarks instruct a microprocessor to perform repetitive tasks and then measure the time it took to finish them. They are the microprocessor equivalent of drag racing. (The word benchmark comes from an ages-old carpenters' habit of cutting regularly spaced marks on a workbench to measure materials.)

Benchmarks are fine, as far as they go, but people often read too much into them. Like the miles per gallon (MPG) sticker on a car, benchmarks are only an estimate. Your mileage may vary. Even if the estimate is correct, one number can't tell you very much about the whole product.

Tech Talk

Measuring Dhrystone MIPS

DEC made a computer called the VAX 11/780, which was the first computer to perform 1 million instructions per second, in 1978. (This turned out to be untrue, but that's another story.) It wasn't long before other computer companies wanted to prove their products were as fast as the VAX.

They looked for a program that was easy to translate for different types of computers, and Dhrystone was selected. The VAX happened to run the Dhrystone program 1,757 times per second. This set the bar. Now any computer that could do more than 1,757 runs per second was judged to be faster than a VAX.

Bizarrely, the magic number of 1,757 Dhrystone runs per second began to be used as the definition of 1 MIPS. Whether a computer was really performing 1 million instructions per second (1 MIPS) or not, the Dhrystone score was used as proof. Even computers that were faster than 1 MIPS were downgraded to 1 MIPS based on their Dhrystone performance. The same scale is still used today.

Misleading MIPS

If you're optimistic, MIPS stands for "millions of instructions per second." If you're cynical, it's "meaningless indicator of performance for salesmen." The MIPS number was for a long time the accepted way to measure a microprocessor's performance. Over time it has slowly outgrown is usefulness and it certainly does not measure anything useful anymore.

Early computer engineers naturally liked to compare their latest computers with their rivals' machines. To do this, they'd count the number of instructions each computer could execute per second. The more instructions per second, the faster the computer. In the 1970s, performing at 1 MIPS was a big achievement, like breaking the sound barrier.

Today's microprocessors in PCs and games can easily polish off hundreds of millions of instructions per second, and for less money than those early computers. However, they aren't the same kind of instructions, so comparing today's computers to yesterday's isn't really fair. It's like comparing a modern Formula 1 auto race to a historic bicycle race. Of course the modern racers go around the track faster, but what does that prove?

By the same token, it's not relevant, or fair, to compare the MIPS ratings of different microprocessors. All microprocessors execute different kinds of instructions (called their instruction set), and they're not directly comparable. Person A might be able to read Japanese faster than Person B can read French, but that doesn't tell us anything useful about either one of them.

Tech Talk

How to Pronounce—and Spell—MIPS

If you really want to impress your colleagues, be sure you always pronounce and spell MIPS with the capital S on the end. Don't get caught saying "one MIP" because there's no such thing. It's always "one MIPS" because the final S stands for "seconds," sort of like the H in miles per hour (MPH). Even though it sounds funny, "one MIPS" is correct.

The Mythical MIPS-per-MHz Ratio

One favorite trick of chip makers is to brag about the "efficiency" of their processors with a MIPS-per-MHz ratio. Obviously this number is derived by taking the number of MIPS (which might be suspect, as described earlier) and dividing by the chip's clock speed measured in megahertz. The larger this number is, the more "efficient" the chip is judged to be.

There are a few problems with this approach. First, nobody cares. Of what value is it to a consumer to know that one chip delivers more MIPS (whatever those are) per millionth of a second? Isn't the end result what matters? Multiplying the two numbers—MIPS times megahertz—might make sense. Dividing one by the other is pointless.

Second, there's the squishy definition of MIPS itself. It might measure how many millions of instructions the chip executes per second, but probably not. More likely it's based on Dhrystone, or another benchmark, or drawn from a hat containing competitors' scores. Even if the true MIPS number is used, that's not a useful indication of work, efficiency, or forward progress.

Finally, the ratio is self-defining; it's a circular reference. Chip makers often define the MIPS rating for their microprocessor by multiplying its frequency (megahertz) by some secret number, essentially reversing the MIPS/MHz equation. With only two numbers, and one of them suspect, the MIPS/MHz ratio is really the "megahertz multiplied by some number we made up in the marketing department" ratio.

Power Consumption and MIPS/Watt

Lately it's become fashionable to design microprocessor chips so that they use the least amount of electricity possible. For battery-operated devices like laptop computers, the motivation for this is obvious. The longer the battery lasts, the happier the customer is. Lower power consumption also means less heat, and sometimes heat is a bigger problem than battery life. Again, customers won't be happy with a laptop computer that gets too hot to touch.

For these reasons and others, engineers have made rapid progress toward reducing the power consumption of high-end microprocessors to manageable levels. It naturally follows, then, that these same chip makers want to trumpet their advancements to their customers and the press. Alas, measuring power consumption is fraught with as many difficulties as measuring performance. The seemingly straightforward task of measuring electrical consumption has become a battlefield among warring microprocessor companies.

The most common measure of power efficiency is the MIPS-per-watt ratio. As we just saw with MIPS-per-MHz, the first of these two numbers is unreliable to begin with. Sadly, the second number can be just as erratic. Measuring the power usage of a processor isn't easy because it changes all the time. The amount of electricity the chip uses depends on what it's doing. It's easy to invent a situation where the processor is relatively idle—vacationing, if you will—and consuming little energy. It's also easy to concoct situations where the processor is fantastically busy and consuming far more electricity. This shouldn't be surprising. Your TV uses more power when it's turned on than when it's turned off. Which condition do you measure?

That depends on whether it's turned on or turned off most of the time. (Let's hope it's the latter.) It also depends on whether you want to know overall power consumption (e.g., over the duration of a month) or instantaneous power consumption (e.g., for a period of 10 seconds). In the same way, a processor's power consumption can be dialed in to nearly any number that suits its promoters.

So we're left with one suspect number (MIPS) divided by another suspect number (watts of power) to produce a monumentally suspect number. Bearing, as it does, no relation to anything tangible or useful, chip makers might as well be measuring furlongs per fortnight.


What Is Software?

Software, or programming, is the essence of what makes microprocessors interesting. Software is a made-up word meant to indicate it's somehow the opposite of hardware. Everybody knows what hardware is: It's the nuts and bolts of a computer, television, or little red wagon. In semiconductor terms, hardware is silicon, plastic, and other things you can touch. Software, on the other hand, is like the music on a CD or the programming on your television. It might not be physical but it's definitely real.

The TV set, the CD player, the cookbook, and the leaflet printed in 12 languages (none of them your own) are just examples of how the software is delivered. For microprocessor chips, software usually comes on floppy disks, CD-ROMs, over the airwaves (like TV and radio), over the Internet, or permanently stored in a ROM chip. Regardless of the form, software is the programming for microprocessors, just like TV shows are the programming for TVs.

Like TV shows, programs have to be created by someone. Usually a team of programmers works together. Some programming teams even have directors and producers, just like studio productions on a movie lot. Other times a single programmer works alone, like an independent film auteur. Like filmmaking, photography, or recording music, some people write programs as a paying profession, whereas others do it in their spare time just because they love it.

Tech Talk

You can call programs software, but saying "software program" is redundant. Creating software is called programming, but programmers sometimes call themselves software engineers. Programmers (or software engineers) say they spend the day "writing code" or simply "coding." At the end of a day of coding, a programmer might have written a certain number of "lines of code," meaning a certain number of instructions to the microprocessor.

In a related vein, there's also "firmware." Firmware is software stored in a chip (which is hardware), blurring the distinction between hardware and software. Finally, "wetware" is simply the human brain.

One difference between programs and movies is that movies can be played on any TV (or cinema screen) around the world; this is not so for programs. Computer programs are always created for a specific type of computer. Programs written for an Apple Macintosh, for example, don't work on a PC running Microsoft Windows. A programmer has to decide early on whether the program should work on a PC, a Macintosh, a UNIX workstation, a Palm Pilot, a Nintendo video game, an antilock brake system, a cellular telephone, or any of a thousand other platforms for running software. You can play music CDs on any CD player, but you can only "play" computer programs on the right kind of computer.

What's the reason for all this incompatibility? The world might be a better place if programs could all work on any microprocessor, but that's not the way it is. Each different microprocessor chip is designed to understand a different set of instructions (called, obviously enough, its instruction set). Like speaking Russian or Swahili, different chips simply speak different languages, and none of them are bilingual. Programs created for one type of microprocessor chip are interpreted as gibberish by any other type of microprocessor chip.

There are families of chips that all understand the same language and run the same programs. Chips in the Pentium family, for example, all run the same programs. That's why old and new PCs can run the same PC programs. Microprocessors from AMD's Athlon and Opteron product lines are also part of the Pentium family, so they can also run PC programs. However, chips from the SPARC family (to pick just one example) cannot run PC programs because SPARC microprocessors have a different instruction set from Pentium-family microprocessors.

If a team of programmers wants their program to work both on Pentium-family processors and SPARC-family processors, they have to either write the program twice or translate the program from one instruction set to the other using an automated tool called a cross-compiler.


Choosing Microprocessors

The market for microprocessors is enormously competitive. Well over 100 different 32-bit microprocessors are available, with even more 16-bit, 8-bit, and 4-bit chips competing for the low end. In all, about 1,000 different processors are competing over millions of different systems, from thermostats to thermonuclear weapons.

Paradoxically, this most technical of products competes on very nontechnical grounds. At the high end of the market, perception and advertising have a big influence on buying decisions and market success. The ultimate example is PC processors: Television advertisements urge (presumably) nontechnical viewers to buy a product they don't understand. The ads don't contain even a hint of technical material. They're all about image and brand-name recognition. When information fails, image prevails.

The 32-bit embedded microprocessor market is only a little less image-conscious. Processor families like MIPS and ARM are successful because they're perceived as safe choices, used and adopted by dozens of clients with no apparent complaints. Even though many other 32-bit alternatives exist, some of which might even be technically superior, their advantages aren't always compelling enough to break through the image of the market leaders.

Software Compatibility

Most of all, the microprocessor business is determined by software. Most buyers choose a microprocessor not by the merits of its hardware, but by the advantages of its software. Because every microprocessor family has its own special instruction set, and programs written for one microprocessor family cannot run on another, it follows that choosing a microprocessor also means choosing the software that's available for it. For most buyers, that's putting the cart before the horse. They'd rather decide what software they want, and then choose a microprocessor that works with that software.

Choosing a microprocessor is a bit like choosing a new language to study. Any new language requires about the same amount of effort to master, so you generally choose one that's widely used (Spanish, French, or Mandarin), one that's related to your area of interest (Italian for singers), or one that's locally popular (German in Milwaukee or Vietnamese in San Jose). The choice has nothing to do with the expressive power of the language or its other qualities; it has more to do with its place in the outside world. Similarly, buyers choose microprocessors that are in wide use, suited to their applications, or entrenched within their company or industry. This has little to do with bittedness, architecture, or any other intrinsic qualities of the hardware.

The downside of this herd instinct is that it makes it harder to differentiate a new product. If you've chosen a particular microprocessor because others in your industry have done so, you're no different from your competitors. You've gained a software foundation but lost a hardware advantage. In the worst case, you differentiate your product by the color of its plastic (literally true in some cases). More optimistically, you can create new software for the product that's original. The additional software can add features your competitors don't have, masking the underlying similarities in the hardware.


Microprocessor Future Trends

There's no question that microprocessors will continue to grow more complex over time. We're nowhere near reaching any natural limit to microprocessor growth. Where once it seemed silly to design a computer-on-a-chip—after all, how many computers does the world need—now it seems just as absurd to stop.

The actual size of microprocessor chips is growing only slowly, but the complexity within them is growing much faster because semiconductor technology permits engineers to squeeze more transistors into less space. Microprocessors with 1 million transistors were surpassed by 10-million-transistor processors after only a few years. Microprocessors with 100 million transistors weren't far behind. This trend continues with no end in sight.

The bigger question is this: How will engineers fill the space? How will they spend their 500-million-transistor budgets? The answer has historically come from above, from mainframe systems and supercomputers. For decades, microprocessors shadowed the developments of high-end computers, first lagging by several generations but now lagging the high-end machines by only a few years. Microprocessors have been nipping at the heels of the computer makers for years, which is why so many big computer companies went out of business in the 1990s. Rather than fight the trend, some computer makers joined the bandwagon and designed their machines around commercial microprocessors, but then had a hard time differentiating their products from other companies with the same strategy and access to the same chips.

Future trends point toward cooperation. Even though microprocessors get about 30 percent faster every year, they're not doing that much more useful work. Instead of performing single tasks even faster, future chips are likely to perform more simultaneous tasks, but slower. A team of 12 bricklayers is more productive than one really fast bricklayer working alone. By the same token, teams of microprocessors working on a problem together will likely generate a better return on the investment of transistors.

Cooperation within a single chip is one way to go. Called instruction-level parallelism (ILP), microprocessors today can execute a few instructions in parallel. This approach can't grow forever, though. Superscalar processors can become so complex that they don't deliver enough extra performance to be worth the extra silicon. ILP has already moved microprocessors about as far forward as it can. It has worked for the past few years, but it's an approach that's running out of steam.

Taking the problem outside the chip is another approach. Chip-level symmetric multiprocessing (SMP) promises to keep many microprocessors working in concert. Large supercomputers do this already, on the theory that two (or more) heads are better than one. Using several chips together has economic advantages, too. Individual microprocessors won't have to be so large (read: expensive) and it might be possible to add or remove processors from a system when upgrading. The problems lie mainly in the software. It's not trivial to program a computer with multiple processors, any more than it is to command multiple cooks working in the same kitchen. Orchestrating that much computing horsepower is a talent few programmers have thus far demonstrated.

RISC concepts seem to be slowly losing currency as chip complexity increases. Paradoxically, the RISC design philosophy arose just as transistor budgets were expanding. Why economize on silicon when transistors are almost free? Why put the burden on software when programmers are scarce and highly paid? Chip designers have learned they can make their microprocessors more complex and still have them run faster. We get to have our cake and eat it, too. Whichever architectural approach gains prominence, tomorrow's microprocessors are guaranteed to be more complex than today's.

The other guarantee is that microprocessors will become even more ubiquitous. In the early 1900s electric motors were rare and precious commodities (so was home electricity). Catalogs and dry-good stores sold myriad attachments and add-ons for householders who presumably had only one electrical motor in the home, if that. Today, electric motors are so prevalent in blenders, tape players, cooling fans, and executive toys that we don't notice them. If they wear out or break we throw them away because it's not worth the effort to repair them.

Tomorrow's microprocessors will go from being in everything to being in everything many times over. The average cellular telephone won't have one or two microprocessors in it; it will have 15. Cars will become rolling computer farms. Children's toys will be the envy of the NASA space program. Gumball machines will dispense 64-bit souvenirs, after you wave your computerized debit card in its general direction. Microprocessors will be like pennies on the sidewalk: shiny and interesting but not worth picking up off the ground.


Chapter 7. Essential Guide to Memory

In this chapter...

  • Overview of Memory Chips

  • Nonvolatile ROM

  • Volatile RAM

  • Memory Interfaces

  • Future Memories


Overview of Memory Chips

Memory chips are among the most plentiful kind of chips, making up a big part of semiconductor shipments and sales around the world. They're produced and sold by the millions and nearly every electronic item that has any kind of chip in it has at least one memory chip as well. Computers are the biggest users of memory chips. Most PCs have at least eight memory chips, and they often contain two dozen or more. Memory chips also lead the way in new advances in chip manufacturing. New silicon technologies are tried out on memory chips before they're used anywhere else.

Chip manufacturing gets better, faster, and more advanced all the time, as we know, and nowhere is this more evident than in memory chips. In fact, memory chips are often used as the yardstick for the whole semiconductor industry's progress. They're the standard by which other chips are measured.

As advanced as they are, memory chips are also among the cheapest of all chips. Even though they continually get better, faster, and more efficient, memory chips never seem to get more expensive. It's this constant increase in functionality (or spiraling decrease in price, depending on your perspective) that has, more than anything else, led to the invasion of electronics into everyday low-cost items in our homes, cars, and pockets. If memory wasn't so cheap, microprocessors, PCs, cell phones, and video games wouldn't be so inexpensive, either.

About Memory Chips

As you know, memory chips store data. They do this electronically in the form of bits. A bit of memory is simply a tiny amount of electricity. Each bit either has an electric charge or it doesn't; there's no in between. That makes life easy for the memory chip. Each bit is either one way or the other: either black or white, up or down, true or false, one or zero. It's pretty easy to remember a bit when there are only two options.

Each bit of storage in a memory chip uses a small amount of silicon on the chip. The bigger the memory chip, the more bits it can store. The storage capacity of memory chips has grown dramatically over the past 30 years, from chips that held 1,000 bits to today's chips, which hold 1 billion bits—a million-fold improvement. Yet for all that, memory prices have remained surprisingly flat.

If you're making memory chips, you try to squeeze each bit into as little space as possible to save silicon. If each bit is even slightly smaller, a million-bit chip will be significantly smaller and cheaper to manufacture. Memory prices are quite competitive, so even a tiny size or cost advantage over your competitors can spell millions of dollars of extra profit over a few months of production. Memory makers never stop trying to make transistors slightly smaller or pack them closer together. As with any commodity, small differences in manufacturing efficiency can translate into big differences in the bottom line.

The constant pressure and competition among memory makers and the lack of any big differentiating features has kept the prices of these chips consistently low. Figure 7.1 shows how the cost per bit of memory has plummeted over several generations of silicon technology. If the cost per bit falls, the cost for a given type of memory chip falls with it. Expensive memory chips quickly become cheap memory chips, and then disappear from the market completely. The commercial shelf life of memory chips is only slightly longer than that of romance novels.

Figure 7.1. The cost to manufacture 1 million bits (1 Mbit) of semiconductor memory chips has fallen by a factor of 1 million since the first DRAM chips were made in 1970. Coincidentally, the capacity of DRAM chips has grown by a factor of 1 million in the same time.

Even as the cost per bit sinks like a rock, the number of bits per chip rises like a rocket. The net effect is that the price of a new memory chip has remained remarkably constant for years. You just get more for your money.

Memory chips are sold in several standard sizes, or capacities, like cartons of milk. You can't buy an arbitrary number of memory bits like bananas to suit yourself; you have to choose from among a few standard sizes. Each new memory chip usually offers four times the capacity of the chip that came before it. For example, you might find chips that store 64 million bits, 256 million bits, and 1,024 million bits for sale at the same time. If what you really wanted was a 288-million-bit chip, you're out of luck and you will have to pay for the 1,024-million-bit chip.

Apart from capacity, the only thing that differentiates one memory chip from another is speed. Some memory chips can retrieve their data faster than others. Large-capacity chips are generally slower than small-capacity chips (because they have to search longer). Some customers will pay a price premium for faster memory chips, but others won't. If you're a memory maker, you have to decide whether to design your chips for maximum capacity (making them slower) or for speed (making them less capacious). The balancing act is a delicate one, and it depends on market conditions, which are difficult to predict.

Types of Memory

Memory chips come in two basic types: permanent and impermanent. The permanent kind of chips store data bits forever, even after their electrical power has been turned off or disconnected from the chip. Their memory lasts for years and years without batteries. The impermanent kind, on the other hand, only works while the power is on. When you power down or disconnect these chips, all their memory is lost. Although that might seem pointless, the latter category is actually the more popular of the two.

Chips with permanent memories are called nonvolatile memory chips. Impermanent memory chips are called volatile memory. That doesn't mean the chips are explosive, only that their memories are easily lost.

Another way to categorize memory chips is by ROM versus RAM. Your basic read-only memory (ROM) can't be erased or have new data written into it. It's permanent, like a stone tablet. You can erase and reprogram a random-access memory (RAM) chip as often as you want. All RAM chips are volatile, losing their memories if not carefully tended. All ROM chips are nonvolatile, storing their data forever, but not all nonvolatile chips are ROMs; some can be erased or changed. Got it?

RAM chips are more expensive than ROM chips but they're indispensable for computers, handheld devices, and most other computer-like products. Microprocessors need an erasable "workspace" in which to perform their calculations and follow their programmed instructions. RAM chips provide this necessary capacity.

ROMs are cheaper than RAMs and they are used for permanent or semipermanent storage. ROM chips are useful for storing permanent bits of data, such as the security code for your garage-door opener or the tiny program that runs a thermostat. Computers also use ROM chips to store some permanent programs that are "etched in stone" and should never be lost, such as how to start up the computer and how to access a floppy diskette.


Nonvolatile ROM

ROM chips come in a few different types. Like all memory chips, ROM prices are based mostly on capacity, with a small price premium for speed. Some ROMs can retrieve data faster than others, and this might be worth a little extra money to someone building a fast system.

Masked ROM

The simplest and cheapest ROMs are called masked ROMs (MROMs). These chips are mass-produced with particular data bits already stored in them. Once the MROMs are made, the data can never be changed. This is usually the point: MROMs are good for mass-produced products like cars, in which the software for the antilock brake system should never be altered.

Because their data patterns are permanently set when the chips are built, MROMs are only made in large volumes for big customers. It isn't cost-effective for a semiconductor maker to produce just a few thousand ROMs once in awhile. The cost of stopping the production line and setting up the tooling is prohibitive. So although MROMs are the cheapest form of ROMs, they're reserved for only the largest customers or the most popular products.

Programmable ROM

A more cost-effective alternative for the average consumer is the programmable ROM (PROM). These are like ROM chips but they are manufactured blank, with no data bits stored in them. (Viewed another way, all the bits are zeros.) The customer then loads the contents of the PROM using a machine called a PROM burner. There's only one chance to program a PROM; after the data has been loaded, the PROM's contents are permanent.

Because PROMs can only be "burned" once, they're called one-time programmable ROMs (OTP ROMs). These chips are a good way for medium-sized companies to enjoy the low cost of mass-produced ROMs without the risk of large volume commitments. Companies can keep a supply of blank PROMs in stock for as long as necessary, burning their contents at the last minute. Sometimes this is literally true: Fast-selling electronics goods are sometimes stored in the warehouse with a wire hanging from the shipping carton. The product receives its final programming just before it goes on the truck.

Erasable Programmable ROM

The next step in the cost-versus-flexibility scale is the erasable programmable ROM (EPROM). Unlike ROMs and PROMs, EPROMs can be erased if you have the right equipment. EPROMs are more expensive than either ROMs or PROMs, and they can't be used in some safety-critical equipment because of the possibility of erasure. Still, EPROMs are extremely popular in computers and other high-volume products where standards and features need to change from time to time.

EPROMs are manufactured and shipped blank, just like PROMs. Customers load data bits into them just the same way, too, using a PROM burner. The only difference between a PROM and an EPROM is that you can erase an EPROM if you expose it to ultraviolet light for long enough. Usually 30 minutes under a special lamp is enough to erase an EPROM and return it back to its original blank condition.

This violates our earlier rule about ROMs being permanent and not erasable, but EPROMs still qualify as ROMs. Because it takes half an hour or more to erase and reprogram an EPROM, these chips do not compete with RAMs, which can be erased and reprogrammed in a fraction of a second. Even though EPROMs can be erased, they're still nonvolatile; any data stored in an EPROM will last for years unless it's deliberately erased.

EPROMs have a small round window on the top of their package, shown in Figure 7.2, to let ultraviolet light through. The window allows light to shine directly on the silicon chip inside. The EPROM chip, unlike most chips, is designed to be sensitive to ultraviolet light, gradually losing its memory.

Figure 7.2. Erasable programmable read-only memory (EPROM) chips have a window in the top that exposes the silicon chip underneath. Shining an ultraviolet light through this window for a few minutes erases the data bits stored on the chip. After erasing, the chip can be reprogrammed with different data. Courtesy of Texas Instruments. Used with permission.

Electrically Erasable Programmable ROM

Electrically erasable programmable ROMs (EEPROMs) are an advancement over EPROMs because they can be erased electronically, instead of through exposure to ultraviolet light. This makes EEPROM chips easier to use in many systems. For example, an EEPROM can be permanently soldered onto a printed circuit board and still be erased without removing it, whereas a normal EPROM would have to be removed from the system and placed under an ultraviolet lamp. This makes EEPROMs more user friendly in PCs and other consumer items where the tools and the skills to remove and erase an EPROM just aren't there.

Typically for engineers, EEPROMs are often called E2PROMs, or "e-squareds." EEPROMs have many useful advantages over traditional EPROMs, but they never captured very much market share because they were quickly overtaken by flash ROMs, which are covered next.

Flash ROM

Flash ROMs are now the most popular type of erasable ROM (and no, erasable ROM is not really an oxymoron). Like EEPROMs, flash ROMs can be erased and reprogrammed completely electronically, without removing the chip from the system. This makes flash ROMs very useful in products for which a relatively naïve customer might be asked to erase and reprogram the chips without any specialized knowledge. MP3 music players and occasionally PCs fall into this category.

Where flash ROMs differ from EEPROMs is speed. EEPROMs are slow to erase but flash ROMs are pretty quick, as their name suggests. You can erase and reprogram an entire flash ROM in a few seconds, versus several minutes for a conventional EEPROM. For most consumer products, that difference has enormous psychological value. Customers are often nervous enough about reprogramming or updating the software on their products; getting it over with quickly alleviates a lot of tension.

Flash ROMs were originally much more expensive than EEPROMs, which were, in turn, more expensive than EPROMs, and so on. The price of flash chips has come down considerably in the 10 years or so since they were first developed because their volume has increased. Flash ROMs have now almost entirely replaced EEPROMs and are even encroaching on EPROM and PROM territory. The advantages of flash ROM's erasability, relative speed, and high volume make it nearly ideal as an all-purpose permanent memory chip.


Volatile RAM

The other major category of memory chips besides ROMs is RAMs. RAM chips store data bits just like ROM chips do, but with two major differences: RAM chips can be erased and reprogrammed almost instantaneously and the data stored in RAM chips is not permanent. RAM chips "forget" everything they're storing when you turn off their electricity. RAM chips are used in computers and other products that need lots of short-term memory storage.

RAM chips are inferior to ROM chips in almost every way, yet they are necessary because they work like electronic scratchpads. Even flash ROM chips take far too much time to erase and reuse to be practical for the main memory in a computer. RAM chips are more expensive and harder to use than ROM chips, but they're the most popular kind of memory chips made. The price of every new PC is determined, in part, by the spot price of RAM chips when the computer was built.

RAM chips come in two basic types: SRAM and DRAM. The initial S and D stand for static and dynamic RAM, respectively. Neither description is particularly useful to us here, and even the term RAM is confusing. Random-access is meant to indicate that a computer can access any bit stored in a RAM chip in random order. For example, it doesn't have to read out the bits in sequence, like watching a videotape from start to finish. RAM chips can provide any bit of data at any time, randomly.

Honestly, ROM chips can also read out data randomly, so RAM doesn't accurately describe the difference between them at all. Read-write memory (RWM) would be more descriptive, but harder to pronounce.

SRAM

SRAM chips are simpler to design, use less electricity in operation, cost less to manufacture, and are faster than DRAM. Overshadowing all these advantages, however, SRAMs have one major drawback: They can only store about one-quarter as many data bits as a DRAM chip. The capacity of both SRAMs and DRAMs increases year by year, but SRAMs are always a factor of four behind their DRAM cousins. Because of that, SRAMs are generally used only in products that run on small batteries (where SRAM's efficiency is valuable) or those that need to be very fast.

Unlike ROM chips, SRAM chips can store data as easily as they retrieve it. In fact, they can store data slightly faster than they retrieve it. This makes SRAM chips important for very fast computers. They are also used for the instruction cache and data cache inside microprocessor chips. An erasable ROM might be erased and reprogrammed with new data once per month, but SRAMs store new data thousands of times per second. SRAMs don't have to be erased all at once like EPROMs, either. They can change one bit of data while holding millions of other bits intact.

DRAM

DRAMs are the volume leader of the entire memory chip market. Computer makers and many consumer electronics products use DRAMs in enormous quantities because they have the greatest storage capacity for the money. SRAM chips might be faster and use less energy, but DRAMs are the cheapest way to get lots of erasable memory.

To the engineer, DRAMs have some drawbacks, but their economic advantages outweigh their technical shortcomings. For starters, DRAM chips use more electrical power to operate than SRAMs do. The difference can be dramatic (to an engineer, that is). Battery-powered products that run for hours with SRAM chips might run for only 20 minutes using DRAM chips. Laptop PCs, unfortunately, use DRAMs because of their lower cost per bit; SRAM-based PCs would have noticeably longer battery life but be far more expensive.

DRAMs also "forget" easily, a serious snag for a memory chip. In fact, the average DRAM can store data only for about one one-hundredth of a second, even if the power is on all the time. After that, it risks forgetting what bits it was storing. To prevent this, DRAM chips must have their memories refreshed about 100 times per second. This takes special circuits, and sometimes a separate chip, just to keep refreshing each DRAM's memory. All this requires even more electricity to operate.

DRAMs can't be used while they're refreshing, either. That means each DRAM chip is offline about 100 times per second, or about 5 percent of the time. These little timeouts aren't noticeable to the average person, but they complicate the design of every computer, which has to tolerate memory chips that sometimes work and sometimes just don't work.

DRAMs don't retain the contents of their memory when the power is turned off. This makes them volatile memory chips, like SRAMs. That's why most personal computers have a button or a menu option to shut down; it gives your PC a chance to copy the contents of its volatile memory chips onto the hard disk before the power goes away.


Memory Interfaces

For all the different kinds of memory chips in existence, there's no standard way to connect these chips to other chips in a system. Flash ROMs, EEPROMs, DRAMs, and SRAMs all connect in different and incompatible ways to microprocessors and other chips. Figuring out ways to make these chips all work together is one of the reasons electrical engineers get paid so well.

ROMs are generally used as low-speed devices, so the problem isn't so bad. Many products that use ROM chips aren't particularly performance sensitive, so getting data out of the ROM in a quick and timely manner often isn't important. RAMs are another matter.

RAMs, and especially DRAMs, are used mostly in computer systems where speed and low cost are paramount. It's important, therefore, to come up with a quick and reliable way to connect fast DRAMs to even faster microprocessors. Transmitting data bits back and forth between these two chips at high speed is a science unto itself, and many different methods have emerged. Most of these are arcane topics best suited for engineering conferences.


Future Memories

The need for electronic data storage will probably be with us forever, and if history is any indication, the demand for memory will grow at an amazing rate. The downward spiral in the cost per bit of memory has fueled an equal and opposite reaction by increasing demand. As soon as memory becomes affordable, we find ways to fill it up. The first Cray-1 supercomputer had a whopping (for its time) 8 megabytes of memory, the same amount as the first Palm Pilot handheld organizer. IBM's first PC came with 64 kilobytes (KB) of memory; now PCs have more memory than that embedded in their CD-ROM drives.

Memory chips have driven semiconductor manufacturing in many areas. The incessant pressure to reduce cost and increase storage capacity pushed DRAM makers to experiment with the first stacked transistors. Like apartment buildings in crowded cities, they started building upward, increasing capacity in three dimensions. DRAM makers also are the first to benefit from any factional improvements in photolithography that slightly decreases the size of transistors. The (almost) guaranteed large volume of DRAM sales encourages these companies to invest heavily in any technology that can increase their production capacity. Consumers benefit from a semiconductor race that keeps all the DRAM makers fighting for every advantage or any sliver of market share.

With memory makers scrambling for tiny advantages here and there, any truly momentous breakthrough would be a godsend. Storing data bits is pretty simple in concept, so researchers have experimented with numerous ways to completely reinvent the humble memory chip. Optical chips that use photons of light; three-dimensional arrays of silicon chips; iron-based chips that store data magnetically; subatomic phenomena that rely on quantum concepts of "spin" and "charm"—they've all been tried and tested. Eventually, some or all of these might lead to commercially viable products.

In the meantime, memory capacity will continue to rise as prices fall. The constant improvements in conventional semiconductor manufacturing that got us to this point show no sign of letting up. New hurdles present themselves, to be sure, but the forces of innovation prevail each time. The economic rewards for overcoming each set of technological hurdles ensures that the world's best and brightest forces are brought to bear. With no end in sight, the million-fold increase in memory capacity and million-fold decrease in cost should multiply for another few powers of 10.


Chapter 8. Essential Guide to Custom and Configurable Chips

In this chapter...

  • Overview of Custom Chips

  • Field-Programmable Chips

  • Custom ASIC Chips

  • Dynamically Reconfigurable Chips

  • Intellectual Property Licensing

  • Future Outlook for Custom Chips


Overview of Custom Chips

Over time, it has become possible for almost anyone to create his or her own custom chip. Instead of being limited to just multinational corporations with billions of dollars invested in manufacturing equipment, chip design is now within reach of the average college student or well-equipped home hobbyist.

These new dilettantes can't manufacture their own chips, of course. That still does require billion-dollar chip-fabrication factories. However, it is possible to design your own chip. To make it real, you can either have a big company manufacture it for you, or you can "burn" the design into a blank chip made for the purpose. Either way, it's an opportunity for the budding chip designer to see his or her creation in silicon.

Of course, there are trade-offs, and the trade-offs here have to do with cost, performance, and quantity. The more you're willing to spend, the faster your chips can go. The very fastest custom chips cost nearly $1 million to make, so they're obviously limited to serious customers only; home-brew hackers need not apply. However, if you're willing to sacrifice a little top-end performance, it's entirely possible to make one custom chip for about $100. Even serious companies often make dozens or thousands of prototype chips using low-cost means before committing big money to a high-end chip.

In this chapter, we review the half-dozen options available for making custom chips. We look at the cost, performance, and volume trade-offs required and take a peek into the future of custom chips.

About Custom Chips

Custom and customizable chips come in a lot of different types and categories. For our purposes, we can divide them into three classes. First, we look at field-programmable chips. These are the lowest cost, and lowest performance, option. Next, there are "hard" custom chips that offer maximum performance for high-volume customers willing to pay the considerable price. Finally, there is a new third class of dynamically reconfigurable chips that are just starting to make a mark on the market. If their promoters' claims are true, dynamically reconfigurable chips could be the wave of the future.


Field-Programmable Chips

Our first category of customizable chips are called field-programmable chips because they are programmed "in the field," meaning in the customer's office or laboratory. They could be programmed literally out in a field, but that wasn't on anyone's mind when these chips were being developed. Field-programmable chips are like blank slates on which customers can draw their own chip design. Like blackboard slates, these chips are erasable and can be reused for many different chip designs.

The category of field-programmable chips includes some specific types that are called by different names by their manufacturers. Some are called FPGAs, short for field-programmable gate arrays. (A gate array is a technical term for an earlier kind of custom chip, which is covered later in this chapter.) You might also hear them called LCAs, for logic-cell arrays, PALs, for programmed array of logic, or CPLDs, for complex programmable-logic devices. By and large, all these terms refer to the same general thing. Naturally, there are minor differences between the FPGAs from one company and the CPLDs from another, but they share more similarities than differences.

Field-programmable chips aren't really custom at all. They're mass-produced like any chip, but customers can customize them after they receive them. Like an Etch-a-Sketch, they're sold by the millions to happy customers all around the world. Each customer can then use it to create, erase, and re-create nearly any chip design he or she can imagine. With an Etch-a-Sketch, you're limited only by the size of the screen. With field-programmable chips, you're limited by the amount of silicon on the chip. Bigger field-programmable chips can hold bigger and more ambitious chip designs, but they also cost more money.

How can a mass-produced chip work like a custom user-designed chip? Field-programmable chips like FPGAs and CPLDs work by dicing up their internal functions and connecting them back together with microscopic fuses or switches. Blowing one fuse disconnects one tiny portion of the chip; leaving the fuse intact leaves that function connected. By carefully deciding which pieces to connect, and how, you can create virtually any electronic design at all.

The whole process is, strangely, a bit like needlepoint. The canvas backing for needlepoint supplies a regular grid pattern, and you essentially connect the dots using colored thread. One little x at a time, a picture slowly starts to emerge. In the same way, field-programmable chips provide a silicon canvas on which you can paint your chip design.

Pushing the analogy a bit further, field-programmable chips waste a lot of silicon the way needlepoint wastes a lot of colored thread on the back of the canvas. This makes FPGAs and similar chips more expensive than usual. It also means field-programmable chips consume more energy than other chips of the same size. Every part of an FPGA that's disconnected by a blown fuse is a part of the chip that's wasted because it's silicon that had to be manufactured, tested, and sold, but is never used by the customer. The ratio of used silicon to unused silicon (called the utilization ratio) thus becomes a big issue for customers who don't like paying for any more silicon than they have to. Typical utilization ratios for a big FPGA are about 35 percent to 50 percent. You're extraordinarily lucky if you actually use 75 percent of an FPGA.

Tech Talk

Technically, some FPGAs and CPLDs don't use fuses; they use antifuses. An antifuse works in the opposite way from a normal fuse, meaning that when you "blow the fuse" you're actually making a connection, not breaking one. Antifuses have some subtle technical advantages over fuses, and one big disadvantage. They use slightly less electricity, and because most of the fuses (or antifuses) in an FPGA are not connected, you don't have to blow as many antifuses to get the connection pattern you want. The big downside to antifuses is they can't be "healed" once they're blown, so the chip can't be erased or reprogrammed.

CPLDs tend to be smaller and less expensive than FPGAs. A small CPLD might have a few thousand transistors, cost about $15, and be about the size of a jellybean. A big FPGA will have several million transistors, cost more than $1,000 per chip, and be as big as a box of matches. Both types—and plenty of sizes in between—are very popular and sell by the millions.

Regardless of type, almost all field-programmable chips are erasable and reusable. In other words, you can "heal" their internal fuses to reset the chip to its original blank condition. This is a great boon to chip developers, who can experiment with different designs without fear of throwing $500 chips into the trash every couple of hours. Field-programmable logic is one of the best things to ever happen to young engineers-in-training.

Apart from their comparatively high cost through wasted silicon, field-programmable chips are also slow. It takes time (albeit, very little time) for electricity to pass through the patchwork of fuses that makes up a large FPGA. All that time adds up, so field-programmable chips are much slower than "real" ASIC chips designed and built from the ground up to perform the same function.

You might think this would make FPGAs useful only for small prototype runs or for experimentation. In reality, companies buy FPGAs by the thousands and include them in their own products. Even though these companies know they're paying a price and performance penalty for using field-programmable logic, it's still cheaper and easier than manufacturing their own chip. Unless you've got a million dollars to spend on development, field-programmable chips are your best alternative.

The field-programmable chip suppliers know this, and their business models rely on customer dependency and addiction. The story is always the same: A new customer buys one or two of the latest expensive FPGA chips thinking they'll use them just for development or a few experiments. Then they buy a few more for their other engineers. Before long, they're buying dozens for use in prototypes. When their product is finished, they need still more FPGAs to build the first production run, and down the slippery slope they go. It's too late to redesign the product around some other type of chip. Time to market is too precious to jettison the FPGAs (which work) and start over with a cheaper alternative (which might not work). After two or three years of this, the customer has consumed thousands of expensive FPGAs and wonders how this compulsion began.


Custom ASIC Chips

For companies with the financial and technical wherewithal, an ASIC is the product of choice. These are "real" custom chips, manufactured using the best process technology to deliver the best performance and lowest power consumption. ASICs aren't generic like field-programmable chips, although they are mass-produced, but only for one customer. An ASIC is the best opportunity for a moderately funded company to design, own, and sell its own chips.

In this chapter, we use ASIC as a catch-all term for a group of subtly different products and processes that all solve the same problem. ASIC stands for application-specific integrated circuit, which is meant to suggest that the chip is designed for one specific application or product. That's usually the case, although it's not a requirement. This group also includes products like ASSP (application-specific standard product) and SoC (system on a chip) devices. The differences among these terms are minor, and are covered shortly, but for now we call them all ASICs.

To ASIC or Not To ASIC

The decision whether or not to make an ASIC comes down to cost: Will you realize a good return on your investment? ASIC development is very expensive, so it's a project that's never undertaken lightly, but the benefits can be great: You get exactly the chip you want, in high volume, and all to yourself. You never have to share your ASIC chip with your competitors. Some of today's most popular products, such as cell phones and laptop computers, wouldn't be possible without custom ASICs.

However, the cost of developing an ASIC can make strong managers tremble. As a rough estimate, plan on spending $1 million before the first chip is ready. That's a big investment before you even know for sure if the chip will work. If not, you have to decide whether to pour more time and money into fixing it and making a revised chip. If it does work, you get to decide how much additional money to pour into mass-producing them.

The cost equation for ASICs is a bit schizophrenic. Almost all the cost is up front, tied up in development. After that initial investment, the unit cost of production is relatively cheap. The more chips you make, the more you can amortize the up-front costs across multiple units. Thus, the key to rationalizing an ASIC project is guaranteeing volume production. As a rough rule of thumb, most companies would not consider an ASIC unless volumes were forecast to exceed 50,000 units. At around 250,000 units an ASIC is probably a safe bet, and if you can sell 1 million units, it's a sure thing.

The costs for an ASIC are exactly the opposite as for an FPGA or other field-programmable chip. FPGAs have no up-front development costs at all, but their unit price is comparatively high. ASICs have very high up-front costs but low unit prices (disregarding amortization). A good business manager would then look at the volume cross-over point to see whether an ASIC or an FPGA makes financial sense. That cross-over changes, of course, for every customer, market, and chip type. Plenty of companies have made the wrong decision, buying FPGAs long after they could have amortized an ASIC, or developing an ASIC when the volumes can't support it. ASIC development is a prestige job among engineers and a mark of respect among electronics companies, so there's often some subtle pressure from within the ranks to create an ASIC even if the numbers can't strictly justify it.

Designing an ASIC

ASICs are designed like any other type of complex chip, using the tools and techniques described in Chapter 3, "How Chips Are Designed." A team of engineers will work for several months plotting out how the chip will work, then moving on to the detailed design. A number of these engineers will be tasked with double-checking and verifying that everything their colleagues do is correct. The team can't afford to design a bad chip, and waiting until the first one is built to test it is too risky. ASIC teams need to assure themselves that every transistor, resistor, and capacitor in their chip is exactly where it should be before they commit their creation to silicon.

Once the ASIC design is finished, the engineers will tape out their chip. Today, this is largely a ceremonial event, but it used to be a big deal. The tape of a new chip design is the final design plan, like the blueprints for a new skyscraper. It's not really a tape any more, and creating the final plans involves pushing a button, but it's still an emotional milestone for the entire design team. Many of the engineers might receive bonus pay if they tape out ahead of schedule.

Between the time they tape out and the time the first chip arrives from the foundry—a period of several weeks—the engineers bite their nails. There's nothing more they can do on their million-dollar project except wait and wonder if it will work.

Full-Custom Designs

A full-custom ASIC design is just what it sounds like: a completely custom chip designed by, and built for, one company. This is easily the most expensive way to make a custom chip, but it's also the most flexible and the only way to achieve the very highest levels of performance. Full-custom ASICs used to be rare but the tools, talents, and technology have all improved to the point where medium-sized electronics companies can create an ASIC every few years. Full-custom ASICs are still not the most common method of making custom chips but they're the path for top-notch performance.

Standard Cell Designs

Ideally, the ASIC design engineers would have free rein to design anything they want. Realistically, however, there might be cost and time limits on what they can do. It's also likely that some chip, somewhere, is at least a little bit similar to what the design team envisions. To save time and money, and to take advantage of existing technology, they can create a "standard cell" design. A standard-cell ASIC sacrifices a little flexibility in return for easier development and lower costs.

Standard-cell chips are a bit like FPGAs in that the custom chip is implemented using an array of already existing functions, like a mosaic made of silicon tiles, called standard cells. It's a modular approach, although a fine-grained one. Standard-cell chips are cheaper than full-custom ASICs because they can be manufactured using semistandard silicon wafers that are partially completed. These require only a little customization during manufacturing, so they're cheaper to produce. They're also far easier and less risky to design because the engineers are not creating everything from scratch. Standard-cell ASICs offer a compromise between ultimate flexibility and moderate cost, and most ASICs are now designed using this method.

Gate Array Designs

Gate array ASICs are another alternative to full-custom or standard-cell ASIC design. Like standard cells, gate array chips trade flexibility for simpler manufacturing and lower cost. Gate arrays are not as finely grained as standard cells, which makes them less flexible. Designing a gate array ASIC is like designing with Lego blocks: They can be connected in innumerable different ways, but the result is always a bit blocky.

Like standard cells, gate array ASICs are built using partially completed silicon wafers that are customized late in the manufacturing process. Chips designed using gate array techniques are a bit bigger in silicon area than standard-cell ASICs (and a lot bigger than full-custom chips), which makes them more expensive to manufacture.

Building an ASIC

Third-party semiconductor factories called foundries manufacture the ASIC chips. Foundries are in the business of providing their manufacturing services to any and all comers. Any customer designing an ASIC can pay for the services of a foundry. The foundry business is competitive, and foundries compete on price, availability, delivery time, performance, and all the other things that make a spirited and healthy market. Some foundries specialize in low-cost manufacturing (although your chips might not be the fastest), whereas others have a reputation for leading-edge technology (although you might have to wait in line and pay premium prices).

ASIC design teams generally have to choose their foundry partner midway through the design process. Some of the chip's design details will depend on who manufactures the chip, and where. These details have to be pinned down before the design is finished.

After the design team tapes out, they send the "tape" (really a big e-mail or a CD-ROM) to the foundry. The foundry might start manufacturing the chip right away, or it might wait until another customer's chips are finished. You might have to wait for weeks, or even months if business is good, before your chip gets to the front of the production queue. After that, it's a matter of a few weeks before the finished chips come out the other end of the production line.

Foundries produce large-volume orders all at once to minimize the down time of their expensive equipment. Smaller orders sometimes have to wait behind larger (and presumably, more lucrative) ones. Very small orders of a few hundred chips will be produced on a shuttle run, which is a collection of different customers' chips processed together on one batch of silicon wafers. Shuttle runs are a compromise for both the customer and the foundry. All the various chips must obviously be compatible with exactly the same production process, because they'll all be processed at once. This means no mixing fast chips with slow chips. Foundries don't like shuttle runs because they're labor intensive and don't produce much revenue, but they're the only way to service small customers, and small customers might one day become big customers.

Each ASIC chip will be marked with your own company's logo, not the foundry's. Foundries are silent partners in ASIC development, and they like to preserve their customers' anonymity as well as their own. There's no easy way to tell what foundry manufactured a particular chip or, in fact, whether it was made at a foundry at all.

Once the chips are ready, they're shipped back to the customer who designed them. This is an exciting day for the ASIC design team and a nervous one for their managers. In Silicon Valley, this event frequently falls around early springtime, because ASIC teams often cram to finish their design before end-of-year deadlines.

Testing the very first chip is sometimes called the smoke test, to see if the chip smokes. Black smoke or white smoke, it's all bad. The wry humor among engineers would have us believe that all silicon chips really run on smoke, not electricity. If you let the smoke out of a chip, it stops working, so obviously, it must be smoke-powered.


Dynamically Reconfigurable Chips

A new kind of custom chip has recently become available. The technology is still a little experimental and some of the initial claims seem a bit wild, but if these dynamically configurable chips live up to even some of their promise, they might become a big part of the overall microprocessor and custom-chip businesses.

The concept is called dynamically reconfigurable logic, although it's known by many other names as well: Reconfigurable computing, adaptive logic, and self-adaptive processing are all terms that are bandied about. Whatever you call it, the idea is certainly interesting.

About Dynamically Reconfigurable Logic

One thing all ASICs have in common is that once the chip is built, it can never be changed. Because it takes nearly a year to design an ASIC, that's a difficult forecasting job for somebody. Technology can change, markets can change, and competitors can do shifty things in that time. However, all chip makers face the same problem. Making chips is no different from making cars: Once the product rolls off the assembly line, it's done.

Field-programmable chips alter that equation, allowing engineers (or even sophisticated customers) to reprogram the chips after they've shipped. FPGAs were thus supposed to herald a new era of fluid logic, chips that change over time to meet changing conditions. With few exceptions, though, that doesn't happen. Chip designers almost never redesign an FPGA once it's out the door and in the customer's hands. All those field-programmable chips might just as well be fixed silicon.

Dynamically reconfigurable logic aims to change all that. These are chips designed from the outset to change, and change frequently. It takes about a minute to erase a big FPGA and reprogram it, but dynamically reconfigurable chips can change in almost no time at all. Thousands or millions of times each second, these chips can change their stripes, becoming different chips at different times.

The idea is certainly tempting. A dynamically reconfigurable chip could act as a kind of universal logic chip, performing whatever task is required. One moment it's a microprocessor, the next moment it's a network chip, and after that it's a graphics accelerator. The companies making these chips have names like Chameleon and Quicksilver that emphasize their mutability. At the extreme, products could be designed with nothing but one big chip in the middle. Dynamically reconfigurable chips could be cheaper than almost every other kind of chip because one dynamic chip could replace dozens of different old-fashioned, fixed-function chips.

At least that's the theory. The reality appears to be creeping toward that point, but the hurdles are still significant. For starters, customers are having a hard time grasping the concept. It's so outlandish that newcomers have a hard time imagining how these chips might be used. It also requires engineers to design multiple different chips and share them in a single physical package, something no one currently is trained to do. If the dynamic chip is also a processor, which it often is, how do you program it? New programs and programming tools have to be devised to deal with a processor that changes its instruction set, registers, buses, and resources moment by moment.

Finally, it threatens the status quo. Engineers are like members of any other profession, so they tend to protect their skills and defend their hard-fought experience. Something entirely new upsets the apple cart, turning all the engineers on a team into inexperienced beginners. Those with the most experience will naturally also be in the position of most authority and put up the most resistance.


Intellectual Property Licensing

ASICs and field-programmable chips are closely tied with another concept called intellectual property. Semiconductor intellectual property (IP) is simply the idea of reusing existing chip designs in new chip designs. Like magpies, chip designers like to borrow and reuse what they can from earlier chips rather than designing every single function of a new chip entirely from scratch. Actually, it's not even a question of preference anymore; there's simply no time to design a chip completely from scratch.

An architect designing a skyscraper would no sooner design individual bricks and plumbing fixtures than an engineer would design each transistor or logic gate. It's only sensible to use preexisting fixtures. Like an architect, a chip designer might want to reuse large pieces from some previous design—an entire microprocessor, perhaps, or a few thousand transistors from a particularly efficient communications chip. This concept is called design reuse among engineers, and the business of supplying reusable functions and features—the plumbing fixtures for silicon skyscrapers—is called intellectual property licensing.

There are several companies that do nothing but create and sell these silicon functions. They create partial chip designs that are meant to be included in larger projects, like designing windows for office buildings. Unlike the window makers, these semiconductor IP companies don't deliver any physical or tangible product. They merely share their design blueprints under license. Like architects, IP companies are in the business of selling what they know, not what they make.

The IP business model has been compared somewhat uncharitably to the world's oldest profession. Both are service industries with no cost of goods, low overhead, no inventory, and the same services that are sold to one customer can be sold again to another. Prices are set by market conditions and the merchandise does not age gracefully. In busy times the business is very profitable. It may be labor-intensive, but the margins are good.

Those in a more benevolent frame of mind compare IP licensing to retail franchises. Retail stores and chain restaurants aren't usually owned by the parent company; they're franchised to licensed operators who follow an established corporate recipe in return for a share of the revenue. Closer to the technology front, Dolby Laboratories licenses its noise-reduction technology to makers of cassette tape players and Adobe's PostScript technology appears in most laser printers. Neither company manufactures anything, yet their brand name and technology—their IP—make someone else's products more valuable.

Among ASIC and FPGA designers, IP is a necessity. It's impossible to design a 10-million-transistor chip from scratch in a reasonable amount of time. It's also impossible to verify that the entire thing works unless major portions of the chip have been tried, tested, and guaranteed by someone else beforehand. The bigger and more complex the ASIC design, the greater the need for outside IP.

The most valuable type of semiconductor IP today is microprocessors. Few ASIC designers want, or need, to design their own CPU. Besides, choosing an existing microprocessor makes the ASIC compatible with that microprocessor's software. A new in-house microprocessor would have no industry support at all, but a popular microprocessor licensed from a major vendor might come with piles of software behind it. Nearly half of all the 32-bit microprocessor chips sold in 2001 were based on licensed designs.

IP Licensing Business

The demand for semiconductor IP is great, but selling IP can be an uphill battle. You're selling to fellow engineers, and engineers have a tendency to believe that anything you can do, they can do better. This is known as the Not Invented Here (NIH) syndrome. Anything that was not invented here is assumed to be inferior, and the NIH syndrome runs high among chip designers who might have, well, a chip on their shoulders.

At the end of the day, IP really provides your customer with two things: the chance to save time and the chance to blame somebody else. Your customer's engineering team probably could duplicate your IP given enough time, but why should they? Using outside IP alleviates the burden of designing every part of a new chip from scratch. Second, outside IP doesn't need to be tested as meticulously as new parts of the chip do. That in itself can save lots of time. If something doesn't work, the ASIC design team can always blame the outside IP supplier.

Making a profit in the semiconductor IP business takes a long time, if it ever happens. It's tempting to want to sell a few IP licenses and then relax on the beach until the royalties pour in while dutiful attendants bring tall drinks and wave palm fronds. Sadly, the IP money train takes a long time to build up steam and get rolling.

Creating semiconductor IP is like making movies: It's all sunk cost before you can sell the first ticket. The designs have to be complete and tested before they can be licensed to others. Once a customer signs a license and you deliver the goods, you'll wait more than a year before the first royalty check arrives. During that time every IP company needs to survive on its cash in the bank. First comes the breathtaking investment, then comes the long wait for revenue.

IP Revenue Streams

IP companies get their revenue from two or three sources, namely the license fee, royalties, and maintenance payments (see Figure 8.1). Almost all IP suppliers charge an up-front license fee and royalties. The regular maintenance payments might be optional.

Figure 8.1. Most IP payment schedules involve an initial license fee followed by eventual royalties. Regular maintenance payments might also be due.

As the figure shows, the commercial relationship starts with the initial license fee. This is shown as a lump sum, although it is sometimes paid in installments and sometimes after certain development milestones are achieved.

After the license fee comes the royalties, maybe. Royalties aren't due until the customer produces chips, which might never happen. Designing an ASIC and putting it into production takes 12 to 18 months, so this is the soonest an IP company could expect to see royalties. It's possible the IP vendor might never receive any royalties at all if the customer's ASIC project is canceled, the company is acquired, or the chip just doesn't work. Lots of IP companies make the grim assumption that half of their customers will never pay them any royalties whatsoever.

Royalties can be calculated in a lot of different ways. Some IP companies charge their licensees a flat rate per chip, some charge based on chip price or volume, and some charge over time. Naturally, vendor and customer rarely agree on the most equitable terms, at least at first. IP vendors like to charge high up-front license fees (because so many chips never produce royalties), yet still reap the benefits of the occasional million-seller. Licensees generally prefer royalties that taper off over time or volume, taking advantage of economies of scale and the ever-decreasing cost of production. Licensees frequently agitate for royalty caps after a certain volume or royalty limit, something IP companies never agree to.

Finally, some IP firms charge customers a monthly maintenance or support fee, which generally entitles them to free upgrades to the IP they've licensed. Customers might also get preferential treatment for hotline technical support.

IP Summary

IP has become the grease lubricating the gears of chip design. The free exchange of designs (free in the sense of liberte, not gratis) has enabled a new class of business for IP suppliers and for small chip companies that can now consider designing their own chips. It doesn't require an enormous team of hardware engineers trained in every discipline of manufacturing, design, and testing to create a new chip. Startup companies can license most of the basic subcomponents of their "dream chip" and create the rest themselves. They can concentrate on adding value through original invention, not on redesigning semiconductor wheels.

To the ASIC design teams, IP is more of a time-saver than an important technology, per se. Very little semiconductor IP is so unique or innovative that it couldn't be duplicated. However, the hurry-up pace of electronics doesn't tolerate wasted effort. If two-thirds of a chip design can be bought ready-made, then two-thirds of its development time can be slashed from the schedule. Outside IP also provides the not inconsiderable benefit of support. Anything licensed from the outside is presumed to work and is someone else's problem. The responsibility for anything designed in-house remains squarely in-house.

We've already passed the point where it's impossible to design an entire chip alone (at least, an economically interesting chip). Even a team of engineers working together can't design a 50-million-transistor chip from scratch and finish it soon enough to be worth the effort. They need to reuse part of the design, even if it's their own material they're reusing. As transistor counts increase, so does the need to reuse or purchase larger and larger blocks of IP. Large chips are becoming like patchwork quilts, with pieces snipped and cut and borrowed from various sources. Even though some of the pieces might be old, the quilt is still original.


Future Outlook for Custom Chips

The genie is out of the bottle. Once it became possible to create custom chips, there was no going back. Now the ASIC business generates tens of billions of dollars per year, a significant part of the overall semiconductor economy. Just as important, custom and customizable chips have enabled new kinds of products, and allowed products to get to market faster. Custom chips complement the mass-market chips produced by big chip companies the way tailored outfits complement off-the-rack clothes.

Yet for all the rising popularity of custom ASICs, some hurdles are fast approaching. Ironically, the very advances in technology that allowed custom chips to exist are now pricing them out of reach. Before, it was technologically impossible to make custom chips; now it's just unaffordable.

New foundries cost more than $1 billion to construct, and many millions more to upgrade and refit every few years. This puts an enormous burden on every foundry to run at maximum capacity and to produce only the most profitable chips. The economics of chip production are such that overhead costs are huge but incremental costs are negligible. Therefore, volume is key, and that works against ASIC customers.

ASIC customers are like boutique shoppers, but they don't want to pay boutique prices. A high-volume ASIC (e.g., 1 million units) can easily pay for itself, making both the ASIC customer and its foundry partner happy. However, as volumes decrease to more reasonable and achievable levels, the financial picture darkens. The overhead burden is amortized across fewer chips, making each one more expensive. Worse, foundry operators don't like to change their tooling for small production runs, making small customers that much less attractive. Yet foundries need volume, so they can't afford to turn too many customers away.

The situation worsens with every new generation of semiconductor technology. Not only do the foundries and their exotic equipment get even more expensive, the chips they produce get smaller and faster. Faster is okay—everybody likes that; but making chips smaller can be counterproductive. Small chips mean more chips per wafer, so fewer wafers are needed to satisfy a customer's entire production requirement. Five or 10 wafers can produce tens of thousands of working chips, which might be all the customer needs for a year. Yet that small number of wafers is hardly worth the effort for a foundry operator. It's hard for their automated systems to track such a small order and it's awkward to reset the tooling so frequently. However, this appears to be the wave of the future. We've gotten too good at manufacturing leading-edge chips. We can produce so many of them at once that anything less than about half a million pieces seems hardly worth the effort. So we come full circle: ASIC design is relegated to the rich and famous, with smaller companies priced out of the market, forced to make do with off-the-rack chips.

All of this is good news, however, if you sell field-programmable chips. Your chips are mass-produced, so volumes are high and production is smooth. There's no customization, retooling, or tracking required for each customer, either. They do all that on their own. All you have to do is keep producing FPGAs and CPLDs that your customers can use to realize their dreams of a (semi-) custom chip.

A few of the larger FPGA vendors have also started offering IP that's tailored to their particular brand of field-programmable chips. This is a parallel effort with the commercial IP vendors, who focus almost entirely on full-custom. ASIC customers (because the volumes are higher and the license fees are easier to justify). FPGA-specific IP naturally helps customers design more complex FPGA-based products in less time. Not incidentally, it also ties the customer to a particular FPGA vendor, as one vendor's IP won't work with a rival vendor's FPGA chips. This represents a sound marketing strategy.

FPGA-specific IP doesn't generate royalties, however. It usually doesn't bring in licensing revenue, either. Customers are already frustrated by the comparatively high cost of FPGA chips; they'd balk even more if they had to pay royalties on top of that, and the whole point of using field-programmable chips is to avoid the sky-high cost of designing an ASIC, so up-front license fees are also greeted with grim looks.

As field-programmable chips like FPGAs and CPLDs get faster and more capable, and as the costs associated with ASICs continue to increase, more customers will flock to the field-programmable alternative. It's a compromise between mass-produced volume economics and customer-specificity, but that's a trade-off many companies are willing to make, as if they had a choice. Slowly, these traditional field-programmable vendors might start to adopt some features from the dynamically reconfigurable proponents, moving this interesting technology into the mainstream.


Chapter 9. Theory

In this chapter...

  • Digital and Binary Concepts

  • Gates and Logic Functions

  • How Transistors Work

  • About Electrons and Electronics

This chapter is optional. It provides an extra helping of underlying explanation and theory behind what you've read in the other chapters. If you're interested in more about how computers, chips, semiconductors, and electronics work, please read on.


Digital and Binary Concepts

We're all used to counting up to 10 on our fingers. We know that there are 10 digits, from 0 to 9, and after 9 comes 10. It's so obvious even little children understand it. But what if everyone around the world had fewer fingers, say, four on each hand? Would we all count differently?

We probably would. We'd likely have just eight digits, from 0 to 7. What comes after 7? If you guessed 8, try again. When you have only eight fingers to count on the number that comes after 7 is 10.

If that seems weird, watch how the odometer in your car works. After you drive 9 miles, the odometer rolls over to 10. And after you've driven 99 miles it rolls over to 100. Obvious, right? The odometer rolls over every time it runs out of digits. The number 9 is the last digit it knows, so every time you add another mile it has to change the 9 back to a 0 and then increase the number beside it by one. In grade school we called that "adding one to the tens column."

The system works just the same way no matter how many digits, or how many "fingers," you have. If 7 is the last number your odometer knows, it will roll over from 7 to 10. Eight miles later it will roll over from 17 to 20, and then from 27 to 30, and so on. After 77 comes 100. We're accustomed to writing the numbers 8 and 9 because we happen to have 10 fingers. If we'd all been born with eight fingers the numbers 8 and 9 would never have been invented and this system would seem perfectly natural.

Here comes the tricky part. What if you had only two fingers? With only two digits, you'd be limited to the numbers 0 and 1. Your odometer would be rolling over almost constantly because after 0 comes 1, but then after 1 comes 10. In fact, with a two-number system counting from 0 up to 8 would look like this: 0, 1, 10, 11, 100, 101, 110, 111, 1000. Yes, that last number is really eight, not one thousand, in the two-number system.

As you've probably figured out by now, computers and other digital electronic products all use this two-number system. They're surprisingly limited when it comes to counting. Unlike most of us who have 10 fingers to count on, digital electronic systems have only two.

You've probably also guessed that this odd two-number system is called binary. The reason electronic systems use binary numbers instead of our familiar 10-number system is because they rely on electricity for their "fingers." A small amount of electric voltage on a wire or in a chip is a 1; if there's no voltage it's a 0. Programmers, mathematicians, and other software people call this system binary. Electrical engineers, chip designers, and other hardware types call it digital. Digital or binary, it means the same thing: a system of counting that uses only two numbers, 0 and 1.

Tech Talk

The word digital comes from the Greek word for finger. In fact, we sometimes call our own fingers digits. Binary also comes from a Greek word meaning one-half or something that has two parts. Biathlon, biennial, and bilingual all come from the same Greek root as binary.

Table 9.1 starts you off with the first 16 numbers written out in both the binary system and our more familiar system with 10 numbers. Binary numbers obviously take more space to write than "normal" numbers because each digit is less powerful, so to speak. It's really the same number in both columns; they just look different. By the same token, Chinese calligraphy takes less space to write than English words because the Chinese characters are more compact. They say more with each character. Yet both English and Chinese newspapers can say the same things; they just look different.

As funny as it looks, the binary system of numbers is just as useful and just as powerful as our own. There's no limit to the size of binary numbers; infinity is still infinity, no matter how you write it. Computers use binary numbers to balance our checkbooks, play games, and surf the Web. Unless you're a computer programmer, you'd never notice your PC was using such a strange system of numbers. If you are a computer programmer, you quickly become accustomed to this alternate number system, like learning to read a second language.

The binary, or digital, system was chosen by the early computer engineers because it is so easy to create using electricity. Simply passing a small voltage down a wire is like sending the number 1. More wires creates more number positions, so five wires can send five-digit numbers from 00000 (zero) to 11111 (thirty-one). Twenty wires can send even bigger numbers, and so on. As we saw in Chapter 6, "Essential Guide to Microprocessors," a 32-bit microprocessor chip uses 32 wires at a time to store, send, and receive numbers.

Table 9.1. The first 16 numbers, from 0 to 15, in both binary and our more familiar "decimal" or base-10 system of counting. Both columns show exactly the same numbers written different ways.

Binary

Decimal

0

0

1

1

10

2

11

3

100

4

101

5

110

6

111

7

1000

8

1001

9

1010

10

1011

11

1100

12

1101

13

1110

14

1111

15


Gates and Logic Functions

The binary/digital system explains how numbers work, but how do chips do things? When you turn the power on, how does a communications chip communicate? Why does a graphics chip make graphics? How does a microprocessor decide when to beep or how to run a word processor?

Deep down, all these chips are amazingly, stupendously stupid. They are not endowed with any uncanny form of intelligence or magical powers. They are just very carefully and laboriously built up from the most basic building blocks by patient and talented engineers. It's the intelligence of the engineers, not the chips themselves, that is impressive.

All digital chips, from memories to microprocessors and everything in between, are built up from just four basic functions called logic gates, plus memory. Like four different shapes of Lego blocks, these four basic gates can be combined to create virtually anything. High-end microprocessor chips contain more than a million of these gates, like a million Lego blocks. Although the individual blocks themselves aren't particularly impressive, the million-block creations certainly can be.

Explaining how to combine a million of these gates is a subject for a four-year engineering degree. Explaining how the individual gates work is the subject of our next section.

Logic, Binary, and Digital Concepts

Gates, as we said, are the simplest kind of digital electronic function. (Analog chips have different functions.) They're one step up the evolutionary ladder from transistors, like bricks compared to mud. Silicon makes transistors, transistors make gates, and gates make interesting digital chips like microprocessors and memories.

Gates come in four basic types, which we review one by one. Each gate is designed to perform one simple "logic" function. Logic functions are not like math, not like adding or subtracting. Logic functions are more like "if-this-happens-then-that-must-happen" type of situations.

Logic problems deal with concepts of true and false. Chips, of course, have no such civilized philosophical concepts as truth and falsehood; those are just nice words that we use to label the two conditions that logical gates can manage.

Two conditions? If that sounds to you a bit like the earlier discussion of binary and digital concepts, you're exactly right. The 0 and 1 from binary numbers are the same as true and false conditions of logic gates. It's all one and the same. Software programmers call it binary, hardware engineers call it digital, and logic specialists call it—are you ready?—Boolean algebra.

Regardless of the terminology, it all boils down to electricity passing through a wire. To a programmer, that small electric current represents the number 1 and the lack of current is the number 0. To an electrical engineer, that same electrical current would be called an asserted signal; no current is a negated signal. To someone using logic gates, that electrical current is the condition "true" and the lack of current is the condition "false." They're all just applying different human concepts to the same physical phenomenon as a handy way to grasp and understand what's happening.

Tradition says that the binary number 1, the digital concept of asserted, and the logical value true are all the same thing. Likewise, 0 is the same as negated, which is the same as false. We'll use that notation throughout this chapter.

NOT Gate

The simplest gate is the NOT gate, also called an inverter. It has just one input wire and one output wire. The electricity coming into the NOT gate on the input wire determines what will happen on the output wire. The NOT gate follows a very simple rule to make this happen. It couldn't be easier. If the input wire is true (i.e., if it is carrying an electric charge), then the NOT gate makes its output wire false (shuts off the electric charge). On the other hand, if the input wire is false (no electricity) then the NOT gate makes its output true (electricity).

Table 9.2 shows how this works. In the table, 1s represent true and 0s represent false. The NOT gate merely does the opposite of whatever is happening on its input wire. In a sense, it turns the electric current upside down. In logical terms, it converts true to false and false to true. In digital terms, it converts assertion to negation and vice versa.

Table 9.2. An inverter, or NOT gate, is the simplest of logic functions. The output is simply the opposite of the input.

Input

NOT Output

0

1

1

0

NOT gates are very simple for engineers to build from just four or five transistors. NOT gates also work very fast, processing their input and asserting or negating their output in less than a nanosecond. That is, electricity passes though the NOT gate in less than one-billionth of a second, or about the time it takes light to travel 6 inches.

AND Gate

Apart from the NOT gate, most gates have two wires going into them and one wire coming out. This opens up the possibility for the gate to make a simple decision based on its two input wires. The electricity coming into these two input wires determines what will happen on the output wire.

When you have two inputs, there are only four possible combinations those inputs can be in. You can have both inputs false; first one, and then the other input can be true; or both can be true. Once again using the numbers 1 and 0 to represent true and false, those four combinations can be written as 00, 01, 10, and 11. That's the notation used by electrical engineers and computer programmers, so we use it here as well.

Table 9.3 shows what an AND gate will do under those four conditions. An AND gate is called that because it only asserts its output if the first input and the second input are both true. If either one is false (negated), the AND gate negates its output wire. You could say that an AND gate detects unanimous inputs.

Table 9.3. A two-input AND function. The output of the AND gate is true if and only if both of its inputs are true.

Input A

Input B

AND Output

0

0

0

0

1

0

1

0

0

1

1

1

Figure 9.1 shows the same function drawn a different way. Table 9.3 is called a truth table because it treats the four conditions as true or false. Figure 9.1 is called a waveform diagram and it shows the inputs and the outputs as high or low lines that change over time. These diagrams look a bit like heart monitors on a hospital EKG machine. Unlike with those machines, a low, flat line is no cause for concern.

Figure 9.1. This is the same two-input AND function shown in Table 9.3, drawn graphically. The high levels indicate true, asserted, or electrically charged wires. The low levels indicate false, negated, or discharged electrical wires. All four possible input combinations are shown from left to right.

Gates can have more than just two inputs. Table 9.4 shows how an AND gate works if it has three inputs. With three inputs, there are twice as many possible combinations of inputs, and all eight of these conditions are shown in the table. As you can see, the three-input AND gate asserts its output only if all three of its inputs are all true. This is logically the same as the two-input AND gate, but with more inputs. Just as in real life, the more inputs you have, the harder it is to reach a unanimous decision.

Table 9.4. A three-input AND gate works like the simpler two-input version. All three of the inputs must be true before the output will be true.

Input A

Input B

Input C

AND Output

0

0

0

0

0

0

1

0

0

1

0

0

0

1

1

0

1

0

0

0

1

0

1

0

1

1

0

0

1

1

1

1

OR Gate

An OR gate asserts its output if one input or the other is asserted. This function is shown in Table 9.5 and in Figure 9.2. You could say that an OR gate detects and collects any true inputs. If even one input to an OR gate is true, its output will also be true. Like pulling on the cord to signal a bus stop, one asserted (or assertive) input is just as good as a dozen.

Figure 9.2. The same two-input OR function shown graphically. An OR gate is the logical opposite of an AND gate, asserting its output in exactly the reverse pattern.

Table 9.5. A two-input OR function. The output of the OR gate is true if either of its inputs is true.

Input A

Input B

OR Output

0

0

0

0

1

1

1

0

1

1

1

1

Gates have no concept of time; they act on what their inputs are doing right now. If an input wire suddenly changes state (e.g., from true to false) the output of the gate changes right afterward. There is an infinitesimally short time delay between when an input changes and when the gate changes its output in response. This is called the propagation delay, and it is usually measured in billionths of a second. As semiconductor manufacturing progresses, this time delay gets even shorter.

Exclusive-OR

An exclusive-OR (XOR) gate is subtly different from a normal OR gate. If you read down the Output column in Table 9.6, you see that the XOR's output pattern is 0110, instead of 0111 for the OR gate. The only difference between the two is in the last condition, where both inputs are true. An XOR gate asserts its output when one or the other of its inputs is true, but not when both are true at the same time. You could say an XOR gate detects disagreement. Like a nightclub bouncer preventing two feuding celebrities from entering at the same time, an XOR won't open its gate if both inputs are present together. An XOR tells you when its inputs are different.

Table 9.6. A two-input exclusive-OR (XOR) function. An XOR is similar to an OR gate except that both inputs must be different. Either one or the other, but not both, must be true for the output to be true.

Input A

Input B

XOR Output

0

0

0

0

1

1

1

0

1

1

1

0

You can have XORs with more than just two inputs. Three-input and more-input XORs are just more exclusive versions of our two-input example (see Figure 9.3). On a five-input XOR the output would be true if exactly one of its five inputs was true. If all the inputs are false, if they're all true, or if more than one is true, then the output will not be true.

Figure 9.3. A two-input XOR function. An XOR gate is similar to an OR gate, but negates its output when both inputs are true.

Inverted Gates

Each of the gates we've just seen has a twin. They are the inverted, or negated, versions of AND, OR, and XOR gates called NAND, NOR, and XNOR gates, respectively. For instance, the NAND gate works just like a normal AND gate except that its output is reversed. Any time an AND gate would output true, the NAND outputs false, and vice versa. In the physical world, NAND gates are built by simply attaching an inverter (a NOT gate) to the output of a normal AND gate.

Table 9.7 and Figure 9.4 demonstrate how an inverted XOR gate would work. Reading down the Output column you can see that the XNOR's outputs are just the opposite of the XOR's output that was listed in Table 9.6. It's 1001 instead of 0110. That's simply because there's now an inverter stuck onto the output of the XOR to make an XNOR.

Figure 9.4. A negated XOR (XNOR) gate. This is a normal XOR gate with an inverter added to its output, making its output the opposite of what a normal XOR gate's would be.

An XNOR gate detects agreement. Its output is true only if both of its inputs are identical, either both true or both false.

Table 9.7. A two-input exclusive-not-OR (XNOR) function. The output of an XNOR is the opposite of a XOR, but otherwise works the same way.

Input A

Input B

XNOR Output

0

0

1

0

1

0

1

0

0

1

1

1


How Transistors Work

Transistors are the most basic form of semiconductor construction as, as we saw before, the basic mud from which the towering spires of microprocessors, memory chips, and logic gates are built. The path and pace of semiconductor progress are measured by the speed and size of individual transistors, which long ago ceased to be visible to the naked eye. Today's transistors can be packed more than 10 million to the square inch and operate at nearly the speed of light. There doesn't seem any way that transistors could become any faster or any smaller, yet they always do.

Transistors have been around since 1947, when the very first one was created in a laboratory in New Jersey. That first transistor was as big as an adult's fist and very slow by modern standards. The 1960s and 1970s were the dawn of the "transistor age," as these mighty mites replaced vacuum tubes in radios, televisions, and stereo equipment. Replacing the fragile glass vacuum tubes with tough, solid-state transistors allowed us to put radios in our cars and televisions in our kitchens. Computers could be built to fit in a single room, and cooling them no longer required industrial air conditioning.

Transistors are so plentiful today that they outnumber the human population by more than 300 million to 1. A single transistor is virtually free, in spite of the extraordinarily advanced and expensive technology required to build them.

Transistors work like water valves, opening and closing to permit the flow of electricity at the right time. Yet there are no moving parts in a transistor. They are still and silent, taking advantage of the way electricity passes through certain materials, particularly silicon.

The diagram in Figure 9.5 shows how a transistor is put together. There are three main parts to a transistor, called the source, the drain, and the gate. The source is where electricity flows in, like water. The drain, of course, is where it drains out of the transistor. The gate is like a hand on the spigot, shutting off the flow when appropriate. The junction area shown in Figure 9.5 is simply the material between the other three parts. There are three tiny wires attached to the source, drain, and gate, although they aren't shown here for clarity.

Figure 9.5. Every transistor has a source and a drain, with a gate that controls the flow of electricity between the other two. Voltage applied to the gate will either allow or inhibit the flow from the source to the drain through the junction.

All three parts of the transistor are made from silicon or materials very much like silicon. The parts are "doped," or mixed, with other exotic-sounding materials like germanium, selenium, or zinc. The source, drain, and gate are generally all made from the same mixture of materials.

Tech Talk

The source, drain, and gate are sometimes called the collector, base, and emitter, depending on how the transistor is made. The latter terms are more accurate for bipolar transistors, whereas the former describe field-effect transistors (FET) or metal-oxide semiconductor (MOS) transistors, which are used in almost all ICs.

A wire attached to the source supplies electrons and a wire attached to the drain takes them away. To get there, the electrons (the constituent parts of electricity) must pass through the junction area. Usually they have no problem doing this and electricity flows freely, like an open tap. If you apply a small electric voltage to the gate, however, the flow stops. Charging the gate sets up a barrier in the silicon below it, stopping the electron flow halfway through the junction. This barrier is not a physical wall, of course. It's a more like a magnetic barrier or a science-fiction force field. It's a gentle barrier, but strong enough to stop electrons from passing underneath the gate as they try to flow from the source to the drain.

The force-field barrier is the key to the whole transistor and the entire semiconductor industry. Silicon is not the only substance that will make a barrier like this, but it's among the most useful and inexpensive. Metals, plastics, ceramics, and other materials don't act this way. Silicon is called a semiconductor because sometimes it conducts electricity and sometimes it doesn't.

As you can see, a transistor works like a valve or a light switch. A small electric voltage applied to the gate can control a large electric current passing through the source and drain. This makes transistors amplifiers in the broadest sense: A small change here makes a big change there. It also makes them ideal components for digital chips. One transistor's drain can control another transistor's gate, and so on. Connecting transistors in complex and interrelated patterns is what semiconductor design is all about.


About Electrons and Electronics

Electricity is a lot like water. It flows from one place to another, it can be shut off with appropriate valves, it can be stored for a while, and it can be used to power big mills. A steady flow of electricity is even called a current.

Like water, electricity likes to flow downhill. In electrical terms, that means it flows from wherever there is an excess of electrons to anyplace there is a shortage. Benjamin Franklin labeled these positive (+), for the "uphill" side where electricity is plentiful and negative (–) for the "downhill" side. We've used his nomenclature ever since, and you can see it marked on batteries.

Electricity even has water pressure. The amount of electricity flowing from one place to another (from the positive source to the negative drain) is called the voltage. A big, wide garden hose can move a lot of water, and big, thick wires can carry a lot of voltage. Water pressure determines how far the water squirts out of the garden hose, and it can fluctuate at different times of the day. Likewise, electricity can have high or low pressure, called amps. Lots of volts means lots of electrical flow; lots of amps means lots of electrical pressure.

That describes electrical current, but what is electricity, really? Once again, we can compare it to water. The current in a river is made up of an uncountable number of water molecules, and by the same token, electric currents are made of individual electrons. What are electrons?

We've all seen pictures of an atom like the one in Figure 9.6, which shows electrons circling around a nucleus, like planets around the sun. (It turns out that physicists don't consider this 1950s-era model to be accurate anymore, but it's close enough for our purposes.) There happen to be three electrons in our example, but if you remember your high-school chemistry, there can be dozens of electrons per atom, depending on what material it is. Silicon has 14 electrons in every atom, for example.

Figure 9.6. This very simplified diagram of an atom shows three electrons circling around the nucleus. The electrons have a negative electric charge and the nucleus has a positive electrical charge, so they cancel each other out.

It so happens that electrons can be stripped off an atom and given to another atom. This creates an imbalance that the electrons themselves try to fix, as shown in Figure 9.7. They are attracted back to their "home" atom like magnets to a refrigerator door. If we strip a few electrons off of Atom A and give them to Atom B, then Atom B will have a surplus and Atom A will have a shortage. If the atoms are close together, the excess electrons migrate back to Atom A all by themselves. If we space the atoms too far apart, however, our emigrant electrons won't be able to make the trek and the two atoms will be permanently imbalanced. They will keep trying, however.

Figure 9.7. Electron shortages tend to balance themselves when atoms borrow missing electrons from their neighbors. The flow of electrons from atom to atom makes an electrical current. The number of electrons migrating is called the voltage.

If we place some other atoms between Atom A and Atom B, the lonely electrons will eventually find their way back home. They do this in a kind of "bucket brigade" fashion. Atom A (which is missing two electrons) will steal two electrons from its nearest neighbor atom. That atom will, in turn, make up its own shortage by stealing two electrons from its neighbor, on so on. Eventually, this chain of compulsive theft ends at Atom B, which had two extra electrons anyway, and all our atoms are once again in balance.

Sometimes this works better than others. It depends on what kinds of atoms are between Atom A and Atom B. Many types of atoms won't give up their own electrons easily, so they put a stop to this migration. Other types of atoms are more than happy to cooperate. We call the first class of materials insulators. Plastic, rubber, porcelain, wood, and many other materials are insulators, which is why the electrical outlets in your home have plastic safety covers to prevent the electricity from migrating into your hands. Materials in the second category are called conductors. Metal makes a good conductor, which is why all your house wiring and electrical plugs are made of metal. A few materials fall somewhere in between, and we call these semiconductors.

Tech Talk

In a sense, the electrons don't really migrate from Atom B back to Atom A. It's really the shortage of electrons that moves from A over to B. Benjamin Franklin was wrong; it's the electron holes that move from the positive side to the negative side, not the other way around.

Electronics is all about controlling the flow of electrons and electron holes from where they are to where they want to be. We use metal wires when we want the electricity to flow fast and easily, and rubber or plastic insulators to keep it from places we don't want it to go. We construct elaborate chips out of semiconductors when we want to control when, how, and where the electrons should migrate. That, dear reader, is how semiconductors work.


Appendix Standards Bodies and Reference

In this chapter...

  • Standards Bodies and Organizations

  • Conferences and Trade Shows

  • Other Resources

This appendix is an incomplete listing of useful Web sites, names, publications, and other resources for readers who are interested in learning more about semiconductors.


Standards Bodies and Organizations

This section lists some of the independent, government, industry, or private standards bodies that affect the semiconductor industry. You're encouraged to contact them for more information about their activities and materials.

Semiconductor Industry of America (SIA)

The SIA works on technological, political, and business measures that advance the interests of America's semiconductor vendors. Some 90 percent of U.S. chip firms are represented by the SIA.

www.semichips.org

World Semiconductor Trade Statistics (WSTS)

This nonprofit organization keeps monthly and yearly figures on semiconductor sales and shipments worldwide. Some of its statistics are available for free on its Web site, and more detailed information is availablefor a subscription fee.

www.wsts.org

Sematech

This organization includes representatives from a number of semiconductor companies around the world. Together, they research advanced manufacturing techniques for next-generation chip production.

www.sematech.org

Semiconductor Equipment and Materials International (SEMI)

SEMI represents 2,400 companies around the world, promoting and encouraging development of semiconductor manufacturing technology.

www.semi.org

Joint Electron Device Engineering Council (JEDEC)

This organization is part of the Electronic Industries Alliance, charged with setting standards for chips and other components so that devices from different vendors can work together.

www.jedec.org

Electronic Industries Alliance (EIA)

This blanket group includes more than a half-dozen separate organizations dealing with various aspects of electronics, telecommunications, and consumer electronics. The EIA's subordinate organizations set technical and political policy for its member companies.

www.eia.org

Electronic Design Automation Consortium (EDAC)

EDAC works on technological, political, and business measures affecting America's EDA vendors.

www.edac.org

Institute of Electrical and Electronics Engineers (IEEE)

The IEEE sets standards for the engineering community and accredits engineers. The group is a professional trade organization, similar to the American Medical Association for doctors. The IEEE publishes several technical periodicals and convenes technical conferences around the world.

www.ieee.org

Institution of Electrical Engineers (IEE)

This professional engineering society represents mostly European engineers. The IEE distributes technical periodicals, sets industry standards, and promotes economic and political agendas that advance the causes of its members.

www.iee.org

International Engineering Consortium (IEC)

The IEC promotes research and cooperation between industry and academia in the areas of computer science and information technology.

www.iec.org

International Symposium on Quality Electronic Design (ISQED)

This relatively young organization is sponsored by the IEEE and covers broad areas such as silicon manufacturing, circuit design, and EDA.

www.isqed.org

Accellera

Accellera is a nonprofit consortium of EDA vendors working on next-generation HDLs. The group promotes discussion and creation of these languages, but leaves their commercial development to its member companies. Accellera was formed from the merger of Open Verilog International and VHDL International, two groups promoting previously incompatible HDLs.

www.accellera.org

Open SystemC Initiative (OSCI)

Like Accellera, OSCI is a nonprofit organization promoting the development and use of next-generation HDLs, in this case, SystemC.

www.systemc.org


Conferences and Trade Shows

Asilomar Conference on Signals, Systems, and Computers ("Asilomar")

This annual conference is sponsored by the U.S. Navy, featuring technical papers, presentations, and discussions on electronics and computer systems. The conference is noted for its informal nature, low cost, and spectacularly picturesque surroundings on the California coast in Pacific Grove, near Monterey, Carmel, and Pebble Beach.

web.nps.navy.mil/~asilomar/

Embedded Systems Conference (ESC)

ESC is held several times a year in the United States, Europe, and Japan. It covers both business and technology and offers attendees a look at new products and tools for engineers and developers. Several papers are presented and full-day tutorials are available.

www.esconline.com

Microprocessor Forum

This annual San Jose conference sees new 32-bit and 64-bit microprocessor chips announced, generally for the first time. The conference is a mix of business and technology and is noted for its professional atmosphere, comparatively high cost, and high level of service.

www.mdronline.com/mpf

Embedded Processor Forum

Like the Microprocessor Forum, the annual Embedded Processor Forum features first-time announcements of new microprocessor chips and related technology for embedded systems (i.e., not PCs). The conference is noted for its combination of technical material with business relevance.

www.mdronline.com/epf

Network Processor Conference

Network Processors is a combination trade fair, product exhibit, and technical conference. It is held annually and provides a broad look at the state of the network processor industry.

www.networkprocessors.com

Hot Chips

Hot Chips is an annual tradition at Stanford University, situated in the heart of Silicon Valley. This low-cost conference features a number of paper presentations of new technology, mostly related to microprocessors. The members of the nonprofit group that organize Hot Chips change every year.

www.hotchips.org

International Solid State Circuits Conference (ISSCC)

ISSCC is an annual event, usually held mid-winter in San Francisco, where semiconductor researchers and manufacturers display and discuss their latest advances. The program is generally very technical, but some of the papers are accessible to the general public.

www.isscc.org/isscc

International Electron Devices Meeting (IEDM)

Like ISSCC, the annual IEDM conference covers low-level advances in semiconductor manufacturing and its underlying technology. The conference is usually held in the winter at locations around the world.

www.ieee.org/conferences/iedm


Other Resources

The Tech Museum of Innovation ("The Tech")

In downtown San Jose, California, The Tech includes an IMAX theater and three floors of hands-on exhibits, demonstrations, and explanations. Good fun even for nontechnical visitors, and nirvana for nerds.

www.thetech.org

Computer History Museum

This Silicon Valley–based museum has created an engaging history of computers and semiconductor development, and it is filled with many donated pieces of rare equipment.

www.computerhistory.org

Sematech Online Dictionary

A convenient online guide to technical terminology.

www.sematech.org/public/publications/dict/index.htm

Electronic Design & Technology News Online Encyclopedia

A convenient online guide to technical terminology.

www.edtn.com/encyclopedia

Microprocessor Report

This is a subscriber-supported (i.e., no advertising) newsletter published every week, covering news and developments in the high-end microprocessor business.

www.mdronline.com

Dynamic Silicon

This monthly newsletter covers MEMS, reconfigurable logic, and other nontraditional uses of silicon technology.

www.dynamicsilicon.com

Electronic Engineering Times

This weekly tabloid is effectively the newspaper of the electronics industry.

www.eetimes.com


Glossary

This is a glossary of words you'll read and hear about semiconductors. Most of the words appear in this book, but many do not. They're included because you might come across them in other materials or in discussions with other people.

µ

Abbreviation for micron or micro. In the first sense, a micron is one-millionth of a meter, or about 1/25-thousandth of an inch. As the prefix micro-, it means one one-millionth of something. Finally, this is a letter in the Greek alphabet, pronounced "moo."

Å

Abbreviation for angstrom, a unit of measure.

Angstrom

A unit of measure that's one-tenth of a nanometer, or about 1/250-millionth of an inch. A single atom is 3 to 10 angstroms across, depending on what material it is an atom of.

ASIC

Application-specific integrated circuit. An ASIC is a chip custom designed by one company for its own use in a specific product or for a specific purpose. ASICs are generally not made available for sale; only the company that designed them uses them. ASIC is pronounced "aay-sick."

ASSP

Application-specific standard product. An ASSP is almost exactly the same as an ASIC, except that an ASSP is intended to be sold to outside companies. There are no technical or physical differences between an ASIC and an ASSP; the difference hinges purely on whether or not the chip will be sold.

Behavioral

A description of an HDL (hardware-design language) meaning that the description of the desired chip is not extremely detailed. Instead, a behavioral description describes how the chip should behave but does not define exactly how that behavior should be achieved. It's the responsibility of the HDL compiler to convert a behavioral description into a working chip design.

BiCMOS

A method of manufacturing semiconductors that combines bipolar and CMOS techniques. BiCMOS chips can be somewhat faster than CMOS chips but use more power and give off more heat. Pronounced as a three-syllable word, "bye-see-moss."

Bin

A verb meaning to sort chips just after they're manufactured. Normal variations in manufacturing will cause some chips on a wafer to run faster or slower than others. The faster chips are usually sorted, or binned, and sold for a premium price. Conversely, the slower chips in the bin sort are often sold at a reduced price.

Binary

A system of counting that uses only two numbers, 0 and 1. People normally count using 10 numbers, from 0 through 9, which is called the decimal system. We count to 10 because we have 10 fingers, but there is nothing mathematically important or biologically "correct" about our habit of using 10 numbers. In electronics, it's much easier to have only two numbers that correspond to on and off. This is called the binary system. Binary arithmetic works the same as decimal arithmetic, but requires a lot of 1s and 0s to write big numbers.

Bipolar

A method of manufacturing semiconductors, or the type of chips made this way. Bipolar chips use more energy than CMOS chips but typically run faster. Bipolar processing techniques are often used to manufacture chips for high-end radio and television equipment.

Bit

A unit of measure, the smallest used in digital systems. In binary arithmetic a bit can be either 0 or 1. In electronics a bit is an electrical charge, either on or off. Depending on the context, a bit can be called 0 or 1, asserted or negated, true or false, high or low, off or on. The term was coined as a contraction of "binary digit."

Byte

A unit of measure equal to 8 bits. Bytes are to bits what words are to letters of the alphabet. Because a single bit can represent only two numbers (i.e., 0 and 1) it takes several bits before you can do any reasonable math. The smallest collection of bits used is a byte. One byte can be rearranged in exactly 256 different combinations of bits (from 00000000 through 11111111), to represent the all the numbers from 0 to 255. Numbers larger than 255 require more bits, usually added eight at a time to make two bytes.

Circuit

A general term for any electronic design. Like water, electricity flows from its source to its final destination, and it might do useful work along the way, such as powering a steel mill. Eventually that electricity, like water, returns to its source, completing a circuit. Thus, all electronic designs, from tiny chips to large televisions, are called circuits.

CMOS

Abbreviation for complementary metal-oxide semiconductor. A dauntingly technical description of the process whereby most semiconductor chips are made. The CMOS process produces chips that consume less electricity and that give off less heat than other processes, such as bipolar (cf.) and BiCMOS (cf.). Pronounced like "sea-moss."

CMP

Abbreviation for chemical-mechanical polishing, a method of smoothing the surface of a silicon wafer. Chemical-mechanical polishing is like sanding a mirror using very fine sandpaper. Silicon wafers are polished mirror-smooth before chips are etched onto them.

Compiler

A computer program for translating commands written in a computer programming language into binary patterns that a microprocessor can understand and execute. Compilers translate from one specific programming language to one specific type of microprocessor's instructions; they are not universal. Different compilers translate different languages.

Conductor

Any material that conducts electricity. Most kinds of metal, such as copper, steel, and aluminum, make good conductors.

CQFP

Ceramic quad flat pack. One of several types of physical packaging for finished chips. CQFP packages are similar to PLCC packages, but with a body of high-temperature ceramic material instead of plastic. CQFP packages are therefore more expensive than PLCCs of equivalent size and are reserved for high-energy chips that would melt a plastic package.

CVD

Abbreviation for chemical vapor deposition, a method of spraying dielectric material onto a silicon wafer before etching chips onto it.

Debugger

A computer program used by computer programmers to locate and remove accidental or unwanted behavior ("bugs") from other computer programs. Debuggers, for instance, allow the programmer to run the computer program very slowly to observe its behavior in something approaching human-perceptible speed.

Decimal

A system of counting that uses 10 numbers, from 0 to 9; in other words, the normal number system. Decimal is different from the binary system, which uses only two numbers.

Defect

A flaw in a chip, usually caused when dirt or dust lands on the wafer while it's being processed. The number of defects divided by the size of the wafer is called the defect density.

Dice

Plural of die; bare silicon chips before they are put into plastic or ceramic packages. Dice are very thin and shiny; they are the actual "chip" in semiconductor chips.

Die

A bare chip; the small rectangular piece of silicon after it has had an electronic circuit etched onto it but before it is placed in a plastic or ceramic package. A die (the plural form is dice) is a fully functional electronic device, or chip. It needs only a protective package before it can be handled and sold. In certain cases, vendors might sell a bare die (called known-good die, or KGD) if the customer is equipped to handle unpackaged chips without contaminating them.

Dielectric

A spacer between two electrical components. In capacitors and transistors, the dielectric is an extremely thin layer of material between two layers of metal or silicon. The dielectric acts as a barrier to the electrical flow.

DIL

Dual in-line. A synonym for DIP, which is one of several types of plastic or ceramic packages used for finished chips.

DIP

Dual in-line package. One of several types of package for finished chips. Rectangular DIP packages are made of either black plastic or brown ceramic material, with two parallel rows of metal legs emerging from the long sides. The metal legs, called pins, are the electrical contacts between the outside world and the chip buried inside. Small DIP packages have eight pins (four on each side), whereas large ones might have as many as 68 pins, making them very long and narrow. DIP packages aren't good for very big chips because it would make them too long and fragile. The pins on a DIP package are spaced exactly 0.10-inch (one-tenth of an inch) apart. Pronounced as a single word, "dip."

Doping

Pure silicon can be "doped," or mixed, with materials such as selenium to make it a better semiconductor for building transistors.

Download

To transfer data, usually from a distant place or computer to a local place or computer. "Download" is like "bring" because it implies that the object is moving toward the user.

DRAM

Dynamic random-access memory. One of the two major types of RAM, the other being static RAM. The "dynamic" qualifier means these chips can only "remember" data for a few thousandths of a second, so they need to be refreshed at regular intervals. The refresh process also makes DRAM chips consume more electricity than SRAM chips. Finally, DRAM chips are slower than SRAM chips when retrieving the data they have stored. The one great advantage DRAMs have over SRAMs is capacity. DRAMs can store about four times more data per square millimeter of silicon than SRAMs, making them more economical for most uses. Pronounced as a two-syllable word, "dee-ram."

ECL

Emitter-coupled logic. A particular way of combining transistors when designing chips. ECL chips are rare but tend to be very fast.

EDA

Abbreviation for electronic design automation, a term that describes the business of automating the design of electronic products. Several companies sell EDA software and tools that help engineers design, test, simulate, and fabricate new chips. Pronounced as individual letters, "ee-dee-ay."

Embedded

A blanket term to describe any chip not associated with personal computers. In other words, everything except PCs is an embedded product. This term is most often used with microprocessors, as in "embedded microprocessor for automotive systems."

Fab

A verb meaning to build a chip and also a noun for the place where you make chips. A fab is a chip-making factory. More subtly, a fab is a factory owned by a large chip company for its own use, as opposed to a foundry.

FET

Field-effect transistor. One of a few special classes of transistors that can be purchased by itself in a very small package. Pronounced as individual letters, "eff-ee-tee."

Flash

A type of nonvolatile memory chip. Flash memories can be electrically erased in a few seconds and loaded with new data in less than a minute. This process is so much faster than the previous generation of EEPROM chips that they earned the name flash memory chips.

Foundry

A chip-manufacturing plant that is operated for the benefit of several client companies; a factory-for-hire. Foundries are distinct from fabs, which are company-owned manufacturing plants for in-house use.

FR-4

The fiberglass material normally used to make printed-circuit boards.

Gate

A basic unit of digital electronics. Gates perform very simple logic functions, such as the AND, OR, and XOR functions. A second meaning of gate is one of the three contact points on a semiconductor transistor.

GB

Abbreviation for gigabyte, or 1,073,741,824 (roughly 1 billion) bytes. With a lowercase b (Gb), it usually means gigabits, a quantity eight times smaller. Beware; not all publications are consistent about this usage.

Gigahertz

One billion cycles or operations per second. Most chips operate at a fixed, regular speed, like the steady beat of a drummer in a band. These beats are measured in units called hertz; a gigahertz is 1 billion beats per second.

HDL

Hardware-description language or high-level design language. A blanket term that covers any language used by a chip designer to describe how a new chip should operate. An HDL compiler will then convert the HDL description into real gates and transistors.

Hertz

A unit of measure, in cycles per second. Similar to RPM, hertz measures how fast something spins around or repeats itself. The word comes from the name of scientist Heinrich Hertz, and has been used for decades to measure the frequency of radio waves, visible light, and other electromagnetic phenomena.

Insulator

Any material that does not conduct electricity. Rubber and plastic are good insulators, which is why they're used on the outside of most electrical products, cords, and plugs.

IP

Intellectual property or Internet Protocol (the two terms are unrelated). In the first sense, IP is a broad term that covers patents, trademarks, copyrights, trade secrets, know-how, and other valuable but intangible assets. The term was popularized in the late 1990s when several semiconductor firms switched from making chips to simply licensing the design of those chips—their intellectual property—to other companies. In that sense, IP licensing is similar in concept to franchising restaurant chains. In its second sense, IP refers to the Internet Protocol, a de facto standard system of communication among computers that is used, obviously, for the Internet as well as in other types of networks. Most often found in the abbreviation TCP/IP.

ITRS

International Technology Roadmap for Semiconductors. A report generated every year or so by the Semiconductor Industry of America that projects what manufacturing trends and advancements will occur in the next few years.

KB

Abbreviation for kilobyte, or 1,024 bytes. With a lowercase b (Kb) it usually means kilobits, a quantity eight times smaller. Beware; not all publications are consistent about this usage.

KGD

Known-good die. Individual silicon chips (die) that have been tested and are guaranteed to be in good working order before being inserted into plastic or ceramic packages. Some large-volume companies prefer to buy KGD instead of normally packaged chips to save space and weight.

Kilohertz

One thousand cycles or operations per second. Most chips operate at a fixed, regular speed, like the steady beat of a drummer in a band. These beats are measured in units called hertz; a kilohertz is 1,000 beats per second.

Kludge

A made-up word for something that's hastily prepared, inelegant, and probably unreliable. The ultimate insult among engineers. Kludge can be used as a noun ("that's a kludge") or a verb ("let's just kludge something together for the investors"). Pronounced "klooj."

LED

Light-emitting diode. A small light, usually red, made using semiconductor materials and techniques. LEDs also come in yellow, green, and more recently, blue. Pronounced as individual letters, "ell-ee-dee."

LSI

Large-scale integration. Part of a series of vague descriptions of the level of complexity on a chip. LSI ranks near the bottom of this series, above SSI but below VLSI and ULSI. The term has no precise meaning or qualifications.

MB

Abbreviation for megabyte, or 1,048,576 bytes. With a lowercase b (Mb) it usually means megabits, a quantity eight times smaller. Beware; not all publications are consistent about this usage.

Megahertz

One million cycles or operations per second. Most chips operate at a fixed, regular speed, like the steady beat of a drummer in a band. These beats are measured in units called hertz; a megahertz is 1 million beats per second.

MEMS

Micro electrical-mechanical sensor. Any of a class of tiny devices that are mechanical in nature but built using semiconductor materials and techniques. Pronounced "mems," even when there's only one.

Micron

A unit of measure equal to one one-millionth of a meter, or about one-25,000th of an inch. Transistors on today's semiconductor chips are much smaller than one micron.

MIPS

Millions of instructions per second. A measure of how quickly a microprocessor or computer processes its software instructions. An ineffective measure of performance, however, because different microprocessors process different kinds of instructions. Note for the pedantic: MIPS is singular, not plural, so the S should always be capitalized and always spoken, even when there is only one.

Moore's Law

A casual observation made by industry executive Gordon Moore in 1965, and revised in 1975, that has since become a de facto "law" for estimating progress in the semiconductor industry. Moore observed that the semiconductor industry in general seemed to need only about 18 months to find ways to double the number of transistors they could squeeze onto a silicon chip. This continual shrink in transistor size, and the resulting increase in chip speed and complexity, has become known as Moore's Law.

MOS

Metal-oxide semiconductor. A term describing the chemistry used in the most popular type of semiconductor manufacturing, including the popular CMOS (complimentary metal-oxide semiconductor) process. Pronounced like "moss."

MSI

Medium-scale integration. Part of a series of vague descriptions of the level of complexity on a chip. MSI ranks near the bottom of this series, above SSI, but below LSI, VLSI, and ULSI. The term has no precise meaning or qualifications.

Nanoacre

A facetious measurement of space or area, sometimes used to brag about how densely packed a chip is, as in "this chip has a million transistors per nanoacre." A nanoacre is technically one-billionth of an acre, or about one one-hundredth of a square inch, but the term is not used in its literal sense.

Nanometer

One-billionth of a meter or one-thousandth of a micron. One nanometer is about 0.0000000394 of an inch. Modern semiconductor transistors are approximately 100 nanometers across, and getting smaller.

Netlist

An electrical circuit diagram or a blueprint for designing a chip or other electronic product. Wires with components connected to them are called nets and the list of all the nets is, naturally, the netlist.

NIH

Not invented here. An attitude that anything created by outsiders is inferior to anything created by oneself or one's employer. Chauvinism.

Nm

Abbreviation for nanometer (one-billionth of a meter). A nanometer is 1,000 times smaller than a micron, or about 0.0000000394 of an inch.

Nonvolatile

A type of memory chip that retains its data even after power is turned off. Most ROM chips are nonvolatile.

PC board

Printed circuit board, often shortened to PCB.

PCB

Printed circuit board. A fiberglass board (usually green) with copper wires, or traces, imprinted onto it.

Pin

The metal "leg" that sticks out of a packaged chip. The pins are internally connected by wires to the silicon chip inside the chip's plastic or ceramic package.

PLCC

Plastic leaded chip carrier. One of several types of physical packaging for finished chips. PLCC packages are square and flat, with a row of metal pins along all four edges that serve as the electrical contacts into and out of the chip. The package material is plastic, by definition; ceramic versions are called CLCC. PLCC packages might have from 28 pins (seven along each side) to a few hundred pins. The pins on a PLCC package are generally curled under in a J-form, suitable for surface-mounting.

Port

A verb meaning to convert, adjust, or modify a computer program (software) that runs on one type of computer so that it runs on another type of computer. Porting might be a simple task or it can be very complex and involved, taking more time and effort than it did to create the original program.

Printed circuit board

A green fiberglass material used to connect individual chips together, both electrically and mechanically. The fiberglass is an insulator (it does not conduct electricity) but the PCB is embedded with copper wires (which do conduct electricity). The fiberglass board serves as a flat mechanical mounting structure for chips and other components. The copper wires buried in the fiberglass conduct electricity between these components. The arrangement of the copper wires (or "traces") within the board is key, and determines how the components are wired together. PCBs are generally green in color, with the copper clearly visible on the surface or buried within the layers of the material. Multilayer PCBs are common, with several layers of fiberglass and copper sandwiched together to provide more conductive paths for more complex circuits.

RAM

Random-access memory. One of two major classifications of memory chips, the other being ROM. RAMs are so called because they can retrieve any data they contain, in random order, without regard to where that data is stored within the chip. In other words, the data does not have to be accessed sequentially, like videotape. The term RAM also implies, albeit indirectly, that data can be both written to, and read from, the chip. This distinguishes them from ROMs, which cannot store new data, but only retrieve what data already exists in the chip. The two major subclassifications of RAM are DRAM and SRAM. Pronounced just like the word for a male goat: "ram."

Real-time

A type of computer or computer program that responds to events in the real, physical world of humans. For instance, a computer that controls the elevators in a tall office building is a real-time computer, but a computer printing checks in a bank is not. Real-time systems must respond quickly to events as they happen; they cannot postpone processing to a more convenient (for the computer) moment. They must be aware of "real" time to avoid annoying or harming humans.

ROM

Read-only memory. One of two major classifications of memory chips, the other being RAM. ROMs differ from RAMs because they cannot store new data; they can only supply the data they were given during manufacturing or initial programming. ROMs are like stone tablets dried in the sun. Attempting to electronically write new data into a ROM chip will not harm it; the new data is simply ignored. ROM chips are economical where large amounts of permanent storage are required, such as video games, automotive engine control systems, or electronic books. Pronounced as a single word, "rom."

RTL

Register-transfer level. A description of a type of HDL (hardware-description language), meaning it describes the desired hardware down to the level of individual registers in the chip. An RTL-level description is a detailed description of a chip. A less detailed use of HDL would be a behavioral description.

RTOS

Real-time operating system. A computer operating system that programs a computer to respond to events in real time (cf.). Microsoft Windows, MacOS, UNIX, and Linux are not real-time operating systems; those computers handle tasks as they see fit, in no particular order. A real-time operating system schedules tasks in a predictable and reliable manner, and guarantees that certain time-critical tasks (e.g., stopping a moving subway train at the station platform) will not be postponed.

Schematic

A diagram of an electrical circuit. Similar to blueprints, schematics show where each component and wire is located. Schematics provide a map of an electrical device.

SDRAM

Synchronous dynamic random-access memory. A subtype of DRAM that uses a synchronous method of communicating with other chips. SDRAMs are neither faster nor slower than other types of DRAMs, nor do they store more or less data. Their only difference lies in their communication method with other chips. Pronounced as a three-syllable word, "ess-dee-ram."

Semiconductor

Any material that conducts electricity, but not particularly well. The most popular and well-known semiconductor is silicon. Semiconductors can be natural or artificial; silicon is a natural substance. Semiconductors are valuable because of their ability to change between a conductive and nonconductive state, making electrical switches.

SIA

Semiconductor Industry Association. A nonprofit organization that conducts research on behalf of the worldwide semiconductor industry as a whole.

Silicon

A natural substance found in soil, especially in sand. Silicon is a natural semiconductor; it conducts electricity but not well. Silicon is refined and processed to produce semiconductor chips. Pronounced "SILL-uh-conn."

Silicon Valley

The general area around Santa Clara County in California. This 40-mile stretch alongside San Francisco Bay is home to most of the world's semiconductor companies. Silicon Valley is a notional concept; it's only a nickname so it has no official borders. Generally speaking, the Valley reaches from San Jose in the south to approximately Redwood City in the north, or roughly the boundaries of Santa Clara County. Journalist Don Hoefler coined the name in a 1971 article that appeared in Electronic News.

Silicone

An artificial substance used in cosmetic surgery and as a household sealer and lubricant. Silicone is waxy and can be molded into various shapes, making it useful as weather stripping. Silicone is not related to silicon. Pronounced "sill-uh-CONE."

SIP

Single in-line package. Similar to a DIP package but with only a single row of metal pins. SIPs are used for very small or simple chips that don't need more than a few pins. SIPs can stand upright on a printed circuit board, making them very space-efficient.

SMT

Surface-mount technology. An abbreviation for any chip or printed circuit board that uses surface-mounted components.

Solder

A mixture of lead and tin, two very soft metals that share two useful characteristics: They both conduct electricity and they both melt at low temperatures. Solder therefore makes a good conductive "glue" for attaching wires to chips or chips to boards. Solder is both a noun and a verb and is pronounced "saw-der."

Solid state

An out-of-date term first used to described semiconductors, as opposed to vacuum tubes. Semiconductors are solid materials, like silicon, with no moving parts. Vacuum tubes, on the other hand, were fragile and had many delicate internal components.

SRAM

Static random-access memory. One of two major types of RAM, the other being dynamic RAM. These chips are "static" because they do not need to be refreshed like DRAM chips do. They hold their storage for as long as the power is on. SRAMs are more energy efficient than DRAMs, and are also faster. These qualities makes SRAMs the memory of choice for both high-performance systems and low-power systems. The major disadvantage of SRAMs is their cost; they store only one-quarter the amount of data compared to DRAMs, making DRAMs cheaper where large quantities of memory are required. Pronounced as a two-syllable word, "ess-ram."

SSI

Small-scale integration. Part of a series of vague descriptions of the level of complexity on a chip. SSI ranks at the bottom of this series, below MSI, LSI, VLSI, and ULSI. The term has no precise meaning or qualifications.

Surface-mount

A method of soldering chips to a printed circuit board without drilling holes in the board for the chip's pins. Surface-mounted chips have their pins curled in a J pattern so they can be soldered to the top or bottom of a PC board.

Trace

A copper wire buried in a printed circuit board. A trace is a thin, flat wire embedded into or etched onto a layer of fiberglass for the purpose of conducting electricity between two or more components soldered on the board. Each layer of a printed circuit board will have several such traces, but the traces cannot cross each other. Even simple printed circuit boards have traces on both sides, running north to south on one side and east to west on the other side. Complex printed circuit boards will sandwich multiple layers together to increase the density of traces and improve opportunities for interconnection among components.

ULSI

Ultra large-scale integration. Part of a series of vague descriptions of the level of complexity on a chip. ULSI ranks at the top of this series, above SSI, MSI, LSI, and VLSI. The term has no precise meaning or qualifications.

Upload

To transfer data, usually from a local place or computer to a distant place or computer. "Upload" is like "send" and implies that the object is moving away from the user.

Verilog

One of two very popular hardware-design languages (HDLs) used to design new chips.

VHDL

Very high-level design language. One of two very popular hardware-design languages (HDLs) used to design new chips.

Via

A small copper-plated hole in a printed circuit board used to join traces from opposite sides of the board. When it's desirable to connect a copper trace on the top of a PC board to another copper trace on the bottom of a PC board, a hole is drilled through the board and plated with copper. These vias are the only place that copper traces travel vertically through the thickness of the PC board. Several vias might be required for a trace to negotiate a crowded PC board to a trace on the opposite side. Vias generally penetrate all layers of a multilayer PC board; holes drilled only partway through are called "blind vias."

VLIW

Very long instruction word. A type of computer or microprocessor architecture or design. A VLIW computer's instructions are very long in comparison to the more common 16-bit or 32-bit instructions used by contemporary microprocessors. VLIW instructions might be 128 bits or 512 bits long, for example. The purpose of VLIW is to get multiple instructions into the microprocessor at once. Pronounced as individual letters.

VLSI

Very large-scale integration. Part of a series of vague descriptions of the level of complexity on a chip. VLSI ranks near the top of this series, above SSI, MSI, and LSI, but below ULSI. The term has no precise meaning or qualifications.

Volatile

A type of memory chip that loses its data when power is turned off. All DRAM and SRAM chips are volatile.

Wafer

The round, flat "pancake" of silicon used to make chips. Wafers are thin, shiny slices cut from an ingot of pure silicon. The size of a wafer depends on the diameter of the ingot from which it is cut, but 6 to 8 inches (200 to 300 mm) is standard. Wafers have a characteristic flat spot on one side as an aid to the automated chip-handling equipment.

Wafer start

The act of beginning to process a wafer of silicon to make chips. The productivity of a fab or foundry can be measured in wafer starts per week.

WSI

Wafer-scale integration. The process of using an entire silicon wafer to create one gigantic chip. WSI was explored in the 1980s as the next step beyond VLSI and ULSI integration. Rather than assemble chips on a PC board, WSI would assemble them while still at the bare-die stage. WSI never caught on, largely because of cost, complexity, and the enormous waste if any part of the chip was found to be faulty.

Yield

The number of working chips out of the total number of chips manufactured, usually expressed as a percentage. In even the best fabs and foundries, some chips will fail final inspection and be discarded. The percentage of chips that work is called the yield percentage. Yields improve over time as the semiconductor vendor gains experience with the product. Mature chips might yield at 97 percent or better; early prototypes might yield fewer than 20 percent good chips.


Team LiB

Brought to You by

Like the book? Buy it!