Table of Contents

Team LiB
Next Section
Mobile and Wireless Design Essentials
Mobile and Wireless Design Essentials
by Martyn Mallick ISBN:0471214191
John Wiley & Sons © 2003 (454 pages)

This text provides a detailed analysis of the complete range of current mobile and wireless network technologies from a software developer’s perspective.

Table of Contents
 | Mobile and Wireless Design Essentials
 | Introduction
 | Part One - Introduction to the Mobile and Wireless Landscape
 | Chapter 1 | - | Welcome to Mobile and Wireless
 | Chapter 2 | - | Mobile Devices
 | Chapter 3 | - | Wireless Networks
 | Chapter 4 | - | Mobile Application Architectures
 | Chapter 5 | - | Mobile and Wireless Messaging
 | Chapter 6 | - | Mobile and Wireless Security
 | Part Two - Building Smart Client Applications
 | Chapter 7 | - | Smart Client Overview
 | Chapter 8 | - | Smart Client Development
 | Chapter 9 | - | Persistent Data on the Client
 | Chapter 10 | - | Enterprise Integration Through Synchronization
 | Part Three - Building Wireless Internet Applications
 | Chapter 11 | - | Thin Client Overview
 | Chapter 12 | - | Thin Client Development
 | Chapter 13 | - | Wireless Languages and Content-Generation Technologies
 | Chapter 14 | - | Wireless Internet Technology and Vendors
 | Chapter 15 | - | Voice Applications with VoiceXML
 | Part Four - Beyond Enterprise Data
 | Chapter 16 | - | Mobile Information Management
 | Chapter 17 | - | Location-Based Services
 | Chapter 18 | - | Other Useful Technologies
 | Index
 | List of Figures
 | List of Tables
 | List of Listings
 | List of Sidebars

Team LiB
Next Section


BackCover

Team LiB
Back Cover

Mobile and Wireless Design Essentials is the first and only book that provides a detailed analysis of the complete range of current mobile and wireless network technologies from a software developer’s perspective. It examines such topics as wireless Internet, smart client and messaging mobile computing models, wireless security, and voice application development. Also explored is the full spectrum of wireless networks including Bluetooth, Wi-Fi, and 3G. You’ll find easy-to-understand guidelines and pointers on how to implement a mobile and wireless application to extend your enterprise systems and meet your company’s needs.

This book presents key information on:

  • How to build smart client applications using mobile database and synchronization technologies
  • The complete spectrum of messaging technologies, including email, SML, MMS, WAP Push, and application-to-application messaging
  • Wireless Internet architectures and related markup languages including HDML, WML, cHTML, XHTML, and VoiceXML
  • Technologies that complement enterprise mobile solutions, including PIM and location-based services
  • Resources and Web sites to consult for industry specifications, downloadable software, and mobile and wireless updates—in dozens of clear, easily referenced tables

About the Author

Martyn Mallick is Senior Software Engineer in Product Management and Wireless Solutions Evangelist for iAnywhere Solutions, a subsidiary of Sybase Inc. He works with enterprise corporations implementing enterprise mobile solutions, conducts training seminars worldwide on mobile and wireless technology design, development, and deployment, and is a regular guest speaker at major conferences.


Mobile and Wireless Design Essentials

Martyn Mallick
Wiley Publishing, Inc.

Publisher: Robert Ipsen

Editor: Carol Long

Developmental Editor: Scott Amerman

Managing Editor: Micheline Frederick

Text Design & Composition: Wiley Composition Services

This book is printed on acid-free paper.

Copyright © 2003 by Martyn Mallick.

All rights reserved.

Published by Wiley Publishing, Inc., Indianapolis, Indiana

Published simultaneously in Canada

No part of this publication may be reproduced, stored in a retrieval system, or transmitted in any form or by any means, electronic, mechanical, photocopying, recording, scanning, or otherwise, except as permitted under Section 107 or 108 of the 1976 United States Copyright Act, without either the prior written permission of the Publisher, or authorization through payment of the appropriate per-copy fee to the Copyright Clearance Center, Inc., 222 Rosewood Drive, Danvers, MA 01923, (978) 750-8400, fax (978) 646-8700. Requests to the Publisher for permission should be addressed to the Legal Department, Wiley Publishing, Inc., 10475 Crosspoint Blvd., Indianapolis, IN 46256, (317) 572-3447, fax (317) 572-4447, E-mail: <permcoordinator@wiley.com>.

Limit of Liability/Disclaimer of Warranty: While the publisher and author have used their best efforts in preparing this book, they make no representations or warranties with respect to the accuracy or completeness of the contents of this book and specifically disclaim any implied warranties of merchantability or fitness for a particular purpose. No warranty may be created or extended by sales representatives or written sales materials. The advice and strategies contained herein may not be suitable for your situation. You should consult with a professional where appropriate. Neither the publisher nor author shall be liable for any loss of profit or any other commercial damages, including but not limited to special, incidental, consequential, or other damages.

For general information on our other products and services please contact our Customer Care Department within the United States at (800) 762-2974, outside the United States at (317) 572-3993 or fax (317) 572-4002.

Trademarks: Wiley, the Wiley Publishing logo and related trade dress are trademarks or registered trademarks of Wiley Publishing, Inc., in the United States and other countries, and may not be used without written permission. All other trademarks are the property of their respective owners. Wiley Publishing, Inc., is not associated with any product or vendor mentioned in this book.

Wiley also publishes its books in a variety of electronic formats. Some content that appears in print may not be available in electronic books.

Library of Congress Cataloging-in-Publication Data:

ISBN: 0-471-21419-1

Printed in the United States of America

10 9 8 7 6 5 4 3 2 1

To my beautiful wife Catherine, for her support, understanding, and encouragement.

Acknowledgments

When I started writing Mobile and Wireless Design Essentials a year and a half ago, I never imagined what a monumental effort it would require. Without the support and assistance from my family, friends, and colleagues it would not have been possible to write on such a broad, evolving topic.

In particular, I must thank my wife Cathy for being patient and understanding when I wrote late into the night, and during most weekends.

I would also like to thank the rest of my family, including my parents Adrian and JoAnn, and my siblings David, Anita, Bryan, and Marissa for helping me stay focused throughout the writing process. Thanks also goes to Carol Long and her team at John Wiley & Sons including Scott, Micheline, Felicia, Janet, Erica, Adaobi, and Holly for offering their insight into the publishing process and for keeping me on schedule. Also deserving my gratitude are many of my colleagues at iAnywhere Solutions including David, Bharat, Alex, Liam, Matt, Chris, and Eric, who allowed me to bounce ideas off of them, and provided technical editing during the latter phases of writing. Additionally, a special mention goes to Michelle Cheng, a very gifted individual, who worked endless hours putting together all of the figures you see throughout the book. And finally I would like to thank my employer for providing an environment that is conducive to expanding my knowledge about both the business and technical aspects of the mobile and wireless industry. I hope the knowledge I have gained, and the lessons I have learned, prove to be valuable as you develop your mobile and wireless solutions.

Martyn Mallick
January 2003

Team LiB


Introduction

Mobile and wireless application development has come a long way in the past few years. It has progressed beyond the hype of wireless Web applications for consumers to the reality of high-value mobile applications for corporate users. Opportunities abound for creating new mobile and wireless applications that provide vital benefits to any business. A sampling of these benefits includes increased worker productivity, reduced processing costs, heightened accuracy, and competitive advantage. In contrast is the concern that developing mobile and wireless applications will involve many new technologies and concepts that many corporate developers are still learning to use.

One of the challenges in the mobile application space is the variety of application architectures available. Though many by now are now familiar with Wireless Application Protocol (WAP) applications, they are not familiar with smart client and messaging application architectures. (Note: WAP is a specific protocol, but is commonly used to describe any type of thin client wireless application. For a detailed discussion of thin client applications, see Chapter 11, "Thin Client Overview," and Chapter 12, "Thin Client Development.") Thin client refers to server-based applications that make it possible to browse the Internet on a wireless device. All of the business logic and data access logic is located on the server. The only software required on the client is a microbrowser, which is often preinstalled on wireless devices. Thin client applications are attractive because they can build upon existing Internet applications and do not require deployment to the client device. They can be viewed by anyone with a wireless Web-enabled device and can be updated at any time simply by changing the software on the enterprise server.

Thin client applications have one fundamental shortcoming, however: They require a wireless network connection to be effective. Without a connection, information cannot be retrieved from the server, essentially making the application useless. Even when a connection is available, unreliable wireless network coverage, slow data transfer rates, and cost also impact the success of thin client applications.

Consequently, a movement is growing toward smart client applications. These applications allow corporations to deploy an application to the mobile device so the user can continue to interact with the application even when a wireless data connection is unavailable. (For more detailed information on smart client applications and technology, see Chapter 7, "Smart Client Overview," and Chapter 8, "Smart Client Development.") These applications commonly include a form of persistent data storage that communicates with enterprise systems using data synchronization. This combination enables applications to have sophisticated user interfaces and high-performance data access, making them suitable for offline computing.

The third mobile application architecture of interest is messaging. (For more detailed information on messaging technology, see Chapter 5, "Mobile and Wireless Messaging.") Messaging technology can be used either on its own or to enhance existing applications. Adding notification capabilities to an application can increase its effectiveness dramatically. Mobile users can have important data "pushed" to them, as opposed to constantly requesting it from an enterprise server. Information notifications can be applied to both thin client and smart client applications. Messaging applications can also be developed on their own using messaging as the data delivery mechanism. In these applications, message queues are present on both the client and the server, allowing for information to be stored when a user is not connected to the network. Once the user connects, the stored messages are automatically forwarded to him or her. This type of messaging is commonly referred to as store-and-forward.

The technologies available to companies that want to extend their enterprise systems to their mobile workforce are covered in depth in the chapters that follow. All three mobile applications architectures are covered in some depth, as is related information on mobile devices, wireless networks, mobile and wireless security, mobile information management, and location-based services. This book provides all of the information you require to build highly successful mobile and wireless applications. Though the content is mainly focused on the creation of enterprise applications, you will find information relevant to developing consumer applications as well.

Overview of the Book and Technology

Developing successful mobile applications requires the integration of many technologies. Handset manufacturers and wireless network operators lay the basic ground-work for many applications, but they are only one component of the solution. Mobile middleware software, in conjunction with client-side technology, rounds out the solution. Developers are responsible for putting the pieces together to form effective mobile and wireless applications.

In order to be successful with this task, a broad knowledge of the mobile and wireless industry as a whole is required. Obtaining this knowledge can be a difficult quest. Although many books have been written on mobile and wireless computing, they typically focus on a very specific topic, meaning that developers would have to read several of these books to learn what is required for a single project. Obviously, this is too time-consuming. Moreover, due to the specific nature of the content being covered, many of these books simply rehash industry specifications or product manuals and do not cover the important issues for designing and developing enterprise mobile solutions. To fill in these gaps, readers then have to spend still more time doing their own research on the Internet before they can be productive.

The lack of comprehensive books on mobile and wireless computing was the motivating factor behind this book. Mobile and Wireless Design Essentials was written to make things easier for developers. It is a single resource whose objective is to bring you up to speed on the full spectrum of technologies and issues related to mobile and wireless computing. Every chapter provides insightful information on its respective topic, beginning with an overview of the subject matter and followed by in-depth analysis of how it is useful to application developers. Each chapter also contains helpful Web links where you can go for more information on any of the topics covered. These Web links alone will save you countless hours of searching for information.

To meet this goal — to be an all-in-one resource—a great number of topics are covered in Mobile and Wireless Design Essentials. The book starts with an overview of the mobile and wireless landscape, to ensure that all readers are "on the same page," before tackling the topics of developing smart client and thin client applications. Each of these application architectures has several chapters dedicated to related design and development issues. The final parts of the book focus on related technologies that are being used today—such as mobile email, mobile device management, and location-based services—and technologies that you will come across in the near future, including mobile Web services, M-Services and BREW.


How This Book Is Organized

Mobile and Wireless Design Essentials is divided into 4 parts and 18 chapters. Part I provides core information, making it essential to read first, to get the most from the rest of the book. After that, feel free to read the rest of the material in any order, as each part is self-contained. The same is true for most of the chapters: each is complete in itself so you can easily reference any one to get what you need on the subject covered. The chapters were written to give you a concise overview of the technology under discussion; you will not be overwhelmed by needless details.

Part Summary

Part I, "Introduction to the Mobile and Wireless Landscape," lays the foundation on which the other parts of the book are based. To that end, it covers mobile devices, wireless networks, mobile application architectures, mobile and wireless security, and messaging technology. These are core topics that should be well understood by anyone involved in a mobile application project. Subsequently, each of these topics is covered in its own chapter to provide a concise introduction to mobile and wireless computing.

Part II, "Building Smart Client Applications," provides an in-depth look at the concepts and technologies pertinent to developing smart client applications. It starts with an overview of the smart client architecture and proceeds to the development process, persistent data technology, and enterprise data synchronization. This part gives you everything you need to know in respect to the design and development of smart client applications.

Part III, "Building Wireless Internet Applications," provides an in-depth look at the concepts and technologies inherent to developing thin client applications. Similar to Part II, this part starts with an overview of the thin client architecture and proceeds to discuss the concepts and technologies involved in thin client development. A complete overview of the thin client markup languages—HDML, WML, cHTML, and XHTML—is provided, along with the techniques that can be used to generate this technology for the wide range of wireless devices being used today. Wireless Internet technology and voice application development using VoiceXML are the final topics discussed in Part III.

Part IV, "Beyond Enterprise Data," takes a look at technologies that are not core to the leading mobile application architectures but that are significant in the adoption and deployment of mobile applications. The first topic is mobile information management, which includes both personal information management (PIM) and mobile device management capabilities. These technologies are becoming increasingly important as mobile devices proliferate and become the responsibility of enterprise IT staffs. The second topic in Part IV is location-based services (LBS). Much of the hype around LBS refers to its use in the consumer market, but many corporate applications can also benefit from location information. Part IV finishes with information on four technologies that gaining momentum in mobile computing: Mobile Web Services, BREW, SALT, and M-Services.

Chapter Summary

Chapter 1, "Welcome to Mobile and Wireless," is a nontechnical introduction to mobile wireless computing. It starts with an overview of key terms (e.g., mobile, wireless, m-commerce, and m-business) and moves on to a discussion of the benefits and challenges that surround mobile computing. An overview is also provided of the main mobility enablers, including wireless networks, mobile devices, and software infrastructure. This chapter will help organizations understand the risks and rewards in developing mobile solutions.

Chapter 2, "Mobile Devices," overviews the mobile device market, with an emphasis on devices that are most appropriate for corporate solutions. For each device category, we will look at the leading features, such as screen size, data input mechanisms, wireless support, and storage space.

This chapter also covers key criteria for selecting mobile devices, with a focus on data input mechanisms and wireless connectivity options. The chapter concludes with information on mobile device manufacturers and the classes of devices they provide.

Chapter 3, "Wireless Networks," addresses all aspects of wireless network coverage, including wireless personal area networks (WPANs), wireless local area networks (WLANs), wireless wide area networks (WWANs), and satellite networks. For each category, the prevalent technologies are examined, followed by a discussion about what the future holds. From this chapter you will gain an understanding of the wireless network protocols that are being used today and for what types of applications. This knowledge will be valuable as you continue through the book to learn more about the design and development of mobile and wireless applications.

Chapter 4, "Mobile Application Architectures," introduces you to the leading application architectures available for mobile computing: thin client (wireless Internet), smart client, and messaging. The chapter starts with a list of key criteria that should be considered when determining which application architecture is most suitable for a given application. It then proceeds with an overview of each application model, which includes a discussion of the advantages and disadvantages they present.

Chapter 5, "Mobile and Wireless Messaging," takes a look at the key messaging technologies currently available. It begins with an overview of the common messaging systems, such as email and paging, then moves on to SMS, EMS, and MMS, and finishes with push and application-to-application messaging. After explaining the various messaging systems, it covers the messaging value chain, from device manufacturers to messaging middleware providers.

Chapter 6, "Mobile and Wireless Security," starts with a security primer on the key aspects of creating a secure environment; it then provides information on each of the technologies involved in building secure applications. Next the chapter offers insight into issues surrounding WAP security, such as the WAP gap, before addressing issues related to securing smart client applications. The goal of this chapter is to provide developers with enough information to make educated decisions when implementing security in their mobile solutions.

Chapter 7, "Smart Client Overview," highlights the main components of a successful smart client solution. It then takes an in-depth look at the major mobile operating systems that are available for smart client solutions. The combination of the mobile operating system and the device hardware often dictate whether a smart client solution is possible to implement.

Chapter 8, "Smart Client Development," prepares you for some of the technical challenges you will encounter while developing smart client applications. It also gives you some pointers on how to get started with development. The chapter steps through each part of the development process, taking a look at technology that is available to help you build your mobile solutions. It also discusses the pros and cons of developing native versus Java applications. Information regarding device emulators, SDKs, and development tools is also provided, to help you get started with your mobile solutions.

Chapter 9, "Persistent Data on the Client," explores one of the fundamental components of smart client applications: persistent data storage. This is the technology that allows you to maintain data on the device, removing the requirement for wireless network coverage. When it comes to how the data is stored, you have a variety of options from which to choose. You can use the device's file system to store data, build your own data storage mechanism, or purchase a commercial solution. This chapter evaluates all of these options, in addition to taking a closer look at the reasons why databases are an important component of smart client applications.

Chapter 10, "Enterprise Integration through Synchronization," provides information on the primary way in which smart client applications access enterprise data, using synchronization. This chapter covers the fundamental concepts involved in enterprise synchronization, including synchronization architectures and techniques. It also covers some of the synchronization technologies available commercially, and provides an overview of SyncML and where it fits into data synchronization.

Chapter 11, "Thin Client Overview," defines the thin client application architecture by highlighting the main components that comprise a successful solution. The overview is followed by a comparison of J2EE and .NET for server-side development. The chapter concludes with information on the leading wireless Internet protocol, Wireless Application Protocol (WAP), and the steps involved in processing a wireless Internet request.

Chapter 12, "Thin Client Development," explains how to start developing wireless Internet applications. It steps you through the various stages of the development process, starting with needs analysis phase and finishing with deployment options. As you move through this process, helpful hints are provided for avoiding common pitfalls of developing thin client applications. At the end of the chapter is a section on the common thin client application models, which outlines the target audiences, technical challenges, and types of solutions available for each application type.

Chapter 13, "Wireless Languages and Content-Generation Technologies," investigates the range of markup languages being used for wireless Internet applications, including HDML, WML, HTML, cHTML, and XHTML. For each markup language, sample code is given to demonstrate its syntax. The second part of the chapter delves into the various techniques that can be used to generate dynamic wireless content. This includes server-specific technology, such as CGI and ASP, as well as cross-platform technologies such as Java servlets, JSPs, and XML with XSL style sheets.

Chapter 14, "Wireless Internet Technology and Vendors," looks at the technologies commonly used when implementing wireless Internet applications. These technologies have been divided into four categories: microbrowsers, wireless application servers, development tools, and wireless service providers. For each category the key technology features are investigated, and a summary of related vendor solutions is provided. The goal is provide you with enough information to make educated decisions as to which technology and vendors you will want to evaluate further.

Chapter 15, "Voice Applications with VoiceXML" explains how voice applications are built using the Voice eXtensible Markup Language, VoiceXML. Unlike other applications discussed in this book, VoiceXML provides a voice interface into enterprise systems, rather than a visual one. The VoiceXML architecture is very similar to that of Internet applications, but the Web browser is replaced by a voice browser, and the handheld device is replaced by a telephone. Voice interfaces give true universal access to your applications. After the history of VoiceXML is examined, the VoiceXML architecture is discussed, followed by information on building VoiceXML applications.

Chapter 16, "Mobile Information Management," covers two separate but related technologies: personal information management (PIM) and mobile device management. PIM applications include email, calendars, task lists, address books, and memo pads. Access to these applications is often the reason why consumers purchase mobile devices. Mobile device management software can provide substantial benefits for both the deployment and management of software and devices. This chapter divides these topics into separate sections to focus on the capabilities that each solution provides.

Chapter 17, "Location-Based Services," examines location positioning technology, specifically addressing how location information can be used in both consumer and corporate applications and previewing the standardization efforts that are underway for location information. It also covers what, why, and when location-based solutions are relevant to mobile and wireless computing.

Chapter 18, "Other Useful Technologies," focuses on technologies that are just beginning to be adopted by mobile application developers. The four technologies covered include Mobile Web Services, BREW, SALT, and M-Services. All have been developed to improve upon previous technologies in the same market space and to become the standard in their respective fields. Of these technologies, Web services are clearly the leader in market acceptance and standardization. The others, BREW, SALT, and M-Services, are still working to achieve meaningful vendor and developer acceptance. The goal of this chapter is to introduce these technologies and explain how they relate to mobile computing.


Who Should Read This Book

If you or your organization is planning to build mobile and/or wireless applications, this book is for you. The content is appropriate for anyone who wants or needs to learn about mobile and wireless technology and how it applies to building successful applications. Though the book is technical in nature, it does not necessarily require you to have a strong technical background. If you are comfortable with general computing architectures and have some understanding of how applications are developed, then you will be able to gain valuable information from reading this book. More specifically, if you have in-depth development experience, and are already knowledgeable about mobile computing, the design and development chapters will prove to be beneficial, as will the chapters on related technologies such as location-based services and mobile information management. Many of my colleagues who are very proficient in mobile computing were able to garner new knowledge and ideas by reading this book.

Depending on your background, you can read this book in a number of different ways. Those of you who are new to mobile and wireless computing or who do not have a technical background will benefit most by reading the first four chapters in order. These will give you a solid understanding of the business aspects of mobile and wireless computing and of mobile devices, wireless networks, and mobile application architectures. You may then want to continue reading through each chapter sequentially, or you may want to jump to another section that is of interest to you. An entire part of the book is dedicated to each of the leading mobile application architectures; and the final part delves into technologies that are useful, but not necessarily required to build mobile applications.

For those of you who have experience with mobile devices and wireless networks, and who want to learn more about mobile application architecture design and development techniques, you may want to jump straight to Chapter 4, "Mobile Application Architectures," and go from there. After reading Chapter 4, you will have a solid understanding of your development options, enabling you to move on to the chapters that are relevant to the applications you are planning to develop. As you are reading, you can always reference the chapters on key technologies, such as wireless networks, mobile devices, and security, to refresh your knowledge of those topics.

However you read this book, it will prove to be a useful reference tool. Whether you read it from cover to cover or only read the chapters most pertinent to your project, you will always be able to go back and review content as required. Each chapter also contains a list of helpful Web links where you can go to get more in-depth information, updates on technology specifications, or another perspective on how the technology relates to your project. This book is intended as an all-in-one resource containing concise, yet insightful, information on all aspects of the mobile and wireless industry.


Where to Go from Here?

The mobile and wireless industry is in a very exciting phase in its evolution. It has moved beyond the marketing hype into the design and development of concrete enterprise solutions. This book provides an in-depth look at the technologies that are available to extend enterprise systems to mobile users.

Those of you who want an overview of mobile and wireless application terminology and business issues should start reading at Chapter 1. Those who want to dive right into the technology can start with an overview of mobile devices in Chapter 2 or wireless networks in Chapter 3. Regardless of what else you decide to read in this book, it is recommended you read Chapter 4, as it provides an overview of the leading mobile application architectures, with the advantages and disadvantages of each.

By reading this book, you will gain a solid understanding of mobile and wireless technologies that will help you to develop many successful mobile applications. Ultimately, it is these applications, not the hardware or software infrastructure itself, that will lead to the overall success of the mobile and wireless industry.


Part One: Introduction to the Mobile and Wireless Landscape

Chapter List

Chapter 1: Welcome to Mobile and Wireless
Chapter 2: Mobile Devices
Chapter 3: Wireless Networks
Chapter 4: Mobile Application Architectures
Chapter 5: Mobile and Wireless Messaging
Chapter 6: Mobile and Wireless Security

Part Overview

Mobile and wireless computing has the power to change the way business is conducted. It allows employees, partners, and customers to access corporate data from almost anywhere. Universal data access, combined with increased worker productivity and effectiveness, is driving the demand for enterprise mobile applications. As the demand continues to increase, the mobile infrastructure that makes creating sophisticated mobile applications possible is maturing. We have moved past the irrational exuberance that surrounded consumer wireless applications into the reality of creating advanced, integrated enterprise solutions that bring true value to enterprises that are adopting mobile and wireless technology as part of their core infrastructure.

Creating successful mobile and wireless applications requires a profound knowledge of various technologies, including network protocols, portable devices, application design and development, and security. In addition, enterprise managers need to understand the risks and rewards of introducing mobility into their organizations. The combination of business rationale and technical expertise can lead to the successful development and deployment of mobile and wireless solutions today!

The first part of this book is aimed at introducing the reader to the mobile and wireless landscape. It lays the foundation on which the rest of the book is based, covering mobile devices, wireless networks, mobile application architectures, mobile and wireless security, and messaging technology. Each of these topics is covered in its own chapter, as follows, to provide a concise introduction to mobile and wireless computing.


Chapter 1: Welcome to Mobile and Wireless

Overview

The mobile and wireless industry is entering an exciting time. Demand for mobile technology is growing at a tremendous rate. Corporations are deploying mobile applications that provide substantial business benefits, and consumers are readily adopting mobile data applications. Exciting new mobile devices are constantly being introduced, and wireless networks are providing access to data from almost anywhere. In short, mobile and wireless technology has matured to the point where it is ready for wide-scale adoption.

Actually, mobile applications have been successfully deployed for many years, but these have been largely the effort of early adopters, who have gained a clear competitive advantage by implementing a mobile solution. Wide-scale deployment of mobile and wireless applications is just starting to take place. Corporations are just beginning to realize the benefits that mobility provides. Oddly enough, many of the advancements are taking place in the enterprise market, contrary to early industry hype, which was largely focused on consumers. There are both business and technical reasons why this is taking place.

Return on investment (ROI) has become an important figure for determining whether to implement a mobile solution. It is pretty simple really. If a company can foresee a reasonable return on its investment, it can justify building the application. If it cannot, then the application will have to wait. It is much easier to determine the ROI for internal business applications than it is for consumer applications, so they get implemented first. On the technical side, corporations have much more control over the technology being used, so they can build applications that require specific hardware, software, or network connectivity. This allows them to deploy a variety of application types that can run in either online or offline modes. There is no such control over the consumer market, often limiting the type of applications that can be deployed.

Before we get into the technical aspects of building mobile applications and discussing the various application architectures, we are going to look at some of the business issues surrounding the mobile industry. This chapter provides information on mobile and wireless from a less technical perspective. It focuses on the issues around implementing a mobile solution, including the business benefits and expected challenges, as well as the main mobility enablers.


Definition of Mobile and Wireless

The definition of mobile and wireless varies from person to person and organization to organization. In many cases, the terms mobile and wireless are used interchangeably, even though they are two different things. Let's start with the term mobile. Mobile is the ability to be on the move. A mobile device is anything that can be used on the move, ranging from laptops to mobile phones. As long as location is not fixed, it is considered mobile. Areas that are not included in our definition of mobile include remote offices, home offices, or home appliances. While these are definitely remote, they are not considered mobile.

Wireless refers to the transmission of voice and data over radio waves. It allows workers to communicate with enterprise data without requiring a physical connection to the network. Wireless devices include anything that uses a wireless network to either send or receive data. The wireless network itself can be accessed from mobile workers, as well as in fixed locations. Figure 1.1 depicts the relationship between mobile and wireless. As you can see, in most cases, wireless is a subset of mobile; but in many cases, an application can be mobile without being wireless.

Figure 1.1: Relationship between mobile and wireless.

For an application to be considered mobile or wireless, it must be tailored to the characteristics of the device that it runs on. Limited resources, low network bandwidth, and intermittent connectivity all factor into the proper design of these applications.

Wireless applications that are not mobile use fixed wireless networks. These are wireless networks that provide network access in a fixed environment. An example is a wireless local area network (WLAN) that is used to give desktops network access. Many businesses as well as home users are installing WLAN technology to avoid having to install network cables throughout their buildings. Another example is network access via satellites in remote locations where there are no other connectivity options.

On the other side, we have mobile applications that are not wireless. There are many examples where this is the case. Any application that can be used on the move and that does not have wireless connectivity fits into this category. This includes many laptop and personal digital assistant (PDA) applications. Until only a few years ago, it was actually rare to have wireless data access for mobile devices. For these mobile applications, data is often synchronized using a fixed connection and stored on the device for use at a later time. It is worthwhile to note that even though these applications do not require wireless connectivity, they can often benefit from it when it is available. A sizeable portion of this book is dedicated to looking at these types of applications, which are referred to as smart client applications.

Now that we have defined mobile and wireless, it is time to look at some of the areas in which mobile applications are being deployed. Similar to the terms mobile and wireless, there is often confusion around the terms m-commerce and m-business.


m-Commerce

Mobile commerce, or m-commerce, refers to the purchase of products or services from a mobile terminal. Most of the early hype surrounding wireless technology was related to m-commerce. Companies envisioned consumers everywhere using mobile devices to purchase products. With the success of e-commerce for many types of purchases, it just made sense that m-commerce would be at least as successful. At the time, new wireless Internet technology was just coming to market, bringing with it enormous expectations. How could m-commerce not succeed? It is essentially the same as e-commerce without the constraints of a wired connection.

To meet these wild expectations, wireless operators paid billions of dollars for wireless spectrum licenses so they could upgrade their networks to meet the upcoming demand. For example, in Britain, the auctions for wireless spectrum raised $35 billion (U.S.). This equates to several hundred dollars from each person in the country. Other countries followed suit, selling their wireless spectrum for billions of dollars as well. But there is one problem: The wireless operators cannot cover these costs based on current revenue, and voice and wireless Internet access do not even come close to compensating for the expenditures. The idea was that m-commerce would help grow revenue for wireless carriers as well as the service providers. Unfortunately, as of early 2003, this has not yet come to fruition, and many operators are in serious financial trouble. The idea of making purchases from a constrained device is not that attractive when there are so many other avenues available to make the same transaction. Making the purchase at a physical store location, or even on a desktop Web browser is much more productive and enjoyable than using a wireless device, especially when the device is a mobile phone.

m-Commerce is best suited where the consumer has a sense of urgency, when they are required to have their goods or services immediately for upcoming functions and events. For product purchases, the sense of urgency is overcome by the fact that the consumer will still have to wait for the product to be delivered. In the near future, this limits m-commerce to products and services that can be obtained instantly, such as movie tickets or information services. We are still far from the time when consumers will be using their mobile devices to purchase appliances or to apply for a mortgage. Thankfully, there are some m-commerce offerings that show potential. The following solutions should help to drive the m-commerce market in the coming years:

  • Digital purchases. The most suitable purchase for a mobile user is for a product that can be downloaded and used immediately. The two biggest markets for digital applications are ringtones and games. Many carriers allow users to download new ringtones for their devices for a nominal fee. This provides users with a way to personalize their device. Another surefire success is mobile and wireless games. The advances made in mobile devices make them great vehicles for game playing.

  • Mobile banking. There are two benefits to mobile banking that a wireless device can provide. The first is providing access to personal bank accounts to view account history and execute transactions. This is an extension to Internet banking that has been very successful. The second is using a mobile device for payments, essentially acting as digital cash. A great deal of interest has been expressed about this area, so expect it to become a reality in the near future.

  • Information services. Although mobility has many advantages, mobile users often feel out of touch with their daily routines. Information services help address this by providing information that the user is accustomed to having, such as stock quotes, weather information, and sport scores. With the mobile messaging technology growing in popularity, many forms of information can actually be pushed to the user in the form of an alert or notification.

  • Location-based services. The ability for merchants to capture and react to a user's current location and requirements can be a powerful tool for selling services. Location-based services allow consumers to find the precise information they need at the exact time they want to use it. This will be an important enabler for m-commerce solutions, although privacy concerns will have to be addressed before location services are widely utilized.

  • Mobile shopping. Most forms of shopping are not going to be popular from mobile devices anytime soon. It is impractical to surf for items using constrained devices, making other methods of shopping much more productive and enjoyable. At the same time, there are some forms of purchases that lend themselves well to m-commerce. For example, having the ability to purchase movie tickets for a show playing the same evening can quite valuable. Mobile devices can also be used for comparison-shopping. Before making a purchase, a shopper in a retail store may want to first see what the current price of a product is from an Internet vendor to ensure they are getting a good price.

  • Mobile advertising. As mobile users start to take advantage of m-commerce solutions, mobile advertising is sure to follow. The mobile operator has access to several types of information that is attractive to advertisers, such as where users are located and what they use their mobile phone for. With this type of information, advertisers can send out personalized messages. The biggest obstacle to mobile advertising is customer backlash. If users start to get unsolicited messages and advertisements on their devices, they are likely to switch service providers, or worse, stop using their device. For this reason, in the near future, we will most likely only see requested advertisements, such as the nearest gas station or restaurant.

The lack of m-commerce acceptance can be blamed on both technical and business issues. On the technical side, the devices and networks do not have compelling features for consumers to use them for purchases. The interface on most phones is inadequate for any real data entry, and the wireless networks only recently have the capacity for the content that is associated with making a purchase. Grayscale images do not do a great job of selling a product. There are also security concerns that need to be addressed. Consumers are not convinced that e-commerce is secure, so confidence in m-commerce security still has a long way to go. On the business side, there are two major issues. The first is the lack of compelling applications. There are no killer m-commerce applications that are driving adoption. The second revolves around billing. The wireless industry has to address billing and pricing policies between the consumer and the company providing the service. Most consumers are not looking to establish billing relationships with every service provider they do business with. All of the billing has to be managed through a central source (most likely the wireless carrier) for adoption of new services to increase.

m-Commerce will eventually succeed. It is just taking longer than most people expected. Devices are steadily improving in both performance and usability, and wireless networks now offer communication speeds surpassing traditional desktop modems. At the same time, wireless operators continue to offer new products and services that are suitable for mobile users. Finally, as mobile devices start to be used as digital wallets, a new form of m-commerce will emerge. Devices have the potential to replace credit cards as the primary means of making purchases. So rather than using the wireless Internet to purchase a product that will be delivered at some point in the future, it can be used to pay for a product at a physical store location, just as you would currently use cash or debit cards.


m-Business

m-Business relates to e-business as m-commerce relates to e-commerce. Typically, m-business solutions are used by corporations to provide secure mobile access to enterprise data from any location. They allow employees to be more effective at their jobs. By having critical data at their fingertips, employees can respond more quickly to inquiries, remove inefficiencies brought about by manual data entry and retrieval, and make decisions based on current information. Most of the current demand for mobile and wireless technology surrounds the m-business market.

While consumers continue to purchase inexpensive mobile phones, business users are adopting high-end PDAs and laptops to conduct business. They require devices that have adequate power and functionality for advanced business applications. When wireless data access is required, business users are not deterred by the associated costs because they obtain justifiable benefits from implementing m-business applications. Corporations are able to readily see the benefits in terms of return on investment and employee productivity. In contrast to the hype around m-commerce, there is true growth and opportunity for revenue around m-business.

m-Business solutions are being deployed in several industries, using a wide variety of mobile and wireless technology ranging from public wireless networks to local area wireless networks. Devices range from mobile phones to PDAs to ruggedized tablets. The users of these applications include mobile business users, sales agents, and field service workers. Some of the leading m-business solutions being deployed today include:

  • Mobile office. Mobile office solutions integrate with enterprise groupware systems, such as Microsoft Exchange and Lotus Notes, to provide timely access to enterprise information such as email, calendars, task lists, and address books. Access to these applications has become a core requirement for many mobile professionals. (This is not to be confused with Microsoft Office productivity tools such as Word and Excel.)

  • Field sales. Current information is one of the most important assets for a sales force to have. The difference between making a sale or not often depends on having immediate access to information while you are still meeting with the customer. The best way to ensure the sales staff has this information is to deploy a mobile Sales Force Automation (SFA) application.

  • Field service. The nature of field service makes it an ideal candidate for mobile solutions. Service workers can improve their efficiency by having job-related information on hand, such as customer service history, inventory information, technical specifications, and data on repair procedures. In addition, information on customer issues and schedule changes can be sent to technicians while they are traveling.

  • Transportation and logistics. Providing delivery drivers with a mobile solution allows transportation and logistics businesses to have up-to-the minute information on deliveries, completed checkpoints, package statuses, and vehicle locations. In addition, delivery drivers can receive wireless dispatches and respond instantly, improving productivity and increasing customer satisfaction.

The applications just listed are only a sample of the numerous m-business solutions being developed and deployed today. There are literally hundreds of other mobile line-of-business solutions being used to help corporations become more successful. Mobile business applications are now starting to move beyond the early adopter stage to become a core component of a successful enterprise solution.

Note

The information provided in this section is just an overview of what m-business solutions can provide. The focus of this book is primarily on the design and development of m-business solutions. The topics discussed do lend themselves well to m-commerce as well, but the intent is to provide information that is relevant to m-business.


Components of a Wireless Environment

Putting together a wireless solution requires products and services from several parties. The combination of all of these parties constructs the mobile value chain. Each "link" in the chain corresponds to one aspect of an end-to-end enterprise solution. Figure 1.2 shows how the components of a complete enterprise mobile solution relate to one another. No single vendor can provide all of these offerings on its own, but with the formation of strategic partnerships, many vendors are working toward providing an integrated end-to-end solution. For many development managers, this is preferable to having to piece together a solution on their own.

Click To expand
Figure 1.2: Wireless solution value chain.

Wireless Operators and Service Providers

For any wireless solution, some form of wireless operator or service provider will be required. These are companies that provide the communications infrastructure for wireless wide area networks and/or wireless local area networks. Most of these providers are the same companies who provide wireless voice access for mobile phones. In some cases, other companies package the wireless communication component with other services such as wireless gateway software and client device software. Companies that provide such packaged offerings are referred to as mobile virtual network operators (MVNOs). In either case, it is important to select a wireless operator that can provide the required services in the geographic area in which your solution will be deployed.

Independent Hardware Vendors

In addition to the mobile devices, other hardware is often required for wireless solutions. This may include wireless modems, network cards, and wireless access points. Most of the laptops and PDAs available require additional hardware for wireless connectivity. This is usually in the form of a Compact Flash (CF) or PCMCIA card. This is starting to change with integrated wireless devices such as the Palm i705, Handspring Treo, RIM BlackBerry, and wireless-enabled laptops, but it will still be some time before this is standard on all devices.

Software Infrastructure Providers

In many aspects, the wireless software industry is just starting to mature. Many of the niche players have either fallen due to poor technology or business planning, or have been acquired by larger organizations. Leaders are emerging in all fields, including wireless application servers, mobile data storage and synchronization, wireless Web browsers, mobile office software, and device management. When implementing an m-business solution, you will want to select a software provider that has a proven track record and can demonstrate its offering in the environment you have selected. More details of software vendors are provided throughout the book as we cover the technology related to their specific offerings.

Independent Software Vendors (ISVs)

In addition to software infrastructure providers, independent software vendors, or ISVs, can provide industry solutions that require less work to deploy than building a solution from the ground up. Many of these solutions are either aimed at horizontal markets, such as field sales or field service, or at vertical industries, such as healthcare, finance, and transportation and logistics. If you are deploying a solution that is common to many other companies, it is likely that a turnkey solution is available from an ISV. Many of the software infrastructure providers will have lists of ISVs for various industry solutions if you are looking for a place to get started.

System Integrators (SIs)

System integrators, or SIs, are the companies that can help bring all of these components together. Many of the large SIs have practices focused on mobile enterprise solutions. If you are uncertain where to start, or can foresee that there will be difficulty implementing a mobile solution, using a system integrator can provide valuable benefits.

Device Manufacturers

Mobile devices are a requirement for a mobile solution. These devices range in size, functionality, and cost. It is important to choose the right device for the application being deployed. For m-business solutions, PDAs and laptops are more commonly used than mobile phones. This is because they offer more effective user interfaces, and can run more sophisticated applications than what is offered on mobile phones. This situation may start to change as smart phones (a combination of phone and PDA) become more popular in the business world. Chapter 2, "Mobile Devices," provides an overview of the range of mobile devices currently being used.

Keep in mind that not all of these components are required for every solution. It is entirely possible to utilize only a subset of the value chain and still produce the application that is right for the task at hand. For example, a mobile field service application can be created using only a software infrastructure provider, application developers, and mobile devices. If the solution is mobile, but not wireless, then the wireless operator is not required. Many solutions do not require additional hardware other than the device itself, and system integrators are required only when development and integration is not performed by in-house resources. As you start to plan your particular solution, you will quickly determine which components your solution will require.

As we continue through the remaining chapters of Part I, more information on these components will be provided. From there, the other parts of the book will provide everything that you need to know to design, develop, and deploy effective mobile and wireless enterprise solutions.


The Mobile Market Evolution

Every technology goes through many phases as it evolves. It starts with market hype, where the media and leading-edge companies set lofty expectations for the benefits that this new technology will provide. If the market hype is successful, early adopters will start to use the technology to attract new customers to their business, with the expectation of increased profits. These early adopters usually help to bring on the next phase—reality. This is when companies realize either that the market is not ready for the technology or that the technology is not ready for the market. In either case, the result is a period of apprehension and reevaluation. This leads to a lull in the market, giving both the technology providers and purchasers an opportunity to mature. The result is technology that is now ready for mass adoption, that is finally able to meet the potential that was widely discussed several years prior. Mobile and wireless technology fits this evolution to a tee:

  • Irrational exuberance. In the late 1990s, companies could not say enough about the benefits that mobility would offer. Industry analysts predicted that within a few years hundreds of millions of people would be using wireless phones for all kinds of tasks such as Internet banking, purchasing goods, or sending text messages to friends and colleagues. Wireless networks would be pervasive, allowing for instant data access from anywhere, at speeds approaching that of wired networks, and devices would be powerful enough for advanced multimedia applications. This phase for mobile and wireless did not last too long.

  • Market reality. By the year 2001, the reality of wireless applications became apparent. Technology such as Wireless Application Protocol (WAP) that promised to provide data access anywhere did not meet expectations. Wireless networks introduced new challenges such as limited coverage, low bandwidth, and high latency that proved to be difficult to overcome. Mobile devices did advance, but many of them were targeted at the consumer market, which turned out not to be quite ready for wireless data on a large scale. Improvements were required if the predictions were going to come true.

  • Mass adoption. After two years of technical advances and modest growth, we are finally reaching the stage of mass acceptance of mobile and wireless applications. The wireless networks have improved with increased bandwidth and always-on data access; mobile devices have evolved to be enterprise-ready; and corporations have had an opportunity to make concrete plans for the introduction of mobility into their organizations. Early adopters showed that tremendous benefits could be achieved by implementing mobile applications, and it is now the time to realize those benefits.


Why Go Mobile?

For most organizations, a time comes when a decision about mobile applications needs to be made. Why go mobile? What benefits will it provide to the organization, to the application users, and to their customers? Does it make financial sense to deploy mobile applications? These are just a few of the questions that organizations need to answer. Unfortunately, there is no single answer that relates to everyone. The answers to these questions will vary depending on the industry, application type, and the current infrastructure in place. For this reason, we will not attempt to provide concrete numbers on going mobile, but rather cover some of the general benefits that both businesses and end users can hope to achieve with a mobile solution.

We are at a time where mobile solutions can provide tremendous benefits to a business. The advances in devices, software infrastructure and wireless networks have made mobile solutions more practical than they ever have been. The cost of these solutions is going down, while the performance is going up, allowing the price/performance ratio to reach a level that is acceptable for most businesses.

Business Benefits

From a business perspective, the main reason to implement a mobile solution is to increase profit. There may be other side benefits, but when it comes right down to it, any expenditure has to have a positive impact on the bottom line to make it justifiable. The question then becomes, How can a corporation increase its profit by implementing a mobile solution? Profits can be increased in two ways: by increasing revenue or by reducing costs. This section explains how mobile solutions can aid in accomplishing each of these goals.

Increasing Revenue

A mobile solution can help to increase revenue in several ways. Most are realized by empowering employees to be more effective at their jobs. Examples include providing access to accurate information at the time it is needed and reducing inefficiencies brought about by dated business procedures. Some of the main advantages that mobile solutions provide to increase revenue include the following:

  • Increased employee productivity

  • Faster response times to business changes

  • Streamlined business processes

  • Improved customer satisfaction

  • Increased competitive advantage

In positions such as field sales and field service, employees require access to many forms of enterprise data. A mobile solution allows them to access this data when it is required, without having to print out work orders, inventory lists, price charts, customer history records, and other similar pieces of information. For many workers, being able to access corporate information from a mobile device helps them avoid unnecessary visits to the office so they can spend more time working with customers.

Having accurate data on hand also makes them more effective at their given position. They can respond to change in the business environment much more quickly, allowing them to capitalize on new opportunities. With the ability to add, alter, or remove jobs throughout the day, field service workers can quickly and easily fill in any gaps in their work schedule, preventing costly downtime. In addition, once a job is complete, the required billing information will automatically be updated in the enterprise system without having to manually enter the data. This allows companies not only to respond to a customer's needs faster, but also to collect for services rendered in a timely fashion. Customer satisfaction will increase, leading to repeat business.

Having a way to measure the benefits the solution provides is very important. For a sales representative, this may include looking at the average revenue per salesperson, measuring the time it takes to close an opportunity, or counting the number of upsells that were executed. For field service workers, it may include counting the number of visits required to fix a problem, measuring customer downtime, and looking at the increase in the number of service calls that are made with the new solution in place. Once these metrics are calculated, they need to be compared with the costs associated with the solution to determine the overall benefit.

Reducing Costs

In many cases, the cost reductions obtained by implementing a mobile solution are more substantial than the increased revenue. Most paper-based systems are very inefficient, with much of the time being spent manually transferring data from printed forms into electronic systems. This introduces an opportunity for errors and adds an extra layer to the process that can easily be avoided. Mobile solutions allow for data to be captured electronically where it is first acquired. This leads to more detailed data with higher accuracy than paper forms. The data is then directly integrated into the appropriate system for processing. The result is quicker turnaround times on orders, shorter billing cycles, more accurate time and expense reporting, reduced reject rates due to errors, and overall more efficient systems that do not require redundant data entry.

Other areas for cost reduction include reducing the number of printed materials. For many businesses, the cost of printed materials such as manuals or schematic diagrams alone is quite high, especially if they have to be reprinted often. Being able to replace these materials with an electronic system can provide tremendous cost savings with little effort. There are also opportunities to manage the supply chain more efficiently, allowing companies to reduce required inventory levels while providing more timely service to customers.

End-User Benefits

In addition to the business benefits, there are also advantages for the end user. Rather than being confined to the office, mobile solutions provide flexibility to work in whatever surroundings are convenient. This is particularly important to mobile professionals who are frequently traveling for business purposes. While traveling, they often have extended periods of downtime waiting in airports, between meetings, or when in a hotel. During these periods, remote access to enterprise applications can provide a tremendous benefit. Having the ability to do time and expense tracking, enter sales orders, or check corporate email allows them to get back to their families and friends on their return home without having to visit the office. For employees who travel a lot, this is a great way to help them balance both work and family priorities.


Challenges

As companies look to reap the benefits of providing mobile enterprise applications, they are sure to come across some of the many challenges that are commonplace in the current state of mobile computing. These challenges do not reflect any particular vendor solution, but rather are inherent in mobile computing today. By understanding these challenges, companies will be able to make better decisions as to which devices, networks, and mobile architectures are best suited for their particular solution.

Oddly enough, many of the challenges are raised by the very technologies that enable mobile solutions: mobile devices, wireless networks, and software infrastructure. In a way this does make sense, since these technologies represent new methods of computing, introducing complexities that development teams may not have experience with. Actually, as the challenges are investigated in more depth, it is clear that many of them represent the relative immaturity of the wireless industry, and will be minimized as the market continues to evolve.

Wireless Network Issues

Even though wireless access is not a requirement for a mobile solution, it is often considered one of the primary challenges of implementing mobile applications. This is because it affects all aspects of the solution, including design, development, and deployment. Even when companies are building an application that will not initially take advantage of wireless connectivity, they usually want to plan for its introduction in a later phase of the application's life cycle. Wireless network issues have to be incorporated into the preliminary planning stages so future adoption is possible. The following are some of the issues with wireless networks that have to be considered when a solution is being developed:

  • Coverage and penetration. Wireless coverage is not pervasive. Wireless operators typically provide coverage in areas of higher population density, surrounding a particular geography. Even when the physical geography has network coverage, there is no guarantee that the signal can penetrate physical barriers such as buildings or tunnels. These interruptions can wreak havoc on applications that are not designed to handle such circumstances.

  • Bandwidth. The speed of wireless connections can differ dramatically depending on the wireless protocol being used. Some of the early wireless networks have very slow data transfer rates, around 9.6 kilobits per second (Kbps), while more modern networks may surpass 56 Kbps.

  • Latency. Sometimes even more important than bandwidth is network latency. Latency is defined as the time it takes for a request to reach the target server. Many users blame poor performance on bandwidth, when it is really the latency in the network that is taking the majority of the connection time. For every round-trip to the enterprise server, network latency can add between 1 and 30 seconds to the overall connection time. The amount of traffic affects latency, so during peak periods of usage, latency will be the highest.

  • Reliability. Dropped connections are common among wireless networks. This can lead to usability issues for certain types of applications. Many of the reliability issues are related to coverage and penetration of the network.

  • Cost. The cost of wireless connectivity can sometimes be prohibitive. Some networks charge by connection times, while others charge based on the amount of data transferred.

  • Lack of standards. Each network provider maintains different network protocols for connecting to wireless devices. Some of these are IP-based, while others are not. This issue is more profound in North America and Asia-Pacific where the leading network providers are implementing several competing protocols. In Europe, there is more of a consensus on network protocols, leading to less complexity.

These wireless network issues have to be addressed on all levels of application design. The mobile device will work only with specific wireless networks, so you have to consider the wireless network during device selection phase. Network issues also affect the type of application that should be deployed. It is important to design the mobile application with wireless challenges in mind. Some mobile architectures are better suited for today's networks than others. (Thorough information on wireless networks is provided in Chapter 3, "Wireless Networks," and a summary of the mobile application architectures is provided in Chapter 4, "Mobile Application Architectures.")

Mobile Device Diversity

The type of device selected is paramount to the success of the mobile application. It is critical that the devices match the types of application being developed. So before selecting which device is most appropriate, you have to ask yourself the following questions:

  • What type of data access is required? Is wireless required? If so, is an integrated modem required, or is an add-on component suitable?

  • What type of application is going to be developed? Is it a smart client business application, email and messaging, or a wireless Internet application?

  • How does the device connect to the enterprise? Does it use wireless connections or is it cradle-based?

  • Which mobile operating systems do we want to use? On which operating systems do we have experience developing?

  • Who is going to use this device? Does it have to be ruggedized to withstand a little punishment or is regular protection adequate?

  • How long does the device have to last without recharging? Does the user have the ability to charge it periodically during the day, once daily, or only every few days?

  • What form factor does this device need to have? What type of data input is required? Is a mobile phone suitable or is a PDA or laptop required?

  • What cost is acceptable?

These are just a few of the questions that need to be addressed before being able to choose the correct device(s). Once a device (or set of devices) has been selected, the development team will have to address some challenges. These include selecting the type of application that works with the mobile operating system employed by the devices, being able to integrate with wireless gateways, learning the APIs for the messaging technology being used, and designing the application to take advantage of the limited screen size and input mechanisms on the device. Very often this requires some degree of knowledge beyond what many developers currently possess.

Sometimes, however, it may not seem like you are choosing a device as much as it is chosen for you. If your company already has equipped your sales force with a certain device, or if the geographic area you are targeting has an extremely limited wireless characteristic, you may feel as if you have no choice. With m-commerce solutions, when a company identifies and targets an end-user group, it often will not have the ability to choose which device that group will use. For instance, if a bank wants to target a certain clientele to provide special mobile services to that group, it will have to determine an application that best fits within the broad range of devices that its customer base is already using.

One final challenge with the device diversity is the management of all of these devices and the applications on the devices. Organizations need to define a device management strategy early in the deployment of mobile solutions before the mobile environment gets too chaotic. If multiple mobile operating systems are supported, a solution needs to be found that provides a single environment for managing all platforms you are deploying.

Software Infrastructure Choices

With the vast number of mobile devices and network connectivity options, it is important to select a software platform that will work effectively with other parts of your solution. This may involve having the ability to create wireless Internet applications using a variety of markup languages, having a persistent datastore with synchronization capabilities, or having mobile messaging services.

Based on the application being developed and which devices it is going to be deployed to, there may be a preference for the server platform that is being used. Is a Java 2 Enterprise Edition (J2EE) platform best suited for your environment? Or is a .NET solution from Microsoft a better choice? For the application on the device, does it have to have offline capabilities or is a WAP online solution acceptable? Each platform has its strengths and weaknesses. You need to find one whose strengths meet your core requirements. This task can prove to be difficult, as mobile and wireless software is constantly changing to meet the growing demands for mobile solutions and to adhere to emerging mobile standards.

Some other concerns that have to be addressed include the following:

  • Mobile and wireless security

  • Introduction of new services, such as location-based services

  • Support of the communication protocols being used

  • Integration with existing enterprise applications and data

  • Support for current, and possibly future, device selections that may be made

  • Development team expertise

All of these aspects of a mobile platform have to be considered when implementing a mobile solution. Additionally, it is a recommended that you anticipate future enhancements you may want in your solutions and adopt a platform that is moving in a similar direction. This may initially seem to be a daunting task, but it is not as difficult as it appears. Mobile and wireless technologies are currently converging on a defined set of standards that are being adopted by network operators, device manufacturers, and software infrastructure vendors alike. This will not happen overnight, but as the mobile and wireless market matures, it will continue to move in the right direction.


Mobility Enablers

Four main market enablers are driving the adoption of mobile and wireless solutions: wireless networks, mobile devices, software infrastructure, and standardization. Without advancements in all of these categories, building mobile enterprise solutions would not be practical. It is no coincidence that mobile and wireless is growing in acceptance just as these technologies and standards are starting to mature.

The previous section covered some of the challenges introduced by these technologies. This section looks at the features these technologies offer and the trends that are emerging to enable the development of robust mobile solutions.

Wireless Networks

As with other mobile and wireless technologies, the initial marketing focus for wireless carriers was aimed at the consumer market. The emphasis was on inexpensive handsets and packaged calling plans to meet the general consumer's needs. This focus was successful in many regards, as mobile phone usage and device sales have skyrocketed. The problem was that the average consumer does not generate much revenue for wireless carriers, and the revenue it does generate is not high-margin. Wireless data usage was considered to be the answer carriers were looking for, but once again, the consumer market did not provide the revenue or profit that was required. Since then, much of the focus of wireless data services has moved to the corporate market.

In an effort to provide attractive functionality for enterprise users, wireless network operators have spent significant resources to upgrade their networks. The first phase of the upgrade was adding data services in conjunction with their voice offerings. The second phase was making these data services faster and more reliable. Actually, network operators are implementing networks with features that will help to overcome many of the problems that were discussed previously in this chapter. The upgrade is not yet complete, but early indications show that the wireless network improvements will have a meaningful impact on mobile and wireless solution deployments. The following are some of the most significant features:

  • Increased bandwidth. Many of the voice-oriented wireless networks provide very limited wireless data capabilities. This is no longer the case with the next-generation wireless networks being deployed today. These networks are designed for wireless data, and provide communication speeds between 56 Kbps and 384 Kbps. This speed is very adequate for the limited amount of data that is typically required from a wireless device. That said, some third-generation wireless networks are boasting speeds approaching 2 Mbps, allowing for advanced multimedia applications.

  • Always-on capabilities. The term always-on refers to the users' ability to access data at any time, without having to establish a connection to the wireless network for each session. This ability has been enabled by packet-switched networks. Unlike circuit-switched networks that bill users on the amount of time they are connected, packet-switched networks charge based on the amount of data transferred. This allows users to stay connected to the network at all times without having to be worried about huge wireless charges. (Chapter 3, "Wireless Networks," has more information on circuit-switched and packet-switched networks.)

  • Lower costs. The introduction of packet-based networks allows wireless operators to offer new types of wireless packages that are based on data usage instead of call times. Many flat-rate packages are now available. These come in various sizes, some offering unlimited data access for a fixed fee. This has become very popular for many corporations as it allows them to know exactly how much the service will cost, making budgeting much easier. Another factor is roaming charges. Many carriers have drastically reduced, if not totally eliminated, roaming charges for using other carriers' services. Historically, these charges have been quite substantial, often limiting the practicality of some mobile solutions.

  • Enhanced services. New services are being offered that can add value to mobile solutions. Many carriers now allow users to download additional applications for their devices, providing a wide range of new capabilities. In addition, some integrated services, such as location-based services, are providing companies with valuable features that can impact the success of custom mobile solutions.

  • Interoperability between carriers. Wireless operators are starting to work together to help promote the benefits of mobility. This cooperation has resulted in a new level of interoperability for both data and voice communication. An example is the ability for users in North America to send text messages to users on other networks, a feature made available in 2002.

Another trend is the introduction of public wireless LANs (PWLANs) to targeted high-traffic areas such as airports, hotels, and conference centers. PWLANs provide high-speed speed data access at a very low cost, and can either augment a wireless wide area network (WAN), or be deployed on their own. These features, along with additional network coverage and new handsets, are an important piece of building wireless enterprise solutions. (Chapter 3 provides complete details on the range of wireless networks and protocols being used.)

Mobile Devices

The advancements being made in mobile devices are truly incredible, and the selection is astounding. A few years ago the choice was between a wireless phone and a simple PDA. Now there is a long list of options ranging from high-end PDAs with integrated wireless modems down to small phones with wireless Web-browsing capabilities. Even the simplest devices provide enough computing power to run small applications, play games, and of course make voice calls.

The proliferation of devices in the enterprise is a key driver for the growth of mobile solutions. As more personal devices find their way into the enterprise, corporations are realizing the benefits that can be achieved with mobile solutions. The trend is for smaller devices and more processing power. A device that fits in your hand has as much computing power as desktops did less than 10 years ago. The same device is also able to communicate over a wireless network and view office documents at the same time. This combination of size, power, and flexibility is a key enabling technology for enterprise mobile solutions. Other key advancements include increased storage space, high-resolution displays, built-in wireless support, reduced energy consumption and increased battery capacity, improved ergonomics, and support for peripherals such as wireless modems, digital cameras, Global Positioning System (GPS) units, portable keyboards, and large-capacity storage.

With the device landscape changing so rapidly, it is recommended that organizations select devices based on immediate business need, not for future intent. Features that are attractive today may not be deemed important for future applications. The device market is currently fragmented, with many specialty-purpose devices targeted at specific sets of users. It is expected that this will continue for the foreseeable future as integrated voice and data devices are not yet experiencing widespread acceptance in the enterprise. (For more details on the range of devices on the market, see Chapter 2, "Mobile Devices.")

Software Infrastructure

Along with wireless networks and mobile devices, a strong software platform is also required to develop and deploy robust mobile solutions. These platforms offer support for the leading mobile computing models, including wireless Internet, smart client, and mobile messaging architectures. In many cases, these platform vendors have partnered with other mobile infrastructure providers to supply an end-to-end solution. This helps ease the process of integrating disparate technologies.

Software vendors have made significant advances in several key areas that enable mobile application development. For wireless Internet applications, the introduction of wireless application server frameworks, device emulators, WAP, and development tools has had an impact. For smart client applications, the advent of small mobile databases, advanced synchronization technology, and comprehensive mobile operating systems has allowed many m-business solutions to be possible. In addition, new technologies from Microsoft in the form of .NET Compact Framework, and Java community in the form of the Java 2 Micro Edition (J2ME), have provided developers with the tools they need to implement these solutions.

We do not want to forget about the advances being made in the areas of messaging, security, enterprise integration, mobile device management, and location services. All of these technologies are key in successful development and deployment of mobile solutions.

Note

This section is intentionally brief, since most of the remainder of this book deals with the design and development of mobile applications using mobile software infrastructure. The first introduction to the mobile application architectures is provided in Chapter 4, "Mobile Application Architectures." These architectures are then explained in more depth in Chapter 5, "Mobile and Wireless Messaging," and in Parts II and III of the book.

Standardization

Many companies have cited the lack of standards as a major obstacle in developing mobile solutions. They are worried that the technology they use will become obsolete before their application is even deployed. This is a valid concern. Having an established standard provides some comfort that their applications will work now and in the future. As with any new industry, it takes time for standards to develop. Fortunately, we are now at the point where standards are emerging at all levels of the mobile environment.

The leading wireless standard is WAP, which defines technologies for developing and deploying wireless Internet applications. The early incarnations of WAP received mixed reactions, partially due to the standard itself, and partly due to the state of the wireless industry. WAP 2.0 has addressed many of these concerns by working much better with common Internet standards.

For markup languages, the eXtensible Hypertext Markup Language (XHTML) is emerging as the language of choice. Many of the existing markup languages such as Wireless Markup Language (WML), Compact HTML (cHTML), and HTML itself are all converging on XHTML. To accommodate differences in client browser capabilities, different profiles of XHTML are targeted at wireless devices. Another markup language that has reached widespread adoption is VoiceXML. VoiceXML is a markup language for the creation of interactive voice applications.

For the development of client-side applications, two technologies are competing for the developers' attention: J2ME and Binary Runtime Environment for Wireless (BREW). BREW is targeted at smart phones, while J2ME spans from smart phones to high-end PDAs. Application developers can feel confident that these standards will provide a stable application environment for some time to come. Although not officially a standard, Microsoft's .NET Compact Framework (.NET CF) will help to drive mobile development for Windows CE-based devices. Similar to J2ME, .NET CF is a viable development platform that is unlikely to fade away. It is also worthwhile to note that the other common development tools based on C/C++ and Visual Basic are good choices for smart client application development.

For synchronization, SyncML is a leading candidate for standardization. The SyncML Initiative now part of the Open Mobile Alliance (OMA) is actively working on synchronization specifications for a variety of data types, including personal information such as calendar and address books, corporate business data, and mobile device management. (More information on SyncML can be found in Chapter 10, "Enterprise Integration through Synchronization," and Chapter 16, "Mobile Information Management.") Finally we have the wireless networks. While there is no agreed-upon standard for wide area wireless, underlying support for the Internet Protocol (IP) is an emerging trend. This is a dramatic improvement over the many proprietary wireless protocols that have been used in the past. For wireless LANs, 802.11b and 802.11a are the leading standards being deployed. Both of these allow for interoperability between both hardware and software products. Bluetooth provides similar support and interoperability for personal area networks (PANs).

Although standards help to promote interoperability and stability, they are not mandatory for creating robust mobile solutions. Many products on the market do not adhere to the standards mentioned previously; nevertheless, they still provide highly functional, stable platforms for building advanced m-business applications.


Summary

Corporations often evaluate mobile solutions by their return on investment (ROI). ROI measures the gains that can be expected in return for the expenditures. This is a very effective approach to determining whether a mobile solution is worthwhile. Many vendors are starting to realize that ROI is an important measurement for success and are providing this information to perspective customers along with the technical merits of their solution. This is helping m-business applications grow in adoption, which helps other mobile and wireless solutions succeed as well. Wireless carriers will continue to increase the capabilities of their networks and provide new services, and device manufacturers will continue to deliver innovative offerings that will be used by both consumers and business users alike.

Many challenges need to be overcome when implementing a mobile solution. Many of these challenges have been introduced by mobility-enabling technology such as mobile devices, wireless networks, and software infrastructure providers. As the industry continues to mature, these challenges will become less significant, and the opportunities mobility provides will become more meaningful. As an industry, we are well on our way to accomplishing the three requirements for substantial industry growth to occur:

  • The availability of compelling applications

  • The availability of suitable mobile devices

  • The introduction of always-on, easy-to-use wireless networks

In the next chapter we will take an in-depth look at mobile devices and their impact on implementing a successful mobile solution.


Helpful Links

Since most of the technical content from this chapter is expanded in upcoming chapters, the links provided in this chapter are for industry analyst Web sites. These sites provide technical and business research and analysis on the mobile and wireless marketplace.

Gartner Group | www.gartner.com
Giga Information Group | www.gigaweb.com
IDC | www.idc.com
META Group | www.metagroup.com
Summit Strategies | www.summitstrat.com
Yankee Group | www.yankeegroup.com


Chapter 2: Mobile Devices

A wide variety of mobile devices are available to address a broad range of applications and users. They range from very inexpensive Web-enabled devices to high-end customized tablets, with laptops, a variety of PDAs, and smart phones in between. Along with size differences come variations in the features and performance that these devices provide. No matter which type of mobile application you are looking to deploy, a device is available that will meet your needs.

This chapter provides an overview of the mobile device market, with an emphasis on the devices that are most appropriate for m-business solutions. For each device category we will look at the leading features, such as screen size, data input mechanisms, wireless support, and storage space. A table summarizing the device manufacturers and the class(es) of devices they sell is also provided for quick reference. This information should be helpful when deciding which device classes are most appropriate for a particular application and which manufacturers produce these devices.

Device Overview

Of all the components in a wireless solution, the mobile device gets the most attention. It is the only part of a mobile solution that the end user is in contact with. When a problem arises, some aspect of the mobile device is often held accountable. This may be the wireless connectivity, mobile operating system, input mechanisms, or performance characteristics. In any case, the application developer absolutely must be intimately familiar with the device or devices being used in order to take advantage of their unique capabilities.

Mobile devices come in all sizes with a wide range of features. Choosing the correct device involves evaluating a variety of criteria other than just cost. Two of the major factors that need to be considered are the data input mechanism and wireless connectivity options. Each of these is described in detail later in this section. Some of the other major areas that should be given special attention include the following:

  • Device size and weight.

  • Available memory for applications and data.

  • Processor speed: This will affect the types of applications that will be able to run on the device.

  • Screen characteristics such as size, color depth, indoor and outdoor suitability.

  • Mobile operating system support: Can it be upgraded when a new version of the operating system is released?

  • Expansion slots for adding peripherals such as more memory, wireless modems, GPS receivers, or digital cameras. Looking into what peripherals are available is also a good idea.

  • Battery life (this is a big one).

  • Integrated features such as digital cameras, keyboards, infrared, and Bluetooth.

  • Software support, including third-party applications, development tools, mobile browsers, hardware drivers, as well as others that may be applicable to your particular situation.

These cover some of the major factors that should be considered, but there are bound to be others specific to the solution being implemented. When you are researching mobile devices, the vendor Web sites are a great place to look first, but keep in mind the information provided will not be very objective. Many other information sites are aimed at developers and business managers alike that can help make the device selection process more effective. The overview of the device categories later in this chapter will also help you become familiar with which devices are available for the enterprise market.

Input Mechanisms

Along with device size and power, the data input mechanism is one of the most important aspects of selecting a mobile device. This does depend on the application, and the levels of user interaction required, but for most m-business applications where a substantial amount of data is entered into the application, data input options have to be given strong consideration.

Mobile data devices receive their properties from two areas: mobile phones and desktop PCs. Both of these have specific design goals and constraints. Mobile phones are designed to be efficient and simple, allowing for single-handed operation by inexperienced users. PCs are designed for power and richness. Mobile data devices have to compromise between the two to provide various levels of functionality and richness. When it comes to methods of data input, several options are available.

Keypad Input

Mobile phones typically implement a 12-digit keypad. This is very intuitive and effective for numerical input but cumbersome and awkward for entering text. This is because each key on a keypad represents three characters. Users have to press a key multiple times to enter a single character. Since mobile phones are primarily designed for voice usage, it is unlikely that the keypad will change anytime soon. That said, there are technologies available that make entering text easier. One of these is called T9, which stands for Text on 9 Keys. This is a predictive text input technology that allows a user to input words by pressing only one button per letter. T9 translates the button press sequences into words. It does not work in all cases, but when it does, it is about twice as fast as using traditional multi-tap systems. America Online, the owner of T9, estimates that it is accurate 95 percent of the time.

Device manufacturers are constantly looking for ways to make keypad text entry more effective. Toggle sticks, rollers, and touch screens will help to alleviate this problem in some areas, but do not expect fast data entry to be a reality on a keypad-driven device anytime soon.

Pen-Based Input

One of the breakthroughs for handheld devices was the introduction of touch screens for pen-based input. This allows a user to enter data using a stylus, without requiring any form of physical keyboard or keypad. Several pen-based input mechanisms are available. Deciding which ones to implement will depend on the mobile operating system and device being used. The most common types of pen-based input are:

  • Soft keyboards. The most approachable method of entering text on mobile devices is by using a soft keyboard, a keyboard displayed on the screen. Users enter data by pressing "keys," just as they would on a physical keyboard. This method is very easy to learn and use, but it is also takes up screen space and can be limiting in terms of input speed. It is often used as a backup mechanism when other forms of data input are not effective.

  • Character recognition. Character recognition works by interpreting which letters a user is entering on the screen. There is usually a specific area on the screen for users to construct the characters. The Windows CE operating system from Microsoft provides this capability. Software runs locally on the device to do the interpretation. The letters have to be constructed fairly accurately for them to be understood. This is usually not a problem for small amounts of data, but can be a challenge for users who need to enter data quickly. They often find the characters difficult to write, leading to mistakes.

  • Graffiti. Palm OS introduced a new form of character recognition based up on simple character-set called Graffiti. The Graffiti characters allow for quicker data input since the letters are easy to input and recognize. There is a learning curve involved, but once Graffiti is mastered, data can be input quickly with few errors.

  • Handwriting recognition. Some forms of handwriting recognition work by taking screen captures of the inputted text, while others actually interpret written characters. The interpretation solutions take character recognition to a new level. Instead of being able to interpret only a defined set of characters with predetermined strokes, handwriting recognition attempts to interpret a user's personal style of text entry. This requires sophisticated software and powerful hardware to do the analysis. Microsoft is implementing forms of handwriting recognition on its Tablet PC platform.

Keyboard Input

Even with the advances being made in other forms of data input, the keyboard remains the most efficient and easy to use (especially for Western languages such as English). Mobile devices have many ways to take advantage of keyboard data entry. Laptops and handheld PCs come equipped with physical keyboards, while the smaller palm-sized PDAs often support keyboards as a peripheral. These keyboards are usually attached as a clip-on unit or via a cable, but wireless connections are also an option. In addition, most PDAs have PC companion software, allowing the user to enter data such as contact information on the PC. Some handheld devices have taken the step of incorporating a keyboard into the unit itself. This is accomplished with small thumb-based keyboards at the bottom of the unit. Research in Motion (RIM) was the first to incorporate this concept into its BlackBerry devices. With its revolutionary design, RIM has attracted a wide variety of users to its devices, prompting other companies, including Handspring and Sharp, to adopt the thumb-sized keyboard as the means for data input.

Voice Input

Voice input is both effective and easy to use. Simple voice commands, such as initiating a call or looking up a contact, can be executed directly on the mobile device. This works by prerecording voice commands into the device. When a voice command is entered, it is compared to the recorded message and executes the corresponding action. Many mobile phones come equipped with this feature.

For more advanced voice applications, such as looking up product information or executing a bank transaction, the voice recognition software resides on a server called a voice gateway. These gateways are run on powerful machines that are capable of running automatic speech recognition and text-to-speech software. This software is capable of understanding complex commands—such as "What is the weather going to be like on Friday in Waterloo?"—and returning the appropriate spoken response. Many of these applications use proprietary Interactive Voice Response (IVR) systems or VoiceXML, an emerging voice standard. (If you are interested in learning more about VoiceXML, see Chapter 15, "Voice Applications with VoiceXML.")

Wireless Communication

Three basic connection options are available for obtaining wireless communication from a wireless device: two-unit, detachable, and integrated.

Two-Unit Configuration

Two-unit connections require two pieces of equipment to work together, such as a PDA and a cell phone, as shown in Figure 2.1. One unit provides the wireless connectivity for the other unit to use. These devices can communicate with each other in a variety of ways:

  • Cable connection. This involves having a physical cable connecting the cell phone and mobile device. The phone must have wireless data support as well as an interface cable to the device of choice.

  • Infrared connection. This involves lining up the Infrared ports on the cell phone and mobile device for communication. A direct line of sight is required for this solution to work. In addition, only selected phones have infrared support available.

  • Bluetooth connection. Bluetooth may be the best option for two-unit connectivity. It allows a mobile phone to provide connectivity through a personal area network (PAN) up to a range of about 10 meters. A direct line of sight is not required, so it is possible to have the cell phone in a different location from the mobile device. This will become an increasingly popular option as more Bluetooth-enabled devices are released.

Click To expand
Figure 2.1: Two-unit configuration.

The advantage of the two-unit configuration is that you can choose each device based on its own functionality, and you do not have to sacrifice features for wireless capabilities. The configuration also provides a great degree of flexibility. If one device becomes outdated or malfunctions, it can be replaced without having to replace the entire system. This is especially appealing when the data device is a laptop or PDA that may not need to be replaced as frequently. In addition, the cell phone can potentially provide the wireless communication for several other devices.

The downside to this configuration is its complexity. Both the cell phone and the mobile device have to be configured properly for this to work. When Bluetooth is not available, the cable or Infrared connections can become cumbersome.

This setup is recommended only where occasional wireless connectivity is required. When frequent access is necessary, it is worthwhile to investigate some of the other options available.

Detachable Configuration

A detachable configuration involves using a plug-in module or clip-on attachment to a mobile device to provide wireless connectivity. These additional modules can provide connectivity to a variety of wireless networks with little configuration. For the plug-in modules, either CompactFlash or PCMCIA cards can be used. This obviously requires a device that has a slot for this type of peripheral. For devices that do not have integrated CompactFlash or PCMCIA slots, external jackets are often available. These jackets (often called sleds) provide the support for CompactFlash or PCMCIA cards.

Note

Some of the wireless modems on the market also include support for voice calls. An example of this is the Sierra AirCard 555, which provides CDMA2000 1x wireless data as well as voice capabilities. The Sierra Wireless Web site can be found at www.sierrawireless.com.

The benefit of using these interfaces is that multiple wireless modems are available, providing connectivity to several wireless networks including WLANs, WANs, and PANs. You can then switch interface cards as you move into different wireless environments. Cards are also available that support connecting to multiple network protocols in one unit.

In some cases, the only available option is a clip-on modem. This is similar to the external jacket, except that the modem is incorporated directly to the unit. These modules are often purchased in conjunction with a wireless service plan since they only provide access to a single wireless protocol, most commonly a wireless WAN.

The majority of the PDAs available now use a detachable configuration for wireless connectivity. It allows users to select the PDA and wireless component separately, but at the same time have them integrate well together. The disadvantage is that the wireless modem uses the open expansion slot so other peripherals cannot be used at the same time.

Integrated Configuration

An emerging trend is to enclose wireless connectivity within the mobile device. This has always been the case for voice-oriented devices such as cell phones and smart phones, but is a new concept for many handheld devices. This configuration has many advantages, as it alleviates complexity and provides tight integration between the mobile OS and wireless modem. Applications for these devices can be designed to take advantage of the wireless modem, knowing that it is always going to be present. Troubleshooting is also simplified, since there is only one manufacturer involved in the solution.

On the downside, some flexibility is lost. The user is now limited to the wireless net-work type that has been integrated into the device. In addition, it may become more difficult for developers to calculate the amount of power an application requires, as they will have a hard time differentiating between the power that the application requires and that of the wireless modem.

For users who will be using wireless communication frequently or who are looking for a very intuitive, user-friendly experience, integrated configurations are ideal. Devices are available for a variety of wireless networks. Many ruggedized devices with integrated wireless LAN access have been on the market for some time, while integrated public WAN devices are just now being deployed on a large scale. As devices continue to evolve, it may become practical to carry a single device for both data and voice communication.


Mobile Device Classifications

Much has changed since 1996 when the PalmPilot was first released. Even though previously there were other palm-sized devices, such as the Apple Newton, the PalmPilot changed the way we look at mobility. Users now had the option of using a small, palmsized device to store their schedules, calendars, to-do lists, as well as perform other simple applications. This was clearly an option that users liked, signaled by the phenomenal pace of adoption of Palm devices. By 2000, the vast majority of all palm-sized devices were based on Palm operating system (Palm OS).

Because of the success of the Palm devices, many other companies released mobile device offerings in an attempt to get a slice of this burgeoning market. As these new companies entered the market, they came out with new devices, with new features. In this section we will look at each of the major device categories. As depicted in Figure 2.2, a distinct relationship exists between number of units sold and price: As the cost rises, fewer devices are sold. Devices costs vary anywhere from under $100 to several thousand, depending on the features required.

Click To expand
Figure 2.2: Device classifications.

Web-Enabled Phones

Cellular phones are by far the most widely used wireless devices on the market. In some European countries, over 75 percent of the population owns a cellular phone. In most cases, the primary use is voice, but with the introduction of WAP, text messaging, and other wireless Internet technologies, data applications have become much more common. With their widespread popularity, Web-enabled phones become an immediate target for wireless Internet applications.

Figure 2.3 shows a typical Web-enabled phone. As you can see, it provides a very limited display (typically between 4 to 12 lines of text), with the regular 12-button phone keypad for data entry. These limitations make cellular phones a poor choice for surfing the Web, since the amount of data that can be received or input is rather limited. The strength of cellular phones is their widespread use, making them very suitable for targeted applications, often aimed at the consumer market. Some examples include stock quotes, traffic reports, flight updates, ticket purchases, and news headlines. In all of these applications, limited amounts of data are required to get the expected response. The amount of data being retrieved is not overwhelming, so the device can display it in a meaningful format. If, however, you are considering implementing corporate applications, such as sales force and field service automation, a more capable device might be a better choice.

Click To expand
Figure 2.3: Nokia 8390 Web-enabled phone. Image courtesy of Nokia.

As you would expect, cellular phones have built-in wireless modems, making it very easy for users to connect to wireless networks. Once connected, the user can use the modem for either voice calls or data applications; or, using the Wireless Telephony Application (WTA) support in WAP, both voice and data can be used simultaneously. In addition, with the always-on capabilities, cellular phones are ideally suited for text messaging applications. Since these messages are typically limited to 160 characters in length, the input capabilities of these devices is suitable. One other side benefit is the long battery life. With their limited processing power, cellular phones are able to conserve battery power, allowing them to last longer than the more sophisticated devices such as smart phones and PDAs. Keep in mind, however, that the more the device is used for wireless communication, the faster the battery power will be consumed.

The primary use of these devices is for voice access, so quality of voice communication, network coverage, and calling packages usually takes precedence over data services when choosing the best device.

Two-Way Pagers

Two-way pagers are designed for mobile users to exchange short, text-based messages. Very often the applications are loaded by the manufacturer and are not upgradeable. These devices do a great job of paging, but often are not suitable for most sophisticated applications. This is true for most two-way pagers, but there are some exceptions.

RIM and Motorola both offer more advanced paging devices, which provide PDA-like capabilities. They both started out using proprietary operating systems, but this has changed with the advent of J2ME, which both have moved to since. The RIM Blackberry devices and Motorola Timeport pagers have expanded upon the basic paging capabilities by offering support for personal information management (PIM) applications and wireless Internet applications. In addition, they offer advanced user input capabilities using a standard—QWERTY—keyboard that is operated using your thumbs. You can see an example of this in Figure 2.4, which shows the RIM 957 (BlackBerry) and RIM 950.

Click To expand
Figure 2.4: RIM two-way pagers. Image courtesy of Research In Motion.

Several microbrowsers are available for these devices, often provided by the company who provides your wireless connectivity. Very often these browsers are WAP-based, using WML as their markup language, although some HTML browsers are available. Since these devices do have a decent means of data input, they are capable of running wireless applications geared at data capture.

One of the most convenient features of two-way pagers is that they are always connected to a wireless network. Users do not have to explicitly connect to a wireless network when they want to access an application. They simply start to use the application and it will transmit the data as required. This is possible because the devices use networks that are packet-switched; users are only charged for the data being transmitted, not per minute as on circuit-switched networks. This feature is required for receiving pages, email, and other types of messages, and also comes in handy for using wireless Internet applications. Also, considering that these devices are always connected to the network, the battery life is quite exceptional, often lasting for weeks without recharging.

Low-End Smart Phones

Smart phones are called such because they provide the ability to run local applications as well as make voice calls. Like Web-enabled phones, these are primarily voice devices, so selection should be based largely on their voice capabilities. The support for applications is somewhat limited due to the constrained storage, processing power, and display sizes. They are similar to Web-enabled devices in form factor and display size, but they provide the ability for applications to run locally without requiring network coverage.

One of the major attractions to smart phones is their simplicity. The average user is able to have her or his device working in minutes without having to worry about extensive configuration. Also, since the devices have very small processors and little memory, they are able to last for days on a single battery charge. Of course, the fact that smart phones offer cell phone capabilities, as well as the support for applications, makes them ideal for those who want to limit the number of devices they have to carry around.

Users can extend the features of the device by downloading new applications over the air. This is called over-the-air (OTA) provisioning. Both handset manufacturers and wireless carriers are creating electronic storefronts where developers can submit their applications for download. Users download applications of interest to them for a nominal fee [usually between $1 and $5 (U.S.)]. The profit is then divided between the developer and the storefront provider.

Much of the interest surrounding the Java 2 Micro Edition (J2ME) is for building applications for these devices. Due to the limitations imposed by the device manufacturers, most m-business applications are not suitable for these devices. At the time this book was written, games were by far the most common applications being downloaded.

Nokia has predicted that it will sell tens of millions of J2ME-based smart phones by the end of 2003. This is not a small number, and presents a very large application development opportunity for J2ME programmers. It also represents a very large number of the new devices that will be coming to market. (Note: This number is only for Nokia devices. Motorola has also released J2ME devices to the market, and a handful of other manufacturers are adopting J2ME as well.)

Palm-Sized PDAs

The palm-sized PDA device is currently in the sweet spot of the mobile device market. This device has touchscreen capabilities for user input. The form factor is in between handheld PCs and smart phones, typically with a one-quarter video graphics array (VGA) screen (320×240), most often in color. The palm-sized PDA has instant on/off capabilities, meaning the device does not have to boot up before being used. The more recent devices on the market also incorporate built-in wireless modems for wireless connectivity. The devices that do not offer a built-in modem usually have an expansion slot into which a wireless modem can be plugged.

The most common devices in this market are the Palm and Pocket PC. Palm devices are currently the market leaders in this category, although their market share lead is shrinking as Pocket PC devices add more capabilities that are well suited for corporate users. Both the Palm and Pocket PC devices have touch-sensitive screens with built-in character recognition support. Palm devices are available in both monochrome and color, while Pocket PCs typically offer color screens. Palm devices are typically somewhat smaller than Pocket PCs, making them very easy to carry around as they can be attached to a belt or easily slipped into a briefcase or purse. They typically weigh around half a pound, or 225 grams.

While the form factor of Palm devices may be attractive, the performance and storage capabilities are often subpar. Many Palm OS-based devices have 8 to 32 megabytes (MB) of total memory and processors running at 33 megahertz (MHz) or less. Historically, this has been acceptable for the applications running on these devices, but as companies roll out enterprise line-of-business applications, this has started to become a problem. As these applications become more advanced, they require more data storage and processing power to meet the application requirements. In addition, as Java applications are deployed on these devices, they require more power to handle the requirements of the Java Virtual Machines (JVMs) and related applications. The new breed of Palm devices running Palm OS 5.0 have overcome this problem by moving to ARM-based processors running at 206 MHz. This puts them on more even ground with the Pocket PC devices on the market.

Most of the Pocket PC-based devices do have slightly better performance characteristics. The latest devices on the market come with between 32 MB and 64 MB of memory along with X-Scale processors running at 400 MHz. The extra computing power is required to run the Windows CE operating system, which is heavier than its Palm OS counterpart. One downside of the increased power is its effect on battery consumption. Palm devices can often last several days on a single battery charge, while Pocket PC devices typically have to be recharged daily.

The original market for many of these devices was as a personal digital assistant, hence the name PDA. Palm grabbed a huge amount of the PDA market by offering an intuitive user interface to access common applications such as calendars, contact lists, and to-do lists. In addition, it has a well-regarded development program to promote the growth of Palm OS-based applications. This broad range of applications, along with the relatively low cost of Palm devices, continues to make Palm OS devices an attractive purchase for many PDA users.

Pocket PC devices came to market a few years after Palm devices, with a different target audience in mind: the high-end PDA audience looking for a rich user interface with multimedia capabilities. These devices of course also target those that wish to be able to use their Microsoft Office products, such as Microsoft Word and Excel, on their PDAs. To accomplish these goals, Pocket PC devices are required to have more hardware capabilities, which also affects the price. In general, most Pocket PC devices are 30 to 50 percent more expensive than Palm OS devices. Although this has started to change with the entry of Dell into the Pocket PC with less expensive devices.

To more clearly distinguish their consumer and enterprise offerings, Palm Inc. have created two subbrands of devices: Tungsten and Zire. The Palm Tungsten family of products is geared for mobile professionals and enterprise work forces. These solutions combine high-powered hardware and software solutions to solve the complex problems IT professionals are faced with. The Palm Zire family of products is aimed at the consumer market, offering low-price devices with easy to use designs. Palm introduced these product families at the end of 2002 with the goal of maintaining their handheld marketshare lead.

When it comes to wireless connectivity, the majority of PDA devices require the modem to be an add-on component. This is usually accomplished by using a sled, or through an expansion slot. In either case, the modem adds extra cost and complexity to the PDA wireless solution. In most cases, users are required to establish a connection to the wireless network when data needs to be transferred and disconnect when they are finished. This means that they are not always connected to the network, so pushing data to the device is more complex.

The manual connection to wireless networks is changing with the introduction of integrated wireless devices such as the Palm i705, shown in Figure 2.5. These devices come with built-in modems for quick and easy data access. These integrated devices are growing in popularity in both the consumer and business markets. The ease of use and always-on network connections make them very attractive choices for a variety of mobile applications.

Figure 2.5: Palm i705 with Integrated Wireless. Image courtesy of Palm Inc.

The years to come are going to be very interesting as the PDA device market continues to evolve. Manufacturers are making devices aimed at corporate users who require high-performance devices to deploy more advanced applications. It is at this market that many of the smart client application vendors are targeting their solutions. With the introduction of Windows CE .NET and Palm OS 5.0, it is very clear that this market is going to remain competitive for some time to come. This will only benefit the consumer as exciting new features are constantly being added to attract their attention.

Note

The market is currently seeing a convergence between PDA devices and voice devices. At the end of 2001 and during 2002, many vendors released combined voice/PDA devices based on the Palm OS. In addition, Pocket PC Phone Edition and Microsoft Smartphone 2002 use Windows CE as their operating system, providing many capabilities present in Pocket PC PDAs with additional voice capabilities.

High-End Smart Phones

As the wireless application market matures, we are seeing a move toward more capable devices in the form of high-end smart phones. The leading cellular phone manufacturers, including Nokia, Sony Ericsson, and Motorola, among others, are producing these devices, which are targeted at the corporate market. These devices provide the ability for voice communication as well as both thin and smart client applications. This makes them a good choice for people who do not want to carry around multiple devices, but still want support for a variety of applications. Figure 2.6 shows the Sony Ericsson P800 Smartphone in voice and data modes.

Click To expand
Figure 2.6: Sony Ericsson P800 Smartphone. Image courtesy of Sony Ericsson.

The form factor of a smart phone falls in between that of a cell phone and a PDA. They typically have a flip-top mechanism for displaying the full screen and keyboard. When they are closed, they look like a large cellular phone, with the regular 12-digit keypad, and small amount of screen showing. When they are opened, they have screen sizes ranging from 640×200 to 320×240. They also often provide a keyboard for data input. The processors in these devices are powerful enough to run sophisticated local applications as well as advanced wireless Internet applications. The browsers for these devices often have support for color graphics and multimedia, using either WML or HTML as the markup language.

Similar to the two-way pagers and cellular phones, smart phones can often be used for days on a single battery charge. Until recently, the services provided on smart phones were not very customizable. The user was not able to add applications or change the content available on the device. This is changing with some of the latest smart phones, which offer full operating systems with memory available for third-party applications. The most common operating systems in smart phones are Symbian OS, Palm OS, Pocket PC Phone Edition, and Microsoft Smartphone 2002. Support for J2ME is also common.

In North America, smart phones have not been accepted as readily as they have been in Europe and Asia. There are many reasons for this, including wireless network support, the operating systems used, and the manufacturers' marketing and distribution plans. Typically, smart phone manufacturers have been rolling out their new devices in Europe before introducing them to North America. A good example of this is the Nokia Communicator. The Nokia 9210 was released in Europe at the end of 2001, while its counterpart, the Nokia 9290 wasn't released in North America until the middle of 2002.

One thing that may kick-start the smart phone market in North America is Microsoft's entry into the market with its Windows CE-based solution called Microsoft Smartphone 2002. Since it uses the same base operating system as Pocket PC devices, we may start seeing application developers include Microsoft Smartphone 2002 in their supported platforms list.

Another category of device that gets included in the high-end smart phone category is the PDA with integrated voice support. Kyocera and Handspring both have Palm OS devices with integrated voice. RIM has released the BlackBerry 6710/6750 with integrated support for voice communication, and a variety of Pocket PC Phone Edition devices by vendors such as AudioVox and Samsung are now available. These hybrid product offerings are blurring the line between the wireless PDA and the high-end smart phone classes of devices.

Handheld PCs

The concept of the handheld PC is not new. The design can be similar to a laptop, where the screen folds over the keyboard creating a compact shell around the internal device. For this reason, handheld PCs were commonly known as clamshell computers. The original clamshell device came out long before current PDAs were available.

In the mid-1980s, Psion introduced an organizer product that offered the unique capability to run applications. It allowed users to run financial, scientific, and data-driven applications locally on the device. This was in addition to the calculator functions for which it was mainly used. Even though this device was not hugely popular, it laid the foundation for the current line of handheld PCs.

By the early 1990s, Psion released a more functional clamshell computer that had a keyboard as well as a graphical user interface (GUI) screen for running more sophisticated applications. Other companies such as Casio released similar offerings, most often based on a proprietary operating system specific to the device. These operating systems did not support third-party applications, a major limitation. Not long afterward, Microsoft, looking to get a foothold in the PDA operating system market, came out with Windows CE. Most of the companies put aside their proprietary systems and adopted Windows CE as the operating system of choice for their devices, Psion being a notable exception. The specific implementation of Windows CE for devices with this form factor is called the Handheld PC.

Jump to the present day. Now, most Handheld PCs have one-half VGA (480×320) color screens with full keyboards. They have the ability to run a variety of smart client and Web-based applications. In general, Handheld PCs are not used to replace laptops, but rather complement them. The common use of the Handheld PC is not as a general computing device, but rather as an information-gathering device. The one-half VGA screen and integrated keyboard promote rapid data capture, allowing corporations to increase productivity for processes that previously required manual data capture.

There are many benefits of running line-of-business data collection applications to replace paper-based processes: faster, more accurate data collection, increased employee productivity, faster business process transactions, and reduced operational costs. Even though these benefits could be realized using a laptop computer, a hand-held PC is ideal for the job for many reasons. The handheld PCs deliver instant on/off capabilities, making data access immediate. They have a long battery life due to the low power consumption chips used in their design. A single battery charge can often last for an entire day's usage. Additionally, since there are no moving parts, they can handle being knocked around, so can be used in many field environments. These characteristics, along with a smaller form factor than a laptop, make the Handheld PC an ideal device for users who are interested in immediate data access and capture. These devices can host a variety of applications that provide clear benefits for users working away from the office environment. The fact that they often weigh around one pound, or 500 grams, is a nice feature for people who spend a lot of time out of the office.

The handheld PC market has been under pressure from increasingly powerful PDAs and smaller and more efficient laptops. HP is one of the only manufacturers that still sells the clamshell Handheld PC. Other manufacturers have gone with a tablet form factor as illustrated by the Samsung NEXiO in Figure 2.7. The Samsung NEXiO runs Windows .NET 4.1 and has integrated 802.11 capabilities. It is a good example of how handheld PCs have evolved, breathing new life into the handheld PC market.

Click To expand
Figure 2.7: Samsung NEXiO Handheld PC.

Tablet PCs

The Tablet PC market is very interesting. Over the past several years, devices in this category have not been terribly successful, and yet Microsoft and its partners are promoting this type of device quite heavily. These devices are aimed at horizontal markets such as field sales and field service, hoping to provide a compelling alternative to a full-blown laptop. Size-wise, they are slightly smaller than a laptop, with some of them having the ability to morph between laptop and tablet layouts. In the laptop position they have a keyboard for data entry; and when in tablet format, they have touch screen, pen-based input. Figure 2.8 shows the Acer TravelMate 100 Tablet PC as it morphs from laptop to tablet mode.

Click To expand
Figure 2.8: Acer TravelMate100 Tablet PC. Image courtesy of Acer.

Microsoft has developed many new applications (such as the Tablet PC Journal) to take advantage of the touch screen features. The journal software allows users to jot down notes and diagrams in their own handwriting, which can then be converted into standard text at the touch of a button. It is like a form of electronic paper.

Tablet PCs run Windows XP as their operating system and have the usual set of laptop add-on peripherals. They also have similar power and storage capacities to laptops. Microsoft is marketing them as an evolution of the laptop, having all of the features of a laptop, with added tablet features and longer battery life.

It is yet to be seen whether the reincarnation of the Tablet PC is here to stay. They do have some attractive features, but until businesses can justify the additional cost and support, laptops will continue to dominate this market.

Notebook/Laptop

In this day and age, laptops are commonplace, and often are not grouped with the other classes of mobile devices. Companies rarely show the benefits of their wireless solution on a full-sized laptop device; they usually prefer to demonstrate the technology using the latest handheld or smart phone to emphasize the small form factors on which the solution is capable of running. In reality, while mobile applications are capable of running on handheld devices, they are often deployed to laptop computers. For this reason, laptop computers are included in the mobile device classification in this chapter. Laptop computers offer many benefits for mobile applications: They run the same operating systems that users are accustomed to on their desktop computer; they can run the same applications as the desktop computers; and they have the same computing power that users experience on their desktop computers. So the laptop is really just a portable desktop computer, with few restrictions as to what types of applications can be executed. This makes it very easy for IT departments to build laptop applications for the company's mobile users.

Many of the Customer Relationship Management (CRM) and mobile Enterprise Resource Planning (ERP) applications that are currently deployed are laptop-based. Yes, there are now versions coming out targeted at the sub-laptop market, but the current deployments are mainly on laptops. As discussed previously, this is because the application does not have to be altered for deployment on the laptop. Implementing a mobile application on a laptop is as straightforward as implementing a desktop client/server-based application. The developer does not have to be concerned with limited screen sizes, memory, or processing power.

Most laptops on the market today have equivalent capabilities when compared to desktop computers. They have processors running around 2 gigahertz (GHz); they have 60-gigabyte (GB) hard drives; and they have 256 to 512 MB of RAM. In addition, they have full keyboards, 14-inch display screens, and CD-ROM or DVD drives. They include everything that a user requires when away from the office.

One of the major downsides to laptops is their weight and size. Even the lightest machines weigh 2 to 4 pounds, or 1 to 2 kilograms. They also require the user to carry around a separate bag or case, whereas many PDAs can be stored in a pocket or purse, or even clipped to a belt.

When making your device selection, do not limit yourself to the handheld mobile device market when a laptop may meet your requirements for size at the same time as providing excellent performance. At the same time, laptop computers do cost significantly more than the smaller devices, so if the smaller device does meet the needs of the end user, it may be more cost-effective and convenient to use.


Device Manufacturers

Many device manufacturers are leading the way with innovative new capabilities in the mobile arena. Table 2.1 summarizes the leading device manufacturers along with the class(es) of device they provide.

Table 2.1: Device Manufacturers[a]

DEVICE MANUFACTURER

DEVICE CLASSES

MANUFACTURER URL

Acer

PDA, Tablet PC

www.acer.com

AudioVox

Web-phone, PDA/smart phone

www.audiovox.com

Casio

Tablet PC, Handheld PC, PDA

www.casio.com

Dell

PDA

www.dell.com

Good Technology

PDA

www.good.com

Handspring

PDA, smart phone

www.handspring

Intermec

Handheld PC, PDA, Tablet PC

www.intermec.com

Motorola

Web-phone, two-way pager, smart phone

www.motorola.com

Nokia

Web-phone, smart phone

www.nokia.com

Palm

PDA

www.palm.com

Research in Motion (RIM)

Two-way pager, PDA/smart phone

www.rim.com

Samsung

Web-phone, smart phone, Handheld PC

www.samsung.com

Siemens

Web-phone, PDA/smart phone, and Handheld PC

www.siemens.com

Sony

PDA

www.sony.com

Sony Ericsson

Web-phone, smart phone

www.sonyericsson.com

Symbol

PDA, custom[b]

www.symbol.com

[a]Because laptop computers have been around for some time, and most organizations are aware of the leading vendors in this device class, they are not included in this table.

[b]" Custom" refers to devices that do not fit into the horizontal categories defined in this chapter. They are typically aimed at vertical markets and have features specific to those markets.


Summary

Many factors must be considered when selecting a mobile device: size, cost, performance, support for peripherals, data input mechanism, and wireless connectivity. It is important to select the device that is appropriate for the job at hand. This means paying special attention to data input mechanisms and wireless connectivity options. The decision is further complicated by the number of mobile device classes available. You will have to select from Web-enabled phones, smart phones, PDAs, Handheld PCs, Tablet PCs, and laptops. Each of these devices has its strengths and weaknesses.

In the next chapter, we are going to cover the wide range of wireless networks that are available for personal area, local area, and wide area networks. This information should help with the device selection process, as wireless is often a key criterion.


Helpful Links

Here are some links that may prove to be useful if you want to learn more about some of the topics covered in this chapter.

AOL Mobile T9 site | www.t9.com
J2ME device list | http://wireless.java.sun.com/device
Microsoft Mobile Devices | www.microsoft.com/mobile
Palm OS Web site | www.palmsource.com
Symbian OS Web site | www.symbian.com
Wireless Developer Network PDA Channel | www.wirelessdevnet.com/channels/pda/


Chapter 3: Wireless Networks

Wireless network technology is one of the hottest topics in mobile computing. Everyone has an opinion on the state of the third-generation (3G) wireless networks, the effect of Bluetooth for personal networks, and which wireless local area network technology will dominate the market. Even though not all mobile applications require wireless connectivity, there is no doubt that wireless technology is one of the main driving forces behind mobile computing.

This chapter provides an overview of the four main categories of wireless networks: wireless personal area networks (WPANs), wireless local area networks (WLANs), wireless wide area networks (WWANs), and satellite networks. For each category we summarize the prevalent technologies and discuss what the future holds. By reading this chapter you will gain an understanding of which wireless network protocols are being used and for what types of applications. This knowledge will be valuable as you continue through the book to learn more about the design and development of mobile and wireless applications.

Overview of Wireless Networks

Wireless networks serve many purposes. In some cases they are used as cable replacements, while in other cases they are used to provide access to corporate data from remote locations. Much of the industry hype surrounds third-generation wide area networks that provide broadband wireless connectivity to users on a national basis. These networks are now commercially available (in larger urban centers) in most first-world regions. At the same time, breakthroughs in short-range networks are also generating excitement. As users carry around multiple devices, a need arises for an easy, effective way for them to communicate; and what is easier than wireless?

For the purpose of our discussion, wireless networks will be divided into two broad segments: short-range and long-range. Short-range wireless pertains to networks that are confined to a limited area. This applies to local area networks (LANs), such as corporate buildings, school campuses, manufacturing plants or homes, as well as to personal area networks (PANs) where portable computers within close proximity to one another need to communicate. These networks typically operate over unlicensed spectrum reserved for industrial, scientific, medical (ISM) usage. The available frequencies differ from country to country. The most common frequency band is at 2.4 GHz, which is available across most of the globe. Other bands at 5 GHz and 40 GHz are also often used. The availability of these frequencies allows users to operate wireless networks without obtaining a license, and without charge.

Long-range networks continue where LANs end. Connectivity is typically provided by companies that sell the wireless connectivity as a service. These networks span large areas such as a metropolitan area, a state or province, or an entire country. The goal of long-range networks is to provide wireless coverage globally. The most common longrange network is wireless wide area network (WWAN). When true global coverage is required, satellite networks are also available.

Four Categories of Wireless Networks

Table 3.1 provides more detail about the four wireless networks categories. Information such as coverage area, function, relative cost, and throughput are some of the main areas where these networks differ. As mentioned earlier, short-range networks operate on unlicensed frequency bands, therefore, there are no airtime fees associated with their usage. The same is not true of WWANs and satellite networks, which charge either by the minute or by the amount of data transferred.

Table 3.1: High-Level Differences between WPANs, WLANs, WWANs, and Satellite
TYPE OF NETWORK | COVERAGE AREA | FUNCTION | ASSOCIATED COST | TYPICAL THROUGHPUT | STANDARDS
Wireless personal area network (WPAN) | Personal operating space; typically 10 meters | Cable replacement technology, personal networks | Very low | 0.1-4 Mbps | IrDA, Bluetooth, 802.15
Wireless local area network (WLAN) | In buildings or campuses; typically 100 meters | Extension or alternative to wired LAN | Low-medium | 1-54 Mbps | 802.11a, b, g, HIPERLAN/2
Wireless wide area network (WWAN) | Coverage provided on national basis from multiple carriers | Extension of LAN | Medium-high | 8 Kbps-2 Mbps | GSM, TDMA, CDMA, GPRS, EDGE, WCDMA
Satellite networks | Global coverage | Extension of LAN | Very high | 2 Kbps-19.2 Kbps | TDMA, CDMA, FDMA

Application developers do not have to know the internal workings of wireless networks to be successful, but having knowledge of how they work helps them understand why certain wireless technologies behave the way they do. This knowledge also lays a foundation on which application design architectures can be based. For example, if an application architect knows that the wireless network will only provide 9.6 Kbps of throughput, he or she will want to limit the frequency and amount of data transfer. Similar rationale applies to coverage and cost issues.

For each category of wireless networks, we will provide a summary of the leading standards as well as some insight into where they are being used.

Frequency Fundamentals

Before we can delve too deeply into wireless technologies, a brief primer on radio frequencies is required. Many of the wireless technologies in the WPAN, WLAN, and WWAN categories transmit information using radio waves. For this to take place, the data is superimposed onto the radio wave, which is also known as the carrier wave, since it carries the data. This process is called modulation. There are many modulation techniques available, all with certain advantages and disadvantages in terms of efficiency and power requirements. This summary of the various mechanisms will be helpful as you read this chapter. The modulation techniques are as follows:

  • Narrowband technology. Narrowband radio systems transmit and receive data on a specific radio frequency. The frequency band is kept as narrow as possible to allow the information to be passed. Interference is avoided by coordinating different users on different frequencies. The radio receiver filters out all signals except those on the designated frequency. For a company to use narrowband technology, it requires a license issued by the government. Examples of such companies include many of the wide area network providers discussed later in this chapter.

  • Spread spectrum. By design, spread spectrum trades off bandwidth efficiency for reliability, integrity, and security. It consumes more bandwidth than narrow-band technology, but produces a signal that is louder and easier to detect by receivers that know the parameters of the signal being broadcast. To everyone else, the spread-spectrum signal looks like background noise. Two variations of spread-spectrum radio exist: frequency-hopping and direct-sequence.

    • Frequency-hopping spread spectrum (FHSS). FHSS uses a narrowband carrier that rapidly cycles through frequencies. Both the sender and receiver know the frequency pattern being used. The idea is that even if one frequency is blocked, another should be available. If this is not the case, then the data is re-sent. When properly synchronized, the result is a single logical channel over which the information is transmitted. To everyone else, it appears as short bursts of noise. The maximum data rate using FHSS is typically around 1 Mbps.

    • Direct-sequence spread spectrum (DSSS). DSSS spreads the signal across a broad band of radio frequencies simultaneously. Each bit transmitted has a redundant bit pattern called a chip. The longer the chip, the more likely the original data can be recovered. Longer bits also require more bandwidth. To receivers not expecting the signal, DSSS appears as low-power broadband noise and is rejected. DSSS requires more power than FHSS, but data rates can be increased to a maximum of 2 Mbps.

  • Orthogonal Frequency Division Multiplexing (OFDM). OFDM transmits data in a parallel method, as opposed to the hopping technique used by FHSS and the spreading technique used by DSSS. This protects it from interference since the signal is being sent over parallel frequencies. OFDM has ultrahigh spectrum efficiency, meaning that more data can travel over a smaller amount of bandwidth. This makes it effective for high-data-rate transmissions. The drawbacks of OFDM are that it is more difficult to implement than either FHSS or DSSS, and consumes greater amounts of power.


Wireless Personal Area Networks (WPANs)

The market for wireless personal area networks is expanding rapidly. As people use more electronic devices at home and in the office, and with the proliferation of peripherals, a clear need for wireless connectivity between these devices has emerged. Examples of the devices that need to be networked are desktop computers, handheld computers, printers, microphones, speakers, pagers, mobile phones, bar code readers, and sensors. Using cables to connect these devices with a PC and with each other can be a difficult task in a stationary location. When you add mobility into the mix, the challenge becomes daunting. If the setup and administration of a WPAN becomes simple and intuitive in the future for the end user, then the most concrete scenario for WPAN technology is cable replacement. This provides a compelling reason to use WPAN technology, and will open the door for more advanced applications in the future. Here are the main characteristics of a WPAN:

  • Short-range communication

  • Low power consumption

  • Low cost

  • Small personal networks

  • Communication of devices within a personal space

While providing these features, a WPAN has to achieve two main goals: broad market applicability and device interoperability. It is important that the WPAN specification addresses the leading device categories that require wireless connectivity in a way that is both easy to implement and affordable. The price point to make a technology attractive is $5 (U.S.) or less. At this level, device manufacturers are willing to incorporate a technology into a broad range of devices for both the consumer and business markets. Interoperability is also imperative. Wireless capabilities are not very useful if they do not allow a device to communicate with other devices and peripherals.

Three wireless standards are leading the way for WPANs: IrDA, Bluetooth, and IEEE 802.15. Each of these standards enables users to connect a variety of devices without having to buy, carry, or connect cables. They also provide a way to establish ad hoc networks among the abundance of mobile devices on the market. Each of these standards is discussed in the following subsections.

WPAN Standards

Many standards are available for personal area networks. Each standard has strengths and weaknesses, making it suitable for specific application scenarios. In some cases, more than one technology will be able to perform a required task, hence nontechnical factors such as cost and availability will factor into the decision as to which technology is more appropriate. Here we take a look at the leading standards in this space. The information provided will give you a solid understanding about where each standard is being used and for what purposes.

IrDA

IrDA, the acronym for Infrared Data Association, is an international organization that creates and promotes interoperable, low-cost infrared data connection standards. IrDA has a set of protocols to support a broad range of appliances, computing, and communication devices. These protocols are typically aimed at providing high-speed, short-range, line-of-sight, and point-to-point wireless data transfer. IrDA protocols use IrDA DATA as the data delivery mechanism, and IrDA CONTROL as the controlling mechanism.

Chances are that you currently own a device that has support for infrared communication. The Infrared Data Association estimates that more than 300 million IrDA enabled devices have been shipped, making it one of the most pervasive wireless technologies in existence. The original goal of IrDA was to provide a cable replacement technology, much like the other PAN standards. The idea was that two computers could communicate simply by pointing them at each other. For example, to print a document, you would simply point the infrared (IR) port at the printer and be able to send the data. No cables would be required.

Technically, infrared technology is well suited for such tasks. The following are some of infrared's features:

  • Communication range of up to 1 meter, although a distance of 2 meters can often be reached.

  • A low-power option for communication up to 20 centimeters. This requires 10 times less power than the full-power implementation.

  • Bidirectional communication.

  • Data transmission from 9600 bps to a maximum speed of 4 Mbps.

In theory, using IR for data transfer is a great idea. Unfortunately, even with such ubiquity it is rarely used for its original intent. This may be due to technical challenges in many early implementations, or more plausibly, to the line-of-sight restriction. For IR to work, the communicating devices have to maintain line of sight. This means that they have to situated within the operating range (typically up to 2 meters apart), point at each other, and have no physical impediments. In most office environments, this limitation is not practical for many peripherals such as printers or scanners. Using infrared to transfer data between two devices is more realistic. Two device users can use infrared to transfer information, such as electronic business cards, between one another. Users with Palm devices call this type of transfer beaming, as in, "Can you beam me your contact information?" Beyond user-to-user data transfer, infrared is not commonly used for information transfer, since most users do not use two devices with IR ports. While nearly all portable devices have one, the majority of desktops do not. Once again, this limits the effectiveness of IR as a mass-market data transfer protocol.

That said, there are some areas where infrared is frequently used. The IrDA CONTROL standard allows wireless peripherals such as keyboards, mice, game pads, joysticks, and pointing units to interact wirelessly with a host device, very often a desktop PC or gaming unit. A host device can communicate with up to eight peripherals simultaneously. The data transmission rate for IrDA CONTROL typically reaches a maximum at 75 Kbps, which is easily fast enough for the type of data being transferred by these types of devices.

One of the major advantages of IrDA from a device manufacturer's perspective is cost. IR ports can be incorporated into a device for as low as $1 (U.S.). This is a very low cost for implementing wireless communication into a device compared to other WPAN standards.

Bluetooth

Bluetooth is a standard for enabling wireless communication between mobile computers, mobile phones, and portable handheld devices. Unlike IR, Bluetooth does not require a line of sight between devices to be effective. It is able to communicate through physical barriers, typically with a range of 10 meters, although with power amplifiers, 100 meters is possible. Bluetooth uses the unlicensed 2.4-GHz spectrum for communication, with a peak throughput of 720 Kbps. It is expected that this throughput will increase to around 10 Mbps with future Bluetooth specifications.

The origins of Bluetooth date back to 1994 when Ericsson was researching ways to enable mobile phones to communicate with peripherals. Four years later, in 1998, Ericsson, along with Nokia, Intel, Toshiba, and IBM, formed the Bluetooth Special Interest Group (SIG) to define a specification for small form-factor, low-cost wireless communication. Since then, 3COM, Lucent, Microsoft, and Motorola have joined the Bluetooth SIG as Bluetooth promoters. In addition, well over 2,000 companies have joined the SIG as Bluetooth Adopter/Associate members. This all happened before a single Bluetooth product was commercially available, leading to unprecedented market excitement.

People were excited about the futuristic products that would soon be available, expecting that every device, from portable computers to home appliances, would soon incorporate Bluetooth technology. These devices would then interact with one another, transferring data files, contact information, security credentials, and even perform financial transactions. All of this would happen seamlessly without any technical knowledge required from the user.

Needless to say, the hype once again surpassed the technology. While Bluetooth will indeed enable those scenarios someday, right now it is most effective as a cable replacement technology. Since a line of sight is not required for communication, getting Bluetooth devices to interact with one another is trivial. Bluetooth provides an autodiscovery mode, whereby Bluetooth devices will automatically discover other devices that are within range. Once they are detected, they can start communicating. There is some concern that this will overload the 2.4-GHz spectrum as more Bluetooth devices become available. To address this issue, the Bluetooth specification defines three device modes:

  • Generally discoverable mode. This allows a Bluetooth device to be detected by any other Bluetooth device within its proximity.

  • Limited discoverable mode. Only well-defined devices will be able to detect a device in this mode. This mode will be used when a user has many Bluetooth devices and wants them to discover each other automatically.

  • Nondiscoverable mode. This makes the device invisible to other devices so it cannot be detected.

When two or more devices connect, they form a piconet, an ad hoc network that can consist of a maximum of eight devices. Every device in a piconet can communicate directly with the other devices. It is also possible to have networks with more than eight devices. In this case, several piconets can be combined together into a scatternet. In a scatternet configuration, not all devices can see each other; only the devices within each piconet are able to communicate. Figure 3.1 helps to illustrate how this works. In this figure there is one scatternet consisting of five piconets; the hands-free mobile phone is a member of three different piconets and is able to communicate directly with the headset, the Bluetooth pen, and the access point, but is not able to communicate directly with the laptops, printer, or fax machine.

Click To expand
Figure 3.1: Bluetooth scatternet with five piconets.

The number of Bluetooth devices on the market is growing every day. It is common for mobile phones, PDAs, laptops, and peripherals to come equipped with Bluetooth chips. This has been made possible by the lowered cost of Bluetooth chipsets [currently around $20 (U.S.), with a targeted range of $5 to $10 (U.S.)] in conjunction with increased market demand. Users are now aware of the many compelling features that Bluetooth offers. The leading ones include:

  • Cable replacement

  • Mobile device networking

  • Global ad hoc networking

  • Support for both voice and data communication

  • Worldwide vendor and product support

Bluetooth Profiles

In order for Bluetooth to realize true ubiquity, interoperability is a key. Bluetooth devices from different vendors have to be able to communicate seamlessly. In order to promote this level of interoperability, the Bluetooth SIG has defined 13 profiles that device manufacturers can use when implementing their products. These profiles help ensure that Bluetooth products are built on a single foundation, allowing for true interoperability.

The entire second volume of the Bluetooth v1.1 specification is dedicated to profile definitions. Each profile is designed for a specific task. Four profiles are foundation profiles, providing the building blocks upon which other profiles are constructed. The other nine profiles are usage profiles. These describe actual usage cases where Bluetooth technology excels. Bluetooth profiles are not meant to be the definitive way to use Bluetooth technology but rather are aimed at providing standards for implementers to build upon. Device manufacturers will base their Bluetooth offerings on these profiles, ensuring that all Bluetooth devices will be able to communicate with one another.

Detailed summaries of each profile are provided in the Bluetooth profile definition book, which is over 450 pages long. If you are interested in obtaining this information, visit the Bluetooth Web site at www.bluetooth.com.

Bluetooth Security

Because cable replacement is one of Bluetooth's primary uses, the overall goal of Bluetooth security is to make the wireless connection at least as secure as cables would be. The Bluetooth specification defines security at the link level. Application-level security is not specified, leaving the developer to choose the security mechanism that is most appropriate for each particular application.

The Bluetooth specification defines several security measures that can be employed in various situations. Additionally, each profile definition outlines when security should be implemented for particular usage scenarios. Bluetooth communication can be encrypted for over-the-air communication and has built-in device authentication. The level of encryption is user-defined and can have a key size between 8 and 128 bits. This allows the user to determine what level of security is required. Note that a tradeoff exists between speed and security: Greater key lengths lead to slow communication. For authentication, each Bluetooth device has a unique address so the user can have some faith in the device with which they are communicating. (For an overview of mobile and wireless security, see Chapter 6, "Mobile and Wireless Security.")

HELPFUL REFERENCE

The Bluetooth SIG is aware of the importance of security, and has put together a concise Bluetooth security white paper that can be downloaded from the whitepapers section of the official Bluetooth Web site: www.bluetooth.com/dev/wpapers.asp.

802.15

802.15 is a specification driven by the Institute of Electrical and Electronics Engineers (IEEE) to develop consensus standards for short-range wireless networks or wireless personal area networks. It has similar goals to Bluetooth in that it looks to address wireless networking of portable and mobile computing devices such as PCs, PDAs, mobile phones, peripherals, and consumer electronics. The 802.15 WPAN Working Group was established in 1999 as part of the Local and Metropolitan Area Networks Standards Committee of the IEEE.

At the time of establishment, the 802.15 WPAN Working Group was aware of the Bluetooth specification and used parts of it as the foundation for the 802.15 standard. The 802.15 WPAN specification is aimed at standardizing the Media Access Control (MAC) and Physical (PHY) layers of Bluetooth, in the attempt to accommodate wider adoption of short-range wireless technology. 802.15 also deals with issues such as coexistence and interoperability within the networks. To accomplish this goal, four task groups have been established, each working on specific components of the 802.15 specification. They are:

  • 802.15 WPAN Task Group 1: WPAN/Bluetooth. The WPAN Task Group 1 (TG1) has created the WPAN 802.15.1 standard based on the Bluetooth v1.1 specification. To accomplish this, the IEEE licensed technology from the Bluetooth SIG. Specifically, 802.15.1 defines the MAC and PHY specifications for wireless connectivity of devices that are either fixed or portable within the personal computing space. The spec also takes into consideration coexistence requirements with 802.11 wireless local area network (WLAN) devices.

  • 802.15 WPAN Task Group 2: Coexistence Mechanisms. The 802.15 WPAN Task Group 2 (TG2) is developing the recommended practices to facilitate the coexistence of WPAN (802.15) and WLAN (802.11) technologies. Part of this task involves developing a coexistence model to quantify the mutual interference of a WPAN and a WLAN. Once approved, this outcome of TG2's work will become the IEEE 802.15.2 specification.

  • 802.15 WPAN Task Group 3: High Rate WPAN. The 802.15 WPAN Task Group 3 (TG3) is chartered to publish a new standard for high-rate (20 Mbps or higher) WPANs. In addition to high data rates, 802.15.3 also has to provide a means for low-power and low-cost solutions to address the needs of portable consumer electronics, digital imaging, and multimedia applications.

  • 802.15 WPAN Task Group 4: Low Rate-Long Battery Life. The 802.15 WPAN Task Group 4 (TG4) is chartered to establish a low-data-rate (200 Kbps maximum) solution with long battery life (many months to many years) and low complexity. It is intended to operate in an unlicensed international frequency band and is targeted at sensors, interactive toys, smart badges, home automation, and remote controls.

The 802.15 specification is still a work in progress as each of the task groups is at different stages in the specification process. TG1 has completed the 802.15.1 specification and has gotten approval from the IEEE Standards Association (IEEE-SA), while the other groups are still working toward that level. Once completed, the 802.15 WPAN specification will cover all of the current issues surrounding WPAN technology, including Bluetooth compatibility, coexistence with 802.11, high-data transfer rates, and low-power consumption solutions. The combination of all of these will make the IEEE 802.15 specification very attractive for WPAN infrastructure providers.

WPAN Comparison

Of the three WPAN standards, IrDA, Bluetooth, and 802.15, IrDA has been around the longest, and has the highest market penetration, with more than 300 million enabled devices shipped. At the same time, infrared also is the most limiting, as the range is up to 2 meters, and it requires a line of site between communicating devices. The Bluetooth specification addresses these issues by using unlicensed 2.4-GHz spectrum for communication. This allows for communication through physical barriers, as well as larger ranges, typically up to about 10 meters. Bluetooth has also garnered a lot of industry attention, with more than 2,000 companies joining the Bluetooth SIG. In order to provide further standardization for WPAN technology, the IEEE 802.15 specification was developed. The 802.15 specification uses Bluetooth v1.1 as a foundation for providing standardized short-range wireless communication between portable and mobile computing devices. Table 3.2 provides a summary of the leading WPAN technologies.

Table 3.2: Comparison of WPAN Technologies
STANDARD | FREQUENCY | BANDWIDTH | OPTIMUM OPERATING RANGE | POINTS OF INTEREST
IrDA | 875nm wavelength | 9600 bps to 4 Mbps. Future of 15 Mbps | 1-2 meters (3–6 feet) | Requires line of site for communication.
Bluetooth | 2.4 GHz | v1.1: 720 Kbps; v2.0: 10 Mbps | 10 meters (30 feet) to 100 meters (300 feet) | Automatic device discovery; communicates through physical barriers.
IEEE 802.15 | 2.4 GHz | 802.15.1: 1 Mbps 802.15.3: 20-plus Mbps | 10 meters (30 feet) to 100 meters (300 feet) | Uses Bluetooth as the foundation; coexistence with 802.11 devices.

There is no clear leader, as we are still in the early stages of WPAN technology development. Bluetooth has generated the most industry attention so far, but 802.15 is just as exciting. Since 802.15 is interoperable with both Bluetooth and 802.11, it will have a solid future in the WPAN space. In many ways, IR is not a competing technology to either Bluetooth or 802.15 since it addresses a separate market need. IrDA is included in nearly all mobile devices, providing a quick and easy way for reliable short-range data transfer. With its low implementation costs, many low-end devices will continue to support IrDA, while more advanced devices with more robust wireless needs will implement Bluetooth or 802.15.

Another area of interest is the increasing range that these technologies can address. Initially, Bluetooth was aimed at a personal operating space of 10 meters. Now, with power-amplified Bluetooth access points, the range has extended to 100 meters. 802.15 is in the same situation. The increased range for these technologies blurs the line between wireless personal area networks and wireless local area networks.


Wireless Local Area Networks (WLANs)

Wireless local area network solutions comprise one of the fastest growing segments of the telecommunications industry. The finalization of industry standards, and the corresponding release of WLAN products by leading manufacturers, has sparked the implementation of WLAN solutions in many market segments, including small office/home office (SOHO), large corporations, manufacturing plants, and public hotspots such as airports, convention centers, hotels, and even coffee shops.

In some instances WLAN technology is used to save costs and avoid laying cable, while in other cases it is the only option for providing high-speed Internet access to the public. Whatever the reason, WLAN solutions are popping up everywhere.

To address this growing demand, traditional networking companies, as well as new players to the market, have released a variety of WLAN products. These products typically implement one of the many WLAN standards, although dual-mode products that support multiple standards are starting to emerge as well. When evaluating these products, some key areas should be considered, including:

  • Range/coverage. The range for WLAN products is anywhere from 50 meters to 150 meters.

  • Throughput. The data transfer rate ranges from 1 Mbps to 54 Mbps.

  • Interference. Some standards will experience interference from standard household electronics and other wireless networking technologies.

  • Power consumption. The amount of power consumed by the wireless adapter differs between product offerings, often depending on standards they implement.

  • Cost. The cost of a solution can vary significantly depending on the requirements of the deployment and which standard is being implemented.

In this section we provide some insight into typical WLAN configurations, as well as the leading WLAN standards.

WLAN Configurations

Wireless LAN configurations range from extremely simple to very complex. The simplest WLAN is an independent, peer-to-peer configuration where two or more devices with wireless adapters connect to each other, as depicted in Figure 3.2. Peer-to-peer configurations are often called ad hoc networks since they do not require any administration or preconfiguration. They also do not require the use of an access point, as each adapter communicates directly to another adapter without going through a central location.

Click To expand
Figure 3.2: Peer-to-peer WLAN configuration.

Peer-to-peer networks are very useful when a group of users need to communicate with one another in an unstructured way. These networks can be extended by adding a wireless access point (AP) to the configuration. The AP can act as a repeater between the devices, essentially doubling the range of operation. In addition, access points can provide connectivity to a wired network allowing wireless users to share the wired network resources. Figure 3.3 illustrates this configuration.

Click To expand
Figure 3.3: WLAN configuration with access point.

In a SOHO environment, access points can be used to provide multiple users access to a single high-speed connection without having to run Ethernet wires to each computer. In a corporate environment, many access points can work together to provide wireless coverage for an entire building or campus. The coverage area from each access point is called a microcell. To ensure coverage over a large area, the microcells will overlap at their boundaries, allowing users to freely move between cells without losing connectivity. This movement between a cluster of access points in a wireless network is called roaming. Roaming is made possible by a handoff mechanism whereby one access point passes the client information to another access point. This entire process is invisible to the client.

In more advanced configurations, extension points (EP) may be used in conjunction with access points. These EPs extend the range of the network by relaying signals to client devices, other EPs, or to an access point. They do not have to be tethered to the wired network, making it possible to service far-reaching clients. One other piece of WLAN equipment is a directional antenna. It allows a signal to be extended to locations many kilometers away. At the second location, the antenna is then connected to an access point, which provides wireless LAN connectivity for the rest of the facility.

WLAN Standards

Two standards bodies, IEEE and European Telecommunications Standards Institute (ETSI) and one technology alliance (HomeRF) promote WLAN standards. In the IEEE 802.11 family of WLANs, three standards deserve individual attention, and a handful of others are worth a quick mention. The leading standard is 802.11b, or Wi-Fi, short for Wireless Fidelity. The clear challenger is 802.11a, which provides increased throughput at a higher, less cluttered frequency; the outside contender is 802.11g, which just completed the final stage of IEEE approval at the time of writing. Other WLAN standards that are worth consideration are HIPERLAN/1 and HIPERLAN/2. We will provide information on each of these standards to give you a firm understanding of their technical and business advantages.

802.11

The IEEE 802.11 specification was approved in July 1997, making it the first wireless LAN standard to be defined. It uses the same switching protocols as wired Ethernet, but allows communication to happen without wires, instead using unlicensed 2.4-GHz frequency radio communication. Two frequency modulation techniques are supported in 802.11: FHSS and DSSS. 802.11 products are not commonly sold anymore, as updated versions (802.11a and 802.11b) have taken its place, providing higher bandwidths at a lower cost.

Note

We are starting with 802.11b before 802.11a because it has achieved a higher level of commercial adoption. The letter after the name represents the time at which the specification was first proposed, but not necessarily which one was first adopted.

802.11b/Wi-Fi

802.11b is the most popular standard in the 802.11x family. The specification was approved at the same time as 802.11a in 1999, but since then has achieved broad market acceptance for wireless networking. 802.11b is based on the DSSS version of 802.11, using the 2.4-GHz spectrum. Since DSSS is easier to implement than orthogonal frequency division multiplexing (OFDM), as used in 802.11a, 802.11b products came to market much sooner than their 802.11a counterparts. In addition, the 2.4-GHz spectrum is available globally for WLAN configurations, while the 5-GHz spectrum that 802.11a uses is for limited uses in many countries.

802.11b is able to reach a maximum capacity of 11 Mbps. This surpassed the 10 Mbps speed that is part of the original Ethernet standard, making 802.11b a practical alternative to, or extension of, a wired LAN. To help foster interoperability between 802.11b products, the Wi-Fi Alliance [formerly the Wireless Ethernet Compatibility Alliance (WECA)] has set up certification the aforementioned Wireless Fidelity, or Wi-Fi. Obtaining Wi-Fi certification ensures that 802.11b products will be able to interoperate with other Wi-Fi products globally. This certification, combined with the release of 802.11b products by leading networking companies such as Cisco, Lucent, Agere Systems, Proxim, and 3Com, has made 802.11b the leading WLAN standard.

The use of the 2.4-GHz band for communication has advantages and disadvantages. On the plus side, the 2.4-GHz spectrum is almost universally available for WLAN configurations. Initially, a few countries did not allow for its usage, but this has changed thanks to lobbying by industry groups. Additionally, 2.4-GHz signals are able to penetrate physical barriers such as walls and ceilings more effectively than higher frequencies can. The downside of using the 2.4-GHz spectrum is congestion. Since it is unlicensed, meaning anyone can use it without obtaining a special license, other electronic products also use this frequency for communication. Two common examples are cordless phones and microwave ovens. With the widespread use of this spectrum, there is a possibility that it will become overcrowded, resulting in too much interference for effective data communication. Hopefully, this will not be the case since any manufacturer of any product that uses the 2.4-GHz band is required to take interference into account in its product design.

One interesting point about the 802.11b specification is how it handles roaming between access points. The specification requires a method for roaming, but leaves the implementation up to the AP manufacturer. This will make roaming between different vendors' access points difficult, as it is unlikely that manufacturers will employ the same handoff routines.

In typical indoor office configurations, an 802.11b access point can communicate with devices up to 100 meters (around 300 feet) away. The further away a terminal is from the access point, the slower the communication will be. Devices within about 30 meters can usually achieve a raw data transfer rate of 11 Mbps; beyond 30 meters, the rate drops to 5.5 Mbps, and then to 2 Mbps around 65 meters away, and finally, to 1 Mbps around the outer edge. These numbers represent the anticipated coverage area and transmission speeds, but the products from each vendor will differ in performance. If you are looking to implement an 802.11b WLAN, it is recommended that you do a site survey to obtain the actual operating range and associated bandwidth for your location.

802.11b Security

When the IEEE created the 802.11 specification, it implemented a feature called Wired Equivalent Privacy (WEP) with the intent of providing basic levels of authentication and data encryption. As the name suggests, the goal of WEP is to provide an equivalent level of security as normally present in an unsecured wired LAN. This is clearly important, as wireless networks do not have the physical protection that wired environments do. Both 802.11a and 802.11b specifications use WEP.

For authentication, an access point that has WEP enabled will send a text request to the client to verify the client's identity. The client uses RC4 encryption with a secret key to encrypt the text, then returns the encrypted text back to the access point. Once received, the access point decrypts the text using the same key. If the text matches the text that was sent, then the client is authenticated and granted access. For encryption, WEP provides a 24-bit initialization vector that augments the WEP key. This vector changes with each packet, thereby providing a basic level of data encryption.

Unfortunately, both forms of WEP security present some concerns. For authentication, WEP supports no more than four keys and provides no mechanism for refreshing those keys on a regular basis. The result is that the same keys are used by multiple clients and access points and are never changed. This means that malicious users can "listen" to the communication stream and, by using freely available software, very quickly authenticate themselves to the access point. For the encryption layer, WEP uses RC4 in what is called a one-time-pad manner. The security of a one-time-pad is only as secure as the pad being used, which for WEP is the 24 bits. This means that the onetime-pad is repeated at least every 224 packets. For access points with moderate amounts of traffic, this is a matter of hours, hence, attackers monitoring the datastream could detect two messages encrypted with the same 24-bit initialization vector and be able to determine the keys and decipher the plain text.

Companies should realize that WEP was never designed to provide end-to-end security. It is intended for usage in conjunction with existing security mechanisms such as firewalls, virtual private networks (VPNs), and application-level security. The following are some suggestions for corporations that are using, or planning on using, WEP security as part of their WLAN:

  • Use a firewall to separate the wireless network from the wired network.

  • Have the wireless users authenticate with a VPN to access the corporate network.

  • Incorporate security at the application level for highly confidential information.

  • Implement dynamic key refreshing for the WEP keys.

  • Do not assume that WEP guarantees absolute data privacy.

Not all of the 802.11 WLAN security issues can be attributed to problems with WEP. Many of these issues have resulted from companies not using the WEP for its original purpose or from not using it at all. By implementing additional security mechanisms as listed, corporations can ensure secure wireless communication. In addition, the 802.11i Task Group is working additional levels of security for 802.11 WLANs. The first component of the 802.11i draft is currently being implemented in the form of Wi-Fi Protected Access. Wi-Fi Protected Access offers increased security over WEP. (More information on mobile and wireless security can be found in Chapter 6 "Mobile and Wireless Security.")

802.11a

802.11a is a high-speed alternative to 802.11b, transmitting at 5 GHz and speeds up to 54 Mbps. Unlike 802.11 and 802.11b, 802.11a uses OFDM modulation technology. This, along with the difference in frequency, makes 802.11a networks incompatible with 802.11b networks. Due to the increased complexity of 802.11a, the first products did not reach the market until early 2002, with all the chipsets being provided by a single vendor, Atheros Communications. Since then other vendors have released 802.11a chipsets, helping 802.11a gain broader market acceptance and interoperability certification.

The Wi-Fi Alliance has included certification for 802.11a products within the Wi-Fi certification program. They are using the same name for both 802.11b and 802.11a to help reduce confusion in the market and to foster growth of the emerging 802.11a products. The Wi-Fi Alliance are hoping that Wi-Fi certification will have the same effect on the 802.11a market as it did on the 802.11b market. Certification gives consumers confidence that the products they are purchasing will work with other products based on the same specification.

The move to the 5-GHz band and OFDM modulation provides two important benefits over 802.11b. First, it increases the maximum speed per channel from 11 Mbps to 54 Mbps. This is a tremendous boost, especially considering that the bandwidth is shared among all the users on an access point. The increased speed is especially useful for wireless multimedia, large file transfers, and fast Internet access. Second, the bandwidth available in the 5-GHz range is larger than available at 2.4 GHz, allowing for more simultaneous users without potential conflicts. Additionally, the 5-GHz band is not as congested at the 2.4-GHz band, resulting in less interference.

These advantages come with some downsides. The higher operating frequency equates to a shorter range. This means that to maintain the high data rates, a larger number of 802.11a access points are required to cover the same area, versus 802.11b. While 802.11b access points have a typical range of 100 meters, 802.11a access points are often limited to between 25 and 50 meters. In addition, OFDM requires more power than DSSS, leading to higher power consumption by 802.11a products. This is definitely a disadvantage for mobile devices that have limited battery power. Another downside is that 802.11a and 802.11b products are not compatible. With the large number of 802.11b products on the market, this will have a negative effect on the adoption of 802.11a products. That said, both standards can coexist, and products are now on the market that support both 802.11a and 802.11b in a single chipset. This dual-mode approach is very attractive for users who want the advantages of 802.11a, with the backward compatibility and market penetration of 802.11b.

One final item to note about 802.11a is that the 5-GHz frequency is not universally available for WLAN products. Many European countries, as well as Japan, are resisting the adoption of 802.11a as a standard, leaving some doubt as to whether it will become a global standard as 802.11b has.

802.11g

IEEE 802.11g brings high-speed wireless communication to the 2.4-GHz band, while maintaining backward compatibility with 802.11b. This is accomplished on two layers. First, 802.11g operates on the same 2.4-GHz frequency band as 802.11b, with the same DSSS modulation types for speeds up to 11 Mbps. For 54 Mbps, 802.11g uses the more efficient OFDM modulation types, still within the 2.4-GHz band. In practice, an 802.11g network card will be able to work with an 802.11b access point, and 802.11b cards will work with an 802.11g access point. In both of these scenarios, the 802.11b component is the limiting factor, so the maximum speed is 11 Mbps. To obtain the 54-Mbps speeds, both the network cards and access point have to be 802.11g compliant. In all other aspects, such as network capacity and range, 802.11b and 802.11g are the same.

Since 802.11g offers the same speed as 802.11a, comparisons between them are inevitable. And because they both use OFDM modulation, the main differences result from their frequency ranges and corresponding bandwidth. The total available bandwidth at 2.4 GHz remains the same as with 802.11b. This results in lower capacity for 802.11g WLANs when compared to 802.11a. In addition, fewer channels are available, leading to a higher potential of conflicts. When we take into consideration the backward compatibility that 802.11g has with 802.11b, 802.11g becomes an attractive option for companies that have 802.11b installations.

Other 802.11 Standards

Just as 802.11g improved upon 802.11b, other 802.11 task groups are in place to improve upon the exiting 802.11x standards. The areas of concentration are security, quality of service, compliance, and interoperability. All of these are still in the task group stage of the specification process:

  • IEEE 802.11e. Aimed at providing quality of service (QoS) capabilities to enable reliable voice communication to complement 802.11b systems. 802.11e will also provide enhanced security and authentication mechanisms. It is expected to receive final IEEE approval in 2003.

  • IEEE 802.11f. Aimed at developing the recommended practices for an Inter-Access Point Protocol (IAPP) to achieve multivendor access point interoperability.

  • IEEE 802.11h. Aimed at enhancing the 802.11a High-Speed Physical layer in the 5-GHz band to make IEED 802.11a products compliant with European regulatory requirements.

  • IEEE 802.11i. Aimed at enhancing the 802.11 MAC layer to increase security and authentication mechanisms.

HomeRF

As the name suggests, HomeRF is a wireless LAN technology aimed at home wireless networking. It is based on the 802.11 FHSS standard, but enhancements have been made to meet the unique needs of the average consumer. HomeRF uses the Shared Wireless Access Protocol (SWAP). One of the major enhancements of SWAP is its support for high-quality voice communication. Additionally, the HomeRF specification incorporates the Digital Enhanced Cordless Telephony (DECT) standard. This allows cordless phones to use the same home networking infrastructure as PCs and appliances while providing advanced telephony features, including call waiting, caller ID, call forwarding, and personal ringtones.

The HomeRF specification has been designed for ease of use and price rather than bandwidth and performance. HomeRF networks provide a range of up to 50 meters (around 150 feet) with maximum speeds at 10 Mbps. The first generation of HomeRF products provided throughput of 1.6 Mbps. HomeRF uses the 2.4-GHz frequency band so it will experience similar interference as 802.11b from household appliances such as microwaves.

With wide industry adoption of 802.11b, HomeRF products have not been able to reach critical mass. The major advantages of HomeRF over 802.11b are ease of use, cost, and telephony support, all areas being addressed by 802.11b products and upcoming 802.11x specifications. For this reason among others, the HomeRF Consortium disbanded in early 2003, making HomeRF a defunct standard.

HIPERLAN/1 and HIPERLAN/2

The European Telecommunications Standards Institute (ETSI) proposed the High-Performance Radio Local Area Network (HIPERLAN) standard in 1992 to address the need for high-speed short-range wireless communication. This first version is commonly referred to as HIPERLAN/1. It is based on Ethernet standards, with its radio transmission taken from GSM. It uses the 5-GHz frequency band. The operating range and bandwidth is difficult to determine since HIPERLAN/1 did not experience commercial success. According to the specification, HIPERLAN/1 has data rates approaching 23.5 Mbps.

HIPERLAN/2 is the next-generation WLAN specification from ETSI Broadband Radio Access Networks (BRAN). It continues to use the 5-GHz frequency band, but with OFDM technology. It is able to achieve peak speeds of 54 Mbps with an approximate range of 150 meters (450 feet).

HIPERLAN/2 has been designed to address the various market segments where WLANs are used: enterprise networking, SOHO, and 3G wireless hotspots. To this end, it has incorporated QoS for real-time multimedia communication, efficient power consumption for portable devices, strong security and interoperability with Ethernet, IEEE 1394 (Firewire), and 3G mobile systems. The specification also permits roaming between HIPERLAN/2 access points, making it suitable for corporate environments. As of late 2002, HIPERLAN/2 still has not seen any meaningful adoption in either the consumer or corporate space.

WLAN Summary

The market demand for WLAN solutions is growing at a rapid pace across several market segments, including the home, office, and public hotspots. Deciding which technology is appropriate to use is not a trivial task, as all three WLAN specifications have strengths and weaknesses and because each WLAN deployment is unique. When evaluating a WLAN solution, make sure you take into consideration future needs, since the technology upgrade paths depend upon the original choice. The following are some key criteria for selecting the right high-speed WLAN solution for you:

  • Capacity requirements. If you are installing a WLAN for a large number of users, and population density is a concern, then 802.11a may be a good choice since it provides larger bandwidth to accommodate more users per access point. If not, 802.11b/g might be more appropriate.

  • Interoperability of wireless devices. Wireless LAN solutions from different vendors may not be interoperable, perhaps because of the frequency band used, the frequency modulation technology (FHSS, DSSS, or OFDM), or just due to the implementation of a particular vendor. Wi-Fi certification helps to ensure that 802.11b and 802.11a products will work with products using the same standard. (The first 802.11g products became available in January 2003.)

  • Timing of high-speed requirement. If high-speed access is needed immediately, a WLAN technology such as 802.11a or HIPERLAN/2 is probably the right choice. If it can wait, then 802.11b with an upgrade to 802.11g might be suitable.

  • Migration plan. If a WLAN solution is already in place, or if you are looking to take advantage of proven technology such as 802.11b, keep in mind the migration plans for incorporating higher speeds or, possibly, other frequencies. A range of dual-mode WLAN products are available that support both 802.11a and 802.11b.

  • Interference concerns. If interference is expected on the 2.4-GHz frequency band from products such as Bluetooth, cordless phones, or even microwave ovens, it might make sense to select a product that is using the less-crowded 5-GHz frequency band.

  • Range/penetration. Higher-frequency signals have shorter range and worse penetration than lower-frequency signals. In some ways, these effects are mitigated by the system manufacturers, but it is still a worthwhile consideration. In some cases, you may prefer a solution that cannot penetrate walls, to prevent eaves-dropping from outside parties. For longer range and better penetration, the 2.4-GHz standards such as 802.11b and 802.11g are better choices than those using the 5-GHz frequency band.

  • Power requirements. Does the device using the WLAN technology have a limited power source? If so, power requirements for each standard must be a factor. The rule of thumb is that higher frequencies require more power to transmit the signal the same distance as lower frequencies. This may not apply in all cases, but it is a safe guideline to go by.

  • Regulatory factors. Are there limitations imposed by your geographic location that you have to consider when choosing a technology? How about the availability of products in your region? These should be taken into account before making any decision.

Table 3.3 provides an overview of the characteristics that you need to evaluate when determining which solution is best for your situation.

Table 3.3: Comparison of WLAN Technologies
STANDARD | FREQUENCY | BANDWIDTH | RANGE | POINTS OF INTEREST
802.11 | 2.4 GHz | 1–2 Mbps | 100 meters (300 feet) | The first approved specification in the 802.11 family.
802.11a | 5 GHz | 54 Mbps | 50 meters (150 feet) | Uses OFDM modulation to achieve high data rates; first commercial products became available in 2002.
802.11b | 2.4 GHz | 11 Mbps | 100 meters (300 feet) | Largest market penetration of any WLAN standard, with commercial products available since 1999.
802.11g | 2.4 GHz | 54 Mbps | 100 meters (300 feet) | Approved by the IEEE-SA in the fall of 2002. Backward-compatible with 802.11b.
HomeRF | 2.4 GHz | 10 Mbps | 50 meters (150 feet) | HomeRF did not achieve commercial success.
HIPERLAN/1 | 5 GHz | Theoretically 20 Mbps | - | HIPERLAN/1did not achieve commercial success.
HIPERLAN/2 | 5 GHz | 54 Mbps | 150 meters (450 feet) | Designed for integration with other networks, including wired LANs, IEEE 1394 (Firewire), and 3G mobile networks. Unlikely to achieve commercial success.

One of the most exciting uses of WLAN technology is for providing high-speed Internet access to public hotspots such as hotels, airports, school campuses, and coffee shops. In this scenario, WLAN technologies are being incorporated to wireless wide area network (WWAN) deployments to provide more reliable connectivity at a lower cost. As we discuss WWAN technologies in the next section, we will take a closer look at how WLAN technology is playing a role in the third-generation (3G) wireless deployments.


Wireless Wide Area Networks (WWANs)

WWANs have been in place since the early 1980s for voice communication, and since the early 1990s for data communication. Access to these networks requires users to sign an agreement with the company that operates the network they are interested in. This agreement will allow them to use the wireless network for a fee, which is often calculated by the number of minutes the user is connected to the network, or more recently, by the amount of data transferred over the network. This fee helps the service provider cover the cost of building and maintaining the wide area network, as well as the cost required to purchase the spectrum used for communication. Unlike WPANs and WLANs, wireless wide area networks do not operate over unlicensed frequencies, meaning they have to pay to purchase (or license) the spectrum being used. In some cases the amount of money paid for this spectrum is incredibly large. For example, the sale of spectrum for next-generation wireless networks cost more than $35 billion (U.S.). In order to recover some of those expenses, a usage fee has to be charged.

Do not let the prospect of a fee turn you away from using WWANs, however, as they provide an important component of many wireless solutions. When coverage beyond the range of a WLAN solution is required, WWANs are the place to look. They can provide national, and often international, wireless coverage for both voice and data communication. The communication quality and speed depends on the technology being used. Other properties that are network-dependent include area of wireless coverage, operating frequencies, handset availability, and, of course, cost.

In the remainder of this section we will take a look at the generations of wireless networks and the protocols currently being used. We will start with an overview of the terminology and concepts for wide area wireless networks.

Communication Fundamentals

Many technical concepts are involved with wireless voice and data transmissions. We are going to cover the most pertinent ones in this section before we discuss the evolution of wide area wireless networks. You will find these terms to be very relevant to WWANs.

Analog versus Digital Signals

The first wireless networks used analog signals to transmit sound. Analog signals constantly change as the voice is transmitted, similar to fluctuations in voice itself. Due to the fluctuating nature of analog waves, they are often represented by a sine wave. The first generation of wireless networks used analog transmission for voice communication.

As wireless networks evolved and started to be used for more data as well as voice traffic, a need for digital communication arose. Digital transmissions are a stream of 1s and 0s. Since the data stored on computers is inherently digital, digital networks proved to be more efficient in terms of both spectrum and power consumption. All second-generation wireless networks with data capabilities use digital technology.

The following are some of the many benefits attained by moving to digital networks:

  • Efficiency. Digital networks can transfer more data over the same amount of spectrum; they also allow for compression for even higher efficiency. Additionally, digital signals consume less power than analog.

  • Security. Analog signals can be easily listened to by eavesdroppers with a radio tuner; even encrypted analog signals can be cracked quite easily. Eavesdroppers have a much more difficult time with digital signals as they can be encrypted to various strengths, depending on the level of privacy required. In addition, the distribution techniques of digital signals make them more difficult to decipher.

  • Quality. Digital signals result in better-quality sound with less interference. Advanced filters can be used to remove any noise.

  • Features. Digital technology allows for voice features such as call answer and caller ID, as well as provide the basis for all data traffic as required for any wireless m-business application.

Circuit-Switching versus Packet-Switching

Two switching mechanisms are used for data transfer: circuit-switched and packet-switched. Circuit-switched networks establish a physical connection between the two communicating parties. This connection is maintained for the duration of the connection and cannot be used by any other parties. Landline telephone networks are circuit-switched. When you make a telephone call, you are granted a connection to the person you are talking to. The line becomes available again only after the conversation is finished and one party hangs up. Thus, for every conversation, a dedicated line is required.

Circuit-switching works well for voice communication where there is a constant stream of data being transferred, but is very inefficient for many forms of data communication where information is requested in bursts, such as when browsing Web pages, because even when no data is being transferred, the connection has to be maintained. This adds additional cost to consumers, as they pay according to the time connected to the network, not by the amount of data downloaded. From the wireless operators' perspective it is also wasteful, as they cannot use that connection for any other purpose. Additionally, if the connection is lost, the user has to establish a new connection, a process that takes anywhere from 5 to 40 seconds.

Packet-switched networks solve these problems. They do not require dedicated connections, but rather allow several users to share a single connection to maximize spectrum. Internet traffic uses packet-based networks for data transmission. This works by dividing data into small units called packets. These packets are then assigned a destination address that they carry around as they are being routed through the network. Multiple users can share the same data path since the data packets do not have to follow any specific path to get to their destination. This allows them to take the optimal path for bandwidth efficiency. At the receiving end, the data packets are then reassembled into their original format.

In terms of the user experience, packet-switched networks are far superior to circuit-switched when it comes to transferring data. Since a dedicated connection does not have to be established, and since no bandwidth is being wasted if data is not being transferred, devices are able to maintain a constant connection to the network without incurring additional costs or network burden. This alleviates users from having to establish a network connection each time they need to transfer data. Additionally, users are charged only for the data they transmit rather than connection times. This can result in significant savings. Network operators also prefer packet networks since they can utilize all of their network bandwidth. Packet switching is the basis of always-on connectivity provided by third-generation wireless networks.

Cells, Handoffs, and Roaming

A cell is the geographical area that obtains wireless coverage from a single cell site (base station). The coverage area for a cell depends on the network protocol, signal power, and obstructions that may impede its progress. As you move further away from the base station, the signal strength is weaker. Typical cell sizes range from 1 to 40 kilometers in radius. For wireless wide area networks, multiple cells are coordinated into a cell system. These systems provide coverage over a larger geographic area. Figure 3.4a illustrates the coverage area of nine cells; Figure 3.4b illustrates the same cells as hexagons as they are often depicted in theoretical drawings.

Click To expand
Figure 3.4: Cell coverage.

In highly populated areas, it is frequently necessary to create microcells, where base stations are positioned closer to one another to handle higher numbers of users. Microcells are often deployed in individual buildings, such as conference centers or airports, to handle the large volume of users. The coverage area of microcells is much less than a regular cell, typically around 100 meters in diameter.

When users move from one cell to another while a call is in progress, their connection has to be passed from cell to cell. This process is called a handoff (or in some cases, handover). The handoff is one of the most important aspects of mobile computing since it allows for the uninterrupted movement of mobile users. An unsuccessful hand-off results in a "dropped" call, which can be very frustrating for users. This is especially true on circuit-switched networks where users have to reestablish their connection before continuing.

When users move to a cell owned by a different wireless operator, they are roaming. Historically, wireless operators have charged high premiums for using services from other carriers, especially when roaming between countries. This situation is starting to change as carrier consolidation and strategic partnerships increasingly come into being. In fact, many wireless plans allow for unlimited roaming within the country or sometimes even the continent.

Multiplexing Techniques

Multiplexing is a term used to describe how a signal can be divided among multiple users. This spectrum sharing allows wireless operators to maximize the use of their spectrum to accommodate a large number of users over fewer channels. For digital systems, three main multiplexing techniques are being used for wide area networks: frequency division, time division, and code division. A fourth method, called orthogonal frequency division, is the most complex of all of these methods. It is commonly used in high-speed local area networks, as discussed earlier in this chapter, but is starting to grow in popularity for wide area networks as well.

  • Frequency-division multiplexing (FDM). Numerous signals are combined on a single channel. Each signal on the channel is assigned unique frequency for communication. The caller and the receiver tune to the same frequency to communicate. This is similar to how radio stations work. Each has its own frequency band over which it broadcasts. To listen to a particular channel, you tune the receiver to that particular frequency. For person-to-person communication, this is a very inefficient use of spectrum, hence is only used by analog wireless networks.

  • Time-division multiplexing (TDM). As with FDM, numerous signals are combined on a single channel, but with TDM they are divided into separate time slots. The time segments are assigned to an individual user and are rotated at regular intervals. The receiver interprets the appropriate time slot (channel) to receive the information. This technique allows for variation in the number of signals sent along the line, and constantly adjusts the time intervals to maximize bandwidth. Many of the current second-generation wireless systems are based on time-division multiplexing as it provides efficient use of spectrum with minimal interference.

  • Code-division multiplexing (CDM). Rather than dividing the signal using frequency or time, CDM attaches a code to each signal, and sends them all over the same broad spectrum. This results in very high spectrum efficiency and low levels of interference by other signals. Even though all of the signals are being broadcast at once, a receiver will only accept the signals with the right code. This technique is used in several second-generation wireless networks and is the basis for nearly all third-generation networks.

First-Generation Networks (1G)

First-generation (1G) wireless networks were first constructed in the late 1970s in the United States and in the early 1980s in Europe. These analog networks were used only for voice communication and they suffered from high levels of interference, which led to unpredictable call quality. Early on, first-generation networks also suffered from poor handoffs, often resulting in dropped connections, low capacity, and almost no security. The devices also had to be quite large to incorporate the radio receivers necessary to capture the analog signal.

Despite these difficulties, first-generation networks were deployed commercially in many countries. In the early 1980s, the United States, along with Japan, Mexico, and Saudi Arabia, deployed networks using the Advanced Mobile Phone Service (AMPS). In Europe, several analog standards were introduced, including the Total Access Communications System (TACS) and Nordic Mobile Telephony (NMT).

Note

Interestingly, the AMPS acronym later came to refer also to Analog obile Phone System, and then to American Mobile Phone System. All three terms are still in use.

Due to the limitations of the first-generation networks, European countries were quick to move to a new standard based on completely different technology. The case is different in the United States where the AMPS network was widely deployed across all geographies. In many regions, the AMPS network is still used, often as a backup when digital coverage is unavailable.

First-generation networks do not play much of a role in the current m-business environment. They are of interest only when looking at backward compatibility of second-generation networks or for broader coverage in rural areas for voice coverage.

Second-Generation Networks (2G)

Second-generation networks introduced digital capabilities to wireless in the early 1990s. This resulted in higher-quality voice as well as basic data services. In addition, other features such as voicemail, call waiting, caller ID, and three-way calling were introduced to the wireless voice market. Another incredibly important benefit of moving to digital technology was increased capacity. Digital technology allows for more users to communicate on the same amount of spectrum, thereby increasing efficiency. Additionally, digital networks also provide a means for strong security, which was missing in the first-generation analog networks.

All of the second-generation networks provide support for data communications, with the exception of TDMA, which uses Cellular Digital Packet Data (CDPD) for its data services. The rates of data transfer range between 9.6 and 19.2 Kbps. This is fast enough for simple Internet applications based on the Wireless Application Protocol (WAP) or text messaging with Short Message Service (SMS), but it is not adequate for more data-intensive applications.

Four major second-generation systems are currently in use:

  • Digital AMPS (DAMPS, now known as TDMA), which can take advantage of first-generation AMPS service.

  • Code Division Multiple Access (CDMA IS-95), introduced by QUALCOMM in 1995.

  • Global System for Mobile Communications (GSM), which is the most popular of the 2G networks.

  • Personal Digital Cellular (PDC), largely used in Japan.

These four networks are all based on different standards, making them incompatible with one another. Moreover, even the same network protocol may not be compatible due to frequency regulations. For example, in Europe, GSM networks operate on the 900-MHz and 1800-MHz frequency bands, while in North America GSM networks use the 1900-MHz frequency band.

To accommodate these differences, dual-band and tri-band handsets are available. These handsets can switch between the different GSM frequencies so a user can roam between countries, or even continents, and still use the same mobile phone. In North America there are also dual-mode phones, which allow for roaming between the digital DAMPS network and the analog AMPS network. Other features in second-generation handsets include WAP browsers, text messaging, contact lists, calendars, games, and changeable ringtones. Kits are also available that allow for PDAs to gain wireless access using a mobile phone as the modem. The handheld devices are either attached to the phone using a cable or via short-range wireless connectivity such as infrared or Bluetooth.

When it comes to deploying data-driven applications, second-generation networks are often inadequate. They are circuit-switched, which is inefficient and expensive, and provide very limited data transfer rates. The need for higher capacity, higher data transfer rates, and global roaming were the driving forces behind the introduction of third-generation wireless networks.

Second-and-a-Half-Generation Networks (2.5G)

Just as the name suggests, 2.5G networks are a step toward third-generation networks, but they are not quite there. The good news is that they provide the main feature that users require to be successful on the mobile Internet: packet data. The move from circuit-switched systems to packet-switched systems is the major difference between 2G and 2.5G networks. This move brings along many other positive features, the leading one being high-speed data transfer at rates up to 144 Kbps, nearly 10 times that of 2G networks. For wireless operators, upgrading to 2.5G networks often requires only a software upgrade, not hardware modifications. This is a very attractive option for carriers who want to test the market for enhanced data services without incurring large capital expenditures.

Note

Although 115 to 144 Kbps is commonly used as the theoretical throughput of 2.5G systems, in practice, a more realistic data transfer rate is approximately 40 to 56 Kbps. This is still fast enough for a broad range of new applications.

Two leading 2.5G network protocols are in use: General Packet Radio Services (GPRS) Code Division Multiple Access 2000 1x (CDMA2000 1x). Both offer many compelling enhancements over existing 2G networks. The following are five important characteristics of 2.5G networks:

  • Efficiency. More efficient use of spectrum by sharing connections among several users for both data and voice communication. This allows wireless operators to accommodate more users on the same network.

  • Speed. By implementing more efficient modulation algorithms and by being able to use multiple channels simultaneously for data transfer, 2.5G networks can provide transfer rates up to 115 Kbps. This is a vast improvement over 2G systems.

  • Always-on capability. Users can remain connected to the 2.5G network without having to pay by-the-minute charges, as they would on a circuit-switched network. This allows users to access data services at their convenience without incurring fees for resources they are not using. It also allows for a new range of applications that can push data to the user, rather than have them request it.

  • Upgrade to 2G systems. Both 2.5G technologies, GPRS and CDMA 1x, are upgrades to existing cellular networks. Users still have the same voice capabilities as before, but now have high-speed data access with the same network coverage. In most cases, moving to 2.5G from 2G involves a software upgrade for the wireless carrier, as opposed to building new infrastructure from the ground up.

  • Foundation of 3G infrastructure. The implementation of 2.5G technology lays the groundwork for future upgrades to 3G systems. This is true from both a business and technical standpoint. It is expected that as users experience the benefits of high-speed packet data, they will require even more speed and capacity, forcing carriers to upgrade to 3G. At the technical level, 2.5G provides the base packet network on which 3G networks can be built.

GPRS Handsets

Three classes of handsets have been defined to take advantage of the new GPRS services. Terminal is the term used to describe the GPRS unit, since it may not actually be a mobile handset, but instead a wireless network card or other module. The following are the three classes:

  • Class A. These terminals handle both voice and packet data at the same time. This requires two transceivers, making Class A devices the most expensive of the three.

  • Class B. These terminals can handle both voice and packet data, but not at the same time. This requires one transceiver that can be used for either voice or data. This keeps the cost of the handset down.

  • Class C. These terminals can handle either voice or data. This class of terminal may be a low-end handset or, more likely, a wireless modem.

Often it is the device that is the limiting factor for the total data rates that 2.5G networks provide. In order to achieve the theoretical 115 Kbps, the device has to utilize all available time slots for both uploading and downloading data. Most devices do not provide this capability, as it increases the overall cost of the device for speed improvements that are not required by the average user.

2.5G Applications

Along with enhanced networks and new handsets come a full range of new wireless data applications. In some cases, the 2.5G applications are simply extensions to the applications used on 2G networks; in other cases, they are applications that previously were not practical or even possible on 2G networks. A good example of this is wireless Internet applications. On 2G networks, WAP applications are typically text-based with limited graphics. With 2.5G networks, wireless Internet applications can contain full graphics with some multimedia capabilities. The applications will also run more efficiently since the networks are packet-switched.

Other applications that lend themselves to 2.5G networks include:

  • Corporate email, calendar, contact lists

  • Instant messaging

  • Still and moving images

  • Job dispatch

  • Vehicle positioning using location-based services

  • Remote LAN access

  • File-sharing applications

All of these applications take advantage of at least one of the characteristics mentioned earlier in this section. The increased data transfer rates apply to nearly all applications, while others, such as instant messaging and job dispatch, make particular use of the always-on functionality. In addition, since GPRS networks behave similarly to a typical LAN, they allow developers to build applications the same way they would for a typical IP network (of course, keeping the device and network limitations in mind).

Third-Generation Networks (3G)

Third-generation (3G) networks started with the vision to develop a single global standard for high-speed data and high-quality voice services. The goal was to have all users worldwide use a single standard that would allow for true global roaming. Unfortunately, as companies and standards bodies from Europe, North America, and Japan met, they could not agree on a single protocol for 3G systems. To help things progress, the leading standards bodies from these countries created a new group called the Third-Generation Partnership Project (3GPP). This group became the driving force behind the development of 3G standards.

After much negotiation, it was realized that backward compatibility with 2G networks and frequency differences among countries were too much to overcome, so agreement on a single 3G implementation could not be reached. Instead, three branches of 3G systems were created: Wideband CDMA (WCDMA), CDMA2000, and Enhanced Data Rates for Global Evolution (EDGE). In 1999, The International Telecommunication Union (ITU) approved an industry standard for third-generation wireless systems. This standard is called International Mobile Telecommunication-2000 (IMT-2000). Each of the 3G network protocols is explained in more depth in the section entitled "Network Protocols" later in this chapter.

Note

Actually, there are more than three branches of 3G, since WCDMA varies in implementation between European and Japanese operators. Also note that, in Europe, 3G systems are often referred to as UMTS (Universal Mobile Telecommunications System) rather than WCDMA.

Interestingly, 3G systems are based on CDMA technology, whereas the majority of 2G implementations use TDMA. This fact was also an item of contention among the standards bodies. Several proposals were made to the 3GPP, but the eventual winner was the CDMA-based solutions mentioned previously. The first 3G systems were implemented on a trial basis in Japan and Europe in late 2001. Worldwide commercial rollouts of these networks began in late 2002, and will continue into 2005. By 2005 to 2006, 3G networks are expected to reach a critical mass in both the consumer and corporate markets. This is the point at which the high-speed wireless networks become a necessity, not a luxury. Over time, the goal of the IMT-2000 is to converge the three 3G standards into a single universally accepted standard. Only time will tell if this will occur.

Once there was agreement on the standards, details were provided on which features these networks would offer. Two main enhancements characterize third-generation networks:

  • Higher data rates. 3G systems provide data transfer rates ranging from 144 Kbps to 2 Mbps, depending on the level of mobility. The IMT-2000 has defined three levels of mobility. All 3G networks must support the following minimum requirements:

    • High mobility: 144 Kbps for outdoor rural users who are traveling at speeds greater than 120 kilometers per hour (75 miles per hour).

    • Full mobility: 384 Kbps for users traveling less than 120 kilometers per hour in urban areas.

    • Limited mobility: 2 Mbps for users who are moving at less than 10 kilometers per hour (around 6 miles per hour).

  • Enhanced quality of service. QoS is supported from end to end in 3G systems, unlike their 2.5G predecessors. This allows users to establish agreements with network operators for certain network properties such as data transfer rate and network latency.

Looking at the preceding information, note that most vendors talk about 2 Mbps bit rates for 3G networks, when in reality that is only for users in stationary indoor environments. A more typical rate for the average mobile user is around 384 Kbps, which is still close to 50 times the rates achieved in most 2G systems. This is also notable, because when users move away from 3G network coverage, they will typically drop into 2.5G or 2G networks that have wider coverage areas. This may result in an unacceptable decrease in speed, as users could potentially move from 384 Kbps to 56 Kbps, or possibly even 9.6 Kbps transfer rates.

Another important point is that the data transfer rates in 3G systems are dependent on the user's distance from the base station. The further a user moves from the base station, the more difficult it becomes to achieve high speeds. The QoS features of 3G networks often mitigate this, but distance still affects network performance.

Note

We do not go into depth about the physical structure of 3G networks, as it is not pertinent to the development of m-business applications. Since 3G networks are IP-based, the applications created for one network should work equally well on others. This is a significant advantage introduced with 2.5G and 3G networks.

3G Devices

Device manufacturers typically trail network operators when releasing new devices. This means that we have yet to see many of the devices for third-generation networks. That said, many manufacturers have already started releasing devices for 3G networks. These devices usually have a few things in common, namely:

  • Support for multimedia content such as video streaming

  • Large, high-resolution screens

  • Form factors similar to PDAs

  • Integrated voice and data as seen in high-end smart phones

  • Mobile operating systems that allow for sophisticated client-side applications

Looking at the device characteristics, it becomes clear that 3G networks are targeted at wireless data as much as they are at voice communication.

3G Applications

Many of the applications aimed at 3G networks are similar to those being developed for 2.5G systems. Both generations of networks support IP applications, providing an easy migration path for application developers. That said, there are several new applications that are enabled specifically by the increased bit rates 3G networks offer, namely:

  • Streaming video applications

  • Downloadable audio such as MP3s

  • Over-the-air download of software programs

  • Workplace collaboration

  • Voice-over-IP (VoIP)

  • Location-based services

  • Multimedia messaging services

  • Support for corporate email and a full range of attachments

This is just a sampling of the new applications that 3G networks will enable. As developers start to gain access to these networks, and the programming interfaces they provide, new and innovative applications will start to enter the market. This is a very exciting time for application developers, as they are just beginning to see the capabilities that wireless has to offer.

Network Protocols

Many network protocols were mentioned in the discussion of the different generations of wireless systems. This section offers more information on these protocols, such as the frequencies over which they operate, their data transfer rates, and the locations where they are deployed. We start with paging networks and data-only networks, and progress to third-generation networks.

Paging Networks

Paging networks provide an alternative to the networks discussed earlier in this chapter. While many people consider pagers to be behind the times, these devices continue to provide some advantages over the current wireless networks. Paging networks operate at a very low frequency, which allows them to have good in-building coverage and wider coverage areas per base station. This has enabled nationwide coverage for paging networks, even in very remote areas. Paging networks are packet-based, allowing for information to be pushed to the user. This is clearly an important characteristic as push data is fundamental to receiving a page.

Three leading paging networks are currently in use:

  • Flex/reflex. A popular paging network in North America, invented by Motorola.

  • ERMES. The European Radio Message System, developed for use in Europe, has been adopted by the ITU as the recommended paging system.

  • POCSAG. This older paging system, named after the Post Office Code Standardization Group, has been replaced by more advanced systems, and is not widely used.

Even though paging networks are often overlooked when evaluating wireless network options, they still provide a service that is essential to many consumers and corporate workers: They are a low-cost alternative for users who do not require the additional features found in mobile phones or wireless PDAs.

Data-Only Networks

Several data-only networks are worth discussing. These networks are either used in conjunction with a voice network or on their own for data-driven applications.

CDPD

Cellular Digital Packet Data (CDPD) was introduced as a packet-switched option for AMPS and DAMPS. This allowed carriers to offer both voice and data services with their existing network infrastructure. It is the only way to send data over the analog AMPS network. Additionally, it is used as the data layer for TDMA networks.

CDPD has a maximum download speed of 19.2 Kbps and upload speed of 9.2 Kbps. In practice, these rates are lower, because they are shared among multiple users in a cell. Even with slow data rates however, CDPD became a popular option for wireless data using laptops and PDAs. In this scenario, wireless cards with embedded CDPD terminals are used for connectivity. For application developers, CDPD is a familiar protocol since it can run IP applications without modification. Every user connected to a CDPD network has a unique IP address. CDPD network coverage is found in most major cities in North America.

Mobitex

Mobitex is a narrowband, packet-switched protocol that provides data transfer rates up to 8 Kbps. It was first developed by Ericsson in the 1980s and has since been deployed in 23 countries worldwide. Mobitex networks provide low data rates at a low cost. The most substantial Mobitex network in North America is offered by Cingular Wireless; consequently, it is used by both Palm.net and BlackBerry.net networks in the United States.

Mobitex operates on three different spectrum bands: 400 MHz, 800 MHz, and 900 MHz. Any application developed for the Mobitex specification can operate equally well on any of these frequencies.

DataTAC

DataTAC stands for Data Total Access Communications. Like Mobitex, DataTAC offers packet-switched narrowband wireless data access, in this case with data transfer rates up to 19.2 Kbps. Three types of DataTAC networks have been deployed:

  • DataTAC 4000, which operates in North America.

  • DataTAC 5000, which operates in Asia and the Pacific.

  • DataTAC 6000, which operates in Europe.

The DataTAC network is often referred to as ARDIS, which is the name brand it operates under in North America. According to ARDIS, its network covers more than 90 percent of the North American business population. Notably, the RIM BlackBerry 850 and 857 devices use the DataTAC network for wireless connectivity.

TDMA (2G)

In the Americas, the term Time-Division Multiple Access (TDMA) is used to describe the DAMPS network, which is used to provide digital capabilities to the AMPS network. TDMA by itself does not provide any data capabilities; these are provided by CDPD, which is commonly integrated into TDMA networks.

TDMA networks are the leading 2G technology in the Americas; in the United States, it has nearly 100 percent coverage, and it is the only national network in many South American countries. In this region, TDMA subscriber growth is outpacing all other technologies, although this is likely to change as third-generation networks become mainstream. AMPS operators are able to add a TDMA layer on their existing infrastructure. By moving to a TDMA network, AMPS operators can achieve a threefold increase in capacity.

In other locations, TDMA is viewed from more of an engineering level. It is a multiplexing technology that uses time slices to divide a signal among multiple users (as described earlier in this chapter). In this sense, TDMA, also referred to as ANSI-136, is the leading 2G technology, as it provides the base for other network protocols such as GSM.

GSM (2G)

The Global System for Mobile Communications (GSM) is the most extensively used 2G technology in the world. GSM is a circuit-switched technology based on TDMA (ANSI-136). TDMA operators in North America are increasingly seeing the benefits of GSM technology: high voice quality, international roaming capability, large number of handset manufacturers, and broad developer base. Additionally, GSM offers a clear path of migration to 3G networks, which is attractive for many TDMA carriers.

GSM operates on three distinct frequencies: 900 MHz, 1800 MHz, and 1900 MHz. The 900 MHz and 1800 MHz are used in Europe, while 1900 MHz is used in North America. In order to provide international roaming, handsets are available that support all three GSM frequencies. These devices are called world phones because they provide worldwide access to wireless networks.

The data transfer rate of GSM networks is 9.6 Kbps. This is enough for the popular text-messaging applications and WAP browsing, but inadequate for other types of applications. To address this concern, a transitional technology called High-Speed, Circuit-Switched Data (HSCSD) was introduced. HSCSD allowed for multiple time slots to be used in a single connection for data transfer up to 57.6 Kbps. This was the expected evolution of GSM networks until more attractive packet-based networks such as GPRS came along. Now HSCSD is rarely discussed as the future for GSM networks. Instead, GSM networks have an upgrade path to 3G using GPRS as the 2.5G technology.

cdmaOne (2G)

Similar to TDMA, Code-Division Multiple Access (CDMA) is both a multiplexing technique and a 2G wireless network protocol. In order to differentiate the two, the network protocol is commonly referred to as cdmaOne, while the standard itself is CDMA, or IS-95.

cdmaOne is a circuit-switched technology that uses a spread-spectrum signal propagation technique. A signal is divided using distinct codes, then spread over the entire spectrum available to it. The advantages of this approach are increased user capacity and high voice quality. CDMA is very efficient when it comes to using spectrum; cdmaOne has been shown to increase the user capacity of an AMPS network by 8 to 10 times.

cdmaOne operates over two main frequencies: 800 MHz and 1900 MHz. The 800 MHz implementation competes with TDMA (DAMPS) in the United States, while the 1900 MHz implementation competes with GSM. Each channel of a cdmaOne system is 1.25 MHz wide and offers data transfer rates of 14.4 Kbps. Like GSM, this is sufficient for text messaging and simple wireless Internet applications, but insufficient for richer applications using images and multimedia content. This has been addressed in the newer CDMA standards called CDMA2000 and WCDMA. Each of these is described later in this section.

QUALCOMM, the pioneer of CDMA, commercially introduced CDMA in 1995. The evolution and promotion of CDMA is now handled by the CDMA Development Group (CDG), which is composed of the leading CDMA service providers and manufacturers. CDMA has experienced broad commercial success in the United States and Asia Pacific where GSM is not as prevalent. It has also been selected by the ITU as the basis for third-generation networks.

PDC (2G)

Personal Digital Cellular (PDC), a system used in Japan, is based on TDMA and offers backward compatibility to the country's existing analog networks. PDC offers a 9.6 Kbps data transfer rate over circuit-switched networks.

In the 1990s, Japan's largest telecom company, NTT DoCoMo, added a packet-switched addition to PDC called Packet PDC (P-PDC) that provides packet data capabilities. It also launched a service called i-mode that provides wireless multimedia over this network. Due to the phenomenal success of i-mode, PDC is now one of the world's most popular wireless standards, even though it is used only in one country.

The evolution of PDC goes directly to third-generation networks using WCDMA. There is no intermediate transition to 2.5G networks.

GPRS (2.5G)

General Packet Radio System (GPRS) introduced packet-switched capabilities to wireless networks. It is a simple, cost-effective upgrade to GSM and TDMA networks that provides increased bit rates and an improved user experience. As discussed in the earlier section on 2.5G networks, packet data systems provide always-on capabilities that allow users to remain connected to the wireless network for extended periods of time without incurring large usage fees.

GPRS operates on the same frequencies as the 2G networks it upgrades, specifically 900 MHz, 1800 MHz, and 1900 MHz. It can provide high-speed data transfer at theoretical rates approaching 115 Kbps, although in practice the throughput has proven to be closer to 40 Kbps. Since GPRS is an upgrade to existing infrastructure, users are able to roam between the GPRS network and GSM/TDMA networks. This ability allows operators to upgrade the major urban centers first, and gradually extend the GPRS network into rural areas.

GPRS is considered a safe point between 2G and 3G networks. It allows operators to experiment with new data services without incurring high capital expenditures. As users become more familiar with the benefits that GPRS networks provide, it is expected they will want even faster data rates, therefore increasing demand for 3G networks. GPRS is the base for EDGE and WCDMA systems.

CDMA2000 1x (2.5G)

CDMA2000 1x is difficult to categorize. Officially, it is classified as a third-generation technology, as defined by the ITU. Practically, it is a 2.5G technology, as it does not meet the minimum speed requirements for 3G networks, and is very similar to GPRS, which is clearly defined at 2.5G. For this reason, we are including CDMA2000 1x as a 2.5G standard.

CDMA2000 1x supports both voice and data services over the standard 1.25 MHz CDMA channel. The 1x in the name signifies that it uses one 1.25 MHz channel. Due to improved modulation, power control, and overall design, it can achieve theoretical data transfer rates of 144 Kbps. In practice, the data throughput for CDMA2000 1x is closer to those of GPRS at 40 to 56 Kbps. Additionally, CDMA2000 1x provides nearly double the capacity of previous CDMA systems and even more substantial increases for TDMA and GSM systems. It also adds packet-data capabilities to provide always-on capabilities.

CDMA2000 1x is backward-compatible with cdmaOne, operating on the same 800-MHz and 1900-MHz frequency bands. It is a cost-effective upgrade to existing cdmaOne networks, paving the way for third-generation CDMA2000 1XEV and CDMA2000 3x networks (3x networks use three 1.25-MHz channels simultaneously, thereby providing increased data throughput).

EDGE (3G)

Enhanced Data Rates for Global Evolution (EDGE) is a technology that allows current GSM networks to offer 3G services within existing frequencies. TDMA or GSM/GPRS infrastructure can be upgraded to EDGE with minimum impact. Since EDGE is a narrowband (200-kHz channels) technology, wireless operators are able to deploy 3G EDGE services without obtaining a 3G license. These two factors make EDGE a lowcost, fast solution for providing 3G services on a nationwide level.

EDGE is able to increase the over-the-air data rates using the same spectrum as 2G/2.5G systems. The peak data rates with EDGE are typically around 384 Kbps, with actual download rates ranging between 75 and 150 Kbps, depending on the user's distance from the base station, among other factors.

EDGE provides a seamless upgrade from 2G GSM networks to 3G UMTS (WCDMA) networks. The frequency bands that EDGE operates in complement the UMTS/WCDMA technology, allowing for the deployment of networks that use GSM, EDGE, and WCDMA in a fashion that is transparent the to user.

CDMA2000 1x EV (3G)

There are two members of CDMA2000 1x EV family: CDMA2000 1x Evolution Data Optimized (CDMA 1x EV-DO) and CDMA2000 1x Evolution Data and Voice (CDMA 1x EV-DV).

CDMA2000 1x EV-DO is a data-optimized version of CDMA2000 that can provide peak data rates of up to 2.4 Mbps using a single CDMA 1.25-MHz channel. With the introduction of improved technology for modulation and dynamically assigned data rates, 1x EV-DO is able to achieve download rates near the theoretical levels. CDMA2000 1x EV-DO supports the complete range of available frequencies, including 450 MHz, 700 MHz, 800 MHz, 1800 MHz, 1900 MHz, and 2 GHz. CDMA 1x EV-DO can work on all IP networks, giving wireless operators an opportunity to gain experience with IP-based technologies before moving their voice networks to IP. It is the natural path of evolution for CDMA 2000 1x networks.

CDMA2000 1x EV-DV networks are expected to be available in 2003. They will provide similar wireless data capabilities as CDMA2000 1x EV-DO, but with the addition of integrated voice capabilities. CDMA2000 1x EV-DV will provide peak data rates topping 3 Mbps, with typical throughput around 1 Mbps. This technology will enable real-time packet services for two-way conversational communication.

WCDMA (3G)

Two types of Wideband CDMA (WCDMA) are in use: Frequency-Division Duplex (FDD) and Time-Division Duplex (TDD). TDD is a hybrid of CDMA and TDMA technologies and is not commonly used commercially for WWAN implementations. It is better suited for indoor usage. The FDD version is the focus here, as it is being deployed commercially in several countries. The "wideband" part of its name refers to the requirement for channel bandwidth of 5 MHz. This is four times larger than CDMA2000 1x (1.25-MHz channel width) and 25 times larger than the GSM (200-kHz channel width). The wider bandwidth allows for higher data transfer rates. WCDMA supports all three modes of mobility as defined in the IMT-2000. As a refresher, these modes are high mobility (144 Kbps), full mobility (384 Kbps), and limited mobility (2 Mbps).

The version of WCDMA being deployed in Europe is commonly referred to as Universal Mobile Telecommunication System (UMTS). It uses direct-sequence (DS) CDMA and therefore it is also called DS-WCDMA. For our purposes, we will continue to refer to it simply as WCDMA. WCDMA has been designed as an upgrade to existing GPRS and EDGE networks, operating on the 2-GHz frequency band, and providing peak data transfer rates of 2 Mbps in stationary environments. Unlike the upgrade to GPRS and EDGE, WCDMA requires coverage to be built from scratch. Since this requires significant capital expenditures by carriers, WCDMA coverage will initially be available only in urban centers. Fortunately, WCDMA is compatible with GSM, GPRS, and EDGE networks, so users do have the ability to roam between the various network implementations. This means that as users move out of WCDMA coverage, they will automatically be handed off to a GSM, GPRS, or EDGE network and continue communicating at a slower data rate.

In Japan, NTT DoCoMo has deployed a WCDMA-based 3G network called Freedom of Multimedia Access (FOMA). It uses a slightly different version of WCDMA than that used in Europe. It was designed as an upgrade from PDC, and therefore does not require backward compatibility with GSM-based networks. In North America, the 2-GHz frequency band is already in use, so WCDMA either has to be introduced into the existing frequencies or new spectrum has to be allotted. This is one of the reasons why a single 3G network protocol cannot be adopted worldwide.


WWAN Operators

One observable trend in the wide area wireless industry is consolidation. In order to remain viable, many network operators are purchasing or partnering with companies that offer complementary technology. This makes it very difficult to maintain an accurate list of the WWAN operators. For this reason, in Table 3.4, rather than attempting to provide an exhaustive list of the wireless operators, we list information and URLs for the organizations that oversee the network protocols. These Web sites will have the most up-to-date information on the carriers in each region for their respective protocols. Additionally, these sites serve as a good resource for information on these operators' respective technologies.

Table 3.4: Oversight Organizations for Network Protocols
ORGANIZATION | WEB SITE | DESCRIPTION
GSM Association | www.gsmworld.com | Country-by-country listing of GSM/GPRS/EDGE carriers
CDMA Group | www.cdg.org | Regional listings of carriers using CDMA technology
UMTS Forum | www.umts-forum.org | Listing of countries with UMTS (WCDMA) networks
Mobitex Operators Association | www.mobitex.org | Listings of all public and private Mobitex networks
Motorola DataTAC | www.datatac.com | Listings of public DataTAC operators

Criteria for Selecting a WWAN Operator

There are literally hundreds of WWAN operators worldwide, each of which supports at least one of the network protocols covered in this chapter. If you are investigating a wireless provider for your organization, the following are the leading characteristics that you will want to consider before making your decision:

  • Coverage. This is potentially the most important aspect. If your user base is outside of the carrier's coverage area, then the service will be useless to them. Inter-carrier roaming helps to alleviate this problem, but does not solve it entirely since the cost of roaming is usually higher than the rate charged by the primary carrier. When looking at coverage for 2.5G and 3G networks, find out which areas the updated networks service and which the 2G networks service.

  • Cost. Many areas of cost need to be investigated. The first item to remember is that cost is often based on call times rather than data usage. This usually results in higher bills than would be accrued with a packet-switched network, which only charges for the actual data transferred. If you are signing up for a call bundle, try to avoid unused minutes, as they end up costing more than you would save by getting the bundle in the first place. Many of the packet data carriers provide unlimited data transfer at a fixed rate. These packages work well for budgeting purposes.

  • Capacity. With the increasing number of wireless users, it is important that the operator you choose has enough capacity to handle them. Insufficient capacity results in the inability to connect to the network and dropped calls for circuit-switched networks, and slow data rates for packet-switched networks. For corporate contracts, wireless carriers should be willing to share their capacity data.

  • Device support. Mobile devices cannot operate on all networks. If a device has already been selected, make sure there is a modem available for the network you select. In cases where the device has a built-in modem, you may want to evaluate the network options before purchasing the devices. In many cases, wireless operators will have formed partnerships with specific device manufacturers to ensure their offerings work well together.

  • Upgrade plans. Consider both current and future deployments in your decision. If you expect that high-speed data will be a requirement in the future, evaluate the carrier's 3G deployments to ensure it will cover the geographies you require. You will also want to find out whether new handsets are required in order to upgrade.

Evolution to 3G

The WWAN market is a complex mesh of network protocols and standards. Second-generation network deployments are largely based on two competing technologies: TDMA and CDMA. The overwhelming majority of second-generation wireless customers use TDMA-based networks (TDMA, GSM, PDC). Interestingly, this looks to change, as the third generation of networks is based largely on CDMA technology (WCDMA, CDMA2000 1xEV). Figure 3.5 illustrates the move to third-generation networks, showing that TDMA is dominant in 2G, while CDMA is prevailing in 3G.

Click To expand
Figure 3.5: Wireless network evolution.

Without some analysis, this seems quite odd. Why are 3G networks based on CDMA when the majority of existing networks are TDMA-based? Is it because CDMA is a superior technology? If that is the case, then are network providers deploying an inferior technology?

Let us look at why this indeed may be the case. Network providers have to evaluate more than just the technology when implementing a wireless network. Some of the factors beyond the spectral efficiency of the protocol include ease of implementation (which affects time to market), technology maturity, backward compatibility, and implementation costs. TDMA technology has been around longer than CDMA and was less risky for companies deploying large networks. Furthermore, CDMA is more complex for operators to deploy, resulting in higher implementation costs and longer time to market. When 2G networks were being deployed, these factors made TDMA a safer choice.

Things have changed. The number of wireless users is growing rapidly. These users are demanding high-speed wireless access, in addition to high-quality voice services. The existing second-generation networks are not capable of providing these services. To accommodate these demands, networks have to be upgraded to provide higher capacity and faster bit rates. Third-generation networks had to adopt a standard with greater spectral efficiency, namely CDMA. The downside is that most of the existing network infrastructure has to be rebuilt to support the 3G networks. This can be an expensive and time-consuming task, so an intermediate step was added: 2.5G. These networks provide a stepping-stone in the evolution to 3G, as 2.5G networks can be deployed on existing 2G systems with relative ease. This enables carriers to provide the increased capacity and higher data rates while still maintaining backward compatibility. GPRS is a software overlay on TDMA/GSM networks, and CDMA2000 1x is a software upgrade to cdmaOne networks. GPRS and CDMA2000 1x also introduced some of the core 3G infrastructure in the form of packet-switched networks, making the move to 3G networks a bit smoother.

The final step (for now) is the move to the third-generation networks. This is a bit tricky as well, since not all 3G networks are the same. While most third-generation networks are based on CDMA, there is one option that is not—EDGE—and it's an attractive option, since it is a technology where TDMA and GSM/GPRS can converge, although it does not offer the same throughput as WCDMA. This situation will likely have one of two outcomes: a direct upgrade from GSM/GRPS to WCDMA, or an eventual second upgrade of EDGE systems to WCDMA.

On the cdmaOne side of the equation, we have CDMA2000 1x providing the intermediate step to either CDMA2000 1x EV, or WCDMA. Since all of these networks are CDMA-based, the upgrade is not quite as difficult. Finally, PDC is moving directly to WCDMA without a 2.5G network in between. This has led to the first commercial WCDMA deployments in Japan.

WWAN Summary

Wireless wide area networks continue to evolve. It has been over 20 years since the first-generation analog networks were deployed commercially. Since then we have seen the emergence of digital technology, resulting in higher-quality voice communication and the capability to transfer data wirelessly. The latest developments are high-speed packet-switched networks that provide always-on capabilities. These networks are a leading driver in the adoption of wireless data applications.

Table 3.5 summarizes the wireless networks that are currently being used for wireless data, showing the network frequency, data transfer rates, and deployment regions.

Table 3.5: Comparison of Network Protocols
NETWORK PROTOCOL | FREQUENCIES | DATA TRANSFER RATE | COVERAGE
Mobitex | 400 MHz, 800 MHz, 900 MHz | 8 Kbps | Widely available in North America; coverage in 23 other countries.
CDPD | 800–900 MHz | 19.2 Kbps | Widely available in North America.
DataTAC | 800 MHz | 19.2 Kbps | North America, Asia Pacific, and Europe.
TDMA | 800 MHz, 1900 MHz | 19.2 Kbps via CDPD | Widely used in the Americas, with some deployment in Asia Pacific.
GSM | 900 MHz, 1800 MHz, 1900 MHz | 9.6 Kbps | Pervasive throughout Europe; deployed in nearly 170 countries.
CDMA | 800 MHz, 1900 MHz | 14.4 Kbps | Widely used in North America; popular in Asia Pacific.
GPRS | 900 MHz, 1800 MHz, 1900 MHz | 115 Kbps | Logical upgrade to GSM and TDMA networks, therefore deployed in the same regions.
CDMA2000 1x | 800 MHz, 1900 MHz | 144 Kbps | Logical upgrade to CDMA networks, therefore deployed in the same regions.
EDGE | 800 MHz, 900 MHz, 1800 MHz, 1900 MHz | 384 Kbps | Upgrade to GPRS, GSM, and TDMA; deployed in same regions.
CDMA2000 1x EV-DO | 450 MHz, 700 MHz, 800 MHz, 1800 MHz, 1900 MHz, 2 GHz | 144 Kbps-2.4 Mbps | Upgrade to cdmaOne and CDMA2000 1X; deployed in same regions.
WCDMA | 2 GHz | 144 Kbps-2 Mbps | Upgrade to PDC, EDGE, and CDMA2000, resulting in potential worldwide deployments.

There is an increasing threat from WLANs to 3G deployments in highly populated areas and public hotspots. While network operators continue to deploy 3G networks, WLANS are being deployed in many public locations. WLANs provide a high-speed (usually 11 Mbps), low-cost solution for wireless data access. There is no doubt that they will have some impact on the business of 3G operators, but perhaps not as much as some might think. We have to remember that the primary revenue stream (by a long shot) for wireless wide area networks is voice communication, not data. Third-generation operators are counting on wireless data for new sources of income and profits, but at the same time voice communication remains the killer application for WWANs.


Satellite Systems

Using satellite systems for wireless voice and data first came into consideration in the early 1990s. The goal was to provide a wireless network that would provide coverage for the entire planet, without the need for multiple mobile phones or to roam between many carriers' networks. The state of WWANs then was quite different from today. Many of the existing WWANs were still analog and there was no clear standard for second-generation networks. Satellite phones had the potential to become the de facto standard for wide area communication.

At the same time that satellite marketers were pitching a phone that would work across the globe, wireless carriers were implementing expansive networks; and mobile phone manufacturers were working on new lightweight attractive designs. By the time the satellite networks were ready for commercial use, they had already been overtaken by cellular systems. Satellite companies had a very difficult time promoting bulky, expensive satellite phones, when attractive, inexpensive cellular phones would provide the same benefits. If that were not enough, the airtime fees for the satellite networks would scare away even the most spendthrift customer.

Many of the early mobile Internet satellite providers discovered that their business plans were not as foolproof as they thought; some went bankrupt. Fortunately, the story did not end here. Even though widespread satellite phone usage was not destined for success, many other scenarios existed where satellite technology could prove to be helpful. Here are three examples:

  • Fixed locations. This refers to situations when access to voice and data systems is required from locations that are not serviced by other network types. Some examples of locations that could benefit from this service are industries such as oil and gas, utilities, and manufacturing; humanitarian workers in remote areas; military establishments; remote office locations or semifixed locations such as trailers or shelters. Consumer services are also offered where the download link is via satellite and the upload is through a telephone line.

  • Portable communication. Field personnel can send and receive voice and data regardless of their location. This can be useful for search-and-rescue efforts, research in remote locations, news agencies, corporate travelers in remote locations, and military efforts.

  • Vehicle. This may be one of the more compelling cases for satellite connectivity. Field workers can be assured that no matter what their location, they can communicate it and other pertinent information back to enterprise systems. Delivery personnel, law enforcement, and news organizations can all benefit from guaranteed coverage.

The terminals used for satellite communication range from handheld units to mobile base stations to fixed satellite dish receivers. The peak data transmission speeds range from 2.4 Kbps to 2 Mbps, depending on the solution being sought. For the everyday mobile professional, satellite communication does not provide a compelling benefit, but for people requiring voice and data access from remote locations or guaranteed coverage in nonremote locations, satellite technology may be worth consideration. Also of interest, some of the satellite service providers offer roaming between existing cellular systems and satellite systems.

To get you started, Table 3.6 lists some of the leading satellite service providers with their Web sites.

Table 3.6: Satellite Service Providers
SATELLITE SERVICE PROVIDER | CORPORATE URL
Iridium | www.iridium.com
WirelessMatrix | www.wirelessmatrixcorp.com
GlobalStar | www.globalstar.com
ICO | www.ico.com
Teledesic | www.teledesic.com
Orbcomm | www.orbcomm.com
Inmarsat | www.inmarsat.com
Hughes Network Systems | www.hns.com
Thuraya Satellite | www.thuraya.com
Asia Cellular Satellite | www.acesphones.com


Summary

Wireless connectivity is available at many levels. Personal networks can be established for communication between devices in close proximity to one another. These networks are most commonly used as a cable replacement technology. The leading technologies in this area are Bluetooth and 802.15. Moving to larger wireless networks, wireless local area networks can provide high-speed wireless coverage within 100 meters of a base station. These networks can be used to either replace wired networks or to extend them. The leading WLAN technologies include 802.11a, 802.11b, and HIPERLAN. Both of these network types operate over unlicensed frequencies so there is no charge or airtime.

For wireless communication on a larger scale, wireless wide area networks are available. These networks are in their third generation, offering high-quality voice communication and high-speed data access on a national level. These networks extend enterprise systems into new locations. There are many competing standards for WWANs, including GSM, GPRS, cdmaOne, and WCDMA. If truly global wireless access is required, satellite networks are available to provide access to voice and data applications from anywhere on the planet.

In the next chapter we will take an introductory look at the leading mobile application architectures.


Helpful Links

With so much information covered in this chapter, we list several Web sites to help you find additional information on a given topic.

Bluetooth | www.bluetooth.com
CDMA Development Group (CDG) | www.cdg.org
ETSI, for HIPERLAN/2 specifications | www.etsi.org
IEEE 802.15 | www.ieee802.org/15/
IEEE 802.11 | www.ieee802.org/11/; www.standards.ieee.org
Infrared Data Association (IrDA) | www.irda.org
International Mobile Telecommunication-2000 (IMT-2000) | www.imt-2000.org
International Telecommunications Union | www.itu.int/home/index.html
Mobitex Operator Information | www.mobitex.org
QUALCOMM CDMA | www.qualcomm.com/cdma/index.html
Third-Generation Partnership Project (3GPP) | www.3gpp.org
Third-Generation Partnership Project 2 (3GPP2) | www.3gpp2.org
3G Americas | www.3gamericas.com
3G information | www.3g.co.uk
Universal Mobile Telecommunications System (UMTS) | www.umts-forum.org
Wi-Fi Alliance | www.wi-fi.org


Chapter 4: Mobile Application Architectures

Many factors contribute to the success (or failure) of a mobile solution. These include the mobile device, wireless network connectivity, enterprise integration, and most important, the application architecture. Many people do not realize that several application models are available for mobile development, each with a different set of characteristics that make it appropriate for some applications and inappropriate for others.

In this chapter we introduce three mobile application architectures: wireless Internet, smart client, and messaging. A summary of each application model is provided, along with the advantages and disadvantages it offers. But before we investigate the architectures, we will look at some of the key criteria used for determining which architecture is best suited for a given application.

Choosing the Right Architecture

Many factors come into play when selecting a mobile application architecture. Evaluating the target audience, device type, network connectivity, enterprise integration, and security requirements, along with the specific criteria in the following list will enable you to select the architecture that is most suitable for your particular situation. Finding the answers to these questions, along with any others that may arise is an important step to determining which application architecture is most appropriate for your particular application.

Application Users

  • Who are the end users of this application?

  • Do they have technical skills?

  • What are the expected usage scenarios?

Understanding the end users is important in meeting their needs and is a fundamental requirement for any mobile application. The success of many mobile applications is often determined by the adoption and usage by end users.

Device Type

  • For corporate solutions, are there devices already deployed that must be used, or are new devices being provisioned for this application?

  • What type of device is most appropriate? Some factors that will affect this include the data input mechanism, wireless connectivity options, and form factor.

  • Is the device a complete package? Some devices come with wireless capabilities, while others need to be coupled with wireless components.

  • What are the capabilities of the components? For instance, some wireless PCM-CIA cards cannot be connected to the Internet and receive SMS messages simultaneously.

For some corporate solutions and many consumer solutions, you may not be allowed to dictate the target device. In that case, the questions must be approached from a different angle.

  • What functionality is available within a specified group of devices?

  • Do any devices preclude certain functionality?

Enterprise Connectivity

  • How will the mobile device connect to the enterprise?

  • Does it require wireless access, or is wired access (for example, USB, dial-up, serial) acceptable?

  • If wireless, what type of networking will it use: WPAN, WLAN, WWAN, or satellite?

  • Does the type of networking affect the amount of data transferred from the mobile application to the enterprise server?

Enterprise Data

  • How much data has to be available to the mobile user?

  • Where does this data reside: on the client device or enterprise server?

  • Is it feasible to download the data in real-time over a wireless network, or is client-side data storage required?

  • What is the longevity of the data and how often must it be refreshed? For example, stock quotes are only valuable when they are current, while an inventory list may not require daily updates.

  • Is it assumed that each end user will have only one device?

  • Can users share a device without mixing their data?

  • If a local data store is chosen, how will you reconcile local data with enterprise data?

  • Do you have a conflict-resolution scheme for updates to your corporate database?

Enterprise Integration

  • Does your client-side method of integration match your server-side API? For example, an application that has a local data store may choose to synchronize its changes up to the corporate database. Usually this process requires direct access to the corporate database or access to a data buffer which sends the data to the corporate data store later.

  • What if the only access to the corporate data store is through an API? In that case, you will need to use business logic to call the API using the data buffer.

One of the fundamental reasons to deploy mobile solutions is to extend the reach of enterprise data to mobile workers. To accomplish this, an application architecture must integrate with enterprise data. This can range in time and complexity, from trivial to impossible, and could be considered the most important area for concern.

For these reasons, many companies that are extending existing Internet sites will choose a wireless Internet model even though other application models may be more appropriate based on the other selection criteria.

User Notification

  • Do users need to be notified of new information during the day?

  • If the only message needed is a "ping" to the user, can existing mobile phones or paging device be used? For example, if a field technician must be informed that he or she must synchronize because another customer has been added to the schedule, can the message be sent via phone, pager, or to a smart client device? Does the message have to be sent at all, because the field technician will synchronize at the end of every job anyway?

  • Does the notification have to communicate some specific information directly to the mobile application, allowing for a lookup value, hyperlink, or automatic login to speed up the process? Receiving a message that reads: "New customer added. Click here to view details," is certainly easier for the end user.

  • What happens if the device is off or in another mode, which does not permit notifications to be received?

The ability for mobile users to be notified or updated during the day is a growing requirement for many mobile applications. This ability to push information can make mobile applications much more effective, and more manageable from the users' perspective.

Security

  • Is the mobile data sensitive in nature? Sensitive data must be protected from within the corporate network, during transmission, and on the device.

  • How can data be kept secure over public networks? Is Secure Sockets Layer (SSL) available for Internet content?

  • Is your data store on the device protected from casual prying and/or from serious hacking?

In addition to hosting your planned application, the device can provide access to other corporate resources. For this reason, access to the device and corporate network needs to be monitored.

  • How strong is your authentication method?

  • Where does user authentication take place: on the device, on the server, or in both locations?

  • Are viruses a concern? If so, where does virus scanning take place?

  • How about the device itself? What happens if a device is lost or stolen?

Battery Life

  • Is power consumption a concern?

  • Does wireless connectivity consume too much power?

  • Can devices be recharged during the day?

  • Is it possible to provide backup batteries for the device?

  • Will users abandon devices that they don't find convenient?

  • If surfing the Web for one hour will drain the battery of the device, is it worth it?

The battery life of the mobile device is a major concern. Mobile phones can often last several days on a single charge, while PDAs often only last a single day. Furthermore, applications that have frequent wireless communication require substantially more battery power than offline applications.

Other Services

In addition to the line-of-business application being developed, are there other services that mobile users will require? This may include access to corporate email, wireless Internet support, or instant messaging.


Application Architectures

In the wireless world, rarely does everything in your architecture perfectly suit your application needs. You will almost always have to make trade-offs between features, convenience for the end user, time to market, range of devices, ease of use, complexity, deployment options, and so on.

Figure 4.1 shows the spectrum of mobile application architectures covered in this chapter. But, note, though the diagram shows five application models, for the purpose of our discussion, the architectures have been divided into three categories: wireless Internet, smart client, and messaging. As we will see shortly, messaging is interesting because it can be used either on its own or in conjunction with the other application architectures. As we move from left to right on the diagram, the complexity of developing and deploying the application increases, as do the capabilities the application provides.

Click To expand
Figure 4.1: Application architecture spectrum.

Finding the right combination of complexity and capabilities for each application being deployed is important. In some cases the benefits of developing a smart client with messaging application will prove to be worth the added development complexity, while in other cases a wireless Internet solution will be more suitable. It is a good idea to enter the design and development phase with an open mind. The purpose of answering the questions in the previous section is to gain an understanding of the user and application requirements, so they can then be matched against the most suitable architecture. Having preconceived opinions about a particular solution may lead to a poor architecture decision.

You may also find that incremental gains in an application can have a large impact on the result. This is often the case when messaging functionality is added to an application. Push messaging can turn a user-driven application into an enterprise-driven application. Rather than requiring the user to request data periodically, important data can be pushed to the user as soon as it is available.

We are now going to take an introductory look at wireless Internet, smart client, and messaging application architectures. The purpose of this overview is to provide enough information for you to understand the high-level benefits of each architecture. Later in this book, detailed information is provided for each application type, as follows: Messaging applications are discussed in Chapter 5, "Mobile and Wireless Messaging"; smart client applications are detailed in Chapters 7 to 10, which make up Part II, "Building Smart Client Applications"; and wireless Internet applications are detailed in Chapters 11 to 15, which make up Part III, "Building Wireless Internet Applications".

Wireless Internet

In most regards, wireless Internet applications have the same architecture as wired Internet applications. The components of the system are essentially the same; the only difference is the way the information is transmitted to the end user. Figure 4.2 depicts the wireless Internet architecture. All of the business logic and enterprise data is stored on servers within the corporate firewall. On the client side is a mobile device that has an Internet browser. These browsers are often called microbrowsers due to their limited size and functionality. No other software is required on the client device. For this reason, wireless Internet applications are also called thin client applications. Each component of the wireless Internet architecture is described in turn in the following subsection.

Click To expand
Figure 4.2: Wireless Internet architecture.

Wireless Internet Architecture Components

The following are the key components of the wireless Internet architecture.

  • Microbrowser client. The browser uses a URL address to contact the specified wireless Web server. The response containing the markup language is then parsed by the browser, and the results are displayed to the application user. In this regard, wireless browsers are very similar to desktop Internet browsers. When the wireless network is not Internet Protocol (IP)-based, the base station contains a gateway that will translate the request and send it as Hypertext Transfer Protocol (HTTP) to the Web server.

    Unlike desktop Internet applications, wireless Internet applications may be deployed to devices running a variety of microbrowsers, supporting several markup languages, all having their own unique way of allowing users to navigate through the application. Most wireless devices come with a microbrowser preinstalled, although this is not always the case.

  • Wireless Web server. The wireless Web server listens to the incoming HTTP request and sends the appropriate response back to the client. This may require some additional steps to gather content from corporate data sources and format the data appropriately for the client in terms of markup language and form factor.

    To accommodate the large number of microbrowsers and markup languages used in wireless computing, the wireless Web server often contains wireless-specific frameworks that help with the formatting of the wireless content. In all other regards, this is identical to how an Internet Web server works.

  • Enterprise data source. The wireless Web server will access the enterprise data source using the preferred access mechanism. Features of your enterprise data source, such as failover, high-availability, and access methods depend on many factors, including how much use you predict your site will see, how critical the service will become, and the existence of alternate methods of accessing your enterprise data source.

Additional Information on Wireless Internet Applications

The entire request/response process happens while the user is connected to a wireless network. If a connection is not available, the user is typically unable to access any part of the application or data. There are exceptions to this with some browsers that provide offline Web content caching. In these cases, cached content may be available, although this content is usually not adequate to perform a complete transaction.

One of the most common protocols for wireless Internet applications is the Wireless Application Protocol (WAP). This protocol was developed and is maintained by the Open Mobile Alliance (formerly the WAP Forum), which is composed of a group of companies to promote wireless Internet development. WAP applications are most common on limited-display devices such as mobile phones.

The majority of consumer application services such as mMode from AT&T (United States) and i-mode from NTT DoCoMo (Japan) are based on the wireless Internet model. Providing access to these services is very straightforward since no software has to be deployed to the device. Essentially, anyone with a wireless device and microbrowser can access the applications provided.

Advantages of Wireless Internet Architectures

The following are the key advantages of wireless Internet (thin client) architecture:

  • Minimal to zero software deployment. This allows applications to be deployed without any additional client-side configuration. Updates to these applications are also straightforward since only the server has to be updated.

  • Extends Internet computing model. Many corporate applications are based on the Internet model. Wireless Internet is a natural extension to these applications.

  • Familiar user interface. Many users are familiar with a browser interface to their applications. Providing a similar interface on mobile devices allows them to be productive immediately; there is no learning curve.

  • Enterprise integration. If an existing Internet application is being extended, the application logic and enterprise integration layers may already be taken care of. This is a tremendous benefit, as enterprise integration often proves to be the most resource-intensive part of a mobile application.

  • Broad deployment. If multiple mobile devices are being targeted, wireless Internet application is often the easiest approach since the entire configuration and adaptation of content takes place on the server.

  • Fresh data. All of the data is assured to be latest version available in the corporate system. There is no worry about stale data.

  • Security. All of the data is stored on the server behind corporate firewalls. No data is stored on the client.

Disadvantages of Wireless Internet Architectures

Wireless Internet architectures have some disadvantages as well, namely:

  • Wireless connectivity. To access any data, all of which resides on the server, you need wireless connectivity. This can be problematic when users are moving between multiple locations. The exception is when browsers have content-caching capabilities. That said, even when caching is available, there is still a very limited amount of data and logic available to perform transactions.

  • Simple user interface. Many microbrowsers have limited capabilities for graphics or other "rich" components. Graphics are also often avoided to minimize the amount of data being downloaded over potentially slow wireless networks.

  • Application performance. For each request being transferred over a wireless network, performance can be an issue. This is due partially to network throughput and partially to network latency.

  • Application testing. Controlling, predicting, and testing the behavior of the application is difficult on the full range of microbrowsers. When emulation software is used to simulate devices, it is not always an accurate representation of the end-user experience since it is not executing over a wireless network.

  • Availability. If a server-side problem occurs, all users will be brought to a halt.

  • Security. Total control of the environment is not available in most cases, because a wireless gateway exists that may lead to security concerns. This problem is discussed in greater depth in Chapter 6, "Mobile and Wireless Security."

  • Cost. Wireless airtime fees can become an issue if the mobile user has to constantly be connected to use the application. On circuit-switched networks, where fees are charged based on the time connected, not the data transferred, charges are incurred even when a user is reading Web content or filling in a form.

Application Examples

Nearly any application can be presented as thin client. This section highlights those applications which are almost always best suited as thin client.

Securities Trading

Securities data is extremely volatile and it is imperative that users be assured that the data they are viewing is the most up-to-date and accurate. This data category is an ideal fit for wireless Internet applications. Users viewing stock quotes or portfolio summaries can be confident the information presented reflects the most up-to-date information available on the enterprise server.

Wireless Internet applications are also applicable to financial transactions. When users purchase or sell a security, they need to be updated immediately on the status of the transaction. With thin-client applications, the transaction information is immediately relayed to the appropriate server where the transaction will take place. If the transaction occurs immediately, the result can be transmitted back to the user in real time. If the transaction happens at a later point in time, the user can check the status throughout the day to get real-time updates.

Information Services

Information services comprise one of the leading uses of wireless Internet applications. Any user with a wireless device and a microbrowser can quickly and easily access a variety of informational sites to access many types of content, including news, weather, sports, airline schedules, traffic information, movie schedules, restaurant information.

Entertainment Information

Similar to information services, a variety of entertainment information is available from wireless Internet devices, including interactive games, horoscopes, puzzles, and instant messaging.

m-Commerce

The majority of m-commerce applications are targeted at the general consumer population. These applications are more successful when they are for goods that can be purchased and obtained immediately, such as downloadable games and mobile phone ringtones. Purchases that require pickup or delivery at a later date have not proven to be popular over mobile devices. This is because m-commerce makes the most sense when there is a sense of urgency.

m-Commerce applications, information services, and entertainment information are all targeted at consumer audiences, so supporting the largest possible number of devices, and in turn the largest number of potential customers, is essential.

Smart Client

Smart client applications are a powerful alternative to wireless Internet applications. Instead of using a microbrowser on the client, custom software is developed. This software typically contains a persistent data storage mechanism as well as business logic. This means that smart client applications can be executed at any time, even when a wireless connection is unavailable. Actually, smart client applications are essentially mobile and do not require wireless communication at all. Integration to the enterprise is typically provided via a synchronization process whereby the client application communicates data to back-end data sources through a synchronization server. This communication can occur over wireless or wired connections such as TCP/IP, serial, or USB. The smart client architecture is depicted in Figure 4.3.

Click To expand
Figure 4.3: Smart client architecture.

In order to deploy smart client applications, the client device has to have a mobile operating system that supports custom applications. This usually eliminates mobile phones from the smart client deployment options, leaving smart phones, PDAs, hand-held PCs, and laptops. The common approach for developing smart client applications is to use libraries native to the mobile operating system, although alternatives such as Java are also available. Let us look at each component of the smart client architecture, in turn in the next subsection.

Smart Client Architecture Components

The following are key components of the smart client architecture:

Smart Client

The smart client application is where client-side business logic is executed. The application itself is either a native executable or Java application that is deployed to the mobile device. To provide offline data access, mobile data store products are incorporated into the application. Many data store options are available, which are discussed in depth in Chapter 9, "Persistent Data on the Client." To communicate to the enterprise systems, a synchronization or messaging layer is also part of the smart client application.

Synchronization Server

Data is sent from the client application to the synchronization server. This can occur over a wireless or wired connection to the server. From there it is then communicated to the enterprise data sources. The synchronization server, with its associated logic, is responsible for ensuring that the minimal amount of data is transferred and that any conflicts are detected and resolved. It also provides the communication layer to enterprise systems. Synchronization is discussed in depth in Chapter 10, "Enterprise Integration through Synchronization."

Enterprise Data Source

The synchronization server will access the enterprise data source using the preferred access mechanism. The access to the enterprise source may occur during the synchronization process if it is imperative for the smart client to receive feedback from the synchronization. This is a simple process and requires that the client connection to the synchronization server remain active until the enterprise is finished processing the data.

It is also possible to synchronize data to a corporate data buffer and return pending status for any operations that need to be completed. The enterprise system can poll the data buffer at its convenience for information to process. On the next smart client synchronization, the status of all pending operations are downloaded. This provides for a much shorter connection time to the server, and a greater number of clients can connect, but at the cost of end-user convenience.

Additional Information on Smart Client Applications

One of the most common concerns about smart client applications is software deployment. Manufacturers of products that specialize in mobile device management have addressed this in the enterprise space. These software packages allow a central server to manage all aspects of application delivery and maintenance. For the consumer market, over-the-air (OTA) provisioning is a key enabler of smart client computing. OTA provisioning enables consumers to purchase and install applications directly over a wireless connection; no companion PC is required. Many wireless operators and device manufacturers are setting up digital malls that users can browse to find a variety of applications. When they find an application they like, they download and install it on the device. A nominal charge [usually between $1 and $5 (U.S.)] will be added to the user's airtime bill.

These malls are very attractive for developers who require a distribution channel for their applications. The most common examples are games, but utilities, music, and other software applications all are benefiting from this type of distribution.

Note

Smart client applications are sometimes called terminal-based since the application runs locally on the device. Other names for smart client applications include rich client and fat client.

Advantages of Smart Client Applications

The following are key advantages of smart client applications:

  • Always-available data. When no wireless coverage is available, the user is still able to access and modify enterprise data to be synchronized later. This overcomes one of the most significant limitations experienced with wireless Internet applications.

  • Rich user interface. Sophisticated displays with graphics and charts can be developed. This type of user interface is more similar to what users expect based on desktop experiences. In the case of Pocket PC devices, a subset of the Windows functionality is available, allowing for rich graphical components.

  • Performance. How the interface is "served up" is determined by processor speed and data access, which are known qualities. No performance is lost in having to continually communicate over wireless networks to access data.

  • Distributed computing. The execution of business logic and data processing occurs on the client devices, reducing the load on the server machines. This means organizations have to purchase less server-side hardware.

  • Security. Implementing a solid end-to-end security scheme is easier than with wireless Internet architectures, as you have the ability to control data on both ends of communication. There is no dependence on third-party systems such as WAP gateways.

  • Cost. Wireless airtime fees can be reduced or even eliminated with smart client applications. Only the data pertaining to the specific mobile user has to be transferred between the smart client and the synchronization server. This results in a minimal amount of data being transferred, thereby lowering wireless airtime charges. The synchronization can also occur over wired networks so that wireless fees can be avoided altogether.

Disadvantages of Smart Client Applications

The disadvantages of smart client architectures are:

  • Enterprise integration. Because smart client application can provide advanced functionality on the client device, many organizations end up enhancing the client application beyond the original design. While the client-side component may not be complex to develop, the enterprise integration component will often take more time and resources than expected. (In a way, this is both an advantage and a disadvantage since the result is a more capable client-side application.)

  • Application deployment. Remote deployment and management of the smart client applications may seem a trivial or end-user-driven process, but it can become an IT burden when there are a lot of remote users. Fortunately, software products are available to help with this task; they are outlined in Chapter 16, "Mobile Information Management."

  • Mobile viruses. Introducing a mobile operating system opens the doors to viruses. This can be addressed by software in the application deployment phase; never-theless, it does add another item of concern.

  • Development complexity. Programming in the native language of the mobile device requires learning a new client-side API. If you are developing for multiple mobile devices, with different operating systems, this can turn into a significant challenge. Java and other cross-platform tools are on the market to help address this issue. This is discussed in more depth in Chapter 8, "Smart Client Development."

  • Multiple development cycles. When multiple devices and mobile operating systems are targeted, separate development and testing phases may be required for each device involved. This can be a drain on resources and result in drawn-out development cycles if not planned for ahead of time.

Application Examples

In general, a smart client architecture deserves strong consideration for any application that requires offline data access. Here are a few example applications that are particularly well suited for a smart client architecture:

Sales Force Automation (SFA)

One of the most important assets for a salesforce is current information. The difference between making a sale or not often depends on having immediate access to information while the salesperson is meeting with the customer. The best way to ensure that the sales staff has this information is to deploy a Sales Force Automation (SFA) application with persistent data storage.

SFA applications give sales representative immediate access to important sales information, such as the customer's contact information and order history, product catalogues, price lists, and inventory lists. With this information on hand, the sales rep can put together quotes with delivery dates on the spot. Once the order is placed locally on the device, the rep relays the order to the back office through synchronization.

Field Force Automation (FFA)

Field service workers can benefit from persistent data access in many ways. By empowering service workers with the information they need, they can improve all aspects of their jobs, resulting in higher productivity and increased customer satisfaction.

The benefits start with order entry and dispatching. Orders can be taken at a call center, entered into a central database, and synchronized through to the mobile worker. This eliminates paperwork and streamlines the dispatching process. Once the service worker is at the job site, he or she will have all the related job information on hand. This includes a machine's service history, repair checklists, troubleshooting information, schematic diagrams, and parts inventory levels. Having this information on hand decreases delays that occur when the required information is not readily available.

Once the job is complete, the field service worker can complete the transaction by completing the job report. This involves entering the appropriate work order data, such as placing an order for parts and scheduling a follow-up visit. Once the data is entered into the remote application, it can be synchronized to the enterprise system, reducing administrative costs.

The overall benefit of providing mobile workers with always-available data is improved customer satisfaction, with the ultimate result being increased customer loyalty.

Healthcare Applications

Medical professionals, such as doctors and nurses, can realize many benefits from smart client applications, in particular, the availability of up-to-date, accurate, patient information at their fingertips. With this information, medical practitioners can diagnose conditions more effectively and accurately.

A prime example is prescription writing. In the United States, close to 3 billion prescriptions are written annually, for some 100,000 different prescription drugs, from a variety of pharmaceutical companies, and over a dozen insurance carriers. Managing this data is an arduous task. By automating this process with a smart client application, doctors can deliver accurate, easy-to-read prescriptions that meet the requirements of the patient's insurance plan. This is just one example where persistent data within a mobile application increases productivity and reduces errors. Many other medical processes can be automated in a similar fashion.

Data Collection Applications

An entire breed of applications has been designed for data capture. These applications allow businesses to streamline existing data capture processes. Many of the most recent devices are very well suited for this task. The rich user interfaces and add-on peripherals increase their usability.

For inventory management applications, having a built-in barcode scanner allows for easy capture of merchandise, asset, and document information. This information is recorded without data entry errors and can be synchronized directly into back-end systems. Digital camera add-ons allow the user to take pictures and store them on the device. They can then manipulate the pictures before synchronization. Insurance claims agents can take advantage of this functionality. They can take a picture of an item and make quick edits to the image to illustrate where the damage occurred. This picture can then be attached to the claim as it is synchronized into the central database.

These are just two examples where smart client applications with persistent data storage increase productivity while reducing errors and administrative costs. Other vertical markets that can achieve the same benefits include the financial, retail, transportation, and healthcare verticals.

Mobile Productivity Applications

For professional services staff and other mobile professionals, several applications are available to increase productivity. In the professional services industry, workers' success is often based on billable hours. By providing an application where they can capture the number of hours logged on each task, corporations will have more accurate records of how time was spent. This often results in more billable hours since they can be entered at the job site, reducing the likelihood that they will be forgotten.

Productivity gains can also be accomplished by providing mobile access to other enterprise business applications such as SAP, PeopleSoft, and Siebel. This type of mobile application allows for more accurate data capture and reduced data entry costs.

Messaging

Messaging applications can take many forms, ranging from email to alerts and notifications to application-to-application messaging. In some cases messaging is used as an enhancement to an existing mobile application; in other situations, it is itself an application architecture.

Numerous messaging technologies are available, so it follows that there are many uses for messaging. However, for our purposes here, three categories of mobile messaging are of interest to us. The following is a brief description of each:

  • User-to-user messaging. Messages can be sent from one user to another using a variety of mechanisms, including email, paging, and wireless text messaging such as the Short Message Service (SMS) or Instant Messaging (IM). Richer messages that include graphics and formatted text can be sent using the Enhanced Message Service (EMS), while multimedia content can be sent using the Multimedia Message Service (MMS). These forms of messaging can also be generated by server-side processes as a means of information dispersal.

  • Notifications and alerts. Messages that are urgent in nature can be pushed to mobile users on their wireless devices. This allows corporations to ensure that information is received in a timely fashion. These messages can contain a URL link to a wireless Internet site where the user can obtain additional information. These types of messages are called actionable alerts, since the recipient performs an action based on the message content. The two leading technologies for notifications and alerts are Handheld Device Markup Language (HDML) alerts and WAP Push.

  • Application-to-application messaging. In many cases, user interaction is not required for the message to be successful. Enterprises can communicate data directly from an enterprise server to a client application without user interaction. This can be useful to enhance smart client applications with server-initiated synchronization.

The first two types of messaging in this list do not require additional software to be deployed to the client device. For user-to-user messaging, the client software is typically provided by the device manufacturer; and for notifications and alerts, this capability is part of the microbrowser on the device. From the users' perspective, when they receive these types of messages, they view the information and react accordingly. This type of messaging is relatively straightforward to implement.

Application-to-application messaging is more involved. It requires software to be deployed on a device that understands the communication stream between the client and the server, as well as how to operate over a wireless or wired network. In a way, an application-to-application messaging application falls under the smart client category since a software application is deployed to the device that can be used when disconnected from a wireless network. Additionally, the client application typically contains a message queue that can store information. Figure 4.4 illustrates the application-to-application messaging architecture. Each component of the application-to-application messaging architecture is described in the next subsection.

Click To expand
Figure 4.4: Application-to-application messaging architecture.

Application-to-Application Messaging Architecture Components

Here are the main components of an application-to-application messaging system:

  • Messaging client. The client application contains message queues as well as clientside logic. The message queues can store incoming and outgoing transactions for future access. For example, if an application attempts to send data to the server when a connection is unavailable, it can be stored in an outgoing queue and be sent automatically when the user establishes a connection to the server. This technique is called store-and-forward messaging. The messaging client can be used either on its own or in conjunction with other smart client features such as a persistent data store. The application itself can usually be programmed in languages specific to the operating system or in Java.

  • Messaging server. The server component is the part of the system that communicates with the messaging client, as well as the enterprise systems. The industry name for messaging servers is Message Oriented Middleware (MOM). Many of these systems are built on the Java Message Service (JMS). JMS provides a reliable and scalable base platform with store-and-forward capabilities. This form of messaging is useful for m-business applications because the sender of the message does not have to wait for the recipient to receive the information, allowing him or her to continue working while the message is routed and acted upon.

  • Enterprise data source. The messaging server can interact with a variety of backend systems, including databases, business applications, and other messaging systems. This integration can use the preferred access technique for the enterprise system. The asynchronous nature of messaging systems is well suited for systems that require complex enterprise integration since the user does not have to wait for a response.

Additional Information on Messaging Applications

The store-and-forward capability is not unique to application-to-application messaging. The server components of both user-to-user messaging and notifications and alerts can implement store-and-forward as well. This feature is especially important when communicating over a wireless network as it helps address the issues of intermittent connectivity, dropped connections, and coverage.

Many types of applications take advantage of messaging technology. For corporate applications, messaging is often used in conjunction with other technologies to provide access to enterprise data. Application-to-application messaging excels in this arena, often as an enhancement to smart client applications, whereas, HDML alerts and WAP Push are very valuable for enhancing thin client applications. SMS can be a valuable service for many businesses, but it is not typically integrated into corporate applications. Over 80 percent of all SMS messages are sent from consumer applications. Over time, more business may adopt text messaging, but the initial market focus is clearly on the consumer. After we examine the advantages and disadvantages of messaging, we will take a look at specific consumer and corporate areas where messaging technology is beneficial.

Advantages of Messaging

Here are the advantages of messaging:

  • Push capabilities. Wireless Internet and smart client applications can be enhanced with push messaging functionality. For wireless Internet applications, the message may contain a URL where the user can go to get more information. For smart client applications the push message could notify the user that he or she should synchronize the client data; or in some cases, the message may actually be able to initiate the synchronization automatically from the server.

  • Store-and-forward. When working over wireless networks, an important capability is for messages to be stored in a queue and delivered when connectivity is available . On the client, it means users can work as if a network connection is available, since the information will be forwarded to the server at a later time. On the server, it is beneficial because messages will be sent to users when they connect to the network, offering a form of guaranteed message delivery.

  • Personalized data delivery. The leading messaging products give end users the ability to register their messaging-enabled devices and schedule the delivery of messages to a particular device. For example, the schedule might dictate that between 9:00 A.M. to 5:00 P.M., a message should be delivered to an email account, but between 5:00 P.M. and 11:00 P.M., it should be sent as an SMS text message. In this way, users can receive messages at the location that is most convenient for them.

  • Wired and wireless communication. Application-to-application messaging can operate over both wired and wireless networks. This gives companies the option of providing wireless access to the application users. It also allows application users to connect through a wired connection when wireless coverage is not available. User-to-user messaging and notifications and alerts typically require wireless networks for communication.

Disadvantages of Messaging

Messaging is an optional component for many applications, so typically it is incorporated into applications only where there is a clear benefit. For this reason, there are not many disadvantages to using messaging, other than when it is simply not required.

However, messaging does add complexity to the development of the mobile application. For application-to-application messaging, development is required on both the client and the server. For text messaging and notifications and alerts, most, if not all, of the development occurs only on the server. In either case, incorporating messaging functionality into an application does require additional development and testing resources.

Sample Consumer Applications

Messaging is extremely popular in consumer applications. Whether using SMS, IM, email, HDML notifications, or WAP Push, consumer applications are usually focused on communication, entertainment, or information dispersal. In all cases, the messages are typically text-based, although this will change as more advanced messaging services grow in popularity.

Communication

Messaging technology is often used for person-to-person communication from something as simple as saying hello to asking a question, arranging a meeting, and to conduct other general interactions. It works well when making a voice call is inconvenient, inappropriate, or too expensive, and when the user wants immediate delivery of messages. SMS is currently the most common mobile messaging technology used for communication, although this may change as IM adoption grows, which will definitely be the case when IM vendors allow for interservice communication between different wireless systems and wired Internet users.

Entertainment

Many entertainment services use messaging technology. Some of the most common include viewing sports scores, reading horoscopes, and exchanging ringtones with other users. SMS can be used for this service, but push technologies such as HDML notifications and WAP Push are better suited. These technologies will include a URL that the user can visit to get more information, usually resulting in higher wireless usage. This benefits both the application provider and the wireless carrier.

Information Dispersal

Perhaps the most useful implementation of messaging in the consumer space is information dispersal. Applications that alert users of, for example, flight information, stock information, and weather forecasts, to name just three, can be very helpful to the mobile user. Essentially, any information that can be incorporated into a message, be it SMS or otherwise, can be dispersed using messaging technology. For urgent messages, push technologies are the best choice, while for general information, a pull-based solution will prove to be less intrusive to the user.

One concern for many people regarding push messaging is the potential of receiving unwanted messages, similar to spam on email. Mobile users are concerned that push messaging will continually interrupt them throughout the day. In addition, push clients have limits on the size and number of messages that can be stored on the device. For example, the Openwave client allows only 1500 bytes to be stored on the device, with each message containing a maximum of 160 bytes. This allows for as few as nine messages before the client reaches capacity.

Already applications are out there that will push information such as advertisements and promotions to mobile users based upon their location. While this is a great service if you are a subscriber, it will quickly become annoying if you are not interested in receiving this kind of message.

Sample Corporate Applications

Corporate applications can reap tremendous benefits by incorporating messaging technology. Whereas consumer applications benefit largely from the communication aspect, corporate applications gain by making enterprise data more readily available. Text-messaging technologies such as SMS and IM do not currently play a large role in corporate applications; application-to-application messaging and some of the push technologies are more conducive to the requirements of enterprise applications.

System Integration

On the server, messaging technology can provide a way to integrate disparate systems. In most organizations, enterprise information is stored in multiple sources, most often with different mechanisms for accessing the data. Messaging systems can provide access to these sources of enterprise data and relay the information to mobile users. The goal is to implement a solution that will require very little, if any, change to the existing systems, while providing a common layer for accessing enterprise data. Systems based on JMS will help meet this goal, at the same time providing integration with other J2EE technologies such as EJBs and JDBC.

Information Exchange

Messaging systems are very effective for exchanging information between mobile and nonmobile applications alike. New mobile applications can be based exclusively on messaging technology. Applications to access corporate email, dispatch work orders, and update inventory levels or pricing information and customer relationship management (CRM) applications are commonplace in the mobile workforce. All of these can be built using messaging as the transport of data between the mobile user and the enterprise system.

In the case of job dispatch, messaging technology is useful both for scheduling new jobs and for retrieving the status of existing ones. The field agent can be notified of an upcoming work order by a text message such as SMS or by a more advanced mechanism using application-to-application messaging, which could add the order directly into a calendar or custom application. Once the service agent has completed the task, he or she can send a message back to the office to keep staff there informed of the current status. This message could also contain notes or other information to keep the customer up to date on the processing of the order.

Application Enhancement

In addition to creating new mobile applications, messaging technology is also useful to enhance existing applications. Many smart client applications can benefit by adding new features such as server-initiated synchronization or store-and-forward messaging, while thin client applications can benefit from HDML or WAP alerts. In most cases, it is possible to add new messaging functionality without having to make major changes to the existing application. In this way, messaging technology can be incorporated into nearly all the smart client and thin client applications that were discussed earlier in this chapter.

Event Propagation

When events occur within corporations that require the attention of some form of service staff (whether it involves repairing a malfunctioning system, fixing a database conflict, or replenishing inventory levels) messaging technology is a great way to notify workers that their attention is required. When a problem arises, the messaging server can take the request, and notify an individual user or a group of users using a variety of technologies. In this scenario, sending out a message to a pager may be the ideal choice for one worker, while an SMS message might be better for another. At the same time, the system administrator may want to receive an email message each time a problem arises to monitor response times. Messaging systems are well suited to handle these types of scenarios.


Other Architecture Selection Considerations

It would be short-sighted to base your device and network selections on a single application. The overall success of mobility in an organization is ultimately based on whether the application users are satisfied with many factors of the solution, even if some of them are totally unrelated to the line-of-business application being deployed.

The best example of this is access to email. Once wireless devices are introduced to an organization, the first request is often whether the selected device will allow for access to corporate email. As the application architect, you may have decided on implementing a smart client solution using a Pocket PC device with wireless access provided by a wireless PCMCIA card. Then you discover that another group has just made the decision that wireless email is a requirement for any solution that is deployed, and in order to get approval for the business application you have designed, a device that is more conducive to email has to be selected. For a variety of reasons, RIM BlackBerry devices are great for accessing email. This is now the device that has to be used, even though there are many good corporate email solutions available for the Pocket PC platform. This decision, made without consideration of the original application has limited the flexibility of the solution you can provide. You might think that this is an isolated case, and that it is not relevant to your situation, but it occurs more often than you might expect.

The next most common request is for Internet access. Even if the solution being deployed uses a smart client architecture, the application users will inevitably want to access Internet content such as stock quotes, weather forecasts, or personal email. So now there is a requirement to select a device that has a microbrowser for wireless Internet access. In most cases this will not be too much of an inconvenience since nearly all wireless devices provide some form of Internet access. This is true of all device classifications (see Chapter 2, "Mobile Devices").

A similar situation is when a company decides that it is going to take advantage of devices already in use. These devices may have been supplied by the company for other applications or they may be devices that employees have purchased on their own and expensed to the company. In either case, you are usually looking at supporting a wide range of devices ranging from WAP phones to high-end PDAs. If you are mandated with developing an application that can take advantage of these devices, then you once again are limited in the architecture that you can choose. In this case, the outcome is usually that a wireless Internet solution is the only option since developing a smart client application for multiple device types running multiple operating systems may go beyond the original scope of the project.

Of course, choosing a device is not the only time when miscommunication between departments causes setbacks or even failure. Talking to the network administrators before deciding which method to use to get past the firewall is always good advice.

There are, of course, exceptions to these scenarios. For instance, specialty shops that cater to a certain type of device can usually be guaranteed to provide certain capabilities. Furthermore, if your company has recently mandated a certain device for use in all or certain circumstances, then provided you are quick to market, you can be reasonably assured of your target devices. And, most likely, your company already has in place at least a few methods that enable external devices to access corporate resources, of which you can take advantage.

The overall message to application architects and developers is to expect the unexpected, as there are many unpredictable factors that will impact the application architecture, device, and network selections. It is a good idea to plan ahead so you do not waste resources on decisions that are out of your hands. In general, plan to have email and wireless Internet access as a component of any solution you are deploying, even if they are not part of the specific application you are developing.


Summary

Developing and deploying a solution that provides mobile access to enterprise data sources is challenging. In order to create a successful solution, many factors have to be taken into consideration. These include wireless connectivity, device type, target user base, enterprise integration, power consumption, and security. Three mobile architectures can be used to address these issues: wireless Internet, smart client, and messaging. Each of these systems has advantages and disadvantages that have to be weighed when making any decision. In many cases, the idea solution will include a combination of two, or possibly all three, architectures.

Part II of this book is dedicated to smart client application development, and Part III to thin client development. But before we move on to those sections, in the next chapter we will take a closer look at mobile wireless messaging technologies.


Helpful Links

Web links relevant to the architectures discussed in this chapter are provided in their respective chapters throughout the book. Here you will find links to common mobile development and information Web sites. These sites are a good source for getting upto-the minute information on the mobile and wireless industry.

Cellular Telecommunications and Internet Association (CTIA) | www.wow-com.com
FierceWireless daily newsletter | www.fiercewireless.com
m-Business Daily | www.mbizcentral.com
MobileInfo Portal | www.mobileinfo.com
ThinkMobile Portal | www.thinkmobile.com
Unstrung | www.unstrung.com
Wireless Business and Technology Magazine | www.sys-con.com/wireless
Wireless Developer Network | www.wirelessdevnet.com
Wireless Internet Daily newsletter | www.wirelessinternetdaily.net
Wireless Week | www.wirelessweek.com


Chapter 5: Mobile and Wireless Messaging

Overview

The term messaging can mean many things. To some people, it may mean email; to others, text messaging; to others still, smart application-to-application messaging. Of course, all of these, as well as others, are valid messaging formats. As discussed in the previous chapter, messaging technology can be used by itself or in conjunction with smart client or thin client applications, but however it is used, messaging technology will be key to implementing a successful mobile solution.

In this chapter, we take a look at the key messaging technologies currently available. We will start with common messaging systems such as email and paging, then move on to SMS, EMS, and MMS, and finish with push and application-to-application messaging. After gaining an understanding of the various messaging systems, we will cover the messaging value chain, ranging from device manufacturers to messaging middleware providers.

Note

Messaging technology relates equally well to both smart client and thin client applications, therefore it is included in the first part of the book rather than in the parts dedicated to specific application architectures. This is intentional, as messaging technology is a great way to tie together both application types.

In Chapter 4, "Mobile Application Architectures" we answered the question why we would want to use messaging for our applications. Here we will look at how this can be accomplished.