Table of Contents

Team LiB
Next Section
Centrex or PBX: The Impact of IP
Centrex or PBX: The Impact of IP
by John R. Abrahams and Mauro Lollo ISBN:158053497X
Artech House © 2003 (161 pages)

This text explains the benefits and shortcomings of Internet Protocol-based Centrex services, for organizations of all sizes and types. It also enables professionals to more accurately estimate the time and resources needed to implement IP telephony.
Table of Contents Back Cover
Table of Contents
 | Centrex or PBX—The Impact of IP
 | Preface
 | Chapter 1 | - | Introduction to Centrex
 | Chapter 2 | - | Internet Protocol Centrex
 | Chapter 3 | - | IP-Centrex Systems and Applications
 | Chapter 4 | - | IP-PBX Systems and Applications
 | Chapter 5 | - | IP-Centrex—Prospects and Pilot Trials
 | Chapter 6 | - | Evaluating IP-Centrex
 | Chapter 7 | - | Implementing and Managing IP-Centrex
 | Chapter 8 | - | Marketing and Selling IP-Centrex
 | Appendix A | - | Useful Addresses
 | Appendix B | - | Centrex Versus PBX
 | Appendix C | - | Centrex Glossary
 | Index
 | List of Figures
 | List of Tables
Team LiB
Next Section


Back Cover

Team LiB
Centrex or PBX: The Impact of IP
Centrex or PBX: The Impact of IP
by John R. Abrahams and Mauro Lollo ISBN:158053497X
Artech House © 2003 (161 pages)

This text explains the benefits and shortcomings of Internet Protocol-based Centrex services, for organizations of all sizes and types. It also enables professionals to more accurately estimate the time and resources needed to implement IP telephony.
Table of Contents Back Cover
Back Cover

Centrex or PBX: The Impact of IP is essential reading for those who are responsible for managing, designing, or upgrading data networks to carry IP telephony. This practical reference enables professionals to more accurately estimate the time and resources needed to implement IP telephony in their organizations. The book describes the IP-Centrex option of having the telephone company take responsibility for service delivery and offers the kind of information service providers need to improve marketing and sales campaigns for IP-Centrex services.

This unique resource helps professionals present their company’s telecom capabilities, and offers a better understanding of the pluses and minuses of competitive sales presentations. It includes summary descriptions of 14 IP telephony systems on the world market, while clearly identifying the advantages and disadvantages of IP-Centrex. There are detailed and financial analyses of three realistic case studies, and clear descriptions of how Centrex is used in various organizations.

About the Authors

John R. Abrahams is a senior consultant with UNIS LUMIN, Inc. in Toronto, Canada. He received his M.Sc. in computer systems from Trinity College, Dublin, Ireland. He is also the author of Manager’s Guide to Centrex (Artech House, 1988).

Mauro Lollo is the vice president and chief technology officer at UNIS LUMIN, Inc. in Toronto, Canada. In addition to cofounding UNIS LUMIN, Inc., he provides consulting services for major clients and is a sought-after speaker on the topics of telecom and computing technology.

Team LiB


Centrex or PBX-The Impact of IP

John R. Abrahams
Mauro Lollo

Artech House
http://www.artechhouse.com

Library of Congress Cataloging-in-Publication Data
A catalog for this book is available from the U.S. Library of Congress.

British Library Cataloguing in Publication Data
Abrahams, John R.
Centrex or PBX: the impact of 1P.-(Artech House telecommunications library)
1. Centrex telephone service 2. Telephone-Private branch exchanges 3. Internet telephone
I. Title II. Lollo, Mauro
621.3'85

1-58053-497-X

Cover design by Christina Stone

*SUCCESSION, CALLPILOT, SYMPOSIUM, E-MOBILITY, the NORTEL NETWORKS Logo, NORTEL, and DMS are trademarks of Nortel Networks.

Copyright © 2003 ARTECH HOUSE, INC.

685 Canton Street
Norwood, MA 02062

All rights reserved. Printed and bound in the United States of America. No part of this book may be reproduced or utilized in any form or by any means, electronic or mechanical, including photocopying, recording, or by any information storage and retrieval system, without permission in writing from the publisher.

All terms mentioned in this book that are known to be trademarks or service marks have been appropriately capitalized. Artech House cannot attest to the accuracy of this information. Use of a term in this book should not be regarded as affecting the validity of any trademark or service mark.

International Standard Book Number: 1-58053-497-X
A Library of Congress Catalog Card Number is available from the U.S. Library of Congress.

10 9 8 7 6 5 4 3 2 1

To Alex, Tara, lessee, Brennan, and Savannah,
representing the next generation

About the Authors

John R. Abrahams is the senior consultant with UNIS LUMIN, Inc. in Toronto, Canada. He received his M.Sc. in computer systems from Trinity College, Dublin, Ireland, and a B.Sc. in electronic engineering from Imperial College, London. He is a professor emeritus in telecom management at Sheridan College, in Oakville, Ontario, and was also the author of Managers' Guide to Centrex (Artech House, 1988).

Mauro Lollo is the cofounder and chief technology officer at UNIS LUMIN, Inc. in Toronto, Canada. With more than 15 years of experience in designing and implementing leading edge technology solutions for corporate and government clients, along with accreditations including CCIE, he is a sought-after speaker at networking technology conferences.


Preface

This book explains the potential benefits and shortcomings of Internet Protocol-based Centrex services, for organizations of all sizes and types. Our emphasis is on what might be seen with IP-Centrex over the next few years, rather than what has been happening with digital Centrex over the past 15 years.

While the "Centrex versus PBX" issue is not new, the introduction of IP Telephony raises this question again, since all organizations should reconsider their Centrex or PBX deployment, with the prospect of migrating voice and video services onto their data networks. The case for outsourcing of telecom services is extensively developed, with attention to application, financial and management considerations.

This text is modestly technical and only some knowledge of telecom terminology is required, rather than a deep understanding of networking technology. Our material is intended for a wide audience, including IS/IT and telecom managers and analysts. We hope that readers in all three parts of the telecommunications market, namely users, service providers and system suppliers, will benefit from the information that we have gathered, as our industry passes through difficult times.

The Web site addresses for organizations that are mentioned in this text are listed in Appendix A. A glossary of abbreviations and technical terms is included in Appendix C.

Acknowledgments

We could only write this book with the encouragement, guidance, and information provided by numerous colleagues in the telecommunications industry. In particular, we are grateful to the following people:

  • Chris Vuillaume of Alcatel

  • Ian Angus, Lis Angus, and John Riddell of Angus Telemanagement

  • Andrew Lenardon of AT&T Canada

  • Bill Edwards of Avaya Communications

  • Tracy St John and Andy Zankowicz of Bell Canada

  • Fran Blackburn, Tom Van Ham, and Rod Weir of Cisco Systems

  • David Hollingsworth of DRH Associates

  • Russ Drumheller of Faulkner Information Services

  • Richard Comtois and Marcel Carignan of InfoTelecom

  • Peter Settles of Lucent Technologies

  • Carole Daoust of Mite1 Networks

  • Kathy Jahns of the National Centrex Users Group

  • Susan Pulfer and John Egli of Nortel Networks

  • Bob Pachal of Pacomm Consulting

  • Ken Dumont of Siemens Canada

  • David Cooper and Morgan Jakobsen of Unis Lumin

  • Debbie Stewart of the University of Toronto

  • Bruce Wildish of Mississauga, for converting rough sketches to detailed diagrams

  • Paul Abrahams, who improved the text while manipulating the features of word processing.


Chapter 1: Introduction to Centrex

Background

Centrex service was launched in the early 1960s and thus has a 40-year history in the telecommunications industry. In that time Centrex has progressed from the financial district of lower Manhattan to being a good source of revenue for some 20 telephone companies (telcos) in various countries around the world.

Our best estimate is that 20 million Centrex lines are in service, with 15 million of these in the United States, over 2 million in Canada, and more than 1 million lines in Britain. Centrex services have also been available for several years in Australia, where Telstra provides perhaps a half million lines in the major cities, as well as in Belgium, Ireland, the Netherlands, and Switzerland.

The sales of Centrex equipment by the telecom manufacturers to the telcos has fallen off, in recent years, as capital expenditure budgets have been cut back heavily. About 1.6 million new Centrex lines were installed in the United States in the year 2000, but these shipments fell to 1.1 million lines in 2001.

On a percentage basis, Centrex services provide approximately 5% of all the business telephone lines in the world, with the highest market shares being 20% in Canada and 15% in the United States. Widespread acceptance of Centrex outside North America has been inhibited by the cost of providing a local loop for each telephone from the serving central office (CO). Centrex and standard business lines are probably double counted, since some CO lines that support key telephone systems (KTS) are actually Centrex lines, because of the relatively low tariffs. In North America up to one-tenth of all Centrex lines are provided by major telcos to resellers on a wholesale basis.

For marketing purposes, a variety of brand names are used to identify Centrex services by different telcos. For example, some parts of SBC Communications use the name Centron; Qwest Communications delivers integrated voice, video, image, and data services as Centrex PRIME in 13 states; and Verizon-NYNEX still calls the service Intellipath. BT labels its digital Centrex as FeatureNet, and Telstra, in Australia, rents the same service with the name of CustomNet.

Early Centrex services were analog in nature, and analog phones are still supported by all the service providers. Most North American telcos classify Basic Rate Integrated Services Digital Network (ISDN) telephone service as Centrex, at least from the tariff viewpoint, and some deliver digital Centrex by using ISDN technology. Most of the proprietary digital Centrex phones and data units predate the availability of ISDN.

In many cases the link between the serving CO and the customer's premises has been with multipair copper cables, requiring one pair per station for digital Centrex. Some installations have been deployed through a concentrator in the customer's premises-a good example being the Cable & Wireless (C&W) Centrex service in London-with an optical fiber connection to the serving CO. This concentrator, or remote module, remains under the control of the CO, meaning that if the main switch or its trunk line fails, all in-progress calls stay on but no new connections can be set up while the CO is not available. Such remote modules may serve a single customer (with the problem of finding equipment room space) or multiple customers (as in a shopping center). These situations are illustrated in Figure 1.1.

Click To expand
Figure 1.1: Centrex service through remote CO modules.


Rationale for Centrex

The relative advantages and disadvantages of the new versions of Centrex, as compared with a private branch exchange (PBX) or KTS for business telephone services, are discussed, together with some comparative financial analyses, in Chapter 6. The 40-year-old debate is also continued, in a lively style, in the article, "A New Look at an Old Debate" in Appendix B. The strategic arguments are summarized in Table 1.1.

Table 1.1: Centrex Positives and Negatives
CENTREX OFFERS | CENTREX MAY RESULT IN
Personnel savings | Loss of control
Network cost savings | Possible cost increase over time
Less management effort | Delays in making changes
Ease of use | Limited systems integration
Space and power savings | Hybrid Centrex-PBX networks
Automatic upgrades |

When we talk to telecom managers about choosing Centrex service or PBX systems, their reasons are remarkably balanced, as shown in Figure B. 1. in Appendix B. The one absolute advantage of conventional Centrex, over the in-house PBX option, they see as saving of space. This is particularly important for large organizations that rent expensive floors in downtown office towers. Good second reasons for choosing Centrex are the savings on personnel-both system administrators and console operators-and the expected relief from problems of technological obsolescence. For 40 years Centrex has been steadily, although not spectacularly, sold on the basis of the two Ss: simplicity and space. These are still the reasons given by small business owners as the rationale for renting single-line Centrex packages.


Virtual PBX Service

We generally consider Centrex as providing a "virtual PBX" service, with multiple customers and many sites being served by the software that resides in the one CO system, as shown in the upper part of Figure 1.2. A standard characteristic of Centrex is that all its stations have direct inward dialing (DID) access, usually based on seven-digit numbers. Users can employ abbreviated dialing (e.g., four digits) between Centrex-based stations within a local calling area. These features minimize the need for operator consoles within a Centrex system, although some type of operator support, for the occasional caller who needs assistance, is still usually required.

Click To expand
Figure 1.2: PBX replacement and KTS support.

A business line package with a few popular features, which is available from carriers in some countries, clearly does not qualify as Centrex service when measured against the virtual PBX definition.


Integration with On-Premise Switches

Many Centrex lines are rented, instead of regular business lines, to link KTSs to the Public Switched Telephone Network (PSTN), as illustrated in Figure 1.2. While the features that are available with Centrex may complement the capabilities of the KTS (which are typically used in offices with fewer than 30 lines), the common motivation for this application is the attractive rental rates, because of discounts that are available with Centrex, taking into account the number of lines attached to one CO and the duration of the contract. An organization with more than 100 lines served by one CO and a 3-year contract can obtain an almost 40% discount from the monthly, single-line tariff. These types of contracts are not generally available with conventional, non-Centrex, business lines (which are rented on a month-to-month basis). Centrex lines that are provisioned with the ground-start signaling compatible with PBX systems are also available from some telcos as an alternative to analog trunks.

The attractive margin of up to 50% offered between the short-term, single-line tariffs and those for a 1,000-line and 5-year package have given rise to a significant Centrex reseller business. In this market a competitive local exchange carrier (CLEC) leases a large number of Centrex lines on a wholesale basis and rents these to small businesses and organizations (such as a school board or a bank) with a number of offices in a given area. Two cautionary notes should be sounded, as some Centrex resellers have proven to be financially unstable and the incumbent carrier (ILEC) continues to control the service, rather than the reseller.


Multiple Centrex Systems

An essential characteristic of Centrex service is its ability to support multiple customers from one CO system, since the software package can be reliably partitioned. After "teething" problems with digital Centrex software were solved in the early 1980s, no case of incorrect connection between different customer services has been reported, which is really a remarkable record. A typical Centrex system based in a large CO can support up to 50,000 phones, so for most purposes the growth potential, for a specific customer, may be considered effectively unlimited.


Investment in Centrex Software

The software employed for circuit-switched Centrex is at least as complicated as that in large PBX systems, and may be more complex because of the need for partitioning into many virtual PBXs, while it supports a similar feature set and comparable interfaces (e.g., to message systems). A Lucent or Nortel Centrex package contains several million lines of code, at the machine language level, and has required well over 1,000 person-years of software development.

To recoup this investment, Centrex system vendors must set a price on a Centrex software package for each equipped CO of, at least, $1 million and likely up to $5 million. Faced with this cost in added software for a single CO, a telco needs to have a good, local, business case before installing Centrex. So it is likely that conventional Centrex service may not be available everywhere across the territory of a telco (i.e., Centrex service may not be found in the outer suburbs or in smaller towns or cities).


Development of Internet Protocol Centrex

Ever since Centrex was launched 40 years ago, it seems that technological advances in telecommunications have occurred in premises-based PBX systems before being adopted for Centrex services. This trend is now apparent with Internet protocol-based telephony products, in that IP-PBXs were being sold 2 years before beta testing of Internet Protocol Centrex (IP-Centrex) was really underway. In late 2002 several telcos were moving from pilot trials of IP-Centrex to the early stages of its service delivery.

In the several years that IP telephony PBX systems have been on the market, they have sold in modest numbers and supported no more than 1% of all PBX-attached stations in the United States by the end of 2002, with a smaller impact in other markets. To some extent, this slow rate of acceptance is certainly due to the overall slackening of investment in telecom equipment since the run-up to the year 2000. However, another serious factor is that the advantages of the IP-PBX over conventional, circuit-switched [or time-division multiplexing (TDM)], PBXs are not obvious to most telecom or IT managers. We discuss this topic more extensively in Chapter 4.

This relatively slow acceptance of the IP-PBX is not necessarily a good indicator of the future of IP-Centrex, once that becomes a stable, fullfeatured service that is intelligently and aggressively sold by the service providers, both ILECs and CLECs.

IP-Centrex offers all the advantages that have been well advertised for premise-based IP telephony systems (e.g., ease of administration and ease of access to corporate, LAN-based applications), combined with the present advantages of Centrex (i.e., the complexity of design; implementation and management being outsourced to the telco with the voice switch placed inside the perimeter of the public network).

We are convinced that IP-Centrex will bring a revolution in the delivery of corporate voice communications and that within 10 years as many business-related endpoints will be supported by IP-Centrex services as by premises-based switches.

The package of advantages that can be promised for IP-Centrex is sufficiently attractive and thus in tune with the trend of renting managed services for IT functions (such as Web server hosting), that organizations that retain ownership of their PBX may be in a minority within a decade.

This predicted revolution, produced by the acceptance of IP-Centrex, will have three dimensions:

  1. The new IP-Centrex hardware and software will be produced by a wider range of companies than the five large manufacturers of CO systems.

  2. Because of the reduced cost and complexity to enter the market, IP-Centrex will be available from more competitive and smaller companies than just the ILECs. Those providers that are now in the managed services business with Web servers and customer relationship management (CRM) software will also be renting integrated voice services.

  3. The current best case, business-line market, share ratio of 20% for Centrex to 80% for premises-based switches could be reversed to an 80:20 ratio in favor of IP-Centrex within 10 years. The senior management of the largest Centrex system manufacturer is predicting a 50:50 market share ratio for Centrex versus PBX, within a decade, and we believe that this is a reasonable expectation.

This subject is developed in more detail in the following chapters.


Blurring the Boundaries

The advent of IP-Centrex will blur the clear distinction between Centrex services and PBX systems in two important ways. With conventional Centrex, call control and switching take place in the CO on telco premises, or in the generally much smaller PBX, both processes occur on the customer's premises.

In a fully IP-Centrex environment, call control remains at the controller in the carrier's CO building, but much of the call switching is done in systems (such as Ethernet switches or routers) on the customer's site. The "payload" packets for an IP telephony call between two phones within the same building will not travel outside the building. In current Centrex systems all voice traffic flows over the local loops from the user's phone to the CO and then either back into the building to another user or off to the PSTN.

The second change, which is already happening, is that service providers (including smaller competitors) can acquire IP-PBXs to provide Centrex-like services, rather than buying a much more expensive CO system. In this way the barriers to entry into the IP-Centrex business are dramatically lower than they were previously.


Chapter 2: Internet Protocol Centrex

Interactive Communications over Internet Protocol

The Internet Protocol (IP) was devised in the 1960s and has been subsequently revised as a universal networking language for the network of networks that we now know as the Internet. Some of the relative objectives of IP are that it should enable:

  • Data to be transmitted over different media and data links;

  • Data packets to be transmitted reliably;

  • New networks to be joined to the Internet without disruption;

  • Equipment of different types and from various vendors to be interconnected smoothly.

Layer 3 and 4 Protocols

IP exists at layer 3 (the network layer) of the seven-layered Open System Interconnection (OSI) protocol stack, above the data link layer, where technologies such as ATM, frame relay, and Ethernet apply, as illustrated in Figure 2.1.

Click To expand
Figure 2.1: IP and OSI Protocol stacks.

While IP, at layer 3, defines the addressing and routing rules for data packets, at layer 4 there are three other relevant protocols: user datagram protocol (UDP), Real-Time Transport Protocol (RTP), and transmission control protocol (TCP). UDP is a connectionless protocol, with an emphasis on the minimizing of packet transit time, which is ideal for the interactions that are essential to voice and video traffic. TCP is the connection-oriented protocol that provides confirmation of a packet's receipt at its destination, if necessary after retransmission and without concern about delay. With a Voice or Video-Conferencing over Internet Protocol (VoIP) session it is usual to employ TCP/IP for the call setup, any in-progress signaling, and teardown, while UDP/IP is better suited to the real-time transmission of the voice or video conversations. TCP provides the same functionality on networks for VoIP as signaling system number 7 (SS7) does over circuit-switched, TDM networks for conventional, long-distance telephony.

RTP is an Internet Engineering Task Force (IETF) standard that defines the streaming of interactive voice and video packets over switched networks. This is a so-called thin protocol that does not provide any quality of service (QoS) features.

IP Telephony

For several years the term Voice over Internet Protocol (VoIP) has been used to identify the transmission of voice signals over any IP-based network. In the business context, VoIP now refers to the transmission of voice and/or video communications over a managed WAN or LAN.

Some consultants and one or two telecom manufacturers have used the term telephony over Internet protocol (ToIP) to describe the switching of real-time, conversational traffic in systems that are attached to IP data networks.

The words "IP telephony" have emerged as the umbrella term that covers both VoIP and ToIP, which can be delivered either by an IP-PBX (housed on the customer's premises) or by IP-Centrex (for which the call processor is owned and accommodated by the carrier).

Some organizations have been using VoIP to reduce the cost of longdistance service, particularly international service, for several years. In countries that have highly competitive interexchange carriers it is generally no longer worthwhile to use VoIP, after allowing for the cost of gateway hardware and software. Several international carriers, such as the T-Systems division of Deutsche Telekom, have specifically promoted the use of IP networks for international traffic.

IP telephony has been validated since the year 2000 by the availability of some IP-PBXs (see Chapter 4). An IP-PBX system or IP-Centrex service may deliver only VoIP (through appropriate trunk and line interfaces), only ToIP (by retaining interfaces for the existing analog and digital devices), or both in the form of IP telephony. Now that IP has become, by far, the most popular protocol for data transmission and is widely deployed in networks of all sizes, from one room to worldwide, organizations have access to the appropriate transport technology to gain the advantages of convergence. Full convergence between multimedia and data applications requires the availability of both VoIP and ToIP, which are both inherent to the concept of IP-Centrex.

Interface Standards

The key to success with IP-Centrex will be a high level of interoperability between devices and systems or applications. This will be a major move away from the proprietary interfaces that have kept acquisition costs up and made application implementations complex with PBX systems. The acceptance of a limited number of open standards will also facilitate more competition between a broader range of manufacturers and service providers.

The earliest call control standard for mapping users' names or telephone numbers into and IP source or destination addresses was H.323, which was adopted by the International Telecommunications Union (ITU). H.323, was originally intended to define how multimedia communications were to be transmitted over a data network between teleconference units and, as used for VoIP, defines only a restricted feature set, with different enhancements being made by various manufacturers. H.323 does not define transmitted voice quality, is considered to be too processing intensive, and depends on the use of intelligent workstations.

A working group of the IETF created the session initiation protocol (SIP) to lessen call setup times and take better advantage of the Internet infrastructure than H.323. SIP is most likely to become the interface standard of choice between telephone sets and computers with ToIP systems.

A third standard, officially known as H.248 but more generally as MGCP or Megaco, is being jointly developed by the IETF and ITU, with support from some, but not all, major manufacturers. The H.248/ MGCP protocol addresses the needs of multimedia conferencing and is intended for use with media gateway controllers (MGC).

Every communicating device on an Internet protocol-conforming network must have an IP address, so that a desktop with a telephone, a PC, and a softphone (within the PC) or a video terminal needs to be allocated three addresses. There must be a process with the network for mapping telephone numbers to corresponding IP addresses.

Also, any endpoint's address must be known in order to be accessible; in some circumstances, this requirement becomes a security concern. This situation can be problematic in that multiprotocol label switching (MLPS), which is widely used in managed wide area networks (WANs), does not allow for any "spoofing" (i.e., the alteration and retransmission of any part of a signal in order to hide the address contents and therefore discourage hacking). For details regarding the use of MPLS, see "Managed Networks" in Chapter 3.


IP Centrex Configurations

The development of IP-Centrex is quickly following the same path trod by the manufacturers of IP-PBXs over the past few years. There are two main stages in this development, where IP-Centrex is first delivered from an existing, circuit-switched type of serving CO and then, launched from a new controller that handles only packet-switched traffic.

The first stage of IP-Centrex could be described as a hybrid service, supporting existing terminals and new IP phones. We may think of the second stage as "pure" IP-Centrex, with a server in the carrier's network providing control signals to various gateways and links to application processors (APs), for applications such as unified messaging (UM), automatic call distribution (ACD), and CRM.

Hybrid IP-Centrex Service

In the examples that are shown in Figures 2.2 and 2.3, a mixture of conventional (analog and digital) and IP phones (both separate sets and softphones on PCs) is used in the single or multilocation situations, served by one legacy Centrex system.

Click To expand
Figure 2.2: Single-location hybrid IP-Centrex.
Click To expand
Figure 2.3: Multilocation hybrid IP-Centrex.

At an organization's branch location, as in Figure 2.3, an on-site IP-Centrex gateway may be placed on the customer's premises to support non-IP phones and, possibly, facsimile machines, through analog and digital ports.

"Pure" IP-Centrex is based on a new type of CO switch that is now appearing on the market and is frequently known as a "softswitch." Part of a typical softswitch configuration is shown in Figure 2.4. With this development the call control functions are physically separated from the various outboard gateways, in a way that has not been obvious with legacy, circuit-switched CO systems.

Click To expand
Figure 2.4: Pure IP-Centrex configuration.

Trends to Full IP-Centrex

The softswitch-based IP-Centrex solution must continue to provide for a significant proportion of legacy phones, both analog and digital, while accommodating a growing population of IP-compatible devices. We do not encounter many large "greenfield" situations, where hundreds of users need new phones or computers at one time, in any one year. Most organizations wish to retain their present inventory of phone sets and a few fax machines for several years. A complete switch to local area network (LAN)-based voice and workstations is much more likely in home offices, for telecommuters, and in branch locations, as at the bottom of Figure 2.4. In the ILEC networks the full transition from large CO systems, using TDM technology, to softswitch COs will certainly take a decade and may last up to 20 years. The competitive service providers, with less capital invested in legacy systems, may be able to move to the pure IP-Centrex scenario more quickly.


Softswitch Characteristics

A softswitch is a high-availability computing platform that houses software to control multimedia traffic over an integrated telecom network and mediates the signaling between packet and circuit-switched networks (i.e., between the IP-based and the legacy TDM domains). Softswitches may be considered software-based replacements for class 5 (local exchange) and class 4 (toll exchange) central offices.

These systems promise an excellent opportunity for service providers to deliver new, innovative broadband services, while reducing equipment and personnel costs by up to 50%, compared with conventional, digital CO systems. The legacy switches, made by the eight major telecommunication equipment manufacturers, are highly proprietary in nature.

A softswitch should reside in an extremely reliable (i.e., extensively redundant), industry-grade, rack-mounted server in a secure network data center. Ample power supply and network access backup capabilities are also essential. Softswitches work in close conjunction with modular media gateways and, partly because of the physical separation of control and packet-switching functions, can be scaled in capacity to meet quickly changing traffic patterns more easily than with older circuit switches.

A significant feature of softswitches is the facility for a system administrator to install and manage all the telecom services of the switch through a Web portal. In this users are offered a much better way to control their own network, such as ordering new services, click-to-call on any numbers, modifying call forwarding, and customizing individual telephone sets (whether real or virtual). For these reasons, managing telecom services will become much easier than it has been with on-premise PBXs or off-site Centrex services. With a softswitch it should be just as simple to administer video-conference services as voice calls, which will be a big improvement over legacy class 5 CO capabilities. Some of these softswitch entities are illustrated in Figure 2.5.

Click To expand
Figure 2.5: Softswitch configuration.

Carrier grade softswitch products have been on the market since late 2001 from established manufacturers, such as Nortel Networks and Siemens, as well as recently started companies including Sonus and Tanqua Systems. Most of the newer companies in this line of business belong to the Softswitch Consortium.

The early applications of softswitches were for off-loading Internet traffic, from more expensive and busy CO systems, primarily with DSL on the line side and IP or ATM on the trunk side. Going forward, the role of softswitches will be much more to replace conventional central office systems and to deliver multimedia IP-Centrex services. Softswitch availability is the key for the development of hosted telephony services by the competitive service providing companies and for the capability of putting all an organization's voice, video, and data traffic onto a single network.


Network Considerations for IP-Centrex

Requirements for VolP

The IP-based systems and networks that will be used for voice or video transmission over IP must meet several criteria to deliver a signal of the same quality that has been available through circuit-switched, digital systems and with which the users are satisfied.

Because of the real-time, interactive nature of VoIP the average transit time (i.e., latency) between source and destination is most important. As shown in Table 2.1, ideally one-way latency should be less than 100 ms. If the round trip delay on a voice conversation exceeds three-tenths of one second, then it becomes difficult to continue an intelligent dialog, as many have experienced when a telephone call was routed through a geostationary satellite. Table 2.1 displays a consensus of numerical criteria published by several manufacturers of VoIP gateway products.

Table 2.1: VoIP Network Criteria
CRITERION | IDEAL | DESIRABLE (MAX)
Latency | 100 ms | 150 ms
Jitter delay | 40 ms | 80 ms
Packet loss | 1% | 3%

Jitter is the variability of packet arrival times at the receiver and is generally caused by large bursts of data interfering with the real-time traffic in the network. Although modest jitter delays have not been considered serious to real-time conversation, yet significant jitter (i.e. delays approaching 60 ms) leads to unintelligible speech patterns and ruins video displays.

Packet loss corresponds to link dropouts, which is a common experience with mobile/cell phones in congested areas and also results in unsatisfactory voice or video communications.

The bandwidth, or bit rate, requirements for VoIP depend on the type of encoding/decoding (i.e., codec) technique that is used in the digital signal processor (DSP) in the end stations. A reasonably good guideline, with current technology, is to allow 20 Kbps in the network or the access link for each simultaneous voice conversation, or 200 Kbps for a small-group video conference session.

LAN Requirements

In a large office complex there may be a correspondingly large number of simultaneous voice calls on the LAN, in the busy hour of the week. This traffic volume depends on the peak telephone utilization level in the organization, which may be 25% in many offices, but rise to nearly 100% of the population in some highly sales-oriented businesses, such as a stock brokerage. Even if there are 1,000 concurrent voice calls on the LAN, this probably represents an added load of only 20 Mbps, which is insignificant on a gigabit backbone.

However, if the in-building network is to carry IP-based video traffic, as will increasingly be the case as multimedia applications are implemented, then a major LAN upgrade is much more likely to be needed. If we assume a minimum bit rate of around 200 Kbps for two-way video interaction and up to 2 Mbps for higher definition, full motion, video displays, then a number of simultaneous video sessions will put a heavy load on the LAN. In some early installations for IP-based video conferencing a separate LAN that went all the way to the main edge router for the building was dedicated to the video outlets.

WAN Requirements

An existing metropolitan area network (MAN) or WAN will certainly be more challenged by the added burden of carrying VoIP packets than a LAN. The transit and jitter delays and bit rate requirements will each have to be seriously addressed across all stages of the larger network. Generally a data network that runs on frame relay (FR) technology will not meet the latency criteria that we have specified. There may be some exceptions if the FR virtual circuit involves only two frame switches. The regular Internet is definitely not suitable for corporate VoIP traffic and only a managed network can meet the requirements.

A managed IP network is one where the service provider(s) monitor and control the QoS, outside the customer's own environment, to minimize latency and jitter, while ensuring that sufficient bandwidth is available for busy traffic. In a managed network the VoIP packets pass through the least number of nodes and the QoS is guaranteed, going beyond just "best effort" engineering.

The characteristics of the access links between the LANs and WAN must also be well defined and managed to fit within the overall criteria budget from source to destination. The topic of virtual private networks (VPNs), which often fulfill this WAN role, is addressed toward the end of Chapter 3, in the "Managed Networks" section.


Deployment Strategies for IP-Centrex

The arrival of credible IP-Centrex services presents different scenarios to corporate decision-makers, depending on the state of their telecom infrastructures and on the alternative offerings in their marketplace. These situations fall into one or more of three classes:

  1. Controlled Migration to IP-Centrex. Many organizations will wish to add IP phones to an existing Centrex configuration (i.e., the hybrid approach). Two possible reasons for this might be:

    • To implement a contact center as a managed service;

    • To extend fully featured, multimedia service to remote or mobile worders.

    For these solutions the organization will need to use a wellmanaged IP network, which may be provided by the ILEC, that currently operates the Centrex service, or may be from another service provider (e.g., an international telco with a wider-ranging network, such as AT&T or BT).

    The use of two or more IP-WANs presents a further choice to the customer, as the customer may prefer to have access directly to the competitive long-haul network through a switch at the customer's site, rather than via the IP-Centrex service provider's own network access. This alternative is shown in Figure 2.6.

    Click To expand
    Figure 2.6: Controlled migration to IP-Centrex.

  2. Greenfield IP-Centrex Implementation. On the reasonable assumption that the average digital PBX needs to be replaced (not just enhanced) after a 10-year life, or that long-term Centrex contracts never last more than a decade, about 10% of all organizations will face a crucial greenfield telephone services decision each year. Some examples of this situation are included in Chapter 5.

  3. Move to a Competitive Service Provider. Many organizations obtain their Internet or VPN connections through an ISP and/or rent Web server hosting facilities from a service provider other than the incumbent telco. In many of these cases this service provider is a good candidate to become the customer's communications application service provider (CASP), in preference to the ILEC.

When considering whether or not to entrust its in-house voice and video communications to a CASP, an organization's management must evaluate the following topics:

  • The specific IP-Centrex design being deployed by the CASP;

  • The match between the feature set available, from the competitive IP-Centrex service, and that needed by the users;

  • The local access technology being offered to the WAN and its scalability to accommodate growth (or, occasionally, contraction) of bandwidth needs;

  • The perceived financial stability of the service provider, in a time when the finances of some long-established, large telcos also have been seriously questioned.


Chapter 3: IP-Centrex Systems and Applications

IP-Centrex Systems

Five major telecommunications equipment manufacturers, namely Alcatel, Ericsson, Lucent, Nortel, and Siemens have been able to supply Centrex solutions, based on their respective digital CO systems, for the last decade. Three other significant public exchange manufacturers-Fujitsu, Marconi, and NEC-have not supplied Centrex software in the past and do not appear to be interested in delivering IP-Centrex systems (although NEC was one of the early suppliers of IP-PBXs).

All five of the legacy Centrex suppliers have announced softswitch products, but it is not clear that all five are making full IP-Centrex capabilities available on these new systems. Some of the Centrex vendors seem to concentrating on supporting hybrid TDM/IP products, while others are emphasizing their softswitches' full abilities.

Other new system manufacturers are attempting to move into the IP-Centrex market, without an earlier background in circuit-switched Centrex. So far, customers have had no say in the choice of a system that supports local Centrex service, because local Centrex service has been delivered only by the former monopoly ILEC. The arrival of IP-Cen trex could well change this situation, as competitive Centrex offerings present alternatives and some customers may be able to choose the service that is most compatible with their needs.

The product descriptions that follow are not intended to be exhaustive but should give a good indication of what systems are available to deliver hybrid and full IP-Centrex from a number of vendors. The hybrid, evolutionary approach extends the life and depreciation time of legacy class 5 switches, but retains proprietary technology in the network and limits the integration of new applications. The softswitch-based, full IP-Centrex, approach can be disruptive for the service provider and its customers. This approach may also be risky if the softswitch comes from a smaller company that has had time only to develop a limited set of the popular Centrex features.

Alcatel

Alcatel includes a Centrex offering on its model 1000 central office, but at the time of this writing had not made any announcement regarding IP-Centrex. Alcatel is not a major vendor of Centrex systems; it has implemented a limited form of Centrex in a few countries and planned for Centrex service with several South American telcos.

The company has developed the powerful 5000 series of softswitch platforms, of which the 5020 is a signaling server and the 5424 is designed for off-loading switched data traffic from the voice network to the Internet. The model 5000 is a class 5 switch server, with a typical network topology as shown in Figure 3.1.

Click To expand
Figure 3.1: Network topology with Alcatel 5000 softswitch.

This 5000 softswitch can process 5 million busy hour call attempts (BHCA) and grow to 1 million virtual ports, delivering voice over IP or ATM and interfaces to the SS7 network. The softswitch in Figure 3.1 is shown with integrated access devices (IAD) on the customers' premises, providing 16 voice channels over one digital subscriber line (DSL).

Ericsson

Ericsson became interested in Centrex over 10 years ago, when the service was first introduced to Europe, but has not become a significant player in wireline Centrex. However, Ericsson makes three major contributions to the overall IP-Centrex market, as follows:

  • A product known as G-Nexus, or GSM Mobile Centrex, delivers PBX-like functionality over a public mobile phone network, using GSM technology, which is the most widely deployed wireless standard in the world. Ericsson-made equipment supports over one-half of the world's GSM users, and its G-Nexus has IP access facilities, with a managed IP network between the enterprise and the Centrex node at the network operator's site. This mobile or fixed access to G-Nexus uses an H.323 media gateway to link to the AXE-based Centrex node, providing business group communications. The latest version of Ericsson's central office, the AXE Local 7.2, is a UNIX-based system that is really a transition product, partway between a legacy circuit switch and a softswitch. Ericsson's softswitch product, known as the IPT 2.1, has an all-IP architecture, supports H.323 protocol, and is intended as a signaling processor for multimedia service delivery. This is illustrated in Figure 3.2.

    Click To expand
    Figure 3.2: Ericsson's IPT 2.1 domains.

  • Ericsson was an early starter in the VoIP (transmission) market during 1997 and is now one of the largest suppliers of VoIP gateways.

  • Ericsson has become the most successful supplier of in-building wireless phone sets, which can work with PBXs and Centrex services from other suppliers, such as Siemens and Nortel.

Lucent Technologies

Lucent Technologies is the second-largest supplier of Centrex systems, based on its 5ESS digital central office, which has been installed in a number of countries. Lucent made an early start in 2000 with its iCentrex product, which is based on the iMerge gateway, extending Centrex over IP and wireless networks. The iCentrex solution is actually switch independent and could work with other vendors' central offices. This product allows for the use of a mobile phone with Centrex dialing and other features when the user is in the Centrex service area. Sharing one voice mailbox between wireless and wireline Centrex services is also possible, with more than 1,000 wireless handsets feasible in one building.

Lucent claims that its 5ESS switch has the least downtime of any CO system in the U.S. public networks. The iCentrex development relies on the 7R/E Packet Driver software to deliver full PBX-like parity, including call transfer to voice mail and auto attendant. The wireless Centrex features work with either code-division multiple access (CDMA) or time-division multiple access (TDMA) technologies.

The iMerge Centrex Feature Gateway (CFG) enables users to enjoy worldwide Centrex service, as emphasized in Figure 3.3.

Click To expand
Figure 3.3: Worldwide IP-Centrex.

Lucent identifies the benefits of worldwide IP-Centrex as including a single dialing plan and uniform telephone system at all locations, including mobile and at-home workers, as well as branch plants or offices. IMerge enables a customer to be freed from service area boundaries with the delivery of existing Centrex and new services across a packet network.

Based on the encouraging results from field trials of Lucent's iMerge product (as described in Chapter 5 in the "IP-Centrex Field Trials" section.) SBC Communications launched commercial IP-Centrex service in September 2002, starting with availability in five major cities across the United States. SBC claimed that it was the first major carrier to bring these new IP-Centrex capabilities to the market.

Nortel Networks

Nortel Networks is the world's largest vendor of Centrex systems and has been responsible for most of the development of these services outside North America over the past decade. There are nearly 100 million lines on Nortel's DMS switches worldwide and of these well over 10 million are for Centrex. Nortel has announced a family of softswitches under the name of Succession, based on Sun computing platforms. The CS2000 can process 300,000 BHCA with a pair of servers, supporting both asynchronous transfer mode (ATM) and IP, together with H.323 and SIP standards. Nortel's concept of IP-Centrex, delivered either from a legacy DMS switch through gateways and from the CS2000 softswitch, is illustrated in Figure 3.4.

Click To expand
Figure 3.4: Centrex IP for extended service reach. (Reproduced with the permission of Nortel Networks. Copyright © 2002 Nortel Networks, All rights reserved.)

Nortel Networks conducted a number of IP-Centrex technology trials in North America and Europe during 2001 and 2002. Then, in late 2001, Telstra announced that it would offer CustomNet IP in the major cities of Australia, using Nortel-made gateways to link IP-based endpoints to the existing CustomNet (i.e., digital Centrex) service. Telstra stated that CustomNet IP would also use data services, such as dial connect, cable, asynchronous digital subscriber line (ADSL), or ATM, to provide access to its DMS-based CustomNet. This is the first product set to be released under Telstra's Next Generation Telephony project, but the actual start-up date for this service was not announced.

Siemens ICN

Siemens ICN sells its Centrex product under the name GeoCENTREX. GeoCENTREX is based on the Siemens EWSD central office switch. The EWSD is the most widely sold such system in the world, supplying 250 million analog and digital ports. A single EWSD system can process 16 million BHCAs, have up to 240,000 ports, and handle 100,000 Erlangs of traffic. Siemens holds a distant third place in the North American market and is still a minor player in the Centrex field.

Siemens intends to provide an end-to-end IP-Centrex solution through a combination of its own technology and vendor partnerships, as shown in Figure 3.5, which illustrates the use of an IAD to link analog stations or KTS/PBX systems to IP-Centrex.

Click To expand
Figure 3.5: Next generation local switch services.

In mid-2002, Siemens sold its controlling share in Unisphere to Juniper Networks and is no longer directly involved in the data router and switch market. However, since Siemens' IP phones work to open standards, the customer and service provider could use any standards-based router. Siemens has retained the name of the Unisphere SRX for its family of softswitches and obtains its IP-Centrex software from Broadsoft Inc.

The Broadworks package can be deployed in a totally packet-based architecture such as full IP-Centrex or work as an extension of a preexisting class 5 switch. The system can support more than 1 million customers per network and process up to 6 million BHCA, based on a cluster of Sun computers, divided into the three classes of application, media, and network servers.

This software enables service providers to manage a nationwide IP-Centrex system centrally, delivering a uniform service to distributed enterprises and optimizing network management resources.

The Broadworks package provides Web portals for five types of service management:

  1. Service providers with complete system administration capabilities;

  2. Resellers that can create and manage their own groups of customers, under contract with the service provider;

  3. Enterprise administrators with access for configuration and management of multilocation dialing plans, for specific organizations:

    • Group administrators, within one enterprise, that can perform modification, addition, and deletion of features and users;

    • End users within a calling group that can personalize calling services and features.

Cisco Systems

Cisco Systems' CallManager server had been installed by at least three service providers as of mid-2002, to provide IP-Centrex services. Pingtel, one of these competitive service providers, delivers IP-Centrex from CallManager installations in New York City, Philadelphia, and Washington, DC. This service has proved most successful with small businesses that have from 100 to 500 users at a site.

This is a development that we expect will be followed by other service providers, both large and small, as an alternative to the use of more powerful softswitches from the established Centrex manufacturers. Cisco's AVVID products are described in Chapter 4.

Sylantro Systems

Sylantro Systems sells an application switch that offers hosted PBX and IP-Centrex features to competitive service providers. Sylantro claimed to have sold systems with more than 10,000 user ports within the first year that its system was available.

Tacqua Systems

Tacqua Systems has created its OCX softswitch with class 5 capabilities, specifically so that CLECs can deliver local telecom services with significantly reduced initial and ongoing costs of ownership. Tacqua delivers a kernel of telephony features, while encouraging other software developers to use its intelligent network (IN), application programming interface (API), and SIP interfaces.


Features and Applications

The effective use of features (within the phone system) and applications (attached to the phone system) is the key benefit promised by IP-Centrex. With legacy PBX systems and Centrex services, most users do not know what features are available and are uncomfortable with some that they do know (e.g., establishing a three-way conference call). Additionally, the integration of desired applications has proven to be complex and expensive with PBXs, and almost impossible with Centrex, due to management and physical separation.

With the next generation networks, as typified by IP-Centrex, voice service features and applications will be created by a wide range of developers, including specialist software companies, the service providers, system manufacturers, and the user community. These improvements can be grouped into three categories:

  1. High-volume services for many users will reside on centralized application servers, next to the carrier's softswitch. These will include address/number translations and other directory services, toll-free number services, nationwide number portability, and links to wireless services.

  2. Applications for work groups that need specialized services, such as contact centers, but that are also physically distributed and frequently changing. A wide variety of occupations, such as brokers of all types, public relations personnel, sale executives, and consultants, spend much of their day on the phone and are highly mobile. These applications need to be flexible and logically distributed, but will mostly be implemented on shared, centralized servers.

  3. Personalized features will involve customization at the endpoint, with an intelligent device. These include features such as call blocking of specific codes or numbers, user-specific icons or audio interfaces, and caller-identifying ring patterns.

Hosted Internet protocol (HIP) telephony is an almost ideal application service provider business model, in that voice services do not involve customization for particular vertical markets. At the same time, other applications, such as CRM and enterprise resource planning (ERP) can be attached to the voice services and tailored to specific industries. Most users of the features and applications that will be delivered through IP-Centrex will need an IP telephone, while some will be served by a softphone within a PC.


Telephone Sets and Consoles

Some users will be satisfied with having a softphone as their only voice terminal, but we cannot assume that the PC, with added software, headset, and speakers, will largely replace telephone sets, as the PC is awkward to use, not always switched on, and certainly less reliable than a single-purpose phone. Most users still seem to prefer having a real telephone, with which they can dial, talk, and listen in a familiar fashion.

Numerous manufacturers are attempting to fill the need for IP-compatible phones and most of those will be based on the SIP standard. Some years ago there were predictions that ISDN-compatible telephones would become commonplace, low-cost devices, in conjunction with PBXs or Centrex. This has not happened because ISDN is an expensive technology to implement and this type of phone has not become a high-volume production item.

IP telephones are akin to ISDN sets in that they cannot easily be supplied with DC power from the central office and must be powered locally. Commonly an ac plug-in power cube is used for each phone, but a better method is to install a power supply unit (PSU) in the closest telecom closet (TC). The DC power is supplied to a number of sets over the LAN wiring and the PSU can be backed up by a small UPS in the TC.

However, the $100-IP phone became a reality in the early days of IP-Centrex, as Ethernet NICs and SIP chip sets both cost just a few dollars. The IP-Centrex service providers cannot expect to generate revenue from the rental of IP phones in the future, because these will become commodity items and will be mostly purchased from highly competitive retailers.

A two-level market in IP phones has developed as the less-demanding users' needs can be met by generic sets that implement just the requirements of the SIP standard. At the higher level of sophistication, manufacturers add their own features on top of SIP and therefore create proprietary sets that cost significantly more. The market for IP phones will simply reflect that for mobile/cell phones, most customers pay less than $100 for a handset, but some users (perhaps 20% of the total) are willing and able to pay well over $200 for a feature-rich handset.

Examples of IP Phones

The large telecom equipment manufacturers, such as Lucent and Nortel, are addressing the IP phone market with just one or two models, compared with the wide variety of telephones that they previously made for their legacy Centrex and PBXs. Presumably these vendors hope to rationalize their production line and minimize the costs of making large quantities of a standard set. The first generation of IP phones from these large companies, including Cisco, were proprietary devices that could only be used with that vendor's switches. The trend now is to produce sets that are based on the SIP or Megaco standards, or both.

Other independent phone suppliers (such as Aastra, Avanti, Pingtel, Telcordia, and Telrad) are offering intelligent, voice-over-IP phones to complement the features of IP-Centrex. Well-established, high-volume handset producers, such as Samsung and Sony, are also supplying this market.

Two telecom manufacturers, Mite1 and Siemens, have earned a reputation for ergonomically excellent telephone terminals, and both produce a range of IP phones. Mitel has five IP phone models, including a low-cost, single-port unit and the 5140 IP Appliance, which is pictured in Figure 3.6. The more expensive device has a 320-by-240 pixel display and an infrared adapter (IrDA) interface, which provides a link to (personal digital assistants) PDAs. This phone enables users to define icons to represent telephony features, using the Palm-based graphical interface.

Click To expand
Figure 3.6: Mitel's 5140 IP Appliance. (Reproduced with the permission of Mitel Networks.)

The Mitel 5140 also has a built-in Hypertext Markup Language (HTML) browser and integrated directory management capabilities. It can be used as an agent's or supervisor's workstation in an automatic call distribution (ACD) configuration.

An interesting and forward-looking type of IP phone is one that is essentially a PDA cradle, built to accommodate a Palm Pilot or a similar device. The PDA provides a color screen display and most of the processing power, as well as its built-in operating system, applications, and database. This keeps the cost of the phone itself very low and provides a powerful desktop terminal.

The Siemens IP phone brand is optiPoint; these were the first sets from a major telecom manufacturer to support SIP. The optiPoint 100, for example, has both 10 Mbps Ethernet and RJ-45 interfaces and includes the G.711 (64 Kbps) and G.723.1 (5.3 Kbps) voice encoding algorithms. It has a two-line, 24-character display and is a hands-free, speakerphone set.

A major advantage with IP phones is that, when moved, these phones automatically reregister with the communication system, providing access to the voice services within a few seconds. Most IP phones also integrate with HTTP-based system management packages to allow for fast and intuitive moves, adds, and changes (MAC).

Attendant Consoles

Because of the inherent DID feature with Centrex, there is less of a need for console attendants than there is with PBX. The availability of autoattendant service, to assist "lost" callers, further reduces the need for attendant personnel. Some requirements for operator assistance still remain with IP-Centrex, especially in institutions that have a highly mobile workforce, such as hospitals and universities. In that environment a PC-based console, closely integrated with the organization's directories and on-line personal diaries, is the best solution. At the departmental level, an attendant answering position based on a midlevel IP phone, with add-on programmable key modules that usually come in 48-button units, is a good solution.


Wireless Capabilities

The availability of IP-Centrex, based on a common voice-data network, should remove management's inhibitions regarding Centrex-based contact centers. In the IP-based environment the physical locations of applications, including call management and customer relationship software, and of agents, are no longer significant concerns.

We can classify the solutions for in-building, wireless access to IP-Centrex into these three categories:

  1. Wireless IP phones, based on the IEEE 802.11b standard, can communicate (as a data device) with wireless access points within the building. A few companies, such as Spectralink and Symbol, have been making this type of phone for a while.

  2. Wireless-enabled data devices, such as PDAs, laptop PCs, and voice-capable pagers are available with IEEE802.11b and/or Bluetooth capability.

  3. Multipurpose wireless handset that can work outside a building as cell phones (with GSM, CDMS, or TDMA systems), but that can also operate to proprietary in-building standards (e.g., Ericsson's Freephone) have not become widely accepted yet. These phones would need an IP gateway between the wireless access points and the IP-Centrex system.

The IEEE 802.11b standard, frequently known as "Wi-Fi," has become the dominant standard for high-rate wireless LANs and employs direct sequence spread spectrum at the physical layer. Wi-Fi operates in an unlicensed 2.4-GHz band in most countries, at a nominal bit rate of 11 Mbps, and delivers a throughput of from 5 to 7 Mbps. An extension known as 802.1 lg offers a nominal bit rate of 22 Mbps.

Although IEEE 802.11a was ratified at the same time as 802.11b (in 1999), this standard has not yet been widely adopted because it involves a radically different modulation technology. IEEE 802.11a wireless systems are intended to operate in the 5-GHz band, where 300 MHz of unlicensed spectrum should be available in most countries.

The disadvantage of moving to a higher radio frequency than that used for IEEE 802.11b is a reduced operating range, which means that the required number of APs may be quadrupled. To compensate for this, the 802.11a standard increases the recommended output to 50 mW and employs coded orthogonal frequency division multiplexing.

As the demand for wireless LAN access grows, it is likely that we will see a mixed-standard enterprise environment develop, where users' devices will be able to roam between 802.11b and 802.1la networks. As equipment prices fall, dual-mode clients and APs will become prevalent.

Equipment made to 802.11b standards can interoperate with earlier 802.11 devices, which may deliver only 1 or 2 Mbps. Most Wi-Fi transmitters radiate at a power level of 30 mW, but the standards do allow for an output of up lW, for use outdoors. There are always concerns regarding security when wireless transmission is used for telecommunications, but the 802. lx standard, which defines the authentication and encryption techniques to be employed, has strengthened the security walls around 802.11 systems.

For over a decade the widespread use of wireless LANs has been a promise for "next year" that never seems to be fulfilled. However, the combination of a powerful array of wireless voice terminals and the capabilities of IP-Centrex may lead to a growth in usage more like that of cellular radio than of wireless data networks.


Unified Messaging

Unified messaging (UM) assembles all e-mail, fax, and voice mail messages (for both wireline and wireless devices) into a single mailbox for one user. While UM systems have been available from several vendors, for about a decade, their acceptance in the market has been quite poor, at much less than 10% of corporate users, compared with the universal utilization of voice mail. This reluctance to invest in UM can be explained by the relatively high cost of software licenses and, perhaps more importantly, the perceived cost of system management.

The proponents of UM claim that a mobile worker, with multiple single-purpose mailboxes, can greatly optimize communications management and save at least 30 minutes of working time each day. With UM, users can review, manage, and answer any electronic messages, using a desktop or mobile phone, or a PDA.

A major capability of UM is that messages can be translated to the most useful medium, so that text message and facsimile headers can be read by a synthesized voice and voice messages can be played through a laptop. A user can point and click through all the message titles and selectively listen to a desired message while quickly deleting junk mail. The possibility of outsourcing the provision and administration of UM to a service provider is one of the prime justifications for IP-Centrex.

Table 3.1 shows estimates of the first-year costs for implementing and operating an in-house UM system for 500 users. The continuing costs, from the second year onward, will include hardware and software maintenance (at 10% of initial costs), a system administration person, and software upgrades, all of which may amount to $1 10,000 each year.

Table 3.1: First-Year Costs of UM System
Cost Items (500 users) | Estimated Costs
Software licenses ($300 each) | $150,000
Hardware and OS (redundant) | $60,000
Integration work (2 person-years) | $150,000
System admin (1 full-time person) | $80,000
First-year cost estimate | $440,000

The total monthly fee for UM from a competitive service provider would likely be in the $20 to $30 range, or perhaps $12,000 for 500 users (i.e., $150,000 annually).

The large first-year costs for acquisition and installation so outweigh the outsourced charges that the managed UM service linked to IP-Centrex shows a worthwhile savings even after 7 years, which probably exceeds the viable system lifetime. Some advantages from owning an on-site UM system, such as better security control and immediate system management action, can be identified. These should be evaluated against the relief from management headaches that a well-managed service can provide and the choice can then be based on the organization's requirements and culture.

Speech-Enabled Call Routing

Autoattendant services, which are usually available as a standard part of a voice-mail package, have not been as widely used with Centrex as with PBX systems. However, there are some mass-market Centrex applications where it is important to have an autoattendant front end.

Call routing systems are now available that have high-performance automatic speech recognition (ASR) abilities and that can work well for large, distributed organizations with hundreds of users. Such a system can be very useful for inbound, outbound, and internal calls.

For inbound communications, ASR is easier and faster to use than touch-tone dialing. Internal callers can control some features, such as initiating conference calls and forwarding calls to selected destinations, without using specific codes or keys. On outbound calls users do not need to remember dialing codes or long number sequences to call the required party. For all callers, an ASR system provides round-the-clock assistance and can be cost-effectively integrated with an IP-Centrex softswitch.


Contact Center Applications

Simple uniform call distribution (UCD) has been available for some 20 years on digital Centrex offerings. The limited features with UCD are suitable only for some small call centers and are not widely used.

Full-scale ACD, based on Centrex, was first launched by NYNEX in New York City in 1990. The vital core of an ACD service for a contact center (or a multimedia call center) is the management information system (MIS) system, which delivers real-time statistics to the supervisors, and printed, historical reports to management and the system administrator. BT (formerly British Telecom), for example, identifies "FeatureNet Call Centres" as a major part of its digital Centrex service.

The design and implementation of contact centers has been one of the busiest parts of the telecommunications industry in the past decade, employing much of the talent available. The acceptance of Centrex-based ACD services has been disappointing and has not nearly matched the growth rate of premise-based contact centers over the past few years in North America. This lack of enthusiasm was due to the perceived problems of integrating in-house systems and software with a remote switch, together with concerns over the lack of administrative control.

The generally accepted allocation of operating costs for a contact center is 50% for network services, 40% for personnel, and 10% for equipment maintenance. A CO-based Centrex-ACD service can save up to one-half of the trunks that would be needed for a separate ACD system on the customer's premises. This savings is made possible because the call queuing occurs in software at the CO, rather than farther out in the network.

Also, a CO-based service can grow one line at a time, up to an open ended maximum. It is easy to handle seasonal business with Centrex, since lines can be turned up and down at short notice, adjusting costs in line with demand. The staffing aspects of contact center operation can be addressed through Centrex by taking the work to the agents, rather than bringing the agents to the center. A standby, part-time pool of agents, who work from their homes, can be easily arranged over a managed IP-WAN.

The availability of IP-Centrex, based on a common voice-data network, should remove management's inhibitions regarding Centrex-based contact centers. In the IP-based environment the physical locations of applications, including call management and customer relationship software, and of agents, are no longer significant concerns.

The shortage and cost of competent people to implement and maintain complex contact center configurations can, hopefully, be addressed by the service provider and not remain as a problem for the customer. The outsourcing of contact center business, which now employs 5% of the working population in the large financial-center cities, could become the main driving force in the acceptance of IP-Centrex services.


Managed Networks

The voice and video traffic that is directed by an IP-Centrex controller travels over the LAN inside a building or campus generally at a nominal bit rate of 100 Mbps to and from the desktop. Increasingly, Ethernet links are being created over virtual local area networks (VLANs) between buildings in an urban area, with an operating range of up to at least 20 miles (30 km). In this way metropolitan area networks have been absorbed into VLANs, so that building boundaries have become invisible. The transport of VoIP packets over WANs is still a challenge and requires careful consideration.

LAN Considerations

Most LANs will need some enhancement to support VoIP, if only to provide the in-line power for telephone sets. The LAN for voice/video over IP must be switched, not shared, and any device used in the LAN should be QoS-aware and/or -capable. Admissions control to the LAN will be done in a gateway.

The voice or video bandwidth requirements depend on the codec used in the endpoints. The two voice encoding standards that are commonly used in IP phones are G.711, which was the original ITU recommendation for pulse code modulation and usually generates 64 Kbps per speaker, and G.729 Annex A, for which 8 Kbps must be reserved for each voice transmission.

The G.723.1 recommendation has been extensively used as a low bit-rate encoding algorithm in VoIP gateways, running at 5.3 or 6.3 Kbps, but it is processing-intensive (at around 30 Mips) and therefore has not been widely implemented in IP telephone sets.

If we add some consideration for packeting overhead and round up the numbers somewhat, for bandwidth estimating purposes the figures of 80 Kbps for G.711 and 20 Kbps for G.729A are reasonable.

It is essential to have coding conversion capability at the transition point from one network to another, to allow for telephones, softphones, or video units with differing codecs. This conversion may take place in a separate subsystem, known as a transcoder, or it might be a DSP card in a slot of a router at the edge of a LAN. A practical budget of $30 to $200 per port (i.e., per user) should be allowed for LAN upgrades. Some reprogramming of the edge router will be needed for voice or video, as no PSTN access was likely when the network handled only data.

E911 service requires that local dial tone be provided to each physical location, which will usually be a discrete LAN, and may then be easily identified. However, if each location is just one domain within a larger VLAN (which spans multiple sites), then identification of a specific location will be much more difficult. For details regarding the challenge of meeting E.911 requirements with IP-Centrex, see "Concerns with IP-Centrex" in Chapter 6.

WAN Requirements

The predominant service for carrying VoIP traffic is the VPN. A VPN delivers multiple service classes and interoperates well with the customer's own IP networks, at lower costs than a customer-managed network. A typical example of the four classes of service in an international VPN appears in Table 3.2.

Table 3.2: Service Classes in an IP-MPLS VPN
Class Of Service Description | Platinum Premium Voice | Gold Multimedia Low Delay | Silver Premium Data | Standard Best Effort Data
Optimization criteria | Delay and jitter | Delay | Packet loss | Price
Protocols | UDP or RTP | UDP or TCP | TCP | UDP or TCP
Queue length | Small | Small | Medium | Large
(Source: Adapted from T-Systems division of Deutsche Telekom.)

One of two complementary architectures is used for most VPNs, namely MPLS or IP security (IPsec). Although MPLS is not strictly essential to carry voice/video over a WAN, it is certainly preferable and is used on well over 50 large carrier networks. MPLS is an IETF standard that was derived from Cisco's proprietary Tag Switching technique; it provides 15 priority classes (through a 4-bit header) for packets being transported over a network.

The use of MPLS enables time- and bandwidth-sensitive traffic to be carried on IP networks, and effectively eliminates IP "over" ATM. From the customer's viewpoint, network design is greatly simplified, as there is no need to define virtual circuits between pairs of locations and there is no customer participation in routing design or changes. The carrier does the traffic engineering and guarantees the bandwidth and delay per class of service (i.e., for each voice or video application). The customer also has addressing freedom, as there may be identical local IP addresses within two or more networks on one VPN. The architecture of a multisite VPN, connected to the Internet for access by some occasional users, is shown in Figure 3.7.

Click To expand
Figure 3.7: Typical VPN configuration.

The MPLS-equipped customer edge routers are not mandatory at small sites. The gateways are scaled for the number of users at a site (probably from 100 to 10,000) and contain the security features, such as shared-secret keys or digital certificates, and firewall facilities.

The carrier's managed network must have provider edge routers that are MPLS-equipped and core label switching routers. The managed VPN uses label distribution protocol (LDP) that delivers the connectionless network characteristics. The central VPN network manager console, with its directory services manager, is at the service provider's site but may be duplicated at the customer's main site to share some system administration functions.

IPsec is used to create VPNs over the public Internet and its only applicability to IP-Centrex would be, potentially, for communication with individual users in the home office situation. This use would be dependent on each Internet connection meeting the delay and jitter criteria of the service, while the use of IPsec would do nothing to improve the QoS obtained from the Internet.


Local Access Facilities

With an MPLS-based WAN providing the public network links for IP-Centrex, the customer is essentially concerned about the bandwidth to and from the network. The typical IP-VPN service provider defines a committed access rate (CAR), which is comparable to the more familiar committed information rate that was defined for frame relay services. For VoIP the CAR should be a minimum of 20 Kbps for each active voice conversation over a symmetrical, digital bit stream, and with an Ethernet interface at the customer's premises.

For a single user (e.g., at home) with a PC, a standard, analog dial-up connection and a 56-Kbps modem are adequate to handle voice conversations through the IP-Centrex service. Where video communications are used this minimum bit rate requirement rises to 200 Kbps. At sites with multiple users (i.e., anywhere other than the smallest home office) the local access is now generally described as a broadband link, or a "fat pipe." This is in contrast to legacy Centrex, which in most cases is delivered by each phone line using one of the copper wire pairs (which are utilized as "thin" pipes in this case, as a bandwidth of only 4 kHz or 64 Kbps is required).

Broadband used to be defined, over the past decade, as bit rates above 45 Mbps (DS-3) in North America, or 34 Mbps (E-3) in other countries. But common usage now seems to define broadband as referring to any bit rates higher than 128 Kbps. An informal survey of documents from 14 countries showed that the lower threshold considered for broadband ranged from 200 Kbps to 30 Mbps.

We can assume that today's multimedia applications demand a symmetrical 1 Mbps per active individual user. Table 3.3 shows the desirable available access bit rate for different types of premises.

Table 3.3: Desirable Access Rates for Different Organizations
User Category | Mbps Needed
Home office | 1
Small business | 1
Medium business | 10
Large business | 100 or more
Regional hospital (including research) | 1,000 (1 Gbps)
Local hospital | 100
University/large college | 1,000 (1 Gbps)
High school | 100
Primary/elementary school | 10
Major government offices | 100
District government offices | 10
Municipal offices | 10
Large library | 10

Broadband Availability

For some years the telecommunications industry has worked hard on various methods to provide high-capacity access to the Internet. The result of this heavy investment (some of which is less valuable now than its original cost) is generally a competitive environment of broadband access availability.

We can identify seven ways to obtain broadband connectivity (that is, appropriate for business VoIP applications) between on-premise LANs and managed WANs, as follows:

  1. Leased digital links using legacy TDM technology are available as DS-1 (i.e., "Tl" as it is commonly known) at 1.5 Mbps, or DS-3, at 45 Mbps. Outside North America the equivalent multichannel digital services are El (at 2 Mbps) and E3 (at 34 Mbps). With the tariffs charged by the incumbent telcos these services are not attractive, but under competitive conditions may still have a role to play.

  2. Switched ISDN channels are at basic (144 Kbps) or primary (1.5 or 2 Mbps) rates. ISDN-PRI was widely used in the early years of rapid growth with the ISP business but, again, is not now competitively priced in most areas.

  3. DSL services are widely offered in many countries at attractive prices.

  4. Cable modems (CMs) are linked by hybrid coaxial/optical fiber to the two-way network of the local monopoly cable TV carrier.

  5. Digital cellular wireless services have moved into the 2.5G and 3G developments. These services have the advantage of mobility and may also be of limited usefulness for fixed locations.

  6. Microwave radio services for broadband access are primarily of the point-to-multipoint type. These high-frequency technologies, such as local multipoint distribution services (LMDS), generated considerable interest when licenses were sold in the mid-1990s. Unfortunately, most of the new fixed-broadband radio carriers have collapsed financially and this choice is not widely available.

  7. Extended Ethernet (i.e., native IP transmission) over optical fiber is available in many urban areas from multiple service providers.

We should note that "sky-based" communications services, whether from geostationary or low-earth-orbit satellites, are not suitable for any interactive VoIP applications, because of either significant transit delays or serious unbalance between the up and down-link data rates.

One major advantage that will become obvious with IP-Centrex is that customers can afford to rent a second broadband access link to their main locations, providing better availability of service than was feasible with legacy Centrex. On a fair accounting basis, the true cost of the copper wire component of a local loop (the traditional "last mile") is around $10 per month. The actual cost of local access bandwidth to support one IP-Centrex user, in a medium-sized office of 100 users, will be less than one-half of that amount. This leaves an ample margin to pay for a second access link, perhaps at a degraded bit rate, that is both physically and service-provider redundant.

Four of the service types that are summarized in the following sections are worthy of further consideration.

DSL Services

DSL services use up to several megahertz of bandwidth over the local loop, compared with conventional, single-carrier modems, which are restricted to the 3.4 kHz that is generally available for audio telephone signals. This means that DSL signals cannot pass through any switch (i.e., PBX or CO) and, because of high attenuation at the higher frequencies, the usable range is limited to a few miles over the standard 24 American Wire Gauge (AWG) copper wire. The main characteristics of several types of DSL are summarized in Table 3.4. Clearly, the available bit rate is inversely proportional to the distance from the CO.

Table 3.4: Typical DSL Service Parameters
DSL Type | Average Bit Rates (Downstream: Upstream) | Max. Distance (Miles: Km)
ADSL (asymmetric) | 1.5 to 6 Mbps: 160 to 576 Kbps | 3.5: 5.5
ADSL "lite" | 128 to 384 Kbps: 64 Kbps | 3.5: 5.5
High Rate over two pairs (HDSL) | 1.5 or 2 Mbps: 1.5 or 2 Mbps | 2.5: 4.0
Single-pair symmetrical (SDSL) | 1.5 or 2 Mbps: 1.5 or 2 Mbps | 1.8: 3.0
Very high bit rate (VDSL) | Up to 52 Mbps: 1.5 to 6 Mbps | 0.8: 1.3

In the customer's premises the DSL modem provides an Ethernet interface to the internal LAN, while at the serving carrier's site the DSL terminates on a digital subscriber line access multiplexer (DSLAM), which is linked directly to the IP or ATM WAN on the trunk side. With ADSL service, an analog channel is reserved for one conventional telephone line, below the frequencies employed for the DSL. But in a fully IP, packet-only access environment, which we can call the all-digital loop (ADL), the full bandwidth over the copper wires can be exploited and there is no need for frequency splitters at each end, resulting in lower equipment costs. This is illustrated in Figure 3.8 for the home office situation, to which dc power can be sent for the phones, because of the end-to-end copper loop.

Click To expand
Figure 3.8: All-digital loop architecture.

Most DSL customers are currently using the service for Internet access from their homes and small businesses. In North America, in late 2002, there were about 4 million DSL users, compared with 7 million cable modem subscribers. In Britain and several other Western European countries, the adoption of DSL remained extremely low, because the incumbents were slow to "unbundle" local loops to competitive carriers and prices were kept too high. By contrast, in South Korea over 10 million customers use a DSL connection for Internet access.

We expect that monthly prices for ADSL will settle in the $30 to $SO range, with HDSL at less than $200, and that DSL will be, by far, the most common broadband access service for small offices, such as bank branches, medical clinics, and schools.

Cable Modems

Cable modems, which use the cable TV infrastructure to deliver broadband access, quickly became popular in North America and Western Europe, where there is a fairly high residential cable penetration, with prices of around $30 per month for nominal 6-Mbps service. Some cable carriers also offer a 128-Kbps access service at a lower cost (e.g., $18 per month) to compete with dial-up modems.

For business applications, such as IP-Centrex, CM for broadband access has two serious disadvantages:

  1. Cable TV is a shared service (like an extended, single-cable, LAN), with the worrisome implications of security risk and variable throughput.

  2. The typical cable TV operating company does not share the same sense of service reliability as an incumbent telco.

Next Generation Wireless Services

Next generation wireless services deliver data transmission rates over the digital cellular (or PCS) networks that are similar to those at the low end of wireline capabilities. For IP-Centrex applications these wireless networks primarily serve mobile users and can be valuable as "fixed mode cellular," providing local access redundancy for small offices. For example, it may be worth spending a few extra dollars for a wireless data service to back up a cable connection to a home office.

The so-called 2.5G data capability is now widely available with digital cellular services in two versions. The general packet radio service (GPRS) is an option with GSM that can deliver a data rate of up to 56 Kbps. With the CDMA services, mainly in North America, the clumsily named one times radio transmission technology ( IxRTT) offers up to 144 Kbps throughput. Pricing plans for these services usually add about $15 to the monthly bill, with additional charges for large data transfers.

Even though some mobile phone operators have spent many billions of dollars to acquire national licenses, third generation (3G) wireless data technology is not yet widely deployed. With 3G services, as an extension of GSM or CDMA, there is a promise of data rates from 144 Kbps (mobile) up to 2 Mbps (fixed).

One attraction of these data services is that they support the full range of mobile devices, including cell phones, PDAs, intelligent pagers, and laptop computers. With one-third of our work force engaged in telecommuting, at least on a part-time basis, the synergy between widely available digital wireless and IP-Centrex services will become invaluable.

Extended Ethernet

The extended Ethernet is the transmission of IP data packets over optical fiber, especially dense wavelength division multiplexed (DWDM) fiber, between the customer's premises and a managed network. This is an extremely competitive market in medium-to-large urban areas, with IP over DWDM being sold by ILECs, CLECs, cable companies, and electrical power distributors. Additionally, some organizations, such as municipal and regional governments, may have laid their own optical fiber links for specific applications. In this environment of bandwidth overcapacity, it is possible to obtain a 100-Mbps IP local access link for less than $500 per month, which is almost equivalent to the cost of a tariffed T1 link (i.e., 1.5 Mbps) from the incumbent telco. Against this low rental there will probably be an installation fee (or "service charge") of 10 month's rental, or a 3-year commitment to gain free installation.

Our three concerns with these financially attractive broadband, optical fiber solutions are:

  1. The QoS from the service provider may be diluted because of intense price competition between carriers.

  2. Some vendors are likely to withdraw from this market or fail commercially because margins may be too low to pay for ongoing network management and maintenance.

  3. The optical fiber network of any one carrier may not be able to serve all of the customer's locations in a given city. In spite of complicating affairs for management, we frequently have to cope with a multivendor situation.


Summary of IP-Centrex Systems and Networks

The first IP-Centrex service offerings were based either on an IP-Centrex gateway "in front" of a class 5 CO-based legacy Centrex system or on an IP-PBX server configuration. The delivery of IP-Centrex from powerful softswitches, developed by the large telecom manufacturers, has not occurred as soon as might have been expected.

The integration of IP-Centrex with powerful applications, primarily ACD, CRM, and UM, should be an attractive solution for many organizations.

The widespread availability of broadband access facilities, especially DSL, managed VPNs, and excess capacity on many optical fiber networks bodes well for the cost-effective delivery of IP-Centrex.


Chapter 4: IP-PBX Systems and Applications

Architectures for IP-PBX Systems

During the short history of IP-PBX systems, three different configurations have come onto the market under this title. The first of these is best described as an "IP-enabled" PBX, which is a legacy system based wholly on TDM technology, but equipped with IP cards, or gateways, to support some IP trunks and/or IP phones. Traditional PBX manufacturers, such as Avaya, Nortel Networks, and Siemens, at first favored this approach, because it enabled their customers to take advantage of VoIP in their long-haul networks and to use some LAN-connected phones.

The second wave of IP telephony combined packet and circuit-switching technologies into the one box, with the intent of obtaining the advantages of both systems while continuing to use existing digital phones and interface cards. Alcatel was the first major telecom manufacturer to adopt this approach; Mite1 and NEC have also now made their hybrid architectures into a major selling point.

The third direction is to have a "pure" IP-PBX, with a common control/call processing server and all the stations connected through a standard Ethernet LAN, while supplying gateways to support existing digital and analog endpoints. This development was started by a few companies that were not previously in the PBX business, such as Shoreline, 3COM, and Selsius (which was acquired by Cisco). As these pioneering vendors, now led by Cisco, have shown that IP-PBXs can be successfully sold and implemented, the large suppliers of circuit-switched systems have fallen into line and announced their own pure IP-PBXs, with client-server architectures. By the end of 2002 not one PBX manufacturer was devoting significant funds to new circuit-switched developments, and all eight major companies in the enterprise communications systems market are committed to IP telephony.

These developments took place in a voice-switch marketplace that, following a growth spurt in the late 1990s, was dismal financially. Sales of PBX lines fell cumulatively by at least 10% in each of the 3 years from 2000 to 2002. The shares for the North American business phone system market in 2001 are shown in Figure 4.1. This chart includes all types of PBXs, key telephone systems, and lines added to Centrex services, for a grand total of about 11 million stations.

Click To expand
Figure 4.1: Business telephone line market in 2001. (Reproduced with the permission of Nortel Networks. Copyright 2002 Nortel Networks, All rights reserved.)


Current IP-PBX Systems

The IP-PBXs that are on the world's enterprise marketplace come from a variety of backgrounds and include at least one model in each of the three classes that are defined here. We include reviews of IP-PBXs from eight suppliers, which sell their systems in many countries. Since it is too early in the development of these products to decide which are winners or losers, we have focused on the different approaches taken by the manufacturers, while not attempting to describe each system in great detail. These reviews are listed by alphabetical order of the manufacturer's name.

Alcatel

Alcatel introduced its OmniPCX 4400 in 1996, as a call server that handles TDM and IP user terminals, with the same services, set of features, and standards of reliability of other digital PBXs. The 4400 is available in four cabinet sizes, as follows:

  1. Media Gateway (rack-mounted) for up to 64 users;

  2. WM1 (wall-mounted) for up to 150 users;

  3. M2 (floor-standing) for 100 to 400 users;

  4. M3 (three cabinets) for up to 1,000 users.

One hundred OmniPCX nodes can be connected into a network, supporting up to 50,000 stations. The network may be based on TDM trunks or packet (ATM, frame relay or IP) transmission technologies. The architecture of this system is illustrated in Figure 4.2.

Click To expand
Figure 4.2: Architecture of Alcatel's OmniPCX 4400.

The PWT 4073 handset uses Alcatel's Private Wireless Telecommunications cellular technology, which is designed for higher user density environments, with up to 10,000 Erlangs per square kilometer. One PCX 4400 server can be linked to 256 base stations and 1,000 wireless users.

Alcatel sells four proprietary telephones (under the trade name Reflexes) which are all digital sets with a display. The Advantage 4035 and Premium 4020 models have an integrated alphabetic keyboard and can include a built-in IP enabler. The more recent version of this module has a 10/100 Mbps Ethernet interface and a mini-LAN switch function, for an adjunct desktop PC connection (so that a desktop PC may be connected into this module, enabling a telephone and the PC to share one LAN outlet). The integrated IP enabler can be fed with DC power remotely, from an OmniPower Patch Panel that operates to the IEEE 802.3AF standard. These two phones show the design influence of the Minitel terminals that were extensively used on France's information network prior to the Internet, but are likely to be relatively expensive when equipped for IP operation. For the two lower-cost phones to be used in the IP mode an external IP enabler is needed.

Alcatel also has a suite of contact center applications, known as OmniTouch, which is integrated with the 4400 system. The agents' stations may be based on the model 4004 or 4035 phones, or may use the Alcatel4980 telephony application that runs on a PC, providing groupware and call management functions.

With this hybrid voice communications system, Alcatel has returned to the crowded North American market, where one of its predecessor companies, IT&T, once had a presence. Alcatel has gained some good PBX accounts in the United States with the OmniPCX 4400, displacing Centrex service in a few cases, and it is obtaining significant dealer support in Canada. In some Latin American countries Alcatel has achieved a major share of the PBX and CO systems markets, displacing Ericsson over the past decade. The company also has a strong presence in the data switch, network management, and VPN businesses through its acquisition of Newbridge Networks.

At the time of this writing, no news of contracts to use the OmniPCX 4400 for managed IP-PBX or IP-Centrex services has been released. Even though this is now a well-established product, it might not be the most attractive vehicle to outsourcing service providers, for the reasons that are described in the "Concerns" section of this chapter.

Avaya

Avaya was spun off from Lucent Technologies in the year 2000, so that the company now provides voice and data network products primarily for enterprise customers. Through its acquisition of Octel, Avaya is the world's largest supplier of voice mail systems.

When the early IP-PBXs first came onto the market, from data switch suppliers, Avaya appeared officially to denigrate these products and to emphasize the power of its Definity systems. After a period of uncertainty about its direction, the company now describes the migration to IP telephony as being "an imperative and a necessary strategy for business."

Avaya introduced a family of media servers and gateways in mid-2002, as its second generation of IP telephony systems, under the name Enterprise Class IP Solutions (ECLIPS). All the features of the Definity range of PBXs and contact center functions are implemented with MultiVantage software that runs in these servers. Some of the capabilities of the three media servers are summarized in Table 4.1.

Table 4.1: Avaya Media Server's Capabilities
SERVER MODEL | S8100 | S8300 | S8700
Operating system | Windows 2000 | Linux | Linux
BHCC | 5,000 | 50,000 | 300,000
Stations | 450 | 450 | 1,200 IP (4,000 digital)
Trunks | 300 | 450 | 4,000
Redundancy | No | Yes | Yes

Avaya defines the call processing power of its systems by the number of busy hour call completions (BHCC), which very much depends on the complexity of the processing for each call. For this reason the BHCC number is lower by a factor of two-fifths for contact center calls than for the general mix of calls.

Avaya sells three different softphone packages-one for a desktop or laptop PC, another for pocket PCs that use Windows CE software, and also the IP Agent, which is intended for contact center personnel. There are five IP phones in Avaya's 46xx range, all with built-in speakerphone and power over the LAN technology. The most expensive model has a full-color, touch-sensitive screen for Web access browsing and six integrated telephony-related applications. A three-port switch base is available for three of the Avaya IP phones, so that a PC can share one LAN outlet with the desktop phone. All of these phones, except the basic model, have an infrared port for communication with a PC or PDA.

Avaya has developed its reputation as North America's leading supplier in of call center solutions, which are integrated with the Definity PBXs. The company now sells a multimedia contact center system that can interwork with several other major PBX and IVR systems. The modular architecture of Avaya's Interaction Center software provides for the management of voice calls, e-mail, Web-based interaction, and contact center agents, while providing computer telephony integration to the three most commonly used database systems.

Avaya supplied 25 ECLIPS servers to the month-long World Cup of football/soccer to connect 7,000 voice endpoints in Japan and South Korea. The IP WAN for this event successfully carried about 100,000 phone calls each day, in addition to conventional data traffic, thus proving the viability of the mass adoption of Internet telephony.

Cisco Systems

Cisco Systems cannot claim to have invented IP-PBXs, but it certainly established the market for these systems by making IP telephony legitimate. Cisco's IP-based system is known as the Architecture for Voice, Video and Integrated Data (AVVID), and this product started shipping in mid-2000. Two years later Cisco claimed to have shipped 800,000 IP phones and, more impressively, to have equipped 6 million ports with power for IP phones.

Cisco's CallManager is the software-based call processing component of the IP telephony solution, extending features and functions to packet telephony devices such as IP phones, multimedia applications, and VoIP gateways. Additional data, voice, and video services, such as integrated messaging (the Unity product), multimedia conferencing, collaborative contact centers, and interactive response systems, may be linked with the IP-PBX through an open telephony API.

Cisco's CallManager is installed on a media convergence server (in the MCS 78xx series), which is a standard computer from manufacturers such as HP-Compaq, Dell, or IBM, with the exact specification set by Cisco and absolutely no applications other than telephony running in the MCS. Release 4.0 of CallManager can support up to 50,000 users and a conceptual network, with multiple voice servers, as illustrated in Figure 4.3. This software release also supports SIP, but Cisco believes that media gateway control protocol (MGCP) will be the protocol of choice within an enterprise for IP telephony.

Click To expand
Figure 4.3: Cisco CallManager clustering.

Concerns about availability and reliability are addressed by using multiple servers, which may not be in the same location, and by having dual gateways to the WAN, which is not shown in Figure 4.3.

While the typical IP-PBX configuration is deconstructed into multiple components (communications server, LAN switch, trunk gateway to the PSTN, line gateways for digital and analog phones, and router to the IP-WAN), Cisco does have an all-in-one-box chassis-based CallManager 7750 system, for branch offices with from 50 to 250 users. There is also a 4225 system, for up to 20 users, serving phones and PCs, with a built-in data switch and router.

Cisco sells a number of models of desktop telephones-including the 7960 (6 lines), 7940 (4 lines), and 7910 (single line), together with an IP conference phone that was developed jointly with Polycom. Each of these phones includes a three-way switch, for 10- or 100-Mbps Ethernet connections, and can be dc-powered over the LAN from a Cisco distribution unit, situated in a telecom closet. The softphone product is good for collaborative working between PC users. Cisco was expected to have its own wireless phone, designed for the IEEE 802.11a standard, on the market in 2003, while wireless phones from Spectralink and Symbol, working to the 802.1 1b protocol, may be used with AWID.

For users to do their own system administration, such as call routing and screening, Cisco's Personal Assistant has speech recognition navigation with all its options linked to the class of service established for each user. Since an IP phone may be moved to any corporate network outlet, a report sponsored by Cisco and published by the Telecom Applications Research Alliance (TARA), in the spring of 2000 optimistically claimed that "the effort required for Moves, Adds and Changes is only 25% of that typical for a PBX of the same size."

We should note that Cisco's Unity voice mail system can connect simultaneously to CallManager and to legacy PBXs. On the other hand, it is still difficult to integrate between Unity and existing voice mail systems, so owners of Meridian Mail and Octel systems will need to replace these with the Cisco product, in those configurations where CallManager has been installed with TDM PBXs.

Cisco's well-known CEO, John Chambers, has been quoted as saying, "Data-voice-video integration is huge for us because it forces my customers to redo their networks," and this certainly appears to be coming true.

Cisco has signed agreements with several large service providers to support convergence of multiple networks with the AVVID solution, even while the users retain ownership of their systems. These situations may be classified as managed IP-PBXs and managed IP-Networks, but will not be the same as IP-Centrex.

Verizon

Verizon, in the United States, will help customers avoid implementation difficulties by providing up-front network and physical site assessments that will identify potential migration pitfalls and pinpoint data network equipment that requires upgrading to handle voice traffic. Verizon will also do comprehensive planning to develop the processes and procedures necessary for successful convergence of their customers' multiple networks.

Cisco and Verizon also joined forces to market high-speed, secure, and reliable work-at-home services, over an IP-enabled network, for advanced teleworker programs. This offering certainly sounds as though it involves IP-Centrex.

C & W

C&W, with its Convergence PBX solution, can deliver IP-PBX, IP-LAN, and IP-VPN services to medium and large-sized businesses on a global basis.

The first major customer for C&W's Cisco-powered network was the well-known Marks & Spencer retailer, with over 300 stores in the United Kingdom. C & W has a private MPLS-IP network, which will be dedicated to voice, video, and data traffic from its Convergence PBX customers, and can deliver customized QoS parameters to national or international users.

Mitel Networks

Mitel Networks, now a private company owned by one of its original founders, uniquely concentrates on the enterprise voice communications system market. Since it was started in the mid-l970s, Mitel has been sold several times, but has managed to survive and attract the appropriate talent to move confidently into the IP telephony era.

Mitel has always manufactured several models of PBX and for many years had an especially good reputation with reliable telephone systems for small businesses. The company claims that it will continue to develop its SX-200 and SX-2000 TDM-based PBXs, while putting a lot of effort into two IP-oriented systems.

Mitel introduced its 3100 Integrated Communications Platform (ICP), which was designed and is manufactured in Britain, in late 2001. This small, rack-mounting system combines a complete set of voice features, including integrated voice mail and autoattendant, a 10/100Mbps Ethernet LAN switch, and a router. The voice switch may be configured as a PBX, a key telephone system (KTS), or a hybrid, supporting up to 24 IP phones and 10 analog stations (with an extension module). Up to 100 IP addresses are available with the 3100 ICP, so some 75 data devices, such as PCs, printers, or servers, could be attached. The 3100 ICP is intended for stand-alone offices or similar locations, but cannot be used as a satellite system in a tightly coupled corporate network based on Mitel's more powerful call servers.

Mitel's 3300 ICP is intended for medium-to-large organizations, while inheriting all of the telephony features and networking capabilities of the SX-2000 digital PBX (which was first launched 20 years ago), for up to 700 users from one call server. The rack-mounting call controller is complemented by an analog services unit (for lines and trunks) and a network services unit (for up to 16 T1/E1 or ISDN/PRI links). A Mitel 3300 configuration is shown in Figure 4.4, with a model 3340 ICP serving a remote location and IP stations in a small remote office connected directly to the network.

Click To expand
Figure 4.4: Converged communications in the enterprise by Mitel.

Although Figure 4.4 shows only IP phones, the 3300 ICP does include a TDM switching bus, so that it can support Mitel's preexisting digital phones through direct single-pair wiring. This Mitel system works with any of the commonly available data switches in the networking market, although the initial versions of Mitel's IP phones used a proprietary protocol.

The 3300 ICP has embedded voice mail, with just a nominal charge for user licenses with the first 20 DSP ports, and this system has full autoattendant features. Mitel sells the model 6500 speech-enabled attendant, which includes toll fraud prevention and mobility features, for forwarding calls to variety of numbers, based on a preset schedule. The 6500 package also provides natural speech navigation of its unified messaging function that may be integrated with Microsoft Outlook.

An easy-to-use system management subsystem, with different sets of tools for system configuration, administration, and simple moves and changes, is also supplied as part of Mitel's 3300.

NEC

NEC has grown to be a corporate giant while, unlike most of its competitors, keeping the same name for over a century. Within a wide range of telecommunications and electronics products, NEC is a major force in PBX and CO systems. The company is the third-largest supplier of enterprise voice switches in the United States, conducting the development of its PBX systems in Dallas, Texas.

NEC sells three sizes of PBX systems, ranging from the NEAX 1000 through the 2000 and the 2400. Of particular interest with IP telephony developments are the NEAX 2000 Express, 2000 IPS, and the 2400 IPX.

The NEAX Express was one of the first IP-oriented PBXs to be announced by a legacy PBX maker and is based on a unique design. NEC took a different approach by compressing its existing NEAX 2000 into a few circuit cards and sharing one chassis, with a common power supply, between the small PBX and three cards that operate as a standard Windows NT server. This approach is shown in Figure 4.5.

Click To expand
Figure 4.5: NEAX 2000 Express system.

This configuration provides IP communications to Microsoft BackOffice Server, with computer-telephony integration, so that voice mail, autoattendant, and unified messaging can be delivered to small and branch office environments. Third-party developed applications, such as ACD and Interactive Voice Response (IVR), can also run in the NT-based server. The basic model of the NEAX Express supports 36 digital and 8 analog stations, but can be expanded to 100 users. It employs the reliable voice-switching matrix from the widely used NEAX 2000 and, while it can deliver the applications promised for IP telephony, does not have interfaces for IP phones or to IP WANs.

NEC launched its NEAX 2000 Internet Protocol Server (IPS) at the end of 2001 as a medium-sized product that is complementary to the NEAX 2400. The 2000 IPS includes both packet and circuit switching in the same system and can be configured in any mix from all TDMs to 100% IP telephony, with up to 500 stations.

Rather than producing a series of IP telephones, NEC sells an IPW-2U adapter, which fits into the bottom of its digital Dterm series E phones. This IP enabler dynamically acquires all the information it needs to interoperate with a NEAX IPS or IPX.

The NEAX 2400 IPX is a version of NEC's large PBX that supports IP telephony on the trunk and line sides, while retaining its standard switching fabric. This IP-enabled PBX can be closely integrated in a network with the NEAX Express or 2000 IPS, as well as with earlier 2400 ICS. This architecture allows customers to migrate to IP telephony, whether they have a new or an upgraded system.

The NEAX 2400 has been on the market through various developments for nearly 20 years and is a powerful PBX with distributed control processing that can have up to 24,000 lines on one system. This PBX has excellent ACD functionality and has achieved a reputation for reliability, as shown by its widespread use in hospitals and military bases.

Nortel Networks

Nortel Networks claims that it is the only telecom equipment supplier to "remain in both camps," believing that it is absolutely necessary to give the customer the choice between a TDM-based PBX, for the lowest single site costs, and an IP-PBX, where that may make sense.

Nortel is certainly the leader in providing IP-enabled telephony, through an Internet Telephony Gateway (ITG) Trunk card, which plugs into a Meridian 1 PBX and may be programmed to support trunks with an IP-network. Another version of this ITG can have up to 96 users connected to one card on the line side, so that the capacity of Nortel's Meridian Option 81C can go up to 16,000 IP phones. Nortel's ITG Line Card actually has 24 DSP ports.

Most of Nortel's large PBX customers have implemented these ITG cards to carry voice traffic over IP long-haul networks, and this was an excellent way for these organizations to gain VoIP expertise. Microsoft Corporation, for example, connected 87 Meridian 1 PBXs over its IP-VPN and recovered the cost of these ITG installations, with long-distance savings, in less than 6 months.

Nortel offers two remote office units, the models 9110 and 9150, which support IP phones, but overcome the problems of local calling and emergency 911 requirements by using BRI/ISDN trunks. These units have a key capability of dynamic fallback, even during a conversation, between an IP network and the PSTN. If the trunk channel over the customer's IP-VPN fails or degrades badly, the call is switched to the PSTN, but it can return automatically to the IP network upon restoration of service, saving the customer money.

A variety of client endpoints is available for VoIP use. Nortel has two IP phones (the i2004 and i2002), the i2050 softphone, software to make the Palm Pilot SIP-enabled, wireless phones made by Symbol, and an IP-adapter base for the 39xx series of digital sets. If a Nortel IP phone and a PC are to share one LAN outlet, then a three-port switch adapter base for the i series phones must be purchased. The use of these peripherals in a CSE 1000 configuration is shown in Figure 4.6. Nortel reports that some early IP telephony installations used a dedicated LAN, with no data traffic on the same wiring.

Click To expand
Figure 4.6: Succession CSE 1000 configuration. (Reporduced with the permission of Nortel Networks. Copyright © 2002 Nortel Networks, All rights reserved.)

Previously existing subsystems for unified messaging (Call Pilot), contact centers (Symposium), and system management (Optivity) have been adapted to interface with the CSE 1000, which is Nortel's enterprise-level, IP-oriented call server, using the brand name Succession. One CSE 1000 can handle up to 1,000 users and at least 10 servers may be in one network. This server uses the same UNIX-like operating system as Nortel's smaller TDM PBX, the option 11C system, so that it was fairly easy to transfer all 450 telephony features to a pure IP architecture.

The Succession Media Gateway, the unit that provides links to WANs, uses TDM trunk cards that are the same as those purchased for legacy Meridian PBXs, delivering a major cost saving to customers. This media gateway has some local call processing capability and is, therefore, useful for remote locations to provide service survivability.

Nortel's multimedia exchange system, the CSE-MX, is a good example of the benefits that come with IP telephony and new protocols, such as SIP. The CSE-MX is a multimedia application server, which facilitates video conferencing and instant messaging within an enterprise network. With multimedia services the setup of a multiparty video conference, between preregistered participants, should be feasible with a few mouse clicks, and collaborative working between remote offices is greatly improved by the sharing of Web sites, files, visuals, and electronic whiteboard.

The CSE-MX also supports dynamic registration (i.e., "find-me and follow-me" service) for mobile and telecommuting users, and provides a personal call agent. This function can be used for call screening and call routing to user-defined locations, which should result in the need to process fewer voice and electronic mail messages.

Siemens

Siemens purchased three major PBX makers, based in the United States, Belgium, and Britain, during the early 1990s and so has the largest share of the worldwide installed base of PBX systems. The company also claims to have sold more digital CO ports, at well over 100 million, on its EWSD system than any other telecom manufacturer.

For small and medium-sized enterprises, Siemens offers the HiPath 3000 family of IP platforms, with the user capacities that are stated in Figure 4.7. These systems can be linked in an IP-based network with the AllServe 150 applications processor, to support up to 1,000 users.

Click To expand
Figure 4.7: Capacity of HiPath 3000 call servers.

Each of these call servers is available in a 19-inch rack-mounting form (the 3300) or as a cabinet, which is wall-mounting (3550) or floor-standing (the HiPath 3750). For markets with European ISDN standards, Siemens also supplies two smaller systems, which are not strictly IP-PBXs: the HiPath 3150, for up to 14 users, and the HiPath 3250, with two basic rate interface (BRI) ports.

In association with its HiPath systems, Siemens introduced a range of optiPoint 500 phones, replacing the optiPoint 300 sets, which had garnered praise for their ergonomic qualities but could not support in-line dc power over the LAN. Five optiPoint 500 IP telephones are available, ranging from an entry model to the advanced, of which three have a Universal Serial Bus (USB) interface, while four models have a display and loudspeaker. Additionally, the optiPoint 400 phones are multiprotocol sets designed for platform and location independence, while still having a built-in Ethernet interface and power-over-LAN capability.

The Siemens CorNet package facilitates networking over an IP WAN, or the PSTN with the more powerful HiPath 4000 or 5000 platforms, and Siemens emphasizes that applications need only be installed once to be accessible across the entire company and from every workstation. Under the HiPath brand name are Xpression for unified messaging, ProCenter for multimedia contact centers, and Fault Management software.

The HiPath 4000 is an IP convergence platform, available in three models, that supports up to 30,000 users on the largest system. The HiPath 5000 is a pure IP communications system, to which all the features and functions of the Siemens' HiCom300 PBX have been transferred, and which can be installed on industry-standard servers running Microsoft Windows NT or Windows 2000.

Siemens deployed its HiPath 5000 system to support over 1,000 IP phones and soft clients in its new San Jose, California, facility during 2000. A detailed diagram, showing how many of Siemens' IP telephony products may be used, is shown in Figure 4.8.

Click To expand
Figure 4.8: Siemens' HiPath systems and terminals.

The RG 2500 is a VoIP gateway that transforms voice signals into IP packets (or vice versa). The optiClient 330 is a PC-based soft client, using the Windows format. The HiPath AP 1100 and 1140 provide analog ports on the line side. The PhoneMail system is a high-performance voice mail product that was inherited by Siemens from ROLM via IBM.

3COM

3COM Corporation was founded by the inventor of Ethernet and grew to be the largest supplier of LAN interface products. During the last decade the most successful PDA, the Palm Pilot, and the Network Branch exchange (NBX) were also developed by 3COM. The first version of the NBX was installed in customers' premises in 1999 and it quickly became the most popular small IP-PBX in the world. Early in the year 2000, 3COM disappointed many of its customers by largely withdrawing from the enterprise data switch market, in the face of heavy competition from Cisco, but continued to develop and promote its IP telephony products.

The 3COM NBX is now sold and serviced in over 40 countries, gaining a 2% share (some 200,000 lines) of the North American market in 2001.

There are three models in the NBX family and the details of these are compared in Table 4.2, with the largest system being the Superstack 3 (SS3).

Table 4.2: Line and Station Capacities of 3COM's NBXs
Feature | NBX25 | NBX100 | SS3 NBX
PSTN Port Capacity |  |  |
Scalability-maximum device capacity | 25 | 200 | 1,500
Analog CO lines (lines/# cards) | 12/3 | 100/25 | 360/90
ISDN BRI-ST (channels/# cards) | N/A | 96/12 | 360/45
T1/PRI circuits (channels/# cards) | N/A | 72/3 | 288/12
E1/PRI circuits (channels I# cards) | N/A | 90/3 | 360/12
Station port capacity |  |  |
Maximum # business phones | 25 | 200 | 1,000
NBX 1102 business phone (10Mb) | Yes | Yes | Yes
NBX 2102 business phone (10/100 Mb) | N/A | Yes | Yes
NBX 2102-IR business phone (10/100 Mb) | N/A | Yes | Yes
NBX 1105 attendant console | 5 | 100 | 100
NBX pcXset (Softphone) user licenses | N/A | 3, 10, 25, 100 | 3, 10, 25, 100
Analog terminal cards (stations I# cards) | 12/3 | 100/25 | 360/90
Analog terminal adapter (ATAs) | 12 | 100 | 750

3COM sells three IP phones, of which the 2102-IR has an infrared port, for dialing from a Palm PDA, and a three-port switch, with a dual 10/100 Mbps Ethernet interface. The first 3COM IP phone was the 1102 model, which has a 10 Mbps-only hub port and originally showed some mechanical reliability problems with its keypad. 3COM has introduced an interesting 16-port card that allows users to connect Nortel Norstar phones to any NBX system. Since the Norstar sets represent a high proportion of the cost of a KTS, while being very reliable and user friendly, this product would make migration from a Norstar system to an NBX much less expensive and easier for the customer than buying a completely equipped IP-PBX.

There is a full range of digital and analog trunk cards for links to the PSTN, analog adapters, and an H.323 gateway, known as the NBX ConneXtions, that creates an IP-based connection to link an NBX system to other PBXs or H.323 gateways.

A SuperStack 3 chassis provides 400 hours of voice mail storage, which should be more than enough for the practical maximum of 1,000 attached telephone users, and includes four voice mail/autoattendant ports. A total of 72 ports may be activated by a key code, upon purchase of the appropriate license.

3COM's IP-PBX systems have been on the market long enough to receive good reviews from users, and have proved relatively easy to install and administer. The infrastructure capabilities of these three systems are summarized in Table 4.3.

Table 4.3: Infrastructure Capabilities of NBX Systems
FEATURE | NBX 25 | NBX 100 | SS3 NBX
Real-time operating system(VxWorks) | Yes | Yes | Yes
10/100 LAN uplinks | N/A | N/A | N/A
Converged voice and data infrastucture | Yes | Yes | Yes
Hard disk mirroring | N/A | N/A | Optional
Redundant power supply | N/A | N/A | Optional
3Com Ethernet power source support | Yes | Yes | Yes
Self-service moves/adds/changes | Yes | Yes | Yes
Browser-based administration (system and user configuration) | Yes | Yes | Yes
3Com network supervisor V3. support | N/A | Yes | Yes
Telecommuter (IP licenses) | N/A | Yes | Yes
Multisite - networking # H.323 channels/site (ConneXtions gateway) | N/A | 16 | 100
Multisite connectivity-PSTN & PBX nesting (T1/E1 PRI/QSIG & T1/DS1) | N/A | 2 sites T1/DS1 | Up to 11 sites

We should note that the NBX systems are not intended for large networks, but deliver all the capabilities needed for small and medium-sized businesses.


Advantages of IP-PBXs

The relative importance of the advantages that are claimed for IP-PBXs (as compared with legacy digital PBXs) has changed since these systems first appeared in 1997, but the claims are now fairly consistent among the IP-PBX vendors. The positive aspects of IP-PBXs can be summarized in the following points:

  • Use the same Ethernet networks for all forms of telecommunications. This immediately means eliminating the need for separate data and voice cabling installations and, ultimately, for any voice-only wide area connections.

  • Simplify the MAC tasks, since an IP phone, with its built-in intelligence, can be plugged into any outlet on the corporate network. Some early adopters of an IP-PBX claim that up to 50% of MACs can be done by users, without the involvement of any telecom professional.

  • Use a Web-based browser management package to administer the features and configuration of an integrated voice, video, and data network, from anywhere that has network access. The administration of the corporate telephone system now becomes a function of the IT department, which already has the required data networking expertise.

  • Gain access to existing and new applications that run on the organization's network, through an IP phone. Some users may not have access to a desktop PC and others may find it simpler to use a phone rather than a computer. One major law firm, for example, claims that it fully cost-justified its purchase of an IP-PBX because its lawyers were then able simply to use an on-line time-tracking package and bill its clients for more hours in a week.

  • Carry intersite voice and video traffic over the corporate data network, and thus do not spend money on long-distance charges that apply to the PSTN.

  • Have a centralized, reliable call-processing server, which is the core of the IP-PBX, but do not need to deploy other voice switches at the remote, smaller corporate locations. Since the signal transport cost across an intranet is low, the intelligence can be in one place, even as the packet switches are distributed, and considerable expenditure can be saved.

  • An integrated messaging server that is based on industry-standard protocols and processors delivers more storage at much less cost than a proprietary voice mail system.

The issue of replacing TDM-based PBXs, or legacy Centrex, with an IP-PBX is not nearly as clear-cut as these seven advantages might suggest. We can find at least one counterargument to each of these points. For instance, the toll bypass justification for VoIP is not now nearly as powerful as once it was.

The fall-off in PBX sales over the past few years has been partly caused by the economic slowdown, but undoubtedly also results from uncertainty regarding the viability of IP-PBXs and their place in corporate plans.


Concerns with IP-PBXs

We have a number of concerns with IP-PBXs that are specific to these systems and are not identified, in the second section of Chapter 6, as applicable to IP-Centrex. Some of the following considerations may be sorted out over time, but the last four in the list will probably stay with us for years to come:

  • The capital cost of an IP-PBX is still likely to be higher than that of a TDM-based PBX with a similar capacity. In most price quotations that we saw in 2001, the IP-PBX vendor was asking an average of 30% more than for the traditional PBX. By the end of 2004 there will, probably, not be any difference in pricing between the two architectures.

    On the other hand, the manufacturer-supported life of a conventional PBX will probably be limited, as development funds are dedicated to the IP-based systems.

  • Several IP-PBX vendors have launched their product and then changed their plans within a year or two. Additionally, every system includes some proprietary features that make the free interchange of components, such as phones and gateways, difficult.

  • Many of the interesting applications that have been promised with IP telephony have not yet been written, or may exist only for one specific combination of telephone and computer systems.

  • Several manufacturers, such as Alcatel and Mitel, have based their main IP-PBX on a dual-switching fabric architecture, retaining a TDM capability in the same box as an IP-oriented call controller. This complexity must add cost to the system and make fault diagnosis and maintenance more difficult.

    For these reasons, this approach may not be the best long-term investment for the customer. It may be a better strategy to acquire a pure, IP-only system and to support non-IP phones by outboard gateways, which could be moved to other locations as conversions proceed. Because of its complexity, a hybrid TDM/IP system is probably not the right vehicle on which to base an out-sourced IP telephony service.

  • The integration of voice, video, and data signals over an IP network demands a special set of design and implementation skills, which take time and practical experience to acquire.

  • One of the advantages claimed for IP telephony is the cost savings that results from using one system management package instead of two. However, telephony and video conferencing are not just two more applications that will now reside on the corporate LAN. There is a serious risk when management becomes convinced that anyone with some data expertise can plan, configure, and administer a feature-rich, multimedia system. Because organizations still depend on voice communications with their customers and prospects, they cannot afford to eliminate voice system administration expertise entirely.

  • Most of the early installations of IP-PBXs were treated as pilot trials, in conjunction with larger, legacy digital systems. The integration of IP phones into the existing voice mail subsystem and with the number display features of the TDM-based PBX proved difficult and remains insoluble in some cases.

  • Several small office-in-one-box products, including those from Cisco and Mitel, have come onto the market as part of the development of IP-PBXs. We should remember that some major manufacturers, including Nortel and Wang, launched integrated small office systems (at that time including a built-in 3270 controller for IBM mainframe terminals) in the mid-1980s, and that all of these products were dramatic failures. Most organizations have long since decided which manufacturer's data equipment is to be used in their networks and probably are not prepared to change at this stage.

  • Because Cisco controls some 80% of the enterprise-level data network equipment market, the company dominates its accounts, in the same way that IBM was all-powerful in the data processing business of the 1960s and 1970s. Some decisions to buy an IP-PBX were made by the CIO or another senior manager because of this influence, sometimes against the advice of the company's telecom manager.


Comparing IP-PBX Systems

We expect that several of the pure IP-PBX models may be used by various companies, particularly CLECs and other application service providers, to deliver IP-Centrex solutions. In this way, some IP-PBXs will probably form part of the IP-Centrex market, as well as being the competition. In Table 4.4 we compare eight IP-PBX systems on the basis of three criteria.

Table 4.4: Comparing Eight IP-PBX Systems
MAKER/MODEL | ARCHITECTURE | OP. SYSTEM | SIZE RANGE
Alcatel PCX4400 | Hybrid TDM/IP | Proprietary | Large
Avaya ECLIPS | Pure IP | Windows/Linux | Large
Cisco AVVID | Pure IP | Windows | Large
Mite1 3300 ICP | Hybrid TDM/IP | VX Works | Medium
NEC 2000 IPS | Hybrid TDM/IP | Proprietary | Medium
Nortel CSE 1000 | Pure IP | UNIX-like | Large
Siemens HiPath 5000 | Pure IP | Windows NT/2000 | Large
3COM NBX | Pure IP | VX Works | Medium


Chapter 5: IP-Centrex-Prospects and Pilot Trials

Because relatively few organizations have implemented IP-Centrex on a commercial basis and many telecom service providers work in a highly competitive environment, it has been a challenge to obtain information about appropriate case studies. Three examples of good prospects for IP-Centrex service are discussed in the first section of this chapter. The situation of a large Centrex customer, which participated in a limited IP-Centrex technology trial, is then described in some detail. Finally, we include descriptions of several IP-Centrex trials for which some information has been made available. Incidentally, the two longest case studies in this chapter illustrate differing ways by which voice messaging may be made available to Centrex users.

IP-Centrex Prospects

A municipal government that serves a city of over 250,000 people has 900 full-time employees supported by Centrex in 70 locations, some of which are indicated in the map in Figure 5.1. The city's Works Department has a fairly modern 120-station PBX, rather than using Centrex, because it is located outside the serving area of the main Centrex-providing CO. The municipality's Centrex service contract is approaching the end of its 10-year term, during which it has provided each line at an attractive 50% discount off the current rate. A new Centrex contract would look expensive to the city because of structural changes in the tariff within recent years. The CIO of this city, therefore, faces a dilemma regarding the annual telephone service bill of $300,000, with the choice of moving to a network of conventional PBX systems, investing in anew IP-PBX infrastructure, or hoping to use IP-Centrex as being suited to an organization with many small offices. There is a serious drawback with each alternative as the system vendors wind down the development of circuit-switched PBXs; the technology of IP-PBXs seems not yet to be settled and the local ILEC cannot offer a schedule for IP-Centrex availability.

Click To expand
Figure 5.1: Municipal locations.

The city owns an optical fiber network that can be linked into locations housing 90% of its personnel. This fiber is installed in ducts that were primarily used for the copper cables linking traffic lights to the traffic control computer center.

Probably the best solution is to negotiate a 1-year extension to the present Centrex contract and hope that the options become more clearly defined meanwhile.

A newly organized health care corporation needs to integrate the services of four hospitals, located as on the map in Figure 5.2. The hospitals and associated clinics employ about 1,500 phones and 50 fax machines. One-third of the phones are single-line, analog sets and are in patients' rooms. The largest hospital in this group, with about 50% of the lines, has a seriously out-of-date PBX and overloaded voice mail/autoattendant subsystem. A major objective is to present a single image to the public served by the health care corporation, as each site will concentrate on selected specializations to achieve optimum economies of scale.

Click To expand
Figure 5.2: Healthcare network integrates four hospitals.

The corporation's board also intends to implement video communications extensively, within a short time frame, to minimize travel time and expenses, for both professional staff and patients. IP-compatible video-conferencing units from several well-established vendors are now available at very competitive prices.

Because this health care organization is in a small, rural town, beyond commuting distance from a large city, it has great difficulty in recruiting and retaining well-trained telecom professionals. Additionally, this market area is not yet attractive to competitive broadband network providers. A deployment strategy that uses IP-Centrex at the largest hospital and integrates three existing small-to-medium PBXs into the corporate network with IP trunk gateway cards is probably the best solution. TI links leased from the telco will serve sites W and E, while the smaller hospital at N will have frame-relay data service at a fractional TI bit rate.

A solo consultant has been a small Centrex customer for 10 years, working from his home office. The positive side of small Centrex is that lots of features (including calling line ID and three-party conference calling) are bundled into the service with no extra costs, at a rental not much above that for a basic business line. The negatives are that there have been no service improvements for a decade, the service is not well marketed, and no one at the local telco's office is willing to talk about small Centrex. The service provider has, obviously, not tried to mine its customer database or to get new services out to these small businesses. Additionally, this customer has not received one sales pitch from any Centrex reseller, in the last 10 years, to sell competitive services. Another concern is that the electronic business set (EBS), which has digital signaling, uses local ac power and is not on during a power failure.

To provide for good service quality, this small office requires two Centrex lines and needs three "PSTN accesses" so that two calls can be handled simultaneously and a third call can be diverted to voice mail. One of the two physical Centrex lines is defined as analog, to serve a fax machine, and that line is also used for ADSL, providing high-speed Internet access. The total monthly rental for two Centrex lines and three network accesses (not including the ADSL service) is about $80.

Since there are no restrictions on access to competitive services, the consultant rents unified messaging from Sprint (at approximately $10 monthly for 200 minutes of storage), because a single voice mailbox is provided for calls to the Centrex wireline phones and to a cell phone. The ILEC, which provides the small Centrex, has configured its own voice mail service in a way that does not allow call forwarding from any number other than the Centrex line. This customer has installed a total of six outlets in his house, so that he can move phones, fax, or modem around without paying any relocation fees.

For small and home office (SOHO) users, the prospects with IP-Centrex are as follows:

  • All services will use one DSL access line.

  • Some Computer Telephony Integration (CTI) functionality, such as the availability of an on-line dialing list, will be available.

  • Programmable IP telephones that receive DC power over the wires from the CO will be sold at reasonable prices.

  • Integrated UM service will be accessible from a cell phone, or other mobile devices, in most locations, if served by a digital radio network.


Provincial Government Relies on Centrex Services

The government of the province of Ontario, Canada, has nearly 70,000 direct, full-time employees working for its ministries and agencies, including the Ontario Provincial Police (OPP). These workers are distributed across the geographically large province, in some 2,000 buildings, serving the population of approximately 11 million citizens. In the early 1990s the provincial government had a policy of moving some large ministerial head offices out of Toronto to other cities, in order to provide steady employment in those regional locations. For example, the Ministry of Transportation is based in the city of St. Catharines and the OPP's headquarters are now located in the town of Orillia. The cities mentioned in this report are shown on the provincial map in Figure 5.3.

Click To expand
Figure 5.3: Major cities in Ontario.

More recently, the government has moved various small offices housing a series of different agencies into a number of consolidated locations, while relying on toll-free numbers, public electronic kiosks, and Internet access to deliver local services. These major moves have greatly increased the province's reliance on telecommunications, especially messaging and teleconferencing.

Outsourcing

During the last 3 years, the government has outsourced most of the management and systems administration of its data and voice networks to contractors, under the overall coordination of EDS. The province was driven to this solution in part due to significant issues in hiring and retaining the required number of competent telecom and IT professionals on government salary scales.

In mid-2000 AT&T Canada was awarded a multiyear contract to provide outbound, switched voice and data services at extremely low rates, which led to much voice traffic being taken off the leased-line Government of Ontario Network (GOnet).

Telephone Services and Systems

For 2 decades, the government of Ontario acquired new telephone services and systems with a focus on individual cost/value, rather than on compatibility with existing systems. In the mid 1990s, the government had more than 40 types of PBXs and KTS in service. As the year 2000 approached, many older KTS and some obsolete PBXs were replaced due to concerns related to both compatibility and Y2K issues between telephone switches and voice mail systems. The replacement program resulted in the narrowing of system types, leaving no more than a dozen different models of phone switches in use by the government, with clusters of certain manufacturers' systems in specific cities within the province (e.g., Siemens/ROLM in Kingston and Mitel in Ottawa). Recently, Avaya Definity systems have become prominent for new contact center implementations.

The government's mid-2000 telecom inventory showed a total of approximately 80,000 desktop phones, of which 35,500 are attached to Centrex circuits. Centrex services, provided by Bell Canada, are used by most provincial employees in the cities of Toronto, Guelph, London, and Peterborough (see Figure 5.3). Some 10,000 of the phones attached to KTS are in small rural offices that, due to seasonal workload, remain quiet for a portion of the year; hence we estimate that the Centrex lines actually carry more than 60% of all voice traffic minutes processed by government departments. It is interesting to note that 85% of the phones in provincial offices are served by Nortel switches (Centrex, KTS, or PBX).

Voice Messaging

The government of Ontario has achieved considerably more standardization with voice processing systems than it did with telephone switches. Over 90% of all voice mailboxes are Lucent systems, linked to Centrex services or government-owned PBXs. In Toronto the government owns 10 Lucent systems that are collocated in Bell Canada buildings, adjacent to the DMS-100 switches that deliver Centrex. These systems have an average of 72 ports and up to 390 hours of voice message storage. A similar collocation arrangement exists for the government with Bell's Centrex switches in the cities of Guelph and Peterborough (with 36 ports and 60 hours each). In other locations, the province rents Centrex-linked voice mailboxes on a contractual basis.

Software from Lucent is used to enable the Voicenet service, linking all of the Lucent-based voice mailboxes throughout the provincial government, whether the user's telephone is served through Centrex or by an Avaya, Mitel, Nortel, or Siemens PBX. Voicenet is very valuable to most provincial employees as an easy-to-use, everywhere-available service parallel to e-mail.

Distributed Contact Center

In 2001, an agency of the provincial government implemented a contact center, which employs a number of agents who are scattered, in small groups, in a number of offices across Ontario. This contact center is based on an Avaya Definity G3 switch, with ACD (including agent skills routing), and uses a number of IP telephony features. An attached Octel (model 250) messaging system, with 12 ports and 70 hours of voice/fax storage, is also part of the center. Up to 100 agents and supervisors have Avaya's IP agent software, which provides a PC-based softphone.

The Avaya and Octel systems are located in an office building in midtown Toronto, together with approximately 50% of the agents. Agents log into the ACD over the government's IP LAN/WAN, with the agent software requiring a maximum bit rate of 8 Kbps to set up and maintain each two-way call. Voice calls are routed from the Definity Enhanced Communication System (ECS) over the PSTN to remote agents using Centrex, DID on a PBX, or a regular business line (1FL) at the agent end. Home-based agents can be incorporated into this distributed contact center with very little difficulty.

A number of primary rate ISDN links are attached to the Definity switch (providing up to 119 B channels), because two voice lines are needed for each active incoming call that is extended over the PSTN for a remote agent. The system is licensed to have 50 simultaneously active agents.

This contact center incurs long-distance charges to its remote agents, for about one-half of the total call volume. The government is paying less than 4 cents per minute for its provincewide toll voice service, so this cost is significant, but not prohibitive. The hybrid IP/TDM solution clearly made the best use of the technology that was available at the time of its cutover, but could be made more cost-effective and flexible when it becomes feasible to transfer the contact center to a wholly IP-Centrex network.

Effectiveness of Centrex

Government telecom managers consider that Centrex delivers an effective service to its users, at a per-line cost of around 50% of the one-month, single-line tariff. Centrex is not used for ACD in contact centers, and, therefore, the Ministry of Finance is unique within the government in being directly responsible for several large PBXs and making little use of Centrex. The widespread use of Centrex is consistent with the government's policy of outsourcing services and is helped by satisfaction with Bell Canada's management of the service.

The government has implemented extended Ethernet VLANs between most of its offices throughout Toronto using DWDM over dedicated optical fiber pairs. A reasonable amount of fiber is available in most urban centers in Ontario because of competition between the electrical power distributors (e.g., Toronto Hydro), cable TV carriers, and several telcos. With these circumstances it will be logical to install interbuilding VLANs in other cities across the province.

As the government of Ontario establishes well-managed broadband networks in urban areas throughout the province and continues to require telephone and data services in over 1,000 buildings, it will become a natural and ideal candidate for the widespread implementation of IP-Centrex, which we expect will replace the older PBXs and many KTS over the corning 5 years.

Technology Trial

The provincial government participated in a limited technology trial of IP-Centrex in the spring of 2002. The duration of this trial was constrained due to the so-called gating requirements of Nortel Networks' schedule, as the manufacturer moved the product through its development and testing stages to market availability.

Some 30 government employees at one building in downtown Toronto used Nortel i2004 sets on their desks and softphones in their PCs for the 90-day test. The IP-Centrex service was delivered over a Fast Ethernet LAN, which had no native QoS capabilities. The coordinator of this trial reported that, on some conversations between the IP phones and off-Centrex callers, there was "clipping" of the voice signals, making the line sound as though it were set up in half duplex mode.


IP-Centrex Field Trials

The electronic government department of the State of Wisconsin conducted a field trial of IP-Centrex, based on Lucent's iMerge product, in conjunction with SBC Communications, in late 2001. The state is a very large Centrex customer, with well over 60,000 lines in state offices, universities, and local agencies, such as county and city governments.

The Centrex features were derived from a 5ESS CO switch in Lisle, Illinois, and carried 145 miles over a T1 link to the state's offices in Madison, using the configuration shown in Figure 5.4. The equipment in Lisle was shared with the much larger IP-Centrex pilot test at Lucent's own campus in Naperville, Illinois (which is described below).

Click To expand
Figure 5.4: IP-Centrex trial network.

This project in Madison lasted for 90 days and involved only 11 users, based on a preexisting 10/100 Mbps LAN, which has approximately 100 users on each Ethernet switch. Unidata IW200 IP phone sets were used for this trial. These telephones employ the H.323 protocol, with a G.711 codec, echo cancellation, an internal hub, and local ac power supply.

The trial's coordinator concluded that the successes of this project were that all the features of Centrex, including 911 calls and voice mail, continued to work, there was full integration into the State's five-digit dialing scheme, and there were no apparent issues with the LAN.

A number of problems were identified, such as intermittent voice clipping and fading, frequent echoing and excessive background noise in the sets, infrequently dropped calls, and two complete service outages. Users also complained about a slight delay in obtaining dialtone and poor telephone set ergonomics.

The conclusions from this small trial were that home-based workers and "road-warriors" are most likely to benefit from IP-Centrex, while no applications have yet been written for the IP phones.

SBC Communications deployed an ambitious trial of IP-Centrex, jointly with Lucent, at that company's new technology center at Naperville, Illinois, in the spring of 2001. This live network trial served more than 1,600 product development, design, and test personnel through an iMerge Centrex Feature Gateway linked to the 5ESS central office system, which also provides digital Centrex service to 10,000 employees on the same industrial campus.

A 2-month trial of IP-Centrex was conducted in the spring of 2002 at the University of Toronto (UTO), in partnership with Bell Canada and Nortel Networks. The university rents about 12,000 Centrex lines for its 200 buildings, spread over four campuses, with single wire center service for each campus. All intercampus calling is done over the PSTN, with 10-digit dialing within and between two area codes, as all the sites are in one extended local calling area. UTO has been a digital Centrex customer since 1986 and currently has a 5-year contract, at $14.35 per month per line.

For the last 5 years the university has subscribed to the Station Configuration Management service, which allows a customer's own telecom personnel to implement some moves, additions, or change orders in real time. However, the more complex change requests need the participation of Bell's technicians in the CO, where their turnaround time for work on one to five sets is up to 1 week. It turns out that approximately 75% of orders need at least some action by the telco, so the telecommunications manager sends the whole request to Bell, since the university would not save any money by doing part of the job and splitting responsibility for a work order increases the possibility of errors. In other words, UTO's telecom analysts can only do about 25% of the MAC requests that are received from their users in the legacy Centrex environment.

UTO owns three Avaya/Octel voice mail systems, with one unit being installed at each of its main campuses, and has a total of 6,800 voice mailboxes. Six thousand mailboxes are used for the large downtown campus, while the Aerospace Studies Institute, in northern Toronto, rents 100 voice mailboxes from the telco's call manager service. There are some 80 bulletin board services also based on the Avaya systems, which vary greatly in size and usage.

A three-position switchboard continues to be ample to handle calls through the main listed number, which is first answered by a recorded announcement, with option 1 going to the operator and option 2 to the main menu.

Bell Canada has provided a stable, dedicated team of support people to UTO, and this has led to a QoS for legacy Centrex that cannot be beaten.

Thirty users, located in several buildings on the downtown Toronto campus, participated in the IP-Centrex trial. The service was delivered over a T1 link from the same DMS-100 system that provides legacy Centrex. These users included administrators, academics, and IT personnel. Each participant had a Nortel i2004 phone plus a SIP Client package in the desktop PC. These people have found it hard to adapt to the softphone and much prefer to use the IP telephone set. Voice quality over IP-Centrex was very good when calling within the trial group or to other Centrex phones in the university. The most significant quality difference was on some calls with cell phones, when "clipping" sometimes occurred. Compared with legacy Centrex, there was also some loss of quality on conference calls; the audio degraded as more participants were added.

Responsibility for data networks at UTO is split between the central IT department, which looks after the optical fiber backbone between buildings, and the department responsible for a specific building, which controls the LANs inside that building. All LANs deliver switched Fast Ethernet to each desktop, but the quality of local network management differs widely.

Within this university environment there is not much call for the networked applications that are offered by IP-Centrex. No one is asking for UM and there are no requirements for CRM. The ability to set up a short-term, virtual call center may be helpful for a few class projects and the potential easily to adjust the number of lines to meet seasonal demand in student residences may have some value.

The real interest in this case is how IP-Centrex will be tariffed. Because the switching is being done in customer-owned equipment, the rates should be lower than with legacy Centrex, but there is not yet any information available as to how much less the costs will actually be. At the very least, there is hope that the implementation of IP-Centrex may allow the university to increase its share of in-house MACs from one-quarter to three-quarters of the total.


Chapter 6: Evaluating IP-Centrex

The Attractions of IP-Centrex

As IP-Centrex proliferates, the benefits inherent to the technology should translate into functional and service-level gains for customer organizations. Network convergence, packet-switching, and the removal of various physical restrictions are among the prime elements that should promote IP-Centrex to the forefront of outsourced telephony services. We can summarize these benefits as follows.

Capital Costs

The most immediate and obvious benefit of Centrex services is the elimination of most capital expenditure. We should note, however, that in the case of IP-Centrex, the LAN infrastructure within an organization must be brought up to specification in order to support the technology of IP telephony.

Convergence

Data and voice requirements are now combined into a single infrastructure. Network convergence provides the benefits of reduced management overhead and the leveraging of existing IT skill sets that lead to reduced operational costs and improved service levels.

Multiple Locations and Mobility

IP-Centrex provides a simpler and more effective means to create a seamless telephony environment when considering multiple geographic locations. An organization can have a number of offices, along with individual remote users, that can all be part of a single unified environment at lower expected costs than with legacy Centrex.

Computer-Telephony Integration

CTI is significantly enhanced and simplified by the use of IP-Centrex. Access to network-based applications via a phone (such as Web browsing or basic task- or lookup-oriented software applications) can now be accomplished with much less integration time and effort, through the use of simplified software interfaces.

Unified Messaging

UM is significantly less difficult and expensive to implement with Centrex than with other technologies. With network-based softswitches and IP-Centrex servers, voice mail information can be integrated with e-mail and fax to form a unified messaging environment, usually provided as the single "inbox" for an individual user.

Simplification of MACs

As IP telephony removes the barriers imposed by hardwired phones, the complexity, time, and cost of moves, adds, and changes are significantly reduced. IP phones can be easily relocated within a facility by attaching them to any appropriate connection on the internal Ethernet LAN. In most cases, a MAC can be accomplished by the user unplugging the set, moving to a new location, and plugging the set back into an operational network jack (such as in the case of moving an individual's office location).

Local Access Cabling

Legacy Centrex generally requires a separate pair of copper wires from the CO to support each phone. This cable plant requirement sometimes resulted in delays with implementation (adding more copper cabling) and put limits on the wired building capacity. Since IP-Centrex utilizes a broadband extension to a site, the cabling requirement from the CO is significantly reduced, as only two fiber-optic cable strands or a limited number of pairs of copper cable are required to provide broadband connectivity. With the elimination of copper cabling requirements from each phone to the CO, the potential issues of electrical interference or damaging currents and voltages induced on such cable are also eliminated.

Inside Wiring

In most cases, legacy Centrex telephone sets within a building must connect directly back to the CO with copper cabling (with the exception of the concentrator approach, as noted in the "Background" section of Chapter 1). As a result, multipair copper riser cable is required to interconnect the telco cabling at the point of entry into the building with each wiring distribution closet. Such cabling is also a requirement with traditional digital PBX installations, in addition to individual drop-cabling to each telephone set. In Centrex nomenclature, this cabling is often called "inside wiring." Since IP telephony requires no main distribution frame (MDF) or secondary distribution frame (SDF) termination points, a significant reduction in copper cabling can be realized, negating the requirement for multipair riser cabling within a building and dedicated drop-cabling per telephone set.

Provider Infrastructure

Added to these benefits, the IP-Centrex service provider also gains from the significant reduction in physical space, management complexity, and support requirements at the CO (or provider location). IP-Centrex and packet-switching systems have a higher packing density on the equipment racks, while at the same time being smaller, lower-powered, and requiring less environmental support than the traditional CO-based circuit-switching equipment.

Provider WAN

IP-Centrex has the opportunity to deliver seamless services to an organization that is geographically dispersed. In a customer-owned solution, voice traffic may have traveled over an internal network (TDM or VoIP) to interconnect remote sites for toll bypass and networked voice requirements. Voice traffic in an IP-Centrex environment has the option of flowing over the carrier's data infrastructure, relieving the customer of implementing and managing QoS factors on their internal WAN, while avoiding the burden of additional traffic on the corporate network.


Concerns with IP-Centrex

We must be aware of the potential issues associated with IP-Centrex, which may not be present with legacy Centrex services. As outlined in Chapter 7, a number of requirements must be fulfilled for a successful implementation of IP-Centrex. These major issues are summarized as follows.

Operational Costs

The single most significant issue surrounding the use of Centrex services, legacy or IP-based, is the recurring operational cost. This is the monthly charge made by the provider for supplying IP-Centrex services and related applications.

In financial evaluations, this cost is most often compared to the sum of capital and operational costs of an in-house telephony system over a specified period of time.

Stability

PBX and CO switching technologies have been developed over a number of decades. Thousands of person-years have been invested in software and hardware engineering to create an exceptionally reliable and ubiquitous service. Enterprise-scale IP telephony technology is relatively new and has not achieved the installed base and extensive long-term field-testing of existing circuit-switched technologies. A risk associated with IP Centrex services is that they are based on emerging technologies with complex software. Providers will have to be extra vigilant to ensure the reliability of IP-Centrex infrastructure components.

Security

The Internet revolution has seen a new breed of individuals evolve: hackers. While the compromising of traditional telephony services (long distance and DISA) has long since been exercised by inventive and unlawful individuals, the advent of IP telephony opens up an entirely new twist to this old story. It is foreseeable that hackers, who currently practice their trade on both the Internet and corporate data networks, will now have much more access to, and control of, telephony services. This could evolve into a serious issue; most IP telephony systems are based on widely used operating systems and protocols, which are well-known to the hacker community. A considerable number of techniques currently exist to attack or use the resources of existing data network-based services, the realm of which telephony has now entered. A hacker at a distant location could, given the appropriate access and knowledge, attack, control, or cripple elements of IP-Centrex.

Whether IP-Centrex or private IP telephony is used by an organization, security of the internal network must be given increasing priority, in order to guard against service disruptions and the loss or compromise of corporate and personal assets and privacy.

Network Considerations

Since IP telephony, and hence IP-Centrex, are required to run over the LAN of a customer's organization, that network must have the inherent capability of carrying such traffic. Latency, jitter, and bandwidth characteristics of the LAN must be within tolerable limits for packet voice traffic. These parameters, otherwise known as quality of service (QoS), are created and sustained by both the architecture of the network and the capability and configuration of the electronic equipment (switches and routers) used to build the LAN on which packet voice traffic will flow.

A number of other network considerations must be made when deploying IP telephony technology, such as dynamic host configuration protocol (DHCP), a network service that provides each IP phone with a unique IP address at startup. This could be supported by the provider, but because of the potential in-house requirements of directory integration and other needs, may have to be supported in-house.

A consequence of convergence is that the failure of part or all of an organization's LAN also means the failure of telephony services. While users of traditional voice networks have enjoyed exceptional reliability, this has not been the case historically with LAN infrastructures and for PC users. Therefore, appropriate amounts of redundancy must be built into the LAN infrastructure to provide for high availability (upward of 99.9%). This is usually accomplished through numerous hardware and software techniques, including redundant power supplies, duplicated backbone links, and routing redundancy. Organizations should plan to invest around 15% over the base capital cost of implementing a LAN to increase its reliability.

911 Requirements

The service provider will have to create the capability of connecting 911 services into the IP-Centrex environment. Basic 911 requirements dictate that a caller must be routed to a public safety answering point (PSAP), with information on the caller location provided by ANI and other database information. This can usually be accomplished with IP-Centrex. Enhanced 911 has the extended requirement of being able to locate a caller to within a particular area of a building or campus, or within a limited number of logically grouped telephones. Enhanced 9 1 1 therefore requires substantially more intelligence from the telephony and LAN infrastructure. Such capabilities can be accomplished by having intelligence built into the LAN, whereby an IP phone set and the particular port on an active LAN switch can be queried by management software, which in turn provides a database search for a location of that phone set. This information will have to be passed to the provider and ultimately (and in a timely manner) to the PSAP.

Due to the geographic independence of IP telephony, both IP-Centrex providers and in-house IP telephony systems must provide for appropriate routing of 911 calls to the local PSAP, as opposed to traversing an internal LAN / WAN and connecting to the PSTN at some unrelated location.

Phone Power

Like residential telephones, most traditional Centrex sets are powered from the CO. With IP Centrex however, multiple phone sets (connected to an in-building LAN) cannot derive power from the CO and must be locally powered. This local power is derived in one of two ways: a phone-based power adapter or in-line power. In either case, the power located in the building is used, which may be subject to a number of anomalies and often has no backup (UPS or emergency power). CO power however is quite reliable because it is typically supported by both battery and a diesel generator for longer outages.

A phone-based power adapter is a small ac/dc power transformer cube connected to a standard ac power outlet near the IP telephone; it provides the necessary power to the set.

In-line power is delivered on the same cable as signaling. Power is "injected" onto the cable either from a special patch panel or by the network Ethernet switch itself (on a per-port basis). In-line power can also be used to power wireless LAN access points, which would be in support of wireless in-building IP-Centrex.

Broadband Connectivity and Call Processing

Reliance on a single broadband connection from the CO for telephony services creates a potential single point of failure. While this is also true of legacy Centrex services and their multipair copper cables from the CO, IP-Centrex can be additionally protected if the telco provides some element of redundant IP call-processing equipment at the customer location. This could provide very basic call capability until normal services are restored. In addition, redundant broadband connectivity should be established, at an additional cost, ideally through a physically separate connection with another carrier. Such a connection could also be created using a lower-performance (and hence, lower-cost) link until the main link is restored.

Messaging and Directory Integration

It is anticipated that the use of an internal IP-PBX will allow an organization to configure unified messaging and directory services in a more controlled and secure manner than with the use of an IP-Centrex service, which might require significantly more involvement between the customer's and the service provider's management. Since internal e-mail systems and network-based directories are cornerstones of data networking, telephony integration to these elements in larger organizations will be vitally important.


Financial Analyses

Any financial comparison between IP-Centrex services and in-house (customer-owned) solutions must use input data that are specific to the organization under review. An exhaustive financial analysis is difficult to achieve without a considerable amount of data and effort. Even so, variables such as interest rates and market dynamics can render an exceptionally detailed financial analysis as an approximation.

An increasingly important factor is the growing popularity of IP telephony systems (usually IP-PBXs). While legacy Centrex services would normally be compared to circuit-switched digital PBXs or KTSs, it is more realistic to build comparisons between IP-Centrex and IP-PBX systems. We fully expect that digital PBXs will wane in popularity as IP telephony takes hold in more enterprises over the next few years. The financial dynamics of IP-PBXs also upset the traditional comparison, because factors such as inside wiring, system management, and application integration have changed considerably with this new technology. For these reasons our financial analyses focus on comparing IP-Centrex service to IP-PBX systems only.

A number of important common factors should be considered in any financial analysis, as commented here.

Approximations

Because no large-scale IP-Centrex offerings were available at the time of this writing, we have used available information and reasonable judgment to provide estimated costs for future IP-Centrex services. Our analyses have also assumed that IP-Centrex rental costs hold steady over a multiyear provider contract, and we have brought these future rental expenditures to an approximate present value by assuming an annual discount rate of 5%.

We have assumed that the premium on IP-PBX costs, as compared with TDM PBXs, will have disappeared by 2004.

While not included in these comparisons, time versus money factors should be considered, to more accurately calculate an organization's return on investment (ROI) of a private IP-PBX option. Standard and well-known financial modeling tools such as net present value (NPV) or internal rate of return (IRR) would most likely be used, along with the weighted average cost of capital (WACC), or interest rate, depreciation, and marginal tax rate.

Investment Period

The installation of a new PBX solution ("greenfield" or major replacement) is normally treated as a 5- to 10-year investment. Even with the introduction of IP-PBXs, a comparative analysis should cover a similar range of time. Government organizations may tend to the high side (10 years) of this period, while a more dynamic company would be on the low side (5 years). We expect that new software releases for IP-PBX systems will occur more frequently over the next few years than has been the custom with legacy PBXs, due to the emerging nature of this technology.

Inside Wiring

Because the inside wiring component is now equalized when IP telephony or IP-Centrex is considered, it is not included in these calculations. You should, however, know that a small number of additional LAN cabling outlets and associated Ethernet switch interfaces may be required in various building locations in which only a phone might be required (such as lobbies).

Telephone Sets

It is reasonable to assume that IP telephones will be available both as rented units from the IP-Centrex provider or as an outright purchase by the customer organization. Per-unit costs are normally driven by the features available on the set itself (e.g., number of lines or Web browsing capability). We categorize these IP phones in the same manner as traditional phone sets: single-line (basic) phones, feature phones, executive phones, and contact-center set (softphone). In the case of purchase, the customer organization should factor in maintenance costs for the sets (which a service provider would include as a component of the rental charges).

For estimation purposes we have assumed that the cost of IP phones will drop 50% in the first 3 years that IP-Centrex is on the market, because several manufacturers should be producing them in large quantities by the year 2005.


Single-Site Organization

This example is based on the head office of a petrochemical company, which consists of a small campus of office/industrial buildings containing 350 phones. The organization has modest growth, with personnel count estimated to increase by 2% per year (total phone set count is allotted in year 1). The organization is a legacy Centrex user that wants to take advantage of IP-PBX features and network convergence. They have realized that to implement IP telephony technology they must replace their existing LAN equipment with new Ethernet switches that support QoS and either in-line power or with the addition of powered patch-panels. Because the cost of the LAN upgrade would occur with either an IP-PBX or IP-Centrex, it is not considered in the financial comparison (suffice it to say that such an upgrade would be on the order of $150 to $300 per network port).

Figure 6.1 illustrates the basic components that make up the IP-Centrex infrastructure from the provider to the customer's premises.

Click To expand
Figure 6.1: Typical infrastructure components for IP-Centrex.

The estimated costs, over 5 years, of the IP-Centrex and IP-PBX solutions for this single-site operation are shown in Table 6.1. Where an item is assumed to be paid on a one-time (capital expenditure) basis, the boxes for years 2-5 have been left blank.

Table 6.1: Single-Site Cost Comparison (350 Subscribers)
IP-CENTREX COSTS | QTY | UNIT COST ($) | YEAR 1 ($) | YEAR 2 ($) | YEAR 3 ($) | YEAR 4 ($) | YEAR 5 ($)
Line installation | 350 | 35 | 12,250 |  |  |  |
Line rental | 350 | 15 | 63,000 | 59,850 | 56,858 | 54,015 | 51,314
Feature installation | 350 | 30 | 10,500 |  |  |  |
Single-line phone | 190 | 10 | 22,800 | 21,660 | 20,577 | 19,548 | 18,571
Feature phone | 100 | 13 | 15,600 | 14,820 | 14,079 | 13,375 | 12,706
Executive phone | 60 | 30 | 11,520 | 10,944 | 10,397 | 9,877 | 9,383
Conference phone | 2 | 30 | 720 | 684 | 650 | 617 | 586
Attendant consoles | 1 | 50 | 600 | 570 | 542 | 514 | 489
Feature rental (ind. UM) | 250 | 7 | 21,000 | 19,950 | 18,953 | 18,005 | 17,105
Administrator interface | 1 | 100 | 1,200 | 1,140 | 1,083 | 1,029 | 977
Administrator/support | 1 | 50,000 | 50,000 | 47,500 | 45,125 | 42,896 | 40,725
Broadband installation and rental | 350 | 5 | 21,000 | 19,950 | 18,953 | 18,005 | 17,105
Annual totals |  |  | 230,190 | 197,068 | 187,215 | 177,854 | 168,961
Total (5 years) |  |  |  |  |  |  | 961,288
IP PBX COSTS | QTY | UNIT COST ($) | YEAR 1 ($) | YEAR 2 ($) | YEAR 3 ($) | YEAR 4 ($) | YEAR 5 ($)
Call processors | 2 | 15,000 | 30,000 |  |  |  |
Voice mail (UM) | 1 | 45,000 | 45,000 |  |  |  |
Single-line phone | 190 | 200 | 38,000 |  |  |  |
Feature phone | 100 | 260 | 26,000 |  |  |  |
Executive phone | 60 | 320 | 19,200 |  |  |  |
Conference phone | 2 | 600 | 1,200 |  |  |  |
Attendant consoles | 1 | 1,000 | 1,000 |  |  |  |
PSTN gateway | 2 | 20,000 | 40,000 |  |  |  |
PSTN access | 39 | 25 | 11,700 | 11,115 | 10,559 | 10,031 | 9,530
System installation | 1 | 30,060 | 30,060 |  |  |  |
Administrator/support | 1 | 50,000 | 50,000 | 47,500 | 45,125 | 42,869 | 40,725
System maintenance | 1 | 43,824 | 43,824 | 41,633 | 39,551 | 37,574 | 35,695
Annual totals |  |  | 335,984 | 100,248 | 95,235 | 90,474 | 85,950
Total (5 years) |  |  |  |  |  |  | 707,891
See "Definition" section on page 96.

We have assumed that the monthly rental for an IP telephone, or console, is one-twentieth of the purchase cost for that set. That figure seems to be in line with telco practices in the past, but in a competitive environment and at a time of low interest rates, telephone rentals may be considerably less expensive. Based on our estimates, the net present cost of IP-Centrex in this situation would be about 35% more than that for an IP-PBX.

Definitions for Tables 6.1-6.3

Line installation: The provider's fee for setting up a logical connection (register) from the IP phone set to the IP telephony switch located in the CO. This is typically a software configuration; the customer would physically place the phone, connect it to the internal LAN, and ensure communications ability to the IP call processors in the CO.

Line rental: The monthly cost of a logical port on the CO located IP call processor.

Feature installation: The one-time cost of having the provider install a package of features for a single user. These features include such items as call hold, call forwarding, and conference calling.

Phones: The cost of buying or renting a particular level of IP phone from the provider, not including physical installation.

Attendant console: The cost of buying or renting a (typically) PC-based softphone that provides attendant console features.

Feature rental: The monthly rental cost of a package of telphony features, including unified messaging.

Administrator interface: The monthly cost for system administrators (employees of the customer) to access the system configuration interface (ideally Web-based) of the IP call processors, or associated CO-based IP-Centrex system, allowing them to carry out "soft" MACs.

Administrator/support: The yearly cost of a trained individual (employee of the customer) who supports the IP-Centrex system or in-house IP-PBX system.

Broadband installation and rental: The monthly cost charged by the carrier for providing a broadband connection (including CPE routedswitch) from the CO to the customer premises for IP Centrex. Note that Tables 6.1 and 6.2 provide broadband costing on a per-user basis.

Table 6.2: Distributed Contact Center Cost Comparison (200 Agents)
IP CENTREX COSTS | QTY | UNIT COST ($) | YEAR 1 ($) | YEAR 2 ($) | YEAR 3 ($) | YEAR 4 ($) | YEAR 5 ($)
Line installation | 200 | 35 | 7,000 |  |  |  |
Line rental | 200 | 15 | 36,000 | 34,200 | 32,490 | 30,866 | 29,322
Feature installation | 200 | 30 | 6,000 |  |  |  |
Executive phone | 40 | 16 | 7,680 | 7,296 | 6,931 | 6,585 | 6,255
Agent phone | 160 | 50 | 96,000 | 91,200 | 86,640 | 82,308 | 78,193
Feature rental (including UM) | 200 | 7 | 16,800 | 15,960 | 15,162 | 14,404 | 13,684
Contact center feature rental | 200 | 80 | 192,000 | 182,400 | 173,280 | 164,616 | 156,385
Contact center integration | 1 | 250,000 | 250,000 |  |  |  |
Administrator interface | 5 | 100 | 6,000 | 5,700 | 5,415 | 5,144 | 4,887
Administrator/support | 2.5 | 70,000 | 175,000 | 166,250 | 157,938 | 150,041 | 142,539
Broadband installation and rental | 200 | 5 | 12,000 | 11,400 | 10,830 | 10,289 | 9,774
Broadband interconnect | 1 | 4,000 | 48,000 | 45,600 | 43,320 | 41,154 | 39,096
Annual totals |  |  | 852.480 | 514,406 | 488,686 | 464,251 | 441,039
Total (5 vears) |  |  |  |  |  |  | 2.760.862
IP PBX COSTS | QTY | UNIT COST ($) | YEAR 1 ($) | YEAR 2 ($) | YEAR 3 ($) | YEAR 4 ($) | YEAR 5 ($)
Call processors | 3 | 21,000 | 63,000 |  |  |  |
Voice mail (UM) | 1 | 40,000 | 40,000 |  |  |  |
Executive phone | 40 | 320 | 12,800 |  |  |  |
Agent phone (soft phone) | 160 | 1,000 | 160,000 |  |  |  |
PSTN gateway | 2 | 24,000 | 48,000 |  |  |  |
PSTN access | 200 | 25 | 60,000 | 57,000 | 54,150 | 51,443 | 48,870
Contact center HW/SW | 1 | 500,000 | 500,000 |  |  |  |
Contact center integration | 1 | 200,000 | 200,000 |  |  |  |
Administrator/support | 3.5 | 70,000 | 245,000 | 232,750 | 221,113 | 210,057 | 199,554
System installation | 1 | 64,760 | 64,760 |  |  |  |
System maintenance |  | 132,570 | 132,570 | 125,942 | 119,644 | 113,662 | 107,979
Annual totals |  |  | 1,526,130 | 415,692 | 394,907 | 375,162 | 356,403
Total (5 years) |  |  |  |  |  |  | 3,068,294
See "Definition" section on page 96.

Broadband interconnect: The carrier's fee for interconnecting two or more physical locations (from a single customer) using IP-Centrex. This is essentially the WAN, which carries VoIP traffic between facilities. Long-distance VoIP calls can also be carried over the carriers' network infrastructure to a terminating location, where they are converted (via a gateway) back to the regular PSTN.

PSTN gateway: A device that provides the interface between an IP telephony system and the PSTN. Usually takes the form of a modular router or dedicated hardware device that attaches to the LAN and is controlled by the IP call processor(s) in an in-house IP-PBX system.

PSTN access: The quantity and monthly cost of CO trunks to access the PSTN. These trunks are usually connected to the PSTN gateways and in most cases are B channels on multiple PRI-ISDN links.

System installation: The one-time cost of installing an IP telephony system, including IP-PBX (call processor), gateways, phones, and unified messaging. This cost is typically between 15% and 20% of the overall capital cost of the system.

System maintenance: The yearly cost of contract maintenance (on-site break/fix) for an in-house IP-PBX system, both hardware and software. This cost is typically between 12% and 20% (recurring yearly) of the overall capital cost of the system and includes the cost of software upgrades (new releases).

Quantity (Qty): The number of units for the specific item. In the case of administrator/support this could be a fraction of an individual such as 3.5, where 3.5 full-time equivalent (FTE) resources are required (that is to say, three support personnel would be dedicated full time, and a fourth person would only spend half of his or her time on system support).

Unit cost: The unit cost column denotes either the one-time capital cost or the recurring charge for the item (e.g., monthly for rented items and annually for personnel).

Phone maintenance: The average unit cost of maintenance for IP telephones in the event that a large IP-Centrex client wishes to purchase (outright) phone sets, as opposed to continuous rental.


Distributed Contact Center

A retail organization with outlets across the country maintains a call center with 200 agents, primarily for inbound customer service. To remain competitive, this retailer must provide extended hours of service, with a "follow-the-sun" approach, by having two call centers, one located on the Pacific and the other on the Atlantic coast. Both call centers have overlapping hours of coverage to assist during the peak call load periods during the day. The centers are supported by two networked digital PBXs with ACD and customized CTI.

In addition to supporting regular inbound calls, the retailer is looking to implement a converged IP contact center, which integrates the functionality of the call center with their Web site. Web site users are to have seamless integration when working with the site and the new contact center.

To build this capability, IP telephony technology has been defined for use. The organization has the choice of purchasing IP-PBX systems or using an IP-Centrex service from a national provider. With the IP-PBX option, the retailer will run VoIP traffic over the corporate WAN between the sites (a 3-Mbps LAN extension circuit derived from a carrier-provided MPLS network). With IP-Centrex, the carrier will be responsible for connecting the traffic between the two sites (resulting in a broadband interconnect charge). The estimated IP-Centrex and IP-PBX costs are itemized in Table 6.2.

In the estimates for IP-Centrex, we have included a figure of $80 per month for each agent, for the rental of contact center-related software (ie., ACD and CRM). Because this results in a 5-year total of $870,000, compared with an estimated $500,000 purchase cost for two copies of the software on the IP-PBXs, it is probably a higher figure than can be justified.

We should also note that the expected annual cost for the system administration/software support personnel has been set at $70,000 each, to account for the high skill level required in this complex contact center environment.

The bottom line totals show a 10% lifetime cost advantage to the IP-Centrex solution, compared with two IP-PBXs.


Multisite Organization

This example is based on a city government that has a number of buildings and many smaller offices throughout a limited area (within city limits), for a total of about 90 sites. The total number of sets is 2,200 and includes a number of conference stations and wireless IP phones. The organization is quite stable in terms of personnel count, essentially holding flat over the period of 5 years. A recent and major upgrade to the enterprise LAN has included the requirements to run IP telephony (switching, QoS, and inline power in most locations). In support of the LAN upgrade costs, the city has planned to implement either IP-PBX technology or IP-Centrex, because the existing PBXs are at capacity and have reached the end of their useful lifespan. Note that in this example, the IP phones are being purchased outright, in order to reduce overall cost and take advantage of volume purchase discounts. For this reason, a line entry for telephone maintenance (at 5% of capital cost) has been included. We should also note that several of the IP-Centrex unit costs are significantly lower than in the two other cases, because of the large quantities involved.

The estimated cost for the IP-Centrex and IP-PBX solutions for this multisite organization are shown in Table 6.3.

Table 6.3: Multisite City Government Cost Comparison (2,200 Users)
IP CENTREX COSTS | QTY | UNIT COST ($) | YEAR 1 ($) | YEAR 2 ($) | YEAR 3 ($) | YEAR 4 ($) | YEAR 5 ($)
Line installation | 2,200 | 21 | 46,200 |  |  |  |
Line rental | 2,200 | 8 | 211,200 | 200,640 | 190,608 | 181,078 | 172,024
Feature installation | 2,200 | 18 39,600 |  |  |  |  |
Single-line phone | 1,140 | 200 | 228,000 |  |  |  |
Feature phone | 650 | 260 | 169,000 |  |  |  |
Executive phone | 300 | 320 | 96,000 |  |  |  |
Conference phone | 18 | 600 | 10,800 |  |  |  |
Wireless IP phone | 110 | 950 | 104,500 |  |  |  |
Attendant consoles | 2 | 1,000 | 2,000 |  |  |  |
Phone maintenance | 2,200 | 1.15 | 30,360 | 28,842 | 27,400 | 26,030 | 24,728
Feature rental (including UM) | 2,200 | 5 | 132,000 | 125,400 | 119,130 | 113,174 | 107,515
Administrator interface | 5 | 90 | 5,400 | 5,130 | 4,874 | 4,630 | 4,398
Administrator/support | 3 | 60,000 | 180,000 | 171,000 | 162,450 | 154,328 | 146,611
Broadband installation and rental | 2,200 | 3 | 79,200 | 75,240 | 71,478 | 67,904 | 64,509
Annual totals |  |  | 1,334,260 | 606,252 | 575,939 | 547,142 | 519,785
Total (5 years) |  |  |  |  |  |  | 3,583,379
IP PBX COSTS | QTY | UNIT COST ($) | YEAR 1 ($) | YEAR 2 ($) | YEAR 3 ($) | YEAR 4 ($) | YEAR 5 ($)
Call processors | 5 | 21,000 | 105,000 |  |  |  |
Voice mail (UM) | 1 | 400,000 | 400,000 |  |  |  |
Single-line phone | 1,140 | 200 | 228,000 |  |  |  |
Feature phone | 650 | 260 | 169,000 |  |  |  |
Executive phone | 300 | 320 | 96,000 |  |  |  |
Conference phone | 18 | 600 | 10,800 |  |  |  |
Wireless IP | phone | 110 | 950 | 104,500 |  |  |
Attendant consoles | 4 | 1,000 | 4,000 |  |  |  |
PSTN gateway | 2 | 24,000 | 48,000 |  |  |  |
PSTN access | 275 | 25 | 82,500 | 78,375 | 74,456 | 70,733 | 67,197
System installation | 1 | 174,795 | 174,795 |  |  |  |
Administrator/support | 5 | 60,000 | 300,000 | 285,000 | 270,750 | 257,213 | 244,352
System maintenance | 1 | 258,389 | 258,389 | 245,470 | 233,196 | 221,536 | 210,460
Annual totals |  |  | 1,980,984 | 608,845 | 578,403 | 549,482 | 522,008
Total (5 years) |  |  |  |  |  |  | 4,239,722
See "Definition" section on page 96.

It is important to note that this organization has constructed, through private fiber via the local electrical power distributor, a metropolitan area network (MAN) essentially interconnecting all sites with a high-speed LAN technology. Due to the nature of the services provided, the city requires multiple, CO-diverse connections to the PSTN, as VoIP traffic can be carried from gateways (either customer-owned IP gateways with PRI-ISDN interfaces, or broadband links from the Centrex provider) across the MAN to service all locations.

In this case, the trunk-to-line ratio for the IP-PBX situation has been set at 1:8, due to the expected high level of inward calling to the local government organization.

In this case, IP-Centrex shows a financial advantage of nearly 20% after 5 years. For a large municipal government we would anticipate a life expectancy of a decade for the telephone system, or for a Centrex contract. If this table were extended to year 10 the IP-Centrex solution would demonstrate a somewhat larger positive margin over the IP-PBX alternative.


Summary of Analyses

These three case studies show much the same results as would have been obtained if we had compared legacy Centrex service with TDM PBX systems.

IP-Centrex will usually not be competitive for a small-to-medium single-site organization with from 50 to 2,000 users and no special CTI requirements. For highly distributed corporations, whether citywide or worldwide, IP-Centrex should show cost savings of around 20% over a few years. Some of these savings originate in the sharing of voice and data access links, particularly where there are many small offices (i.e., with fewer than 50 users each).

If the service provider passes the economies of scale onto the customer by sharing complex software systems with multiple users, IP-Centrex with closely coupled applications will also be a financially attractive proposition.


Chapter 7: Implementing and Managing IP-Centrex

Some practical considerations relevant to the initial implementation and ongoing management of IP-Centrex services are included in the following sections.

Installing IP-Centrex

In many conventional Centrex installations the service provider, usually the incumbent telephone company, owned the telephone wiring within the customer's building, as well as provided the telephone service. This arrangement meant that the telco was responsible for the quality of service to the user's desktop and, if the telephone was rented as part of the service right up to the user's ear and mouth. The disadvantage of this situation was that the telco was usually unwilling for the unshielded twisted pair (UTP) cabling to be shared between voice and data signals, thus necessitating the installation of separate cables and cross-connect equipment for Centrex service and for the corporate LAN.

Within recent years most telcos in North America and in some European countries have disposed of the telephone cabling in customers' premises, making the building owners responsible for all in-house telecommunication cabling. This development has made fault diagnosis more complex, but has also opened the door to the shared use of the cabling infrastructure within an office area.

The arrival of IP-Centrex carries this shared use trend to completion, in that the voice and signaling packets travel over the same LAN and through the same switches as the corporate data traffic. In most installations, therefore, IP-Centrex will be superimposed on a preexisting LAN, which is likely to be Ethernet operating at 100 Mbps, and those responsible for implementing the service will not be much concerned with the underlying cable infrastructure.

The exceptions will be those cases where IP-Centrex is to be implemented in conjunction with a major LAN upgrade, or when additional cabling runs and outlets are required to service the IT phones.

For these reasons we have included the following discussion of the types of copper cabling that are now generally used for Ethernet networks.


Cabling Categories

The use of UTP copper wiring for multimegabit-per-second, in-building data networks was first proposed in the mid-1980s and became generally accepted after the Category 5 standards were defined in 1994. Category 5 (Cats) cables usually have four twisted pairs of 24-AWG copper wire and are terminated with eight-wire RJ45 miniature connectors. This cable delivers 100-Mbps Ethernet bitstreams up to a distance of l00m (325 ft) between the electronic equipment (e.g., a switch) and the desktop device. Typically, cabling system manufacturers will provide guarantees or "certification" of the performance of their cabling materials if the cable plant in a new installation has been designed and installed correctly.

We cannot be sure that full Cat5 performance will be delivered if the in-line components, as identified in Figure 7.1, between the desktop computer (or IP phone) and the server come from different cable and equipment manufacturers. For this reason cabling implementations should follow best practices for design and implementation, according to the manufacturer's specifications, and those outlined in the EIA/TIA Building Telecommunications Wiring Standards (to which the cabling performance specification must abide).

Click To expand
Figure 7.1: End-to-end components with a LAN.

Category 5 Enhanced (Cat5E) standards were defined by the telecom industry in early 2000. Cat5E performance has been so improved over the earlier standard that a string of Cat5E components will deliver guaranteed Cat5 performance, even if they come from a variety of manufacturers.

Category 6 (Cat6) cabling has been on the market, from several manufacturers, for a few years. It offers a 10 times improved performance bit rate over Cat5 (i.e., supporting 1,000 Mbps, or gigabit, Ethernet). Most applications do not justify gigabit Ethernet to the desktop, but it is used in LAN backbones and for connection to network servers. Standardization of the Cat6 specifications was due to take place by the end of 2002. Until that happens, there is some risk with using the Cat6 class of cabling and mixed-vendor implementations should certainly be avoided before there is industrywide acceptance of Cat6 standards.

Category 7 (Cat7) is a different class of cabling, because it includes a metallic mesh shield around the twisted copper pairs, underneath the outer layer of plastic insulation. Cat7 cabling was developed in Europe and is being used in several countries there, particularly in Germany, for highcapacity LAN installations.

Over the past 5 years many corporate LANs in North America have been built with Cat5E cabling, and a limited number of Cat6 infrastructures are now in place, in spite of its lack of standardization. Our experience has been that there is no more than a 10% cost differential between quotations for Cat5E and Cat6 implementations. One reason for this is that the actual cable materials make up well under one-half of the cost of a complete wiring installation.

Physical LAN costs have not changed much over the past decade, at around $200 per outlet for Cat6 (or about $180 with Cat5E), including needs analysis, system design, hardware, cable, cable-pulling, connecting, and testing, in small-to-medium installations (e.g., a school or a low-rise suburban office building). Expect cabling infrastructure costs to be above $200 per outlet in high-rise, downtown office towers, especially if installation is controlled by unionized workers.


Guidelines for Implementation

The following set of guidelines is useful for the successful implementation and management of in-house LANs that support voice communications:

  • Prior to implementing IP-Centrex, the personnel who are responsible for telephony should acquire reasonable knowledge of the technology embodied in the first three layers of the OSI model-namely the physical data link and network layers. This would cover aspects of cabling, Ethernet, and IP as general technologies that are critical to the function of enterprise IP telephony and hence IP-Centrex. This knowledge might be obtained by communicating with other existing IP telephony installations (whether IP-PBX or IP-Centrex) and from vendors' literature.

  • Membership in a Centrex users' group is an invaluable way to share information with other analysts and managers, and to provide feedback to suppliers.

  • The cabling system is the key to a "clean" network installation. A well-designed, installed, and certified cabling system will form the foundation of an enterprise-grade LAN capable of supporting the demands IP telephony.

  • The physical installation of an IP-Centrex service has to be well coordinated with a number of crucial departments, in addition to the users. These include the premises management, information technology/services operations, and senior management. In many situations any installation work (such as the pulling of new cable runs or the placing of phone sets) has to be done outside regular working hours.

  • Every detail of an IP-Centrex installation, as part of the overall

  • LAN infrastructure, must be fully documented. This documentation starts with the user's name, and continues through the identification of the voice terminal (IP phone or a computer with softphone), the jack identification, and various cross-connect positions to the port on an Ethernet switch. The identity of other users in a calling group, with interdependent call forwarding, must also be recorded to help with fault diagnosis.

  • Feature validation and configuration of Ethernet switches and routers on a LAN will be necessary as part of the upgrade to carry voice and video over an IP network. Software and firmware upgrades may be required on such equipment to enable QoS and high-reliability capabilities, along with the planned configuration of these features to provide for end-to-end QoS capabilities. We recommend that some testing be undertaken to ensure that the characteristics of the LAN will support IP telephony under a range of call loads during peak data traffic. This can be done using specialized simulation software and "virtual" call endpoints that simulate call loads on the network while capturing statistical information on the ability of the network to carry the voice traffic. The overall architecture of the network must be in keeping with current design rules that stipulate a hierarchy of connectivity, such as the core, distribution, and edge approach, along with using both layer 2 and layer 3 switching with VLANs. Network reliability is paramount; all financial and technically practical approaches should be considered to ensure high uptime (over 99.9%) of the network infrastructure, including the processes and procedures used for troubleshooting, upgrade, and general maintenance.

  • Data-oriented operations personnel have lower expectations of the availability, or uptime, of their network than do telephony support staff. Planned maintenance of networking equipment may include scheduled downtime, which may well be unacceptable to the phone users. There is more likelihood of problems with IP networks than with voice-only service.

  • Understand and deal with issues surrounding the powering of IP phone sets, which is a significant factor in the overall reliability of an IP telephony system.

  • IP-Centrex service, partly because of the physical separation between control and switching functions, will always involve multiple vendors, with the risk of finger-pointing. For the LAN equipment we are free to pick and choose, if the vendors support industry standards. With telephones, we will probably want to stay with one vendor; otherwise users will encounter a reduced feature set.

  • The line of demarcation between carrier and customer must be clearly identified, as the sets and switches on the users' side of the demarcation line will be totally the customer's responsibility.

  • There will always be tension between the needs for security and the desire for accessibility and mobility. The security arrangements must be monitored and tested frequently, as they will need updating to meet new threats or to handle increased traffic loads.

  • Any organization that has a number of IP-Centrex installations in different locations must have the ability to manage these networks from a central site over a WAN, typically a corporate intranet. For this purpose there should be as much conformity in access technologies, protocols, and bit rate as possible.

  • Both end-user and support personnel training are critical components to any voice technology implementation, and they are especially important with IP-Centrex. The ability to provide end users with an interface to the system, allowing them to make changes to their IP telephone, is a powerful feature that could either reduce or increase management overhead, depending on the nature of education provided.

  • Finally, a wise project manager knows that an unexpected technicians' strike, or a sudden shortage of a specific type of network interface card, can hold up installation for several weeks without warning. Since so many players are involved in the implementation of IP-Centrex at any site, it is sensible to allow at least one month's leeway for the completion date of a new or significantly enhanced service.


System Management

IP-Centrex and IP-PBXs share features that make system administration easier, as compared with legacy telephone systems. The common trend is to push down more responsibility for system administration from the expensive expert to the user (which, in turn, is part of the larger push for cost saving that has all of us dialing complex number codes and counting out our own bank notes at an automatic teller machine). With IP telephony services and systems, the user may move an IP phone from one outlet to another on the same network, since the device is self-registering with the controller-so users could essentially handle the physical moves. Individual users can also set up some features on their own phones, such as ring patterns and tones, together with icons used on the screen.

An internal system administrator using a Web-based browser package can change calling features and forwarding patterns, set up UM mailboxes, and manipulate access to long-distance or international codes. This in-house capability not only saves the cost of work orders that were, previously, sent to the telco (which may charge $100 per hour), but also enables changes to be completed within hours, rather weeks.

With a major Centrex-based application (such as ACD for a contact center), managers, supervisors, and system administration personnel can view and print exactly the information that they need. This would include agent and group performance, load and profile management, and historical reporting.

An example of a system administration screen from Nortel's IP-Centrex Management package is shown in Figure 7.2.

Click To expand
Figure 7.2: System administration screen. (Reproduced with the permission of Nortel Networks. Copyright ©2002 Nortel Networks, All rights reserved.)

A prime characteristic of IP-Centrex is that the service is delivered over the existing LAN within a building or campus, and that a network management system for that is all ready in place. There will be the need, however, to enhance the management capabilities to support multimedia services over the previously data-only network. This VoIP traffic needs a high-performance, reliable, and flexible IP-network based on a set of techniques that will ensure the required QoS. The following list of action items is taken from a position paper published by Nortel Networks:

  • Use a high-level, software-based policy manager to define and control traffic flow, especially for premium traffic.

  • Control bandwidth utilization based on time of day, application priority, and network conditions.

  • Separate traffic into queues.

  • Mark and police entry traffic.

  • Monitor traffic levels at each outgoing interface.

  • Actively manage output queues.

  • Filter exit traffic for security and congestion control.

  • Use packet discard algorithms.


Service-Level Agreements

The convergence of voice, video, and data networks leads to the demand for toll-quality services equivalent to those delivered by legacy circuit-switched networks, but delivered on top of a packet-switched network. The ability to provide preferential, or guaranteed, service to certain traffic flows is known as QoS. QoS is designed to manipulate four key network characteristics that are analogous to a water pipe:

  • Bandwidth = width of the pipe;

  • Delay = length of the pipe;

  • Jitter = variation in length of the pipe (i.e., delay variations);

  • Packet loss = leaks in the pipe.

QoS is ultimately about the control of networks, about providing a network infrastructure that is responsive to the needs of all users, both inside and outside the organization. The overprovisioning of network resources, in the hope that full capacity will not be reached, has been a common approach with LANs. However, overprovisioning only addresses the need for increased bandwidth, while delay, jitter, and packet loss need to be addressed with other techniques.

The overprovisioning of bandwidth is not practical with WANs, where bandwidth is usually contracted with a carrier and the cost is much higher than with a LAN. It has become a common and desirable practice for the management of QoS to be defined by service-level agreements (SLAs).

Purpose of an SLA

The purpose of an SLA is to spell out the terms and conditions of a business arrangement between two or more participants. The SLA provides the "glue" for a good relationship, in which all parties may be winners. However, if participants have difficulty making and implementing commitments, the service agreement is bound to fail.

In a telecommunications systems environment, there will be a number of SLAs. For example, an internal SLA may exist between a service-providing department (e.g., IS) and a user department, or perhaps for a specific application for the organization. Another example may be an SLA within a single department, where two groups need to work together to meet a particular user need.

In most cases, an SLA is an external service agreement between an organization and its vendor. With telecom service agreements the content is not necessarily a strict legal document, but rather a statement of expectations. An SLA need not be technically detailed; it delineates "what," "when," and "(who," but not "how" or "why." You should avoid creating SLAs that are win-or-lose arrangements.

Contents of an SLA

A normal SLA will contain the following information:

  1. Names of the partner organizations to the agreement;

  2. Names of those persons who have authority to commit to the agreement;

  3. Agreement commencement and termination dates, possibly also specifying regular review dates, at which the adequacy and currency of the agreement will be determined;

  4. Details regarding what is to be delivered to whom, perhaps including when (but not how or why);

  5. Details of any crucial elements that must be provided by assignees in order to meet commitments;

  6. Service standards for delivery in terms of quality, quantity, and cost, where applicable;

  7. Definitions of noncompliance;

  8. Details on the escalation procedures required to resolve conflict, should it occur;

  9. Details about the process involved in revising or edit the SLA;

  10. Details of the process regarding agreement termination;

  11. Details regarding penalties which would apply for nonperformance;

  12. Implementation details.

Implementation of an SLA

SLA implementations can take two forms. Often a dry run or pilot test is held for a month or two, to ensure that the parties understand their commitments and can deliver as promised. On other occasions, implementation commences at a given point and revisions are processed through the terms of the SLA.

With all good SLAs the partners must have a positive attitude and a strong desire to make the agreement work. If the agreement fails, or creates negative feelings, then it is considered a management failure by all. The best SLAs are those that exist through mutual trust and personal relationships, rather than those where changes to the agreement seem to be going on perpetually.

Importance of an SLA

In the last few years, senior managers have led the move to using SLAs, both within organizations (i.e., between departments) and between organizations. SLAs are used in many contexts apart from the telecom business, but are especially crucial in the related areas of multimedia communications and supporting applications, such as ACD, CRM, and UM.

The popularity of extensive outsourcing arrangements, to allow organizations of all sizes to concentrate on their core competencies and to move away from service activities that are difficult to maintain (e.g., because of skilled personnel shortages), plays a large part in this greater interest in SLAs. This trend is consistent with the development of IP-Centrex services.


Personnel and Training Requirements

One major advantage frequently claimed for legacy Centrex service was that it needed fewer support people than an in-house PBX system, both at the system analyst/administrator level and at the console operator level. The average PBX (within a typical office complex) tends to require one analyst and two operators for every 1,000 users on the system. A commonly accepted figure for a Centrex-based service is one analyst and two operators per 3,000 users (i.e., locals). Many of these savings are the result of sending most change orders to the telco for implementation, along with the inherent DID characteristics of Centrex.

Voice and Video

A supposed advantage of IP telephony systems, whether Centrex or PBX, is that end users can configure their own phones-but that is true only to a limited extent. The majority of callers into an organization, and most people within it, depend on telephones for real-time, person-to-person communications.

A PC on a desktop may be, largely, an island of personal preference, but this cannot be the case with our phones, as these must be closely integrated into a dynamic system with widespread connections. An organization needs people who possess, or can be trained in, the administrative and technical skill sets to match IP telephony resources to everyone's needs.

All of this means that IP-Centrex will likely continue to need the same number of telephony support personnel that were in place for legacy Centrex. However, this complement of analysts will fall to about one-quarter of those needed for a complete in-house PBX solution in many organizations, because the integration and administration of application subsystems (such as messaging, contact centers, relationship management, and wireless integration) will be the responsibility of the service provider.

Training Needs

Each IP-Centrex-using organization will need to invest in professional training for voice service management, along with good user education, but will gain the benefit of more versatile system administrators and a simpler user environment than was previously the case. In a new generation Centrex solution, the professional telecom analyst will need to be conversant with not only the features of a telephone system, but also much that pertains to the underlying Internet protocol network and multimedia communications systems.

In many cases, these needs will be addressed by the cross-training of voice personnel on data and vice versa, together with support personnel all being trained on the implications of real-time multimedia communications.


User Groups

As the market has become more competitive and vendors have become more careful with their money, the major associations for telecommunications users, such as the International Communications Association (ICA) in the United States and the Canadian Business Telecommunications Alliance (CBTA) in Canada, have faded away, with the result that their Centrex special interest groups have been lost as well. This trend is unfortunate, because accessible user groups can be valuable forums in which to share experiences with other users and information with vendors and customers. Two user groups remain specifically for Centrex customers in North America.

The National Centrex Users Group (NCUG), which is somewhat misnamed, as it has one Canadian director and a number of members from outside the United States, provides Centrex users with a platform to deal with product development, product delivery, and regulation issues. NCUG has good relationships with service providers and switch manufacturers, and provides free membership for end users and associate members. The NCUG operates a 3-day conference in the United States in late March of each year; it also publishers a quarterly newsletter.

Nortel Networks has now consolidated its separate Canadian and American user organizations into one DMS-Centrex users' group, to provide a forum for all those customers whose Centrex service is delivered from Nortel-made COs. Meetings of the predecessors to this Nortel group were lively events in the 1980s when digital Centrex was first introduced, but they did not see significant activity in the past decade, as third generation Centrex remained quite stable.

With the arrival of IP-Centrex, combined with the likely growth in the number of service providers and customers, the value of user groups is expected to be much greater over the next few years.


Chapter 8: Marketing and Selling IP-Centrex

Where IP-Centrex Will Win

The dominant manufacturers of Centrex systems have adopted the philosophy that the marketing of the service is a three-sided arrangement, a partnership of the system supplier, the service provider (often the telco), and the customer (or end user). The aim of this partnership is to provide the most cost-effective, multimedia telecommunications services, while keeping the customer's transactions on a shared public network.

A survey by Nortel Networks asked telecom and IT managers to rate the relative importance of a number of needs, on a scale of zero to three. The results of the survey appear in Figure 8.1. A significant finding from the survey is that managers identified less expensive networks and less costly administration as their two most important needs.

Click To expand
Figure 8.1: Enterprise convergence needs. (Reproduced with the permission of Nortel Networks. Excerpted from Nortel Networks DMS/Centrex Sales Handbook, Copyright © 1996 Nortel Networks, All rights reserved.)

The benefits to an enterprise of using hosted VoIP (in other words, IP-Centrex) are as follows:

  • Network consolidation that results in long-distance savings;

  • Reduced costs of MACs;

  • Productivity improvements with collaborative services;

  • Extended service reach and ubiquity.

While some of these benefits can be claimed for IP-PBXs, which are owned and (usually) operated by the customer, the advantages of IP-Centrex can be quantified for those organizations that have a significant number of telecommuters and mobile professional workers (say, more than 10% of their employees), who also benefit from unified messaging and shared applications. A Nortel study that compared IP-Centrex and PBX costs for a company with several fairly large branch offices (at least 100 employees per office) is summarized in Table 8.1. The business model used for this case study included the full purchase cost of hand- or headsets and was inclusive of LAN upgrades.

Table 8.1: IP-Centrex Versus PBX: Cost Savings
Employee Category | Annual Savings Person Savings | Percentage of Costs Saved
Branch office worker | $270 | 30%
Telecommuter | $1,100 | 60%
Mobile professional | $1,250 | 75%
Branch office worker | $270 | 30%
Telecommuter | $1,100 | 60%
Mobile professional | $1,250 | 75%

Most studies of the competition between Centrex and PBXs clearly show that PBX vendors gain most of the business for medium-sized, single-site enterprise communication systems. Where multiple office sites are served by one telco within a Local Access and Transport Area (LATA) in the United States or within an extended area service, legacy Centrex has been attractive, compared with multiple PBX systems and a network of leased lines.

Those owners of small businesses and home offices who were aware of Centrex have gained benefits from that service. The concept of national Centrex, with harmonized features and billing, has been developed, and international Centrex has been demonstrated, but not really used so far.

The advent of IP-Centrex should change the shape of the telecommunications marketplace, as it could be made attractive to small businesses and to organizations that are geographically distributed, to the national or international level, as summarized in Table 8.2.

Table 8.2: IP-Centrex Market Segmentation
System Size And Location | Small (2 to 50 locals) | Medium (50 to 500 locals) | Large (over 500 locals)
Single-site | Centrex appears attractive | PBXs win most business | PBXs and Centrex share business
Multisite (intra-LATA) | Centrex wins over a PBX-based network |  |
Multisite (intercity or international) | Centrex should do well with access to a managed VPN |  |

Two more dimensions that are difficult to portray in this table are:

  1. The users' requirements for integrated applications;

  2. The proportion of mobile/remote users within the organization.

These two factors should make the choice of IP-Centrex decisive. If an organization has already decided to outsource its Web site or its messaging service to a provider on a contract, then it is a prime candidate for IP-Centrex services. A Lucent executive was quoted in 1999 as stating that "there couldn't be a better time for Centrex, as network convergence creates options for new business services and better efficiency."

In order to identify which organizations should be the targets for Centrex marketing efforts, it is useful to know the distribution of companies by type of industry. Figure 8.2 (taken from U.S. Census Bureau statistics) shows that more than 70% of large companies (companies with over 500 employees) can be classified as being within six industry groups. These numbers can be safely extrapolated to most countries with a modern infrastructure.

Click To expand
Figure 8.2: Large companies by industry classification. (Reproduced with the permission of Nortel Networks. Excerpted from Nortel Networks DMS/Centrex Sales Handbook, Copyright © 1996 Nortel Networks, All rights reserved.)

Another set of figures shows that 18% of these large organizations are local in scope, while 20% are nationwide and 26% have an international presence. It is easy to guess that education and health care organizations are frequently local operations. However, large financial and professional services companies often have national or international activities and, therefore, should be prime prospects for IP-Centrex.

Significantly, while these quoted statistics show publicly funded organizations, direct governmental administrations that operate at three or four levels in most countries are not included. Most governments have offices in many locations and, frequently, find it difficult to recruit and retain well-qualified telecom and IT professionals. We can state unequivocally that government organizations are excellent candidates for IP-Centrex.


Effects of Centrex Tariffs

In many jurisdictions Centrex remains regulated, with tariffs set by a government-appointed commission because it is considered a voice-access service. Regulation usually applies to the incumbent telco but is often not enforced for any CLEC, which would be expected to hold a smaller share of the local telecom market than the former monopoly carrier. Because of this regulation, most of those concerned with Centrex, whether vendors or customers, still refer to the monthly rental charges as a "tariff" (using the word as both a noun and a verb).

Now that it has become common for data communication services in competitive markets to be deregulated, we expect that the rates for some parts of an IP-Centrex service, such as call processing and use of applications, may be free from regulation. The access component of IP-Centrex, whether provided by a telco or cableco, will probably remain regulated for a while. Regardless of the terminology used, the feedback from Centrex customers and prospects, as typified by Figure B.1 in Appendix B, shows that overall cost remains the deciding factor in any "Centrex or PBX?" analysis. Also, telecom and IT managers expect IP-Centrex tariffs to be lower than legacy Centrex tariffs, since local switching of calls occurs in customer-owned data switches and much of the phone set administration becomes the customer's responsibility. The traditional discounts that apply for larger numbers of "lines"' (or attached stations) and for contract duration (or "rate stability contracts") should be available but be as simple as possible.

For a negative example, the first tariffs that were published for Centrex service in London started with a minimum of 200 lines per site, had six size bands, and different rates for one, two, or more sites with one customer, as illustrated in Table 8.3. The limitations and complexity of this legacy Centrex offering do not reflect the opportunities with IP-Centrex.

Table 8.3: Centrex Tariffs For Mercury Communications
Number of Lines Per Site | Dollars per Month Per Service Line
 | One Site | Two Sites | Three Sites or More
200 (min) | 28.00 | 29.00 | 30.25
201-300 | 28.00 | 29.00 | 30.25
301-450 | 25.00 | 26.50 | 28.00
451-600 | 23.25 | 24.50 | 25.00
601-900 | 22.50 | 24.00 | 25.00
901 and up | 21.75 | 23.25 | 24.00

Some large Centrex service providers have included a PSTN access charge in their tariffs, where a public network connection is needed for all outgoing calls and for access to voice mail. A typical tariff for offices served by one CO appears in Table 8.4. This tariff could set the pattern for one approach to IP-Centrex rates, with the monthly charges for endpoints and message boxes being unregulated and the access link (probably shared by voice, video, and data) having a regulated tariff.

Table 8.4: Three-Part Legacy Centrex Tariff
Centrex Locals | Contract Duration
 | Monthly ($) | 1 Year | 3 Years | 5 Years
1 to 100 | $25.60 | $24.20 | $22.20 | $21.00
101 and over | $24.70 | $20.70 | $15.50 | $14.30
Mailboxes
1 to 500 | $8.20 | $7.90 | $6.30 | $6.20
501 to 2,000 | $8.20 | $7.35 | $5.65 | $5.50
2,000 and over | $8.20 | $7.35 | $5.40 | $5.25
PSTN access rates (per month):
One to five connections = $10.20 each
Six or more connections = $17.40 each

A monthly IP-Centrex rate for each voice endpoint should probably be set at around 60% of the corresponding legacy Centrex tariff, to be fair to the service provider and customer (e.g., from $15 per station for small quantities on a monthly basis to $8 for larger sites with a 5-year contract).

The arrival of IP-Centrex presents a good opportunity to break new ground by selling telephone and multimedia services truly on a usage basis, rather than by the number of lines or mailboxes. Some suggested unit pricing is shown in Table 8.5. The daily volume figures in this table apply to the estimated number of calls, transactions, or messages handled by each appropriate endpoint. We have assumed 20 working days in an average month.

Table 8.5: Suggested Unit Pricing For IP-Centrex
IP-Centrex Function | Cents per unit | Daily Volume | Monthly Cost
Simple voice call | 1 | 40 | $ 8
Small group video | 4 | 20 | $ 16
Large group video | 10 | 10 | $ 20
Contact center transactions | 2 | 100 | $ 40
CRM software trans. | 5 | 100 | $100
UM storage (40 KB) | 1 | 60 | $ 12

For example, a typical office worker utilizes the phone for 25% of the day, with an average call duration of 3 minutes, for about 40 calls each day. Also, 30 seconds of voice mail or several pages of text may occupy approximately 40 KB of disk space, so this is a suitable measure for pricing UM storage.

We should emphasize that these suggestions for IP-Centrex usage rates do not include the cost of the shared broadband access link between the service provider's and the customer's sites. Based on the estimates quoted in Chapter 3, derived from Table 3.3, the monthly cost of IP-Centrex access for the typical voice user should be well below $5 per month.

The proposed unit prices shown in Table 8.5 should be subject to the widely accepted two-dimensional discounts for contract size and duration. At the maximum, these reductions would amount to about 40% off the amounts quoted in the table.


Who Will Buy IP-Centrex?

The availability and characteristics of IP-PBXs have somewhat changed the factors that define excellent opportunities for IP-Centrex. For example, an organization with multiple locations was considered a good prospect for legacy Centrex. Now that IP telephony can be implemented with either an IP-enabled PBX or IP-Centrex, this consideration is no longer distinctive.

If you know the profile of the organizations that are likely to rent IP-Centrex, you should be able to focus on those good prospects and do a complete job of specifying the optimum solution for those customers. The concerns of a typical IP-Centrex customer now consist of two parts: considerations that are general to Centrex (as a rented, outsourced service) and considerations that are more specific to IP-Centrex (with powerful call-processing capabilities and related applications situated in the network, rather than on the customer's premises). The general Centrex-favoring factors are:

  • Purchases are based on value, not simply on cost.

  • Operating expenses are preferred to capital investments.

  • Office size or telecom needs are changing quickly.

  • Do not want to own or manage telephone systems.

Those additional factors, which tend to favor IP-Centrex, may be summarized as follows:

  • Multiple business sites, especially nationwide or international, with a managed intranet is in use or planned (as described in Section 6.6).

  • There are major requirements for flexible video or multimedia communications.

  • More than 10% of employees are at-home workers, telecommuters, or travel extensively.

  • There is significant need for contact center or unified messaging capabilities.

  • Seasonal activities change telecom requirements considerably;

  • Major IT activities, such as Web sites, are outsourced.

Small businesses, with up to 50 employees, are good IP-Centrex prospects, especially if they provide professional services, such as law firms, insurance agents, financial advisors, real estate agents, or health care centers. These small operations do not have any dedicated IT or telecom personnel, and thus rely on technical support from the service provider. Additionally, the advantages of combining all access lines into one are more significant for the smaller-scale offices.

The senior management of large organizations now view telecommunications as a strategic resource. These corporations expect high standards of quality, reliability, support, and vendor reputation, with ease-of-use and a full range of advanced features that enable outstanding customer service levels. Major businesses that handle large volumes of inbound or outbound calls worry about jeopardizing sales and customer service operations when their system is running at full capacity.

The redundancy of servers and network accesses that is the hallmark of carrier-based IP-Centrex is especially attractive in this environment.

These five questions may help a manager make the IP-Centrex or IP-PBX choice:

  1. Is it significantly easier to obtain an annual operating budget rather than a capital budget for the purchase of telecom and IT technology? That is, does your company prefer "pay as you go" solutions?

  2. Is management concerned about head count? Would they prefer to run operations with limited internal support personnel?

  3. Are you finding it difficult to recruit competent network support personnel?

  4. Does your company experience fluctuation in staffing levels?

  5. Are you concerned with the ability of telephony system vendors to provide reliable service and support?

Two or more "yes" answers to these questions indicate that an organization should at least consider IP-Centrex service, if and when it becomes available in its location(s).

To summarize, in the medium and large telecom markets the organizations that are considered to be good IP-Centrex prospects are as follows:

  • Financial services, especially banks;

  • Retail store chains;

  • Governments at all levels;

  • Educational institutions of all types;

  • Businesses that prefer outsourced solutions.


Enlarging the IP-Centrex Marketplace

Even though the host hardware, software, and support for IP-Centrex can be more easily scaled to match demand than that for legacy Centrex, the system still represents a significant investment for the service provider. There is, therefore, a good incentive to use the following strategies to enlarge the market and so optimize the return on this front-end expenditure.

Reselling

Because of the availability of discounts (for quantity of lines and contract duration) in Centrex's tariff structure, resellers can take advantage of the margin at the retail level.

Over the last two decades some of the telcos have actively encouraged these aggressive, sales-oriented companies to sell Centrex-based local and long-distance packages. Some resellers grew to have tens of thousands of Centrex lines rented by their customers. Unfortunately, in recent years, the rapidly falling rates for toll calls and the costs of serving many small customer sites have pushed many CLECs into bankruptcy, and forced others to dilute their ownership as a way of reducing their excessive debts.

In closely related telecom markets, such as selling key telephone systems or retailing cellular/mobile phones, independent companies continue to handle most of the business, and these are obvious candidates to sell IP-Centrex successfully.

Application Service Providers

According to market research published by Nortel Networks, "over 40% of medium and large enterprises want to outsource the implementation of IP telephony solutions and lease the technology from a service provider." The service provider that can package complex applications, such as contact center operations or unified messaging, with the multimedia services of IP-Centrex, should be able to make a powerful sales proposition to at least half of the businesses in its area.

Experienced system integrators who understand LAN-based traffic are in a good position to implement an effective IP telephony system with an excellent QoS.

IP-Centrex is not always easy to install on an enterprise LAN, as it is essential to ensure that no switch ports are generating jitter, to determine which IP phone's NIC is sending out unwanted bursts of data, and to design a VLAN to segregate priority traffic correctly. Companies that have built up a team of systems engineers with current IP-networking expertise will be in high demand as the pace of IP-Centrex implementation accelerates.


Appendix A: Useful Addresses

Apparatus Vendors (Telephone Sets; Consoles; DSL Hardware)

  • Aastra Technologies Limited http://www.aastra.com

  • ADC-The Broadband Company http://www.adc.com

  • Avanti, Inc. http://www.telradusa.com

  • Conveyant Systems, Inc. http://www.conveyant.com

  • dba Telecom Corp. http://www.dbatele.com

  • Locus Dialog (automatic speech recognition) http://www.locusdialog.com

  • MCK Communications, Inc. http://www.mck.com

  • Mite1 Networks, Inc. http://www.mitel.com

  • Pingtel Corp. http://www.pingtel.com

  • Siemens AG http://www.siemens.com

  • T-Metrics, Inc. http://www.t-metrics.com

  • Telcordia Technologies, Inc. http://www.telcordia.com

  • Tone Commander Systems, Inc. http://www.tonecommander.com


Centrex System Vendors

  • Alcatel http://www.alcatel.corn

  • Ericsson http://www.ericsson.com

  • Lucent Technologies http://www.lucent.com

  • Nortel Networks http://www.nortelnetworks.com

  • Siemens ICN http://www.siemens.corn

  • Sylantro Systems Corp. http://www.sylantro.com


Information Sources

  • Angus Telemanagement http://www.angustel.ca

  • Business Communications Review http://www.bcr.com

  • Business Research Group http://www.businessresearchgroup.com

  • Computer Telephony (articles on IP-Centrex and New Centrex) http://www.cconvergence.com

  • Faulkner Information Services http://www.faulkner.com

  • InfoTelecom http://www.comtois-carignan.ca

  • International Softswitch Consortium http://www.softswitch.org

  • IP-Centrex.org (Web site to share information about IP Centrex) http://www.ip-centrex.org

  • Mier Communications, Inc. (product testing services) http://www.mier.com

  • Newton's Telecom Dictionary http://www.harrynewton.com http://www.telecombooks.com

  • pulver.com (Jeff Pulver-Reports and Events) http://www.pulver.com

  • State of Minnesota (paper on Centrex versus PBX) http://www.mainserver.state.mn.us/intertech/

  • Telecom Applications Research Alliance http://www.tara.ca


IP-PBX System Vendors

  • Alcatel http://www.alcatel.com

  • Avaya http://www.avaya.com

  • Cisco http://www.cisco.com

  • Mite1 Networks, Inc. http://www.mitel.com

  • NEC America, Inc. http://www.nec.com

  • Nortel Networks http://www.nortelnetworks.com

  • Siemens ICN http://www.siemens.com

  • 3COM Corp. http://www.3com.com


Service Providers/Telcos

  • Aliant (Atlantic Canada-Business Communication Services) http://www.nbtel.ca http://www.mtt.ca

  • AT&T Canada http://www.attcanada.com

  • Bell Canada http://www.bell.ca

  • BellSouth (Centrex) http://www.bellsouth.com

  • British Telecom / BT (FeatureNet Services) http://www.bt.com

  • Cable & Wireless UK (Managed Voice Services) http://www.cw.com

  • Pingtel Corp. http://www.pingtel.com

  • Qwest Communications International, Inc. (Centrex PRIME) http://www.qwest.com

  • SBC Corp. (Centron) http://www.sbc.com

  • T-Systems (Deutsche Telecom) http://www.tsystems.com

  • Telstra (CustomNet) http://www.telstra.com.au

  • Telus http://www.telus.com http://www.telus.ca

  • Verizon (Centrex Plus and Intellipath) http://www.verizon.com


Software Vendors (ACD, CTI, System Management)

  • Aspect Communications (IP Contact Centers) http://www.aspect.com

  • Perimeter Technology http://www.ip-acd.com

  • Strata Group, Inc. http://www.stratagroup.com

  • Telesoft Corp. http://www.telesoft.com

  • Xtend Communications http://www.xtend.com


User Groups

  • National Centrex Users Group http://www.centrexncug.org

  • Nortel Networks http://www.nortelnetworks.com


Appendix B: Centrex Versus PBX

"A New Look at an Old Debate"[*]

"The issue isn't which is better-it's which is better for your organization."

--Ian Angus

Telecom professionals have wrestled with the "(Centrex-versus-PBX" debate for decades. The fact that it is still a hot topic-that both types of business communication systems do well in the market-shows that there is no simple answer to the question, "Which is better?" It's more appropriate to ask, "Which is better for our organization?" But that question isn't easy to answer either.

Background

PBXs-telephone switching systems located on the customer's premises-have been with us since the late nineteenth century. They provide the ability to make internal calls without using the public network and allow many telephone users to share a smaller group of outside lines for inbound and outbound calls.

In the 1950s, some organizations in the United States and Canada grew so large that no PBX could support all of the phones they needed. The Bell System responded by proposing what today might be called "hosted PBX"-they would use their exchange equipment (commonly called a central office) to provide PBX-like service. Centrex was born.

For users, Centrex was pretty much like the old PBX. Internal calls were dialed using abbreviated 3-, 4-, or 5-digit extension numbers, and external calls had to be preceded by a special code, usually 9. Every phone company had its own variation on the theme, but five consistent characteristics distinguished Centrex from PBXs and defined its advantages:

  • Central Office Location: The switching equipment was located in the phone company's premises.

  • Extension-Based Rates: Instead of renting equipment, the customer rented "service," with the price dependent on the number of extensions installed.

  • Wide Area Coverage: Extensions could be located anywhere in the central office's local serving area, with no additional circuit or "mileage" charges.

  • Direct-In Dialing: Each extension had a seven-digit phone number that could be dialed directly from the outside world without operator intervention.

  • Extension LD Bills: The phone company provided a separate longdistance bill for each extension.

In the early days, the DID feature locked up blocks of 1,000 local numbers at a time, whether they were needed or not, so the phone companies only offered Centrex to large customers.

Centrex did well in large organizations until the mid-1970s, when Nortel, ROLM, AT&T, and other companies introduced PBXs that had hundreds of new features, took up much less space than their predecessors, and even supported direct-in dialing and long-distance call detail. Many observers predicted the death of Centrex, but the phone companies fought back with varying degrees of success by introducing new, feature-rich Centrex systems.

In general, Canadian telephone companies offered advanced Centrex more quickly than did U.S. companies and have been more aggressive in marketing it. As a result, Centrex has a larger share of the business telephone market in Canada than south of the border.

Canadian phone companies have also had considerable success offering Centrex to the small business market. The extreme case is NBTel, where about 98% of multiline customers use Centrex. That reflects marketing decisions to offer Centrex to everyone, and to price the service so attractively that PBX and key system suppliers have difficulty competing.

Bell Canada's LocalLink product is actually a packaged Centrex service that offers dial tone plus eight bundled features for about $26.50 per month to customers in the 2- to 100-line range. Bell Nexxia Vice President May Scally tells us that it is "selling like hot cakes," because it offers a low price combined with simple, one-stop shopping.

Market researchers at NBI/Michael Sone Associates estimate that there are about 2.3 million Centrex extensions and about 11.5 million PBX and key system stations in operation in Canada today.

The numbers cannot be compared directly because about 20% of Centrex lines are actually provided on a wholesale basis to resellers, and because many of the key systems are connected to Centrex lines.

Nevertheless, these figures do show that significantly more customers use on-premise equipment than Centrex.

Is It Just Perception?

In 1998, Nortel Networks commissioned a study on why customers chose a PBX over Centrex or vice versa. The responses, as shown in Figure B.1, were remarkably parallel.

Click To expand
Figure B.1: Primary reasons for choosing Centrex or PBX.

This might be interpreted as proving that the only difference between PBX and Centrex is perception-that customers are not objective about their equipment choices. Indeed, in our experience, a good sales pitch may be the most important deciding factor for some customers.

But there's more involved than that. As we will see, the arguments for the superiority of Centrex or PBX systems are almost always double-sided. On cost, for example, one customer's financial situation may make rental more attractive, while another would find outright purchase the best choice.

It is also noteworthy that "historical reasons" was the third most frequently cited reason for choosing Centrex and the fourth for choosing PBX. In other words, customers often decide to stay with the type of system they have used in the past or are using in other locations. There's nothing wrong with that: staying with the devil you know is often the wisest decision, and a homogeneous telecom environment is usually preferable to one that features multiple technologies and suppliers.

But Which Is Better?

Okay, but what if you don't have "historical reasons" and you have not been convinced by the salespeople on either side? Which way should you go?

To start with, let's state the obvious: tens of thousands of organizations use Centrex or PBX systems and are perfectly happy with their choices. If they aren't happy, it's much more likely to be because the supplier isn't doing a good job with configuration, management, or support than because the technology is inadequate. And it's important to bear in mind that Centrex pricing, features, and availability can and do vary significantly from one phone company to another, much more so than for PBXs. So use the following points as guides, but check with your supplier about pricing and options in your areas before making a decision.

Fifteen Points

  1. Equipment Space: This is Centrex's one absolute advantage over a PBX. With a PBX you'll have to provide an equipment room with air conditioning, power, security, and so on. With Centrex, most of the equipment is located off-site, and the telephone company pays for space, power, and cooling. We have seen cases in which this alone tipped the balance to Centrex.

  2. Ownership: This is the PBX's one absolute advantage. By definition you cannot own Centrex, so if that's important to you, a PBX is a better choice. But if you don't want to own, for tax or other reasons, a Centrex rental may be attractive.

  3. Direct-In Dialing: In the past, only Centrex offered the ability to dial a seven-digit number from the outside world directly to an extension, and some large organizations justified Centrex on the savings in operator salaries alone. DID is now available on any PBX, and auto attendant is a reasonable substitute in many cases, so that one is a wash.

  4. Cost: Typically, a PBX has a high capital cost and a relatively low monthly cost for maintenance. With Centrex there is no capital cost, but the monthly costs are usually higher, and since it's a rental they go on forever. In either case you'll pay installation and trunk charges. It is difficult to do a straight cost comparison; a lot will depend on your organization's cost of capital and tax rate, and on the number of years used for the analysis. For some organizations, Centrex is financially attractive simply because capital dollars are hard to come by but the operating budget is flexible; in others, exactly the opposite is true.

  5. Pricing Flexibility: Telco-provided Centrex is a tariffed service. That means that the rates are fixed-no negotiation on the main components. That can be an advantage or a disadvantage, depending on your situation.

  6. Choice of suppliers: Unhappy with your supplier? In major cities you can almost always find some other company to take over PBX maintenance. Even if you don't really want to change suppliers, having a choice improves your negotiating position when the maintenance contract comes up for renewal. But with Centrex, you're stuck. The only way to change suppliers is to change to a different Centrex system, if indeed there is an alternative Centrex provider in your area.

  7. Management and Control: Historically telephone companies have been very protective of their central office equipment and reluctant to let customers do much Centrex configuration and programming. With a PBX, if you are prepared to train and retain the necessary staff, there isn't much you can't do in-house.

    With Centrex, changing trunk configurations still requires service orders in most cases. But many telcos now offer terminals that Centrex customers can use to make most station and feature changes. Bell Canada calls this option Station Configuration Management (there's a minimum charge of $300 a month, and installation is about $5,000, so it obviously isn't meant for small or midsized organizations).

  8. Management Reports: Both PBXs and Centrex can provide reports of long distance and network usage, traffic data and call blockage reports, feature activation, and so on. With many PBX-based reporting systems you can get the reports in real time, and you have quite a bit of control over format and content. In most cases with Centrex, you'll have to wait for the telco to run and deliver the reports.

  9. Call Center Support: You can get the most commonly used automatic call distribution features on either Centrex or a PBX. But when it comes to advanced features such as computer telephone integration and real-time configuration management, PBX-integrated ACDs have a significant edge because of the difficulties of implementing them over data links to a central office. (However, if you need really sophisticated call center features, a stand-alone ACD system will often be better than either.).

  10. Reliability: If it's configured for full hardware and software redundancy, and has a well-planned backup power system, a PBX can be nearly as reliable as a central office-based telephone system. But let's face it, nothing really matches the famous "five nines" reliability of the public network.

  11. Entry Cable: Increasingly, the phone companies are using fiber-optic cable to deliver dial tone into office buildings, and in such cases there won't be much difference between the outside cabling for Centrex or PBX. But if they are still using traditional copper wire to your building, Centrex requires a separate pair for every phone, all the way back to the central office. All that wire has to enter the building and be terminated somewhere; we've seen cases in which the space required for cable was bigger than a normal PBX room!

  12. Multiple Location Support: Historically, this has been one of Centrex's biggest advantages. It is true that you can now support multiple offices on a single PBX using off-premise extensions or remote modules of various kinds, and you can combine several PBXs into a single-image system using leased digital lines and networking software-many organizations do so. Still, it's easier and often cheaper to do it with Centrex, using the telephone company's ubiquitous local network to deliver single-system dial tone to all of your offices in a city. The ability to implement a single citywide phone system is the primary reason for Centrex's widespread use by governments. Note, however, that there may be restrictions on multilocation Centrex service. Bell Canada, for example, requires you to have 160 extensions served by each of two different wire centers, and at least 1,000 extensions in the city, to qualify for multiwire-center service and rates.

  13. Future Proofing: In theory, one advantage of renting is that you don't bear the burden of keeping the technology current, installing the latest software and hardware upgrades, and so on. If you just don't want to deal with such things, Centrex is a good choice. But if you want to have access to the latest technology and features as soon as they emerge from the labs, think twice. Historically, new options have been developed and widely implemented sooner for PBXs than for Centrex. What's more, with a PBX you have some control about if, when, and how the latest software or hardware is installed. With Centrex, those decisions are up to your supplier.

  14. Growth: There is virtually no limit to the number of extensions that can be supported by a single Centrex system. What's more, you can add extensions one at a time, and only pay for the ones you use. PBXs tend to grow in jumps-you must add cards, shelves, or cabinets to support growth. If the existing cabinets are full, it can be very expensive to add even one phone. Smart managers buy PBX systems that can handle growth, but with Centrex you don't have to. (Counterpoint: Some phone companies charge extra to keep spare Centrex capacity and numbers available.)

  15. Decline: On the other hand, Centrex can be very appropriate for organizations that need many phones today but expect to need substantially fewer in the near future or whose requirements fluctuate significantly with the seasons. Bear in mind, however, that your monthly rate may increase substantially if your extension count falls below the required minimum, and that you can incur large installation charges to reconnect the lines you removed for the winter.

Either Centrex or PBX will meet your basic communications needs, and most of your more complex requirements, if it is installed, configured, and managed properly. The differences are matters of degree, and the importance of each of these issues will depend on your organization's specific needs and preferences.

In general, if you want to own, manage, and control your business systems, you'll be attracted to PBX systems. If you strongly prefer a pay-as-you-go rental, with all or most of the management and maintenance handled by the supplier-and especially if you want one system to serve multiple offices in a single city-you'll like Centrex.

And if you are in between, you'll have to weigh the issues and make a tough decision based on your specific needs.

[*]Copyright © 2001 Angus Telemanagement Group. Reprinted by permission from Telemanagement: The Angus Report on Business Telecommunications in Canada (http://www.angustel.ca).


gloss_A

Team LiB

Appendix C: Centrex Glossary

A

ACD
Automatic call distribution
ADL
All-digital loop
ADSL
Asymmetric digital subscriber line
AP
Application processor
API
Application programming interface
ATM
Asynchronous transfer mode
AT&T
American Telephone & Telegraph
AVVID
Architecture for Voice, Video and Integrated Data-Cisco
AWG
American Wire Gauge Bandwidth


gloss_B

Team LiB

B

Bandwidth
The transmission capacity of a communications channel, measured in hertz (analog) or bits per second (digital)
BHCA
Busy hour call attempts
BHCC
Busy hour call completions
Bluetooth
A standard for short-range wireless cominunication between a variety of desktop and personal devices
BRI
Basic rate Interface-ISDN
BT
Britain's largest telecom carrier, formerly British Telecom


gloss_C

Team LiB

C

CAR
Committed access rate
CAS
Channel Associated Signaling
CASP
Communications application service provider
CBTA
Canadian Business Telecommunications Alliance, now defunct
CDMA
Code-division multiple access
CDR
Call detail recording
Centrex
Central exchange service
CFG
Centrex feature gateway
Class 4
Switch used in a tandem office, controlling high-capacity toll connections
Class 5
Switch used in local end office, providing customer services
CLEC
Competitive local exchange carrier
CM
Cable modem
CO
Central office
Codec
Coder-decoder device
CRM
Customer relationship management
CS 2000
Softswitch for carrier-based call processing by Nortel
CTI
Computer telephony integration
C&W
Cable & Wireless


gloss_D

Team LiB

D

Demarc
The demarcation line between the telco's and customer's equipment
DID
Direct-inward dialing
DMS
Digital Multiplexed System by Nortel
DSL
Digital subscriber line,

See also ADSL.

See also HDSL.

See also xDSL.

DSLAM
Digital subscriber line access multiplexer
DSP
Digital signal processor
DWDM
Dense wavelength division multiplexing


gloss_E

Team LiB

E

El
The European 2.048 Mbps transmission system to ITU standards
E.164
The ITU recommended numbering plan in the PSTN
EDS
Electronic data systems
Erlang
One hour of telecommunications traffic
ERP
Enterprise resource planning
Ethernet
Commonly used name for the IEEE 802.3 LAN standard
ETSI
European Telecommunications Standards Institute
EWSD
Digital Electronic Switching System by Siemens
Exchange
The Microsoft Office automation package
Extranet
A controlled use of the Internet for business applications


gloss_F

Team LiB

F

FR
Frame relay (See definition below.)
Firewalls
Systems that enforce a boundary between two or more networks for the purpose of network protection
Frame relay
A switching technology used to transmit packetized digital data over wide area networks


gloss_G

Team LiB

G

G.711
Algorithm for digitally encoded voice signals at 64 Kbps
G.723.1
Algorithm for low bit rate encoded voice, at 5.3 Kbps
Gbps
Gigabits per second or one billion bits per second
GPRS
General packet radio service
GSM
Global system for mobile communications


gloss_H

Team LiB

H

H.248
The ITU standard for MGCP
H.323
The ITU's overall standard for a set of standards that define real-time communication over packet networks
HIP
Hosted Internet protocol
HDSL
High-rate digital subscriber line
HTML
Hypertext markup language
HTTP
Hypertext transfer protocol


gloss_I

Team LiB

I

IAD
Integrated access device
ICA
International Communications Association
ICP
Integrated Communications Platform, by Mitel
IEEE 802.11
A set of standards that apply to wireless LANs
IETF
Internet Engineering Task Force
ILEC
Incumbent local exchange carrier
IN
Intelligent network
Intranet
Closed user group network to Internet standards
IP
Internet protocol
Ipsec
Internet protocol security
ISDN
Integrated services digital network, basic and primary
ISP
Internet service provider
IT
Information technology
ITG
Internet Telephony Gateway by Nortel
ITU
International Telecommunications Union
IVR
Interactive voice response


gloss_J

Team LiB

J

Jitter
Differing latency for different packets in a transmission


gloss_K

Team LiB

K

KHz
Kilohertz
Kbps
Kilobits per second
KTS
Key telephone system


gloss_L

Team LiB

L

LAN
Local area network
LATA
Local access and transport area
Latency
Time delay or waiting time
LDP
Label distribution protocol
Linux
Operating system based on UNIX
LNP
Local number portability


gloss_M

Team LiB

M

MAC
Moves, adds, and changes
Mbps
Megabits per second or one million bits per second
MGCP
Media gateway control protocol
Minitel
Videotex service widely used in France
MIS
Management information system
MPLS
Multiprotocol label switching


gloss_N

Team LiB

N

NAP
Network access point
NBX
Network Branch exchange, by 3COM
NIC
Network interface card/chip
NYNEX
New York and New England telephone company (now Verizon)


gloss_O

Team LiB

O

OA&M
Operation, administration, and maintenance
OS
Operating system
OSI
Open systems interconnection


gloss_P

Team LiB

P

PBX
Private branch exchange
PC
Personal computer
PCS
Personal communication service
PDA
Personal digital assistant
PRI
Primary Rate Interface-ISDN
PSTN
Public switched telephone network
PSU
Power supply unit


gloss_Q

Team LiB

Q

QoS
Quality of service


gloss_R

Team LiB

R

RSVP
Resource reservation protocol


gloss_S

Team LiB

S

SCM
Station Configuration Management
SCP
Service control point
SIP
Session initiation protocol
SLA
Service level agreement
SNMP
Simple network management protocol
Softphone
A software package that enables a PC to emulate a telephone
Softswitch
Industry-standard hardware equipped with call-processing software to replace a circuit-switching CO
SOHO
Small offce/home office
SS7
Signaling system number 7
STP
Signaling transfer point


gloss_T

Team LiB

T

T1
The North American standard for a digital 1.5-Mbps link
T3
The North American standard for a digital 45-Mbps link
TARA
Telecom Applications Research Alliance
TCP
Transmission control protocol
TDM
Time-division multiplexing
TDMA
Time-division multiple access
Telco
The local telephone company
Telstra
Australia's largest telecommunications carrier
ToIP
Telephony over Internet protocol


gloss_U

Team LiB

U

UCD
Uniform call distribution
UDP
User datagram protocol
UM
Unified messaging
UNIX
Operating system that runs on a wide variety of computers
UPS
Uninterruptible power supply
USB
Universal Serial Bus
UTP
Unshielded twisted pair


gloss_V

Team LiB

V

VLAN
Virtual local area network
VoIP
Voice or Video-Conferencing over Internet Protocol
VPN
Virtual private network


gloss_W

Team LiB

W

WAN
Wide area network
www
World Wide Web or Web


gloss_X-Z

Team LiB

X-Z

xDSL
Generic abbreviation for any type of digital subscriber line


index__Numbers

Team LiB

Index

Numbers

3COM, 68-69
defined, 68
IP phones, 69
NBX, 68, 70
See also IP-PBX systems
911 requirements, 91-92
3100 Integrated Communications Platform (ICP), 59-60


index_A

Team LiB

Index

A

Addresses, 131-36
apparatus vendors, 131-32
Centrex system vendors, 132-33
information sources, 133-34
PBX system vendors, 134
service providers/telcos, 135-36
software vendors, 136
user groups, 136
Alcatel
address, 132
OmniPCX 4400, 53-55
OmniTouch, 54
proprietary telephones, 53
PWT 4073 handset, 53
Alcatel 5000 softswitch, 24
defined, 24
network topology with, 25
See also IP-Centrex systems
Apparatus vendor addresses, 131-32
Application service providers (ASPS), 129
Attendant consoles, 35, 98
Attractions, 87-89
capital costs, 87
computer-telephony integration, 88
convergence, 87-88
inside wiring, 89
local access cabling, 88-89
multiple locations and mobility, 88
provider infrastructure, 89
provider WAN, 89
simplification of MACs, 88
UM, 88
See also IP-Centrex evaluation
Autoattendant services, 38
Automatic call distribution (ACD), 39
Automatic speech recognition (ASR), 38
Avaya, 55-56
defined, 55
Enterprise Class IP Solutions (ECLIPS), 55
media servers, 55
software packages, 56
See also IP-PBX systems


index_B

Team LiB

Index

B

Broadband
availability, 44-46
connectivity concern, 92-93
defined, 44
installation, 98
interconnect, 98
methods, 45
Broadworks package, 30


index_C

Team LiB

Index

C

Cable modems (CMs), 45, 47-48
defined, 47
disadvantages, 48
pricing, 48
Cable & Wireless (C&W) Centrex, 2
Cabling
categories, 106-8
as key to "clean" installation, 108
CallManager, 56-58
clustering, 58
defined, 56-57
installation, 57
server, 30
See also Cisco Systems
Canadian Business Telecommunication Alliance (CBTA), 117
Capital costs, 87
Carrier/customer demarcation, 110
Centrex
analog, 2
background, 137-39
Basic Rate ISDN, 2
Cable &Wireless (C&W), 2
decision points, 141-44
distinguishing characteristics, 138
extensions, 139
introduction, 1-8
lines in service, 1
multiple systems, 6
PBX vs., 137-44
percentage of business telephone lines, 1-2
positives and negatives, 3
primary reasons for choosing, 139
rationale for, 2-4
service through remote CO modules, 3
software, investment in, 6
space advantage, 4
system vendor addresses, 132-33 See also IP-Centrex
Centrex tariffs, 122-26
IP-Centrex tariffs vs., 123
for Mercury Communications, 124
three-part, 125
Cisco Systems, 30-31, 56-59
AWID products, 31, 56
CallManager, 30, 56-58
Unity voice mail system, 58
See also IP-Centrex systems; IP-PBX systems
Committed access rate (CAR), 42-43
Communications application service provider (CASP), 20-21
Competitive local exchange carriers (CLECs), 5
Computer-telephony integration, 88
Concerns, 90-93
911 requirements, 91-92
broadband connectivity and call processing, 92-93
messaging and directory integration, 93
network considerations, 91
operational costs, 90
phone power, 92
security, 90-91
stability, 90 See also IP-Centrex evaluation
Contact center applications, 39-40
Convergence
as attraction, 87-88
enterprise, needs, 120
Customers, 126-28
favoring factors for, 126-27
parts, 126
prospects, 128
questions for, 127-28
CustomNet, 28
C&W, 59


index_D

Team LiB

Index

D

Decision points, 141-44
call center support, 142
choice of suppliers, 142
cost, 141
decline, 144
direct-in dialing, 141
entry cable, 143
equipment space, 141
future proofing, 143-44
growth, 144
management and control, 142
management reports, 142
multiple location support, 143
ownership, 141
pricing/flexibility, 141
reliability, 143 See also Centrex; PBX
Dense wavelength division multiplexed (DWDM) fiber, 49
Digital cellular wireless, 45
Direct inward dialing (DID), 4
Distributed contact center, 99-100
cost comparison, 101
IP-Centrex estimates, 100 See also IP-Centrex evaluation
DSL services, 45, 46-47
bandwidth, 46
customers, 47
parameters, 46
pricing, 47


index_E

Team LiB

Index

E

EIA/TIA Building Telecommunications Wiring Standards, 106-7
Ericsson, 24-26
address, 132
G-Nexus, 24-25
IP-Centrex contributions, 24-25
IPT 2.1 domains, 26
See also IP-Centrex systems
Extended Ethernet, 45, 49


index_F

Team LiB

Index

F

Financial analyses, 93-95
approximations, 94
inside wiring, 94
investment period, 94
telephone sets, 95
See also IP-Centrex evaluation
Frame relay (FR) technology, 19
Full IP-Centrex, 14-15


index_G

Team LiB

Index

G

General packet radio service (GPRS), 48
GeoCENTREX, 29
G-Nexus, 24-25


index_H

Team LiB

Index

H

HiPath, 65-67
3000, 65-66
4000, 67
5000, 67
See also Siemens
Hosted Internet protocol (HIP) telephony, 32
Hybrid IP-Centrex service, 13-14
mukilocation, 14
single-location, 13 See also IP-Centrex


index_I-J

Team LiB

Index

I-J

iCentrex, 26
IEEE 802.11b standard, 36-37
iMerge, 26, 27
Implementation guidelines, 108-11
Incumbent local exchange carriers (ILECs), 5
Information source addresses, 133-34
Inside wiring
as attraction, 89
in financial analyses, 94
Installation, 105-6
documentation, 109
physical, 109
Integrated services digital network (ISDN), 2, 32, 45
International Communications Association (ICA), 116-17
Internet Protocol-based telephony products. See IP-Centrex; IP-PBX
Internet Protocol (IP)
defined, 9
interactive communications over, 9-12
interface standards, 11-12
OSI protocol stacks and, 10
telephony, 10-1 1
Voice over (VoIP), 10-11, 17, 18, 119-20
IP-Centrex, 9-21
advantages, 7
boundaries and, 8
cabling, 106-8
call control, 8
configurations, 12-15
contact center applications, 39-40
controlled migration to, 19-20
customers, 126-28
as decisive choice, 121
deployment strategies, 19-21
development of, 6-8
favoring factors, 126-27
features and applications, 31-32
full, 14-15
Greenfield implementation, 20
hybrid service, 13-14
implementation guidelines, 108-11
installing, 105-6
LAN requirements, 18
local access facilities, 42-49
managed networks, 40-42
marketplace, enlarging, 128-29
market segmentation, 122
monthly rate, 124
network considerations, 16-19
PBX vs. (cost savings), 121
personnel/training requirements, 115-16
pilot trials, 6
service delivery, 11 1
softswitch characteristics, 15-16
success, 119-22
success key, 11
suggested unit pricing for, 126
telephone sets/consoles, 32-35
unified messaging (UM), 37-38
user groups, 116-17
VoIP requirements, 16-18
WAN requirements, 18-19
wireless capabilities, 35-37
worldwide, 27 See also Centrex
IP-Centrex evaluation, 87-103
attractions, 87-89
concerns, 90-93
distributed contact center, 99-100
financial analyses, 93-95
multisite organization, 100-102
single-site organization, 95-99
summary, 102
IP-Centrex Prospects, 75-79
health care corporation, 77-78
municipal government, 75-77
for small and home office (SOHO), 78-79
solo consultant, 78
IP-Centrex systems, 23-31
Alcatel, 24
Cisco Systems, 30-31
Ericsson, 24-26
Lucent Technologies, 26-27
management, 11 1-12
Nortel Networks, 27-28
overview, 23-24
product descriptions, 23
Siemens ICN, 29-30
softswitch products, 23
summary, 49
Sylantro Systems, 31
Tacqua Systems, 31
IP-Centrex trials, 83-86
network, 84
SBC Communications, 85
UTO, 85-86
IP-PBX systems, 51-74
3COM, 68-69
advantages, 69-71
Alcatel, 53-55
architectures, 51-52
Avaya, 55-56
capital cost, 71-72
Cisco Systems, 56-59
comparison, 73-74
concerns, 71-73
current, 53-69
C&W, 59
Mitel Networks, 59-60
NEC, 60-63
Nortel Networks, 63-65
"pure," 51-52
Siemens, 65-67
slow acceptance of, 7
Verizon, 59
IP phones, 32-35
3COM, 69
advantages, 35
examples, 33-35
illustrated, 34
ISDN sets vs., 33
maintenance, 99
Nortel Networks, 64
two-level market, 33
IP security (IPsec), 41, 42


index_K

Team LiB

Index

K

Key telephone systems (KTSs), 2
linking to PSTN, 4
support, 5


index_L

Team LiB

Index

L

Label distribution protocol (LDP), 42
Leased digital links, 45
Local Access and Transport Area (LATA), 120
Local access cabling, 88-89
Local access facilities, 42-49
broadband availability, 44-46
cable modems, 47-48
DSL services, 46-47
extended Ethernet, 49
next generation wireless services, 48
Local area networks (LANs), 40-41
physical costs, 108
requirements, 18
virtual (VLANs), 40
wireless, 37
See also Wide area networks (WANs)
LocalLink product, 139
Local multipoint distribution services (LMDS), 45
Lucent Technologies, 26-27
address, 132
iCentrex, 26
iMerge Centrex Feature Gateway (CFG), 27
iMerge gateway, 26
in provincial government Centrex, 81
See also IP-Centrex systems


index_M

Team LiB

Index

M

Managed networks, 40-42
LAN considerations, 40-41
WAN requirements, 41-42
Market segmentation, 122
Media gateway controllers (MGC), 12
Microwave radio, 45
Mitel Networks, 59-60
3100 Integrated Communications Platform (ICP), 59-60
converged communications, 61
defined, 59 See also IP-PBX systems
Multiprotocol label switching (MPLS), 12, 41-42
customer edge routers, 42
use of, 42
Multisite organization, 100-102
cost comparison, 103
IP-Centrex financial advantage, 102 See also IP-Centrex evaluation


index_N

Team LiB

Index

N

NEC, 60-63
NEAX 1000, 61
NEAX 2000 Express, 61, 62
NEAX 2000 IPS, 62
NEAX 2400 IPX, 63 See also IP-PBX systems
Nortel Networks, 27-28, 63-45
address, 132
Centrex IP for extended service reach, 28
CSE 1000, 64, 65
CustomNet, 28
Internet Trunk Gateway (ITG), 63
IP-Centrex technology trials, 28
IP phones, 64
users group, 117 See also IP-Centrex systems; IP-PBX systems


index_O

Team LiB

Index

O

OmniPCX 4400, 53-55
contracts, 55
defined, 53
illustrated, 54 See also Alcatel
Open System Interconnection (OSI), 9
Operational costs, 90


index_P

Team LiB

Index

P

PBX, 2-3
background, 137-39
Centrex vs., 137-44
decision points, 141-44
distinguishing characteristics, 138
key system stations, 140
primary reasons for choosing, 140
replacement, 5
sales fall-off, 71
system vendor addresses, 134
TDM-based, replacing, 71
virtual service, 4 See also IP-PBX
Personnel/training requirements, 11 5-16
Phone power, 92
Private branch exchange. See PBX
Provincial government Centrex, 79-83
distributed contact center, 81-82
effectiveness, 82-83
outsourcing, 79-80
overview, 79
technology trial, 83
telephone services/systems, 80-8
I voice messaging, 81 See also IP-Centrex
Public Switched Telephone Network (PSTN), 4
access, 98
gateway, 98


index_Q

Team LiB

Index

Q

QoS, 113


index_R

Team LiB

Index

R

Real-Time Transport Protocol (RTP), 10
Reselling, 128-29


index_S

Team LiB

Index

S

Security, 90-91
Service level agreements (SLAs), 113-15
contents, 114
defined, 113
implementation, 114
importance, 115
purpose, 113-14
Service provider/telco addresses, 135-36
Session initiation protocol (SIP), 12, 32
Siemens, 29-30, 65-67
address, 133
Broadworks package, 30
CorNet package, 66-67
GeoCENTREX, 29
HiPath, 65-67
IP phone, 35
RG 2500, 67 See also IP-Centrex systems; IP-PBX systems
Single-site organization, 95-99
administrator interface, 98
administrator/support, 98
attendant console, 98
broadband installation and rentals, 98
broadband interconnect, 98
cost comparison, 97
defined, 95-96
feature installation, 96
feature rental, 98
infrastructure components, 95, 96
line installation, 96
line rental, 96
phone maintenance, 99
phones, 96
PSTN access, 98
PSTN gateway, 98
quantity, 99
system installation, 98-99
system maintenance, 99
unit cost, 99 See also IP-Centrex evaluation
Softswitch(es)
carrier grade products, 16
characteristics, 15-16
configuration, 17
defined, 15
residence, 16
as software-based CO replacements, 15
telecom service management and, 16
Software vendor addresses, 136
Stability, 90
Switched ISDN channels, 45
Sylantro Systems, 31, 133
System management, 111-12


index_T

Team LiB

Index

T

Tacqua Systems, 31
Time-division multiplexing (TDM), 7
Training, 115-16
needs, 116
voice and video, 116
Transmission control protocol (TCP), 10


index_U

Team LiB

Index

U

Unified messaging (UM), 37-38
as attraction, 88
defined, 37
first-year costs, 38
major capability, 37
proponents, 37
speech-enabled call routing, 38
Uniform call distribution (UCD), 39
Unshielded twisted pair (UTP), 105
User datagram protocol (UDP), 10
User groups, 116-17
addresses, 136
CBTA, 117
ICA, 116-17
Nortel Networks, 117, 136
UTO IP-Centrex trial, 85-86


index_V

Team LiB

Index

V

Verizon, 59
Virtual LANs (VLANs), 40
Virtual PBX service, 4
Virtual private networks (VPNs), 19, 41
IP-MPLS, service classes, 41
typical configuration, 43
Voice over Internet Protocol (VoIP), 10-11
bandwidth requirements, 18
hosted, benefits, 119-20
jitter, 18
network criteria, 17
packet loss, 18
requirements for, 16-18


index_W-Z

Team LiB

Index

W-Z

Wide area networks (WANs), 12
MPLS and, 12
requirements, 18-19, 41-42 See also Local area networks (LANs)
Wireless capabilities, 35-37
categories, 36
IEEE 802.11b standard and, 36-37
Wisconsin field trial, 83-84


List of Figures

Chapter 1: Introduction to Centrex

Figure 1.1: Centrex service through remote CO modules.
Figure 1.2: PBX replacement and KTS support.

Chapter 2: Internet Protocol Centrex

Figure 2.1: IP and OSI Protocol stacks.
Figure 2.2: Single-location hybrid IP-Centrex.
Figure 2.3: Multilocation hybrid IP-Centrex.
Figure 2.4: Pure IP-Centrex configuration.
Figure 2.5: Softswitch configuration.
Figure 2.6: Controlled migration to IP-Centrex.

Chapter 3: IP-Centrex Systems and Applications

Figure 3.1: Network topology with Alcatel 5000 softswitch.
Figure 3.2: Ericsson's IPT 2.1 domains.
Figure 3.3: Worldwide IP-Centrex.
Figure 3.4: Centrex IP for extended service reach. (Reproduced with the permission of Nortel Networks. Copyright © 2002 Nortel Networks, All rights reserved.)
Figure 3.5: Next generation local switch services.
Figure 3.6: Mitel's 5140 IP Appliance. (Reproduced with the permission of Mitel Networks.)
Figure 3.7: Typical VPN configuration.
Figure 3.8: All-digital loop architecture.

Chapter 4: IP-PBX Systems and Applications

Figure 4.1: Business telephone line market in 2001. (Reproduced with the permission of Nortel Networks. Copyright 2002 Nortel Networks, All rights reserved.)
Figure 4.2: Architecture of Alcatel's OmniPCX 4400.
Figure 4.3: Cisco CallManager clustering.
Figure 4.4: Converged communications in the enterprise by Mitel.
Figure 4.5: NEAX 2000 Express system.
Figure 4.6: Succession CSE 1000 configuration. (Reporduced with the permission of Nortel Networks. Copyright © 2002 Nortel Networks, All rights reserved.)
Figure 4.7: Capacity of HiPath 3000 call servers.
Figure 4.8: Siemens' HiPath systems and terminals.

Chapter 5: IP-Centrex-Prospects and Pilot Trials

Figure 5.1: Municipal locations.
Figure 5.2: Healthcare network integrates four hospitals.
Figure 5.3: Major cities in Ontario.
Figure 5.4: IP-Centrex trial network.

Chapter 6: Evaluating IP-Centrex

Figure 6.1: Typical infrastructure components for IP-Centrex.

Chapter 7: Implementing and Managing IP-Centrex

Figure 7.1: End-to-end components with a LAN.
Figure 7.2: System administration screen. (Reproduced with the permission of Nortel Networks. Copyright ©2002 Nortel Networks, All rights reserved.)

Chapter 8: Marketing and Selling IP-Centrex

Figure 8.1: Enterprise convergence needs. (Reproduced with the permission of Nortel Networks. Excerpted from Nortel Networks DMS/Centrex Sales Handbook, Copyright © 1996 Nortel Networks, All rights reserved.)
Figure 8.2: Large companies by industry classification. (Reproduced with the permission of Nortel Networks. Excerpted from Nortel Networks DMS/Centrex Sales Handbook, Copyright © 1996 Nortel Networks, All rights reserved.)

Appendix B: Centrex Versus PBX

Figure B.1: Primary reasons for choosing Centrex or PBX.


List of Tables

Chapter 1: Introduction to Centrex

Table 1.1: Centrex Positives and Negatives

Chapter 2: Internet Protocol Centrex

Table 2.1: VoIP Network Criteria

Chapter 3: IP-Centrex Systems and Applications

Table 3.1: First-Year Costs of UM System
Table 3.2: Service Classes in an IP-MPLS VPN
Table 3.3: Desirable Access Rates for Different Organizations
Table 3.4: Typical DSL Service Parameters

Chapter 4: IP-PBX Systems and Applications

Table 4.1: Avaya Media Server's Capabilities
Table 4.2: Line and Station Capacities of 3COM's NBXs
Table 4.3: Infrastructure Capabilities of NBX Systems
Table 4.4: Comparing Eight IP-PBX Systems

Chapter 6: Evaluating IP-Centrex

Table 6.1: Single-Site Cost Comparison (350 Subscribers)
Table 6.2: Distributed Contact Center Cost Comparison (200 Agents)
Table 6.3: Multisite City Government Cost Comparison (2,200 Users)

Chapter 8: Marketing and Selling IP-Centrex

Table 8.1: IP-Centrex Versus PBX: Cost Savings
Table 8.2: IP-Centrex Market Segmentation
Table 8.3: Centrex Tariffs For Mercury Communications
Table 8.4: Three-Part Legacy Centrex Tariff
Table 8.5: Suggested Unit Pricing For IP-Centrex
Team LiB
Previous Section