Building the Perfect PC, 2nd Edition

Next Page

Book Cover
Building the Perfect PC, 2nd Edition
By Barbara Fritchman Thompson, Robert Thompson
...............................................
Publisher: O'Reilly
Pub Date: December 01, 2006
ISBN-10: 0-596-52686-5
ISBN-13: 978-0-596-52686-3
Pages: 352

Table of Contents | Index
Overview

This popular Build-It-Yourself (BIY) PC book covers everything you want to know about building your own system: Planning and picking out the right components, step-by-step instructions for assembling your perfect PC, and an insightful discussion of why you'd want to do it in the first place. Most big brand computers from HP, Dell and others use lower-quality components so they can meet their aggressive pricing targets. But component manufacturers also make high-quality parts that you can either purchase directly, or obtain through distributors and resellers. Consumers and corporations alike are opting to build rather than buy PCs to ensure high quality and compatibility.

The new edition of Building the Perfect PC shows you how to construct a variety of top-flight systems with the latest technology, including AMD Socket AM-2 and Intel Core 2 processors, that are Vista- and Linux-ready. The book includes several new options, including:

  • A Budget PC you can build for approximately $350 that offers performance and reliability similar to that of mainstream systems

  • A full-blown media-center system that runs Linux and MythTV or Windows MCE with multiple tuners and HDTV support

  • A fire-breathing high-performance gaming system

  • A fast, low-power, low-heat, low-noise, Small Form Factor system (the size of a shoe box)

  • A low-cost SOHO (small office, home office) server system with a 2 terabyte (2,000 GB) disk subsystem that's suitable for a residential environment rather than a server closet

Regardless of your technical experience, Building the Perfect PC will guide you through the entire process of building or upgrading your own computer. You'll use the latest top-quality components, including Intel's Core 2 Duo and AMD's Athlon X2 CPUs. And you'll know exactly what's under the hood and how to fix or upgrade your PC, should that become necessary. Not only is the process fun, but the result is often less expensive and always better quality and far more satisfying than anything you could buy off the shelf.

Next Page


Table of Contents

Previous Page

Book Cover
Building the Perfect PC, 2nd Edition
By Barbara Fritchman Thompson, Robert Thompson
...............................................
Publisher: O'Reilly
Pub Date: December 01, 2006
ISBN-10: 0-596-52686-5
ISBN-13: 978-0-596-52686-3
Pages: 352

Table of Contents | Index

Copyright
Dedication
Foreword to the Second Edition
Preface
Chapter 1. Fundamentals
 | Section 1.1. Why Build a PC?
 | Section 1.2. Designing the Perfect PC
 | Section 1.3. Things to Know and Do Before You Start
 | Section 1.4. Things You Need to Have
 | Section 1.5. Getting to Know Your Motherboard
 | Section 1.6. Troubleshooting
Chapter 2. Choosing and Buying Components
 | Section 2.1. Choosing Components
 | Section 2.2. Buying Components
 | Section 2.3. Final Words
Chapter 3. Building a Mainstream PC
 | Section 3.1. Determining Functional Requirements
 | Section 3.2. Hardware Design Criteria
 | Section 3.3. Component Considerations
 | Section 3.4. Building the Mainstream PC
 | Section 3.5. Post-Assembly
 | Section 3.6. Final Words
Chapter 4. Building a SOHO Server
 | Section 4.1. Determining Functional Requirements
 | Section 4.2. Hardware Design Criteria
 | Section 4.3. Component Considerations
 | Section 4.4. Building the SOHO Server
 | Section 4.5. Final Words
Chapter 5. Building a Gaming PC
 | Section 5.1. Determining Functional Requirements
 | Section 5.2. Hardware Design Criteria
 | Section 5.3. Component Considerations
 | Section 5.4. Building the Gaming PC
 | Section 5.5. Final Words
Chapter 6. Building a Media Center PC
 | Section 6.1. Determining Functional Requirements
 | Section 6.2. Hardware Design Criteria
 | Section 6.3. Choosing Software
 | Section 6.4. Component Considerations
 | Section 6.5. Building the Media Center PC
 | Section 6.6. Final Words
Chapter 7. Building a Small Form Factor (SFF) PC
 | Section 7.1. Determining Functional Requirements
 | Section 7.2. Hardware Design Criteria
 | Section 7.3. Component Considerations
 | Section 7.4. Building the SFF PC
 | Section 7.5. Final Words
Chapter 8. Building a Budget PC
 | Section 8.1. Determining Functional Requirements
 | Section 8.2. Hardware Design Criteria
 | Section 8.3. Component Considerations
 | Section 8.4. Building the Budget PC
 | Section 8.5. Final Words
About the Authors
Colophon
Index

Previous Page


Copyright

Building the Perfect PC, Second Edition

by Robert Bruce Thompson and Barbara Fritchman Thompson

Copyright © 2007, 2004 Robert Bruce Thompson and Barbara Fritchman Thompson. All rights reserved.

Printed in Canada.

Published by O'Reilly Media, Inc., 1005 Gravenstein Highway North, Sebastopol, CA 95472.

O'Reilly books may be purchased for educational, business, or sales promotional use. Online editions are also available for most titles (safari.oreilly.com). For more information, contact our corporate/institutional sales department: 800-998-9938 or corporate@oreilly.com.

Print History:

August 2004: | First Edition.
December 2006: | Second Edition.

Editor: | Brian Jepson
Production Editor: | Philip Dangler
Cover Designer: | Karen Montgomery

The O'Reilly logo is a registered trademark of O'Reilly Media, Inc. The MAKE: Projects series designations, Building the Perfect PC, and related trade dress are trademarks of O'Reilly Media, Inc.

Many of the designations used by manufacturers and sellers to distinguish their products are claimed as trademarks. Where those designations appear in this book, and O'Reilly Media, Inc. was aware of a trademark claim, the designations have been printed in caps or initial caps.

While every precaution has been taken in the preparation of this book, the publisher and authors assume no responsibility for errors or omissions, or for damages resulting from the use of the information contained herein.

Cover photograph features:

Antec NSK1300 case
Gigabyte GeForce 7600GS video adapter
Hauppauge WinTV-PVR 150 TV capture card
Intel D946GZIS motherboard
Intel Core 2 Duo E6300 processor
Seagate Barracuda 7200.10 750 GB hard drive
Thermalright XP-120 CPU cooler

This book uses RepKover™, a durable and flexible lay-flat binding.

ISBN-10: 0-596-52686-5

ISBN-13: 978-0-596-52686-3

[F]


Dedication

To Mark Brokering, who came up with the idea and kept the ball rolling.


Foreword to the Second Edition

I was asked to revise the Foreword I wrote for the first edition of this book, but I found there was no need. A few details have changed, but the principles haven't.

However, the details are important. My main systems at Chaos Manor now mostly run with dual core (both Intel and AMD) CPU chips. Since the first edition of Building the Perfect PC, the video card scene has changed several times. Intel lost its dominance as the maker of the fastest desktop CPUs for the money. AMD took advantage of the Intel stumble and surged ahead to its highest market share yet. AMD and nVIDIA joined forces, and now AMD has bought ATI. Case designs have changed. We have both DDR and DDR2 RAM to contend with.

If you have the first edition, you know how important the book is, and when you contemplate building a new system, you'll be wise to upgrade. And if you don't have the first edition, this remains the best book you can buy if you're building or planning to build a PC. Now read the Foreword to the first edition.

Jerry Pournelle, Chaos Manor, December 2006

Foreword to the First Edition

I presume you're reading this because you've either just bought this book, or you're thinking of buying it; so let's get that out the way now. Should you buy this book, or, having bought it, should you be happy you did? The answer is yes. If the subject of building your own computer interests youand why in the world are you reading this if it doesn't?then you need this book.

That out of the way, we can look at the broader question of whether you should build your own computers.

As I look around Chaos Manor (http://www.jerrypournelle.com) I see that I have over 20 computers, all networked, and I built nearly every one of them myself. The exceptions are Princess, an ancient Compaq desktop Professional Workstation running Dual Pentium Plus 200 MHz CPUs; a Mac; a Tablet PC; and another laptop. No one in his right mind builds his own laptop or Tablet. I keep Princess because I've had her for a decade, and she hasn't been shut down in more than a year, and I haven't the heart to scrap her; besides, she's still useful for doing long web searches. Until fairly recently I had a Compaq Professional Workstation (Dual 750 MHz Pentium III) as my communications system, but I retired it a few months ago in favor of a new 3 GHz built here, and since then every server and workstation added to the Chaos Manor network was built here. Clearly I must like building systems and using them.

It wasn't always this way. Until a few years ago I had at least as many brand-name systems as home-built "white boxes." Then came the consumerization of the PC industry. Manufacturers were forced to make cost reduction after cost reduction. Some of those cost reductions were not wise. Some were disasters. Worse, component makers were themselves competing on cost. It became more and more difficult to build a quality line of PC's to sell at any realistic price.

It is still possible to buy quality computers. You'll pay for them, though, and sometimes having paid an arm and a leg you still won't know what quality you have bought. There are still big companies with mission-critical tasks who are well advised to buy the very best machines from top-of-the-line companies; but most users and small businesses would be better advised to consider building their own, or having them built to specs by a trustworthy local shopand this book is indispensable when it comes to writing out those specifications.

In general there are two reasons why you build your own systems. First is if you want the highest possible performance using only the latest and greatest components. When new and better components come out, it takes a while for commercial system builders to change over, and the first ones to come out with the latest in high performance demand and get premium prices. If you're interested in building a really screaming machine, you need this book, because building that kind of system is tricky. Components like power supplies, cases, and fans are important, and information about why they are important is often hard to come by. You'll find all the information you need in this book.

The other reason for building your own system is to get the best performance and quality for your money, and to customize your high-performance system for your specific needs. You probably don't need the very best performance available, and often you can get more than good enough systems at dramatically lower prices. These are known as "sweet-spot" systems, and once again, if that's your goal, you need this book, because that too can be tricky. Sometimes saving money isn't a good idea at all. You can fudge on some components, but you're better off paying premium for others. Bob and Barbara Thompson offer great advice on which is which.

So. If you're thinking of building your own system, you need this book to give you some notion of how difficult it's likely to be, and help you decide if it's a good idea; and if you're determined to build a PC, you need this book because most of us who build PCs have picked up a number of techniques and tricks over the years, and the Thompsons know nearly all of them. Learn from our mistakes. It's a lot easier.

Jerry Pournelle, Chaos Manor, August 2004


Preface

When we sat down to write the Preface for this second edition, we realized that, as they say, the more things change the more they remain the same.

In one sense, things have changed a lot in two years. Almost none of the components we used in the first edition are still available. They've been replaced by bigger, faster, better, cheaper parts. But those are mere details. In a fundamental sense, nothing has changed. The reasons for building your own PC are the same. The decisions you need to make differ only in details. The skills you need to master are the same, and the satisfaction you'll gain from designing and building your own PC is as great as ever.

So, on with the original preface, which we found it necessary to modify only to update information about the system configurations in the book and other similar details.

Building PCs isn't just for techies any more.

It used to be, certainly. Only gamers and other geeks actually built their PCs from the ground up. Everyone else just called the Dell Dude and ordered a system. That started to change a few years ago. The first sign was when general merchandisers like Best Buy started stocking upgrade components. If you wanted to expand the memory in your PC or install a larger hard drive or add a CD writer, you could now get the components you needed at the local big-box store.

A year or two ago, things changed again. Big-box retailers started carrying PC components like cases and motherboardsparts seldom needed by upgraders, but necessary to build a new PC from scratch. Nowadays, although CompUSA, Best Buy, and other local retailers may not carry as broad a range of PC components as some online specialty retailers, you can get everything you need for a new PC with one visit to a big-box store.

Specialty PC component superstores like Fry's carry a full range of components at extremely good prices. We wish we had a Fry's within driving distance. Then again, maybe not. There's too much good stuff there. Our credit cards are smoking already, and a trip to Fry's might be the last straw.

And you can bet that big-box stores don't allocate shelf space to products that aren't selling. Building your own PC has become mainstream. Nowadays, even regular nontechnical people build their own systems and have fun doing it. Instead of settling for a mediocre, cookie-cutter system from Dell or Gateway, they get a PC with exactly the features and components they want, at a good price, and with the pride that comes from knowing they built it themselves. They also get a faster, higher-quality PC with much better reliability than any mass-market system. No small thing, that.

Every project system in this book can be built entirely from components available at your local big-box store. If some of the components we recommend aren't in stock, one or more of the alternative components we recommend almost certainly will be. If you buy this book on a Friday, you can buy your components Saturday morning, assemble the new system Saturday afternoon, test it Sunday, and have it up and running Monday morning.

Robert visited Best Buy one day and spent some time hanging out in the PC component aisles. He watched a lot of regular people comparing hard drives, video adapters, DVD writers, and other PC components. Some of them were buying components to upgrade their current systems, but many of them were buying components to build new systems.

Robert watched one grandmotherly woman fill her shopping cart. She chose an Antec case and power supply, a Maxtor hard drive, an Abit motherboard, an AMD Athlon XP processor, an nVIDIA graphics adapter, a couple sticks of DDR memory, and a Lite-On DVD writer. He approached her, and the conversation went something like this:

Robert: "Looks like you're building a new computer."

Woman: "Yes, I'm building my granddaughter a new PC for her birthday."

Robert: "Are you worried about getting everything to work?"

Woman: "Oh, no. This is the third one I've built. You should try it. It's easy."

Robert: "I may do that."

If she'd had this book, she might have made different choices for one or two of her components. Still, Dell may have something to worry about.

Goals of This Book

This book is your guide to the world of building PCs. Its goal is to teach youeven if you have no training or prior experienceeverything you need to know to select the best components and assemble them into a working PC that matches your own requirements and budget.

We present six projects, in as many chapters, each of which details design, component selection, and assembly instructions for a particular type of PC. You can build any or all of these systems as presented, or you can modify them to suit your own requirements.

Rather than use a straight cookbook approach, which would simply tell you how to build a PC by rote, we spend a lot of time explaining why we made particular design decisions or chose certain components or did something a certain way. By "looking over our shoulders" as we design PCs and choose components, you'll learn to make good decisions when it comes to designing and building your own PC. You also learn how to build a PC with superior quality, performance, and reliability.

Not that we skimped on the how-to. Each project system chapter provides detailed assembly instructions and dozens of photographs that illustrate the assembly process. Even if you've never seen a hard drive, after reading this book you should be completely comfortable sitting down with a bunch of components to build your own PC.

If you have never built a PC, we hope this book will inspire you to build your first system. If you have some PC building experience, we hope this book will provide the ideas and advice that you need to make the next PC you build the perfect PC for your needs.

Audience for This Book

This book is intended for anyone who wants to build a PC for personal or business use. System builders of any experience level will find this book useful because it explains the concepts used to design a PC to fit specific needs and budgets, and provides the information needed to choose the best components. First-time system builders will also find this book helpful because it provides detailed step-by-step instructions for building a PC, supplemented by numerous photographs that illustrate each step in detail.

Organization of This Book

The first two chapters of this book are a short but comprehensive course in planning the perfect PC and choosing and buying components for it.

Chapter 1, Fundamentals, focuses on things you need to know, things you need to have, and things you need to do before you start to buy components and build your new PC. This chapter explains the advantages of building a PC versus buying one (YOU control quality, performance, reliability, and quietness of your components); provides design guidelines; and explains the inevitable trade-offs in performance, price, size, and noise level. We list tools and software you'll need, and provide a detailed tour of the motherboard, the most important and complex PC component. Finally, we provide detailed troubleshooting information in this chapter, because it's easier to avoid problems if you know from the beginning what to look out for. After you read this chapter, you'll be prepared for the next step, actually buying the components for your new PC.

Chapter 2, Choosing and Buying Components, tells you everything you need to know about how to choose and buy the components you need to build your new PC.

When you design and build your own PC, you get something that money can't buy if you purchase a preassembled machine: total control of quality, reliability, performance, and noise level.

We explain the important characteristics of each component and how to choose among alternatives. We also recommend specific components by brand and model number, and provide alternative recommendations for those with different requirements or smaller budgets.

The final six chapters detail project systems, any of which you can build as-is or modify to suit your particular needs. The introductory section of each project chapter is a design guide that explains the choices we made (and why) and how we decided to implement them. Following that is a detailed section on selecting components, with specific products listed by brand name, and a bill of materials at the end of the section. In each case, we list alternatives for those with different needs or budgets. The bulk of each chapter is a detailed guide, with numerous photographs, that shows you step-by-step how to build the system.

As this book went to press, Windows Vista was still in beta testing. We designed all of the project systems in the book to be capable of running Windows Vista, based on the Vista hardware requirements published by Microsoft. We also verified that each system was in fact able to load and run the most recent Vista beta release we had access to, subject to limitations such as buggy or missing drivers. It's likely that any of the systems will run the release version of Vista perfectly, but obviously we can't guarantee that until Vista actually ships, whenever that may be. At worst, the most any of these project systems should require to run the release version of Vista flawlessly are some additional memory and perhaps a more capable video adapter. Either of those upgrades is easy and inexpensive, so it's unlikely you'll paint yourself into any corners with regard to Vista if you build any of these systems as specified.

Chapter 3, Building a Mainstream PC, teaches you how to build a general-purpose PC that is a jack of all trades and a master of...well, quite a few, actually. In the standard configuration, this system combines high performance, top-notch reliability, and moderate cost. Depending on the components you chooseand how much you're willing to spendyou can make this system anything from an inexpensive entry-level box to a do-it-all powerhouse. And it's also quiet, particularly if you build it in a midrange configuration. In a normal office or home environment, you can barely hear it running.

Chapter 4, Building a SOHO Server, focuses on building a reliable, high-performance SOHO (Small Office/Home Office) server, appropriate for anything from an inexpensive server for a home office to a serious server for a small-business network. Because these requirements span a vast range, we take particular pains to detail alternative choices and configurations that are appropriate for different environments. We emphasize reliability and data safety regardless of configuration, because a server failure is as disruptive for a home office as for a small business. Accordingly, we emphasize such features as redundant disk storage and reliable backup.

Chapter 5, Building a Gaming PC, is all about building a gaming PC on a reasonable budget. Some devoted gamers spend $3,000, $4,000, $5,000, or more to buy or build a fire-breathing PC optimized for games. That's fine if you've just won the lottery, but most gamers can't justify spending that much on their systems. We set out to design and build a seriously fast gaming system that's a lot easier on the wallet. By paying careful consideration to component choices, we were able to design and build a system that offers about 90% of the performance of the extreme systems for about a third of the price.

Each project chapter is full of tips, many of which are useful no matter what type of system you build. Accordingly, we suggest you read the entire book, including all project system chapters, before you start building your new system.

Chapter 6, Building a Media Center PC, shows you how to build a PC that provides TiVo-like DVR (Digital Video Recorder) functions, without the monthly subscription or the DRM (Digital Restrictions Management) "features" common to commercial PVR units. For not much more than the price of a combination TiVo/DVD writer and program guide subscription, this PC substitutes not only for a commercial DVR unit, but also for an AV receiver, CD-ROM player, DVD-ROM player, DVD recorder, 5.1 home-theater speaker system, and a gaming console. Talk about bang for the buck.

Chapter 7, Building a Small Form Factor (SFF) PC, shows you how to build a full-featured PC that is small enough and quiet enough to fit in almost anywhere. Depending on the components you choose, you can make the SFF PC anything from an inexpensive secondary system suitable for a dorm room or child's bedroom to a primary general-purpose system to a home theater or PVR system to a barn-burner of a portable gaming system to a dedicated "appliance" system or small server.

Chapter 8, Building a Budget PC, shows you how to build a fast, reliable PC on a minimum budget. For only $300 or so (not counting external peripherals), it's possible to build a system with high quality components that matches or exceeds the performance of last year's mainstream models. We designed this budget system to be capable of running Windows Vista with at most one or two minor, inexpensive upgrades. It's ideal as a secondary systemor even a primary system, if your needs are modestand can be upgraded incrementally to add additional features.

Acknowledgments

The first edition of this book was conceived one day in late 2003, when Robert received a phone call from Mark Brokering, vice president of sales and marketing for O'Reilly Media. Mark had decided to build a new PC rather than buy one, and he'd picked up a copy of Robert and Barbara's book, PC Hardware in a Nutshell.

Mark had lots of good questions about which components to choose and, later on, questions about assembling his new system. At some point during the back-and-forth of emails and phone calls, Mark commented, "You know, we really need to do a book about building a PC." And so this book was born.

The working title was Build Your Own Computer. None of us thought that was a great title, but none of us could come up with a better one. Then one day Tim O'Reilly weighed in. "Why don't we call it Building the Perfect PC?," Tim asked. Duh. It always seems so obvious after the fact.

In addition to Mark, Tim, and the O'Reilly production staff, who are listed individually in the Colophon, we want to thank our technical reviewers. Ron Morse has been building PCs for more than 20 years. Jim Cooley has built and repaired computers from San Francisco to Athens (Ohio), with the occasional stop in Bangalore. Brian Bilbrey started with vacuum tubes and wire wrap, passed through S-100, ISA, and PCI buses, and was last seen tunneling into a quantum future. All of them did yeoman duty in finding mistakes we made and in making numerous useful suggestions, all of which helped make this a better book. We're entirely responsible for any errors that remain.

We also want to thank our contacts at the hardware companies, who provided technical help, evaluation units, and other assistance. There are far too many to list individually, but they know who they are. We also want to thank the readers of our books, web sites, and message boards, many of whom have taken the time to offer useful suggestions for improvements to this book. Thanks, folks. We couldn't have done it without you.

Finally, we want to thank our editor, Brian Jepson, who contributed numerous useful comments and suggestions.

We'd Like to Hear from You

We have tested and verified the information in this book to the best of our ability, but we don't doubt that some errors have crept in and remained hidden despite our best efforts and those of our editors and technical reviewers to find and eradicate them. Those errors are ours alone. If you find an error or have other comments about the book, you can contact the publisher or the authors.

How to Contact O'Reilly

Please address comments and questions concerning this book to the publisher:

O'Reilly Media, Inc.
1005 Gravenstein Highway North
Sebastopol, CA 95472
(800) 998-9938 (in the United States or Canada)
(707) 829-0515 (international or local)
(707) 829-0104 (fax)

There is a web page for this book, which lists errata and other information. You can access this page at:

http://www.oreilly.com/catalog/9780596526863/

You can also send us email. To be put on our mailing list or to request a catalog, send email to:

info@oreilly.com

For comments on the book, send email to:

bookquestions@oreilly.com

For more information about books, conferences, Resource Centers, and the O'Reilly Network, go to:

http://www.oreilly.com

How to Contact the Authors

To contact one of the authors directly, send mail to:

barbara@hardwareguys.com
robert@hardwareguys.com

We read all mail we receive from readers, but we cannot respond individually. If we did, we'd have no time to do anything else. But we do like to hear from readers.

There is also a web site for the book, which includes updated hardware recommendations, buying guides, and articles, as well as errata, archived older material, and so on:

http://www.hardwareguys.com

We also maintain a message board, where you can read and post messages about PC hardware topics. You can read messages as a guest, but if you want to post messages you must register as a member of the message board. We keep registration information confidential, and you can choose to have your email address hidden on any messages you post:

http://forums.hardwareguys.com/

When you see a Safari® Enabled icon on the cover of your favorite technology book, it means that book is available online through the O'Reilly Network Safari Bookshelf.

Safari offers a solution that's better than eBooks. It's a virtual library that lets you easily search thousands of top tech books, cut and paste code samples, download chapters, and find quick answers when you need the most accurate, current information. Try it for free at: http://safari.oreilly.com.

We each maintain a personal journal page, updated daily, which frequently includes references to new PC hardware we're working with, problems we've discovered, and other things we think are interesting. You can view these journal pages at:

Barbara: http://www.fritchman.com/diaries/thisweek.html
Robert: http://www.ttgnet.com/thisweek.html

Disclaimer

Much of the information contained in this book is based on personal knowledge and experience. While we believe that the information contained herein is correct, we accept no responsibility for its validity. The hardware designs and descriptive text contained herein are provided for educational purposes only. It is the responsibility of the reader to independently verify all information. Original manufacturer's data should be used at all times when implementing a design.

The authors, Robert Bruce Thompson and Barbara Fritchman Thompson, and O'Reilly Media, Inc., make no warranty, representation, or guarantee regarding the suitability of any hardware or software described herein for any particular purpose, nor do they assume any liability arising out of the application or use of any product, system, or software, and specifically disclaim any and all liability, including, without limitation, consequential or incidental damages. The hardware and software described herein are not designed, intended, nor authorized for use in any application intended to support or sustain life or any other application in which the failure of a system could create a situation in which personal injury, death, loss of data or information, or damages to property may occur. Should the reader implement any design described herein for any application, the reader shall indemnify and hold the authors, O'Reilly Media, Inc., and their respective shareholders, officers, employees, and distributors harmless against all claims, costs, damages and expenses, and reasonable solicitor fees arising out of, directly or indirectly, any claim of personal injury, death, loss of data or information, or damages to property associated with such unintended or unauthorized use.

Thank You

Thank you for buying Building the Perfect PC. We hope you enjoy reading it as much as we enjoyed writing it.


Chapter 1. Fundamentals

The idea of building their first PC intimidates a lot of people, but there's really nothing to worry about. Building a PC is no more technically challenging than changing the oil in your car or hooking up a DVD player. Compared to assembling one of those "connect Tab A to Slot B" toys for your kids, it's a breeze.

PC components connect like building blocks. Component sizes, screw threads, mounting hole positions, cable connectors, and so on are standardized, so you needn't worry about whether something will fit. There are minor exceptions, of course. For example, some small cases accept only microATX motherboards and half-height or half-length expansion cards. There are important details, certainly. You must verify, for example, that the motherboard you intend to use supports the processor you plan to use. But overall there are few "gotchas" involved in building a PC. If you follow our advice in the project system chapters, everything will fit and everything will work together.

Most compatibility issues arise when you mix new components with older ones. For example, an older video card may not fit the video slot in a new motherboard, or a new processor may not be compatible with an older motherboard. If you build a PC from all-new components, you are likely to encounter few such issues. Still, it's a good idea to verify compatibility between the motherboard and other major components, particularly CPU, video adapters, and memory. The configurations in this book have been tested for compatibility.

Nor do you need to worry much about damaging the PCor it damaging you. Taking simple precautions such as grounding yourself before touching static-sensitive components and verifying cable connections before you apply power are sufficient to prevent damage to all those expensive parts you bought. Other than inside the power supplywhich you should never openthe highest voltage used inside a modern PC is 12V, which presents no shock hazard.

This chapter doesn't cover the nuts-and-bolts details of assembling a PC, because that's covered exhaustively in text and images in the project system chapters. Instead, this chapter explains the fundamentalseverything you need to prepare yourself properly. It examines the advantages of building your own PC and explains how to design a PC that is perfect for your needs. It tells you what you need to know and do before you start the project, and lists the components, hand tools, and software tools you'll need to build your system. Because the motherboard is the heart of a PC, we include a "motherboard tour" section to illustrate each major part of the motherboard. Finally, because the best way to troubleshoot is to avoid problems in the first place, we include a detailed troubleshooting section. Let's get started.


Section 1.1. Why Build a PC?

1.1. Why Build a PC?

With entry-level PCs selling for less than $500 and fully-equipped mainstream PCs for $1,000, you might wonder why anyone would bother to build a PC. After all, you can't save any money building one, can you? Well, yes you can. But that's not the only reason to build a PC. There are many good reasons to build your own PC.

Cheaper by the Dozen?

For example, when AMD announces price reductions or a faster new version of the Athlon 64, the news stories often report "Quantity 1000" pricing for the OEM or "tray" versions. This is what a computer maker who buys processors 1,000 at a time pays. A maker who buys 100,000 at a time may pay a few dollars less per processor. If you buy just one OEM processor, you'll typically pay a couple bucks more than the Quantity 1000 pricing. You may even pay less, because PC makers often order more processors than they need to take advantage of price breaks on larger quantities, and then sell the unneeded processors at a slight loss to distributors who then sell them to retailers.

Lower cost

PC makers aren't in business for charitable reasons. They need to make a profit, so they need to sell computers for more than they pay for the components and the labor to assemble them. Significantly more, in fact, because they also need to support such expensive operations as research and development departments, toll-free support numbers, and so on.

But PC manufacturers get big price breaks because they buy components in huge volume, right? Not really. The market for PC components is extremely efficient, with razor-thin margins whether you buy 1 unit or 100,000. A volume purchaser gets a price break, certainly, but it's a lot smaller than most people think.

Mass-market PCs are inexpensive not because the makers get huge price breaks on quality components, but because they generally use the cheapest possible components. Cost-cutting is a fact of life in mass-market, consumer-grade PCs. If mass-market PC makers can save a few bucks on the case or the power supply, they do it every time, even though spending a few dollars more (or even a few cents more) would have allowed them to build a noticeably better system. If you compare apples to applesa home-built system versus, say, a business-class PC from Micron, Dell, or HPyou'll find you can build it yourself for less, sometimes a lot less. Our rule of thumb is that, on average and all other things being equal, you can build a midrange PC yourself for about 75% to 85% of what a major manufacturer charges for an equivalent top-quality system.

More choice

When you buy a PC, you get a cookie-cutter computer. You can choose such options as a larger hard drive, more memory, or a better monitor, but basically you get what the vendor decides to give you. If you want something that few people ask for, like a better power supply or quieter cooling fans or a motherboard with more features, you're out of luck. Those aren't options.

And what you get is a matter of chance. High-volume direct vendors like Dell and HP often use multiple sources for components. Two supposedly identical systems ordered the same day may contain significantly different components, including such important variations as different motherboards or monitors with the same model number but made by different manufacturers. When you build a PC, you decide exactly what goes into it.

Flexible design

One of the best things about building your own PC is that you can optimize its design to focus on what is important to you and ignore what isn't. Off-the-shelf commercial PCs are by nature jacks of all trades and masters of none. System vendors have to strike a hapy medium that is adequate, if not optimum, for the mythical "average" user.

Want a small, quiet PC for your home theater system? There are three options. You can use a standard PC despite its large size and high noise level, you can pay big bucks for a system from a specialty builder that does just what you want, or you can build your own. Need a system with a ton of redundant hard disk storage for editing video or a professional audio workstation? Good luck finding a commercial system that fits your requirements, at least at a reasonable price. When you build your own PC, you spend your money on things that matter to you and ignore those that don't.

Better component quality

Most computer vendors cut costs by using cheaper OEM versions of popular components if they're "visible" and no-name components if they're not. By "visible" we mean a component that people might seek out by brand name even in a prebuilt PC, such as an ATI or nVIDIA video adapter. Invisible components are ones that buyers seldom ask about or notice, such as motherboards, optical and hard drives, power supplies, and so on.

OEM components may be identical to retail models, differing only in packaging. But even if the parts are the same, there are often significant differences. Component vendors usually do not support OEM versions directly, for example, instead referring you to the system vendor. If that system vendor goes out of business, you're out of luck, because the component maker provides no warranty to end users. Even if the maker does support OEM products, the warranty is usually much shorter on OEM parts, often as little as 30 to 90 days. The products themselves may also differ significantly between OEM and retail-boxed versions. Major PC vendors often use downgraded versions of popular products, for example, an OEM video adapter that has the same or a very similar name as the retail-boxed product, but runs at a lower clock rate than the retail version. This allows PC makers to pay less for components and still gain the cachet from using the name-brand product.

It's worse when it comes to "invisible" components. We've popped the lid on scores of consumer-grade PCs over the years, and it never ceases to surprise us just how cheaply they're built. Not a one of them had a power supply that we'd even consider using in one of our own systems, for example. They're packed with no-name motherboards, generic memory, the cheapest optical drives available, and so on. Even the cables are often shoddy. After all, why pay a buck more for a decent cable? In terms of reliability, we consider a consumer-grade PC a disaster waiting to happen.

No bundled software

Most purchased PCs include Microsoft Windows, Microsoft Office, or other bundled software. If you don't need or want this software, building a PC allows you to avoid paying the "Microsoft tax."

If you do want commercial software, you can buy OEM versions at a bargain price when you buy your hardware components. Buying a hard drive or a motherboard entitles you to buy full OEM versions of the software you need at a large discount. OEM software includes a full license rather than an upgrade license, so you needn't own the product already to benefit from OEM software pricing. OEM software is one of the best-kept secrets in the retail channel. If you need Windows or Office, when your order components ask the vendor if it has OEM versions of the titles you want. OEM versions of Windows and Microsoft applications are "For sale only with a new PC," but Microsoft takes a liberal view of what constitutes a new PC. Buying a hard drive, motherboard, or processor entitles you to buy OEM software.

Quality Costs Money

Not all commercial PCs are poorly built. Business-class systems and gaming systems from "boutique" vendors are well engineered with top-quality components and high build quality. Of course, they also cost a lot more than consumer-grade systems.

YOU CAN'T TAKE OEM WITH YOU

OEM versions are "locked" to the system upon which you first install them, so they can't be moved to a new system later on. Full-retail and retail upgrade-only versions can be moved to a new system, as long as you delete them from the old system.

OEM Software Bargains

OEM software prices are striking. For example, when we priced motherboards for a new system in October 2006, with the motherboard we could have bought full OEM versions of Windows XP Home for $64, Windows XP Pro for $95, or Office Pro 2003 for $89. Full OEM versions sell for a small fraction of the price of full retail versions and significantly less than even upgrade-only versions, so if you need the software this is a cheap way to get it.

Warranty

The retail-boxed components you'll use to build your own PC include full manufacturer warranties, which may run from one to five years or more, depending on the component. PC makers use OEM components, which often include no manufacturer warranty to the enduser. If something breaks, you're at the mercy of the PC maker to repair or replace it. We've heard from readers who bought PCs from makers who went out of business shortly thereafter. When a hard drive or video card failed six months later, they contacted the maker of the item, only to find that they had OEM components that were not under manufacturer warranty.

Experience

If you buy a computer, your experience with it consists of taking it out of the box and connecting the cables. If you build the computer, you know exactly what went into it, and you're in a much better position to resolve any problems that may occur.

Upgradability

If you design and build your own PC, you can upgrade it later using industry-standard components. That's sometimes not the case with commercial systems, some of which are intentionally designed to be incompatible with industry-standard components. PC makers do this because they want to force you to buy upgrade and replacement components from them, at whatever price they want to charge.

Save Those Receipts

Keep receipts together with the "retain this portion" of warranty cards and put them someplace they can be found if required for future warranty service. This goes for software, too.

INTENTIONAL GOTCHAS

These designed-in incompatibilities may be as trivial as nonstandard screw sizes, or as profound as components that are electrically incompatible with standard components. For example, in the late '90s some Dell PCs used motherboards and power supplies with standard connectors but nonstandard pin connections. If you replaced a failed Dell power supply with a standard ATX power supplyor if you connected the nonstandard Dell power supply to a standard motherboardthe power supply and motherboard were destroyed as soon as you applied power to the system.


Section 1.2. Designing the Perfect PC

1.2. Designing the Perfect PC

A sign you'll see in many repair shops says, "Good. Cheap. Fast. Pick any two." That's also true of designing a PC. Every choice you make involves a trade-off, and balancing those trade-offs is the key to designing a PC that's perfect for your needs. Each of the project system chapters has a graphic that looks something like what's shown to the right.

Ah, if it were only true. Reality, of course, is different. One can't put the highest priority on everything. Something has to give. As Frederick the Great said of designing military defenses, "He who defends everything defends nothing." The same is true of designing a PC.

DESIGN PRIORITIES

Price

Reliability

Size

Noise level

Expandability

Processor performance

Video performance

Disk capacity/performance

If you focus on these elements while designing your PC, you'll soon realize that compromises are inevitable. If small size is essential, for example, you must make compromises in expandability, and you may very well have to compromise in other respects. The trick is to decide, before you start buying components, which elements are essential, which are important, which would be nice to have, and which can be ignored.

A Dissenting View

Our technical reviewer Jim Cooley says, "I disagree. You don't load the crap on your machines that Average Joe does, but if you did you'd find most crashes were software related, not hardware."

Jim is right. Years ago, before we migrated to Linux, we were very careful to avoid Windows Rot, going as far as to reinstall Windows from scratch every few months. A fresh Windows install with current drivers is reasonably stable (although not remotely in the same class as Linux), but as you use a Windows system over weeks and months, its stability degrades gradually (or not so gradually).

Once you have the priority of those elements firmly fixed in your mind, you can make rational resource allocations and good purchasing decisions. It's worth looking at each of these elements in a bit more detail.

Price

We put price first, because it's the 900-pound gorilla in system design. If low price is essential, you'll be forced to make compromises in most or all of the other elements. Simply put, high performance, reliability, low noise, small size, and other desirable characteristics cost money. We suggest you begin by establishing a ballpark price range for your new system and then play "what-if" with the other elements. If you've set too low a price, it will soon become clear that you'll need to spend more. On the other hand, you may well find that you can get away with spending less and still get everything you want in a system.

Reliability

We consider high reliability essential in any system, even the least expensive entry-level PC. If a system is unreliable, it doesn't matter how feature-laden it is, or how fast, or how cheap. We always aim for 5-star reliability in systems we design for ourselves and others, although sometimes price and other constraints force us to settle for 4-star reliability. The best mass-market systems may have 3-star reliability, but most deserve only a 1- or 2-star rating.

What does reliability mean, and how do you design for it? A reliable system doesn't crash or corrupt data. It runs for years with only an occasional cleaning. We are always amused when people claim Windows is crash-prone. That is true of Windows 9X, of course, but Windows NT/2000/XP has never blue-screened on us except when there was a hardware problem, and that's going back to the early days of Windows NT 4. We're not Microsoft fanboysfar from itbut the truth is that the vast majority of system crashes that are blamed on Windows are actually caused by marginal or failing hardware.

There are a few simple rules for designing a reliable system. First, use only top-quality parts. They don't have to be the fastest availablein fact high-performance parts often run hotter and are therefore less reliable than midrange onesbut top-quality components may be a full order of magnitude more reliable than run-of-the-mill ones. Use a motherboard built around a reliable chipset and made by a top-notch manufacturer. For Intel processors, Intel motherboards and chipsets are the standard by which we judge, and for AMD processors the same is true of ASUS motherboards and nVIDIA chipsets. Use a first-rate power supply and the best memory available. Avoid cheap cables. Keep the system cool and clean out the dust periodically. That's all there is to it. Following this advice means the system will cost a bit more, but it will also be significantly more reliable.

Determining Quality

Of course, this raises the question, how does one tell great from good from bad? Discriminating among companies and brands is difficult for someone who doesn't know which companies have an established reputation for quality and reliability, which purvey mostly junk, and which are too new to have a track record. All of the components and brands we recommend in this book are safe choices, but the proliferation of brands makes it easy to choose inferior components.

If you must use components other than those we recommend, the best way to avoid inferior components is to do your homework. Visit the manufacturers' web sites. A good web site doesn't guarantee that the products are also good, but a poor web site almost certainly means the products are also poor. Check online reviews of products you are considering, and visit discussion forums for those components. In the end, trust your own judgment. If a component appears cheap, it probably isn't reliable. If the documentation is sparse or isn't written in good English, that tells you something about the likely quality of the component as well. If the component has a much shorter warranty than similar components from other manufacturers, there's probably good reason.

Finally, although price is not invariably a perfect predictor of component quality, it's usually a very good indicator. The PC component business is extremely competitive, so if a product sells for much less than similar competing products, it's almost certain that that product is inferior.

Size

Most people prefer a small PC to a large one, but it's easy to design a system that's too small. Albert Einstein said, "Everything should be made as simple as possible, but not simpler." In other words, don't oversimplify. Use the same rule when you choose a size for your PC. Don't over-smallify.

Choosing a small case inevitably forces you to make compromises. A small case limits your choice of components, because some components simply won't fit. For example, you may have to use a different optical drive than you'd prefer because your first choice is too long to fit into the case. A small case also limits the number of components you can install. For example, you may have to choose between installing a card reader and installing a second hard drive. Because a small case can accept fewer (and smaller) fans, it's more difficult to cool the system properly. To move the same amount of air, a smaller fan must spin faster than a larger fan, which generates more noise. The limited case volume makes it much harder to work inside the case, and makes it more difficult to route cables to avoid impeding air flow. All other things being equal, a small PC will cost more, run slower, produce more heat and noise, or be less reliable than a standard-size PC, or all of those.

For most purposes, the best choice is a standard mini- or mid-tower case. A full-tower case is an excellent choice for a server, or for an office system that sits on the floor next to your desk. Choose a microATX or other small form factor case only if size is a high priority.

Noise level

Noise level has become a major issue for many people. If you think PCs are getting louder, it's not your imagination. As PCs get faster and faster, they consume more power and produce more heat. The most convenient way to remove heat is to move a lot of air through the case, which requires fans. Fans produce noise.

Just a few years ago, most PCs had only a power supply fan. A typical modern PC may have half a dozen or more fansthe power supply fan, the CPU fan, a couple of supplemental case fans, and perhaps fans for the chipset, video card, and hard drive. All of these fans are needed to keep the components cool, but all of them produce noise. Fortunately, there are methods to cool a PC properly while minimizing noise. We'll look at some of those methods later in this section.

Expandability

Expandability is worth considering when you design a PC. For some systems, expandability is unimportant. You design the system for a particular job, install the components you need to do that job, and never open the case again except for routine cleaning and maintenance. For most general-purpose systems, though, expandability is desirable. For example, if you need more disk space, you might prefer to add a second hard drive rather than replace the original drive. You can't do that unless there's a vacant drive bay. Similarly, integrated video might suffice originally, but you may later decide that you need faster video. If the motherboard you used has no AGP or PCI Express (PCIe) video slot, you're out of luck. The only option is to replace the motherboard.

Keep expandability in mind when you choose components, so you won't paint yourself into any corners. Unless size constraints forbid it, choose a case that leaves plenty of room for growth. Choose a power supply that has sufficient reserve to support additional drives, memory, and perhaps a faster processor. Choose a motherboard that provides sufficient expansion slots and memory sockets to allow for possible future expansion. Choose less flexible components only if you are certain that you will never need to expand the system.

Processor performance

Most people worry too much about processor performance. Here's the truth. Midrange processorsthose that sell for $150 to $225are noticeably faster than $50 to $100 entry-level processors. The most expensive processors, which sell for up to $1,000, are noticeably faster than midrange processors. Not night-and-day different, but noticeable. For casual usebrowsing the Web, checking email, word processing, and so onchoose a $75 "value" processor from AMD or Intel. For a general-purpose system, choose a Pentium D, Core 2, or Athlon 64 processor that sells for $150 to $225 in retail-boxed form. It makes little sense to choose a high-end processor unless cost is no object and performance is critical.

Video performance

Video performance, like processor performance, usually gets more attention than it deserves. It's probably no coincidence that processors and video adapters are two of the most heavily promoted PC components. When you design your PC, be careful not to get caught up in the hype. If the PC will be used for intense 3D gaming or similarly demanding video tasks, you need a high-end video adapter (or dual video adapters). Otherwise, you don't.

Integrated videoa video adapter built into the motherboardis the least expensive video solution, and is perfectly adequate for most uses. The incremental cost of integrated video ranges from $0 to perhaps $10, relative to a similar motherboard without integrated video. The next step up in video performance is a standalone video adapter, which requires that the motherboard have a slot to accept it. Standalone video adapters range in price from $25 or so up to $500 or more. The old 80/20 rule applies to video adapters, which is to say that a $100 video adapter provides most of the performance and features of a $500 adapter.

More expensive video adapters provide incrementally faster 3D video performance and may support more recent versions of Microsoft DirectX, both of which are of interest to serious gamers. Expensive video adapters also run hot and are generally equipped with dedicated cooling fans, which produce additional noise.

When you design your PC, we recommend using integrated video unless you need the faster 3D performance a standalone video adapter can provide. If you choose integrated video, make sure the motherboard has an AGP or PCIe slot available in case you later decide to upgrade the video.

Disk capacity/performance

A mainstream 7,200 RPM ATA or Serial ATA hard drive is the best choice for nearly any system. Such drives are fast, cheap, and reliable. The best models are also relatively quiet and produce little heat. When you design your system, use one of these drives (or two, mirrored for data protection) unless you have good reason to do otherwise. Choose a 10,000 RPM ATA drive if you need the highest possible disk performanceas for a server or personal workstationand are willing to pay the price. Avoid 5,400 RPM ATA drives, which cost only a few bucks less than 7,200 RPM models, but have noticeably poorer performance.

AGP Versus PCIe

AGP is an older video adapter interface that is gradually being replaced by the newer PCIe interface. Many AGP motherboards and video adapters are still availableand are likely to remain so for quite some timebut AGP is a dying standard. For example, when we searched the NewEgg site in November 2006, we found 150 AGP video adapter models available, versus 356 PCIe models. When we did that search a few months earlier, there were about 200 AGP models, versus about 300 PCIe models.

AGP video adapters and motherboards, with few exceptions, are restricted to older technology. The latest and fastest video and motherboard chipsets and support for the fastest memory are available only in PCIe models. Although it may seem a bad idea to buy into an obsolescent technology like AGP, an AGP-based motherboard is often a good and economical choice, particularly for a system you are building on a tight budget.

See Chapter 2 for specific component recommendations.

1.2.1. Balanced Design

Novice PC builders often ignore the important concept of balanced design. Balanced design means allocating your component budget to avoid bottlenecks. If you're designing a gaming PC, for example, it makes no sense to spend $50 on the processor and $500 on the video card. The resulting system is nonoptimal because the slow processor is a bottleneck that prevents the expensive video adapter from performing to its full potential.

The main enemy of balanced design is the constant hype of manufacturer advertising and enthusiast web sites (which sometimes amount to the same thing). It's easy to fixate on the latest "must-have" component, even though its price may be much too high to justify. Many people just can't help themselves. Despite their best intentions, they end up spending $700 for a premium LCD display when a $400 model would have done just as well, or they buy a $400 video adapter when a $150 adapter would suffice. If your budget is unlimited, fine. Go for the latest and best. But if you're building a system to a fixed budget, every dollar you spend needlessly on one component is a dollar less you have to spend somewhere else, where it might make more difference.

Balanced design does not necessarily mean giving equal priority to all system components. For example, we have built servers in which the disk arrays and tape backup drive cost more than $10,000 and the rest of the system components totaled less than $2,000. A balanced design is one that takes into account the tasks the system must perform and allocates resources to optimize performance for those tasks.

But balanced design takes into consideration more than simple performance. A truly balanced design accommodates nonperformance issues such as physical size, noise level, reliability, and efficient cooling. You might, for example, have to choose a less expensive processor or a smaller hard drive in order to reserve sufficient funds for a quieter case or a more reliable power supply.

The key to achieving a balanced design is to determine your requirements, look dispassionately at the available alternatives, and choose accordingly. That can be tougher than it sounds.

1.2.2. Designing a Quiet PC

The ongoing PC performance race has had the unfortunate side effect of making PCs noisier. Faster processors use more power, which in turn requires larger (and noisier) power supplies. Faster processors also produce more heat, which requires larger (and noisier) CPU coolers. Modern hard drives spin faster than older models, producing still more noise and heat. Fast video adapters have their own cooling fans, which add to the din. The days when a high-performance PC sat under your desk making an unobtrusive hum are long gone.

Fortunately, there are steps you can take to reduce the amount of noise your PC produces. No PC with moving parts is completely silent, but significant noise reductions are possible. Depending on your requirements and budget, you can build a PC that is anything from quietly unobtrusive to nearly silent. The key to building a noise-reduced PC is to recognize the sources of noise and to minimize or eliminate noise at the source.

The major sources of noise are typically the power supply, CPU cooler fan, and supplementary case fans. Minor sources of noise include the hard drive, chipset fan, video adapter fan, and optical drive. As you design your PC, focus first on major noise sources that can be minimized inexpensively, then minor noise sources that are cheap to deal with, then major noise sources that are more expensive or difficult to minimize, and finally (if necessary) minor noise sources that are expensive or difficult to fix. Use the following guidelines:

Choose a low-power processor

The amount of power consumed by the processor has a direct effect on the noise level of the system. The peak power consumption of mainstream processors ranges from less than 70W to more than 130W. That power ends up as waste heat that must be exhausted from the case. Using a lower-power processor produces less waste heat, which in turn allows you to use a quieter CPU cooler, fewer and quieter case fans, and so on.

Power consumption isn't necessarily proportional to processor performance. For example, an AMD Athlon 64 X2 that draws 70W peak power may be faster than an Intel Pentium D that draws 130W, and an Intel Core 2 Duo processor that draws only 60W may be faster than either, at least for some tasks. None of this is to say that there's anything wrong with choosing a high-wattage processor, but doing so complicates cooling and noise issues.

Choose a quiet case

Inexpensive cases are designed with little thought to noise abatement. Better cases incorporate numerous design features that reduce noise, including large, slow-spinning exhaust fans, sound-absorbing composite panels, rubber shock mounts for drives that isolate vibration, and so on. We cover case considerations thoroughly in the next chapter.

Choose a quiet power supply

In most systems, the power supply is potentially the first or second largest noise source, so minimizing power supply noise is critical.

  • At the first level, choose a noise-reduced power supply, such as the Antec TruePower (http://www.antec.com) or PC Power & Cooling Silencer (http://www.pcpowercooling.com) models we recommend in the next chapter. Such power supplies cost little or no more than competing models of equivalent capacity and quality, and are noticeably quieter. A system that uses one of these power supplies can be quiet enough to be unobtrusive in a normal residential environment.

  • The next step down in noise level is a power supply that is specifically designed to minimize noise, such as the Antec NeoHE series, Enermax NoiseTaker series (http://www.enermaxusa.com), or Seasonic S12 series (http://www.seasonicusa.com). These power supplies cost a bit more than comparable noise-reduced power supplies, but produce as little as 18 dB at idle, and not much more under load. A system that uses one of these power supplies (and other similarly quiet components) can be nearly inaudible in a normal residential environment.

  • Finally, there are power supplies that substitute huge passive heatsinks for cooling fans. These power supplies, such as the Antec Phantom 350 and the Silverstone ST30NF (http://www.silverstonetek.com), have no moving parts, and the only noise they produce is a slight buzz from the electronic components. (The Antec Phantom 500 includes an "emergency" fan that runs only if the power supply begins to overheat. Up to 200W or so, the fan doesn't run and the power supply is completely silent; above 200W, the fan kicks in, and this power supply becomes a bit louder than the best quiet fan-based power supplies.)

Monitoring CPU Temperature

Most modern motherboards provide temperature sensors at important points such as the CPU socket. The motherboard reports the temperatures reported by these sensors to the BIOS. You can view these temperatures by running BIOS Setup and choosing the option for temperature reporting, which can usually be found under Advanced Hardware Monitoring, or a similar menu option. Alternatively, most motherboards include a monitoring utilityIntel's, for example, is called the Intel Active Monitorthat allows you to monitor temperatures from Windows rather than having to run BIOS Setup.

CPU temperature can vary dramatically with changes in load. For example, a CPU that idles at 30°C may reach 50°C or higher when it is running at 100% capacity. A hot-running modern processor such as a fast Pentium D may reach temperatures of 70°C or higher under load, which is perilously close to the maximum acceptable temperature for that processor. It is therefore very important to verify that your CPU cooler and system fans are doing their jobs properly.

An idle temperature of 30°C or lower is ideal, but that is not achievable with the hottest processors, which idle at 40°C or higher with any but the most efficient CPU coolers. In general, a CPU cooler that produces an idle temperature of 40°C or lower suffices to cool the CPU properly under load.

If you want to verify temperature under load, run an application that loads the CPU with intense calculations, ideally with lots of floating-point operations. Two such applications we have used are the SETI@home client (http://setiathome.ssl.berkeley.edu) and the Mersenne Prime client (http://mersenne.org). Run the application for an hour to ensure that the CPU has reached a steady-state temperature, and then use the temperature monitoring application to view the temperature while the application is still running.

Choose an efficient power supply

Power supply efficiency has a direct bearing on system noise level. Every power supply requires higher input power than the output power it provides, and that power difference is converted to heat within the power supply. For example, if the system actually requires 200W from the power supply, a 67% efficient power supply draws 300W of input power to provide that 200W of output power (200W/0.67 = 300W). That extra 100W is converted to heat within the power supply. An 85% efficient power supply requires only about 235W of input power to provide 200W of output power. The difference between 300W input and 235W input power translates to an extra 65W of heat within your system. The efficiency of mainstream power supply models ranges from about 65% to about 85%.

Choose a quiet CPU cooler

As processor speeds have increased over the last few years, manufacturers have gone from using passive heatsinks to using heatsinks with slow, quiet fans to using heatsinks with fast, loud fans. Current processors differ greatly in power consumption from model to model. At the lower end of the rangeless than 50Wnearly any decent CPU cooler can do the job with minimal noise, including the stock CPU coolers bundled with retail-boxed processors and inexpensive third-party units. At the middle of the range50W to 90Wstandard CPU coolers begin to produce intrusive noise levels, although specialty quiet CPU coolers can cool a midrange processor with little or no noise. At the upper end of the range, even the quietest fan-based CPU coolers produce some noise.

  • For a processor with low to moderate power consumption, try using the stock CPU cooler supplied with the retail-boxed processor. If it produces too much noise, install an in-line resistor to reduce the voltage supplied to the fan, which reduces fan speed and noise. Resistor kits (sometimes called voltage or fan speed controllers) are sold by quiet-PC vendors such as FrozenCPU (http://www.frozencpu.com), QuietPC USA (http://www.quietpcusa.com), and Endpcnoise.com (http://www.endpcnoise.com).

  • For processors with high power consumption, there are several alternatives. Some of the CPU coolers bundled with Intel Pentium D processors are reasonably quiet in stock form, and can be quieted further while still providing adequate cooling by using an in-line resistor to drop the supply voltage to 7V. However, Intel uses different CPU cooler models and changes them without notice, so which you get is hit or miss. For the quietest possible fan-based cooler, you can install a premium CPU cooler from manufacturers such as Thermalright (http://www.thermalright.com) and Zalman (http://www.zalmanusa.com).

  • To minimize noise for any processor, install a Thermalright or Zalman unit. For processors with low to midrange power consumption, some of these premium coolers can be run in silent (fanless) mode, which completely eliminates CPU cooler noise.

Choose quiet case fans

Most modern systems have at least one supplemental case fan, and some have several. The more loaded the system, the more supplemental cooling you'll need to use. Use the following guidelines when selecting case fans:

  • Case fans are available in various sizes from 60mm to 120mm or larger. All other things being equal, a larger fan can move the same amount of air with less noise than a smaller fan, because the larger fan doesn't need to spin as fast. Of course, the fan mounting positions in most cases are of fixed size, so you may have little choice about which size fan(s) to use. If you do have a choicefor example, if the case has two or three fan positions of different sizeuse the largest fan that fits.

  • Case fans vary significantly in noise level, even for the same size and rotation speed. Many factors come into play, including blade design, type of bearings, grill type, and so on. In general, ball bearing fans are noisier but more durable than fans that use needle or sleeve bearings.

    CPU Coolers and Motherboard Compatibility

    If you choose an aftermarket CPU cooler, verify that it is physically compatible with your motherboard. Quiet CPU coolers often use very large heatsinks, which may conflict with protruding capacitors and other motherboard components. Most premium CPU cooler manufacturers post compatibility lists on their web sites.

  • The noise level of a fan can be reduced by running it at a lower speed, as long as it moves enough air to provide proper cooling. The simplest method to reduce fan speed is to install an in-line resistor to reduce the supply voltage to 7V. These are available from the sources listed above, or you can make your own with a resistor from RadioShack or another electronics supply store. Some fans include a control panel, which mounts in an available external drive bay and allows you to control fan speed continuously from zero to maximum by adjusting a knob. Finally, some fans are designed to be controlled by the power supply or a motherboard fan connector. These fans vary their speed automatically in response to the ambient temperature, running at high speed when the system is heavily loaded and producing lots of heat, and low speed when the system is idle.

  • The mounting method you use makes a difference. Most case fans are secured directly to the chassis with metal screws. This transfers vibration directly to the chassis panels, which act as sounding boards. A better method is to use soft plastic snap-in connectors rather than screws. These connectors isolate vibration to the fan itself. Better still is to use the soft plastic snap-in connectors in conjunction with a foam surround that insulates the fan frame from the chassis entirely.

Silent PC Review

Silent PC Review (http://www.silentpcreview.com) is an excellent source of information about quiet PC issues. The site includes numerous articles about reducing PC noise, as well as reviews of quiet PC components, a forum, and other resources.

The preceding six elements are the major steps required to quietize your PC. Once you minimize noise from those major sources, you can also take the following steps to reduce noise from minor sources. Some of these steps cost little or nothing to implement, and all contribute to quieting the PC.

Put the PC on a mat

Rather than put the PC directly on your desk or the floor, put a sound-deadening mat between it and the surface. You can buy special mats for this purpose, but we've used objects as simple as a couple of mouse pads, front and rear, to accomplish the same thing. The amount of noise reduction from this simple step can be surprisingly large.

Choose a quiet hard drive

Once you've addressed the major noise sources, hard drive noise may become noticeable, particularly during seeks. The best way to reduce hard drive noise is to choose a quiet hard drive in the first place. Seagate Barracuda ATA and SATA models are the quietest mainstream hard drives. To reduce hard drive noise further you can use a Smart Drive Enclosure or the Zalman Hard Drive Heatpipe, both of which are available from the sources listed above.

Choose a video card with a passive heatsink

All video adapter chipsets produce significant heat, but most use a passive heatsink rather than a fan-based cooler. If possible, choose a video adapter with a passive heatsink. If you must use a high-end video adapter with a fan-based cooler, consider replacing that cooler with a Zalman Video Heatpipe. The small fans used on video adapters typically run at high speeds and are quite noisy, so replacing the cooler with a passive device can reduce noise noticeably.

Choose a motherboard with a passive heatsink

The north bridge chip of modern chipsets dissipates significant heat. Most motherboards cool this chip with a large passive heatsink (see, for example, Figure 1-5), but some use a fan-based cooler. Again, these coolers typically use small, fast fans that produce significant noise. If you have a choice, pick a motherboard with a passive heatsink. If you must use a motherboard with a fan-based chipset cooler, consider replacing that cooler with a Zalman Motherboard Heatsink.

1.2.3. Designing a Small PC

At the beginning of the millennium, some forward-thinking PC builders and manufacturers began to design and build PCs smaller and/or more portable than traditional mini-tower systems. Small PCs have become extremely popular, and it's no wonder. These systems are small, light, easily portable, and fit just about anywhere. In order of decreasing size, small/portable PCs fall into four broad categories:

LAN party PC

A LAN Party PC is essentially a standard ATX mini- or mid-tower system with a handle and other modifications to increase portability, port accessibility, and other factors important in a "totable" PC. Most LAN party cases are constructed largely of aluminum to minimize weight and maximize cooling efficiency. LAN party PCs are often "tricked-out" with colorful motherboards, clear side panels, fluorescent lights, fans, and cables, and similar visual enhancements. Despite the customizations, LAN party PCs are based on industry-standard components and are as capable as any standard PC.

microATX PC

A microATX PC is basically a cut-down version of a standard ATX PC. The microATX case and motherboard are smaller and provide less expandability, but are otherwise comparable in features and functionality to a standard ATX system. The great advantage of microATX PCs relative to the smaller styles described next is that microATX PCs use industry-standard components. microATX cases are available in two styles. Slimline cases are about the size and shape of a VCR. "Cube" cases are typically 8" tall and roughly a foot wide and deep. The relatively small case capacity makes cooling more difficult and puts some restraints on the number and type of hard drives, expansion cards, and other peripherals you can install, but it is possible to build a reliable, high-performance PC in the microATX form factor.

Small Form Factor (SFF) PC

Small Form Factor (SFF) means different things to different people. We use the term to mean the cube-style form factor pioneered by Shuttle (http://us.shuttle.com) with their XPC models. In fact, Shuttle says that SFF stands for Shuttle Form Factor. Other companies, including Soltek, Biostar, and others, now produce cube-style SFF systems. These true SFF systems use proprietary cases, power supplies, I/O templates, and motherboards, which limits their flexibility. In effect, "building" an SFF system consists of buying a bare-bones system with case, power supply, and motherboard, and adding your choice of memory, drives, video adapter, and so on. SFF PCs are typically more expensive, slower, and less reliable than standard-size or microATX PCs, but they are noticeably smaller.

Mini-ITX PC

Mini-ITX is a semi-proprietary form factor pioneered by VIA Technologies. Although a few minor third-party manufacturers supply Mini-ITX components, VIA products dominate the Mini-ITX market. Mini-ITX motherboards are 170mm (6.7") square, and are in effect smaller versions of microATX motherboards. Although Mini-ITX motherboards are available that accept Socket 479 Intel Pentium M and Intel Celeron M processors, the majority of Mini-ITX systems use VIA motherboards with embedded processors.. These processors are very slow relative to modern AMD and Intel processors, and Mini-ITX motherboards are relatively expensive. Even so, Mini-ITX has its place, for systems that do not require high performance but need to be small and very quiet. Mini-ITX motherboards are so small that they can be built into enclosures as small as a cigar box (literally), and the flip side to low processor performance is that these processors consume little power and produce little heat. Most Mini-ITX systems use passive cooling and "wall-wart" power supplies, which eliminates fan noise and allows the system to be almost totally silent. Mini-ITX is most appropriate for such "appliance" applications as small Linux servers, routers, and satellite DVR playback-only systems.

Small Outside Means Small Inside

The limited space available in cube-style SFF cases restricts component choice. For example, you may have to purchase special low-profile memory modules and you may not be able to install full-length, standard-height expansion cards. The tiny case volume also makes heat dissipation critical. For example, you may not be able to use the fastest available processors because the case is not capable of cooling them sufficiently.

Table 1-1 lists the characteristics of each of these system types relative to a standard mini/mid-tower desktop system, using the rankings of Excellent (E), Very Good (VG), Good (G), Fair (F), and Poor (P).

Table 1-1. Small system strengths and weaknesses

Desktop

LAN party

microATX

SFF

Mini-ITX

Typical case volume (liters)

35 to 60

25 to 40

12 to 20

8 to 12

2.5 to 9

Size

P to F

F to G

G to VG

VG to E

E

Cost efficiency

E

VG

E

P to F

P to F

Reliability

E

F to VG

VG to E

F to VG

F to VG

Portability

P

VG to E

F to VG

VG to E

VG to E

Noise level

VG to E

F to VG

VG to E

P to VG

E

Cooling

E

G to E

G to VG

P to F

F to E

Upgradability/expandability

E

VG to E

F to VG

F to G

P

Processor performance

E

E

VG to E

VG to E

P

Graphics performance

E

E

VG to E

F to E

P

Disk capacity/performance

E

E

G to VG

G to VG

P

Table 1-1 presents best-case scenarios for each of the form factors. For example, not all standard desktop systems have excellent performance, nor are all of them extremely quiet.

Rather, this table presents the best that can be done within the limitations of each form factor, which may vary according to the specific components you select.

If you need to design a small PC, recognize that each step down from standard mini-tower size involves additional compromises in performance, cost, reliability, noise level, and other key criteria. Reducing case size limits the number and type of components you can install and makes it more difficult to cool the system effectively. It also makes it harder to quiet the PC. For example, small cases often use relatively loud power supplies. Because the power supply is proprietary, installing an aftermarket quiet power supply is not an option. Similarly, using a small case forces you to trade off performance against cooling against noise. For example, you may be forced to use a slower processor than you'd like, because the necessary CPU cooler for a faster processor is too large to fit in the available space or is louder than acceptable.

When it comes to designing small PCs, our rule is to use a standard mini-tower system whenever possible. If that's too large, step down to a microATX system. If a microATX system is too large, we suggest you rethink your priorities. Perhaps you could free some additional space by moving things around, or perhaps you could place the PC in a different position. Try hard to avoid using any form factor smaller than microATX.

Then, if and only if you are certain that the trade-offs are worth it, buy a bare-bones SFF system and build it out to meet your requirements. We don't think of Mini-ITX systems as direct competitors to traditional PCs at all. They're simply too slow to be taken seriously as a mainstream PC. Instead, we suggest you consider Mini-ITX systems to be special, relatively expensive, low-performance computing appliances that are suitable only for very specialized applications.


Section 1.3. Things to Know and Do Before You Start

1.3. Things to Know and Do Before You Start

We've built many systems over the years, and we've learned a lot of lessons the hard way. Here are some things to keep in mind as you begin your project.

Make sure you have everything you need before you start

Have all of the hardware, software, and tools you'll need lined up and waiting. You don't want to have to stop in mid-build to go off in search of a small Phillips screwdriver or to drive to the store to buy a cable. If your luck is anything like ours, you won't find the screwdriver you need and the store will be closed. In addition to tools and components, make sure you have the distribution CDs for the operating system, service packs, device drivers, diagnostics utilities, and any other software you'll need to complete the build.

RTFM

Read the fine manuals, if only the Quick Start sections. Surprisingly, while system manuals are notoriously awful, many component manuals are actually quite good. You'll find all sorts of hints and tips, from the best way to install the component to suggestions on optimizing its performance.

DO AS WE SAY...

Okay, we admit it. We almost never read the manuals, but then we can just about build a system blindfolded. Until you're proficient, reading the manuals before you proceed is the best way to guarantee that your new PC will, um, work.

Missing Pieces

Don't assume that every box contains what it's supposed to. Before you begin the build, open every box and verify its contents against the packing list. Quite often, we open a new component box only to find that the driver CD, manual, cable, or some other small component that should have been included is missing. On one memorable occasion, we opened a new, shrink-wrapped video adapter box only to find that everything was present except the video adapter itself!

Download the latest drivers

Although PC component inventories turn over quickly, the CDs included with components usually don't contain the most recent drivers. Some manufacturers don't update their driver CDs very often, so the bundled drivers may be a year or more out of date, even if the component itself was made recently. Before you begin building a PC, visit the web site for each of your components and download the most recent driver and BIOS updates for each. (Bookmark the URLs so you can easily find updates later.) Unpack or unzip them if necessary, burn them to CD, and label the CD. You may choose to install drivers from the bundled CDin fact, at times it's necessary to do so because the downloadable updates do not include everything that's on the CDbut you want to have those later drivers available so that you can update your system immediately.

Don't Forget the Manuals

While you're at it, download all of the documentation you can find for each component. Quite often, the detailed documentation intended for system builders is not included in the component box. The only way to get it is to download it.

Ground yourself before touching components

Processors, memory modules, and other electronic componentsincluding the circuit boards in drivesare sensitive to static shock. Static electricity can damage components even if the voltage is too low for you to see or feel a static spark. The best way to avoid static damage to components is to get in the habit of grounding yourself before you touch any sensitive component. You can buy special antistatic wrist straps and similar devices, but they're really not necessary. All you need do is touch a metal object like the chassis or power supply before you handle components.

Keep track of the screws and other small parts

Building a PC yields an incredible number of small pieces that need to be kept organized. As you open each component box, your pile of screws, cables, mounting brackets, adapters, and other small parts grows larger. Some of those you'll need, and some you won't. As we can attest, one errant screw left on the floor can destroy a vacuum cleaner. Worse, one unnoticed screw can short out and destroy the motherboard and other components. The best solution we've found is to use an egg carton or old ice cube tray to keep parts organized. The goal is to have all of the small parts accounted for when you finish assembling the PC.

A SNAKE IN THE WOODPILE

Some PCs use a variety of screws that look very similar but are in fact threaded differently. For example, the screws used to secure some case covers and those used to mount some disk drives may appear to be identical, but swapping them may result in stripped threads. If in doubt, keep each type of screw in a separate compartment of your organizer.

Static Guard

To minimize problems with static, wear wool or cotton clothing and avoid rubber-soled shoes. Static problems increase when the air is dry, as is common in winter when central heating systems are in use. You can reduce or eliminate static with a spray bottle filled with water to which you've added a few drops of dishwashing liquid. Spritz your work area thoroughly immediately before you begin working. The goal is not to get anything wet, but simply to increase the humidity of the air. (Whatever you do, avoid wetting the case or components themselves, especially the connectors and slots, which must be kept clean and dry at all times.)

Use force when necessary, but use it cautiously

Many books tell you never to force anything, and that's good advice as far as it goes. If doing something requires excessive force, chances are a part is misaligned, you have not removed a screw, or something similar. But sometimes there is no alternative to applying force judiciously. For example, drive power cables sometimes fit so tightly that the only way to connect them is to grab them with pliers and press hard. (Make sure all the contacts are aligned first.) Some combinations of expansion card and slot fit so tightly that you must press very hard to seat the card. If you encounter such a situation, verify that everything is lined up and otherwise as it should be (and that there isn't a stray wire obstructing the slot). Then use whatever force it takes to do the job, which may be substantial.

Check and recheck before you apply power

An experienced PC technician building a PC does a quick scan of the new PC before performing the smoke test by applying power to the PC (if you don't see any smoke, it passes the test). Don't skip this step, and don't underestimate its importance. Most PCs that fail the smoke test do so because this step was ignored. Until you gain experience, it may take several minutes to verify that all is as it should beall components secure, all cables connected properly, no tools or other metal parts shorting anything out, and so on. Once you are comfortable working inside PCs, this step takes 15 seconds, but that may be the most important 15 seconds of the whole project.

A Screw Loose Somewhere

After we build a system, we pick it up, shake it gently, and tilt it front-to-back and side-to-side. If something rattles, we know there's a screw loose somewhere.

Start small for the first boot

The moment of greatest danger comes when you power up the PC for the first time. If the system fails catastrophicallywhich sometimes happens no matter how careful you aredon't smoke more than you have to. For example, the SOHO Server project system we built for this book uses four hard drives and two memory modules. When we built that system, we installed only one drive and one memory module initially. That way, if something shorted out when we first applied power, we'd destroy only one drive and memory module rather than all of them. For that reason, we suggest starting with a minimum configurationmotherboard, processor, one memory stick, video, and one hard drive. Once you're satisfied that all is well, you can add your optical and other drives, additional memory, expansion cards, and so on.

Leave the cover off until you're sure everything works

Experts build and test the PC completely before putting the lid back on and connecting the external cables. Novices build the PC, reassemble the case, reconnect all the cables, and then test it.

COVER UP

The corollary to this rule is that you should always put the cover back on the case once the upgrade is complete and tested. Some believe that leaving the cover off improves cooling. Wrong. Cases do not depend on convection cooling, which is the only kind you get with the cover off. Cases are designed to direct cooling air across the major heat-generating components, processors, and drives, but this engineering is useless if you run the PC uncovered. Replace the cover to avoid overheating components.

Another good reason to replace the cover is that running a system without the cover releases copious amounts of RF to the surrounding environment. An uncovered system can interfere with radios, monitors, televisions, and other electronic components over a wide radius.

This Probably Won't Happen to You

Don't let this warning put you off building a PC. If you choose good components, assemble them carefully, and double-check everything before you apply power, the probability of catastrophic failure is probably about the same as the probability you'll be hit by lightning or win the lottery.


Section 1.4. Things You Need to Have

1.4. Things You Need to Have

The following sections detail the items you should have at hand before you actually start building your new system. Make a checklist and make sure you check off each item before you begin. There are few things more frustrating than being forced to stop in mid-build when you belatedly realize you're missing a cable or other small component.

1.4.1. Components

Building a PC requires at least the following components. Have all of them available before you start to build the system. Open each component box and verify the contents against the packing list before you actually start the build.

  • Case and power supply, with power cord

  • Motherboard, with custom I/O template, if needed

  • Processor

  • CPU cooler, with thermal compound or pad

  • Memory module(s)

  • Hard drive(s), cable(s) (and SATA power adapter(s), if applicable)

  • Optical drive, with data cable (and audio cable, if applicable)

  • Floppy drive and cable (if applicable)

  • Tape drive, cable, and tape cartridge (if applicable)

  • Card reader and cable (if applicable)

  • Video adapter, unless embedded

  • Sound adapter, unless embedded

  • Network adapter, unless embedded

  • Any other expansion cards (if applicable)

  • Supplementary case fan(s)

  • Keyboard, mouse, display, and other external peripherals

  • Screws, brackets, drive rails, and other connecting hardware

1.4.2. Hand Tools and Supplies

You really don't need many tools to build a PC. We built one PC using only our Swiss Army knife, just to prove it could be done. Figure 1-1 shows our basic PC-building toolkit. Yep. It's true. You can build every PC in this book using only a #1 Phillips screwdriver. It's a bit small for the largest screws and a bit large for the smallest, but it works.

Figure 1-1. A basic PC toolkit

It's helpful to have more tools, of course. Needle-nose pliers are useful for setting jumpers. A flashlight is often useful, even if your work area is well lit. A 5mm (or, rarely, 6mm) nutdriver makes it faster to install the brass standoffs that support the motherboard. A larger assortment of screwdrivers can also be helpful.

You may also find it useful to have some nylon cable ties (not the paper-covered-wire type of twist tie) for dressing cables after you build the system. Canned air and a clean microfiber dust cloth are useful for cleaning components that you are migrating from an older system. A new eraser is helpful for cleaning contacts if you mistakenly grab an expansion card by the connector tab.

Non-Fatal Attraction

Don't worry about using magnetized tools. Despite the common warnings about doing so, we've used magnetized screwdrivers for years without any problem. They are quite handy for picking up dropped screws and so on. Use commonsense precautions, such as avoiding putting the magnetized tips near the flat surface of a hard drive or near any floppy disk, tape, or other magnetic media.

1.4.3. Software Tools

In addition to hand tools, you should have the following software tools available when you build your system. Some are useful when you build the system, others to diagnose problems. We keep copies of our standard software tools with our toolkit. That way, we have everything we need in one place. Here are the software tools we recommend:

Operating system distribution discs

OS distribution discs are needed when you build a system, and may also be needed later to update system software or install a peripheral. We always burn copies of the distribution discs to CD-R or DVD+R and keep a copy with our toolkit. If you use Windows or another nonfree operating system, remember to record the initialization key, serial number, and other data you'll need to install the software. Use a felt-tip permanent marker to record this data directly onto the disc immediately after you burn it. It also helps to record the same information on a small piece of paper so that you'll have it available while the disc is in the drive.

Service packs and critical updates

Rather than (or in addition to) updating Windows and Office online, download the latest service packs and critical updates and burn them to CD-R. In addition to giving you more control of the process, having these updates on CD-R means you can apply them even when the system has no Internet connection, such as when you're building it on your kitchen table.

USE SOME PROTECTION

It's a very bad idea to connect a PC directly to the Internet, and that's especially true for an unpatched system. Several of our readers have reported having a new system infected by a worm almost instantly when they connected to the Internet, intending to download patches and updates. Patch the new system before you connect it to the Internet, and never connect it directly to the Internet. Use a NAT/router between any PC and your broadband modem.

Major applications discs

If your system runs Microsoft Office or other major applications that are distributed on CDs, keep a copy of those discs with your toolkit. Again, don't forget to record the serial number, initialization keys, and other required data on the disc itself and on a supplementary note.

Driver CDs

Motherboards, video adapters, sound cards, and many other components include a driver CD in the box. Those drivers may not be essential for installing the componentthe Windows or Linux distribution CD may (or may not) include basic drivers for the componentbut it's generally a good idea to use the driver CD supplied with the component (or an updated version downloaded from the web site) rather than using those supplied with the OS, if any.

FIRST THINGS FIRST

Pay close attention to the instructions that come with the driver. Most drivers can be installed with the hardware they support already installed. But some drivers, particularly those for some USB devices, need to be installed before the hardware is installed.

In addition to basic drivers, the driver CD may include supporting applications. For example, a video adapter CD may include a system tray application for managing video properties, while a sound card may include a bundled application for sound recording and editing. We generally use the bundled driver CD for initial installation and then download and install any updated drivers available on the product web site. Keep a copy of the original driver CD and a CD-R with updated drivers in your toolkit.

Hard drive installation/diagnostic utility

We're always amazed that so few people use the installation and diagnostic software supplied with hard drives. Perhaps that's because many people buy OEM hard drives, which include only the bare drive. Retail-boxed drives invariably include a utilities CD. Most people ignore it, which is a mistake.

Seagate, for example, provides DiscWizard installation software and SeaTools diagnostic software. If you're building a system, you can use the bootable floppy or bootable CD version of DiscWizard to partition, format, and test the new drive automatically. If you're adding a drive, you can use the Windows version of DiscWizard to install, prepare, and configure the new drive automatically. You can configure the new drive as a secondary drive, keeping the original drive as the boot drive. You can specify that the new drive be the sole drive in the system, and DiscWizard automatically migrates your programs and data from the old drive. Finally, you can choose to make the new drive the primary (boot) drive, and make the old drive the secondary drive. DiscWizard does all of this automatically, saving you considerable manual effort.

Driver Education

Keep original driver CDs stored safely. They may be more valuable than you think. More than once, we've lost track of original driver CDs, thinking we could always just download the latest driver from the manufacturer's web site. Alas, a company may go out of business, or its web site may be down just when you desperately need a driver. Worse still, some companies charge for drivers that were originally freely downloadable. That's one reason we don't buy HP products.

HARD DRIVE DIAGNOSTICS

All hard drive makers provide installation and diagnostic utilities. Maxtor, for example, distributes MaxBlast installation software and Powermax diagnostic utilities. If you buy an OEM hard drive or lose the original CD, you can download the utilities from the manufacturer's web site. For obvious reasons, many of these utilities work only if a hard drive made by that manufacturer is installed.

Diagnostic utilities

Catch-22. Diagnostic utilities are of limited use in building a new system, because if the PC works well enough to load and run them, you don't need to diagnose it. Conversely, when you need to diagnose the PC, it's not working well enough to run the diagnostic utility. Duh. (Diagnostic utilities can be helpful on older systems; for example, to detect memory problems or a failing hard drive.) The only diagnostic utility we use routinely when building systems is a Knoppix Live Linux CD (http://www.knoppix.com). With Knoppix, you can boot and run Linux completely from the CD, without writing anything to the hard drive. Knoppix has superb hardware detectionbetter than Windowsand can be useful for diagnosing problems on a newly built system that refuses to load Windows.

TEST YOUR MEMORY

Many system builders routinely run a memory diagnostic to ensure the system functions before installing the operating system. One excellent utility for this purpose is MEMTEST86 (http://www.memtest86.com). It's free, and self-boots from a CD-ROM or floppy drive, and can also be loaded via a Linux bootloader. Best of all, it does a great job testing the otherwise difficult to diagnose memory subsystem. The Knoppix Live CD can run MEMTEST86 from its boot menu.

Burn-in utilities

PC components generally fail quickly or live a long time. If a component survives the first 24 hours, it's likely to run without problems for years. The vast majority of early failures are immediate, caused by DOA components. Something like 99% of the remaining early failures occur within 24 hours, so it's worth "burning in" a new system before you spend hours installing and configuring the operating system and applications.

Many people simply turn on the system and let it run for a day or two. That's better than nothing, but an idling system doesn't stress all components. A better way is to run software that accesses and exercises all of the components. One good (and free) ad hoc way to burn in a system is to repeatedly compile a Linux kernel, and we sometimes use that method. We generally use special burn-in software, however, and the best product we know of for that purpose is BurnInTest from PassMark Software (http://www.passmark.com).


Section 1.5. Getting to Know Your Motherboard

1.5. Getting to Know Your Motherboard

A motherboard is so complex and has so many components and connections that it can be overwhelming to someone who is not used to working inside PCs. All of the other system components connect to and are controlled by the motherboard, so it's important to be able to identify the major parts of the motherboard. As is true of many things, the easiest way to understand the working of the whole is to understand the working of the individual parts. So let's take the $2 tour of a modern motherboard, where you'll learn the functions of each important component and how to identify those components visually.

This section includes photographs of each of these components to help you visually identify items. The details and layout vary from model to model, but all modern motherboards include these or similar components. Once you're able to locate and identify the major components on any motherboard you should be able to do the same on any other motherboard.

Once You Label Me, You Negate Me

Most motherboards include a reference label to show the location of connectors, jumpers, and other key components. Place this label inside the case after assembly so you'll have key configuration information readily available if you open the case to install additional components or troubleshoot problems.

To begin, let's examine a block diagram of a chipset. Figure 1-2 shows the major components and functions of the Intel 925XE chipset. (Other modern chipsets are similar.) The 925XE chipset uses two physical chips. The north bridge chip, which Intel calls the MCH (Memory Controller Hub), is the blue box labeled 82925X MCH. The MCH arbitrates and coordinates communications between the processor, memory, and the PCI Express video adapter. The MCH provides very high bandwidth channels: 6.4 GB/s between the MCH and processor; 8.0 GB/s between the MCH and the video adapter; and 8.5 GB/s between the MCH and memory.

Figure 1-2. Block diagram of the Intel 925X chipset (graphic courtesy of Intel Corporation)

The south bridge chip, which Intel calls the ICH (I/O Controller Hub), is the blue box labeled ICH6RW. The ICH handles input/output functions, which function at much lower data rates than the processor, memory, and video channels. These channels include four 150 MB/s Serial ATA ports, six PCI slots with a cumulative 133 MB/s bandwidth, eight USB 2.0 ports with 60 MB/s bandwidth each, and four 500 MB/s PCI Express x1 slots. The ICH also handles such functions as embedded audio, the interface with the system BIOS, and wireless networking.

Figure 1-3 maps these chipset features to the component layout on a real-world motherboard. For illustrative purposes, we've used an Intel D925XECV2 motherboard, but any recent motherboard has similar features and layout. Not all of the components shown are present on all motherboards, and the exact positioning of some components may differ, but the essentials remain the same.

Figure 1-3. Component layout on a typical motherboard (graphic courtesy of Intel Corporation)

Figure 1-4, the left-rear quadrant of the motherboard, is dominated by expansion slotstwo pairs of white PCI slots bracketing a pair of PCI Express x1 slots, with a black PCI Express x16 video adapter slot at the far right. The white auxiliary rear fan connector is visible centered above the left pair of PCI slots. The yellow connector at top center is the front-panel audio connector, with the audio codec chip to its upper left. The gigabit Ethernet controller chip is visible centered between the two mounting holes on the upper right. The round object below the PCI Express x1 slots is the system speaker. The large chip at bottom center is the FireWire controller, and the two blue header-pin connectors to its right are the front-panel FireWire interface connectors.

Figure 1-4. Left-rear quadrant of the D925XECV2 motherboard (graphic courtesy of Intel Corporation)

  1. Auxiliary rear fan connector

  2. ATAPI CD-ROM audio connector

  3. PCI Express x1 expansion slots

  4. Audio codec

  5. Front-panel audio connector

  6. PCI expansion slots

  7. Gigabit Ethernet PCI Express controller chip

  8. PCI Express x16 video adapter slot

  9. Rear case fan connector

  10. Back panel I/O connectors

  11. Alternate power connector

  12. ATX12V power connector

  13. Processor socket

  14. CPU fan connector

  15. MCH (north bridge)

  16. Channel A memory slots

  17. Channel B memory slots

  18. Supplemental I/O controller chip

  19. ATX main power connector

  20. Diskette drive interface connector

  21. ATA (IDE) interface connector

  22. Battery

  23. Chassis intrusion connector

  24. BIOS Setup configuration jumper block

  25. Firmware Hub (FWH)

  26. Front case fan connector

  27. Serial ATA interface connectors

  28. Auxiliary front-panel power LED connector

  29. Front-panel connector

  30. SCSI hard disk activity indicator LED

  31. Auxiliary power output connector

  32. Front-panel USB interface connector

  33. Trusted Platform Module (TPM) chip

  34. Front panel USB interface connector

  35. ICH6R (south bridge)

  36. Front-panel IEEE-1394a (FireWire) interface connectors

  37. IEEE-1394a (FireWire) controller chip

  38. Speaker

  39. PCI expansion slots

The right-rear quadrant of the motherboard, shown in Figure 1-5, is dominated by the processor socket (lower right), the heatsink for the north bridge chip (bottom left), and a top view of the rear I/O panel (top). The group of three white connectors at the upper left are, from left to right, the rear case fan connector, the alternate power connectorused to provide additional current to the motherboard if the power supply has a 20-pin main power connector rather than a 24-pin connectorand the ATX12V power connector.

Figure 1-5. Right rear quadrant of the D925XECV2 motherboard (graphic courtesy of Intel Corporation)

Figure 1-6 shows the rear I/O panel connectors. Legacy PS/2 mouse (top) and keyboard connectors are visible at the far left. The second group of connectors includes a parallel (LPT) port at the top and a 9-pin serial port at the lower left. At the bottom right of this group are coax (round) and optical (square) digital audio-out ports. The third group of connectors are all audio connectors, which can be configured for various functions. The fourth group of connectors has a FireWire connector at the top, with two USB 2.0 connectors beneath it. The fifth group of connectors has a gigabit Ethernet connector at the top, with two more USB 2.0 connectors beneath it.

Figure 1-6. Rear I/O panel connectors (graphic courtesy of Intel Corporation)

It took longer than it should have, but the I/O connectors on many motherboards now use a more-or-less standardized color code, shown in Table 1-2.

Table 1-2. I/O connector color codes

Connector

Color

Connector

Color

Analog VGA

Blue

PS/2-compatible keyboard

Purple

Audio line-in

Light blue

PS/2-compatible mouse

Green

Audio line-out

Lime

Serial

Teal/turquoise

Digital monitor/flat panel

White

Speaker out/subwoofer

Orange

IEEE 1394

Gray

Right-to-left speaker

Brown

Microphone

Pink

USB

Black

MIDI/gameport

Gold

Video-out

Yellow

Parallel

Burgundy

SCSI, LAN, telephone, etc.

Not defined

Obviously, manufacturers make some case-by-case exceptions. The coax digital audio-out connector on this motherboard, for example, is orange, which should make it a speaker out/subwoofer. Similarly, one of the audio connectors is bright yellow, which should make it a video-out connector. Oh, well.

The left-front quadrant of the motherboard is shown in Figure 1-7. The round object at the lower right is the battery. The large chip immediately to its left is the Firmware Hub (FWH), with the orange BIOS Setup Configuration jumper block below it. The white object to the left of the jumper block is the front case fan power connector. Above that power connector is the Trusted Platform Module (TPM) chip, and a group of four Serial ATA interface connectors appears to the left of the TPM chip and power connector. The large silver object at right center is the heatsink for the ICH6 south bridge chip. The black header pin connector to the left of the south bridge heatsink is one front-panel USB connector, with a second identical connector below it. The multicolored jumper block at the center bottom edge of the motherboard is the front-panel connector.

Figure 1-7. Left-front quadrant of the D925XECV2 motherboard (graphic courtesy of Intel Corporation)

Figure 1-8 shows the right-front quadrant of the motherboard, with the two Channel A memory slots at the top and two Channel B memory slots beneath them. The large chip at the lower right is the supplemental I/O controller chip, with the white ATX main power connector to its left. The black ATA interface connector is at the bottom-left edge of this image, with the floppy drive interface connector immediately to its right.

Figure 1-8. Right-front quadrant of the D925XECV2 motherboard (graphic courtesy of Intel Corporation)

Previous Page
Next Page


Section 1.6. Troubleshooting

1.6. Troubleshooting

Many first-time system builders are haunted by the question, "What if it doesn't work?" Or, worse still, "What if it goes up in flames the first time I turn it on?" Set your mind at ease. This isn't rocket surgery. Any reasonably intelligent person can build a system with a high degree of confidence that it will work normally the first time it is turned on. If you use good components and assemble them carefully, you're actually less likely to encounter problems with a home-built system than with a prebuilt mail-order system or one off the shelf from your local superstore.

CONTENTS MAY SETTLE DURING SHIPPING

Shipping can be tough on a computer. We always pop the cover of PCs that have been shipped, and often find something has been jarred loose. Our editor reports that when he shipped a PC to his parents, it arrived with the video card completely out of its slot. Not good.

Even worse, shipping can cause the CPU cooler to break loose. A heavy heatsink rattling around can do some serious damage to other components. If someone ships a system to you, always open it up and verify that everything is properly connected before you apply power to the system.

Still, it can happen. So, while it would take a whole book to cover troubleshooting in detail, it's worth taking a few pages to list some of the most likely problems and solutions. Fortunately, it's easier to troubleshoot a newly built system than a system that's been in use for some time. Fewer things can go wrong with a new system. You can be certain that the system is not infected with a virus or malware, for example, and driver problems are much less likely on a new system because you have all the latest drivers installed.

The best time to troubleshoot is while you build the system. A good carpenter measures twice and cuts once. Take the same approach to building your system, and you're unlikely to need any of this troubleshooting advice. As you build the system, and then again before you apply power for the first time, verify that all cables are oriented and connected correctly. Make sure expansion cards, memory modules, the processor, and so on are fully seated, and that you haven't left a tool in the patient. Each project system chapter includes a final checklist. Verifying the items on that checklist eliminates about 99% of the potential problems.

Possible problems fall into one of four categories, easy versus hard to troubleshoot and likely versus unlikely. Always check the easy/likely problems first. Otherwise, you may find yourself replacing the video card before you notice that the monitor isn't plugged in. After you exhaust the easy/likely possibilities, check the easy/unlikely ones followed by hard/likely and, finally, hard/unlikely.

Cables Are Commonplace

Fortunately, most problems with defective cables involve ribbon cables, and those are pretty easy to come by. For example, when we recently assembled a new PC, the motherboard came with two IDE cables and a floppy drive cable. The floppy drive came with a cable, the hard drive with another IDE cable, and the optical drive with still another IDE cable. That gave us four IDE cables and two floppy cables, so we ended up with two spare IDE cables and a spare floppy cable. Those went into our spares kit, where they'll be available if we need to swap cables to troubleshoot another system.

Other than sheer carelessnessto which experienced system builders are more prone than are novicesmost problems with new systems result from one or more of the following:

Most problems that occur during repairs and system upgrades result from one or more of the following:

Cable problems

Disconnected, mis-connected, and defective cables cause more problems than anything else. The plethora of cables inside a PC makes it very easy to overlook a disconnected data cable or to forget to connect power to a drive. It's possible to connect some cables backward. Ribbon cables are a particularly common problem, because some can be connected offset by a row or column of pins. And the cables themselves cannot always be trusted, even if they are new. If you have a problem that seems inexplicable, always suspect a cable problem first.

Configuration errors

Years ago, motherboards required a lot more manual configuration than do modern motherboards. There were many switches and jumpers, all of which had to be set correctly or the system wouldn't boot. Modern motherboards auto-configure most of their required settings, but may still require some manual configuration, either by setting physical jumpers on the motherboard or by changing settings in CMOS Setup. Motherboards use silk-screened labels near jumpers and connectors to document their purposes and to list valid configuration settings. These settings are also listed in the motherboard manual. Always check both the motherboard labels and the manual to verify configuration settings. If the motherboard maker posts updated manuals on the Web, check those as well.

DON'T FORGET THE FLASHLIGHT

One of our technical reviewers observes, "A good flashlight with a tight beam (I use a mini Maglight) really helps to spot offset ribbon connector problems, even if workspace lighting is otherwise adequate. I've done systems where a handheld magnifier became an indispensable tool."

Incompatible components

In general, you can mix and match modern PC components without worrying much about compatibility. For example, any IDE hard drive or optical drive works with any IDE interface, and any ATX12V power supply is compatible with any ATX12V motherboard (although a cheap or older power supply may not provide adequate power, which means you need to visit Chapter 2). Most component compatibility issues are subtle. For example, you may install a 1 GB memory module in your system. When you power it up, the system sees only 256 MB or 512 MB because the motherboard doesn't recognize 1 GB memory modules properly. It's worth checking the detailed documentation on the manufacturers' web sites to verify compatibility.

Dead-on-arrival components

Modern PC components are extremely reliable, but if you're unlucky one of your components may be DOA. This is the least likely cause of a problem, however. Many novices think they have a DOA component, but the true cause is almost always something elseusually a cable or configuration problem. Before you return a suspect component, go through the detailed troubleshooting steps we describe. Chances are the component is just fine.

The Happy Noise

A healthy PC finishes the POST (Power-On Self-Test) with one happy-sounding beep. If you hear some other beep sequence during startup, there is some sort of problem. BIOS beep codes provide useful troubleshooting information, such as identifying the particular subsystem affected. Beep codes vary, so check the motherboard documentation for a description of what each code indicates.

Note that some recent motherboards do not generate beep codes. Also, unless the motherboard has a built-in speaker, you'll have to connect the case speaker to hear the beep codes.

Here are the problems you are most likely to encounter when you repair or upgrade a system, and what to do about them:

1.6.1. Problem: When you apply power, nothing happens

  • Verify that the power cable is connected to the PC and to the wall receptacle, and that the wall receptacle has power. Don't assume. We have seen receptacles in which one half worked and the other didn't. Use a lamp or other appliance to verify that the receptacle to which you connect the PC actually has power. If the power supply has its own power switch, make sure that switch is turned to the "On" or "1" position. If your local mains voltage is 110/115/120V, verify the power supply voltage selector switch, if present, is not set for 220/230/240V. (If you need to move this switch, disconnect power before doing so.)

  • If you are using an outlet strip or UPS, make sure that its switch (if equipped) is on and that the circuit breaker or fuse hasn't blown.

  • If you installed a video adapter, pop the lid and verify that the adapter is fully seated in its slot. Even if you were sure it seated fully initiallyand even if you thought it snapped into placethe adapter may still not be properly seated. Remove the card and reinstall it, making sure it seats completely. If the motherboard has a retention mechanism, make sure the notch on the video card fully engages the retention mechanism. Ironically, one of the most common reasons for a loose video card is that the screw used to secure it to the chassis may torque the card, pulling it partially out of its slot. This problem is rare with high-quality cases and video cards, but is quite common with cheap components.

  • Verify that the 20- or 24-pin main ATX power cable and the 4-pin ATX12V power cable are securely connected to the motherboard and that all pins are making contact. If necessary, remove the cables and reconnect them. Make sure the latch on each cable plug snaps into place on the motherboard jack.

  • Verify that the front-panel power switch cable is connected properly to the front-panel connector block. Check the silk-screened label on the motherboard and the motherboard manual to verify that you are connecting the cable to the right set of pins. Very rarely, you may encounter a defective power switch. You can eliminate this possibility by temporarily connecting the front-panel reset switch cable to the power switch pins on the front-panel connector block. (Both are merely momentary on switches, so they can be used interchangeably.) Alternatively, you can carefully use a small flat-blade screwdriver to short the power switch pins on the front-panel connector block momentarily. If the system starts with either of these methods, the problem is the power switch.

  • Start eliminating less likely possibilities, the most common of which is a well-concealed short circuit. Begin by disconnecting the power and data cables from the hard, optical, and floppy drives, one at a time. After you disconnect each, try starting the system. If the system starts, the drive you just disconnected is the problem. The drive itself may be defective, but it's far more likely that the cable is defective or was improperly connected. Replace the data cable, and connect the drive to a different power supply cable.

    Swapping Power Supplies

    If you have a spare power supplyor can borrow one temporarily from another systemyou might as well try it as long as you have the cables disconnected. A new power supply being DOA is fairly rare, at least among good brands, but as long as you have the original disconnected, it's not much trouble to try a different power supply.

  • If you have expansion cards installed, remove them one by one. Remove all but the video adapter. If the motherboard has embedded video, temporarily connect your display to it and remove the video card as well. Attempt to start the system after you remove each card. If the system starts, the card you just removed is causing the problem. Try a different card, or install that card in a different slot.

  • Remove and reseat the memory modules, examining them to make sure they are not damaged, and then try to start the system. If you have two memory modules installed, install only one of them initially. Try it in both (or all) memory slots. If that module doesn't work in any slot, the module may be defective. Try the other module, again in every available memory slot. By using this approach, you can determine if one of the memory modules or one of the slots is defective.

  • Remove the CPU cooler and the CPU. Check the CPU to make sure there are no bent pins (some newer CPUs don't have pins). If there are, you may be able to straighten them using a credit card or a similar thin, stiff object, but in all likelihood you will have to replace the CPU. Check the CPU socket to make sure there are no blocked holes or foreign objects present.

  • Remove the motherboard and verify that no extraneous screws or other conductive objects are shorting the motherboard to the chassis. Although shaking the case usually causes such objects to rattle, a screw or other small object may become wedged so tightly between the motherboard and chassis that it will not reveal itself during a shake test.

  • If the problem persists, the most likely cause is a defective motherboard.

Use New Thermal Goop Every Time

Before you reinstall the CPU, always remove the old thermal compound and apply new compound. You can generally wipe off the old compound with a paper towel, or perhaps by rubbing it gently with your thumb. (Keep the processor in its socket while you remove the compound). If the compound is difficult to remove, try heating it gently with a hair dryer. Never operate the system without the CPU cooler installed.

1.6.2. Problem: The system seems to start normally, but the display remains black

  • Verify that the display has power and the video cable is connected. If the display has a noncaptive power cable, make sure the power cord is connected both to the display and to the wall receptacle. If you have a spare power cord, use it to connect the display.

  • Verify that the brightness and contrast controls of the display are set to midrange or higher.

  • Disconnect the video cable and examine it closely to make sure that no pins are bent or shorted. Note that the video cable on some analog (VGA) monitors is missing some pins and may have a short jumper wire connecting other pins, which is normal. Also check the video port on the PC to make sure that all of the holes are clear and that no foreign objects are present.

  • If you are using a standalone video adapter in a motherboard that has embedded video, make sure the video cable is connected to the proper video port. Try the other video port just to make sure. Most motherboards with embedded video automatically disable it when they sense a video card is installed, but that is not universally true. You may have to connect the display to the embedded video, enter CMOS Setup (usually by pressing a key such as F2 or Delete while the system is booting), and reconfigure the motherboard to use the video card.

  • Try using a different display, if you have one available. Alternatively, try using the problem display on another system.

  • If you are using a video card, make certain it is fully seated. Many combinations of video card and motherboard make it very difficult to seat the card properly. You may think the card is seated. You may even feel it snap into place. That does not necessarily mean it really is fully seated. Look carefully at the bottom edge of the card and the video slot, and make sure the card is fully in the slot and parallel to it. Verify that installing the screw that secures the video card to the chassis did not torque the card, forcing one end up and out of the slot.

  • If your video card requires a supplemental power cable, be sure to connect it and make sure it snaps into place.

  • If the system has PCI or PCIe expansion cards installed, remove them one by one. (Be sure to disconnect power from the system before you remove or install a card.) Each time you remove a card, restart the system. If the system displays video after you remove a card, that card is either defective or is conflicting with the video adapter. Try installing the PCI or PCIe card in a different slot. If it still causes the video problem, the card is probably defective. Replace it.

1.6.3. Problem: When you connect power (or turn on the main power switch on the back of the power supply), the power supply starts briefly and then shuts off

DANGER, WILL ROBINSON

All of the following steps assume that the power supply is adequate for the system configuration. This symptom may also occur if you use a grossly underpowered power supply. Worse still, doing that may damage the power supply, motherboard, and other components.

  • This may be normal behavior. When you connect power to the power supply, it senses the power and begins its startup routine. Within a fraction of a second, the power supply notices that the motherboard hasn't ordered it to start, so it shuts itself down immediately. Press the main power switch on the case and the system should start normally.

  • If pressing the power switch doesn't start the system, your power supply may have another switch on the back that's set in the off position. Switch it on and then try pressing the front power switch again.

  • If pressing the main power switch still doesn't start the system, you have probably forgotten to connect one of the cables from the power supply or front panel to the motherboard. Verify that the power switch cable is connected to the front-panel connector block, and that the 20-pin or 24-pin main ATX power cable and the 4-pin ATX12V power cable are connected to the motherboard. Connect any cables that are not connected, press the main power switch, and the system should start normally.

  • If the preceding steps don't solve the problem, the most likely cause is a defective power supply. If you have a spare power supply, or can borrow one temporarily from another system, install it temporarily in the new system. Alternatively, connect the problem power supply to another system to verify that it is bad.

  • If the preceding step doesn't solve the problem, the most likely cause is a defective motherboard. Replace it.

1.6.4. Problem: When you apply power, the floppy drive LED lights solidly and the system fails to start

  • The FDD cable is defective or misaligned. Verify that the FDD cable is properly installed on FDD and on the motherboard FDD interface. This problem is caused by installing the FDD cable backward or by installing it offset by one row or column of pins.

  • If the FDD cable is properly installed, it may be defective. Disconnect it temporarily and start the system. If the system starts normally, replace the FDD cable.

  • If the FDD cable is known-good and installed properly, the FDD itself or the motherboard FDD interface may be defective. Replace the FDD. If that doesn't solve the problem and you insist on having an FDD, either replace the motherboard or disable the motherboard FDD interface and install a PCI adapter that provides an FDD interface, or, if your motherboard allows you to boot from USB devices, purchase a USB external floppy drive for the purpose.

1.6.5. Problem: The optical drive appears to play audio CDs, but no sound comes from the speakers

  • Make sure the volume/mixer is set appropriately, i.e., the volume is up and CD Audio isn't muted. There may be multiple volume controls in a system. Check them all.

  • Try a different audio CD. Some recent audio CDs are copy-protected in such a way that they refuse to play on a computer optical drive.

  • If you have tried several audio CDs without success, this may still be normal behavior, depending on the player application you are using. Optical drives can deliver audio data via the analog audio-out jack on the rear of the drive or as a digital bit stream on the bus. If the player application pulls the digital bit stream from the bus, sound is delivered to your speakers normally. If the player application uses analog audio, you must connect a cable from the analog audio-out jack on the back of the drive to an audio-in connector on the motherboard or sound card.

    SPECIAL AUDIO CABLES

    Few optical drives or motherboards include an analog audio cable, so you will probably have to buy a cable. In the past, audio cables were often proprietary, but modern drives and motherboards all use a standard ATAPI audio cable. However, most modern optical drives will send audio over the ATAPI data cable.

  • If you install an audio cable and still have no sound from the speakers, try connecting a headphone or amplified speakers directly to the headphone jack on the front of the optical drive (if present). If you still can't hear the audio, the drive may be defective. If you can hear audio via the front headphone jack but not through the computer speakers, it's likely the audio cable you installed is defective or installed improperly.

1.6.6. Problem: SATA drives are not recognized

  • How SATA (Serial ATA) drives are detected (or not detected) depends on the particular combination of chipset, BIOS revision level, SATA interface, and the operating system you use. Failing to recognize SATA devices may be normal behavior.

  • If you use a standalone PCI SATA adapter card, the system will typically not recognize the connected SATA drive(s) during startup. This is normal behavior. You will have to provide an SATA device driver when you install the operating system.

  • If your motherboard uses a recent chipset, e.g., an Intel 865 or later, and has embedded SATA interfaces, it should detect SATA devices during startup and display them on the BIOS boot screen. If the drive is not recognized and if you have not already done so, update the BIOS to the latest version. Restart the system and watch the BIOS boot screen to see if the system recognizes the SATA drive. Run BIOS Setup and select the menu item that allows you to configure ATA devices. If your SATA drive is not listed, you can still use it, but you'll have to provide a driver on diskette during OS installation.

  • Recognition of SATA drives during operating system installation varies with the OS version and the chipset. The original release of Windows 2000 does not detect SATA drives with any chipset. To install Windows 2000 on an SATA drive, watch during the early part of Setup for the prompt to press F6 if you need to install third-party storage drivers. Press F6 when prompted and insert the SATA driver floppy. Windows XP may or may not recognize SATA drives, depending on the chipset the motherboard uses. With recent chipsets, e.g., the Intel 865 series and later, Windows XP recognizes and uses SATA drives natively. With earlier chipsets, e.g., the Intel D845 and earlier, Windows XP does not recognize the SATA drive natively, so you will have to press F6 when prompted and provide the SATA driver on floppy. Most recent Linux distributions (those based on the 2.4 kernel or later) recognize SATA drives natively.

  • If the SATA drive is still not recognized, pop the lid and verify that the SATA data and power cables are connected properly. Try removing and reseating the cables and, if necessary, connecting the SATA drive to a different motherboard interface connector. If the drive still isn't accessible, try replacing the SATA data cable. If none of this works, the SATA drive is probably defective.

Why Only 128GB or 137GB?

If you install Windows XP from an early distribution disc, it will recognize at most 137 GB (decimal) or 128GB (binary) of hard drive capacity, even if the drive is much larger. You can use the remaining space after Windows is installed, but only if you format it as a separate volume. If you want the entire capacity of a large hard drive to be used as a single volume by Windows XP, you'll need a more recent distribution disc that includes Service Pack 2 (SP2) or later.

1.6.7. Problem: The monitor displays BIOS boot text, but the system doesn't boot and displays no error message

  • This may be normal behavior. Restart the system and enter BIOS Setup (usually by pressing Delete or F1 during startup). Choose the menu option to use default CMOS settings, save the changes, exit, and restart the system.

  • If the system doesn't accept keyboard input and you are using a USB keyboard and mouse, temporarily swap in a PS/2 keyboard and mouse. If you are using a PS/2 keyboard and mouse, make sure you haven't connected the keyboard to the mouse port and vice versa.

  • If the system still fails to boot, run BIOS Setup again and verify all settings, particularly CPU speed, FSB speed, and memory timings.

  • If the system hangs with a DMI pool error message, restart the system and run BIOS Setup again. Search the menus for an option to reset the configuration data. Enable that option, save the changes, and restart the system.

  • If you are using an Intel motherboard, power down the system and reset the configuration jumper from the 12 (Normal) position to 23 (Configure). Restart the system, and BIOS Setup will appear automatically. Choose the option to use default CMOS settings, save the changes, and power down the system. Move the configuration jumper back to the 12 position and restart the system. (Actually, we routinely run the configuration optionwhen such an option is offeredand reset BIOS values to default every time we first use a new motherboard, regardless of make, model, or chipset. It may not be absolutely required, but we've found that doing this minimizes problems.)

  • If you are still unable to access BIOS Setup, power down the system, disconnect all of the drive data cables, and restart the system. If the system displays a Hard Drive Failure or No Boot Device error message, the problem is a defective cable (more likely) or a defective drive. Replace the drive data cable and try again. If the system does not display such an error message, the problem is probably caused by a defective motherboard.

1.6.8. Problem: The monitor displays a Hard Drive Failure or similar error message

  • This is almost always a hardware problem. Verify that the hard drive data cable is connected properly to the drive and the interface and that the drive power cable is connected.

  • Use a different drive data cable and connect the drive to a different power cable.

  • Connect the drive data cable to a different interface.

  • If none of these steps corrects the problem, the most likely cause is a defective drive.

1.6.9. Problem: The monitor displays a No Boot Device, Missing Operating System, or similar error message

  • This is normal behavior if you have not yet installed an operating system. Error messages like this generally mean that the drive is physically installed and accessible, but the PC cannot boot because it cannot locate the operating system. Install the operating system.

  • If the drive is inaccessible, verify that all data and power cables are connected properly. If it is a parallel ATA drive, verify that master/slave jumpers are set correctly, and that the drive is connected to the primary interface.

  • If you upgrade your motherboard, but keep your original hard drive (or use a utility such as Norton Ghost to clone your original), your operating system installation may not have the drivers necessary to function with your new hardware. If you're upgrading your motherboard, chances are good that enough things are different that Windows won't be able to boot. You'll need to reinstall Windows.

1.6.10. Problem: The system refuses to boot from the optical drive

  • All modern motherboards and optical drives support the El Torito specification, which allows the system to boot from an optical disc. If your new system refuses to boot from a CD, first verify that the CD is bootable. Most, but not all, operating system distribution CDs are bootable. Some OS CDs are not bootable, but have a utility program to generate boot floppies. Check the documentation to verify that the CD is bootable, or try booting the CD in another system.

  • Run CMOS Setup and locate the section where you can define boot sequence. The default sequence is often (1) floppy drive, (2) hard drive, and (3) optical drive. Sometimes, by the time the system has decided it can't boot from the FDD or hard drive, it "gives up" before attempting to boot from the optical drive. Reset the boot sequence to (1) optical drive, and (2) hard drive. We generally leave the system with that boot sequence. Most systems configured this way prompt you to "Press any key to boot from CD" or something similar. If you don't press a key, they then attempt to boot from the hard drive, so make sure to pay attention during the boot sequence and press a key when prompted.

  • Some high-speed optical drives take several seconds to load a CD, spin up, and signal the system that they are ready. In the meantime, the BIOS may have given up on the optical drive and gone on to try other boot devices. If you think this has happened, try pressing the reset button to reboot the system while the optical drive is already spinning and up to speed. If you get a persistent prompt to "press any key to boot from CD," try leaving that prompt up while the optical drive comes up to speed. If that doesn't work, run CMOS Setup and reconfigure the boot sequence to put the FDD first and the optical drive second. (Make sure there's no diskette in the FDD.) You can also try putting other boot device options, such as a Zip drive, network drive, or boot PROM ahead of the optical drive in the boot sequence. The goal is to provide sufficient delay for the optical drive to spin up before the motherboard attempts to boot from it.

  • If none of these steps solves the problem, verify that all data cable and power cable connections are correct, that master/slave jumpers are set correctly, and so on. If the system still fails to boot, replace the optical drive data cable.

  • If the system still fails to boot, disconnect all drives except the primary hard drive and the optical drive. If they are parallel ATA devices, connect the hard drive as the master device on the primary channel and the optical drive as the master device on the secondary channel and restart the system.

  • If that fails to solve the problem, connect both the hard drive and optical drive to the primary ATA interface, with the hard drive as master and the optical drive as slave.

  • If the system still fails to boot, the optical drive is probably defective. Try using a different drive.

1.6.11. Problem: When you first apply power, you hear a continuous high-pitched screech or warble

  • The most likely cause is that one of the system fans either has a defective bearing or a wire is contacting the spinning fan. Examine all of the system fansCPU fan, power supply fan, and any supplemental fansto make sure they haven't been fouled by a wire. Sometimes it's difficult to determine which fan is making the noise. In that case, use a cardboard tube or rolled up piece of paper as a stethoscope to localize the noise. If the fan is fouled, clear the problem. If the fan is not fouled but still noisy, replace the fan.

  • Rarely, a new hard drive may have a manufacturing defect or have been damaged in shipping. If so, the problem is usually obvious from the amount and location of the noise and possibly because the hard drive is vibrating. If necessary, use your cardboard tube stethoscope to localize the noise. If the hard drive is the source, the only alternative is to replace it.


Chapter 2. Choosing and Buying Components

The components you choose for your system determine its features, performance level, and reliability. How and where you buy those components determines how much the system costs.

Sometimes it is a good idea to spend more for additional features or performance, but often it is not. The trick is to figure out where to draw the linewhen to spend extra money for extra features and performance, and when to settle for a less expensive component. Our years of experience have taught us several lessons in that regard:

  • Benchmarks lie. Buying PC components based solely on benchmark results is like buying a car based solely on its top speed. It's worse, actually, because no standards exist for how benchmarks measure performance, or what aspect of performance they measure. Using one benchmark, Component A may be the clear winner, with Component B lagging far behind. With another benchmark, the positions may be reversed. When you select components for your new system, we suggest you regard benchmarks with suspicion and use them only as very general guidelines, if at all.

  • Performance differences don't matter if it takes a benchmark to show them. Enthusiast web sites wax poetic about a processor that's 10% faster than its competitor or a video card that renders frames 5% faster than its predecessor. Who cares? A difference you won't notice isn't worth paying for.

  • It's easy to overlook the really important things and focus on trivialities. The emphasis on size and speed means more important issues are often ignored or at best given short shrift. For example, if you compare two hard drives you might think the faster drive is the better choice. But the faster drive may also run noticeably hotter and be much louder and less reliable. In that situation, the slower drive is probably the better choice.

  • Integrated (or embedded) components are often preferable to standalone components. Many motherboards include integrated features such as video, audio, and LAN. The integrated video on modern motherboards suffices for most purposes. Only hardcore gamers and others with special video requirements need to buy a separate video adapter. The best integrated audiosuch as that on motherboards that use Intel and nVIDIA chipsetsis good enough for almost anyone. Integrated LAN adapters are more than good enough for nearly any desktop system.

    Vista and Integrated Video

    The one exception to the general suitability of integrated video is systems that will run Windows Vista. The fastest integrated video currently available is fast enough for running Vista, but only just. If you plan to use Vista, particularly if you will place additional demands on the video adapter other than just running the interface, consider installing a standalone video adapter that is approved to run the Vista Aero Glass interface.

  • The advantage of integrated components is three-fold: cost, reliability, and compatibility. A motherboard with integrated components costs little or no more than a motherboard without such components, which can save you $100 or more by eliminating the cost of inexpensive standalone equivalents. Because they are built into the motherboard, integrated components are usually more reliable than standalone components. Finally, because the motherboard maker has complete control over the hardware and drivers, integrated components usually cause fewer compatibility issues and device conflicts.

    Bang for the Buck

    To find the sweet spot, just compare the price of a component to its performance or capacity. For example, if one processor costs $175 and the next model up is 10% faster, it should cost at most 10% more. If it costs more than that, you've reached the wrong part of the price/performance curve, and you'll be paying a premium for little additional performance. Similarly, before you buy a hard drive, divide the price by the capacity. At the low end, you may find that a small hard drive costs more per gigabyte than a larger drive. At the high end, a very large drive probably costs significantly more per gigabyte than a medium capacity model. The sweet spot is in the middle, where the cost per gigabyte is lowest. Make sure, though, that you compare apples to apples. Don't compare a dual-core processor to a single-core processor, for example, or a 5,400 RPM hard drive to a 7,200 RPM model.

  • Buying at the "sweet spot" is almost always the best decision. The sweet spot is the level at which the price/performance ratio is minimizedwhere you get the most bang for your buck. For example, Intel sells a broad range of processors, from $50 Celerons to $1,000 Core 2 Duo Extreme Editions. Celerons are cheap, but slow. Extreme Edition processors are fast, but hideously expensive. There must be a happy medium. The sweet spot for Intel processors is around $175 for a retail-boxed CPU. If you spend much less, you get less performance per dollar spent. If you spend much more, you get only a slight performance increase. This sweet spot has stayed the same for years. That $175 buys you a faster processor every time Intel cuts prices. But that $175 processor has always been the bang-for-the-buck leader.

  • It's almost always worth paying more for better quality and reliability. If the specs for two components look very similar but one sells for less than the other, it's a safe bet that someone cut corners to reduce the price of the cheaper component. The cheaper component may use inferior materials, have shoddy build quality, or poor quality control, or the manufacturer may provide terrible tech support or a very short warranty. If it's cheaper, there's a reason for it. Count on it. The best way to avoid the trap of poor-quality components is to be willing to pay a bit more for quality. The price difference between a mediocre product and a top-quality one can be surprisingly small. Throughout this book, we recommend only high-quality products. That's not to say that products we don't list are bad, but those we do recommend are good.

  • Brand names really do mean something, but not all brands are good ones. Brand names imply certain performance and quality characteristics, and most manufacturers take pains to establish and maintain those links in consumers' minds. Different brand names are often associated with different quality and/or performance levels in a good/better/best hierarchy, in the same way that General Motors sells their inexpensive models as Chevrolets and their expensive models as Cadillacs.

    For example, ViewSonic makes several lines of LCD displays, including their high-end Pro Series, their midrange Graphics Series, and their entry-level E2 Series. Like many vendors, ViewSonic also maintains a separate brand name for their cheapest products, which they call OptiQuest. If you buy a Pro Series monitor, you know it's going to cost more than the lower-end models, but you also know it's going to have excellent performance and will likely be quite reliable. Conversely, if you buy an OptiQuest monitor, you know it's going to be cheap and not very good. Some manufacturers also have a "high-end" brand name, although that practice has declined as margins have eroded throughout the industry.

    A Rose by Any Other Name

    It's not uncommon for several manufacturers to relabel identical or closely similar products from the same Pacific Rim factory. For example, the factory that makes many of the cases that Antec sells under its brand names also makes similar cases that are sold under other brand names such as Chieftec and Chenming. Contrary to web wisdom, that doesn't mean those similar products are identical to the Antec case. Different companies can specify different levels of finish, quality control, and so on. A case with the Antec name on it meets Antec's quality standards. An "identical" case with a different brand name may not be of the same quality.

  • If you're on a tight budget, shop by brand name rather than by performance specifications. For the same price, it's usually better to choose a component that has less impressive specifications but a better brand name rather than a component with better specifications but a poor brand name. For example, if you can't afford a high-end 19" Samsung LCD display with 4 ms response time, but an 8 ms Samsung model or a similarly priced Brand-X 19" LCD display with 4 ms response time is within your budget, choose the 8 ms Samsung model. It may be a bit slower than the Brand-X display, but the Samsung will almost certainly have better display quality and be more reliable. In other words, if you have to choose between better quality and higher performance, choose quality every time.

In this chapter, we tell you what we've learned based on more than 20 years of buying PC hardware components. In the first edition of this book, we recommended specific brands and models. The obvious downside to doing that is that products change in Internet time. A product that is leading edge when we proof the final galleys may be midrange by the time the book arrives in bookstores and discontinued by the time you read it.

So, rather than a detailed discussion of such ephemera, this chapter focuses instead on important characteristics of hardware componentsthe things you need to understand to make good decisions. But we recognize that many people want detailed recommendations, so we also include links to our online forums, where we post our current recommendations for specific products by brand name and model that are reliable and offer good value for money. If you hew closely to our advice when you make your buying decisions you won't go far wrong.

With so many alternatives, it's easy to buy the right part from the wrong source. Accordingly, the last part of this chapter distills what we've learned about how and where to buy PC hardware components. When you finish reading this chapter, you'll have all the information you need to make the right buying decisions.


Section 2.1. Choosing Components

2.1. Choosing Components

The biggest advantage of building your own PC is that you can choose which components to use. If you buy a cookie-cutter system from Dell or HP, most of the decisions are made for you. You can specify a larger hard drive, more memory, or a different monitor, but the range of options is quite limited. Want a better power supply, a quieter CPU cooler, or a motherboard with built-in FireWire and enhanced RAID support? Tough luck. Those options aren't on the table.

When you build from scratch, you get to choose every component that goes into your system. You can spend a bit more here and a bit less there to get exactly the features and functions you want at the best price. It's therefore worth devoting some time and effort to component selection, but there are so many competing products available that it's difficult to separate the marketing hype from reality.

On your own, you might find yourself struggling to answer questions like, "Should I buy a Seagate hard drive or a Western Digital?" (hint: Seagate), or "Does Sony or HP make the best DVD writers?" (hint: neither; Plextor makes the best optical drives, but there are "bargain" brands that are quite good). We've done all that research for you, and the following sections in conjunction with our online forums distill what we've learned in testing and using hundreds of products over many years.

We recommend products by brand name, and we don't doubt that some people will take issue with some of our recommendations. We don't claim that the products we recommend are "best" in any absolute sense, because we haven't tested every product on the market and because "best" is inherently subjective. What's "best" for us may be just "very good" from your point of view, but it almost certainly won't be "awful."

So, keeping all of that in mind, the following sections describe the products we recommend.

2.1.1. Case

The case (or chassis) is the foundation of any system. Its obvious purpose is to support the power supply, motherboard, drives, and other components. Its less-obvious purposes are to contain the radio-frequency interference produced by internal components; to ensure proper system cooling; and to subdue the noise produced by the power supply, drives, fans, and other components with moving parts.

A good case performs all of these tasks well, and is a joy to work with. It is strongly built and rigid. Adding or removing components is quick and easy. All the holes line up. There are no sharp edges or burrs. A bad case is painful to work with, sometimes literally. It may have numerous exposed razor-sharp edges and burrs that cut you even if you're careful. It is cheaply constructed of flimsy material that flexes excessively. Tolerances are very loose, sometimes so much so that you have to bend sheet metal to get a component to fit, if that is even possible. Using a cheap case is a sure way to make your system-building experience miserable.

BTX

The latest case form factors are BTX (Balanced Technology eXtended) and its smaller variants microBTX and picoBTX, which until late 2006 Intel had been pushing strongly as the eventual replacement for ATX and microATX. Relative to ATX-family cases, BTX-family cases offer superior ventilation and cooling and other improvements. BTX-family cases use ATX-family power supplies, but are physically incompatible with ATX-family motherboards.

As of August 2006, when we completed the final draft manuscript for this book, Intel had announced its intention to convert fully to BTX in 2007 and 2008, abandoning the ATX standard. In mid-October 2006, as this book was about to go to press, Intel abruptly reversed course, announcing that it would cease producing BTX components in 2007, and return to producing only ATX and microATX products. Most industry observers believe that this abrupt change was caused by Intel's fast transition from the hot-running, power-hungry Pentium 4/D architecture to the cool, low-power Core 2 architecture. Suddenly, Intel processors no longer had a heat problem, and BTX was a solution in search of a problem.

Use the following guidelines when choosing a case:

  • Choose the proper size case, taking into account the original configuration and possible future expansion. For a general-purpose system, choose a mini- or mid-tower case. For a small PC, choose a microATX case. Choose a case that leaves at least one drive bayideally a 5.25" external bayfree for later expansion.

  • Get a case with supplemental cooling fans, or space to add them. Heat is the enemy of processors, memory, drives, and other system components. Cooler components last longer and run more reliably.

The cases we recommend are listed at http://www.hardwareguys.com/picks/cases.html.

2.1.2. Power Supply

The power supply is one of the most important components in a PC, and yet most people give it little consideration. In addition to providing reliable, stable, closely-regulated power to all system components, the power supply draws air through the system to cool it. A marginal or failing power supply can cause many problems, some of which are very subtle and difficult to track down. Most problems are not subtle, however. A poor or marginal power supply is likely to cause system crashes, memory errors, and data corruption, and may fail catastrophically, taking other system components with it.

Use the following guidelines to choose a power supply appropriate for your system:

  • Above all, make sure the power supply you buy fits your case and has the proper connectors for your motherboard. Most cases use ATX power supplies, and any ATX power supply fits any ATX case. SFF and microATX cases often use SFX or proprietary power supplies. We avoid using those whenever possible.

  • Size your power supply according to the system configuration. For an entry-level system, install a 300W or larger power supply. For a mainstream system, install a 400W or larger power supply. For a high-performance system, install a 500W or larger power supply. If you're installing dual video adapters in an nVIDIA SLI (Scalable Link Interface) or AMD/ATi CrossFire configuration, make sure to use a power supply that is certified for operation with dual video adapters.

  • Buy only an ATX12V 2.0 or higher compliant power supply.

  • Make sure the power supply provides Serial ATA power connectors.

The power supplies we recommend are listed at http://www.hardwareguys.com/picks/power.html.

2.1.3. Processor

Most people spend too much time dithering about which processor to install. The two choices you have to make are, first, Intel versus AMD, and, second, how much to spend. Here are the considerations for each of the processor price ranges:

Low-end (under $150)

At the bottom of this rangesub-$100 processorsinexpensive AMD Sempron models are generally faster than comparably-priced Intel Celerons. At the upper end of this range are the least expensive processors that we consider mainstream modelsthe slower Athlon 64, Athlon 64 X2, Pentium 4, and Pentium D processors, all of which offer similar price/performance ratios.

Midrange ($150 to $250)

This is the mainstream. The bottom half of this range includes fast Pentium D and Athlon 64 X2 processors, any of which are good choices for a mainstream system, as well as the entry-level Core 2 Duo processors. At the upper end of this range are the fastest Pentium D and Athlon 64 X2 processors and midrange Core 2 Duo models. Midrange processors as a group are generally noticeably faster than low-end processors and cost only a little more, while at the same time they are only a bit slower than high-end processors and cost a lot less.

High-end ($250+)

AMD is no longer competitive in this segment. At the lower end, this range is the realm of midrange Core 2 Duo models. At the high endwhich may approach or exceed $1,000you'll find the Intel Core 2 Duo Extreme Edition. This range is characterized by a rapidly decreasing bang-for-the-buck ratio. A $150 processor might be 50% faster than a $75 processor, but a $500 processor may be only 10% faster than a $250 processor, and a $1,000 processor only 5% faster than a $500 one.

Also consider the following issues when you choose a processor:

  • Even the slowest current processor more than suffices for office productivity applications. If you never load the system heavily, you'll not notice much difference between an inexpensive processor and a more expensive model.

  • Low-end processors are hampered by small secondary caches, which cripple performance, particularly if you work with large data sets, such as multimedia, graphics, or video.

  • Processors in the "sweet spot" range$150 to $225 for a retail-boxed processorusually represent the best bang for the buck.

  • Buy the processor you need initially, rather than buy a slower processor now and plan to upgrade later. Processor upgrades, AMD and Intel, are a minefield of compatibility issues.

The processors we recommend are listed at http://www.hardwareguys.com/picks/processors.html.

THE GREAT PROCESSOR SHAKEUP

In July 2006, Intel introduced its long-awaited Core 2 Duo line of processors and obsoleted its existing single-core Pentium 4 processors and dual-core Pentium D processors overnight. At introduction, even the entry-level $185 Core 2 Duo E6300 processor was as fast as existing AMD and Intel processors that had been selling for $350 to $600. In addition to very high performance, Core 2 Duo processors feature very low power consumption and correspondingly low heat production. For Core 2 Duo, Intel claims a 40% increase in performance at 40% lower power consumption, and our testing confirms those claims.

Core 2 Duo was a devastating blow to AMD's single-core Athlon 64 and dual-core Athlon 64 X2 processor line. AMD took a meat-ax to its processor price list, cutting prices on many models by 60% or more. Even that wasn't enough to give AMD price/performance parity with Core 2 Duo. In effect, Core 2 Duo knocked AMD back into K6 days, when all it had to sell was "value" processors. Or, more accurately, AMD is now selling what we consider "mainstream" and "performance" processors at "value" prices. Intel again owns the high end, and is likely to keep that crown at least through late 2007. In the interim, Intel and AMD will compete strongly in the midrange $150 to $250 segment, with Intel selling its slowest processors in that price range, and AMD selling its fastest. All of us benefit, because we're now able to get what amounts to a performance processor for a mainstream price.

As we write this in August 2006, Intel's plans for the Core 2 processor line are unclear. We expect Intel to release single-core Core 2 Solo models in late 2006 as a replacement for the aging Celeron series. If that occurs, Intel will own the low-end segment as well as the midrange and high-end segments unless AMD makes extraordinary pricing cuts on its single-core Athlon 64 line. We expect that to happen as well, because otherwise AMD will find itself unable to sell any processors.

Whither Pentium D?

Although Intel has not yet discontinued the Pentium D, and in fact introduced new models in July 2006, Pentium D is really just a bridge processor. Intel will continue to offer it as they ramp up Core 2 Duo production, but will almost certainly discontinue it as soon as they are able to meet demand for Core 2 Duo. While it remains available, which will probably be well into 2007, Pentium D remains an excellent choice. Intel has priced it competitively in terms of price/performance against the Core 2 Duo, and certainly against the AMD Athlon 64 X2. The only downside of Pentium D is that it draws a lot of power and produces a lot of heat. Still, that can be dealt with, so don't rule out Pentium D when you're designing your own system.

2.1.4. Heatsink/Fan Units (CPU Coolers)

Modern processors consume 50W to 100W or more. Nearly all systems deal with the resulting heat by placing a massive metal heatsink in close contact with the processor and using a small fan to draw air through the heatsink fins. This device is called a heatsink/fan (HSF) or CPU cooler. Use the following guidelines when choosing an HSF:

  • Make certain the HSF is rated for the exact processor you use. An HSF that physically fits a processor may not be sufficient to cool it properly. In particular, be careful with newer Intel Pentium 4 and Pentium D processors, which produce much more heat than the earlier models that ran at similar speeds.

  • Make sure the HSF is usable with your motherboard. Some HSFs are incompatible with some motherboards because clamping the HSF into position may crush capacitors or other components near the processor socket.

  • Pay attention to noise ratings. Some high-efficiency HSFs designed for use by overclockers and other enthusiasts have very noisy fans. Other HSFs are nearly silent.

  • Use the proper thermal compound. When you install an HSF, and each time you remove and replace it, use fresh thermal compound to ensure proper heat transfer. Thermal compound is available in the form of viscous thermal "goop" and as phase-change thermal pads, which melt as the processor heats up and solidify as it cools down. Make sure that the thermal compound you use is approved by the processor maker.

The CPU coolers we recommend are listed at http://www.hardwareguys.com/picks/cpu-coolers.html.

2.1.5. Motherboard

The motherboard is the main logic board around which a PC is built. The motherboard is the center of the PC in the sense that every system component connects to the motherboard, directly or indirectly. The motherboard you choose determines which processors are supported, how much and what type of memory the system can use, what type of video adapters can be installed, the speed of communication ports, and many other key system characteristics.

Use the following guidelines when choosing a motherboard:

  • For a general-purpose system, choose an ATX motherboard. For a small system, a microATX motherboard may be a better choice, although using the smaller form factor has several drawbacks, notably giving up several expansion slots and making it more difficult to route cables and cool the system.

  • For a Pentium D or Core 2 Duo system, choose a Socket 775 (Socket T) motherboard that is compatible with your choice of processor. For an Athlon 64 X2 system, choose a Socket AM2 motherboard.

  • For an Intel processor, choose an Intel or ASUS motherboard that uses an Intel 946/955X/963/965/975X-series chipset. For an AMD processor, choose an ASUS motherboard that uses an nVIDIA nForce 5-series chipset.

  • Make sure the motherboard supports the exact processor you plan to use. Just because a motherboard supports a particular processor family doesn't mean it supports all members of that family. You can find this information on the motherboard maker's web site or in the release notes to the BIOS updates. It's also important to know exactly what revision of the motherboard you have, because processor support may vary by motherboard revision level.

  • Make sure the motherboard supports the type and amount of memory you need. Do not make assumptions about how much memory a motherboard supports. Check the documentation to find out what specific memory configurations are supported.

  • Before you choose a motherboard, check the documentation and support that's available for it, as well as the BIOS and driver updates available. Frequent updates indicate that the manufacturer takes support seriously.

The motherboards we recommend are listed at http://www.hardwareguys.com/picks/motherboards.html.

2.1.6. Memory

The only real decisions are how much memory to install, what size and type of modules to use, and what brand to buy. Consider the following factors when choosing memory modules (DIMMs):

  • For budget systems, install no less than 512 MB. If the system will run Windows Vista, install 1 GB or more. For mainstream systems, install 1 GB or more. For performance systems, workstations, and multimedia/graphics systems, install 2 GB or more. If you use a Core 2 Duo, Pentium D or Athlon 64 X2 dual-core processor, double these amounts.

  • Memory manufacturers like Crucial (http://www.crucial.com), Kingston (http://www.kingston.com), Corsair (http://www.corsairmemory.com), and Mushkin (http://www.mushkin.com) provide online memory configurators that allow you to enter the brand and model of your motherboard and return a list of compatible memory modules. Before you buy memory, use these configurators to make sure the memory you order is compatible with your particular motherboard.

  • For motherboards that use 184-pin DDR memory, buy only PC3200 or faster DDR-SDRAM memory modules. Choose modules that support fast CAS latency timings only if they cost little or no more than modules that support standard timings.

  • For motherboards that use 240-pin DDR2 memory, buy DDR2 memory modules of at least the speed required by your motherboard/processor combination. DDR2 memory is available in PC2 3200, PC2 4200, PC2 5300, PC2 6400, and PC2 8000 variants. Choose the fastest modules that do not sell at a significant price premium over slower modules. Once again, choose modules that support fast CAS latency timings only if they cost little or no more than modules with standard timings.

  • For higher performance, use DIMMs in pairs to enable dual-channel memory operation.

  • It's generally less expensive to buy a given amount of memory in fewer modules. For example, if you are installing 2 GB of memory, two 1 GB DIMMs will probably cost less than four 512 MB DIMMs. Using fewer but larger DIMMs also preserves memory slots for future expansion. However, the largest capacity modules often sell at a substantial premium. For example, a 2 GB DIMM may cost five times as much as a 1 GB DIMM, rather than only twice as much.

  • Verify the memory configurations supported by your motherboard. For example, a particular motherboard may support 1 GB DIMMs, but not 2 GB DIMMs. One motherboard may support 1 GB DIMMs in all four of its memory slots, but another may support 1 GB DIMMs in only two of its four slots. Check the motherboard documentation to determine the memory configurations your chosen motherboard supports.

  • Nonparity memory modules provide no error detection or correction. ECC modules detect and correct most memory errors, but are slower and more expensive than nonparity modules. Use ECC memory if you install more than 2 GB of memory and the motherboard supports ECC memory. For 2 GB or less, use nonparity modules.

The memory modules we recommend are listed at http://www.hardwareguys.com/picks/memory.html.

2.1.7. Floppy Disk Drive (FDD)

Every time we build a PC without an FDD we regret doing it when we need to load a driver from floppy. (But we keep doing it anyway...) Accordingly, we recommend installing an FDD. At $8 or so, it's cheap insurance. If you want an FDD, buy any brand. FDDs are commodity items, and the brand makes little difference. If you're short on external drive bays and want both an FDD and a card reader, install a combination FDD/card reader such as the Mitsumi FA402A.

ADVICE FROM BRIAN BILBREY

Almost all new motherboards support booting from a USB floppy these days. Buy one of these, and your days of installing a new FDD in a box, or migrating an FDD from a retired system to a new one are over.

2.1.8. Hard Drive

It's easy to choose a good hard drive. Several manufacturers produce drives at similar price points for a given size and type of drive. That said, we prefer Seagate hard drives because they are fast, quiet, cool-running, and competitively-priced, and because we and our readers have experienced poor reliability with drives made by some other manufacturers.

Compatibility is not an issue for hard drives. Hard drives are plug-and-play devices. Any recent hard drive coexists peacefully with any other recent hard drive or optical drive, regardless of manufacturer. (But see the warning about Serial ATA optical drives in the next section.)

Use the following guidelines when you choose a hard disk:

  • Hard drives are available in standard ATA (Parallel ATA or PATA) and Serial ATA (SATA) interfaces. PATA drives are suitable only for upgrading older systems that lack SATA interfaces. For a new system, choose a drive that uses the SATA interface. Choose a model that supports the 3.0 Gb/s SATA interfacewhich is often (incorrectly) described as SATA-IIand native command queuing (NCQ).

  • It's tempting to buy the highest-capacity drive available, but high-capacity drives often cost more per gigabyte than midrange drives, and the highest-capacity drives are often slower than midrange models. Decide what performance level and capacity you need, and then buy a drive that meets those requirements. Choose the model based on cost per gigabyte. You may need to buy the largest drive available despite its higher cost per gigabyte and slower performance, simply to conserve drive bays and ATA channels.

  • Choose a 7,200 RPM SATA drive for a general-purpose system. 10,000 RPM drives cost more than 7,200 RPM models, are not all that much faster, and are much noisier and hotter running than 7,200 RPM models.

  • Get a model with larger buffer/cache if it doesn't cost much more. Some drives are available in two versions that differ only in buffer size. One might have a 2 MB buffer and the other an 8 MB buffer. The larger buffer is worth paying a few extra dollars for.

The hard drives we recommend are listed at http://www.hardwareguys.com/picks/harddisk.html.

2.1.9. Optical Drive

Every system needs an optical drive of some sort, if only for loading software. There are several types of optical drives available. Some can use only CDs, which typically store about 700 MB of data. Other optical drives can use DVDs, which typically store between 4,700 MB and 8,500 MB of data. CD-ROM and DVD-ROM drives are read-only (the "ROM" part of the name). CD writers and DVD writers (also called burners or recorders) can write optical discs as well as read them. DVD is backward compatible with CD, which means that a DVD drive can also read CD discs, and all DVD writers can also write CD discs.

CD drive speeds are specified as a multiple of the 150 KB/s audio CD rate, which is called 1X. For example, a 52X CD drive transfers data at 52 times 150 KB/s, or 7,800 KB/s. DVD drives use a different "X-factor." A 1X DVD drive transfers data at about 1.321 MB/s, or about nine times faster than a 1X CD drive.

Choose an optical drive for your system based on the capabilities you need and the price you are willing to pay. In the past, there were many different types of optical drives, with a wide range of prices and capabilities, including such variants as hybrid DVD-ROM/CD writers. Most of those drive types have fallen by the wayside, victims of the rapidly declining prices of more capable drives. Nowadays, only two optical drive types make sense for use in new systems.

DVD-ROM drive

DVD-ROM drives read CD and DVD discs, cannot write discs, and sell for $20 or less. Install a DVD-ROM drive only when budget is the top priority and you don't need a drive that can write discs. Choose any current model made by Lite-On, Mitsumi, NEC, Samsung, or Toshiba. If you need to read writable DVD discs, make sure the model you choose explicitly lists compatibility with the formats you use. If you need to read DVD-RAM discs, buy a Toshiba model. Otherwise, buy on price.

DVD writer

DVD writers read and write both CDs and DVDs. Inexpensive DVD writers such as those made by BenQ and NEC sell for $35, and are perfectly acceptable for casual use. Midrange and premium models made by Plextor are a better choice for heavy use and when reliability counts, such as making backups.

DON'T BUY AN SATA OPTICAL DRIVE

Nearly all optical drives use the PATA interface. A few models are available with the SATA interface, but we suggest you avoid those. SATA optical drives are plagued with compatibility problems. If you must have an SATA optical drive, make absolutely sure it is certified to be compatible with the exact motherboard model you use.

DON'T BUY A PATA OPTICAL DRIVE

Of course, if you're building an Intel Core 2 system based on a motherboard built around the Intel ICH8 south bridge, you have no choice. ICH8 does not provide PATA interfaces, so your only option is to use an SATA optical drive. The only SATA model we can recommend is the Plextor PX-755SA. Just make sure the motherboard is explicitly listed on Plextor's supported motherboards list.

The optical drives we recommend are listed at http://www.hardwareguys.com/picks/optical.html.

2.1.10. Video Adapter

The video adapter, also called a graphics adapter, renders video data provided by the processor into a form that the monitor can display. Many motherboards include embedded (integrated) video adapters. You can also install a standalone video adapter, also called a video card or graphics card, in a motherboard expansion slot. Keep the following in mind when you choose a video adapter:

  • Unless you run graphics-intensive games, 3D graphics performance is unimportant. Any recent video adapter is more than fast enough for business applications and casual gaming.

  • Choose integrated video unless there is good reason not to. Integrated video adds little or nothing to the price of a motherboard, and generally suffices for anyone except hardcore gamers or those with other special video requirements. Make sure any motherboard you buy allows integrated video to be disabled and provides an AGP or PCI Express slot. That way, you can upgrade the video later if you need to.

  • Make sure that the video adapter you choose uses the type of interface provided by your motherboard. Older motherboards and some current models use the obsolescent AGP (Accelerated Graphics Port) interface. Most current motherboards use the newer PCI Express (PCIe) interface. When you buy a motherboard for a new system, always choose a PCIe model unless you already have an AGP video adapter that you want to migrate to the new system.

    WHAT ABOUT VISTA AND AERO GLASS?

    Much has been made of the fact that Windows Vista is the first version of Windows to use a 3D graphical interface. While it's true that the Aero Glass interface requires 3D graphics support, we have verified that recent integrated video adapters including Intel GMA 950, Intel GMA 3000, and nVIDIA 6100/6150 have sufficiently powerful 3D acceleration to handle Aero Glass. Any video adapter, standalone or integrated, that supports DirectX 9 and PS (Pixel Shader) 2.0 and has 128 MB of memory (on-board or shared) should suffice to run Aero Glass, albeit not with top performance.

    ADVICE FROM BRIAN JEPSON

    And even then, trying to keep the old one locks you into some unpleasant trade-offs. I had a great AGP adapter that I handed down to my brother because I couldn't find a decent AGP motherboard that supported a dual core Pentium. It seems that trying to get AGP support on a modern system leads to some motherboards that are real mongrels in terms of chipsets.

  • Make sure that the video adapter you choose (or the integrated video on your motherboard) provides the type of video output connector you need. CRT monitors and some LCD displays use the 15-pin analog VGA connector; other LCD displays use the digital DVI connector.

  • If you plan to use dual displays, make sure that your integrated video or video adapter supports dual displays, and that it provides the type of video connectors you need for both displays. Note that some video adapters provide one analog and one digital video connector, but allow only one of those to operate at a time. The most flexible choice is a card with dual DVI-I hybrid video connectors, which support both analog and digital displays.

    ADVICE FROM JIM COOLEY

    Even if you plan to use a separate video adapter, having integrated video available is a good diagnostic resource. For that reason alone I'd never buy a board without one.

  • If you need a 3D graphics adapter, don't overbuy. A $400 video adapter is faster than a $100 adapter, but nowhere near four times faster. As with other PC components, the bang-for-the-buck ratio drops quickly as the price climbs. If you need better 3D graphics performance than integrated video provides but you don't have much in the budget for a video adapter, look at "obsolescent" 3D video adaptersthose a generation or two out of date. If you buy an older adapter, make sure the level of DirectX it supports is high enough to support the games you play.

    Advice from Brian Jepson

    I find the user reviews on NewEgg to be helpful in determining whether a given card might be a hassle under Linux.

  • Make sure that the adapter you choose has drivers available for the operating system you intend to use. This is particularly important if you run Linux or another OS with limited driver support.

The video adapters we recommend are listed at http://www.hardwareguys.com/picks/video.html.

2.1.11. Display

You spend a lot of time looking at your display, so it's worth devoting some time and effort to choosing a good one. The first decision to make when you choose a display is whether to buy a traditional "glass bottle" CRT monitor or a flat-panel LCD display.

WHITHER CRTS?

Our editor comments that CRTs are becoming more difficult to find and the selection more limited, which is true. For that matter, CRT-based televisions are fast waning in popularity. But we believe that CRT monitors will continue to be widely available at least through 2007, and probably into 2008 or later.

Relative to CRTs, LCDs have several advantages. LCDs are brighter than CRTs and have better contrast. Short of direct sunlight impinging on the screen, a good LCD provides excellent images under any lighting conditions. LCDs are much lighter than CRTs, and are only a few inches deep, which makes them more convenient when space is limited. Finally, LCDs consume only 20% to 60% as much power as typical CRTs.

Pay Me Now or Pay Me Later

Their lower power consumption means that an LCD costs less to run than a CRT. The amount you save on your power bill depends on how much you pay for power and how many hours your display is used each day, but saving $25 or more per year is typical for a SOHO system. Over a four- to five-year period, lower power bills may offset the higher initial cost of an LCD display. Against this advantage, however, is the fact that even a high-quality LCD display is unlikely to last as long as a good CRT display.

LCDs also have many drawbacks relative to CRTs. Not all LCDs suffer from all of these flaws. Newer models are less likely than older models to suffer from any particular flaw, and inexpensive models are more likely than premium models to suffer from these flaws, both in number and in degree.

The primary drawback of LCDs is their high price, 50% to 100% more than CRTs of comparable size and quality. (Yes, you can buy a $200 19" LCD, but to match the display quality and durability of a $200 19" CRT LCD you'll have to spend $350 or more on an LCD.) LCDs are optimized for one resolution, usually 1024 x 768 for 15" LCDs and 1280 x 1024 for 17", 18", and 19" LCDs. LCDs backlight the image with an array of cold cathode ray tubes (CCRTs), which are similar to fluorescent tubes and are subject to failure and to gradual dimming over time. An out-of-warranty CCRT failure means you might as well buy a new LCD, because it's very costly to repair.

LCDs have other drawbacks as well. Only fast LCD displaysthose with black-white-black response of 8 ms or lessare acceptable for displaying fast-motion video and games, because on slower models the image smears and ghosts. LCDs have a limited viewing angle. Most graphic artists we've spoken to refuse to use LCDs, because the appearance of colors and the relationship between colors change depending on the viewing angle. LCDs provide less vibrant color than a good CRT monitor. This is particularly evident in the darkest and lightest ranges, where the tones seem to be compressed, which limits subtle gradations between light tones or dark tones that are readily evident on a good CRT. Also, some LCDs add a color cast to what should be neutral light or dark tones. LCDs, particularly inexpensive models, suffer from image persistence, which causes temporary "ghost images."

Finally, some LCDs have one or more defective pixels. ISO Standard 13406-2 defines rules for defective pixels, including their number, type, and locations relative to each other. Defective pixels may be always-on (white, called a Type 1 defective pixel) or always-off (black, called a Type 2 defective pixel). A defective subpixel, called a Type 3 defective pixel, is always on, but displays a color other than white. In general, Type 3 defective pixels are more intrusive visually than Type 1 defective pixels, which in turn are more intrusive than Type 2 defective pixels.

ISO standard 13406-2 defines the four classes of panels listed in Table 2-1.

Table 2-1. ISO Standard 13406-2 panel classes (defects per million pixels)

Class

Type 1

Type 2

Type 3

I

0

0

0

II

2

2

5

III

5

15

50

IV

50

150

500

A Class I panel must be perfectzero dead pixels of any typeregardless of its size or resolution. Such panels are extremely expensive, so nearly all high-quality LCD displays use Class II panels. Some of the very cheapest LCD displays use Class III panels. As far as we know, no one sells a Class IV panel for computer use.

The actual number of defective pixels in a panel of a specific class depends on the resolution of that panel. For example, a 17" LCD display with 1280 x 1024 resolution has 1280 x 1024 = 1,310,720 pixels = 1.31072 million pixels. If the panel is Class II, it can have at most the following number of dead pixels of each type:

Type 1 = 1.31072 x 2 = 2.62144 dead pixels = 2 dead pixels
Type 2 = 1.31072 x 2 = 2.62144 dead pixels = 2 dead pixels
Type 3 = 1.31072 x 5 = 6.5536 dead pixels = 6 dead pixels

So, for example, a 1280 x 1024 panel that had as many as 10 dead pixelstwo Type 1, two Type 2, and six Type 3could qualify as a Class II panel. Defective pixels cannot be "traded" among types. For example, if this panel had three Type 1 defective pixels, it would not qualify as a Class II panel, even if it had zero Type 2 and Type 3 defective pixels. Also, some manufacturers voluntarily exceed ISO 13406-2 requirements. For example, Samsung offers a "Zero Bright Pixel Defect Warranty" on some of its premium models. Although these models use Class II panels, Samsung warrants them to be free of Type 1 defective pixels (although the Class II standards for Type 2 and Type 3 defective pixels remain in effect).

People vary in their reaction to defective pixels. Many people won't even notice a few defective pixels, while others, once they notice a defective pixel, seem to be drawn to that pixel to the exclusion of everything else. Some manufacturer warranties specifically exclude some number of defective pixels, typically between 5 and 10, although the number may vary with display size and, sometimes, with the location of the defective pixels and how closely they are clustered. As long as the display meets those requirements, the manufacturer considers the display to be acceptable. You may or may not find it acceptable.

We formerly suggested that LCDs should be used only if their size, weight, low power consumption, or portability outweighed their higher cost and other disadvantages. Otherwise, we recommended choosing a good CRT and allocating the money saved to other system components. But current LCD displays are better, faster, more reliable, and much less expensive than earlier models. In the 17" and 19" range, a midrange name-brand LCD can cost as little as $100 to $150 more than a comparable CRT, and that differential is soon made up, at least in part, by the LCD's lower power consumption. We currently recommend LCD displays for any mainstream or higher system, and recommend CRTs only for budget systems or for those to whom the color accuracy of CRTs is important.

If you've decided that a CRT monitor is right for you, use the following guidelines to choose one:

  • Remember that a CRT display is a long-term purchase. Even with heavy use, a high-quality CRT can be expected to last five years or more, so buy quality and choose a model that's likely to keep you happy not just for your current system, but for one or even two systems after that.

  • Make sure the CRT is big enough, but not too big. We consider 17" models suitable only for casual use or those on the tightest of budgets. For not much more, you can buy a 19" model that you'll be much happier with. Conversely, make sure your desk or workstation furniture can accommodate the new CRT. Many people have excitedly carried home a new 21" CRT only to find that it literally won't fit where it needs to. Check physical dimensions and weight carefully before you buy. Large CRTs commonly weigh 50 lbs. or more, and some exceed 100 lbs. That said, if you find yourself debating 17" versus 19" or 19" versus 21", go with the larger model. But note that if your decision is between a cheap larger CRT and a high-quality smaller one for about the same price, you may well be happier with the smaller CRT. A $130 17" CRT beats a $130 19" CRT every time.

  • Stick with good name brands and buy a midrange or higher model from within that name brand. That doesn't guarantee that you'll get a good CRT, but it does greatly increase your chances. The CRT market is extremely competitive. If two similar models differ greatly in price, the cheaper one likely has significantly worse specs. If the specs appear similar, the maker of the cheaper model has cut corners somewhere, whether in component quality, construction quality, or warranty policies.

  • If possible, test the exact CRT you plan to buy (not a floor sample) before you buy it. Ask the local store to endorse the manufacturer's warrantythat is, to agree that if the CRT fails you can bring it back to the store for a replacement rather than dealing with the hassles of returning it to the manufacturer. Mass merchandisers like Best Buy usually won't do thisthey try to sell you a service contract instead, which you shouldn't buybut small local computer stores may agree to endorse the manufacturer's warranty. If the CRT has hidden damage from rough handling during shipping, that damage will ordinarily be apparent within a month or two of use, if not immediately.

    Recommended Brands

    Our opinion, which is shared by many, is that NEC-Mitsubishi, Samsung, and ViewSonic make the best CRTs available. Their CRTs, particularly midrange and better models, provide excellent image quality and are quite reliable. You're likely to be happy with a CRT from any of these manufacturers.

  • Most mainstream CRT manufacturers produce threeGood, Better, and Bestmodels in 17", 19", and 21". In general, the Good model from a first-tier maker corresponds roughly in features, specifications, and price to the Better or Best models from lower-tier makers. For casual use, choose a Good model from a first-tier maker, most of which are very good indeed. If you make heavier demands on your CRTsuch as sitting in front of it 8 hours a dayyou may find that the Better model from a first-tier maker is the best choice. The Best models from first-tier makers are usually overkill, although they may be necessary if you use the CRT for CAD/CAM or other demanding tasks. Best models often have generally useless features like extremely high resolutions and unnecessarily high refresh rates at moderate resolutions. It's nice that a Best 17" model can display 1600 x 1200 resolution, for example, but unless you can float on thermals and dive on rabbits from a mile in the air, that resolution is likely to be unusable. Similarly, a 17" CRT that supports 115 MHz refresh rates at 1024 x 768 is nice, but in practical terms offers no real advantage over one that supports 85 or 90 MHz refresh.

  • Choose the specific CRT you buy based on how it looks to you. Comparing specifications helps narrow the list of candidates, but nothing substitutes for actually looking at the image displayed by the CRT.

  • Make sure the CRT has sufficient reserve brightness. CRTs dim as they age, and one of the most common flaws in new CRTs, particularly those from second- and third-tier manufacturers, is inadequate brightness. A CRT that is barely bright enough when new may dim enough to become unusable after a year or two. A new CRT should provide a good image with the brightness set no higher than 50%.

Like all other component manufacturers, CRT makers have come under increasing margin pressures. A few years ago, we felt safe in recommending any CRT from a first-tier maker, because those companies refused to put their names on anything but top-notch products. Alas, first-tier makers have been forced to make manufacturing cost reductions and other compromises to compete with cheap Pacific Rim CRTs.

Accordingly, low-end models from first-tier makers may be of lower quality than they were in the past. The presence of a first-tier maker's name plate still means that CRT is likely to be of higher quality than a similar no-name CRT, but is no longer a guarantee of top quality. Many first-tier CRTs are actually made in the same Pacific Rim plants that also produce no-name junk, but don't read too much into that. First-tier CRTs are still differentiated by component quality and the level of quality control they undergo. There is no question in our minds that the first-tier CRTs are easily worth the 10% to 20% price premium they command relative to lesser brands. In fact, we think it is worth the extra cost to buy not just a first-tier CRT, but a midrange first-tier CRT.

Buy CRTs Locally

After shipping costs, it may actually cost less to buy locally, but that is not the main reason for doing so. Buying locally gives you the opportunity to examine the exact CRT you are buying. Except for LCDs, CRTs vary more between samples than other computer components. Also, CRTs are sometimes damaged in shipping, often without any external evidence on the CRT itself or even the box. Damaged CRTs may arrive DOA, but more often they have been jolted severely enough to cause display problems and perhaps reduced service life, but not complete failure. Buying locally allows you to eliminate a "dud" before you buy it, rather than having to deal with shipping it back to the vendor or manufacturer.

If you've decided that an LCD display is right for you, use the following guidelines to choose one:

  • Current LCDs are available in analog-only, digital-only, and models with both analog and digital inputs. Analog input is acceptable for 15" (1024 x 768) models, but for 17" (1280 x 1024) models analog video noise becomes an issue. At that screen size and resolution, analog noise isn't immediately obvious to most people, but if you use the display for long periods the difference between using a display with a clean digital signal and one with a noisy analog signal will affect you on almost a subconscious level. For a 19" (1280 x 1024) LCD, we regard a digital signal as extremely desirable but not absolutely essential. For a larger display or above 1280 x 1024, we wouldn't consider using analog signaling.

  • Insist on true 24-bit color support, which may be described as support for 16.7 million colors. Most current LCDs support 24-bit color, allocating one full byte to each of the three primary colors, which allows 256 shades of each color and a total of 16.7 million colors to be displayed. Many early LCDs and some inexpensive current models support only six bits per color, for a total of 18-bit color. These models use extrapolation to simulate full 24-bit color support, which results in poor color quality. If an LCD is advertised as "24-bit compatible," that's good reason to look elsewhere. Oddly, many LCDs that do support true 24-bit color don't bother to mention it in their spec sheets, while many that support only 18-bit color trumpet the fact that they are "24-bit compatible."

  • Most LCD makers produce three or more series of LCDs. Entry-level models are often analog-only, even in 19" and 21" sizes, and have slow response times. Midrange models usually accept analog or digital inputs, and generally have response times fast enough for anything except 3D gaming and similarly demanding uses. The best models may be analog/digital hybrids or digital-only, and have very fast response times. Choose an entry-level model only if you are certain that you will never use the display for anything more than word processing, web browsing, and similarly undemanding tasks. If you need a true CRT-replacement display, choose a midrange or higher model with a digital interface and the fastest response time you are willing to pay for.

  • Decide what panel size and resolution is right for you. Keep in mind that when you choose a specific LCD model, you are also effectively choosing the resolution that you will always use on that display.

  • Buy the LCD locally if possible. Whether or not you buy locally, insist on a no-questions-asked return policy. LCDs are more variable than CRT monitors, both in terms of unit-to-unit variation and in terms of usability with a particular graphics adapter. This is particularly important if you are using an analog interface. Some analog LCDs simply don't play nice with some analog graphics adapters. Also, LCDs vary from unit to unit in how many defective pixels they have and where those are located. You might prefer a unit with five defective pixels near the edges and corners rather than a unit with only one or two defective pixels located near the center of the screen.

  • If you buy locally, ask the store to endorse the manufacturer's warrantythat is, to agree that if the LCD fails you can bring it back to the store for a replacement rather than dealing with the hassles of returning the LCD to the maker.

  • If possible, test the exact LCD you plan to buy (not a floor sample) before you buy it. Ideally, in particular if you will use the analog interface, you should test the LCD with your own system, or at least with a system that has a graphics adapter identical to the one you plan to use. We'd go to some extremes to do this, including carrying our desktop system down to the local store. But if that isn't possible for some reason, still insist on seeing the actual LCD you plan to buy running. That way, you can at least determine if there are defective pixels in locations that bother you. Also, use a neutral gray screen with no image to verify that the backlight evenly illuminates the entire screen. Some variation is unavoidable, but one or more corners should not be especially darker than the rest of the display, nor should there be any obvious "hot" spots.

    Recommended Brands

    Our opinion, confirmed by our readers and colleagues, is that NEC-Mitsubishi, Samsung, Sony, and ViewSonic make the best LCDs available. Their LCDs, particular midrange and better models, provide excellent image quality and are quite reliable. You're likely to be happy with an LCD from any of these manufacturers.

  • Stick with good name brands and buy a midrange or higher model from within that name brand. That doesn't guarantee that you'll get a good LCD, but it does greatly increase your chances. The LCD market is extremely competitive. If two similar models differ greatly in price, the cheaper one likely has significantly worse specs. If the specs appear similar, the maker of the cheaper model has cut corners somewhere, whether in component quality, construction quality, or warranty policies.

The CRT monitors and LCD displays we recommend are listed at http://www.hardwareguys.com/picks/displays.html.

2.1.12. Audio Adapter

Audio adapters, also called sound cards, are a dying breed. Nearly all motherboards provide integrated audio that is more than good enough for most people's needs. In particular, the integrated audio provided by nVIDIA and Intel chipsets is excellent, with good support for six-channel audio. Only gamers, those who work professionally with audio, and those who have purchased a motherboard without integrated audio need consider buying a standalone audio adapter.

Use the following guidelines when choosing an audio adapter:

Don't buy too much audio adapter

When you add or replace an audio adapter, don't pay for features you won't use. Don't buy an expensive audio adapter if you'll use it only for playing CDs, casual gaming, VoIP telephony, and so on. Even $25 sound cards include most of the features that more expensive cards provide, and are more than adequate for most purposes.

Don't buy too little audio adapter

If you use your sound card for 3D gaming, buy one with hardware acceleration and other features that support what you use the card for. Capable consumer-grade audio adapters like the M-AUDIO Revolution and Creative Labs Audigy2-series sound cards sell for under $75, and are suitable for anything short of professional audio production.

External USB Sound Adapters

Several companies, including Creative Labs, M-Audio, and Turtle Beach, manufacture external audio adapters that connect to a PC via a USB port. The advantage of these devices is easy installationyou just connect the box to a USB port and install the drivers; no need to open the case. The disadvantage is that you have one more box cluttering up your desk.

Avoid no-name audio adapters

Stick to name-brand audio adapters. We frequently hear horror stories from readers who have purchased house-brand audio adaptersoutdated drivers, missing or inadequate documentation, poor (or no) tech support, shoddy construction, incompatibilities with Windows, and on and on. What's particularly ironic is that you may pay more for a house-brand audio adapter than for a low-end name-brand card. You can buy decent name-brand audio adapters for $25 from reputable companies. Don't buy anything less.

The audio adapters we recommend are listed at http://www.hardwareguys.com/picks/soundcard.html.

2.1.13. Speakers

Computer speakers span the range from $10 pairs of small satellites to $500+ sets of six or seven speakers that are suitable for a home theater system. Personal preference is the most important factor in choosing speakers.

Speakers that render a Bach concerto superbly are often not the best choice for playing a first-person shooter like Unreal Tournament. For that matter, speakers that one person considers perfect for the Bach concerto (or the UT game), another person may consider mediocre at best. For that reason, we strongly suggest that you attempt to listen to speakers before you buy them, particularly if you're buying an expensive set.

Speaker sets are designated by the total number of satellite speakers, followed by a period and a "1" if the set includes a subwoofer (also called a low-frequency emitter or LFE). Speaker sets are available in the following configurations:

  • 2.0: Front left and right satellites

  • 2.1: 2.0 with a subwoofer

  • 4.1: 2.1 with a rear left/right satellite pair added

  • 5.1: 4.1 with a front center-channel speaker added

  • 6.1: 5.1 with a rear center-channel speaker added

  • 7.1: 5.1 with a side left/right satellite pair added

  • 8.1: 7.1 with a rear center-channel speaker added

6.1, 7.1, and 8.1 speaker sets are used primarily by gamers. Some manufacturers have begun to produce "wireless" 5.1 and higher speaker sets. These speaker sets are wireless in the sense that the audio signal is communicated wirelessly; the remote satellite speakers still must be connected to AC power. Wireless speakers use the 2.4 GHz band that is shared with wireless networks, cordless telephones, microwave ovens, and innumerable other devices, so interference is always a consideration. Still, the absence of speaker wires makes it much easier to install these speakers, particularly in a living room, den, home theater, or other residential environment.

The price of a speaker set doesn't necessarily correspond to the number of speakers in the set. For example, there are very inexpensive 5.1 speaker sets available, and some 2.1 sets that cost a bundle. We recommend that you decide on the number of speakers according to your budget. If you have $75 to spend, for example, you're better off buying a good 2.1 speaker set than a cheesy 5.1 set.

The speakers we recommend are listed at http://www.hardwareguys.com/picks/speakers.html.

2.1.14. Keyboards

The best keyboard is a matter of personal preference. A keyboard we really like, you may dislike intensely, and vice versa. Ultimately, your own preferences are the only guide.

Keyboards vary in obvious wayslayout, size, and styleand in subtle ways like key spacing, angle, dishing, travel, pressure required, and tactile feedback. People's sensitivity to these differences varies. Some are keyboard agnostics who can sit down in front of a new keyboard and, regardless of layout or tactile response, be up to speed in a few minutes. Others have strong preferences about layout and feel. If you've never met a keyboard you didn't like, you can disregard these issues and choose a keyboard based on other factors. If love and hate are words you apply to keyboards, use an identical keyboard for at least an hour before you buy one for yourself.

That said, here are several important characteristics to consider when you choose a keyboard:

  • Keyboards are available in two styles, the older straight keyboard and the modern ergonomic style. Some people strongly prefer one or the other. Others don't care. If you've never used an ergonomic keyboard, give one a try before you buy your next keyboard. You may hate iteveryone does at firstbut then again after you use it for an hour or so you may decide you love it.

  • The position of the alphanumeric keys is standard on all keyboards other than those that use the oddball Dvorak layout. What varies, sometimes dramatically, is the placement, size, and shape of other keys, such as shift keys (Shift, Ctrl, and Alt), function keys (which may be across the top, down the left side, or both), and cursor control and numeric keypad keys. If you are used to a particular layout, purchasing a keyboard with a similar layout makes it easier to adapt to the new keyboard.

  • Most current keyboards use the USB interface natively, and are supplied with an adapter for those who need to connect them to a PS/2 keyboard port. We use mostly USB keyboards, but it's a good idea to have at least one PS/2 keyboard available (or a PS/2 adapter) for those times when Windows shoots craps and won't recognize USB devices.

  • Some keyboards provide dedicated and/or programmable function keys to automate such things as firing up your browser or email client or to allow you to define custom macros that can be invoked with a single keystroke. These functions are typically not built into the keyboard itself, but require loading a driver. To take advantage of those functions, make sure a driver is available for the OS you use.

  • The weight of a keyboard can be a significant issue for some people. The lightest keyboard we've seen weighed just over a pound, and the heaviest nearly eight pounds. If your keyboard stays on your desktop, a heavy keyboard is less likely to slide around. Conversely, a heavy keyboard may be uncomfortable if you work with the keyboard in your lap.

  • Some manufacturers produce keyboards with speakers, scanners, and other entirely unrelated functions built in. These functions are often clumsy to use, fragile, and have limited features. If you want speakers or a scanner, buy speakers or a scanner. Don't get a keyboard with them built in.

  • Wireless keyboards are ideal for presentations, TV-based web browsing, or just for working with the keyboard in your lap. Wireless keyboards use a receiver module that connects to a USB port or the PS/2 keyboard port on the PC. The keyboard and receiver communicate using either radio frequency (RF) or infrared (IR). IR keyboards require direct line-of-sight between the keyboard and receiver, while RF keyboards do not. Most IR keyboards and many RF keyboards provide limited rangeas little as five feet or sowhich limits their utility to working around a desk without cables tangling. Any wireless keyboard you buy should use standard AA, AAA, or 9V alkaline or NiMH batteries rather than a proprietary battery pack.

Logitech and Microsoft both produce a wide range of excellent keyboards, one of which is almost certainly right for you. Even their basic models are well built and reliable. The more expensive models add features such as RF or Bluetooth wireless connectivity, programmable function keys, and so on.

The keyboards we recommend are listed at http://www.hardwareguys.com/picks/keyboards.html.

2.1.15. Mice

Choosing a mouse is much like choosing a keyboard. Personal preference is by far the most important consideration. If possible, try a mouse before you buy it.

Small Hands, Big Mouse

Don't assume that hand size and mouse size are necessarily related. For example, Barbara, who has small hands, prefers the Microsoft IntelliMouse Explorer, which is an oversize mouse. She found that using a standard or small mouse for long periods caused her hand to hurt. Changing to a large mouse solved the problem.

Use the following guidelines when choosing a mouse:

  • Mice are available in various sizes and shapes, including small mice intended for children, notebook-sized mice, the formerly standard "Dove bar" size, the mainstream ergonomic mouse, and some oversize mice that have many buttons and extra features. Most people find standard-size mice comfortable to use for short periods, but if you use a mouse for longer periods small differences in size and shape often make a big difference in comfort and usability. Although oversize mice provide attractive features and functions, people with small hands may find such mice too large to use comfortably. Pay particular attention to mouse shape if you are left-handed. Although asymmetric ergonomic mice are often claimed to be equally usable by left- and right-handers, many lefties find them uncomfortable and resort to right-handed mousing. Some manufacturers, including Logitech, produce symmetric ergonomic mice.

  • Get a wheel mouse. Although some applications do not support the wheel, those that do are the ones most people are likely to use a great dealMicrosoft Office, Internet Explorer, Firefox, and so on. Using the wheel greatly improves mouse functionality by reducing the amount of mouse movement needed to navigate web pages and documents. Mice with a tilt-wheel allow you to scroll vertically and horizontally.

  • Standard two-button mice (three, counting the wheel) suffice for most purposes. However, five-button mice are ideally suited to some applications, such as games and web browsing. For example, the two extra buttons can be mapped to the Back and Forward browser icons, eliminating a great deal of extraneous mouse movement.

  • Mice have cords ranging in length from less than 4 feet to about 9 feet. A short mouse cord may be too short to reach the system, particularly if it is on the floor. If you need a longer mouse cord, purchase a PS/2 keyboard or USB extension cable, available in nearly any computer store.

  • Consider buying a cordless mouse. The absence of a cord can make a surprising difference.

  • Buy an optical mouse. Optical mice use a red LED or chip LASER light source and do not require any special mousing surface. Because they are sealed units, optical mice seldom need cleaning. Robert had to take his mechanical mice apart and clean them literally every few days, but his optical mice go for months without cleaning. Fortunately, only the cheapest mice nowadays are mechanical.

Logitech and Microsoft both produce a wide range of excellent optical mice, in corded and cordless models. One of them is almost certainly right for you. Even their basic models are well built and reliable. The more expensive models have more features, are more precise, and are probably more durable. We used Microsoft optical mice almost exclusively for many years, and continue to recommend them. However, when we tested the superb Logitech MX-series optical mice, we found that we preferred their shape and feel. We now use Logitech optical mice on most of our primary systems.

Mouse Alternatives

Consider using a trackball or touchpad, particularly if you experience hand pain when using a mouse.

Avoid cheap, no-name mice. If someone tries to sell you a mechanical "ball" mouse, run.

The mice we recommend are listed at http://www.hardwareguys.com/picks/mice.html.

2.1.16. Network Adapters

A network adapteralso called a LAN (Local Area Network) adapter, or NIC (Network Interface Card)is used to connect a PC to a home or business network. A network adapter provides a relatively fast communication link100 megabits per second (Mb/s) or 1,000 Mb/sbetween the PC and other devices connected to the network. Network adapters are available in wired and wireless versions. A network may use all wired network adapters, all wireless network adapters, or some combination of the two.

2.1.17. Wired network adapters

In a typical wired network, the network adapters in each PC connect to a central hub or switch that allows any connected device to communicate with any other connected device. In a home or SOHO setting, a wired network adapter may also be used to connect an individual PC directly to a cable modem or xDSL modem.

Nearly all wired network adapters support one or more of a family of networking standards that are collectively called Ethernet. Current Ethernet adapters use unshielded twisted pair (UTP) cable, which resembles standard telephone cable, and communicate at 100 Mb/s (100BaseT or "Fast Ethernet") or 1,000 Mb/s (1000BaseT or "Gigabit"). Wired Ethernet adapters use an 8-position, 8-connector (8P8C) jack that resembles an oversized telephone jack, and is usually (although incorrectly) called an "RJ-45" connector.

Many motherboards include integrated wired Ethernet adapters, which are typically 10/100 or 10/100/1000 hybrid devices. You can add wired Ethernet to a system that lacks an integrated NIC by installing an inexpensive PCI expansion card. Integrated network adapters are reliable and add little or nothing to the cost of a motherboard. Standalone desktop PCI network adapters typically cost from $15 to $40, depending on manufacturer and speed. PCI network adapters are often more efficient and fully featured than integrated adapters.

Apples and Oranges

Make sure you know what you're getting when you order a motherboard. Many motherboards are available in several variants, which may provide different levels of integrated Ethernet. For example, the Intel D945GNT motherboard is available in five variants. The D945GNTL and the D945GNTLR provide integrated 10/100 Ethernet. The D945GNTLK, D945GNTLKR, and the LAD945GNTLKR provide integrated 10/100/1000 Ethernet.

Warning: Most Ethernet adapters are backward compatible with slower Ethernet versions. For example, most 100BaseT adapters can also communicate with old 10BaseT devices, and most 1000BaseT adapters can also communicate with 100BaseT and 10BaseT devices. This is not invariably true, however. Some Ethernet devices support only one or two standards. That can cause problems if, for example, you connect a 10BaseT adapter (for example, in an old notebook system) to a hub or switch that supports only 100BaseT or 100BaseT and 1000BaseT. Although the devices can be physically connected, they do not communicate. Components that support multiple speeds, called hybrid components, are usually labeled in the form 10/100BaseT, 100/1000BaseT, or 10/100/1000BaseT.

The best rule of thumb for most desktop systems is to use an integrated network adapter, if your chosen motherboard offers that option and if you do not require the additional management and other features available only with standalone adapters. For servers, use a standalone 100BaseT PCI network adapter, unless you are using a special server motherboard that incorporates one or more server-class 100BaseT or 1000BaseT network adapters. For 1000BaseT on a server, use only an integrated adapter. A PCI 1000BaseT adapter simply consumes too much of the available PCI bandwidth to be usable in such an environment.

If you need wired connectivity, choose a motherboard that provides an integrated 10/100, 100/1000, or 10/100/1000 Ethernet adapter. 10/100 is acceptable for most people's current needs, but Gigabit models provide "future-proofing" at small additional cost.

If your motherboard does not provide an integrated LAN adapter or if you prefer to use a separate LAN adapter, choose one of the wired network adapters we recommend at http://www.hardwareguys.com/picks/lan.html.

Warning

Running at 1,000 Mb/s, a PCI Gigabit Ethernet adapter can swamp the 133 MB/s (1,067 Mb/s) PCI bus, so it's a bad idea to use a PCI Gigabit adapter. Instead, look for a motherboard that provides integrated Gigabit LAN that keeps LAN traffic off the PCI bus by using a dedicated high-speed bus, such as Intel's CSA or Communications Streaming Architecture bus, or a PCIe channel. Alternatively, install a Gigabit Ethernet card that uses the PCIe bus.

2.1.18. Wireless network adapters

Wireless network adaptersalso called WLAN (wireless LAN) cards, 802.11 cards, or Wi-Fi (Wireless Fidelity) cardsuse radio waves to communicate. WLAN adapters communicate with a central device called an access point (AP) or wireless access point (WAP). In a mixed wired/wireless network, the AP connects to the wired network and provides an interface between the wired and wireless portions of the network. One AP can support many WLAN adapters, but all of the adapters must share the bandwidth available on the AP. In a large network, multiple APs may be used to extend the physical reach of the wireless network and to provide additional bandwidth to computers that connect to the network with WLAN adapters.

WLAN adapters are commonly used in notebook computers, either in integrated form or as a PC card. WLAN adapters are also available as PCI expansion cards that can be installed in desktop systems to provide a network link when it is difficult or expensive to run a cable to a system. The original 1997-era WLAN adapters used the 802.11 standard, which supported a maximum data rate of only 2 Mb/s. Those adapters are long obsolete. Current WLAN adapters support one or more of the following standards.

802.11b

802.11b supports a maximum data rate of 11 Mb/s, comparable to 10BaseT Ethernet, and has typical real-world throughput of 5 Mb/s. 802.11b uses the unlicensed 2.4 GHz spectrum, which means it is subject to interference from microwave ovens, cordless phones, and other devices that share the 2.4 GHz spectrum. The popularity of 802.11b is waning because components that use the faster 802.11g standard, described shortly, are now available at low cost, and because most 802.11b components support only the compromised WEP authentication and encryption rather than trustworthy WPA or WPA2. Millions of 802.11b adapters remain in use, primarily as integrated or PC Card adapters in notebook computers.

802.11a

802.11a supports a maximum data rate of 54 Mb/s, and has typical real-world throughput of 25 Mb/s. It uses a portion of the 5 GHz spectrum that until late 2003 was licensed, but is now unlicensed. 5 GHz signals have shorter range and are more easily obstructed than 2.4 GHz signals, but are also less likely to interfere with other nearby devices. 802.11a is incompatible with 802.11b because they use different frequencies. The higher cost for 802.11a devices means they are used almost exclusively in business environments. Most 802.11a components have business-oriented features such as remote manageability that add cost but are of little interest to home users.

802.11g

The most recent WLAN standard is 802.11g, which combines the best features of 802.11a and 802.11b. Like 802.11b, 802.11g works in the unlicensed 2.4 GHz spectrum, which means it has good range but is subject to interference from other 2.4 GHz devices. Because they use the same frequencies, 802.11b WLAN adapters can communicate with 802.11g APs, and vice versa. Like 802.11a, 802.11g supports a maximum data rate of 54 Mb/s, and has typical real-world bandwidth of about 25 Mb/s. That is sufficient to support real-time streaming video, which 802.11b cannot. 802.11g devices now sell for little more than 802.11b devices, so 802.11g has effectively made 802.11b obsolete.

Warning: 802.11b and 802.11g components are standards-based, so devices from different manufacturers should interoperate. In practice, that is largely true, although minor differences in how standards are implemented can cause conflicts. In particular, some high-end 802.11b/802.11g components include proprietary extensions for security and similar purposes. Those components do generally interoperate with components from other vendors, but only on a "least common denominator" basisthat is, using only the standard 802.11 features. The best way to ensure that your wireless network operates with minimal problems is to use WLAN adapters and APs from the same vendor.

"802.108g"

Several manufacturers, including D-Link and NetGear, produce APs that claim to provide 108 Mb/s bandwidth. In fact they do, but only by "cheating" on the 802.11g specification. Such APs, colloquially called "802.108g" devices, work as advertised, but using them may cause conflicts with 802.11g-compliant devices operating in the same vicinity.

802.11g defines 11 channels (13 in Europe), each with 22 MHz of bandwidth. Each 22 MHz channel can support the full 54 Mb/s bandwidth of 802.11g. But these channels overlap, as shown in Figure 2-1. Three of the channels1, 6, and 11are completely nonoverlapping, which means that three 802.11g-compliant APs in the same vicinityone assigned to each of the three nonoverlapping channelscan share the 2.4 GHz spectrum without conflicts. Alternatively, two 802.11g-compliant APs can be assigned to two channels that do not overlap each other, for example, Channels 2 and 8.

Figure 2-1. 802.11g channels

An 802.108g device claims two of the three completely nonoverlapping channels, typically either 1 and 6 or 6 and 11, although it could in theory use 1 and 11. That leaves only one channel available for other 802.11g devices. To make matters worse, although 802.11g APs detect other nearby 802.11g APs and adjust themselves to use nonconflicting channels, many 802.11g APs fail to detect 802.108g APs operating nearby. The 802.11g devices wrongly assume that the channels being used by the 802.108g devices are available, and so may choose to operate on those "available" channels. The upshot is that it's possible, even likely, to end up with an 802.11g device and an 802.108g device attempting to use the same channel at the same time, which means neither device works properly.

If you are building a new wireless network, use a D-Link 802.11g or 802.108g WLAN adapter and AP. Choose 802.11g if channel conflicts are possible, e.g., if you live in an apartment or if your business is in close proximity to other businesses. Choose 802.108g if there are no 802.11b/g APs nearby, but note that you may have to replace 2.4 GHz cordless phones with models that use a different frequency band. If you are expanding a wireless network, use an 802.11g adapter from the same company that made the existing components.

Avoid no-name network adapters and other components. Avoid mixing components from different manufacturers, if possible, particularly in a wireless network. Avoid 802.11a unless you need SNMP remote manageability and other business-oriented features.

Run a Router

If you need to purchase an 802.11g or 802.108g AP, consider buying a model that also incorporates a hardware firewall/router. Using a hardware firewall/router on a home or SOHO network is the single most important thing you can do to improve security and reduce the likelihood that your systems will be infected by a worm.


Section 2.2. Buying Components

2.2. Buying Components

We've bought hundreds of thousands of dollars' worth of PC components over the last 20 years, for ourselves and on behalf of employers and clients. In the following sections, we'll tell you what we learned along the way.

2.2.1. Buying Guidelines

Until the early 1990s, most computer products were bought in computer specialty stores. Retail sales still make up a significant chunk of computer product salesalthough the emphasis has shifted from computer specialty stores to local "big-box" retailers like Best Buy, CompUSA, Fry's, Wal-Mart, and Costcobut online resellers now account for a large percentage of PC component sales.

Should you buy from a local brick-and-mortar retailer or an online reseller? We do both, because each has advantages and disadvantages.

Local retailers offer the inestimable advantage of instant gratification. Unless you're more patient than we are, when you want something, you want it Right Now. Buying from a local retailer puts the product in your hands instantly, instead of making you wait for FedEx to show up. You can also hold the product in your hands, something that's not possible if you buy from an online reseller. Local retailers also have a big advantage if you need to return or exchange a product. If something doesn't work right, or if you simply change your mind, you can just drive back to the store rather than dealing with the hassles and cost of returning a product to an online reseller.

Online resellers have the advantage in breadth and depth of product selection. If you want the less-expensive OEM version of a product, for example, chances are you won't find it at local retailers, most of which stock only retail-boxed products. If an online reseller stocks a particular manufacturer's products, they tend to stock the entire product line, whereas local retailers often pick and choose only the most popular items in a product line. Of course, the popular products are usually popular for good reasons. Online resellers are also more likely to stock niche products and products from smaller manufacturers. Sometimes, if you must have a particular product, the only option is to buy it online.

Online resellers usually advertise lower prices than local retailers, but it's a mistake to compare only nominal prices. When you buy from a local retailer, you pay only the advertised price plus any applicable sales tax. When you buy from an online retailer, you pay the advertised price plus shipping, which may end up costing you more than buying locally.

Warning: Ah, but you don't have to pay sales tax when you buy online, right? Well, maybe. In most jurisdictions, you're required by law to pay a use tax in lieu of sales tax on out-of-state purchases. Most people evade use taxes, of course, but that free ride is coming to an end. States faced with increasing budget problems, which is to say all of them, are starting to clamp down on people who buy from online resellers and don't pay use tax. States are using data-mining techniques to co-ordinate with each other and with credit card companies and online retailers to uncover unpaid use taxes. If you don't pay use taxes, one day soon you're likely to hear from the audit division of your state department of revenue, asking what these credit card charges were for and why you didn't report the use taxes due on them. Count on it.

Although online resellers may have a lower overall price on a given component, it's a mistake to assume that is always the case. Local retailers frequently run sales and rebate promotions that cut the price of a component below the lowest online price. For example, we bought a spindle of 100 CD-R discs on sale from a local retailer for $19.95 with a $10 instant rebate and a $20 mail-in rebate. After the cost of the stamp to mail in the rebate form, they paid us $9.68 to carry away those 100 discs, which is pretty tough for an online reseller to match. Similarly, we bought an 80 GB hard drive for $79.95, with a $15 instant rebate and a $30 mail-in rebate. Net cost? About $35 for a retail-boxed 80 GB hard drive, which no online vendor could come close to matching.

In particular, local retailers are usually the best place to buy heavy and/or bulky items, such as monitors, cases, UPSs, and so on. Local retailers receive these items in pallet loads, which makes the cost of shipping an individual item almost nothing. Conversely, online resellers have to charge you, directly or indirectly, for the cost of getting that heavy item to your door.

Whether your purchase your PC components from a local brick-and-mortar store or a web-based retailer, here are some guidelines to keep in mind:

  • Make sure you know exactly what you're buying. For example, a hard drive may be available in two versions, each with the same or a similar model number but with an added letter or number to designate different amounts of cache. Or a hard drive maker may produce two models of the same size that differ in price and performance. Always compare using the exact manufacturer model number. Before you buy a product, research it on the manufacturer's web site and on the numerous independent web sites devoted to reviews. We usually search Google with the product name and "review" in the search string.

  • Vendors vary greatly. Some we trust implicitly, and others we wouldn't order from on a bet. Some are always reliable, others always unreliable, and still others seem to vary with the phases of the moon. We check http://www.resellerratings.com, which maintains a database of customer-reported experiences with hundreds of vendors.

  • The list price or Suggested Retail Price (SRP) is meaningless. Most computer products sell for a fraction of SRP, others sell for near SRP, and for still others the manufacturer has no SRP, but instead publishes an Estimated Selling Price (ESP). To do meaningful comparisons, you need to know what different vendors charge for the product. Fortunately, there are many services that list what various vendors charge. We use http://www.pricescan.com, http://www.pricewatch.com, http://www.pricegrabber.com, and http://www.froogle.com. These services may list 20 or more different vendors, and the prices for a particular item may vary dramatically. We discard the top 25% and the bottom 25% and average the middle 50% to decide a reasonable price for the item.

  • Many components are sold in retail-boxed and OEM forms. The core component is likely to be similar or identical in either case, but important details may vary. For example, Intel CPUs are available in retail-boxed versions that include a CPU cooler and a three-year warranty. They are also available as OEM components (also called tray packaging or white box) that do not include the CPU cooler and have only a 90-day warranty. OEM items are not intended for retail distribution, so some manufacturers provide no warranty to individual purchasers. OEM components are fine, as long as you understand the differences and do not attempt to compare prices between retail-boxed and OEM.

  • The market for PCs and components is incredibly competitive and margins are razor-thin. If a vendor advertises a component for much less than other vendors, it may be a "loss leader." More likely, though, particularly if its prices on other items are similarly low, that vendor cuts corners, whether by using your money to float inventory, by shipping returned product as new, by charging excessive shipping fees, or, in the ultimate case, by taking your money and not shipping the product. If you always buy from the vendor with the rock-bottom price, you'll waste a lot of time hassling with returns of defective, used, or discontinued items and dealing with your credit card company when the vendor fails to deliver at all. Ultimately, you're also likely to spend more money than you would have by buying from a reputable vendor in the first place.

  • The actual price you pay may vary significantly from the advertised price. When you compare prices, include all charges, particularly shipping charges. Reputable vendors tell you exactly how much the total charges will be. Less reputable vendors may forget to mention shipping charges, which may be very high. Some vendors break out the full manufacturer pack into individual items. For example, if a retail-boxed hard drive includes mounting hardware, some vendors will quote a price for the bare drive without making it clear that they have removed the mounting hardware and charge separately for it. Also be careful when buying products that include a rebate from the maker. Some vendors quote the net price after rebate without making it clear that they are doing so.

  • Some vendors charge more for an item ordered via their 800 number than they do for the same item ordered directly from their web site. Some others add a fixed processing fee to phone orders. These charges reflect the fact that taking orders on the web is much cheaper than doing it by phone, so this practice has become common. In fact, some of our favorite vendors do not provide telephone order lines.

  • It can be very expensive to ship heavy items such as CRTs, UPSs, and printers individually. This is one situation in which local big-box stores like Best Buy have an advantage over online vendors. The online vendor has to charge you for the cost of shipping, directly or indirectly, and that cost can amount to $50 or more for a heavy item that you need quickly. Conversely, the big-box stores receive inventory items in truckload or even railcar shipments, so the cost to them to have a single item delivered is quite small. They can pass that reduced cost on to buyers. If you're buying a heavy item, don't assume that it will be cheaper online. Check your local Best Buy or other big-box store and you may find that it actually costs less there, even after you pay sales tax. And you can carry it away with you instead of waiting for FedEx to show up with it.

  • Most direct resellers are willing to sell for less than the price they advertise. All you need do is tell your chosen vendor that you'd really rather buy from them, but not at the price they're quoting. Use lower prices you find with the price comparison services as a wedge to get a better price. But remember that reputable vendors must charge more than the fly-by-night operations if they are to make a profit and stay in business. If we're ordering by phone, we generally try to beat down our chosen vendor a bit on price, but we don't expect them to match the rock-bottom prices that turn up on web searches. Of course, if you're ordering from a web-only vendor, dickering is not an option, which is one reason why web-only vendors generally have better prices.

  • Using a credit card puts the credit card company on your side if there is a problem with your order. If the vendor ships the wrong product, defective product, or no product at all, you can invoke charge-back procedures to have the credit card company refund your money. Vendors who live and die on credit card orders cannot afford to annoy credit card companies, and so tend to resolve such problems quickly. Even your threat to request a charge-back may cause a recalcitrant vendor to see reason.

  • Some vendors add a surcharge, typically 3%, to their advertised prices if you pay by credit card. Surcharges violate credit card company contracts, so some vendors instead offer a similar discount for paying cash, which amounts to the same thing. Processing credit card transactions costs money, and we're sure that some such vendors are quite reputable, but our own experience with vendors that surcharge has not been good. We always suspect that their business practices result in a high percentage of charge-back requests, and so they discourage using credit cards.

  • Good vendors allow you to return a defective product for replacement or a full refund (often less shipping charges) within a stated period, typically 30 days. Buy only from such vendors. Nearly all vendors exclude some product categories, such as notebook computers, monitors, printers, and opened software, either because their contracts with the manufacturer require them to do so or because some buyers commonly abuse return periods for these items, treating them as "30-day free rentals." Beware of the phrase, "All sales are final." That means exactly what it says.

  • Check carefully for any mention of restocking fees. Many vendors who trumpet a "no questions asked money-back guarantee" mention only in the fine print that they won't refund all your money. They charge a restocking fee on returns, and we've seen fees as high as 30% of the purchase price. These vendors love returns, because they make a lot more money if you return the product than if you keep it. Do not buy from a vendor that charges restocking fees on exchanges (as opposed to refunds). For refunds, accept no restocking fee higher than 10% to 15%, depending on the price of the item.

  • If you order by phone, don't accept verbal promises. Insist that the reseller confirm your order in writing, including any special terms or conditions, before charging your credit card or shipping product. If a reseller balks at providing written confirmation of their policies, terms, and conditions, find another vendor. Most are happy to do so. If you're ordering from a vendor that uses web-based ordering exclusively, use a screen capture program or your browser's save function to grab copies of each screen as you complete the order. Most vendors send a confirming email, which we file in our "Never Delete" folder.

    A Cunning Plan

    Nearly all retailers refuse to refund your money on opened software, DVDs, etc., but will only exchange the open product for a new, sealed copy of the same title. One of our readers tells us how he gets around that common policy. He returns the open software in exchange for a new, sealed copy of the same product, keeping his original receipt. He then returns the new, sealed copy for a refund. That's probably unethical and may be illegal for all we know, but it does work. Recently, though, some stores including Best Buy and CompUSA have begin annotating the original receipt when you make an exchange. Oh, well. It was too good to last.

  • File everything related to an order, including a copy of the original advertisement; email, faxed, or written confirmations provided by the reseller; copies of your credit card receipt; a copy of the packing list and invoice; and so on. We also jot down notes in our PIM regarding telephone conversations, including the date, time, telephone number and extension, person spoken to, purpose of the call, and so on. We print a copy of those to add to the folder for that order.

  • Make it clear to the reseller that you expect them to ship the exact item you have ordered, not what they consider to be an "equivalent substitute." Require they confirm the exact items they will ship, including manufacturer part numbers. For example, if you order an eVGA GeForce 7900GT graphics card with 512 MB of RAM, make sure the order confirmation specifies that item by name, full description, and eVGA product number. Don't accept a less detailed description such as "graphics card," "eVGA graphics card," or even "eVGA 7900 graphics card." Otherwise, you'll get less than you paid fora lesser GeForce card, a card with a slower processor or less memory, or even a card with a GeForce processor made by another manufacturer. Count on it.

  • Verify warranty terms. Some manufacturers warrant only items purchased from authorized dealers in full retail packaging. For some items, the warranty begins when the manufacturer ships the product to the distributor, which may be long before you receive it. OEM products typically have much shorter warranties than retail-boxed productssometimes as short as 90 daysand may be warranted only to the original distributor rather than to the final buyer. Better resellers may endorse the manufacturer warranty for some period on some products, often 30 to 90 days. That means that if the product fails, you can return the item to the reseller, who will ship you a replacement and take care of dealing with the manufacturer. Some resellers disclaim the manufacturer warranty, claiming that once they ship the item dealing with warranty claims is your problem, even if the product arrives DOA. We've encountered that problem a couple of times. Usually, mentioning phrases like merchantability and fitness for a particular purpose and revocation of acceptance leads them to see reason quickly. We usually demand the reseller ship us a new replacement product immediately and include a prepaid return shipping label if they want the dead item back. We don't accept or pay for dead merchandise under any circumstances, and neither should you.

  • Direct resellers are required by law to ship products within the time period they promise. But that time period may be precise (e.g., "ships within 24 hours") or vague (e.g., "ships within three to six weeks"). If the vendor cannot ship by the originally promised date, it must notify you in writing and specify another date by which the item will ship. If that occurs, you have the right to cancel your order without penalty. Make sure to make clear to the reseller that you expect the item to be delivered in a timely manner. Reputable vendors ship what they say they're going to ship when they say they're going to ship it. Unfortunately, some vendors have a nasty habit of taking your money and shipping whenever they get around to it. In a practice that borders on fraud, some vendors routinely report items as "in stock" when in fact they are not. Make it clear to the vendor that you do not authorize them to charge your credit card until the item actually ships, and that if you do not receive the item when promised you will cancel the order.

    Another Cunning Plan

    If you buy from a local retailer, open the box from the bottom rather than the top. If you need to return a non-defective item, that makes it easier to repackage the product with the manufacturer's seals intact, which keeps the retailer happy and can help you avoid restocking fees.

Even if you follow all of these guidelines, things may go wrong. Even the best resellers sometimes drop the ball. If that happens, don't expect the problem to go away by itself. If you encounter a problem, remain calm and notify the reseller first. Good resellers are anxious to resolve problems. Find out how the reseller wants to proceed, and follow their procedures, particularly for labeling returned merchandise with an RMA number.

If you seem to have reached a dead end with the vendor, explain one last time to the vendor why you are dissatisfied, and ask them to resolve the problem. Tell them that unless they resolve the matter you will request a charge-back from your credit card company. Mail-order and Internet vendors live and die on credit card revenue, so keeping a good relationship with the credit card companies is critically important to them. Finally, but only as a last resort, contact your bank or credit card issuer and request a charge-back. Be prepared to provide a full explanation of the problem with documentation.

2.2.2. Recommended Sources

The question we hear more often than any other is, "What company should I buy from?" When someone asks us that question, we run away, screaming in terror. Well, not really, but we'd like to. Answering that question is a no-win proposition for us, you see. If we recommend a vendor and that vendor treats the buyer properly, well that's no more than was expected. But Thor forbid that we recommend a vendor who turns around and screws the buyer.

Loot, Pillage, and Burn

Thor? Yes, it's true. Robert the Red is of Viking extraction. On government forms, he describes himself as "Viking-American." And, no, he doesn't wear a funny helmet. Except among friends. And he hasn't pillaged anything in months. Years, maybe. In fact, he's not absolutely certain what pillaging is, although it does sound like fun.

So, which online resellers do we buy from? Over the years, we've bought from scores of online vendors, and our favorites have changed. For the last few years, our favorite has been NewEgg.com (http://www.newegg.com). NewEgg offers an extraordinarily good combination of price, wide product selection, support, shipping, and return or replacement policies. We know of no other direct vendor that even comes close.

NewEgg's prices aren't always rock-bottom, but they generally match any other vendor we're willing to deal with. NewEgg runs daily specials that are often real bargains, so if you're willing to consider alternatives and to accumulate components over the course of a few weeks you can save a fair amount of money. NewEgg ships what they say they're going to ship, when they say they're going to ship it, and at the price they agreed to ship it for. If there's a problem, they make it right. It's hard to do better than that.

Warning: All of that said, if you buy from NewEgg and subsequently your goldfish dies and all of your teeth fall out, don't blame us. All we can say is that NewEgg has always treated us right. Things can change overnight in this industry and, while we don't expect NewEgg to take a sudden turn for the worse, it could happen.

As to local retailers, we buy fromin no particular orderBest Buy, CompUSA, Target, Office Depot, OfficeMax, and our local computer specialty stores, depending on what we need and who happens to have advertised the best prices and rebates in the Sunday ad supplements. Wal-Mart used to sell only assembled PCs. It has recently started stocking PC components, such as ATi video adapters, so we'll add Wal-Mart to our list as well.


Section 2.3. Final Words

2.3. Final Words

We've done our best in this chapter to tell you what components to buy for your new PC and where and how to buy them. The specific components you need differ according to the type of system you plan to build. We describe how to make component-specific decisions in the "project system" chapters later in the book. So, before you actually start ordering components, you might want to read some (or all) of those chapters.

When the components arrive, restrain yourself. Don't start building your system before the FedEx truck even pulls out of your driveway, particularly if this is your first system build. Read or reread the relevant project chapter.

One thing you should do immediately, though, is check the contents of the boxes that were just delivered. Verify what you ordered against the packing list and invoice, and verify what's actually in the box against those documents. Usually everything will be right, but if you have components coming from different sources, you don't want to wait a week or two before you find out that an early shipment was wrong or incomplete.

Take it a step further. Once you've verified that everything is correct with the order, start opening the individual component boxes. Look for a packing list in the front of the manual, and make sure that you actually received everything that was supposed to be in the box. It's not uncommon for small partsmounting hardware, cables, driver CDs, and so onto be missing. If that happens, call the vendor immediately and tell them what's missing from your order.

At this point, you should have everything you need to start building your new PC. It's kind of like being a kid again, on Christmas morning.


Chapter 3. Building a Mainstream PC

A mainstream PC is one that seeks balance at a reasonable price point. A mainstream PC uses top quality (but midrange performance) components throughout, because that is where you find the best value for your dollar. What differentiates a mainstream PC from a budget PC is that the former makes fewer compromises. Whereas price is always a very high priority for a budget PC, it is less important for a mainstream PC. If spending more money yields better performance or reliability, or adds desirable features, a mainstream PC gets those extra dollars, whereas a budget PC probably doesna't.

Relative to the budget PC, that means the mainstream PC gets more expensive components, particularly where they pay off in additional performance, convenience, or data safety; more memory; a fast dual-core processor; redundant disk storage; better peripherals; and additional features. Considered individually, the incremental cost of better components is typically quite small. But taken collectively, the difference adds up fast. Depending on which components you choose, a mainstream system may cost 50% to 100% more than a budget system. That extra money buys you higher performance now and down the road, and extends the period between upgrades. If a budget PC will meet your needs for 12 to 18 months without upgrades, a mainstream PC may suffice for 24 to 36 months or longer, depending on the demands you put on it.

In this chapter, we'll design and build the perfect mainstream PC.


Section 3.1. Determining Functional Requirements

3.1. Determining Functional Requirements

A Sheep in Wolf's Clothing

Many consumer-grade systems, particularly those sold in office superstores and big-box stores and by some large OEMs, masquerade as mainstream PCs but are really budget PCs with a few extra bells and whistles. These PCs have faster CPUs and more memorycomponents whose specifications are easily visiblebut use the same low-end motherboards, marginal power supplies, and inferior optical drives found in their less expensive budget lines. True mainstream PCs, at least as we define them, are a vanishing breed. Marketers believe that spending $5 more on a better power supply or $10 more on a better motherboard will only boost the price of their systems, making them uncompetitive with other brands, without increasing sales or profit. From their point of view, consumers are too ignorant to appreciate the difference between cheap components and good components that cost only slightly more. The best way to prove them wrong is to build your own mainstream PC from top-notch components.

We sat down to think through our own requirements for a mainstream PC. Here's the list of functional requirements we came up with:

Reliability

First and foremost, the mainstream PC must be reliable. We expect it to run all day, every day, for years without complaint. The key to reliability is choosing top-quality components, particularly the motherboard, memory, hard drive, and power supply. Those components don't need to be the largest or fastest available, but they do need to be of high quality.

Balanced performance

A mainstream PC is a jack of all trades and master of none. We expect it to perform any task we might give it, at least competently if not better. But, because this is not a cost-no-object system, we need to balance component performance against price. For example, we expect this system to be capable of serious number crunching, but the fastest processors cost more than we can justify for this system. Accordingly, we aimed for a balanced design that allows the system to do most things very well and everything else at least acceptably well.

Data safety

Although most of our data resides on our network server, which is backed up six ways to Sunday, a hard drive failure in our mainstream system could still wipe out local configuration files and cost us hours to rebuild and reconfigure the system. We decided that the small incremental cost of RAID (Redundant Array of Inexpensive Disks) was justified to protect against a hard drive failure.

Video capture

Although we built a full-feature dual-tuner media center system as another of the projects for this book, there are times when that system may be fully occupied, recording one program while we watch another. For those rare occasions when we need to record yet another program at the same time, we decided it made sense to add basic PVR capabilities to this system. The cost to do so is less than the cost of a standalone DVD recorder, and a PC-based solution provides much more flexibility.

Noise level

Most mainstream PCs are used in environments where noise is an issue. Accordingly, we designed this system for quiet operation, but we didn't spend much extra money to do so. That means, for example, that we chose the hard drive, case, and power supply based on noise level, but we did not spend $50 extra to replace the stock CPU cooling fan with a silent unit or $100 extra for a fanless power supply. Our goal is a quiet PC, not a silent PC (if there can truly be such a thing).


Section 3.2. Hardware Design Criteria

3.2. Hardware Design Criteria

With the functional requirements determined, the next step was to establish design criteria for the mainstream PC hardware. Here are the relative priorities we assigned for our mainstream PC. Your priorities may of course differ.

DESIGN PRIORITIES

Price

Reliability

Size

Noise level

Expandability

Processor performance

Video performance

Disk capacity/performance

Silence Is Golden

This system is destined to be Robert's secondary office desktop system. His office is already home to four other systems, so it's important that this system contribute as little additional noise as possible.

As you can see, this is a well-balanced system. Other than reliability, which is of primary importance, all of the other criteria are of similar priority. Here's the breakdown:

Price

Price is moderately important for this system, but value is more so. We won't attempt to match the low price of commercial systems built with low-end components, but we won't waste money, either. If spending a bit more noticeably improves performance, reliability, or usability, or if it adds features we want, we won't begrudge the extra cost.

Reliability

Reliability is the single most important criterion. A mainstream PC that is not built for reliability is not worth building.

Size

Size is somewhat important in the sense that it must fit in an already crowded office, so we don't want the system to be any larger than it needs to be to do its job. So, although we will not compromise other criteria in exchange for smaller size, we will choose the smallest case that meets other system requirements.

Noise level

Noise level is at least moderately important for nearly any mainstream PC. Our goal is to build a reasonably quiet PC at little or no incremental cost rather than to build a very quiet PC using expensive special components. Accordingly, when we choose components we'll keep noise level in mind, but we won't pay much extra for a marginally quieter component.

Expandability

Expandability is relatively unimportant for a mainstream PC. Fewer than 5% of commercial mainstream PCs are ever upgraded, and those upgrades are usually of a minor nature such as adding memory or replacing a video card or hard drive. Self-built mainstream PCs are more likely to be upgraded, but even then the upgrades are unlikely to require more than perhaps a spare drive bay or two, an expansion slot, or a couple of available memory sockets. We'll choose a case, power supply, and motherboard that are adequate to support such minor upgrades.

Processor performance

Processor performance is moderately important for a mainstream PC, both initially and to ensure that the system can run new software versions without requiring a processor upgrade. Midrange mainstream single- and dual-core processors are the "sweet spot" in price/performance ratio. At a given price point, a single-core processor is slightly faster than a dual-core model for people who single-task (do pretty much one thing at a time). A dual-core processor comes into its own on systems like ours that tend to have many windows open simultaneously and many tasks in progress. With a dual-core system, one core is always devoted to the foreground task, so the system doesn't "bog down" under load.

Although economy single-core processors like the Intel Celeron and AMD Sempron may suffice initially, spending a bit more on a mainstream processor buys you more horsepower and a larger cache, both of which increase the time during which the processor will provide subjectively adequate performance. The slow and midrange variants of the Intel Pentium D processors are the most cost-effective dual-core processors available. They are aggressively priced and fast enough that you probably won't need to upgrade the processor anytime soon.

Video performance

3D video performance is critical for a mainstream PC only if you use it to run 3D games or Microsoft Vista. Otherwise, integrated video suffices. In fact, current-generation integrated video such as Intel GMA 950 and nVIDIA 6150 is good enough for casual gaming, the Vista Aero interface, and will even support Vista's Aero Glass user interface effects (at the expense of using more shared memory than usual).

2D video quality is important for any mainstream PC, because it determines display clarity and sharpness for browsers, office suites, and similar 2D applications. Intel integrated video provides excellent 2D quality and reasonably good 3D performance. To future-proof the system, we'll choose a motherboard that provides a PCI Express x16 video card slot. That way, we can always add an inexpensive or midrange video adapter if we need better 3D performance or other features not supported by the integrated video.

Disk capacity/performance

Disk capacity is unimportant for this particular mainstream system, because it connects to a network that has more than 3,000 GB of available storage. For a standalone mainstream system, or one that connects to a network with insufficient shared storage, disk capacity may be a key consideration. Fortunately, with hard drives currently available in capacities ranging from 80 GB to 750 GB, it's easy enough to accommodate nearly any storage requirements simply by installing one or more hard drives of whatever capacity are needed.

Disk performance is unimportant for most mainstream systems in the sense that any standard 7,200 RPM ATA or Serial ATA hard drive is fast enough to avoid noticeable storage bottlenecks for most applications. For those few systems that do require higher performance disk subsystems, a variety of solutions are available, including 10,000 RPM ATA/SATA drives, RAID 0, or, when cost is no object, 15,000 RPM SCSI drives. But standard 7,200 RPM ATA/SATA hard drives are fine for most systems, including this one.

For this system, we're less concerned with disk capacity and performance, and more concerned with reliability. Modern ATA/SATA hard drives are extremely reliable, particularly Seagate models, but any hard drive is destined to fail eventually, usually at the worst possible time. When we designed this system, we had just suffered a hard drive crash in one of our secondary desktop systems and spent hours rebuilding and reconfiguring the system, so we had hard drive reliability firmly in mind.

In years past, there was no practical, inexpensive way to insure against a hard drive failure. But nowadays, RAID is easy and inexpensive to implement. Most midrange and higher motherboards provide integrated RAID support, so the only incremental cost is the cost of a second hard drive.

ADVICE FROM RON MORSE

RAID does not insure against hard drive failure. It mitigates/limits data loss resulting from a hard drive failure. In fact, the added drive to support RAID slightly increases the probability you will experience a hard drive failure.

<soapbox> And I still contend it is a very narrow attempt to deal with a much broader problem. The idea is to prevent inadvertent data loss. The vast majority of reasons people lose data have nothing to do with drive failure. On the other hand, RAID does complicate installation and maintenance so you do get something for your money.

RAID on servers is great. Ought to be mandatory, even. But on a desktop? It promises a false sense of security while dealing directly with only the most unlikely source of data loss. It would be better to hammer home the backup message. </soapbox>


Section 3.3. Component Considerations

3.3. Component Considerations

With our design criteria in mind, we set out to choose the best components for the mainstream PC system. The following sections describe the components we chose, and why we chose them.

Warning: Although we tested the configuration we used to build our own mainstream PC, we did not test permutations with the listed alternatives. Those alternatives are simply the components we would have chosen had our requirements been different. That said, we know of no reason the alternatives we list should not work perfectly.

3.3.1. Case and Power Supply

Antec BK640B microBTX Case (http://www.antec.com)

Intel introduced the ATX form factor more than a decade ago, with the smaller Mini-ATX and microATX form factors introduced soon thereafter. Although Mini-ATX never caught on, ATX and microATX became immensely popular. Most commercial systems and nearly all home-built systems use ATX or microATX cases and motherboards to this day.

But ATX was designed at a time when a typical processor or video adapter consumed only a few watts and used a passive heatsink. As the power consumption of processors and video adapters continued to grow by leaps and boundsreaching as much as 130W or morethe limitations of ATX became obvious. Getting rid of the heat became a major problem, despite such workarounds as the Intel TAC (Thermally Advantaged Chassis) initiative, which was a fancy name for a simple air duct between the processor and the side panel of the case. In addition to the CPU fan and power supply fan, ATX systems are usually equipped with at least one case fan to aid cooling. All of these fans inevitably add to the noise level of the system.

Intel addressed the problem by introducing a new form factor called BTX (Balanced Technology eXtended). BTX cases feature a redesigned component layout, greatly improved air flow, and other measures designed to optimize cooling while minimizing the number, size, and speed of cooling fans needed.

Despite the demonstrable superiority of BTX, manufacturers of motherboards and other components ignored BTX in droves. Intel had originally forecast that 40% of new systems would use BTX by the end of 2004. That turned out to be wildly optimistic, to put it kindly. With very few exceptions, system and component makers ignored BTX entirely, ridiculing BTX as a jerry-built fix for the notoriously high power consumption of Prescott-core Pentium 4 processors. ExtremeTech listed BTX in its Ten Failed Tech Trends for 2005 article. They weren't alone. By the end of 2005, most industry pundits had written off BTX as a dead technology.

Dead Again

As we mentioned in the previous chapter, just as the BTX zombie was staggering to its feet, Intel drove a stake through its heart, announcing that it would discontinue BTX components in 2007. Oh, well. That just means BTX components will be available at firesale prices. The case, motherboard, and CPU cooler are the only BTX-specific components in a BTX system, so we wouldn't hesitate to build this mainstream BTX system even in the face of BTX being discontinued.

Which Power Supply Fits Which Case?

There is no such thing as a BTX power supply. ATX-family cases and BTX-family cases both accept ATX-family power supplies. There are five ATX power supply form factors. Standard-size ATX and BTX cases use full-size ATX12V power supplies, and may also use the small form factor SFX12V power supplies. Nearly all home-built systems use an ATX12V power supply, although a few use SFX12V.

But then something odd happened. Beginning in early 2006, BTX rose from the dead. Major OEMs, including Dell, HP, and Gateway, introduced new BTX models. Online vendors like NewEgg began offering BTX components, albeit in limited variety.

Ironically, this revival began just as Intel began shipping the Core Solo and Core Duo processors, which consume much less power than earlier models and produce much less heat. If anything, these new, cooler-running processors should have been the final nail in the coffin of BTX. Instead, system makers apparently finally realized that if BTX could cool even hot processors with minimal noise, it could cool the newer low-current processors at extremely low noise levels.

ExtremeTech reversed its opinion, saying in an April 2006 article, "If you're building an Intel system, it's worth considering moving to the BTX form factor." We agree. It's nice to see ExtremeTech belatedly endorse our conclusion.

Although BTX appears to be gaining traction, its long-term viability is not yet assured. BTX cases and motherboards are now widely available, although the selection is quite limited. Despite these facts, we decided that the advantages of BTX were worth pursuing, so we decided to build our mainstream system around a BTX case and motherboard.

We began by evaluating the BTX cases available at the time we built this system. We considered BTX cases from various manufacturers, including Antec, Casetek, CoolerMaster, InWin, Thermaltake, and others. We had several checklist items, the most important of which were:

  • Mini-tower or micro-tower form factor

  • Two or more optical drive bays

  • Two or more hard drive bays

  • Front-panel audio, USB, and FireWire ports

  • Provision for a standard ATX12V v2.0 power supply

The three remaining ATX form factors are all small. TFX12V is a "thin" form factor, used in some small commercial systems. LFX12V is a "low-profile" form factor, also used in some small commercial systems. CFX12V is a "compact" form factor, and is used in the smallest commercial systems. For more details about power supply form factors, visit http://www.formfactors.org.

Most of the cases we considered were too small, had too few drive bays, were too expensive, or otherwise failed to meet one or more of our requirements. The Antec BK640B, shown in Figure 3-1, met all of our requirements.

Figure 3-1. Antec BK640B microBTX case (image courtesy of Antec, Inc.)

The Antec BK640B belongs to Antec's mainstream line. It lacks some of the costly features included in premium Antec cases, but, like all Antec cases we have used, the BK640B is solidly built, has no sharp edges, and has excellent fit and finish. It is also an attractive case, and sells for only $75 or so, including a solid ATX12V v2.0 380W power supply. Finally, the Antec BK640B is an extremely quiet case.

3.3.2. Motherboard

Intel D945GCZLR (http://www.intel.com)

Intel motherboards set the standards by which we judge all other motherboards for construction quality, stability, and reliability. We chose the rock-solid Intel D945GCZLR, shown in Figure 3-2, which supports a socket 775 Intel Pentium 4, Pentium D, or Celeron D processor. Note the markedly different layout of a BTX motherboard, with the processor set at an angle near the front edge of the motherboard, the memory slots at the far left side, and the positions of the expansion slots and rear I/O panel reversed relative to ATX.

Figure 3-2. Intel D945GCZ motherboard (image courtesy of Intel Corporation)

945 OR 946?

We built this system in Summer 2006. The Intel Core 2 Duo processor and motherboards that support it were not yet widely available. In anticipation of their new processors and motherboards, Intel deeply discounted their older products, pricing them too attractively for us to refuse. If we were building this system now, we'd probably use an Intel Core 2 Duo and an Intel 946- or 965-series motherboard.

ALTERNATIVES: CASE & POWER SUPPLY

For a BTX system, none we'd choose. For an ATX or microATX mainstream system, the Antec New Solution Series NSK3300 micro-tower, NSK4400 mini-tower, or NSK6500 mid-tower. If you're willing to spend a bit more, the premium Antec P150 and P180 cases are superb choices.

The Intel D945GCZLR provides integrated Intel GMA 950 video, which suffices for anyone other than serious gamers, and excellent integrated high-definition audio. The D945GCZLR has four DIMM slotswhich makes future memory upgrades easyand supports up to 4 GB of DDR2-400, -533, or -667 memory. It also provides a plethora of interfaces and ports, including two PCI slots, a PCI Express x16 video card slot, a PCI Express x1 general-purpose expansion slot, one dual parallel ATA-100 interface, four Serial ATA interfaces with RAID support, an FDD interface, PS/2 mouse and keyboard ports, serial and parallel ports for compatibility with legacy peripherals, a 10/100-BaseT Ethernet port, three FireWire ports, eight USB 2.0 ports, a digital optical out (S/PDIF) port, and a partridge in a pear tree.

MAKE SURE YOU KNOW WHAT YOU'RE GETTING

If you buy a D945GCZ, make sure you know exactly what you're getting. Like most Intel motherboards, the D945GCZ is available in several variants that have different feature sets. Some models, for example, include 7.1 audio, while others have 5.1 audio. Some models include RAID support, and others do not. One model does not include FireWire ports, and only the D945GCZLR model we chose provides the S/PDIF connector. For available configurations, see http://developer.intel.com/design/motherbd/cz/cz_available.htm.

ALTERNATIVES: MOTHERBOARD

For an Intel BTX system, you can use any Intel BTX motherboard that fits the case you choose. Very few BTX motherboards are made for AMD processors, and those motherboards are not generally available in retail channels, at least in the U.S. For an Intel ATX system, choose any Intel motherboard that offers the features you want and fits the case you choose, or any similar ASUS motherboard that uses an Intel chipset. For an AMD ATX system, choose an ASUS motherboard with an nVIDIA nForce-series chipset.

3.3.3. Processor

Intel Pentium D 940 (http://www.intel.com)

A mainstream PC deserves a dual-core processor. Although a fast single-core processor can hold its own against a dual-core processor on a lightly loaded system, a dual-core processor really shines on a more heavily loaded system. As you add more background tasks and open more windows on a single-core system, the processor bogs down. With a dual-core processor, one core is always allocated to the foreground task, so the system appears just as responsive when it is heavily loaded as when it is running only one or two tasks.

At the time we built this system, we had three dual-core technologies to choose from. We considered using the Intel Core Duo, which is essentially a desktop version of the Intel mobile processor, and was chosen by Apple as the basis of their Intel-based Mac systems. We rejected Core Duo for two reasons. First, although Core Duo processors were reasonably fast, they were also quite expensive compared to other dual-core processors with similar performance. Second, the selection of motherboards available for Core Duo was very limited, both in terms of the number of models available and the features supported by those motherboards. Core Duo was obviously an interim processor, introduced by Intel as a stopgap until they could ramp up production of their Conroe Core 2 desktop CPUs in late 2006 and into 2007.

That left us with the AMD Athlon 64 X2 and the Intel Pentium D, both of which are excellent dual-core processors. The Athlon 64 X2 features an elegant design, low power consumption, and superior gaming performance. The Pentium D draws more power and is less suitable for gaming, but offers top-notch multimedia performance. Dollar-for-dollar, the Athlon 64 X2 and Pentium D are pretty evenly matched in performance at the high end. But at the time we built this system, the least expensive Athlon 64 X2 sold for about $300, a $75 premium over an Intel Pentium D model with similar overall performance. We chose to use the Intel Pentium D, shown in Figure 3-3, which in turn allowed us to build the BTX system we really wanted to build.

Figure 3-3. Intel Pentium D (image courtesy of Intel Corporation)

MORE POWER

If you wonder why we chose an Intel Pentium D processor despite its notoriously high power consumption, it's because power consumption differences are much less important than most people believe.

The processor in most systems spends nearly all of its time at idle (even when the system is being used). At idle, the Pentium D 940 consumes only about 20W more than a comparable AMD Athlon X2 processor, or about 480 watt-hours per day for a system that runs 24x7. We pay about $0.10 per KW-hour for electricity, which means that using the Pentium D instead of the Athlon 64 X2 boosts our power bill by about 4.8 cents a day, or less than $20 per year.

Or it would, if both systems were always running at idle. But what about when they're running under load? Running at 100% CPU utilization, the Pentium D draws as much as 60W more than the Athlon 64 X2, so if both systems ran constantly at 100% load, the Pentium D system might cause our power bill to skyrocket... by nearly 15 cents a day. But of course most systems average more like 3% to 5% CPU utilization over the course of day, which brings the incremental cost of power back down to very close to five cents a day.

That small difference is dwarfed by other factors, including the relative prices of the processors and motherboards and particularly the relative strengths and weaknesses of the two processors. So, while the AMD Athlon 64 X2 is a superb processor and there are many good reasons to choose it, its lower power consumption probably shouldn't be a major factor in your decision.

ALTERNATIVES: PROCESSOR

An ATX AMD Athlon 64 X2 system offers equal or better performance, albeit at a somewhat higher price. By late 2006 and into 2007, Intel Conroe processors will become an increasingly attractive solution, as more full-feature motherboards become available and prices fall.

3.3.4. CPU Cooler

Intel Pentium D 940 retail-box cooler

Ordinarily, the bundled CPU cooler supplied with a retail-boxed processor is quite a bargain. Bundled coolers are not as effective or as quiet as the best aftermarket CPU coolers, but they ordinarily add only $10 or $15 to the cost of the processor. At the time we built this system, that was not true of the bundled Pentium D BTX cooler, shown in Figure 3-4. (Two AA batteries are shown for scale.) Although the retail-boxed ATX version of the processor cost only a few dollars more than the bare OEM processor, the version with a BTX cooler sold for $30 to $40 more. (In addition to the bundled cooler, the retail-boxed version includes a much longer warranty on the processor.)

Figure 3-4. Intel Pentium D retail box cooler, with square white thermal pad visible on base

Intel supplied us with a retail-boxed BTX processor for this project, so we used the bundled CPU cooler. If we had bought the processor ourselves, we would probably have used an OEM processor with an aftermarket cooler.

It's quite possible, though, that by the time you read this retail-boxed BTX processors will have achieved price parity with ATX models. Compare prices on a retail-boxed BTX processor versus the same processor in OEM form with a third-party cooler before you decide what to buy.

ALTERNATIVES: CPU COOLER

Any good third-party Type I BTX Thermal Module. Our first choice would be the Thermaltake CL-P0030 or the CoolerMaster CB5-NPFSA-02-GP.

BTX COOLER TYPES

There are two types of BTX coolers, which Intel imaginatively designates Type I and Type II. Our CPU uses a Type I cooler. Type II coolers are physically smaller, use smaller fans, are designed to be used in compact cases, and are less efficient and somewhat louder than Type I coolers. Both types of BTX cooler fit the same mounting holes, occupy the same motherboard real estate around the processor, and are otherwise interchangeable. The retail-boxed Intel Type I cooler supplied with our processor compares favorably in cooling efficiency and noise level with aftermarket coolers in the $25 to $30 range.

3.3.5. Memory

Kingston 2GB PC2-5300 DDR2 memory kit (1 GB x 2) (http://www.kingston.com)

Memory costs little enough that it is senseless to hamper a system by installing insufficient memory. We consider 1 GB appropriate for most single-core mainstream systems, although you may want more if you run Photoshop or other memory-intensive applications on your system. But using a dual-core processor is, for all intents and purposes, the same as using two processors. That means a dual-core system really needs twice as much memory as a single-core system, so we elected to install 2 GB of memory in our mainstream system.

ALTERNATIVES: MEMORY

Any compatible name-brand memory modules. Memory from different companies can vary dramatically in quality and reliability. For 20 years, we've depended on memory from Kingston and Crucial, and have never had cause to regret that decision. Whatever you do, avoid house-brand memory or any memory that's offered at a "bargain" price.

The Intel D945GCZLR motherboard has four DIMM slots and a dual-channel memory controller that provides faster memory performance when DIMMs are installed in pairs. Installing a pair of 1 GB DIMMs, for a total of 2 GB, leaves two DIMM slots available for future expansion. If you need more memory later on, you can fill that second pair of DIMM slots with 1 GB modules, taking the system to 4 GB of total memory. That should suffice for the expected lifetime of the system.

The Intel D945GCZLR supports DDR2-400 (PC2-3200), DDR2-533 (PC2-4200), and DDR2-667 (PC2-5300) memory. Although PC2-3200 modules would have been fast enough for our processor, we elected to install the faster PC2-5300 modules. The cost difference was small, and using the faster memory means we can later upgrade to a processor that uses a faster front-side bus without replacing the memory.

3.3.6. Video Adapter

Integrated Intel Graphics Media Accelerator (GMA) 950

A mainstream PC needs excellent 2D video quality and, if it is to be used for casual gaming or running Windows Vista, support for DirectX 9 and reasonable 3D graphics performance. Intel GMA 950 video easily meets the first requirement, and even suffices for casual gaming and running Vista's Aero Glass effects, depending on your expectations.

We had no intention of running Vista on this systemalthough we did install Vista to test compatibilitynor did we plan to use this system for anything more than casual gaming. Accordingly, we chose a motherboard that included integrated graphics, but with an available PCIe x16 slot in case we later decide to upgrade the graphics.

ALTERNATIVES: VIDEO ADAPTER

We recommend using integrated video unless you require faster video performance or additional features. If you need better 3D graphics performance, install an appropriate nVIDIA or ATI PCI Express video adapter in the x16 video slot on the Intel D945GCZ motherboard. The Intel motherboard provides only a single standard 15-pin VGA analog video connector. If you need a DVI video connector for an LCD display or support for dual displays, install a PCI Express video card with a DVI connector. If you need only one DVI connector, even a $25 video adapter suffices. If you need a dual-head card, shop carefully. The least expensive dual-DVI adapters sell for more than $100. A few can use two standard DVI cables, but some require a special dual-DVI cable, which is often "optional" and may add $100 or more to the price of the card.

3.3.7. Video Capture Adapter

Hauppauge WinTV-PVR-150 (http://www.hauppauge.com)

Although this system is not a full-blown media-center PC, we wanted it to have video capture capability, if only to serve as a backup to our primary media-center system when it was busy doing something else. We needed only a single-tuner analog capture card, so we chose the inexpensive and reliable Hauppauge WinTV-PVR-150 card. The PVR-150 provides hardware-accelerated MPEG compression, so the system can be used for other tasks while it is recording a TV program without any degradation of either task.

The WinTV-Scheduler and WinTV-Editor utilities included with the card more than suffice for casual TV recording and editing. If you prefer to use a more featureful PVR application, the PVR-150 is supported by nearly every Windows and Linux PVR application available.

ALTERNATIVES: VIDEO CAPTURE ADAPTER

Not many, really. Hauppauge video capture cards are the gold standard in terms of image capture quality and compatibility with capture applications. ATI All-In-Wonder and TV Wonder cards provide video capture functions, but their software compatibility is much more limited and some of our readers have reported them to be less reliable than Hauppauge video capture cards. The Hauppauge WinTV-PVR-150 is inexpensive and extremely reliable. If you want your mainstream system to support basic video capture functions, use the Hauppauge WinTV-PVR-150 unless you have good reason to choose something else.

ADVICE FROM RON MORSE

Consider the Hauppauge Win-PVR-USB2 model. Slightly more expensive, comparable feature set. External means another box on the desk, but connections are extremely easy to make. Can be moved to another computer/location (say, your laptop) with ease. Works well. Needs USB 2.0 high speed port.

3.3.8. Sound Adapter

Integrated Intel High Definition Audio

The integrated Intel High Definition Audio is more than sufficient for anything other than serious gaming. The Intel D945GCZ model we used supports 7.1 audio, but other models support only 5.1 audio. We recommend using the integrated audio unless you require additional channels or you play games that benefit from hardware-accelerated audio.

ADVICE FROM RON MORSE

I would not recommend the Creative Labs Audigy X-Fi series at this time. They have serious driver issues, which CL has been reluctant to address... starting with a "Problem? What problem?" attitude and then going downhill from there. I understand there has been some progress, but there is still a long way to go. The Audigy 2ZS is a very solid card with mature, reliable drivers.

ALTERNATIVES: SOUND ADAPTER

If your motherboard model provides only 5.1 audio and you need 7.1 audio, or if you need a hardware-accelerated sound card, install a standalone M-Audio or Creative Labs sound adapter. The M-Audio Revolution 7.1 has superb sound quality and good gaming support. The Creative Labs Audigy2 ZS and X-Fi sound cards have good sound quality and superb gaming support. If sound quality is your top priority, install the Revolution 7.1. If hardware-accelerated gaming support is your top priority, install an Audigy2 ZS or one of the X-Fi cards, depending on your budget.

3.3.9. Network Adapter

Integrated Intel Ethernet adapter

Intel D945GCZ motherboards provide an embedded 10/100 or 10/100/1000BaseT network adapter, which you should use unless you have good reason for installing a standalone network adapter.

3.3.10. Hard Disk Drive

Seagate Barracuda 7200.9 SATA (two) (http://www.seagate.com)

A mainstream PC needs a mainstream hard drive, and you can't get much more mainstream than a Seagate Barracuda 7200.9 SATA drive. The Barracuda 7200.9 is inexpensive, fast, very quiet, and extremely reliable. It is available in capacities from 80 GB to 500 GB. We chose the 80 GB model because this system connects to our home network, which has more than 3,000 GB of network storage. There was no point to spending any more than necessary for local storage. If you need more local disk space, choose one of the larger models.

ALTERNATIVES: NETWORK ADAPTER

If your motherboard model provides only 10/100BaseT and you require 1000BaseT, install a D-Link DGE-560T PCI-Express Gigabit Network Adapter. PCI gigabit adapters are a poor choice, because under load they use enough bandwidth to swamp the PCI bus. A PCI Express gigabit adapter uses a PCI Express x1 slot with its own dedicated bandwidth, which isolates the network traffic from the PCI bus.

We decided our mainstream system deserved two hard drives, not to increase storage capacity but to reduce the risk of losing data to a hard drive failure. Seagate hard drives are extremely reliable, but as mechanical devices they are destined to fail, sooner or later. The best way to protect your data against a hard drive failure is to run two hard drives in a RAID 1. With RAID 1, all data is written to both hard drives. If one drive fails, data can be accessed from the second drive until you replace the failed drive and rebuild the RAID. The motherboard we chose includes built-in RAID 1 support, so the only additional cost for this protection is the $51 we paid for the second hard drive. That's cheap insurance by any reckoning.

RAID IS NOT BACKUP

RAID 1 protects against a hard drive failure, but it is not a substitute for backing up. There are any number of things that cause data loss, from viruses to accidental deletions to fires and other catastrophes. RAID protects against none of these. To protect your data properly, you must make backup copies on removable media such as tapes or optical discs.

3.3.11. Optical Drive

BenQ DW1650 DVD writer (http://www.benq.us)

DVD writers are now available for as little as $30, so it's pointless to choose a less capable optical drive. Although DVD writer manufacturers continue to make minor tweaks to their product lines, the technology is essentially mature. Nearly every model has similar features and writes the various types of discs at the same or similar speeds. More expensive models generally have larger buffers and provide a few bells and whistles that are of little practical importance. What counts is the durability of the drive and the quality of the discs it writes, and many current models, even some inexpensive ones, do well in both respects.

ALTERNATIVES: HARD DISK DRIVES

We use only Seagate hard drives in our systems, and recommend our readers do the same.

In the past, we used and recommended Plextor optical drives exclusively. Plextor still makes the best drives available, but the gap has narrowed. It's not that Plextor drives have declined in quality, but that inexpensive drives are now much better than they used to be.

The BenQ DW1650 is among the best of the inexpensive drives, so we decided to use one for our mainstream system.

ALTERNATIVES: OPTICAL DRIVE

We were torn among the BenQ DW1650, DW1655, and DQ60, along with several competing models from Lite-On. All are excellent drives with similar features, and we consider them essentially interchangeable. We also considered the otherwise-excellent NEC ND-3550A, but were forced to choose another drive because of the compatibility problem we experienced with the ND-3550A, described at the end of this chapter. If you use a different motherboard, the ND-3550A is an excellent alternative.

If you need a drive that also writes DVD-RAM discs, choose the BenQ DQ60 or the Lite-On SHM-165P6S. If you need a drive with LightScribe support, choose the BenQ DW1655. If you want the best, most durable optical drive available, choose one of the Plextor premium series drives.

TORTURE-TESTING DRIVES

Periodically, we torture-test optical drives by burning discs continuously. As soon as one disc finishes writing, we start writing another disc until we've burned through a spindle of 25 or 50 discs. We then run detailed surface scans on several discs from each batch to check write quality, focusing most of our attention on discs written late in the sequence.

In the past, inexpensive drives simply didn't stand up to this kind of abuse. As they heated up after burning several discs, many of them started burning coasters or refusing to load a disc. Even those that completed the torture test generally produced poor quality writes, particularly late in the process. Only Plextor drives came through with flying colors.

We repeated our torture test in mid-2006. The bad news is that premium-series Plextor drives were still the only models that survived unscathed. The good news is that several inexpensive drives we tested did remarkably well. The NEC ND-3550A and BenQ DW1655 were both able to write a spindle of 25 discs without failing, although both generated several poor quality discs late in the sequence. The Plextor PX-716A wrote an entire spindle of 50 discs, all of which were nearly perfect from first to last.

The moral here is that if you use your optical drive very heavily, pay the extra money and get a Plextor premium-series drive. If you use your drive less intensively, an NEC or BenQ model is adequate.

3.3.12. Floppy Disk Drive

Since before the turn of the century, Microsoft and Intel have claimed that the humble floppy disk drive is a "legacy" device that should not be installed in modern systems. We took them at their word, more fool us. For five years, we've been building systems without floppy drives, and for five years we've frequently had cause to regret it. All too often, we ended up popping the cover on a PC to install a floppy disk drive because that was the easiest way to solve one problem or another.

Intel at least provides motherboard BIOS updates that can be run from within Windows rather than requiring booting the system with a floppy disk to update the BIOS. That's fine for those who run Windows on an Intel system. Most of our systems run Linux, though, and the only way to update the Intel BIOS on a Linux system is to boot from a floppy disk. And many other motherboard manufacturers provide BIOS updates only as .bin files that must be loaded from a floppy.

Microsoft is worse. When we install Windows, we frequently encounter the dreaded prompt to insert a floppy disk with a driver that Windows Setup requires for a RAID card or some other component. You'd think Microsoft would join the '90s and support loading drivers from a CD during Setup, but no. Windows Setup demands drivers on a floppy disk and will accept nothing else.

We ran into the "can't get there from here" problem while testing the budget system, which had no floppy drive. Windows XP installed and ran perfectly on the budget system. After testing Windows, we blew away Windows and installed Linux. Then we realized that we needed to update the motherboard BIOS. Ooops. ASRock had a Windows BIOS updater, but we were no longer running Windows. ASRock also had a floppy-based BIOS updater, but we had no floppy drive. Arrrrrrghhh.

ALTERNATIVES: FLOPPY DISK DRIVE

If you want to save drive bay space, install the Mitsumi FA404M combo floppy disk drive, which also incorporates a card reader. Note that the FA404M uses the USB interface for both the FDD and the card reader. That means that it can be used to load BIOS updates only if the motherboard supports booting from a USB floppy drive, which nearly all current motherboards do although that option is often disabled by default in BIOS setup. If your system does support booting from a USB FDD, consider buying an external USB FDD, which can be moved from system to system as needed.

If we were smart, we'd ignore Microsoft and Intel and install a floppy disk drive on every system we build. That drive may be used only a few times over the life of the system, but at $6 or so an internal floppy disk drive is cheap insurance. Instead, while we had the system open, we temporarily installed an old FDD that was gathering dust on our workbench. We needed the FDD only long enough to install the Intel RAID drivers during Windows setup. After the system was up and running, we shut it down, disconnected the FDD, and reassembled the system.

If you decide to install a floppy drive permanently in your system, don't worry about brand name. Buy whichever 3.5" FDD happens to be cheapest. It will probably run for literally only a few minutes over the life of the system, so durability is of little concern.

3.3.13. Keyboard

Logitech Media Elite (http://www.logitech.com )

Personal preference outweighs all else when choosing a keyboard. So many personal factors determine the usability of a keyboardstraight versus ergonomic, layout, key size, cup depth, angle, stroke length, corded versus cordless, and so onthat no one can choose the "best" keyboard for someone else. That said, we had to pick a "mainstream" keyboard for our mainstream PC, and our favorite mid-priced keyboard is the Logitech Media Elite, although we also like several of the other Logitech models. Microsoft also offers many excellent standard and ergonomic keyboard models, but we generally prefer the feel of Logitech models.

ALTERNATIVES: KEYBOARD

Many. Decide which features and layout you want, and then look for an appropriate Logitech model. If Logitech doesn't offer a model that suits you, look next to one of the many models sold by Microsoft.

3.3.14. Mouse

Logitech LX7 cordless optical mouse (http://www.logitech.com )

Personal preference is also the most important factor in choosing a mouse. Subtle differences in size, shape, button position, and so on can have a major effect on how comfortable a mouse is to use. What someone else loves, you may hate, and vice versa.

Brian Bilbrey Warns

Cordless keyboards. The more I think about them, the less happy I am. You're typing in your online banking password. Can I sit at the top of a neighborhood and use a high-gain directional antenna to cherry-pick usernames and passwords? There aren't THAT many banks...

Years ago, Microsoft sent us prototype samples of their first "red light" optical mouse. We fell in love with optical mice, and used Microsoft optical mice exclusively for years. Several years ago, we tried a Logitech optical mouse and soon began replacing our Microsoft cordless mice with Logitech models. At the midrange and high-end, we actually prefer the feel of the Logitech mice. They feel more precise than the Microsoft models, and seem to fit our hands better. At the low end, Logitech and Microsoft optical mice seem comparable, but the Logitech models generally cost a bit less for models with features similar to competing Microsoft models.

Small Hands, Big Mouse

Conventional wisdom is not always reliable. For example, because Barbara has small hands, most ergonomics experts would recommend a small mouse for her. She used a small mouse for years, but began experiencing hand pain when using it. On a whim, she decided to try a Microsoft Explorer 5-button mouse, which was one of the largest standard mice available. Her hand pain went away, and she's been using large mice ever since. The moral is that if you're at all unhappy with your current mouse, try something else. You may well like it much better.

3.3.15. Speakers

Logitech Z-2300 speaker system (http://www.logitech.com )

A mainstream PC deserves a decent set of speakers, but we can realistically spend no more than $100 on speakers for a mainstream PC. There are scores of speaker systems available within that range, including sets with 6 or even 8 speakers. We decided it was better to spend our $100 on a good 2.1 systemtwo satellites and a subwooferrather than spending the same amount on a cheesy, tinny-sounding speaker system with a half dozen satellites.

At 120W RMS for the subwoofer and 40W RMS for each satellite, the Z-2300 can rattle the walls when you're gaming, but at lower volume it's also fine for listening to anything from classical music to DVD soundtracks. The satellites do a good job on the midrange and highs, and the subwoofer provides excellent bass response for this price level.

The THX-certified Z-2300 speakers are solidly built, and are attractive enough to use in your living room or den. The subwoofer includes an 8" long-throw woofer and the built-in amplifier. The satellites each use one 2.5" midrange/tweeter driver, and are brushed aluminum with removable grilles. The Z-2300 includes a wired remote with volume control, mute button, and headphone jack.

ALTERNATIVES: MOUSE

Many. We used a Logitech LX7 Cordless Optical Mouse for the mainstream PC based on price and feel, but you might prefer another model. We recommend limiting your choices to Logitech and Microsoft models. Whatever you do, get a cordless optical mouse. The absence of a mouse cord is worth the small additional cost. Early cordless mice ate batteries quickly, but current Logitech and Microsoft models run for a month or more on one set of batteries. We keep a set of NiMH rechargeable batteries in the charger, ready to swap out when our mouse batteries die.

3.3.16. Display

NEC MultiSync FE992 19" CRT (http://www.necmitsubishi.com ) Samsung SyncMaster 997MB 19" CRT (http://www.samsung.com) ViewSonic G90FB 19" CRT (http://www.viewsonic.com)

A mainstream PC should have a 19" display, and we allocated $200 to this component. That $200 buys us a top-notch 19" CRT monitor like the NEC MultiSync FE992, Samsung SyncMaster 997MB, or ViewSonic G90FB, or a mediocre 19" LCD display. In that price range, the CRT monitor wins hands down in every respect, including image quality and durability.

ALTERNATIVES: SPEAKERS

In this price range, the Logitech Z-2300 is head and shoulders above any competing 2.1 system. If you prefer a $100 2.0 speaker system that's superior to the Z-2300 for listening to music, consider the Klipsch ProMedia Ultra 2.0 speaker system. We listened to several sub-$100 5.1 and 7.1 speaker systems, and decided none of them were worth having. We prefer decent sound from two or three speakers to terrible sound from six or eight speakers.

Table 3-1 summarizes our component choices for the mainstream PC system.

Table 3-1. Bill of materials for mainstream PC

Component

Product

Case

Antec BK640B microBTX micro-tower case

Power supply

Antec 380W (bundled)

Motherboard

Intel D945GCZLR

Processor

Intel Pentium D 940

CPU cooler

(Bundled with retail-boxed CPU)

Memory

Kingston PC2-5300 DDR2-SDRAM (two 1 GB DIMMs)

Video adapter

(Integrated)

Video capture adapter

Hauppauge WinTV-PVR-150

Sound adapter

(Integrated)

Network adapter

(Integrated)

Hard disk drive

80 GB Seagate Barracuda 7200.9 SATA (two)

Optical drive

BenQ DW1650 DVD writer

Floppy disk drive

(See text)

Keyboard

Logitech Media Elite

Mouse

Logitech LX7 Cordless Optical Mouse

Speakers

Logitech Z-2300 2.1 speaker system

Display

(See text)


Section 3.4. Building the Mainstream PC

3.4. Building the Mainstream PC

Figure 3-5 shows the major components of the mainstream PC. The Intel D945GCZLR motherboard is to the left of Antec BK640B case, with the Intel Pentium D 940 processor and Hauppauge PVR-150 video capture card to the right. Front and center are the two 80 GB Seagate Barracuda 7200.9 hard drives, just behind the NEC ND-3550A optical drive and the Kingston 2GB memory kit.

Figure 3-5. Mainstream PC components, awaiting construction

Before you proceed, make sure you have everything you need. Open each box and verify the contents against the packing list.

3.4.1. Preparing the Case

To begin, remove the two screws that secure the side panels, as shown in Figure 3-6. We call them "shipping screws" because they're there primarily to keep the side panel securely in place during shipping. Although you can insert these screws after you finish building the system, it really isn't necessary. The side panel latch by itself is sufficient to secure the side panel during routine use.

Figure 3-6. Remove the screws that secure the side panels

Warning: The first step in building any system is always to make sure that the power supply is set to the correct input voltage, if necessary. Some power supplies, including the unit in the Antec BK640B, set themselves automatically. Others must be set manually using a slide switch to select the proper input voltage.If you connect a power supply set for 230V to a 115V receptacle, there's no harm done. The PC components receive half the voltage they require, and the system won't boot. But if you connect a power supply set for 115V to a 230V receptacle, the PC components receive twice the voltage they're designed to use. If you power up the system, that overvoltage destroys the system instantly in clouds of smoke and showers of sparks.

Assembly Order

Although by necessity we describe building the system in a particular order, you don't need to follow that exact sequence when you build your own system. Some stepsfor example, installing the processor and memory before installing the motherboard in the caseshould be taken in the sequence we describe, because doing otherwise makes the task more difficult or risks damaging a component. Other steps, such as installing the CPU cooler after you install the motherboard in the case, must be taken in the order we describe, because completing one step is a prerequisite for completing another. But the exact sequence doesn't matter for most steps. As you build your system, it will be obvious when sequence matters.

After you remove the screws, remove the side panels, as shown in Figure 3-7 by sliding them slightly toward the rear of the case and then tilting the panels away from the chassis.

Figure 3-7. Press the latch and lift the side panel off

With the side panels removed, place the case flat on your work surface. The BK640B has two removable hard drive cages, one on each side of the violet BTX air duct. It's almost impossible to work on the motherboard with these cages in place, so for the time being we'll remove the cages and set them aside. Each cage is secured to the chassis by one screw. Remove both of those screws, as shown in Figures 3-8 and 3-9.

Figure 3-8. Remove the screw that secures one hard drive cage

Figure 3-9. Remove the screw that secures the second hard drive cage

With the screws removed, you can remove each of the drive cages by sliding it toward the rear of the case and lifting it free, as shown in Figure 3-10. Each drive cage connects to the chassis with a slot-and-tab arrangement. If the cage doesn't release easily, wiggle it slightly until it slides freely toward the rear of the case.

Figure 3-10. Slide each drive cage toward the rear of the case and lift it free

With the drive cages removed, the interior of the case is completely open and uncluttered, as shown in Figure 3-11. The power supply is visible at the lower-right corner, and the optical drive bay at the upper-right corner. The large violet plastic box at the top left is the BTX air duct, which will guide cool air from the front case vent directly to the CPU cooler once the motherboard is installed.

Figure 3-11. The case interior after removing the drive cages

The stamped metal structure visible at the lower center of the image is the BTX SRM (Support and Retention Module). The SRM provides a rigid mounting point for the heavy BTX CPU cooler, which is secured with four screws that pass through the motherboard and are threaded into the screw holes visible as a rectangular pattern on the SRM. The SRM transfers the weight of the CPU cooler directly to the chassis, instead of requiring the relatively fragile motherboard to support that weight. This allows BTX systems to use massive CPU coolers, which can be quieter and more efficient than the smaller CPU coolers used in ATX systems.

Most cases include a generic I/O template, which never seems to fit the I/O panel of the motherboard. The Antec BK640B case doesn't include a generic I/O template, so there's no need to pop out the old template before proceeding.

Most motherboards, including the Intel D945GCZLR, come with a custom I/O template designed to match the motherboard I/O panel. Before you install the custom I/O template, compare it to the motherboard I/O panel to make sure the holes in the template correspond to the connectors on the motherboard.

Once you've done that, press the custom I/O template into place. Working from inside the case, align the bottom, right, and left edges of the I/O template with the matching case cutout. When the I/O template is positioned properly, press gently along the edges to seat it in the cutout, as shown in Figure 3-12. It should snap into place, although getting it to seat properly sometimes requires several attempts. It's often helpful to press gently against the edge of the template with the handle of a screwdriver or nut driver, as shown in Figure 3-13.

Figure 3-12. Press the custom I/O template into place

Figure 3-13. Use a tool handle to snap the I/O template into place

ADVICE FROM JIM COOLEY

It's often easiest to start in one corner. Once that snaps into place, move to an adjacent corner and continue to work your way around.

After you install the I/O template, make a "test run." Carefully slide the motherboard into place, making sure that the back panel connectors on the motherboard are firmly in contact with the corresponding holes on the I/O template.

Warning: Be careful not to bend the I/O template while seating it. The template holes need to line up with the external port connectors on the motherboard I/O panel. If the template is even slightly bent it may be difficult to seat the motherboard properly.

Compare the positions of the motherboard mounting holes with the standoff mounting positions in the case. One easy method is to place the motherboard in position and insert a felt-tip pen through each motherboard mounting hole to mark the corresponding standoff position beneath it.

LET THERE BE LIGHT

If you simply look at the motherboard, it's easy to miss one of the mounting holes in all the clutter. We generally hold the motherboard up to a light, which makes the mounting holes stand out distinctly.

The Intel D945GCZLR motherboard has seven mounting holes. The Antec BK640B, like many cases, is shipped with several standoffs already installed. The BK640B had seven standoffs installed, all of which corresponded to the mounting holes in the motherboard, so we didn't need to install or remove any standoffs.

Warning: If your case comes with preinstalled standoffs, make absolutely certain that each standoff matches a motherboard mounting hole. If you find one that doesn't, remove it. Leaving an "extra" standoff in place may cause a short circuit that may damage the motherboard and/or other components.

Pen and Paper

Another method we've used to verify that all standoffs are properly installed is to place the motherboard flat on a large piece of paper and use a felt-tip pen to mark all motherboard mounting holes on the paper. We then line one of the marks up with the corresponding standoff and press down until the standoff punctures the paper. We do the same with a second standoff to align the paper, and then press the paper flat around each standoff. If we've installed the standoffs properly, every mark will be punctured, and there will be no punctures where there are no marks.

If necessary, install additional standoffs in your case until each motherboard mounting hole has a corresponding standoff. Although you can screw in the standoffs using your fingers or needle-nose pliers, it's much easier and faster to use a 5mm or 6mm nut driver. Tighten the standoffs finger-tight, but do not overtighten them. It's easy to strip the threads by applying too much torque with a nutdriver.

Once you've installed all the standoffs, do a final check to verify (a) that each motherboard mounting hole has a corresponding standoff, and (b) that no standoffs are installed that don't correspond to a motherboard mounting hole. As a final check, we usually hold the motherboard in position above the case and look down through each motherboard mounting hole to make sure there's a standoff installed below it.

3.4.2. Preparing and Populating the Motherboard

It is always easier to prepare and populate the motherboardinstall the processor and memorywhile the motherboard is outside the case. In fact, you must do so with some systems, because installing the heatsink/fan unit requires access to both sides of the motherboard. Even if it is possible to populate the motherboard while it is installed in the case, we always recommend doing so with the motherboard outside the case and lying flat on the work surface. More than once, we've tried to save a few minutes by replacing the processor without removing the motherboard. Too often, the result has been bent pins and a destroyed processor.

Warning: Each time you handle the processor, memory, or other static-sensitive components, first touch the power supply to ground yourself.
3.4.2.1. Installing the processor

To install the Pentium D processor, press the lever slightly away from the socket to unlatch it, as shown in Figure 3-14. Then lift the lever straight up until it comes to a stop vertical or slightly past vertical.

Figure 3-14. Lift the socket lever to unlock the metal retention plate

With the lever vertical, the metal retention plate is unlocked and free to swing up and away from the socket. Pivot the retention plate up and remove the plastic socket protector, as shown in Figures 3-15 and 3-16. Ours required quite a bit of pressure to snap out. Keep the plastic socket protector in the motherboard box, in case you ever remove the processor. The exposed Socket 775 connectors are very fragile, and should never be left unprotected.

Figure 3-15. Lift the metal retention plate to expose the socket contacts

Figure 3-16. Snap the plastic socket protector out of the retention plate

With the plastic retention plate removed, as shown in Figure 3-17, the socket is prepared to receive the processor.

Figure 3-17. The socket prepared to receive the processor

Remove the processor from its plastic blister-wrap container. The contact side of the processor is covered by a plastic protector. Hold the processor by its edges, as shown in Figure 3-18, and peel the plastic protector away from the processor. Store that protector with the motherboard or processor box, in case you ever remove the processor. Always reinstall the protector when you store a bare processor.

Figure 3-18. Remove the plastic protector from the processor

Keying is indicated on the processor by a small triangle and on the socket by a corresponding beveled edge, both visible in Figure 3-19. The socket also has two protruding nubs that correspond to notches in the processor, one of which is visible in the figure just to the right of the gold arrow at the lower-left corner of the processor.

Figure 3-19. Dropping the processor into place

With the metal retention plate vertical, align the processor with the socket and drop the processor into place, as shown in Figure 3-19. The processor should seat flush with the socket just from the force of gravity. If the processor doesn't simply drop into place, something is misaligned. Remove the processor and verify that it is aligned properly. Never apply pressure to the processor. You'll bend one or more pins, destroying the socket (and the motherboard).

With the processor in place and seated flush with the socket, lower the metal retention plate, as shown in Figure 3-20. If the processor is fully seated in its socket, the retention plate should freely seat flush with the top of the processor. Note the lip on the lower right of the retention plate and the corresponding cammed area of the clamping lever. When the retention plate is properly closed, the cammed portion of the clamping lever should engage that lip as the clamping lever is moved to the latched position.

Figure 3-20. Closing the retention plate

With the retention plate closed, close the socket latching lever, as shown in Figure 3-21. Make certain that the lever is locked in place by the hook on the side of the socket.

Figure 3-21. Locking the processor into the socket

3.4.2.2. Installing memory

Installing memory is easy enough, but before you begin plugging in memory modules willy-nilly, take a moment to determine the best memory configuration. The Intel D945GCZLR motherboard has a dual-channel memory controller that provides better memory performance than a single-channel controller, but it's possible to force the motherboard to operate in single-channel mode if you're not careful about where you install the memory modules. Dual-channel operation requires using DIMMs in pairs, one per channel.

Examining the D945GCZLR motherboard, we see that it has four DIMM slots in two pairs. The slot nearest the processor is Channel A, DIMM0; followed by Channel A, DIMM1; Channel B, DIMM0; and Channel B, DIMM1. We want to install one memory module in Channel A and the second in Channel B. We could use either slot, but as a matter of good practice we decided to install our DIMMs in the first (DIMM0) slot of each channel.

Having decided where to install the memory modules, the first step in actually installing them is to pivot the locking tabs on both sides of the DIMM socket outward. To install the first DIMM, orient it with the notch in the contact area of the DIMM aligned with the raised plastic tab in the Channel A, DIMM0 slot and slide the DIMM into place, as shown in Figure 3-22.

Figure 3-22. Orient the DIMM with the notch aligned properly with the socket

With the DIMM properly aligned with the Channel A, DIMM0 slot and oriented vertically relative to the slot, use both thumbs to press down on the DIMM until it snaps into place, as shown in Figure 3-23. The locking tabs should automatically pivot back up into the locked position when the DIMM snaps into place. If they don't, close them manually to lock the DIMM into the socket.

Figure 3-23. Seat the DIMM by pressing firmly until it snaps into place

To install the second DIMM, orient it with the notch in the contact area of the DIMM aligned with the raised plastic tab in the Channel B, DIMM0 (blue) slot and slide the DIMM into place. Use your thumbs to press down on both sides of the DIMM, as shown in Figure 3-24, until the DIMM seats fully in the slot and the locking tabs snap into place.

Figure 3-24. Insert the second DIMM in the Channel B, DIMM0 slot

Before you proceed, verify that the locking tabs on both sides of both DIMMs are locked into place, as shown in Figure 3-25.

Figure 3-25. Verify that both DIMMs are fully seated and locked in place

With the processor and memory installed, you're almost ready to install the motherboard in the case. Before you do that, check the motherboard documentation to determine if any configuration jumpers need to be set. The Intel D945GCZLR has only one jumper, which sets operating mode. On our motherboard, that jumper was set correctly by default, so we proceeded to the next step.

3.4.3. Installing the Motherboard

Installing the motherboard is the most time-consuming step in building the system because there are so many cables to connect. It's important to get all of them connected right, so take your time and verify each connection before and after you make it.

Before you begin installing the motherboard, use a paper towel to polish the processor, as shown in Figure 3-26. You want to remove any smudges or skin oil from the processor surface to make sure the CPU cooler can make good contact with the processor.

Figure 3-26. Polish the processor to remove any smudges

3.4.3.1. Seating and securing the motherboard

To begin, slide the motherboard into the case, as shown in Figure 3-27. Carefully align the back panel I/O connectors with the corresponding holes in the I/O template, and slide the motherboard toward the rear of the case until the motherboard mounting holes line up with the standoffs. Also verify that the four CPU cooler mounting holes that surround the processor socket are aligned with the corresponding holes in the Support and Retention Module (SRM).

Figure 3-27. Slide the motherboard into position

MEASURE TWICE, CUT ONCE

Check one more time to make sure that there's a standoff installed for each mounting hole, and that no standoff is installed where there is no mounting hole. One of our technical reviewers suggests installing white nylon standoffs, trimmed to length, in all unused standoff positions covered by the motherboard, particularly those near the expansion slots. Doing so provides more support to the motherboard, making it less likely that you'll crack the motherboard if you seat a recalcitrant expansion card.

Although the image shows Barbara grasping the motherboard by the northbridge heatsink, she was using it only to guide the motherboard into position. Be careful not to put any pressure on that heatsink. It is not firmly connected to the motherboard, and can easily be torn loose.

Before you secure the motherboard, verify that the back-panel I/O connectors mate cleanly with the I/O template, as shown in Figure 3-28. The I/O template has metal tabs that ground the back-panel I/O connectors. Make sure none of these tabs intrude into a port connector. An errant tab at best blocks the port, rendering it unusable, and at worst may short out the motherboard.

Figure 3-28. Verify that the back panel connectors mate cleanly with the I/O template

After you position the motherboard and verify that the back-panel I/O connectors mate cleanly with the I/O template, insert a screw through one mounting hole into the corresponding standoff, as shown in Figure 3-29. You may need to apply pressure to keep the motherboard positioned properly until you have inserted two or three screws.

Figure 3-29. Install screws in all mounting holes to secure the motherboard

If you have trouble getting all the holes and standoffs aligned, insert two screws but don't tighten them completely. Use one hand to press the motherboard into alignment, with all holes matching the standoffs. Then insert one or two more screws and tighten them completely. Finish mounting the motherboard by inserting screws into all standoffs and tightening them. If you're still having difficulty getting everything aligned, try installing all of the mounting screws before you tighten any of them completely.

Less Power

People sometimes ask us why we don't use power screwdrivers. Because they're large, clumsy, and the batteries are always dead when we want to use the driver. Worse still, we once watched someone crack a motherboard by over-torquing the mounting screws with a power screwdriver. A clutched driver eliminates that objection, but we still find power screwdrivers too clumsy to use, even when we've built many identical systems on an ad hoc production line.

With first-rate products like the Antec BK640B case and the Intel D945GCZLR motherboard, all the holes usually line up perfectly. With second- and third-tier brands, that's not always the case. At times, we've been forced to use only a few screws to secure the motherboard. We prefer to use all of them, both to physically support the motherboard and to make sure all of the grounding points are in fact grounded, but if you simply can't every hole lined up, just install as many screws as you can.

After you've inserted all of the motherboard mounting screws, make one final check to verify that all of the ports on the back-panel I/O connector are clear of the metal grounding tabs on the I/O template.

3.4.4. Installing the CPU Cooler

Modern processors draw as much as 130W of power and must dissipate a correspondingly large amount of heat. Our Pentium D 940 processor has a TDP (Thermal Design Power) rating of 95W, and can actually exceed that figure under heavy load. All of that wattage is converted to waste heat. The processor must rid itself of that heat over the surface of its heat spreader, which is about the size of a large postage stamp. Without a good CPU cooler, the processor would almost instantaneously shut itself down to prevent damage from overheating.

To install the CPU cooler, position it over the processor, as shown in Figure 3-30. Make sure that the cylindrical finned-metal heatsink portion of the cooler is toward the rear of the case and that the front of the CPU cooler (the part with the fan) mates cleanly to the violet plastic air duct just visible behind Barbara's hand. Check the four holes in the base of the CPU cooler to verify that they are aligned with the corresponding screw holes in the SRM.

Figure 3-30. Position the CPU cooler over the processor

Correct Cooling

Using a proper CPU cooler is critical. A retail-boxed processor includes a CPU cooler that is designed for that processor. If you buy an OEM processor, it's up to you to install a CPU cooler that can keep the processor operating within its design temperature range.

Just because a CPU cooler fits doesn't guarantee it's usable. Even apparently identical processors may differ widely in their power consumption and heat production. For example, our Pentium D 940 is a later model that is rated at 95W TDP. Earlier Pentium D 940 models were rated at 130W TDP. If you choose a third-party CPU cooler, make certain that it is rated to cool the exact processor you use, not just by model number but by the S-spec number or a similar detailed specification number.

The Intel CPU cooler includes a preapplied thermal pad, visible as a square white patch on the copper base of the heatsink shown earlier in Figure 3-4. A thermal pad uses phase-change media, which is a fancy way of saying that it melts when it gets hot and solidifies when it cools down again. This thermal compound greatly improves heat transfer between the CPU heat spreader plate and the base of the heatsink by eliminating air gaps and filling in tiny pits in the smooth surfaces of the heat spreader and heatsink base.

Warning: Always check the thermal pad before you install the CPU cooler to verify that there is no protective paper or plastic film covering it. Some thermal pads have protective film; others are supplied bare. If the pad has protective film, peel it off before you position the CPU cooler.If you remove the heatsink, you must replace the thermal compound or pad when you reinstall it. Before you reinstall, remove all remnants of the old thermal pad or compound. That can be difficult, particularly for a thermal pad, which can be very tenacious. We use an ordinary hair dryer to warm the thermal material enough to make it easy to remove. Sometimes the best way is to warm up the compound and rub it off with your thumb. (Use rubber gloves or a plastic bag to keep the gunk off your skin.)Alternatively, one of our technical reviewers says that rubbing gently with #0000 steel wool works wonders in removing the gunk, and is fine enough not to damage the surface. Another of our technical reviewers tells us that he uses Goof-Off or isopropyl alcohol to remove the remnants of the thermal goop or thermal pad. Whatever works for you is fine. Just make sure to remove the old thermal compound and replace it with new compound each time you remove and reinstall the processor.When we replace a heatsink, we use Antec Silver Thermal Compound, which is widely available, inexpensive, and works well. Don't pay extra for "premium" brand names like Arctic Silver. They cost more than the Antec product and our testing shows little or no difference in cooling efficiency.

With the CPU cooler in position, secure it by driving the four provided screws through the holes in the base of the CPU cooler and into the SRM, as shown in Figure 3-31. Intel says you can drive those screws in any order. We drove them as we'd install the lug nuts on a tire. We drove all four screws to a loose fit and then tightened them down, alternating diagonally. You want these screws to be tight enough to force the CPU cooler into tight contact with the heat spreader plate on the processor, but not tight enough to risk cracking the motherboard. Finger-tight is good enough.

Figure 3-31. Secure the CPU cooler with four screws

The thermal mass of the heatsink draws heat away from the CPU, but the heat must be dissipated to prevent the CPU from eventually overheating as the heatsink warms up. To dispose of excess heat as it is transferred to the heatsink, most CPU coolers use a fan to continuously draw air through the fins of the heatsink. Some CPU fans use a drive power connector, but most are designed to attach to a dedicated CPU fan connector on the motherboard. Using a motherboard fan power connector allows the motherboard to control the CPU fan, reducing speed for quieter operation when the processor is running under light load and not generating much heat, and increasing fan speed when the processor is running under heavy load and generating more heat. The motherboard can also monitor fan speed, which allows it to send an alert to the user if the fan fails or begins running sporadically.

To connect the CPU fan, locate the header connector on the motherboard labeled CPU Fan, and plug the keyed cable from the CPU fan into that connector, as shown in Figure 3-32.

Figure 3-32. Connect the CPU cooler fan power lead to the CPU fan header

3.4.4.1. Connecting front-panel switch and indicator cables

With the CPU cooler installed, the next step is to connect the front-panel switch and indicator cables to the motherboard. Before you begin connecting front-panel cables, examine the cables. Each is labeled descriptively, e.g., "Power," "Reset," and "HDD LED." Match those descriptions with the front-panel connector pins on the motherboard to make sure you connect the correct cable to the appropriate pins. The motherboard header pins are color-coded. Figure 3-33 shows the pin assignments for the Hard Drive Activity LED (yellow), Reset Switch (purple), Power LED (green), and Power Switch (red) connectors.

  • The Power Switch and Reset Switch connectors are not polarized and can be connected in either orientation.

  • The Hard Drive Activity LED is polarized and should be connected with the ground (black) wire on Pin 3 and the signal (red) wire on Pin 1.

  • The Power LED connector on the Intel motherboard accepts a two-position Power LED cable. Like other Intel motherboards, the D945GCZLR also provides an alternative three-pin Power LED connector with pins in positions one and three. The Power LED connector is dual-polarized, and can support a single-color (usually green) Power LED, as is provided with the Antec BK640B case, or a dual-color (usually green/yellow) LED. If you are using a case that has a dual-color Power LED, check the case documentation to determine how to connect the Power LED cable.

Despite Their Best Intentions

Intel has defined the standard front-panel connector block shown in Figure 3-33, and uses that standard for its current motherboards. Unfortunately, few other motherboard makers adhere to that standard. Accordingly, rather than provide an Intel-standard monolithic connector block that would be useless for motherboards that do not follow the Intel standard, most case makers, including Antec, provide individual one-, two-, or three-pin connectors for each switch and indicator. A few cases provide both a monolithic Intel connector block and individual wires for nonstandard motherboards. If your motherboard provides the monolithic connector block, use it to minimize the possibility of connecting the cables incorrectly.

Figure 3-33. Front panel connector pin assignments (graphic courtesy of Intel Corporation)

Once you determine the proper orientation for each cable, connect the Hard Drive Activity LED, Reset Switch, Power LED, and Power Switch cables to the motherboard, as shown in Figure 3-34. Not all cases have cables for every connector on the motherboard, and not all motherboards have connectors for all cables provided by the case. For example, some cases provide a speaker cable. The Intel D945GCZLR motherboard has a built-in speaker, but no connector for an external speaker, so that cable goes unused. Conversely, the Intel D945GCZLR has a Chassis Intrusion Connector, for which no corresponding cable exists on the Antec BK640B case, so that connector goes unused.

Figure 3-34. Connect the front-panel switch and indicator cables

When you're connecting front-panel cables, try to get it right the first time, but don't worry too much about getting it wrong. Other than the power-switch cable, which must be connected properly for the system to start, none of the other front-panel switch and indicator cables is essential, and connecting them wrong won't damage the system. Switch cablespower and resetare not polarized. You can connect them in either orientation, without worrying about which pin is signal and which ground. LED cables may or may not be polarized, but if you connect a polarized LED cable backwards the worst that happens is that the LED won't light. Most cases use a common wire color, usually black, for ground, and a colored wire for signal.

3.4.4.2. Connecting front-panel USB ports

The Antec BK640B case provides two front-panel USB 2.0 ports, for which the Intel D945GCZLR motherboard provides corresponding internal connectors. Both front-panel USB 2.0 ports are routed through a single cable that terminates in an Intel-standard 10-pin monolithic USB connector block.

TWO BY TWO

The D945GCZLR actually provides four internal USB 2.0 connectors, in two sets of two header pin groups. One of those connectors serves the two front-panel USB 2.0 ports on the BK640B, leaving the second connector free for other uses, such as connecting an internal USB card reader or routing additional USB ports to the rear of the system.

Other cases provide individual wires rather than a monolithic USB connector block. If your case has individual wires, refer to Figure 3-35 for the pin assignments for the dual front-panel internal USB connectors.

Figure 3-35. Front panel USB connector pin assignments (graphic courtesy of Intel Corporation)

To route USB to the front panel panel of the BK640B, you simply connect the USB cable to the corresponding internal connector, as shown in Figure 3-36.

Figure 3-36. Connect the front-panel USB cable

3.4.4.3. Connecting the front-panel IEEE-1394a (FireWire) port

The Antec BK640B case provides one front-panel FireWire (IEEE-1394a) port, for which the Intel D945GCZLR motherboard provides a corresponding internal connector (actually, it provides two). To route FireWire to the front panel, you must connect a cable from the front-panel FireWire port to this internal connector.

Although the Antec BK640B case provides a front-panel FireWire cable with an Intel-standard monolithic connector block, many cases provide only individual wires that must be connected one by one to the FireWire header on the motherboard. Figure 3-37 shows the pinouts for the internal FireWire connector.

Figure 3-37. Front-panel IEEE-1394a (FireWire) connector pin assignments (graphic courtesy of Intel Corporation)

Connect the FireWire cable, as shown in Figure 3-38. A second set of FireWire pins is visible immediately below Barbara's finger in the figure. You can connect the front-panel FireWire cable to either of these sets of pins. With the standard back-panel FireWire port, that gives you two available FireWire connectors. If you need a third FireWire connector, you can install a "cliffhanger" bracket with a FireWire port and run its cable to this unused connector. Such brackets are available from most online computer parts vendors.

Figure 3-38. Connect the front-panel FireWire cable

3.4.4.4. Connecting the front-panel audio ports

The Antec BK640B case provides two front-panel audio ports, Line Out and Mic In. These ports are very convenient for connecting a headset to use Skype or simply to listen to music on your headphones. Some earlier Intel motherboards forced you to make a decision: to connect the front-panel audio port cable, you had to disable the corresponding rear-panel ports. Fortunately, the D945GCZLR requires no such decision. You can connect the front-panel audio ports and still use Line Out and Mic In on the back panel. To enable the front-panel audio ports, connect the Audio cable to the front-panel audio header pins near the rear I/O panel, as shown in Figure 3-39.

Figure 3-39. Connect the front-panel audio cable

3.4.5. Installing the Tuner Card

As long as we have the system on its side, we might as well install the Hauppauge WinTV-PVR-150 tuner card. To begin doing so, remove the screw that secures the expansion slot cover bracket, as shown in Figure 3-40.

Figure 3-40. Remove the screw that secures the expansion slot cover bracket

With the screw removed, slide the expansion slot cover bracket up and tilt it toward the inside of the case, as shown in Figure 3-41. (Our bracket required a light tap with the screwdriver handle to free it.) Remove the bracket completely and set it aside for now.

Figure 3-41. Remove the expansion slot cover bracket

Choose one of the expansion slot covers that corresponds to a PCI expansion slot on the motherboard. (If you're not sure which cover to remove, temporarily align the Hauppauge PVR-150 card with the expansion slot you intend to install it in and see which expansion slot cover needs to be removed.)

Slide the expansion slot cover upward, as shown in Figure 3-42, and remove it. Be careful while doing so. Antec cases are renowned for their absence of sharp edges and burrs, but expansion slot covers are thin metal and may have sharp edges.

Figure 3-42. Remove the selected expansion slot cover

Slide the Hauppauge WinTV-PVR-150 card into position, making sure that the card contacts are aligned with the expansion slot. Using your thumbs, press down on the card, as shown in Figure 3-43, until you feel the card snap into place in the expansion slot.

Figure 3-43. Align the tuner card and press down until it snaps into the expansion slot

Replace the expansion slot cover bracket, as shown in Figure 3-44, working from inside the case. Press the bracket down until the keyed tabs on the bracket slide into place in the corresponding cutouts in the case. Insert the screw that secures the expansion slot cover bracket, and then insert the screw to secure the tuner card in place. (That second screw passes through the expansion slot cover bracket first, then through the card bracket itself, and then into the case frame.)

Figure 3-44. Reinstall the expansion slot cover bracket

3.4.6. Connecting the ATX Power Cables

The next step in assembling the system is to connect the two power cables from the power supply to the motherboard. The main ATX power connector is a 24-pin connector located near the rear of the motherboard, adjacent to the rear I/O connector panel. Locate the corresponding cable coming from the power supply. The main ATX power connector is keyed, so verify that it is aligned properly before you attempt to seat it.

Once everything is aligned, press down firmly until the connector seats, as shown in Figure 3-45. It may take significant pressure to seat the connector, and you should feel it snap into place. The locking tab on the side of the connector should snap into place over the corresponding nub on the socket. Make sure the connector seats fully. A partially seated main ATX power connector may cause subtle problems that are very difficult to troubleshoot.

Figure 3-45. Connect the main ATX power connector

Modern processors require more power to the motherboard than the standard ATX main power connector supplies. Intel developed a supplementary connector, called the ATX12V connector, that routes additional +12V current directly to the VRM (Voltage Regulator Module) that powers the processor. On most current Intel (and AMD) motherboards, including the D945GCZLR, the ATX12V connector is located very near the processor socket. The ATX12V connector is keyed. Orient the cable connector properly relative to the motherboard connector, and press the cable connector into place until the plastic tab locks, as shown in Figure 3-46.

Figure 3-46. Connect the ATX12V power connector

Warning: Failing to connect the ATX12V connector is one of the most common causes of initial boot failures on newly built systems. If nothing happens the first time you power up the system, chances are it's because you forgot to connect the ATX12V connector.

As long as we're connecting power cables, let's connect power to the blue LED that illuminates the front of the case. Locate a female Molex (hard drive) power connector among the other wires coming from the front panel. Connect that to one of the Molex connectors coming from the power supply, as shown in Figure 3-47.

Figure 3-47. Connect the front-panel blue LED to a power supply connector

Installing the Drives

The Antec BK640B case provides two externally-accessible 5.25" bays, each of which is covered by a snap-in plastic bezel. We decided to install the NEC ND-3550A DVD writer (our initial choice for the burner) in the upper bay. Before installing the drive, you have to remove the bezel. The easiest way to do that on the BK640B case is to press out on the bezel from inside the case until the bezel snaps out, as shown in Figure 3-48.

Figure 3-48. Remove the bezel to prepare the bay to receive the optical drive

Before you install the optical drive, verify the master/slave jumper settings. Like most optical drives, the NEC ND-3550A DVD writer is set by default to be the master device on the ATA channel. Our hard drives are S-ATA, so the optical drive will be the only parallel ATA device in the system, and should be set as the master device on the ATA channel. If you use a different optical drive, verify that its jumper is set to master.

It's usually easier to connect the ATA cable to the drive before you install the drive in the case. The Intel D945GCZLR motherboard comes with an 80-wire Ultra ATA cable, which we used. Because optical drives have relatively slow transfer rates, they can use the older 40-wire ATA cable rather than the 80-wire Ultra-ATA cable used for ATA hard drives. (An 80-wire cable works fine if that's all you have, but it's not necessary.)

To connect the cable, locate pin 1 on the drive connector, which is usually nearest the power connector. The pin-1 side of the cable is indicated by a colored stripe, usually red or blue. Align the cable connector with the drive connector, making sure the colored stripe is on the pin-1 side of the drive connector, and press the cable into place, as shown in Figure 3-49.

Figure 3-49. Connect the ATA cable to the optical drive

To mount the optical drive in the case, feed the loose end of the ATA cable through the drive bay from the front, align the drive with the corresponding tracks in the case, and slide the drive into the bay, as shown in Figure 3-50. Make sure the front panel of the drive is flush with the front bezel of the case.

Figure 3-50. Slide the optical drive into the drive bay

With the optical drive aligned flush with the front case bezel, secure the drive in the bay by inserting four screws, two on each side of the drive, as shown in Figure 3-51. The front mounting position on each side of the bay provides three discrete screw holes, one of which should align properly with the drive screw hole when the drive is aligned flush with the front panel. (For our drive and case, the middle screw hole is the proper one.) The rear mounting position is a slot that allows some slack to account for minor manufacturing variations in the position of the screw hole.

Figure 3-51. Secure the optical drive with four screws

The next step in installing the optical driveone we forget more often than we shouldis to connect power to the drive. Choose one of the power cables coming from the power supply and press the Molex connector onto the drive power connector, as shown in Figure 3-52. It may require significant pressure to get the power connector to seat, so use care to avoid hurting your fingers if the connector seats suddenly. The Molex power connector is keyed, so verify that it is oriented properly before you apply pressure to seat the power cable.

Figure 3-52. Connect the power cable to the optical drive

With the optical drive installed, the next step is to install the hard drives. We had the choice of mounting both of our hard drives in one of the removable drive cages, or one drive in each cage. At first, we were inclined to split the drives between cages so that each drive would run cooler.

Then we noticed the vent arrangement on the BK640B case. The drive cage that connects to the optical drive bay has no vent of its own, while the bottom drive cage is positioned directly behind a front-panel vent. We decided that mounting both of our hard drives in the bottom cage would actually provide better drive cooling, so we decided to leave the top cage unused.

We might need that top cage later, though, if we decide to add hard drives to the system, so the next step was to reinstall the top hard drive cage (we removed them back in the "Preparing the Case" section). To do so, position the hard drive cage so that it is aligned with the bottom of the optical drive bay, and slide the cage into position, as shown in Figure 3-53. Make sure the locking tabs engage and that the screw hole in the cage aligns with the screw hole in the optical drive bay.

Figure 3-53. Slide the top hard drive cage into place

Once the drive cage is seated, secure it by driving a single screw through the drive cage and into the optical drive bay, as shown in Figure 3-54.

Figure 3-54. Secure the hard drive cage with a screw

The next step is to mount the hard drives in the bottom hard drive cage. To do so, first position the empty cage against the chassis as though you were reinstalling it. Note the orientation of the cage to make sure you don't install the hard drives upside-down or backward. You want to install the drives with the label side facing up and the power and data connectors toward the rear.

You don't need to set configuration jumpers for Serial ATA drives, because each drive connects to a dedicated interface. Set aside four screws for each of the two hard drives. Verify that the screws are the proper size by threading one screw into the drive before you begin mounting the drives, and then selecting seven identical screws. Once you have done so, insert each drive into the cage and secure it with four screws, as shown in Figure 3-55.

Figure 3-55. Secure each drive in the cage with four screws

After you mount both drives in the drive cage, connect an S-ATA data cable to each drive, as shown in Figure 3-56. The S-ATA connector is keyed with an L-shaped slot. Make sure the cable is oriented properly to the drive connector, and then slide the connector onto the drive until it seats completely. Be careful not to apply any sideways torque to the connector, which is relatively fragile and may snap off if you're not careful.

Figure 3-56. Connect an S-ATA data cable to each drive

ADVICE FROM JIM COOLEY

Once both the S-ATA and ATA cables are inserted, I use a Wite-out pen to paint a stripe across both cable and connector, making it much easier to identify the correct orientation if I disconnect them at some point in the future.

MINOR VARIATIONS

Although an S-ATA data cable can have the same connector on both ends, our S-ATA cables had slightly different connectors on each end. These S-ATA cables were included with the Intel motherboard. One end of each cable includes a metal locking tab that is designed to mate with a special matching connector on the motherboard S-ATA interface connector. Even so, we could have connected either end of the cable to our hard drive, because the S-ATA part of the connector body is identical on each end.

After you have the data cables connected to both drives, place the drive cage assembly near the bottom front of the case. Connect an S-ATA power cable to each drive, as shown in Figure 3-57. Once again, the S-ATA power connectors use an L-shaped keying slot, and are relatively fragile. Be careful as you attach the connectors.

Figure 3-57. Connect an S-ATA power cable to each drive

Slide the hard drive cage assembly into the case, as shown in Figure 3-58. Make sure that the locking tabs on the cage and chassis align and seat properly, and that the screw hole in the chassis aligns with the screw hole in the cage. Drive one screw through the chassis and into the drive cage to secure it, as shown in Figure 3-59.

Figure 3-58. Slide the hard drive cage into the case

Figure 3-59 Secure the drive cage to the chassis with one screw

JIM COOLEY WARNS

DO NOT SKIP THIS STEP. If you don't lock the hard drive cage down you'll forget it's not secure and only find out the hard way when you move the computer at some point in the distant future, quite possibly causing much damage in the process.

The final step in installing the drives is connect their data cables to the motherboard. The S-ATA data cable from each hard drive can be connected to any of the four S-ATA ports on the motherboard. As a matter of good practice, we prefer to connect the hard drives in sequence to the S-ATA ports. We connected the first hard drivewhich by convention we designate the top of the two drivesto the first S-ATA port, labeled S-ATA 0. We then connected the second (bottom) hard drive to the second S-ATA port, labeled S-ATA 1, as shown in Figure 3-60.

Figure 3-60. Connect the S-ATA data cables to the motherboard

Once again, the S-ATA connectors are keyed with an L-shaped slot and the connectors are relatively fragile. Make sure the cable connector is aligned properly with the motherboard connector, and then press the cable connector firmly onto the motherboard connector until it seats fully. Do not apply any sideways torque.

After you've connected the S-ATA data cables, it's time to connect the P-ATA data cable from the optical drive. The Intel D945GCZLR motherboard has only one ATA interface, which is visible in Figure 3-60 just below the S-ATA connectors.

Orient the motherboard end of the P-ATA data cable so that its keying tab is aligned with the keying notch in the motherboard connector, and press the P-ATA cable firmly into place, as shown in Figure 3-61.

Figure 3-61. Connect the ATA data cable to the motherboard

What About the Audio Cable?

Speaking of connecting cables, one of our technical reviewers pointed out that we'd forgotten to connect the audio cable to the optical drive in all of the project systems. We hadn't forgotten; we just don't do it any more.

Years ago, connecting an audio cable from the optical drive to the motherboard audio connector or sound card was an essential step, because systems used the analog audio delivered from the optical drive by that cable. If you didn't connect that cable, you didn't get audio from the drive. All modern optical drives and motherboards support digital audio, which is delivered across the bus rather than via a dedicated audio cable.

To verify the setting for digital audio, which is ordinarily enabled by default, use the Windows XP Device Manager to display the Device Properties sheet for the optical drive. The Enable digital CD audio... checkbox should be marked. If it is not, mark the checkbox to enable digital audio.

3.4.7. Final Assembly Steps

Congratulations! You're almost finished building the system. Only a few final steps remain to be done, and those won't take long.

Before you go any further, dress the cables. That simply means routing the cables away from the motherboard and other components and tying them off so they don't flop around inside the case. Chances are that no one but you will ever see the inside of your system, but dressing the cables has several advantages other than making the system appear neater. First and foremost, it improves cooling by keeping the cables from impeding air flow. It can also improve system reliability. More than once, we've seen a system overheat and crash because a loose cable fouled a fan.

After you dress the cables, take a few minutes to double-check everything. Verify that all cables are connected properly, that all drives are secured, and that there's nothing loose inside the case. If your power supply is not auto-sensing, check one last time to verify that it is set to the correct input voltage. It's a good idea to pick up the system and tilt it gently from side to side to make sure there are no loose screws or other items that could cause a short. Use the following checklist:

  • Power supply set to proper input voltage (the built-in power supply on the Antec BK640B sets itself automatically)

  • No loose tools or screws (shake the case gently)

  • CPU cooler properly mounted; CPU fan connected

  • Memory modules full seated and latched

  • Front-panel switch and indicator cables connected properly

  • Front-panel I/O cables connected properly

  • Hard drive data cable(s) connected to drive(s) and motherboard

  • Hard drive power cable(s) connected

  • Optical drive data cable connected to drive and motherboard

  • Optical drive power cable connected

  • Optical drive audio cable connected, if applicable

  • Floppy drive data and power cables connected (if applicable)

  • All drives secured to drive bay or chassis, as applicable

  • Expansion card(s) fully seated and secured to the chassis

  • Main ATX power cable and ATX12V power cable connected

  • Front and rear case fans installed and connected (if applicable)

  • All cables dressed and tucked

Once you're certain that all is as it should be, it's time for the smoke test. Leave the cover off for now. Connect the power cable to the wall receptacle and then to the system unit. Unlike some power supplies, the Antec unit has a separate rocker switch on the back that controls power to the power supply. By default, it's in the "0" or off position, which means the power supply is not receiving power from the wall receptacle. Move that switch to the "1" or on position. Press the main power button on the front of the case, and the system should start up. Check to make sure that all fans are spinning. You should also hear the hard drive spin up and the happy beep that tells you the system is starting normally. At that point, everything should be working properly.

False Starts

When you turn on the rear power switch, the system will come to life momentarily and then die. That's perfectly normal behavior. When the power supply receives power, it begins to start up. It quickly notices that the motherboard hasn't told it to start, and so it shuts down again. All you need to do is press the front-panel power switch and the system will start normally.

Turn off the system, disconnect the power cord, and take these final steps to prepare the system for use:

Set the BIOS Setup Configuration jumper to Configure mode

The BIOS Setup Configuration jumper block on the Intel D945GCZLR motherboard is used to set the operation mode. This jumper is located at the rear center of the motherboard, near the speaker and the Main ATX Power connector. By default, the jumper is in the 12 or "normal" position. Move the jumper block to the 23 or "configure" position.

Reconnect the power cord and restart the system

When the configuration jumper is set to configure mode, starting the system automatically runs BIOS Setup and puts the system in maintenance mode. This step allows the motherboard to detect the type of processor installed and configure it automatically. When the BIOS Setup screen appears, reset the system clock and load the system defaults. Save your changes, exit, and power down the system. Disconnect the power cord.

Set the BIOS Setup Configuration jumper to Normal mode

With the power cord disconnected, move the BIOS Setup Configuration jumper block from 23 (Configure mode) to 12 (Normal mode).

Replace the side panels and reconnect power

With the jumper set for Normal operation, replace the side panels and reconnect the power cord. Your system is now completely assembled and ready for use.


Section 3.5. Post-Assembly

3.5. Post-Assembly

This system was as easy to build as any system we've ever assembled. Counting only actual construction time, it took only about 30 minutes from start to finish. (Of course, counting the time to shoot images, reshoot images, re-reshoot images, tear down for re-shoots and re-reshoots, rebuild and re-rebuild after the re-shoots and re-reshoots, and so on, it took a couple days.) A first-time system builder should be able to assemble this system in an evening with luck, and certainly over a weekend.

3.5.1. Initial Problems

When we fired up our mainstream PC for the first time, we were surprised when it refused to boot. The system started up normally enough, with all fans spinning and the BIOS boot text appearing onscreen. The access light on the NEC ND-3550A optical drive came on, and we expected the system to boot into Windows XP Setup. Alas, after a few seconds, the light on the NEC optical drive went out. After a minute or two, we concluded that the system had hung.

Our first thought was that the Windows XP distribution disc was bad. We had some Linux distribution discs handy, so we tried booting one of them. Same thing: the light on the optical drive would come on, the drive would read the disc for a few seconds, and then the light would go out. Hmmmm.

When we have problems like this, we always suspect the cable. We replaced the ATA cable and restarted the system. Same problem. Apparently, the drive itself was bad. We happened to have another NEC ND-3550A drive on the work bench, so we tried swapping it in. Same problem. Double hmmmm. Thinking that perhaps we'd just been unlucky enough to get two bad samples of the NEC ND-3550A, we pulled an ND-3550A from another system. Despite the fact that that third drive had been working normally in the other system, it exhibited exactly the same symptoms in our new system.

Once is happenstance. Twice is coincidence. Three times is enemy action. It seemed that the only possible explanations were that the motherboard ATA interface was bad or that the NEC ND-3550A drives were somehow incompatible with the motherboard. We'd never had a dead ATA interface out of the box on an Intel motherboard, but then we'd never seen an optical drive that was incompatible with a motherboard, either. An ATA optical drive should Just Work.

So we went back to the stock room and pulled a selection of other optical drives. We swapped them in one after the other, and every one worked perfectly. The system booted normally with several models of DVD-ROM drives, a selection of Plextor optical drives, and a BenQ DW-1650 DVD writer. Obviously, the motherboard ATA interface was working just fine. Whatever incompatibility caused our initial problems was apparently related to some interaction between the NEC ND-3550A and our D945GCZ motherboard. Oh, well. The ND-3550A is a nice optical drive, and quite inexpensive, but there are numerous other alternatives that cost about the same.

We left the BenQ DW-1650 drive in the system and went back to modify our recommended optical drive section earlier in the chapter. That's why the text recommends the BenQ DW-1650 but the images show us installing the NEC ND-3550A.

3.5.2. Configuring RAID

Intel supplies a RAID driver floppy with the D945GCZLR motherboard. During Windows XP Setup, you insert that floppy when Setup prompts you for a third-party disk subsystem driver. But before you install Windows, you must configure your RAID in BIOS Setup. To do so, restart the system and watch the screen as the system boots. When the Intel Matrix Storage Manager setup screen shown in Figure 3-62 appears, press Ctrl-I to enter the Configuration Utility.

Figure 3-62 Intel Matrix Storage Manager setup screen

You Can't Get There from Here

The "screen shots" in this section are dummies. We couldn't use our usual screen-capture utility, because when these RAID configuration screens are visible, the system hasn't finished booting yet.

At first, we tried shooting literal screenshots. That didn't work very well with our little point-and-shoot digital camera, so we set up Barbara's Pentax DSLR on a tripod. We figured that using a telephoto lens from a distance would give us reasonably good images. It didn't, or at least it didn't during several trial passes. We probably could have made it work, given enough time and effort, but we decided it'd be easier and cleaner just to create dummy "screen shots" in OpenOffice Writer to use for the illustrations. If you notice any minor differences between these illustrations and what you see onscreen, that's why.

The Intel Matrix Storage Manager Main Menu shown in Figure 3-63 appears. This screen displays the current RAID configuration, if any, and information about the disks and volumes available on the system. At this point, no RAID has been configured. Make sure the first option, Create RAID Volume, is highlighted, and press Enter to begin the process of creating the RAID.

Figure 3-63. Creating the RAID

The next step is to specify the level of your new RAID. We have only two hard drives installed, so the RAID10 and RAID5 options cannot be selected. We can choose RAID0, which offers the fastest performance at the expense of reduced data safety, or RAID1, which offers high performance and data safety at the expense of total disk capacity. We chose RAID1 to mirror our two drives, as shown in Figure 3-64. RAID1 writes the same data to two drives, so if one drive fails, no data is lost.

Figure 3-64. Choosing the RAID level

By default, Intel Matrix Storage Manager assigns all available disk space to the new array. If you want to change the amount of disk space allocated to your RAID, move the cursor to the Capacity field and enter a new value for volume size, as shown in Figure 3-65.

Figure 3-65. Specifying volume capacity

Gigabytes Versus Gibibytes

You might wonder why our two 80 GB drives show up as only 74.5 GB. It's because Seagate, like all drive makers, uses decimal notation. Seagate defines a gigabyte as 1,000,000,000 (10^9) bytes. Intel, Microsoft, and nearly everyone else uses binary notation, defining a gigabyte as 1,073,741,824 (2^30) bytes. Seagate is correct. A binary gigabyte should properly be called a gibibyte, although almost no one uses that term.

After you select the RAID level and specify the volume size, press Enter to create the new RAID volume. The Main Menu is redisplayed, as shown in Figure 3-66, updated to show the new RAID configuration.

Figure 3-66. The Main Menu displaying the final RAID configuration

3.5.3. Installing Software

With RAID configured, we booted the Windows XP SP2 distribution disc to install the OS. Early in Setup, we were prompted to press F6 if we had a third-party driver floppy. Oops. We hadn't installed a floppy drive in this system, so we pulled one off the bench, shut down the system, and temporarily connected it. Once we install the Intel RAID drivers, we'll never need that floppy drive again, and we didn't want it messing up the appearance of the front panel.

Windows XP installed uneventfully. We installed the various drivers from the Intel CD, and then used the Passmark BurnInTest utility (http://www.passmark.com) to burn in the system. The system passed with no problems. We installed the applications disc provided with the Hauppauge WinTV-PVR-150 tuner card to test TV capture functions, which worked as expected. (In fact, the Hauppauge bundled utilities are surprisingly complete; if your needs are modest, the Hauppauge utilities may be all you need for capturing TV programs.)

With Windows installed and running on this system, it was a good time to check for firmware updates. We visited the Intel web site to check for BIOS updates. We found that we already had the most recent BIOS version available, so there was no need to run the Intel Express BIOS Update utility. There was a firmware update available for the BenQ optical drive, so we downloaded and installed it.

With all of that done, we blew away our Windows installation and installed the operating system we'll really run on this system, Ubuntu 6.06 LTS Linux (http://www.ubuntu.com).

UBUNTU AND RAID

Brian Bilbrey queried us about Intel Matrix RAID support under Ubuntu Linux. As far as we know, Ubuntu doesn't support Intel Matrix RAID, which, although it's often described as hardware RAID, is in fact hybrid RAID that depends on Windows-only drivers.

We disabled Intel Matrix RAID and installed Ubuntu on the system. During Ubuntu setup, we had the choice to partition manually, and setting up RAID is one of the options. We're sure that Ubuntu software RAID is slower than hardware RAID and perhaps even Matrix RAID, but it does the job.


Section 3.6. Final Words

3.6. Final Words

Overall, we're happy with our new mainstream PC system, although it's a bit louder than we hoped it would be. The problem isn't the Antec power supply or the Seagate Barracuda hard drive, both of which are nearly inaudible. The culprit is the CPU cooler fan, which produces a noticeable buzz.

That surprised us, because recent Intel ATX CPU coolers we've used have been quiet enough to be inaudible in a typical home office environment. This one is definitely audible, although not loud enough to be intrusive. Still, others who have built similar systems have commented about how quiet this BTX cooler is, so we wonder if our CPU cooler fan is defective. When we get a chance, we may disassemble the system and replace the CPU cooler fan with a Panaflo or similar quiet model.

The other thing that surprised us was the CPU temperature. Running in a room at 23°C ambient temperature, the sensor on the Intel motherboard reports the CPU temperature as 58°C at idle and 75°C or more under load. Although those temperatures are within acceptable limits, they're about 20°C higher than we'd like to see.

Still, there's no doubt that the Pentium D 940 is a hot processor in every sense of the word, so perhaps we'll just have to get used to it. Also, motherboard temperature sensors are notoriously unreliable. In the past, we've used a thermal probe on various systems and found that the actual CPU temperature was as much as 10°C or 15°C lower than the temperature reported by the CPU temperature sensor. We hope that's the case here, although there's no convenient way to test it because the humongous BTX CPU cooler leaves us no way to get a temperature probe in contact with the processor.

But those are mere niggles. Sure, we'd like the system to run a bit quieter and a bit cooler, but its performance is top-notch. It's also rock-solid stable, as we proved by running the Passmark burn-in utility for 72 hours without a single glitch. We can't ask for much more.

For updated component recommendations, commentary, and other new material, visit http://www.hardwareguys.com/guides/mainstream-pc.html.


Chapter 4. Building a SOHO Server

One day in early 2004, our server started making funny noises. It was no big deal, as it turned out. A bearing in the supplemental case fan was failing. That was cheap and easy to fix, but it started us thinking.

Our server, that anonymous beige box where all our data lived, was an antique. As we blew the dust off it, literally and figuratively, we took stock of the hardware upon which so much of our working lives depended. An ancient Intel RC440BX motherboard. A Slot 1 Pentium III/550 processor with 128 MB of Crucial PC133 memory (we could have sworn we'd upgraded that to 256 MB). A 10 GB 7,200 RPM hard drive that Maxtor had sent us for evaluation before that drive was commercially available. A Travan tape drive from Tecmar, a company that departed the tape drive business years ago. And Windows NT Server 4. Ugh.

Although we'd made a few minor upgradesincluding mirroring the 10 GB Maxtor to a larger Seagate drivewe realized that we were several years into the 21st century and still depending on a server that dated from the late 20th century. That was good in the sense that a server should be so reliable that one simply forgets it's there. And, despite all the nasty things people say about Windows stability, that server often ran for months on end without a reboot. That's what happens when you build a machine with top-notch components, put it on a good UPS, and blow out the dust dinosaurs from time to time.

But, although that box had been a good and faithful servant, it was clearly time for a change. So we set out to design and build a server that would meet our needs then and (we hoped) for several years to come. We decided from the start that we would look to the future rather than to the past. Accordingly, we designed our server to run Linux rather than a legacy Microsoft OS. Linux is fast, free, easier to install and maintain than Windows, immensely stable, and suffers from few of the security flaws endemic to Microsoft operating systems.

We described the design and construction of that new server in the first edition of this book. Our new server turned out to be fast and reliable, but it was also much more than we really needed for our small home businessparticularly because we were using it only as a file and print serverand it was much noisier than we would have liked. Barbara had recently converted to using Xandros Linux on her main desktop system, and we decided that Barbara's desktop system was perfectly adequate as a dual-function desktop/server. So we donated our new server to a local nonprofit agency that needed a real server.

A couple of years passed, we signed a contract to write this new edition, and we decided it was again time to build a dedicated server for our own use. We work in a typical SOHO (Small Office/Home Office) environmenthalf a dozen desktop systems, some printers and other shared peripherals, and a cable-modem Internet connection. Of necessity, we designed our new SOHO server to meet our own needs. Your needs may differ from ours, though, and a SOHO server isn't a one-size-fits-all proposition. Accordingly, we've made every attempt to explain why we chose to configure our new server as we did, and how you might want to alter our configuration to suit your own requirements. In this chapter, you'll look over our shoulders as we design and build the perfect SOHO server.

Shared Versus Dedicated

If yours is a typical SOHO environment, you may wonder if you need a dedicated server. After all, it's easy enough to set up a share on a desktop system and use that box as a shared desktop/server, just as we did until mid-2006. If you have only a couple users and make few demands on a network, that may be a viable alternative. Otherwise, the security, reliability, and other advantages of a dedicated server are worth the relatively low cost.

ADVICE FROM RON MORSE

I'm not sure printers should be shared with an active workstation. A single machine can easily share workstation and file server duties, but add a printer to that mix and every incoming print job will tie up that machine totally until it is fully spooled, and the workstation will still suffer noticeably as the job spools to the printer.

Advice from Brian Bilbrey

One real downside of using a workstation as a shared server is instability. That is, a server isn't usually running a GUI, and even if it is, you're not running any of the userland apps that might cause even a Linux system to be less than stable. Not that the running OS will keel over, but if you're transferring files when the person using the shared server decides to reboot because the browser doesn't want to get un-hung... that's a bad thing.


Section 4.1. Determining Functional Requirements

4.1. Determining Functional Requirements

The problem with defining a "SOHO server" is that both words mean different things to different people. SOHO might encompass anything from 1 to 25 or more users, and a simple file and print server has very different requirements from a system that also functions as an application, database, web, and/or email server. In short, a "SOHO server" can be just about anything.

At one extreme, a SOHO server can be just a repurposed older desktop system, perhaps with a larger hard drive added. At the other extreme, a SOHO server can be a $15,000 box that uses such technologies as multiple processors, ECC memory, SCSI RAID, redundant power supplies, and so on.

As much as we believe in the advantages of building your own, we think it's a mistake to build the latter type of server, except perhaps for medium or larger companies that will have several such servers in use. A small company can no more afford extended server downtime than can a larger company, and avoiding downtime means having spares on hand. If you're running a dozen such servers, it's no great hardship to maintain a reasonable spares kit. If you're running only one server, the cost of spares can nearly double the cost of building the server.

Accordingly, for a "larger" small company that requires a powerful, sophisticated server, we recommend buying rather than building. Call IBM, buy a server that meets your requirements, and sign up for the best on-site service plan they offer. The cost of 20 people sitting around drawing their salaries while they're unable to work adds up quickly. Even a short server outage may cost the company more than you "saved" by building your own server.

Buy Blue

If you're going to do it, do it right. Don't buy from Dell or another second-tier server vendor. Don't buy HP. Buy IBM, period. We know we'll get mail from people with horror stories about their IBM servers. It happens, but not often. And we'd hear lots more horror stories if we recommended anything but IBM servers.

Most SOHO servers fall between the extremes, and it's such servers that this chapter focuses on. Tables 4-1 and 4-2 list some starting points for configuring a SOHO file or application server appropriate for your own requirements. (In reality, we'd probably not build either of the 1120 user or 20+ user configurations; we'd buy an IBM server instead.)

Table 4-1. Suggested SOHO file server configurations

15 users

610 users

1120 users

20+ users

CPU

Celeron

Sempron

Pentium 4

Athlon 64

Pentium D

Core 2 Duo

Athlon 64 X2

Opteron

Dual Opteron

Memory

512 MB

1 GB

2 GB (1 GB/core)

2 GB/CPU

Disk subsystem

S-ATA

S-ATA RAID 1

S-ATA RAID 1

S-ATA RAID 5

S-ATA RAID 0+1

S-ATA RAID 0+1

SCSI RAID 1

SCSI RAID 5

SCSI RAID 5

SCSI RAID 0+5

Ethernet interface

100BaseT

1000BaseT

1000BaseT

1000BaseT dual

1000BaseT

1000BaseT

dual 1000BaseT

Backup hardware

DVD+R

external hard drives

DVD+R

external hard drives

tape drive/changer

external hard drives

tape drive/changer

external hard drives

Table 4-2. Suggested SOHO application server configurations

15 users

610 users

1120 users

20+ users

CPU

Pentium D

Core 2 Duo

Athlon 64 X2

Pentium D

Core 2 Duo

Athlon 64 X2

Opteron

Dual Opteron

Dual Opteron

Quad Opteron

Memory

2 GB (1 GB/core)

4 GB (2 GB/core)

application dependent

application dependent

Disk subsystem

S-ATA

S-ATA RAID 1

S-ATA RAID 1

S-ATA RAID 5

S-ATA RAID 0+1

S-ATA RAID 0+1

CSSI RAID 1

SCSI RAID 5

SCSI RAID 5

SCSI RAID 0+5

Ethernet interface

100BaseT

1000BaseT

1000BaseT

1000BaseT

dual 1000BaseT

dual 1000BaseT

Backup hardware

DVD+R

external hard drives

DVD+R

external hard drives

tape drive/changer

external hard drives

tape drive/changer

external hard drives

All of these configurations assume you are running Linux, which for most situations is the best OS choice for a SOHO server. If you run a Microsoft server OS, these configurations may be marginal, particularly CPU and memory. There's no getting around it; Windows server is a pig. When it comes to server hardware, Linux takes tiny sips whereas Windows server takes great gulps.

Although we specify number of users, all users are not equal. One user who runs a CPU-intensive server-based application may put more load on an application server than a dozen users who simply retrieve and save a document or spreadsheet occasionally. The type of load also varies. A shared database that resides on the server may stress the disk subsystem but place fewer demands on CPU and memory. A client/server application that ships large amounts of data to clients may stress the network interface. A server-based application may hammer the CPU and memory but not the disk subsystem. And so on.

SCSI Versus SATA

We recommend SCSI hard drives for any server whose disk subsystem is very heavily accessed. SATA hard drives, particularly in a performance-enhancing RAID, are suitable for servers that experience light to moderate disk activity. In fact, under such conditions, SATA is often faster than SCSI. But when the disk subsystem is being hammered by a flood of disk requests, SCSI simply leaves SATA in the dust. Also, the fastest hard drives are available only in SCSI interfaces.

When you design a SOHO server, it's important to determine which server subsystems are likely to be bottlenecks and design accordingly. For example, if the server functions primarily as a database server, you might spend a significant part of your budget on a stacked SCSI RAID disk subsystem and lots of memory, and correspondingly less on CPU, the network interface, and other components. If network throughput is the bottleneck, you might install multiple Gigabit Ethernet adapters on the server and use Gigabit Ethernet switches rather than 10/100BaseT hubs or switches. Designing a SOHO server is all about balanceallocating your budget to eliminate the most important bottlenecks. Of course, each time you eliminate one bottleneck, you uncover another.

We sat down to think through our own requirements for a SOHO server. Here's the list of functional requirements we came up with:

Reliability

First and foremost, the SOHO Server must be reliable. Our server will run 24/7/365. Other than periodic downtime to blow out the dust, upgrade hardware, and so on, we expect our server to take a licking and keep on ticking.

Massive storage capacity

In the past, we routinely used lossy compression formats to cut down file sizes, storing our audio as MP3s and our digital camera images as JPEGs. Hard disk space is so inexpensive nowadays that it's no longer necessary to use lossy compression for many types of files. For example, instead of storing important digital camera images as 3 MB JPEG files, we now store them in RAW format, which produces 20 MB files. Similarly, when we rip one of our audio CDs, we no longer store the tracks in lossy MP3 format. Instead, we simply store the original, uncompressed WAV files, or convert them to FLAC files, which use lossless compression, but produce files significantly larger than MP3 or OGG files. Also, we have begun experimenting with a DV camcorder, which requires 13 GB of storage per hour of video. Obviously, we need a lot of disk space on our server. We decided that 2 TB (2000 GB) would suffice, at least to get started.

Data safety

We've never lost any data other than by our own stupidity, and we want to keep it that way. Accordingly, our initial thought was to configure our server with RAID storage. Just because it's possible to do something, though, doesn't mean it's always the best solution.

RAID prevents data loss when a hard drive fails, and can increase disk subsystem performance on a heavily loaded server. Weighed against those advantages, using RAID requires buying more hard drives (and perhaps a special RAID adapter) and doesn't protect against the more common causes of data loss, such as accidental deletion, data being corrupted by a virus or malfunctioning hardware, or catastrophic loss caused by theft or fire. Even if you have a full RAID storage system, you must still back up your data frequently to protect against loss.

We're paranoid about backup. We do daily backups of our server data directories to the local hard drive of Robert's main desktop system, and copy those backups to DVD+RW discs daily and DVD+R discs weekly. We use rsync to replicate our data continuously from the server drives to networked volumes on other systems, and we capture a snapshot of all our working data every day to external hard drives, which also contain multiple copies of our archived data. All of our video is duped to backup DV tapes. Even a catastrophic server failure would cost us at most a few minutes' work.

So, after considering the advantages and disadvantages of using RAID, we decided to use nonredundant S-ATA hard drives in our SOHO server. By giving up the small additional safety factor provided by RAID, we gain much more available hard disk space and free up at least a couple of drive bays that can be used for later expansion.

Flexibility

Initially, our SOHO server will be almost exclusively a file and print server. It will run Linux, though, so it's likely that at some point the server will transmogrify to an application server of some sort. To allow for that possibility with minimum disruption, we'll configure the server initially with enough processor and memory to allow adding functions incrementally without upgrading the hardware.

Expandability

When we set out to design our new SOHO server, we originally considered building an "appliance" system with a microATX board and a low-power processor in a small form factor case. There are a lot of advantages to such a server. It's small and so can be put anywhere. It doesn't consume much power, produces little heat, and doesn't make much noise. But as we thought about it, we realized that for us the disadvantages of a small system outweighed the advantages. However flexible our initial configuration, it's likely that at some point we will want to expand the server by adding disk space or other additional hardware. The microATX form factor is simply too limiting. With a full ATX motherboard and a larger case, we have room to grow.

Television capture

Although we have a full-blown media center system with complete PVR functionality, there may be times when it would be useful to have additional PVR capability in another system. For example, if we are watching one program on the media center system using "live-pause" while recording a second program, both tuner cards are occupied. If we need to record a second program simultaneously, we're out of luck. The SOHO server system is an ideal "backup PVR." It's lightly loaded, particularly during nonworking hours when we're most likely to want to record programs. It has plenty of disk storage, and is protected by an industrial-grade UPS.

Jim Cooley Warns

Jim commented, "Dumb idea. Why add the risk of corrupting the OS with recording software? Use it on the client and store to the server." And he has a point. But Jim is a Windows guy and we're Linux guys. We agree that installing a TV capture card on a Windows server would be a dumb idea. But Linux is much more stable than Windows. If our TV recording application crashed under Windows, there's a very good chance it would crash the server. Under Linux, if the TV recording application crashes, there's very little chance it would crash anything but itself.


Section 4.2. Hardware Design Criteria

4.2. Hardware Design Criteria

With the functional requirements determined, the next step was to establish design criteria for the SOHO server hardware. Here are the relative priorities we assigned for our SOHO server. Your priorities may of course differ.

DESIGN PRIORITIES

Price

Reliability

Size

Noise level

Expandability

Processor performance

Video performance

Disk capacity/performance

Here's the breakdown:

Price

Price is moderately important for this system. We don't want to spend money needlessly, but we will spend what it takes to meet our other criteria.

Reliability

Reliability is the single most important consideration.

Size

Size is unimportant. Our SOHO server will reside in Barbara's office, which has more than enough room for a full tower or even a double tower system.

Noise level

Noise level is unimportant for a server that sits in a server room, but in a residential or small-business environment it can be critical. Because the SOHO server will be installed in Barbara's office, it's important to minimize noise level. We'll choose quiet components whenever possible.

Expandability

Expandability is moderately important. Our server will initially have four hard drives and an optical drive installed, but we may want to expand the storage subsystem later. Similarly, although we'll use the integrated S-ATA and network interfaces initially, we may eventually install additional disk adapters, network interfaces, and so on.

Processor performance

Processor performance is relatively unimportant, at least initially. Our SOHO server will run Linux for file and print services, which place little demand on the CPU. However, we expect the server eventually to run at least some server-based applications, perhaps X11 apps that display on workstations or server-based applications such as mailman or squirrelmail. The incremental cost of installing a moderately fast dual-core processor and sufficient memory to support those expected software upgrades is small enough that we'll do it now and have done with it.

Video performance

Video performance is of literally zero importance, because we'll run our SOHO server headless. That is, we'll temporarily install a monitor while we install and configure Linux, but we'll subsequently manage the server from a desktop system elsewhere on the network. We'll either use a motherboard with integrated video, or install a video card just long enough to get Linux installed and working.

Disk capacity/performance

Disk capacity and performance are very important. Our SOHO server has only one or two simultaneous users, so standard 7,200 RPM S-ATA hard drives provide more than adequate performance. Capacity is the more important consideration for our server. We want at least 2 TB of hard disk space initially, and we'd like to be able to expand that to 4 TB or more without making major changes to the case or the existing drive subsystem. That means we'll need to use relatively few high-capacity hard drives instead of many lower-capacity drives.

4.2.1. RAID for SOHO Servers

Although we elected not to use RAID on our SOHO server, that doesn't mean RAID isn't right for your SOHO server. RAID is an acronym for Redundant Array of Inexpensive Disks. A RAID stores data on two or more physical hard drives, thereby reducing the risk of losing data when a drive fails. Some types of RAID also increase read and/or write performance relative to a single drive.

Warning

We can't say it often enough. RAID does not substitute for backing up. RAID protects against data loss as a result of a drive failure, and may increase performance. But RAID does not and cannot protect against data loss or corruption caused by viruses; accidental or malicious deletions; or catastrophic events such as a fire, flood, or theft of your server.

Five levels of RAID are defined, RAID 1 through RAID 5. RAID levels are optimized to have different strengths, including level of redundancy, optimum file size, random versus sequential read performance, and random versus sequential write performance. RAID 1 and RAID 5 are commonly used in PC servers. RAID 3 is used rarely. RAID 2 and RAID 4 are almost never used. The RAID levels typically used on SOHO servers are:

RAID 1

RAID 1 uses two drives that contain exactly the same data. Every time the system writes to the array, it writes identical data to each drive. If one drive fails, the data can be read from the surviving drive. Because data must be written twice, RAID 1 writes are a bit slower than writes to a single drive. Because data can be read from either drive in a RAID 1, reads are somewhat faster. RAID 1 is also called mirroring, if both drives share one controller, or duplexing, if each drive has its own controller.

RAID 1 provides very high redundancy, but is the least efficient of the RAID levels in terms of hard drive usage. For example, with two 500 GB hard drives in a RAID 1 array, only 500 GB of total disk space is visible to the system. RAID 1 may be implemented with a physical RAID 1 controller or in software by the operating system.

RAID 5

RAID 5 uses three or more physical hard drives. The RAID 5 controller divides data that is to be written to the array into blocks and calculates parity blocks for the data. Data blocks and parity blocks are interleaved on each physical drive, so each of the three or more drives in the array contains both data blocks and parity blocks. If any one drive in the RAID 5 fails, the data blocks contained on the failed drive can be re-created from the parity data stored on the surviving drives.

RAID 5 is optimized for the type of disk usage common in an office environmentmany random reads and fewer random writes of relatively small files. RAID 5 reads are faster than those from a single drive, because RAID 5 has three spindles spinning and delivering data simultaneously. RAID 5 writes are typically a bit faster than single-drive writes. RAID 5 uses hard drive space more efficiently than RAID 1.

In effect, although RAID 5 uses distributed parity, a RAID 5 array can be thought of as dedicating one of its physical drives to parity data. For example, with three 500 GB drives in a RAID 5 array, 1,000 GBthe capacity of two of the three drivesis visible to the system. With RAID 5 and four 500 GB drives, 1,500 GBthe capacity of three of the four drivesis visible to the system. RAID 5 may be implemented with a physical RAID 5 controller or in software by the operating system. Few motherboards have embedded RAID 5 support.

RAID 3

RAID 3 uses three or more physical hard drives. One drive is dedicated to storing parity data, with user data distributed among the other drives in the array. RAID 3 is the least common RAID level used for PC servers, because its characteristics are not optimal for the disk usage patterns typical of small office LANs. RAID 3 is optimized for sequential reads of very large files, and so is used primarily for applications such as streaming video.

Then there is the so-called RAID 0, which isn't really RAID at all because it provides no redundancy:

RAID 0

RAID 0, also called striping, uses two physical hard drives. Data written to the array is divided into blocks, which are written in an alternating fashion to each drive. For example, if you write a 256 KB file to a RAID 0 that uses 64 KB blocks, the first 64 KB block may be written to the first drive in the RAID 0. The second 64 KB block is written to the second drive, the third 64 KB block to the first drive, and the final 64 KB block to the second drive. The file itself exists only as fragments distributed across both physical drives, so if either drive fails all data on the array is lost. That means data stored on a RAID 0 is more at risk than data stored on a single drive, so in that sense a RAID 0 can actually be thought of as less redundant than the zero redundancy of a single drive. RAID 0 is used because it provides the fastest possible disk performance. Reads and writes are very fast, because they can use the combined bandwidth of two drives. RAID 0 is a poor choice for desktops and workstations, which typically do not load the disk subsystem heavily enough to make RAID 0 worth using. Heavily loaded servers, however, can benefit from RAID 0 (although few servers use bare RAID 0 because of the risk to the data stored on a RAID 0 array).

Finally, there is stacked RAID, which is an "array of arrays" rather than an array of disks. Stacked RAID can be thought of as an array that replaces individual physical disks with subarrays. The advantage of stacked RAID is that it combines the advantages of two RAID levels. The disadvantage is that it requires a lot of physical hard drives.

Stacked RAID

The most common stacked RAID used in PC servers is referred to as RAID 0+1, RAID 1+0, or RAID 10. A RAID 0+1 uses four physical drives arranged as two RAID 1 arrays of two drives each. Each RAID 1 array would normally appear to the system as a single drive, but RAID 0+1 takes things a step further by creating a RAID 0 array from the two RAID 1 arrays. For example, a RAID 0+1 with four 500 GB drives comprises two RAID 1 arrays, each with two 500 GB drives. Each RAID 1 is visible to the system as a single 500 GB drive. Those two RAID 1 arrays are then combined into one RAID 0 array, which is visible to the system as a single 1,000 GB RAID 0. Because the system "sees" a RAID 0, performance is very high. Because the RAID 0 components are actually RAID 1 arrays, the data is very well protected. If any single drive in the RAID 0+1 array fails, the array continues to function, although redundancy is lost until the drive is replaced and the array rebuilt.

HARDWARE VERSUS SOFTWARE VERSUS HYBRID RAID

RAID can be implemented purely in hardware, by adding an expansion card that contains a dedicated RAID controller, processor, and cache memory. Hardware RAID, if properly implemented, offers the highest performance and reliability and places the fewest demands on the main system processor, but is also the most costly alternative. True hardware RAID adapters cost several hundred dollars and up, and are generally supplied with drivers for major operating systems including Windows and Linux.

Software RAID requires only standard ATA or S-ATA interfaces, and uses software drivers to perform RAID functions. In general, software RAID is a bit slower and less reliable than hardware RAID and places more demands on the main system processor. Most modern operating systems, including Windows Server and Linux, support software RAIDusually RAID 0, RAID 1, and RAID 5and may also support RAID 0+1. We believe that well-implemented software RAID is more than sufficient for a typical SOHO Server.

Hybrid RAID combines hardware and software RAID. Hybrid RAID hardware does not contain the expensive dedicated RAID processor and cache memory. Inexpensive RAID adapters have limited or no onboard processing, and instead depend on the main system processor to do most or all of the work. With very few exceptions, motherboards that feature onboard RAID support, such as Intel models, use hybrid RAID, although it is sometimes incorrectly called hardware RAID. If you choose a hybrid RAID solution, make certain that drivers are available for your operating system.

RAID 1 Versus RAID 0+1

If your storage subsystem has four hard drives, there is no point to using RAID 1 rather than RAID 0+1, assuming that your motherboard or RAID adapter supports RAID 0+1. A RAID 1 uses two of the four drives for redundancy, as does the RAID 0+1, so you might just as well configure the drives as a RAID 0+1 and get the higher performance of RAID 0+1. Either RAID level protects your data equally well.

Until a few years ago RAID 0+1 was uncommon on small servers because it required SCSI drives and host adapters, and therefore cost thousands of dollars to implement. Nowadays, thanks to inexpensive S-ATA drives, the incremental cost of RAID 0+1 is very small. Instead of buying one $200 hard drive for your small server, you can buy four $100 hard drives and a $50 RAID adapter. You may not even need to buy the RAID adapter, because some motherboards include native RAID 0+1 support. Data protection doesn't come much cheaper than that.

ADVICE FROM SCOTT KITTERMAN

Linux 2.4 kernels had support for hybrid RAID, but it was dropped in 2.6, so unless a distributor has specifically added it or the hybrid RAID card vendor supplies Linux-specific drivers/kernel patches, a 2.6-based distro won't support hybrid RAID.

I discovered this the hard way when converting my old dual Pentium III 450 box with a Promise IDE RAID controller from Win2K to Ubuntu Server.

And what if you choose not to use any form of RAID, as we did? We decided to install four 500 GB hard drives in our SOHO server, configured as a JBOD (Just a Bunch of Drives). All four drives function independently as ordinary drives, and we get the full 2 TB combined capacity of the four drives. Just because we chose not to use RAID doesn't mean you should do the same. With our four 500 GB drive configuration, you can choose any of the following disk configurations without making any hardware changes.

JBOD

All four drives operate independently. The operating system "sees" 2 TB of disk capacity. Performance and data safety are determined by the performance and reliability of the individual drives. Note that, with four drives spinning, the failure of one drive is four times more likely to occur than when only one drive is spinning. If a drive fails, you lose whatever data was stored on that drive, but the data on other drives is not affected.

RAID 5

All four drives are assigned to the RAID 5. The operating system sees 1.5 TB of disk capacity. (The equivalent of one drive's capacity is used to store parity data, although that data is actually distributed across all four drives.) Read and write performance for small files is the same or slightly faster than with individual drives. Read and write performance for large files is slightly slower than with individual drives. RAID 5 offers moderate redundancy. Any one drive may fail without loss of data. If two drives fail simultaneously, all data on the array is lost.

RAID 0+1

All four drives are assigned to the RAID 0+1, as in effect a RAID 0 pair of RAID 1 mirrored drives. The operating system sees 1 TB of disk capacity. Read performance for any size file is noticeably faster than JBOD or RAID 5, particularly when the drives are heavily loaded. Write performance is slower. RAID 0+1 offers very high redundancy. Any two drives may fail without loss of data, as long as they are not both members of the same RAID 1. If both drives in a RAID 1 fail simultaneously, all data on the array is lost.

With the hardware configuration we detail later in this chapter, you can choose any of these disk configurations during setup. You don't even need to pop the lid or move any cables. But give some serious thought to which configuration to use. If you change your mind later, you can reconfigure the disk subsystem, but you'll need to back up all of your data and re-store it after you set up the new configuration.


Section 4.3. Component Considerations

4.3. Component Considerations

With our design criteria in mind, we set out to choose the best components for the SOHO server system. The following sections describe the components we chose, and why we chose them.

Your Mileage May Vary

Although we tested the configuration we used to build our own SOHO server, we did not test permutations with the listed alternatives. Those alternatives are simply the components we would have chosen had our requirements been different. That said, we know of no reason the alternatives we list should not work perfectly.

4.3.1. Case

Antec P180 Advanced Super Mid-Tower Case (http://www.antec.com)

SOHO servers can be built in anything from full-tower cases specifically designed to house servers down to the smallest of small form factor cases. True server cases are usually large, heavy, and expensiveoverkill for a typical SOHO server. Either that, or they are rack-mount (or blade) cases, and few homes or small offices have need of an equipment rack. (Robert tried to convince Barbara that an equipment rack was just what we needed, but she put her foot down.)

To fill the void, many case manufacturers offer so-called "SOHO server cases," which are usually just standard tower or mini/mid-tower cases with lockable front panels. Whether you're building a SO server or a HO server, you probably don't need the small additional security provided by a lockable front panel, so we suggest you also consider more mainstream case styles.

The key considerations for a SOHO server case are the number of drive bays it provides and its cooling efficiency. In a residential or small business environment, noise level and appearance may also be important. For us, all four of those factors were important. We wanted at least half a dozen hard drive bays to accommodate our initial disk configuration while leaving drive bays available for future expansion. Effective cooling is critical for obvious reasons. Noise level is important because this server will live in Barbara's office, which is across the hall from our master bedroom. Appearance is important because Barbara refuses to have an ugly box sitting in her office.

For all of these reasons, we chose the Antec P180 case, shown in Figure 4-1.

Figure 4-1. The Antec P180 case

The Antec P180 provides a total of 11 drive baysfour external 5.25" bays, one external 3.5" bay, and six internal 3.5" bays. Allocating one 5.25" bay to the optical drive leaves room for as many as nine hard drives, which should suffice for the life of the system.

The Antec P180 offers the best cooling of any case we have ever tested. It uses dual interior chambers, isolating the power supply from the rest of the system, which simplifies cooling. (The downside is that you must choose a power supply that is compatible with the P180; not all power supplies have cables long enough to reach the motherboard and drive connectors from the location of the power supply in the bottom chamber.) The P180 comes standard with three 120mm fansone rear, one top, and one in the lower chamber to cool the power supply. There are mounting positions for two optional 120mm fans, one in front and one in the middle to cool the graphics card.

The P180 is also the quietest case we've ever tested, despite its effective cooling. Antec engineered this case to be as quiet as possible, incorporating such features as silicone grommets to isolate the hard drives from the chassis and aluminum-plastic-aluminum composite panels to absorb noise.

ALTERNATIVES: CASE

If you're building a SOHO server on a tighter budget but you still need lots of drive bays, consider using the Antec Titan550 or Atlas server cases or the TX1088AMG SOHO tower case. If a mid-tower case is large enough, consider the Antec P150. All of these cases include Antec TruePower power supplies, which are of excellent quality. Do not underestimate the importance of a high-quality power supply when you build a server. You can buy less expensive cases, but they include inferior power supplies.

Appearance is a matter of taste, but we think the P180 is the most attractive case we've ever used. We wouldn't hesitate to have it in our den, library, or living room, let alone our offices. If you prefer something darker than the aluminum-and-black color scheme of the P180, consider the P180B, which is the same case in all-black.

The only real downside to the Antec P180 is the price. It sells for about $125, not including a power supply. A good power supply suitable for our SOHO server costs $75 to $100, taking the total price to $200 or more. But for that price, you get what we consider to be the best case on the market, with top-notch expandability, cooling, and noise level.

4.3.2. Power Supply

Antec NeoHE 550 (http://www.antec.com)

The P180 case does not include a power supply, which gave us the opportunity to choose the power supply best suited for our SOHO server. The power supply is a critical component for a server that will run 24 hours a day, every day, year after year. Although reliability was paramount, we also wanted a power supply that was quiet and efficient. Quiet, because this server will reside in Barbara's office, which is directly across the hall from our master bedroom. Efficient, because high efficiency reduces power consumption, which makes it easier to cool the system and allows the fans to run slower and quieter.

Figure 4-2. Antec NeoHE power supply

We also decided to oversize the power supply, because a power supply that runs at a fraction of its rated output is more efficient, quieter, and much more reliable than one that runs near its rated output. An oversize power supply also makes upgrades easier. If in the future we decide to add more hard drives, expansion cards, memory, or a faster processor, the existing power supply will suffice to carry the extra load. Accordingly, although a 400W unit might have been adequate, we decided to look for a 500W or 550W unit.

We looked at quiet, high-efficiency power supplies from Antec, Enermax, PC Power & Cooling, Seasonic, and others, keeping in mind the need for long cables for use in the P180 case. Many of those units are excellent power supplies, but we chose the Antec NeoHE 550 power supply for its combination of high quality, very low noise, and reasonable price.

ALTERNATIVES: POWER SUPPLY

The Antec TruePower 2.0 550 is a bit less expensive than the NeoHE 550, but is also a bit louder. The Antec Phantom 500 is more expensive than the NeoHE 550 and has looser voltage regulation (5% versus 3%), but is utterly silent except when it is running under a heavy load. If you use a case other than the P180, consider the Seasonic S12-500 (500W) or the Seasonic S12-600 (600W) units, which are very quiet and very efficient.

4.3.3. Processor

Intel Pentium D 820 (http://www.intel.com)

Processor performance is a minor consideration for a file/print server. In fact, if this server were to be used only for file/print duties, even the slowest current processor would do the job with Linux. But, although this server will provide only file and print services initially, we expect it to last for years with few upgrades, and we may eventually run some applications on it. Accordingly, it made sense to choose a faster processor that would give us some horsepower in reserve.

At the time we built this server, Intel had just introduced their new-generation Core 2 Duo (Conroe) processors. Usually, Intel sets a significant price premium on such new products, but in this case Intel priced their new processors at mainstream levels. That left no "price umbrella" for the older models, which began selling at fire sale prices.

We were able to pick up a retailed-boxed Pentium D 820 dual-core processor for about $100, so for the price of a "value" processor we obtained a very capable dual-core processor. (Although Intel has de-emphasized its older models, it did not discontinue them; we expect this processor or a similar model to be available well into 2007.) The retail-boxed Pentium D processor comes with a three-year warranty and a surprisingly effective and quiet CPU cooler.

It may seem strange to choose an obsolescent processor for our SOHO server, but cutting-edge technology is the last thing we want for a server. We want proven technology, and the Pentium D provides that in spades. The fact that the Pentium D costs less than newer models with similar performance is just a nice bonus.

ALTERNATIVES: PROCESSOR

If you're on a very tight budget, even a $50 value processor is fast enough for a small Linux-based SOHO file and print server. Spending $100 on a Pentium D is worthwhile if you expect your server to function as an application server, now or in the future.

If we were building an AMD-based server, we'd choose whichever retail-boxed Socket 939 Athlon 64 we could get for about $100. Dual-core Athlon 64 X2 models are simply out of our price range, and Socket AM2 processors (and particularly Socket AM2 motherboards) are too new for us to be comfortable using them, at least for a server.

4.3.4. Motherboard

Intel D945PVSLKR (http://www.intel.com)

Choosing the Intel Pentium D processor means we need a compatible Socket 775 motherboard. We wanted an Intel-branded motherboard, because we have found Intel motherboards to be the most reliable of any brand we have tested. Intel-branded motherboards also offer top-notch compatibility and driver support, whether you run Linux or Windows Server.

945 OR 946?

We built this system in Summer 2006. The Intel Core 2 Duo processor and motherboards that support it were not yet widely available. In anticipation of their new processors and motherboards, Intel deeply discounted their older products, pricing them too attractively for us to refuse. If we were building this system now, we'd probably use an Intel Core 2 Duo and an Intel 946- or 965-series motherboard.

Any Intel-branded motherboard based on the 945P or 945G chipset would probably have worked well, but we chose the Intel D945PVSLKR model. Although the D945PVS lacks integrated video and costs more than 945G models like the D945GNT, we chose it for two reasons. First, we happened to have a new D945PVS sitting unused in our inventory room. More important, we plan to run the Server Edition of Ubuntu 6.06 LTS (Long Term Support) on our SOHO Server. Robert ran the Desktop Edition of Ubuntu 6.06 LTS extensively on his main workstation, which usesyou guessed itan Intel D945PVSLKR motherboard and a Pentium D processor. Based on that experience, we knew with absolute certainty that Ubuntu 6.06 was fully compatible with the D945PVSLKR and fully supported its hardware features. We decided that the $30 higher cost of the D945PVSLKR relative to the D945GNT was cheap insurance.

ALTERNATIVES: MOTHERBOARD

If you're on a tight budget, consider one of the Intel D945GNT models, which are available with or without integrated RAID support, with 100BaseT versus 1000BaseT integrated LAN, and so on. For an AMD-based SOHO server, choose an ASUS Socket 939 motherboard that uses an nVIDIA chipset.

CHECK COMPATIBILITY

If we'd chosen a different motherboard, we might have used the Pentium D 805 processor, which is a bit slower than the Pentium D 820 model we used, but which cost $20 less. Fortunately, we checked the processor compatibility list for the D945PVSLKR motherboard before we ordered the processor. We found that the D945PVSLKR supported every Pentium D processor except the 805.

In fact, no Intel-branded motherboard listed the Pentium D 805 as compatible, and the Intel compatibility page for the Pentium D 805 listed only one MSI-branded motherboard as supported. We suspect that's because the Pentium D 805 is a "special" processor. Intel introduced it primarily to allow Dell and other OEMs to build inexpensive systems that could be advertised as "dual-core" models.

Before you order your motherboard and processor, make sure that the motherboard you intend to use supports the exact processor model you are ordering. Significantly different processor models may have similar names or model numbers, so always check the full model number for compatibility.

Also verify that the BIOS version installed on the motherboard supports the processor you install. Quite often, a more recent processor is supported by a particular motherboard, but not unless you install an updated BIOS. Of course, that often introduces a "can't get there from here" problem, because you can't update the BIOS without a working processor, and the processor isn't supported by the existing BIOS. In that situation, either return the motherboard and ask for one with a current BIOS, or temporarily install a supported processor, update the BIOS, and then remove that processor and install the one you intend to use.

What Does PVSLKR Mean, Anyway?

Intel and some other motherboard manufacturers use trailing letters or numbers or some similar means of designating slightly different variants of a motherboard model. For example, although the Intel D945PVS motherboard is available in only one variant, the similar D945GNT motherboard is available in three models, all with the same basic features, but each with different options.

The D945GNTL includes only integrated 10/100 Ethernet. The D945GNTLKR adds 1000BaseT Ethernet support, as well as three IEEE-1394a (FireWire) ports, a Trusted Platform Module, and support for Intel Matrix RAID. The D945GNTLR drops back to the 10/100 Ethernet and eliminates the Trusted Platform Module, but includes the FireWire ports and Matrix RAID support, and adds better integrated audio and a digital optical-out connector.

When you order a motherboard, make sure to check available options and variants. Otherwise, you may find you've ordered a motherboard that doesn't include the options you thought you were getting.

4.3.5. Memory

Crucial CT6464AA40E PC3200 DDR2 DIMMs (512 MB x 4) (http://www.crucial.com)

We could analyze the memory requirements of a Linux SOHO server all day long, but what's the point? Memory is inexpensive, so it's a false economy to install too little. In our 20 years of dealing with servers, we've never heard anyone complain that his server had too much memory.

In terms of memory requirements, using a dual-core processor is essentially the same as using dual processors. To avoid memory bottlenecks, it's a good idea to install twice as much memory for a dual-core processor as you would for a single-core processor. Our Linux SOHO server could probably get along initially with 1 GB (512 MB/core), but the incremental cost of installing 2 GB (1 GB/core) was less than $100, so we decided to install 2 GB.

The Intel D945PVS motherboard provides four memory slots, and supports a maximum of 4 GB of memory. We could have installed two 1 GB modules for 2 GB totalwhich would leave two memory slots available for future expansionor four 512 MB modules. At the time we ordered memory for this system, two 1 GB modules cost about $30 more than four 512 MB modules. After thinking about it, we decided that we were unlikely to upgrade the memory in this server beyond 2 GB, so we decided to save the $30 and install four 512 MB modules.

We chose four 512 MB Crucial CT6464AA40E PC3200 DDR2 memory modules, using the online Crucial product selector to ensure compatibility with our D945PVS motherboard. The motherboard supports DDR2-400 (PC3200), DDR2-533 (PC4200), and DDR2-667 (PC5300) memory modules. Although Crucial offers PC4200 and PC5300 modules for this motherboard, those modules are more expensive. PC3200 is fast enough for the processor we chose and for any upgrade processor we're likely to install later.

ALTERNATIVES: MEMORY

Any Crucial or Kingston DDR2 memory modules that are compatible with the motherboard. Compare prices for modules of various capacities before you decide which modules to install.

4.3.6. TV Tuner

Hauppauge WinTV-PVR-500MCE (http://www.hauppauge.com)

Although it is not a primary function, we wanted our server to function as a backup to our primary media center system. The media center system has two analog tuner cards and one HDTV tuner card, which should suffice for most of our television recording needs. Still, there may be times when we want to record additional programs when the media center system is fully occupied.

So we decided to add a TV tuner card or cards to our server. The only question was which model to install. Because our server will run Linux, we needed a tuner card that was supported by MythTV, the most popular and featureful PVR application available for Linux. Obviously, we required top-notch video quality. To minimize the load on the CPU we wanted a card that provided hardware-based MPEG encoding.

After comparing the specifications and reviews of several tuner cards, we decided to use a Hauppauge WinTV-PVR-500MCE, shown in Figure 4-3. Hauppauge is the gold standard in TV tuner cards. Hauppauge tuner cards have the best capture quality of any we have used, and are supported by nearly every PVR application available, under both Windows and Linux.

Figure 4-3. Hauppauge WinTV-PVR-500 tuner

Hauppauge offers several models, including some that bundle a remote control that is compatible with Windows Media Center Edition (MCE). We don't intend to run MCE, and we have no need of a remote control because this system will function only as a "back end" for recording. (Remember, our server runs headless, so we'll control recording setup from another system elsewhere on the network.) We narrowed our choices to the WinTV-PVR-150 single-channel tuner card and the WinTV-PVR-500 dual-channel tuner card.

The PVR-150 is less expensive and by some reports offers very slightly better recording quality. (The PVR-500 splits a single TV-in cable connector; the second F-connector visible in the image is FM-in.) Conversely, the PVR-500 costs less than two PVR-150 cards, and occupies only one expansion slot. We decided the small additional cost of the PVR-500 was worthwhile in exchange for the additional flexibility of having a second tuner available. When we're on vacation, for example, we can shut the rest of the house down, leaving only the server running, and still be able to record two programs simultaneously.

ALTERNATIVES

Whether you run Linux or Windows, Hauppauge tuner cards are the best choice. If you decide to equip your server with a tuner card, choose whichever Hauppauge model best suits your own requirements.

4.3.7. Hard Disk Drives

Seagate Barracuda 7200.9 Serial ATA (500 GB x 4) (http://www.seagate.com)

The disk subsystem of our SOHO server must be capacious, fast, and reliable. Capacious, because this server will store all of the data we want to keep online, including large DV video files. Fast, because the server will sometimes be hammered by clients accessing large amounts of data. Reliable, well, for obvious reasons.

ALTERNATIVES: HARD DISK DRIVES

As far as brand names, none. We recommend Seagate drives, period. As far as disk configuration, choose your own poison. If the small increase in data safety provided by RAID is worth the cost to you, install a RAID. Otherwise, do as we did and configure your disk subsystem as standard drives.

Capacity

Our target for capacity was 2 TB (2,000 GB). The largest hard drives available when we built this system held 750 GB, so clearly we needed multiple hard drives to meet our capacity requirement. We decided to use four 500 GB drives. For about $100 more, we could have installed three 750 GB drives, and used only three drive bays. For about $100 less, we could have used five 400 GB drives, at the expense of using one more drive bay. But doing that would have required adding an S-ATA interface card for the fifth hard drive, which would have reduced the cost benefit of using five drives to about $50. The economics will be different when you build your system, so balance the cost versus the number of drive bays and S-ATA interfaces required when you order your drives.

The Intel D945PVS motherboard provides four Serial ATA interfaces, just enough for our purposes, and allows the drives connected to those interfaces to be configured as standard drives or a RAID. If we need the entire capacity of all drives to appear as one volume, we can use the operating system disk management utilities to concatenate those four physical drives into one logical volume. If multiple volumes are acceptable, we can simply install the four drives normally and partition and format them as separate volumes.

Performance

In olden days, we used SCSI hard drives on all but the smallest servers. Nowadays, although SCSI is still desirable for large, heavily loaded servers, most SOHO servers can use standard Serial ATA drives with little or no performance hit. Modern S-ATA drives like the Seagate 7200.9 and 7200.10 Barracuda models provide performance features such as large caches and NCQ (Native Command Queuing) that were formerly available only on SCSI models. For our purposes, Serial ATA drives provide more than enough performance, particularly with the load distributed among four spindles.

Reliability

For a desktop system, we sometimes use the RAID support integrated on many motherboards to build a RAID 1 (mirrored) array. All that is required is a second hard drive, at the small cost of $50 to $75, to eliminate the risk of data loss from a hard drive failure.

But RAID 1 is impractical for our 2 TB server, for which a RAID 1 would require four additional hard drives. In addition to the significant expense of four additional 500 GB hard drives, we'd have to install a separate RAID adapter to provide additional S-ATA interfaces, and we'd end up with nearly all of our drive bays occupied. Also, that add-on RAID adapter, unless we were able to find a PCI Express model, would put an unacceptably high load on the PCI bus of our server. Accordingly, we decided to risk running a standard disk configuration, with no redundancy.

There are different kinds of reliability. First, of course, is the inherent reliability of the hardware itself. Seagate Barracuda S-ATA drives are extremely reliable, as any data recovery firm knows. We (and our readers) have had fewer failures with Seagate drives than with any other brand. A clean, well-ventilated system with reliable power protection contributes further to drive reliability. And, although we could nearly eliminate the small risk of data loss caused by a drive failure by using RAID, that protection comes at a very high price for a 2 TB drive configuration.

Which brings up the final type of reliability, procedural reliability. Our procedures replicate our data, both manually and automatically, to numerous locations, from network shares to optical discs to external hard drives. A failed hard drive on the server might cost us at most a few minutes' work, depending on which drive failed. Chances are that a drive failure will lose no work at all, but simply require replacing the failed drive and restoring the data to it from backup. We can live with that.

Strength in Numbers

One of the advantages of having several hard drives installed is that it gives you a great deal of flexibility. With four drives, for example, we can easily configure our disk subsystem as a RAID 0, RAID 1, RAID 5, RAID 10, or JBOD.

Several of our readers who reviewed early drafts of this book questioned our sanity when they read of our plans to run a server without disk redundancy. To that, we plead long experience with the reliability of Seagate hard drives and our rigorous backup procedures. Still, they got us thinking about RAID 5. Perhaps we'll settle for a 1.5 GB RAID 5. Better still, we may upgrade to four 750 GB hard drives and set up a 2.25 TB RAID 5.

4.3.8. External Hard Drives

Build-them-yourself

The first decision is whether to buy purpose-built external hard drives or to build them yourself using bare hard drives and external enclosures. Each has advantages, although on balance we've come to prefer home-built external drives.

Commercial external hard drives are available from Seagate, Maxtor, Western Digital, and many other companies. Their major advantage over a home-built external hard drive is that they typically bundle Dantz Retrospect, CMS Bounceback Express, or similar backup software that allows you to initiate a backup just by pressing a button on the external drive. (Of course, that software works only if you run Windows on your server, and in some cases the software is limited to workstation versions of Windows rather than Windows Server.) The major drawbacks of commercial external hard drives are limited choice of configuration, relatively high cost, and short warrantiesoften a year or less versus five years on a standard hard drive.

Home-built external hard drives have many advantages. By choosing the appropriate enclosure, you can have a USB 2.0, FireWire, or e.SATA external interfaceor any of the two, or all three in one device. (We generally use USB 2.0 for maximum compatibility with any system we might need to restore to in an emergency, but it's nice to have the choice.) Enclosures are available to support old-technology ATA hard drives as well as current S-ATA models, so you can use an enclosure to convert an otherwise useless older ATA drive into a useful backup device. External enclosures offer complete flexibility because they accept essentially any standard hard drive. That means you can build an external hard drive using anything from a small, slow, inexpensive drive to the latest high-capacity barn burner. Giving up the one-touch convenience of commercial models can save you a lot of money, particularly if you need several external drives. The total cost of a new hard drive and enclosure may be only 50% to 75% the cost of a commercial model of similar capacity. Finally, with a home-built external drive, you get the standard five-year warranty on the hard drive instead of a one-year warranty. (Presumably, hard drive manufacturers offer shorter warranties on external drives because their mobility makes them more subject to damage than a similar hard drive installed internally in a nice, safe computer case.)

ALTERNATIVES: EXTERNAL HARD DRIVES

If you prefer commercial external hard drives, we recommend Seagate models. As an alternative to external hard drives, consider a frame-carrier system, such as those made by StorCase (http://www.storcase.com). The frame mounts in a standard drive bay, and accepts carriers that contain a standard hard drive. In the past, these frame-carrier systems had a real advantage. Although they were more costly than external enclosures, they used the standard ATA interface, which transfers data faster than USB 2.0. The availability of FireWire and e.SATA external drives has eliminated this advantage, so frame-carrier systems are no longer as popular as they were. Still, many people prefer them and there's certainly nothing wrong with using one.

If you decide to roll your own, choose your external enclosure carefully. The first decision is which internal and external interfaces to use. A few enclosures support both ATA and S-ATA internal interfaces, although most have only one or the other. (Some are designed for SCSI hard drives, but that is beyond the scope of this book.) Any enclosure provides one or more external interfaces, which may be USB 2.0, FireWire, or e.SATA, in any combination. If high data transfer rates are important to you, choose a model that provides FireWire and/or e.SATA external interfaces. Otherwise, USB 2.0 is sufficient and has the advantage of compatibility with any computer built in the last several years.

There is a strong correlation between the price of an external enclosure and its quality. Cheap enclosures are of mostly plastic construction, and are quite flimsy and unreliable. Better enclosures use a metal chassis and generally have better quality connectors and power bricks. Some enclosures, particularly more expensive models, provide very robust internal power and data connectors, which means you can swap drives in and out of them as necessary. Others, including every inexpensive model we've seen, use less robust internal connectors. They're fine if all you plan to do is install the drive and use it until it drops, but they're not really intended to allow drives to be swapped in and out frequently.

Our "default" choice is the KingWin TL-35CS Night Hawk model. At $40 or so, it's twice as expensive as the cheapest models, but it's built like a tank and extremely reliable. It has only a USB 2.0 external interface, which suffices for our needs. We don't use FireWire for external drives, and so have no experience upon which to base a recommendation. For an e.SATA enclosure, we recommend the Vantec NST-360SU, which includes an external USB 2.0 interface.

TECH HELP
Backing Up the Beast

If you're concerned about how to back up a 2 TB disk subsystem, you're not alone. For us, the problem actually isn't as bad as it first appears. Not all of the data on our server needs to be backed up. For example, we may eventually have hundreds of gigabytes of digital video stored on our server. That data is already "backed up" in the sense that we still have the original DV tapes, as well as duplicates of those tapes, so it is not in danger of being lost if a hard drive fails. Similarly, Barbara's collection of several hundred audio CDs will be stored as .wav files on the server. If those files are lost, they can easily be retrieved from the original CDs. Some of the files on the server, such as copies of television programs recorded by our media center system, are really just backup copies anyway.

Still, that leaves a significant amount of data that does need to be backed up. Optical drives are neither large enough nor fast enough to back up this amount of disk space. Although tape changers with sufficient speed and capacity are available, we'd have to sell our yacht to afford one. And we don't own a yacht.

So what's left? External e.SATA/FireWire/USB 2.0 hard drives, which we suggest you look at not as hard drives, but as funny-looking backup tapes. Using compression, a 500 GB external hard drive can typically store between 750 GB and 1 TBdepending on the compressibility of the datawhich is more than sufficient to store the critical data from our 2 GB disk subsystem. If the disk subsystem is of smaller capacity or the amount of data stored on the server does not exceed the capacity of the external drive, you can make an exact copy without compression, which makes it trivially easy to restore.

A USB 2.0 external drive can transfer about 25 MB/second, which translates to about 90 GB/hour. FireWire 400 is nearly twice as fast, although the transfer rate of the hard drive itself may limit you to something less than the 40+ MB/s rate of the FireWire interface. An e.SATA external drive is limited only by the transfer rate of the hard drive. With any of these interfaces, you can transfer a terabyte or more of data overnight, which is sufficient for all but the largest SOHO servers. And, at well under $0.50/GB, the cost of hard drive space is the same or lower than the cost of backup tapes.

We recommend buying (or buildingsee the "External Hard Drives" section) at least two or three e.SATA/FireWire/USB 2.0 external hard drives and using them, just as you would tapes, to back up your server. If you gulp at spending a few hundred dollars on external drives, just think for a moment about the cost of losing all of your data. You might think RAID is sufficient protection for your data. It isn't. RAID prevents data loss when a drive fails, period. It doesn't prevent accidental deletions or corrupted files. Nor does it prevent catastrophic data loss caused by fire or theft. The only way to protect against such dangers is to have an off-line, off-site copy of your data, ideally more than one copy. e.SATA/FireWire/USB 2.0 external hard drives are the only affordable solution we know of for backing up a large SOHO array.

But external hard drives are only part of the solution. A weekly full backup is a good start, but a proper backup plan requires backing up changed files at least daily. Such incremental backups are much smaller than full backups, but are essential to recovering files changed since the previous full backup. As for full backups, it is important that these incremental backups be stored off-line and off-site. We recommend one of the following methods, depending on how much data you need to back up daily:

  • DVD writerA DVD writer stores about 4 GB (6 GB to 8 GB with compression) to a $0.20 DVD+R disc, or about 8 GB (11 GB to 15 GB with compression) to a $3 DVD+R/DL disc. A 16X or 18X writer, such as the Plextor PX-760A, fills a disc in just a few minutes. A DVD writer is appropriate for incremental backups if your server has many small files or several relatively large files changed on a daily basis.

  • External hard driveexternal e.SATA/FireWire/USB 2.0 hard drives are as good a solution for incremental backups as they are for full backups. We keep several, one or another of which is always connected to Robert's desktop system, where it used frequently during the working day to make quick backups of our working data directories. When we leave the house, the current external hard drive goes with us, as well as the external hard drive that contains the most recent full backup. If disaster happens, at least we won't lose any data.

When it comes to preventing data loss, we recommend the belt-and-suspenders method. In addition to backing up to external hard drives and optical discs, we frequently copy changed files to other network volumes using Windows batch files or rsync. If you value your data, you should do the same.

ADVICE FROM BRIAN JEPSON

Our editor, Brian Jepson, comments, "I have seen these wonderful nonenclosures (http://www.wiebetech.com) that are nothing more than the FireWire to ATA bridge, no case. So, if you're buying a pile of drives and want to avoid paying for an enclosure for each of them, you can just snap the drive into the drive dock when you need to use it and put the drive on the shelf when you are done."

4.3.9. Optical Drive

NEC ND-3550A DVD writer (http://www.necus.com)

Our SOHO server runs headless, so in theory it doesn't really need a DVD writer. We'll back it up across the network and to removable hard drives. The only reason we'll use the optical drive in this system is for installing software and perhaps for infrequent periodic maintenance. Still, the NEC DVD writer costs only $30, so it was pointless to install a read-only optical drive. Although we can't foresee the circumstances, one day having that writable optical drive installed might be a lifesaver. (As our old friend Mandy frequently says, "It could happen.")

ALTERNATIVES: OPTICAL DRIVE

Any good name-brand DVD-ROM drive or DVD writer. We generally use models from BenQ, Lite-On, Pioneer, Plextor, or NEC. After several bad experiences, we avoid models from HP, LG, and Sony.

4.3.10. Keyboard, Mouse, and Display

Because this SOHO server runs Linux, we need a keyboard, mouse, and display only for initial installation and configuration. Once the server is running, we can manage it remotely from one of our desktop systems.

WINDOWS VERSUS LINUX

Yes, we know about Windows Remote Desktop, but it's not the same. Remote Desktop provides limited remote management functions, but some management tasks must still be done from a monitor and keyboard physically connected to the server. Linux remote management tools allow us to do almost anything remotely that doesn't require changing hardware.

4.3.11. UPS

Falcon Electric SG Series 1 kVA On-Line UPS (http://www.falconups.com)

Running a server without a UPS is foolish. Even a momentary power glitch can corrupt open databases, trash open documents, and crash server-based apps, wiping out the work of everyone connected to the server. A UPS may literally pay for itself the first time the power fails.

We used and recommended APC UPSs for many years. Then, after we experienced several premature failures of APC units and received numerous messages from readers about their increasingly frequent problems with APC units, we decided to look elsewhere. On the advice of our friend and colleague Jerry Pournelle, we looked at Falcon Electric UPSs, which turned out to be as good as Jerry said they were. (Years ago, an earthquake rattled Chaos Manor, knocking everything over. All of Jerry's equipment failed, except the Falcon Electric UPS, which just kept running, lying on its side amidst the debris of his computer room.) We've now used Falcon Electric units exclusively for a couple of years, without so much as a hiccough.

Falcon Electric units are built to industrial standards. They cost more than consumer-grade systems, although we found the actual price difference surprisingly small. You won't find them at online resellers or big-box stores, but they are readily available from numerous distributors. Check the Falcon Electric web site for details.

Our server connects to the 1 kVA Falcon Electric SG Series On-Line UPS that was already located in Barbara's office, protecting her desktop system. That unit has plenty of reserve capacity to protect the server as well, so there was no need to install a separate UPS for the server. Note that the Falcon Electric SG is a true online UPS. Falcon also sells less expensive line-interactive models that offer similar functionally to mass-market models from APC and others, but are substantially better built. Table 4-3 lists our component choices for a SOHO Server system.

Table 4-3. Bill of materials for SOHO server

Component

Product

Case

Antec P180

Power supply

Antec NeoHE 550

Motherboard

Intel D945PVSLKR

Processor

Intel Pentium D 820 (retail boxed)

CPU Cooler

(Bundled with processor)

Memory

Crucial PC2-3200 DDR2 (4 x 512 MB)

TV tuner

Hauppauge WinTV-PVR-500MCE

Video adapter

(None permanent; integrated or temporary for setup only)

Sound adapter

(Integrated)

Hard drive

Seagate Barracuda 7200.9 SATA (four 500 GB)

External hard drives

Seagate 500 GB drives in Kingwin USB 2.0 enclosures

Optical Drive

NEC ND-3550A DVD writer

Keyboard

(None)

Mouse

(None)

Speakers

(None)

Display

(None)

UPS

Falcon Electric 1 kVA SG Series On-Line UPS

ALTERNATIVES: UPS

We think it's worth spending some additional time and effort to get a Falcon Electric UPS. Even though they cost a bit more than consumer-grade units with similar capacity and features, the Falcon Electric units really are better built and more reliable. If the Falcon Electric units are out of your price range, we think the APC Smart-UPS units remain the best of the mass-market UPSs, despite the problems we've had with them. (We've had more problems with other brands.) For those on an even tighter budget, the APC Back-UPS Pro and Back-UPS units are reasonable choices.

If you've decided to forego a UPS entirely, we suggest you think again. Any power protection is better than none at all. Even the inexpensive units that look like outlet strips are better than nothing. Their runtime is very short, but even a few seconds of backup power is often sufficient. If you buy one of these inexpensive units, just make sure that the VA rating is high enough to support the draw of your server. Also be aware that the built-in surge and spike suppression in these units is often very poor, so it's worthwhile to install a good surge protector between the power receptacle and the UPS.


Section 4.4. Building the SOHO Server

4.4. Building the SOHO Server

Figure 4-4 shows the major components of the SOHO server. The Antec P180 case is flanked on the left by the Intel Pentium D processor and Intel D945PVS motherboard. To the right of the case, a Kingwin external drive enclosure sits atop the Falcon Electric UPS and the Antec NeoHE power supply. Four 500 GB Seagate Barracuda 7200.9 hard drives are visible at the lower left. The NEC ND-3550A DVD writer is front and center, with four 512 MB sticks of Crucial DDR2 memory sitting on top of it. Finally, the Hauppauge WinTV-PVR-500 dual tuner card is visible at the lower right.

Make sure you have everything you need before you start building the system. Open each box and verify the contents against the packing list.

Figure 4-4. SOHO server components, awaiting construction

HE GOT UP, GOT DRESSED, AND TOOK A SHOWER

As always, you needn't follow the exact sequence of steps we describe when you build your own SOHO server. Always install the processor and memory before you install the motherboard in the case, because doing otherwise risks damaging the processor, memory, or motherboard. The exact sequence doesn't matter for most other steps. Some steps must be taken in the order we describe, because completing one step is required for completing the next, but as you build your system it will be obvious when sequence matters.

4.4.1. Preparing the Case

As much as we like the Antec P180 case, using it involves a bit more work than a typical case requires. To begin preparing the case, remove both thumbscrews from the left side panel, as shown in Figure 4-5, and then slide the panel to the rear and remove it from the case, as shown in Figure 4-6.

Figure 4-5. Remove both thumbscrews from the left side panel

Figure 4-6. Slide the panel to the rear and remove it from the case

For some reason, Antec decided to use ordinary screws rather than thumbscrews on the right side panel. Remove the three screws that secure the panel, as shown in Figure 4-7. Remove the panel and set it aside.

Figure 4-7. Remove the three screws that secure the right side panel

The Antec P180 has two hard drive cages. One, located in the upper chamber of the case, holds three hard drives. The second, located in the lower chamber, holds four hard drives. We decided to install our hard drives in the lower cage. The number of positions happens to match the number of hard drives we are installing, but that wasn't the main reason for our decision. Putting the four hard drives at the bottom of the case places the center of gravity lower, which makes the system easier to move around safely. Most important, the lower drive cage is very well ventilated, with both the power supply fan and a supplemental fan constantly drawing cool outside air over the drives.

To remove the lower drive cage, remove the one thumbscrew that secures it, as shown in Figure 4-8, and then slide the drive cage out of the chassis, as shown in Figure 4-9. (We used a screwdriver because the thumbscrew was very tight.)

Figure 4-8. Remove the thumbscrew that secures the lower hard drive cage

Figure 4-9. Pull the drive cage out of the chassis

Remove the parts box, as shown in Figure 4-10. When we pulled out this box, we assumed it would contain screws and other small parts. Not so. It contains the spoiler for the fan mounted on the top of the case.

Figure 4-10. Remove the parts box from the hard drive cage

Remove the screws that secure the black plastic VGA ventilation duct and drive rail holder, as shown in Figure 4-11. Pull the duct straight out, as shown in Figure 4-12, and set it aside for now.

Figure 4-11. Remove the screws that secure the VGA ventilation duct and drive rail holder

Figure 4-12. Remove the VGA ventilation duct and set it aside

Removing the ventilation duct reveals the black plastic sliding panel assembly shown in Figure 4-13. Loosen both of the thumbscrews that secure this panel and slide the panel all the way toward the rear of the case to clear the opening into the power supply bay, as shown in Figure 4-14.

Figure 4-13. Loosen the two thumbscrews that secure the sliding panel

Figure 4-14. Slide the panel fully to the rear of the case to open the access hole to the power supply bay

With these steps complete, it's time to install the power supply.

4.4.1.1. Assembling and installing the power supply

It still seems strange to us to talk about "assembling" a power supply. Most power supplies are ready to use out of the box, with all of their cables permanently attached. Several Antec power supply models, including our NeoHE, are different. They use a patented cable-management system that allows you to connect only the cables you actually need for your system, eliminating the rats' nest of unused cables.

Warning: The Antec NeoHE power supply is auto-sensing, which means that it automatically detects the input voltage and sets itself accordingly. Many power supplies are not autosensing, and must be set manually for 120V or 240V input. If you use such a power supply, make certain to set the input voltage switch correctly.If the switch is set to 240V and you connect the power supply to a 120V receptacle, nothing bad happens. The motherboard and other components get half the voltage they require, and simply don't run. But if the switch is set to 120V and you connect the power supply to a 240V receptacle, the components get twice the voltage they require. You'll realize your mistake immediately, as your new system disappears in a shower of sparks and clouds of smoke.

Figure 4-15 shows the NeoHE power supply and a selection of optional cables. Only the main ATX power cable and the ATX12V power cable are permanently connected. All other cables are optional. These optional cables use a proprietary plug on one end that connects to a matching proprietary jack on the power supply.

Figure 4-15. Antec NeoHE power supply with optional cables

Our system has four S-ATA hard drives, so we'll need to install two of the optional S-ATA power cables, each of which provides two connectors. We'll also install one or two Molex cables, which use the old-fashioned Molex hard drive connectors. We'll need those to power the optical drive as well as the case fans. Finally, we'll install one of the two optional PCI Express power cables that Antec includes with this power supply. We probably won't need that cable, but we'd prefer to have it available in case the video card we install temporarily to use while we do the initial software installation requires a PCI Express power cable.

Figure 4-16 shows Barbara connecting one of the optional cables to the power supply. One of the proprietary jacks is visible immediately to the right of the cable she's connecting. Note that the connector is keyed both by the shapes of the individual holes in the connector and by the keying tab visible at the top of the jack. Press each optional cable into a jack until it seats completely, which may require some pressure. After you seat each cable, tug gently on it to make sure that it's locked into place.

Figure 4-16. Connect the optional cables to the power supply

With the power supply prepared, the next step is to remove the power supply retaining cage. The retaining cage is secured by four screws, two on each side of the case. Remove those screws, as shown in Figure 4-17, and then slide the retaining cage out of the case, as shown in Figure 4-18.

Figure 4-17. Remove the four screws that secure the retaining cage

Figure 4-18. Slide the retaining cage out of the case

Orient the power supply so that its rear screw holes correspond with those in the back of the case, and then place the retaining cage over the power supply, as shown in Figure 4-19. This bracket was a very tight fit on our power supply. When we pressed the bracket down flush on the top of the power supply, the bottom of the retaining cage was forced outward, as is visible in Figure 4-19. At first, we thought we'd have to assemble the system without the retaining cage, but as it turned out we were able to use it, although it was a very tight fit.

Figure 4-19. Place the retaining cage over the power supply

Don't install the power supply and retaining cage assembly in the case quite yet. Instead, place the assembled unit near the rear of the case, with the cable side of the power supply toward the case. Feed all of the power cables up through the rear access hole into the upper chamber, as shown in Figure 4-20. Feed the main ATX power cable (the one with the largest connector) through first. We learned this by experience. We'd fed all the other cables through first, and attempted to feed the main ATX power cable through last. With the other cables already in place, there wasn't room for the main ATX power cable to fit through the access hole.

Figure 4-20. Feed all of the cables through the large (rear) hole into the upper chamber

Slide the assembled power supply and retaining cage assembly into the case, as shown in Figure 4-21. As you do so, take up the slack in the cables by pulling them gently into the upper chamber of the case. The goal is to have as little of the cables as possible remaining in the lower chamber, where they would block the air flow.

Figure 4-21. Slide the assembled power supply and retaining cage into position

Once the power supply and retaining cage assembly are in place, secure the retaining cage with four screws, as shown in Figure 4-22. (The white box on the white cable visible at the front of the power supply is a temperature sensor.)

Figure 4-22. Secure the power supply retaining bracket to the case with four screws

To complete installation of the power supply, insert the four mounting screws provided with the power supply to secure the power supply to the rear panel of the case. (With eight screws securing it, that power supply isn't going anywhere.)

4.4.1.2. Installing the hard drives

With the power supply installed, the next step is to install the hard drives in the lower hard drive cage. This cage requires special mounting screws, which Antec supplies. For years, we've played the hide-the-screws game with Antec. Once or twice, we were convinced Antec hadn't included them, but each time we eventually found the cunningly concealed storage box.

We spent a couple of minutes looking around for the secret storage box this time, but without success. Where had they put it this time? Finally, we admitted defeat and looked in the manual, which told us the storage box was attached to the "back of the upper HDD cage." Hmmm. "Back" to us meant the open part of that cage, visible in Figure 4-24 with metal drive mounting rails protruding. Obviously, it wasn't there. Perhaps they meant the front of the hard drive cage, visible as a black plastic assembly to the right of the cage.

Figure 4-24. Slide the upper hard drive cage out of the case

Accessing that area requires removing the hard drive cage. To do so, remove the one thumbscrew securing the upper hard drive cage, as shown in Figure 4-23, and then slide the cage out of the case, as shown in Figure 4-24. (Once again, the thumbscrew was tightened enough that we found it easier to use a screwdriver to remove it.)

Figure 4-23. Remove the thumbscrew that secures the upper hard drive cage

As it turns out, the secret storage box is attached to the right side of the upper hard drive cage assembly. It's actually visible from the right side of the case when the panel is removed. We spotted it there after reading the manual, but with the limited clearance around the box, Robert wasn't able to open the latch, nearly breaking a fingernail in the attempt. With the upper hard drive cage removed, the secret storage box is easily accessible.

Open the latch, as shown in Figure 4-25, and remove the plastic baggie of screws and other small parts.

Figure 4-25. Open the secret storage box and remove the baggie of screws

Once you've retrieved the baggie, close the latch, slide the upper hard drive cage back into place, and reinsert the thumbscrew to secure it.

The next step, as shown in Figure 4-26, is to feed the S-ATA power cables from the upper chamber down through the front (smaller) access hole in the sliding panel assembly and into the area of the lower hard drive cage. For the time being, feed the full lengths of the S-ATA power cables down into the lower hard drive cage area. You'll need as much slack as possible when you connect the drives.

Figure 4-26. Feed the S-ATA power cables from the upper chamber to the front lower chamber

With four hard drives in this system, it's a good idea to do a little advance planning. The Seagate Barracuda 7200.9 drives are remarkably reliable. Chances are they'll all keep running until years from now when you decide to replace them with larger drives. Still, hard drives are mechanical devices, and even the most reliable mechanical devices sometimes fail.

If the hard drive fails in a typical system, there's no ambiguity. There's only one hard drive, and it failed. Even if the system has two hard drives, chances are good that one was installed as an upgrade and they're of different models or capacities. Identifying the failed drive is usually straightforward.

But we have four identical hard drives in this system. What happens if one fails? The operating system or BIOS tells us that, say, hard drive #2 has failed. Great. Which one is #2? They all look the same, so the only way to identify the failed drive is to trace the cable from the motherboard interface port to the drive. That can be easier said than done in an assembled system.

Spending an extra 30 seconds now can save you an hour of aggravation if a drive does fail. Simply use a permanent felt-tip marker to label both sides of both ends of all four cables, as shown in Figure 4-27. We keep it simple. The S-ATA interfaces are designated 0, 1, 2, and 3. We simply draw 0, 1, 2, or 3 bars across each cable to match it to an interface and drive. If a drive does fail, it's immediately clear which drive it is.

Figure 4-27. Label the S-ATA data cables to identify the port and drive they connect

After you label the cables, feed them through the access hole from the upper chamber of the case into the lower front chamber, as shown in Figure 4-28. Just leave them dangling for now.

Figure 4-28. Feed the S-ATA data cables from the top chamber to the lower chamber

The next step is to mount the four hard drives in the lower hard drive cage, as shown in Figure 4-29. Use the special screws from the baggie that was in the secret storage box. These screws have a very wide head and a long shaft, of which only the lower part is threaded. Secure each drive with four of these screws, driving them through the white silicone grommets. (These grommets fall out of the cage easily. If you lose one, locate the spare grommets in the secret storage box baggie.) Drive the screws in far enough to compress the grommets slightly. Driving them in too far squishes the grommet and eliminates its ability to isolate drive vibrations from the chassis structure.

Figure 4-29. Secure each hard drive with four special mounting screws

Once you have secured all four drives in the lower hard drive cage, connect an S-ATA data cable to each drive, as shown in Figure 4-30. The S-ATA data cable is keyed with an L-shaped notch. Align the cable connector with the drive connector and press firmly to seat the cable connector. S-ATA data connectors are relatively fragile. Avoid putting any torque on the connectors, or they may break off. Press the cable connector straight in to seat it. If you need to remove a cable, pull straight out on the connector.

Figure 4-30. Connect an S-ATA data cable to each drive

ADVICE FROM JIM COOLEY

Because the connectors are so fragile, I use a white-out pen to draw a stripe across the connector and its block to make reconnecting them easier in the future.

By convention, we mount multiple drives with drive 0 in the topmost or leftmost bay. In fact, when we are using only two drives, we sometimes forget to label the cables (as we did when we built the Mainstream PC).

With all four S-ATA data cables connected, the next step is to connect the S-ATA power cables, as shown in Figure 4-31. Like the S-ATA data cables, the S-ATA power cables are keyed with an L-shaped slot. The power cables are also at least as fragile as the data cables, so take care when connecting or disconnecting them.

Figure 4-31. Connect an S-ATA power cable to each drive

With all of the S-ATA data and power cables connected, the next step is to reinstall the lower hard drive cage, as shown in Figure 4-32. Guide the cage into the chassis, using your left hand to press the excess cable lengths up into the upper chamber. Once again, the goal is to minimize the amount of cable in the lower chamber to provide as little impediment as possible to air flow. Once the drive cage is fully seated, secure it with one thumbscrew, as shown in Figure 4-33.

Figure 4-32. Slide the lower hard drive cage into position, feeding the cables into the upper chamber

Figure 4-33. Secure the lower hard drive cage with one thumbscrew

4.4.1.3. Installing the I/O template and standoffs

Like most cases, the Antec P180 comes with a generic back-panel I/O template installed. We're not sure why case makers bother, because the generic template almost never matches the motherboard back-panel I/O ports. Remove the installed template by pressing gently along its edges from the outside of the case until the template pops loose. If the template is well and truly stuck, as sometimes happens, don't worry too much about bending it. You won't need it later.

With the original template removed, the next step is to install the template supplied with the motherboard. Before you do so, hold the template up against the motherboard rear-panel I/O ports to verify that the holes are in the right places. Although it doesn't happen often, we've received motherboards that included an incorrect template.

Working from inside the case, position the I/O template in the cutout, as shown in Figure 4-34, making sure that the lip on the edge of the template seats against the edge of the cutout. Once the I/O template is aligned, press gently against its edges until it snaps into place. If you have trouble seating the I/O template, use a screwdriver handle to apply even pressure until one corner seats, and then run the handle along the edges of template to seat it.

Figure 4-34. Position the I/O template in the case cutout and press until it snaps into place

The final step in preparing the case is to install standoffs to support the motherboard. Although the standoff positions are standardized, different motherboards use different subsets of the available standoff positions. Also, different cases come with standoffs preinstalled in various positions.

In addition to supporting the motherboard physically, standoffs provide electrical grounding points, so it's important to install a standoff that corresponds to each motherboard mounting hole. It's just as important to make sure that no standoffs are installed that don't have a matching motherboard mounting hole. An "extra" standoff can cause a short circuit in the motherboard. If that happens, the best outcome is that the system just won't boot. If you're unlucky, a short circuit may damage the motherboard, processor, memory, or other components.

The best way to ensure that there's a standoff for every mounting hole and a mounting hole for every standoff is to count the preinstalled standoffs and then count the mounting holes in the motherboard. With the clutter of components on the motherboard, it's easy to miss a mounting hole. We hold the motherboard up to a light, which makes the mounting holes stand out. (Don't include the CPU cooler mounting holes in your count. These four holes form a square pattern around the CPU socket, and don't require standoffs.)

Pen and Paper

One of our technical reviewers recommends another method. Place the motherboard flat on a large sheet of paper and use a felt-tip pen to make a large dot on the paper under each mounting hole. Then place the paper in the case with two of the dots aligned with two corresponding standoffs. Press the paper down until the standoffs puncture the paper. Continue pressing the paper down until it is flat against the bottom of the case. Each of the large dots on the paper should have a standoff protruding through it, and there should be no standoff protruding where there is no dot.

Once you have located all of the mounting holes, slide the motherboard into position, with the back-panel I/O ports mated to the corresponding holes in the I/O template, and examine each mounting hole to see if a standoff is visible. Count the visible standoffs, and compare that number with the number of preinstalled standoffs you counted earlier. The numbers should match. If they don't, one or more of the preinstalled standoffs needs to be removed. If no standoff is visible beneath a mounting hole, install a standoff as shown in Figure 4-35.

Figure 4-35. Remove any unneeded standoffs and install standoffs where they are needed

The Intel D945PVS motherboard has 11 mounting holes. The Antec P180 case has nine standoffs preinstalled, all of which correspond to mounting holes in the motherboard. If you use this case and motherboard you need install only two standoffs.

4.4.2. Populating the External Drive Bays

The Antec P180 case provides four externally accessible 5.25" bays and one externally-accessible 3.5" bay. We'll fill one of the 5.25" bays with the NEC ND-3550A optical drive, and the 3.5" bay with the port-expander supplied with the Intel D945PVS motherboard.

4.4.2.1. Installing the optical drive

We decided to install the NEC ND-3550A DVD writer in the upper bay. Before installing the drive you have to remove the plastic bezel that covers the drive bay and the metal RF shield plate that is concealed by the bezel. To remove the bezel, simply pull gently with your finger until it snaps out, as shown in Figure 4-36. With the plastic bezel removed, the metal RF shield plate is visible. Twist that plate back and forth until the metal tabs snap, and then remove it from the case.

Figure 4-36. Remove the bezel to prepare the bay to receive the optical drive

ADVICE FROM JIM COOLEY

Save those bezels! If you remove an optical drive, replacing the bezel will help maintain proper air circulation inside the case.

The P180 case uses drive rails for mounting the optical drive. Locate the white cardboard box that was stored in the lower hard drive bay. In addition to the spoiler for the top vent, this box contains a pair of 5.25" drive rails. Install the drive rails on the ND-3550A drive, as shown in Figure 4-37, using two screws to secure each rail. Position the metal spring tabs forward and angled outward, with the front lip of the spring tab flush with the rear surface of the drive bezel. The drive rails should be just above the centerline of the drive, which you can accomplish by driving the screws into the rear hole in each group of three holes in the rails.

Figure 4-37. Install the drive rails on the optical drive

Before you install the optical drive, verify the master/slave jumper settings, and slide the drive partway into the bay to verify you've positioned the rails correctly. Like most optical drives, the NEC ND-3550A DVD writer is set by default to be the master device on the ATA channel. Our hard drives are S-ATA, so the optical drive will be the only parallel ATA device in the system, and should be set as the master device on the ATA channel. If you use a different optical drive, verify that its jumper is set to master.

It's usually easier to connect the ATA cable to the drive before you install the drive in the case. The Intel D945PVS motherboard comes with a round 40-wire ATA cable, which we used. Because optical drives have relatively slow transfer rates, they can use the older 40-wire ATA cable rather than the 80-wire Ultra-ATA cable used for ATA hard drives. (An 80-wire cable works fine if that's all you have, but it's not necessary.)

To connect the cable, locate pin 1 on the drive connector, which is nearest the power connector. The pin 1 side of the cable is indicated by a red stripe. Align the cable connector with the drive connector, making sure the red stripe is on the pin 1 side of the drive connector, and press the cable into place, as shown in Figure 4-38. Nowadays, most optical drives and ATA cables are keyed with a protruding tab on the cable connector and a corresponding notch on the drive connector.

Figure 4-38. Connect the ATA cable to the optical drive

ADVICE FROM JIM COOLEY

Pin 1 is almost always positioned closest to the power connector. I've never seen this otherwise.

To mount the optical drive in the case, feed the loose end of the ATA cable through the drive bay from the front, align the drive rails with the corresponding tracks in the case, and slide the drive into the bay, as shown in Figure 4-39. Make sure the drive rails snap into place to secure the drive.

Figure 4-39. Slide the optical drive into the drive bay until the rails snap into place

The final step in installing the optical drive is to connect power to the drive. Choose one of the power cables coming from the power supply and press the Molex connector onto the drive power connector, as shown in Figure 4-40. It may require significant pressure to get the power connector to seat, so use care to avoid hurting your fingers if the connector seats suddenly. The Molex power connector is keyed, so verify that it is oriented properly before you apply pressure to seat the power cable.

Figure 4-40. Connect the power cable to the optical drive

Color Contrast

Most people would choose a black optical drive for the P180 case. We chose a silver model instead. The silver drive bezel closely matches the silver portions of the P180 case, and the silver drive bezel makes it easier to locate the drive in the dimly lit area under Barbara's desk.

4.4.2.2. Installing the front-panel port expander

The Antec P180 case provides five front-panel ports: two USB, one IEEE-1394 (FireWire), one audio-in, and one audio-out. The Intel D945PVS motherboard provides port connectors for four USB ports, two FireWire ports, one audio-in, and one audio-out. That means two USB ports and one FireWire port for which connections are available on the motherboard go unused in a standard configuration.

For a server, we don't care about audio, but more USB ports are always welcomeparticularly if they're easily accessible from the frontand a second FireWire port might be very handy indeed. Fortunately, Intel includes a front-panel port expander with the motherboard. The port expander installs in a 3.5" external drive bay, and provides two USB ports, one FireWire port, and a pair of audio ports. The audio ports are superfluous, but the other ports match up nicely with the "extra" port connectors on the Intel motherboard.

The Antec P180 has only one externally accessible 3.5" drive bay, so installing the port expander rules out installing a floppy drive or card reader (although we could use an adapter to mount any of those devices in an available 5.25" bay). We didn't plan to install a floppy drive or card reader in this server, so using the bay for the port expander was no sacrifice.

To install the port expander, use the same procedure you used to install the optical drive. Remove the plastic bezel that covers the 3.5" bay and twist the metal RF shield back and forth until it breaks loose. The white cardboard box that contained the rails for the optical drive also contains a set of 3.5" rails. Attach these rails to the port expander, as shown in Figure 4-41, positioning the metal spring tabs forward and angled outward. Secure the rails with two screws on each side, using the rear set of screw holes in the port expander and the rear of each group of three screw holes in the rails. When the rails are properly installed, the bottom of each rail should be flush with the bottom of the port expander, and the metal spring clips should be flush with the front bezel.

Figure 4-41. Install drive rails on the optical drive

Feed the cables on the back of the port expander through the bay from the front and then slide the port expander into the bay, as shown in Figure 4-42. Make sure that the rails snap into place to secure the port expander. With the port expander installed, our SOHO server now has four front USB 2.0 ports, two front IEEE-1394a (FireWire) ports, and two pairs of audio ports, one pair of which will remain disconnected. (Later, we'll apply tape over the unused audio port pair to provide a clear indication that those ports are unusable.)

Figure 4-42. Slide the port expander into the bay until it snaps into place

4.4.3. Preparing and Populating the Motherboard

It is always easier to prepare and populate the motherboardinstall the processor and memorywhile the motherboard is outside the case. In fact, you must do so with some systems, because installing the CPU cooler requires access to both sides of the motherboard. Even if it is possible to populate the motherboard while it is installed in the case, we always recommend doing so with the motherboard outside the case and lying flat on the work surface. More than once, we've tried to save a few minutes by replacing the processor without removing the motherboard. Too often, the result has been a damaged processor or motherboard.

Warning: Each time you handle the processor, memory modules, or any other static-sensitive components, first touch the power supply to ground yourself.
4.4.3.1. Installing the Processor

To install the Pentium D processor, press the lever slightly away from the socket to unlatch it, as shown in Figure 4-43. Then lift the lever straight up until it comes to a stop vertical or slightly past vertical.

Figure 4-43. Lift the socket lever to unlock the metal retention plate

With the lever vertical, the metal retention plate is unlocked and free to swing up and away from the socket. Pivot the retention plate up and remove the plastic socket protector, as shown in Figures 4-44 and 4-45. Keep the plastic socket protector in the motherboard box, in case you ever remove the processor. The exposed Socket 775 connectors are very fragile, and should never be left unprotected.

Figure 4-44. Lift the metal retention plate to expose the socket contacts

Figure 4-45. Snap the plastic socket protector out of the retention plate

With the plastic retention plate removed, as shown in Figure 4-46, the socket is prepared to receive the processor.

Figure 4-46. The socket prepared to receive the processor

Remove the processor from its container. The contact side of the processor is covered by a plastic protector. Hold the processor by its edges, as shown in Figure 4-47, and snap the protector away from the processor. Store that protector with the processor box, in case you ever remove the processor. Always reinstall the protector when you store a bare processor.

Figure 4-47. Remove the plastic protector from the processor

Keying is indicated on the processor by a small gold triangle and on the socket by a matching beveled edge. The socket also has two protruding nubs that correspond to notches in the processor, one of which is visible in the figure just to the right of the gold triangle at the lower-left corner of the processor.

With the metal retention plate vertical, align the processor with the socket and drop the processor into place, as shown in Figure 4-48. The processor should seat flush with the socket just from the force of gravity. If the processor doesn't simply drop into place, something is misaligned. Remove the processor and verify that it is aligned properly. Never apply pressure to the processor. You'll bend one or more pins, destroying the socket (and the motherboard).

Figure 4-48. Drop the processor into place

With the processor in place and seated flush with the socket, lower the metal retention plate, as shown in Figure 4-49. If the processor is fully seated in its socket, the retention plate should freely seat flush with the top of the processor. Note the lip on the lower right of the retention plate and the corresponding cammed area of the clamping lever. When the retention plate is properly closed, the cammed portion of the clamping lever should engage that lip as the clamping lever is moved to the latched position.

Figure 4-49. Close the retention plate

With the retention plate closed, close the socket latching lever, as shown in Figure 4-50. Make certain that the lever is locked in place by the hook on the side of the socket.

Figure 4-50. Lock the processor into the socket

4.4.3.2. Installing the CPU cooler

With the processor locked in its socket, the next step is to install the CPU cooler. We used a retail-boxed Intel Pentium D processor, which includes a quiet and effective CPU cooler. Before you install the CPU cooler, use a paper towel to polish the surface of the CPU heat spreader, as shown in Figure 4-51. The idea is to remove any skin oil or other foreign matter that might prevent the CPU cooler from making good thermal contact with the processor.

Figure 4-51. Polish the processor heat spreader with a paper towel

The stock Intel cooler has a pre-applied thermal pad on the surface that contacts the CPU. Our cooler had a bare pad, but we have seen Intel coolers with a plastic or paper film covering the thermal pad. If there's film covering the thermal pad on your cooler, peel it off before you proceed.

Position the CPU cooler over the processor socket, aligning the four posts of the cooler mounting assembly with the four corresponding holes in the motherboard, as shown in Figure 4-52. The four mounting holes form a square, so you can orient the CPU cooler any way you please. We generally orient the cooler so that the CPU fan cable has as little slack as possible after it's connected to the power header pins on the motherboard. Once you have aligned the CPU cooler with the mounting holes, press down each of the four mounting posts and rotate them until they lock into place, as shown in Figure 4-53.

Figure 4-52. Align the CPU cooler over the processor socket

Figure 4-53. Press down all four mounting posts and rotate them to the locked position to secure the CPU cooler

The last step required to install the CPU cooler is connecting the CPU fan power lead to the 4-pin CPU fan connector on the motherboard, as shown in Figure 4-54. The cable connector and motherboard connector are keyed to prevent misaligning the pins or connecting the cable backward. Align the cable connector with the motherboard header pins and press the connector into place until it seats completely.

Figure 4-54. Connect the CPU cooler fan lead to the motherboard CPU fan header

4.4.3.3. Installing memory

Installing memory is always easy, but this time it's easier than usual. Because we're populating all four memory slots in the D945PVS motherboard with identical memory modules, we don't have to make any decisions about which modules should be installed in which slots. (If you're using a different motherboard or installing only two memory modules, make sure you install the modules in the proper slots to enable dual-channel memory operation. See the motherboard manual.)

To install the memory modules, pivot the locking tabs on both sides of all four DIMM sockets outward. Examine the contact side of a DIMM to locate its keying notch. Position the DIMM vertically above a memory slot, with the keying notch in the DIMM aligned with the keying tab in the slot, and slide the DIMM into place, as shown in Figure 4-55.

Figure 4-55. Orient the DIMM with the notch aligned properly with the socket

With the DIMM properly aligned with the slot and oriented vertically relative to the slot, use both thumbs to press down on the DIMM until it snaps into place, as shown in Figure 4-56. The locking tabs should automatically pivot back up into the locked position when the DIMM snaps into place. If they don't, close them manually to lock the DIMM into the socket. Install the three remaining DIMMs the same way.

Figure 4-56. Seat the DIMM by pressing firmly into the slot until it snaps into place

With the processor and memory installed, you're almost ready to install the motherboard in the case. Before you do that, check the motherboard documentation to determine if any configuration jumpers need to be set. The Intel D945PVS has only one jumper, which sets operating mode. On our motherboard, that jumper was set correctly by default, so we proceeded to the next step.

4.4.4. Installing the Motherboard

Installing the motherboard is time consuming because there are so many cables to connect. It's important to get them all connected properly, so check each connection before and after you make it.

4.4.4.1. Seating and securing the motherboard

To begin, slide the motherboard into the case, as shown in Figure 4-57. Carefully align the back panel I/O connectors with the corresponding holes in the I/O template, and slide the motherboard toward the rear of the case until the motherboard mounting holes line up with the standoffs.

Figure 4-57. Slide the motherboard into position

Do one final check to make absolutely certain that there's a standoff installed for each mounting hole and that no extra standoffs are installed. Before you secure the motherboard, make sure the back panel I/O connectors mate cleanly with the I/O template, as shown in Figure 4-58. Make sure none of the metal grounding tabs on the I/O template intrude into a port connector. Although we've never seen a system actually damaged by an errant tab, we have worked on a few systems that exhibited mysterious boot failures that turned out to be caused by a tab protruding into a USB port.

Figure 4-58. Verify that the back panel connectors mate cleanly with the I/O template

After you position the motherboard and verify that the back panel I/O connectors mate cleanly with the I/O template, insert a screw through one mounting hole into the corresponding standoff. You may need to apply pressure to keep the motherboard positioned properly until you have inserted two or three screws.

If you have trouble getting all the holes and standoffs aligned, insert two screws but don't tighten them completely. Use one hand to press the motherboard into alignment, with all holes matching the standoffs. Then insert one or two more screws and tighten them completely. Finish mounting the motherboard by inserting screws into all standoffs and tightening them, as shown in Figure 4-59.

Figure 4-59. Install screws in all mounting holes to secure the motherboard

With high-quality products like the Antec P180 case and the Intel D945PVS motherboard, all the holes line up perfectly. With cheaper brands, that's not always the case. At times, we've been forced to use only a few screws to secure the motherboard. We prefer to use all of them, both to physically support the motherboard and to make sure all of the grounding points are in fact grounded, but if you can't get all of the holes lined up, simply install as many screws as you can.

After you've inserted all of the motherboard mounting screws, make one final check to verify that all of the ports on the back-panel I/O connector are clear of the metal grounding tabs on the I/O template.

4.4.4.2. Connecting front-panel switch and indicator cables

With the motherboard secured, the next step is to connect the front panel switch and indicator cables to the motherboard. Before you begin connecting front panel cables, examine the cables. Each is labeled descriptively, e.g., "Power," "Reset," and "HDD LED." Match those descriptions with the front panel connector pins on the motherboard to make sure you connect the correct cable to the appropriate pins. The motherboard header pins are color-coded. Figure 4-60 shows the pin assignments for the Hard Drive Activity LED (yellow), Reset Switch (purple), Power LED (green), and Power Switch (red) connectors.

Figure 4-60. Front panel connector pin assignments (graphic courtesy of Intel Corporation)

  • The Power Switch and Reset Switch connectors are not polarized, and can be connected in either orientation.

  • The Hard Drive Activity LED is polarized, and should be connected with the ground (black) wire on Pin 3 and the signal (red) wire on Pin 1.

  • The Power LED connector on the Intel motherboard accepts a two-position Power LED cable. Like other Intel motherboards, the D945PVS also provides an alternative three-pin Power LED connector with pins in positions one and three. The Power LED connector is dual-polarized, and can support a single-color (usually green) Power LED, as is provided with the Antec P180 case, or a dual-color (usually green/yellow) LED. If you are using a case that has a dual-color Power LED, check the case documentation to determine how to connect the Power LED cable.

Once you determine the proper orientation for each cable, connect the Hard Drive Activity LED, Reset Switch, Power LED, and Power Switch cables to the motherboard, as shown in Figure 4-61. Not all cases have cables for every connector on the motherboard, and not all motherboards have connectors for all cables provided by the case. For example, some cases provide a speaker cable. The Intel D945PVS motherboard has a built-in speaker, but no connector for an external speaker, so that cable goes unused. Conversely, the Intel D945PVS has a Chassis Intrusion Connector, for which no corresponding cable exists on the Antec P180 case, so that connector goes unused.

Figure 4-61. Connect the front-panel switch and indicator cables

Despite Their Best Intentions

Intel has defined the standard front-panel connector block shown in Figure 4-61 and uses that standard for its current motherboards. Unfortunately, few other motherboard makers adhere to that standard. Accordingly, rather than provide an Intel-standard monolithic connector block that would be useless for motherboards that do not follow the Intel standard, most case makers, including Antec, provide individual one-, two-, or three-pin connectors for each switch and indicator. A few cases provide both a monolithic Intel connector block and individual wires for nonstandard motherboards. If your motherboard provides the monolithic connector block, use it to minimize the risk of connecting the cables incorrectly.

When you're connecting front-panel cables, try to get it right the first time, but don't worry too much about getting it wrong. Other than the power switch cable, which must be connected properly for the system to start, none of the other front-panel switch and indicator cables is essential, and connecting them wrong won't damage the system. Switch cablespower and resetare not polarized. You can connect them in either orientation, without worrying about which pin is signal and which ground. LED cables may or may not be polarized, but if you connect a polarized LED cable backward, the worst that happens is that the LED won't light. Most cases use a common wire color, usually black, for ground, and a colored wire for signal.

4.4.4.3. Connecting front-panel USB ports

The Antec P180 case provides two front-panel USB 2.0 ports. Both are routed through one cable that terminates in an Intel-standard 10-pin monolithic USB connector block. The Intel D945PVS motherboard provides two internal dual-USB ports, which are black connectors located at the left front of the motherboard, near the S-ATA connectors. The two front-panel USB ports on the case require only one of these internal connectors, leaving the second one available to connect the front-panel port expander we installed earlier.

Other cases provide individual wires rather than a monolithic USB connector block. If your case has individual wires, refer to Figure 4-62 for the pin assignments for the dual front-panel internal USB connectors.

Figure 4-62. Front-panel USB connector pin assignments (graphic courtesy of Intel Corporation)

To route USB to the front panel of the P180, simply connect the USB cables from the front of the case and from the port expander to the corresponding internal connectors, as shown in Figures 4-63 and 4-64. It doesn't matter which cable you connect to which internal USB connector.

Figure 4-63. Connect the front-panel USB cable from the case

Figure 4-64. Connect the front-panel USB cable from the port extender

4.4.4.4. Connecting the front-panel IEEE-1394a (FireWire) ports

The Antec P180 case provides one front-panel FireWire (IEEE-1394a) port. The Intel D945PVS motherboard provides two internal FireWire connectors. We'll connect the front-panel FireWire cable to one of those internal FireWire connectors, and the port expander FireWire cable to the second one.

Although the Antec P180 case provides a front-panel FireWire cable with an Intel-standard monolithic connector block, many cases provide only individual wires that must be connected one by one to the FireWire header on the motherboard. Figure 4-65 shows the pinouts for the internal FireWire connector.

Figure 4-65. Front panel IEEE-1394a (FireWire) connector pin assignments (graphic courtesy of Intel Corporation)

Connect one of the FireWire cables to one of the blue internal FireWire connectors, as shown in Figure 4-66, and the second FireWire cable to the second connector visible immediately below Barbara's finger, as shown in Figure 4-67. Once again, it doesn't matter which FireWire cable you connect to which FireWire internal connector. With the standard back-panel FireWire connector, our system now has three available FireWire ports, which should be more than enough for our purposes.

Figure 4-66. Connect the front-panel FireWire cable from the case

Figure 4-67. Connect the front-panel FireWire cable from the port

4.4.4.5. Connecting the front-panel audio ports

The Antec P180 case provides two front-panel audio ports, line out and mic in. The port expander adds a second set of audio ports. Obviously, audio is unimportant on a server, but we decided to connect one set of ports (the set on the case itself) just for completeness. To enable the front-panel audio ports, connect the audio cable to the front-panel audio header pins at the back-left corner of the motherboard, as shown in Figure 4-68. That leaves the audio ports on the port expander unconnected. As a matter of good practice, we used a piece of tape to cover those disabled ports.

Figure 4-68. Connect the front-panel audio cable

4.4.5. Installing the Tuner Card

As long as we have the system on its side, we might as well install the Hauppauge WinTV-PVR-500 tuner card. To begin, remove the four screws that secure the black plastic vent shroud above the expansion slot covers, as shown in Figure 4-69. Pull the shroud off and put it aside.

Figure 4-69. Remove the four screws that secure the black plastic vent shroud

The next step is to choose an expansion slot in which to install the card. Position the card temporarily to determine which slot cover bracket it aligns with. Once you're sure you're removing the correct slot cover bracket, remove the screw that secures the bracket, as shown in Figure 4-70.

Figure 4-70. Remove the screw that secures the expansion slot cover bracket

With the screw removed, slide the expansion slot cover bracket up and tilt it toward the inside of the case, as shown in Figure 4-71. Remove the bracket completely and set it aside for now.

Figure 4-71. Remove the expansion slot cover bracket

Slide the Hauppauge WinTV-PVR-500 card into position, making sure that the card contacts are aligned with the expansion slot. Using your thumbs, press down on the card, as shown in Figure 4-72, until you feel the card snap into place in the expansion slot. After you seat the card, reinsert the slot cover screw to secure it.

Figure 4-72. Align the tuner card and press down until it snaps into the expansion slot

At this point, we also installed a PCI Express video adapter temporarily. We'll use it to install the operating system and other software, and then remove it.

Replace the expansion slot cover shroud, as shown in Figure 4-73, using four screws to secure it.

Figure 4-73. Reinstall the expansion slot cover shroud

4.4.6. Connecting the Remaining Motherboard Cables

All that remains is to connect the final few cables to the motherboard. Begin by connecting the Serial ATA data cables, as shown in Figure 4-74.

Figure 4-74. Connect the Serial ATA data cables

The four motherboard S-ATA ports are labeled 0 through 3. Connect each S-ATA cable to a port, making sure to align the keying notch on the cable connector with the corresponding tab on the S-ATA port. Also make sure to connect each cable to the correct port, cable 0 to port 0, and so on. Once you have aligned each cable connector, press it down firmly until it snaps into place. The motherboard S-ATA connectors are more robust than those on the drives, but they are still relatively fragile. Be careful not to put any sideways pressure or torque on the cable connector as you insert it.

The next step is to connect the main power cable from the power supply to the motherboard. The main ATX power connector is a 24-pin connector located near the front edge of the motherboard. Locate the corresponding cable coming from the power supply. The main ATX power connector is keyed, so verify that it is aligned properly before you attempt to seat it.

Once everything is aligned, press down firmly until the connector seats, as shown in Figure 4-75. It may take significant pressure to seat the connector, and you should feel it snap into place. The locking tab on the side of the connector should snap into place over the corresponding nub on the socket. Make sure the connector seats fully. A partially seated main ATX power connector may cause subtle problems that are very difficult to troubleshoot.

Figure 4-75. Connect the Main ATX Power Connector

As long as you're working near the front edge of the motherboard, locate the 40-pin ATA connector (labeled "IDE") adjacent to the main ATX connector. Align the data cable from the optical drive with the ATA interface connector, making sure that the cable keying nub aligns with the keying slot in the motherboard connector. Once the cable is aligned, press straight down to seat it, as shown in Figure 4-76.

Figure 4-76. Connect the ATA data cable

Modern processors require more power to the motherboard than the main ATX power connector can provide. Intel developed a supplemental connector, called the ATX12V connector, that routes additional +12V current directly to the VRM (Voltage Regulator Module) that powers the processor. There are actually two forms of ATX12V connector, the older 4-pin version and the newer 8-pin version. Both versions are still used. Which one a motherboard uses is determined by its current requirements. The 8-pin connector is a superset of the 4-pin connectorthe 8-pin connector simply supplies more current at the same voltages and the pin assignments are compatibleso a power supply with an 8-pin supplemental power connector can be used with a motherboard that has either an 4-pin or 8-pin connector.

As it happens, the Antec NeoHE 550 has an 8-pin supplemental power connector, and our Intel D945PVS motherboard has a 4-pin connector. That means we need to take care to align the four proper pins on the 8-pin power cable with the 4-pin connector on the motherboard. (Because both connectors are keyed with square and rounded sockets, it's impossible to seat the connector unless it's aligned properly.)

Examine the motherboard and cable connectors to determine how to orient them, and then press the cable connector into the motherboard socket, as shown in Figure 4-77. Make sure the plastic tab on the cable connector snaps into place over the motherboard socket to lock the connectors.

Figure 4-77. Connect the ATX12V Power Connector

Only one cable connection left. Well, two. Each of the two case fans has a Molex connector for power. The Molex cable you ran to the optical drive has two spare connectors. Connect each fan to one of those connectors, as shown in Figure 4-78.

Figure 4-78. Connect the fan power cables

4.4.7. Final Assembly Steps

Congratulations! You're almost finished building the system. Only a few final steps remain to be done, and those won't take long.

Before you go any further, dress the cables by routing them away from the motherboard and other componentsparticularly fansand tying them off so they don't flop around inside the case. Install the spoiler for the top vent (it's in the white cardboard box that contained the rails you used to mount the optical drive and port expander).

If you intend to run your server headless, as we do, leave the cover off for now. You can install the operating system and other software with the case open. Once the software is installed and tested, you can shut down the system and remove the video card. Slide the black plastic assembly that separates the upper and lower chambers of the case to seal the gap as well as possible and tighten both thumbscrews to secure it. Reinstall the VGA ventilation duct (the black plastic assembly that holds extra drive rails), and replace the side panels.

Before you proceed, take a few minutes to double-check everything. Verify that all cables are connected properly, that all drives are secured, and that there's nothing loose inside the case. If your power supply is not auto-sensing, check one last time to verify that it is set to the correct input voltage. It's a good idea to pick up the system and tilt it gently from side to side to make sure there are no loose screws or other items that could cause a short. Use the following checklist:

  • Power supply set to proper input voltage (the Antec NeoHE power supply is auto-sensing)

  • No loose tools or screws (shake the case gently)

  • CPU cooler properly mounted; CPU fan connected

  • Memory modules full seated and latched

  • Front-panel switch and indicator cables connected properly

  • Front-panel I/O cables connected properly

  • Hard drive data cables connected to drives and motherboard

  • Hard drive power cables connected

  • Optical drive data cable connected to drive and motherboard

  • Optical drive power cable connected

  • Floppy drive data and power cables connected (if applicable)

  • All drives secured to drive bay or chassis, as applicable

  • Expansion card(s) fully seated and secured to the chassis

  • Main ATX power cable and ATX12V power cable connected

  • Front and rear case fans installed and connected

  • All cables dressed and tucked

Once you're certain that all is as it should be, it's time for the smoke test. Connect the power cable to the wall receptacle and then to the system unit. Unlike some power supplies, the Antec unit has a separate rocker switch on the back that controls power to the power supply. By default, it's in the "0" or off position, which means the power supply is not receiving power from the wall receptacle. Move that switch to the "1" or on position. Press the main power button on the front of the case, and the system should start up. Check to make sure that all fans are spinning. You should also hear the hard drive spin up and the happy beep that tells you the system is starting normally. At that point, everything should be working properly.

FALSE STARTS

When you turn on the rear power switch, the system will come to life momentarily and then die. That's perfectly normal behavior. When the power supply receives power, it begins to start up. It quickly notices that the motherboard hasn't told it to start, and so it shuts down again. All you need to do is press the front-panel power switch and the system will start normally.

Turn off the system, disconnect the power cord, and take these final steps to prepare the system for use:

Set the BIOS Setup Configuration jumper to Configure mode

The BIOS Setup Configuration jumper block on the Intel D945PVS motherboard is used to set the operation mode. This jumper is located at the rear center of the motherboard, near the speaker and the main ATX power connector. By default, the jumper is in the 12 or "normal" position. Move the jumper block to the 23 or "configure" position.

Reconnect the power cord and restart the system

When the configuration jumper is set to configure mode, starting the system automatically runs BIOS Setup and puts the system in maintenance mode. This step allows the motherboard to detect the type of processor installed and configure it automatically. When the BIOS Setup screen appears, reset the system clock and load the system defaults. Save your changes, exit, and power down the system. Disconnect the power cord.

Set the BIOS Setup Configuration jumper to Normal mode

With the power cord disconnected, move the BIOS Setup Configuration jumper block from 23 (Configure mode) to 12 (Normal mode).


Section 4.5. Final Words

4.5. Final Words

Our SOHO server took longer to build than we expected. The Antec P180 case is the quietest case we have ever used, and has superb cooling. But those benefits come at the small price of some additional complexity during the build process. That's a trade-off we were more than happy to make. The system runs cooler than any comparable system we have built, and is nearly inaudible even in a quiet room.

If this is the first system you've built, expect to spend a full weekend building it. Even if you've built systems before, the SOHO server will probably be more than a one-evening project. Still, once it's complete, you've built something worth having.

4.5.1. Installing Software

Choosing the operating system for a SOHO server involves several trade-offs. We considered the following operating systems for our own SOHO server.

Microsoft Small Business Server

Microsoft Small Business Server (SBS) is a turnkey server OS aimed squarely at small businesses. It is designed to be easy to install and administer, although many small businesses choose to pay a consultant to install it and sometimes to manage it. SBS Standard sells for about $400 for a one-server license with five Client Access Licenses (CALs). Additional CALs cost about $450 per five-pack, and are needed for additional users or machines. SBS Premium costs about $800 for a one-server license with 5 CALs. Additional CALs cost about $850 per five-pack. Both versions support file and print sharing, email, shared calendaring, and other basic features. SBS Premium adds limited versions of SQL Server and ISA Server.

Xandros Server

Xandros Server is, in effect, a Linux-based superset of Microsoft SBS Premium. A one-server license costs about $300, and no CALs are required for basic client access. (Some of the bundled third-party utilities, such as the Scalix groupware server, the BRU Backup Server, and the Helix Streaming Media Server include some number of bundled CALs, but require additional CALs for additional users.) Xandros Server is, if anything, easier to set up and maintain than SBS. (That's fortunate, because Xandros Server consultants are still relatively thin on the ground compared to SBS consultants.) We think Xandros Server is the best choice for SOHO administrators who need a "full-function" server OS.

Ubuntu Server

Ubuntu Server is free-as-in-beer and free-as-in-speech. It uses text-based installation and maintenance, so it's unlikely to be suitable for anyone who's not comfortable with command-line Linux. On the other hand, this is serious server software. It's stripped down to essentials, whence the absence of a default GUI, and it's far faster than any of the other products we considered. One wonderful feature of Ubuntu Server is its scripted setup of a LAMP (Linux, Apache, MySQL, PHP/Perl/Python) server. Setting up a LAMP server manually may take hours, even for an experienced Linux administrator. With Ubuntu Server, setting up a LAMP server is a single menu option. Frankly, we think Ubuntu Server is a pretty good choice for nearly any SOHO environment, provided you're already a moderately experienced command-line-savvy Linux administrator (or have access to a Linux guru for advice and assistance).

A desktop Linux distribution

If your functional requirements are modest, don't rule out using a standard desktop Linux distribution like Xandros 4 or Ubuntu/Kubuntu on your server. In theory, there are a lot of disadvantages to doing that, but in practice many of those objections disappear. For example, a desktop Linux distribution is usually slower than a purpose-built server distribution. So what? We'll never notice any tiny performance difference that may exist. A desktop distribution may not support software RAID. Again, we don't care, because we plan to run JBOD on our SOHO server. Desktop Linux distributions also have advantages relative to server distributions. The biggest advantage for most people is that the desktop distro uses a familiar graphic interface. Setting up a shared disk volume or printer is usually a matter of a few clicks.

We ruled out Microsoft SBS for our SOHO server based on cost, if nothing else. Based on how Microsoft calculates CAL requirements, we would have had to spend more than $800 for SBS Standard or $1,600 for SBS Premium. That was simply more than we could justify based on the features and benefits of SBS. We also distrust the business policies and security of Microsoft software, so we took SBS off our list immediately.

Ubuntu Server was the next candidate we eliminated. We simply don't know Linux well enough to maintain a command-line server, nor do we need the LAMP stack that is the real reason Ubuntu Server was created. For a small business that has an experienced Linux administrator, Ubuntu Server might be an excellent and economical choice. For us, it was a nonstarter.

We looked next at Xandros Server. This product is reasonably inexpensive, extremely full-featured, and by default uses a Windows-like graphical interface, shown in Figure 4-79. (There is the option to run it in text mode for higher performance.) Xandros sent us an evaluation copy, which we spent some time evaluating.

Figure 4-79. The Xandros Server administrator desktop

The core of Xandros Server is the Xandros Management Console, shown in Figure 4-80 only three minutes after we'd installed Xandros Server and before we'd installed and enabled any but the default functions. Anyone who has even a bit of experience managing Windows servers will immediately feel right at home in Xandros Server.

Figure 4-80. Xandros Management Console

We concluded that Xandros Server was fast, reliable, and very easy to manage. If we needed even one or two of the advanced features of this productsuch as the groupware server or the streaming media serveror if we needed to manage multiple servers, we'd choose Xandros Server in a heartbeat.

But all we really need our SOHO Server to do is share files, printers, and other resources. For those simple tasks, even the minimal $300 street price of Xandros Server was more than we wanted to pay. We decided to do what we really intended to do all alonginstall a desktop Linux distro and set it up as our server OS. The choice came down to Xandros 4 Home Edition Premium or Ubuntu 6.06 LTS, both of which we were already running on other systems.

We looked first at Ubuntu 6.06 LTS Linux, which Robert runs on his primary office desktop system. Unfortunately, although Ubuntu has good support for Windows Networking as a client, setting up a Windows Networking server turned out to be nontrivial.

We read the Samba documentation and various Ubuntu help pages until we were confident that we could set up network shares properly. After an hour or two of mucking about, we got it working, or so we thought. Unfortunately, we soon encountered some strange problems with Windows clients authenticating to the server, sporadically dropped connections, and so on.

We turned next to Xandros 4 Home Edition Premium, which Barbara runs on her primary office desktop. Xandros 4 Premium retails for $80, but is available from online merchants for $55 or so. Although it is licensed for use on only one business system, the license allows it to be installed on unlimited personally owned systems for personal use.

In contrast to our struggles to configure Ubuntu to work properly as a server, Xandros 4 is trivially easy to set up as a server. Sharing a disk volume or printer with other Linux and Windows users on the network requires only a few clicks, and Just Works. In fact, it's easier to set up Xandros to share resources in either direction than it is to set up Windows to do the same.

The desktop version of Xandros lacks the Management Console and third-party server applications bundled with Xandros Server, but for our purposes it was perfect. Inexpensive, reliable, and easy to use. We couldn't ask for more.

For updated component recommendations, commentary, and other new material, visit http://www.hardwareguys.com/guides/soho-server.html.


Chapter 5. Building a Gaming PC

In the first edition of this book, we built a LAN party PCone designed for high performance and maximum portability. When we built that system in the summer of 2004, it was faster than any system we were likely to encounter at a LAN party. Even today, its Pentium 4 Extreme Edition processor and RADEON 9800XT are fast enough for any but the most intense recent games.

But after more than two years, it was time to update our gaming system. We call this version a gaming PC rather than a LAN party PC because we designed this system to be appropriate both for LAN parties and for gaming at home. We found ourselves traveling less than we expected and playing more at home, so for our new gaming PC we decided to deemphasize the portability aspects and pay more attention to issues that bear on home use.

Of course, our gaming PC is useful for much more than just gaming. Gaming demands more from a PC than any other common task, so a PC that's configured for gaming is by definition good for nearly any other job you throw at it. For most people, our gaming PC configuration will also serve as an ideal general-purpose system.

In the first edition of this book, we described our LAN party PC as a "kick-ass" system, which it indeed was for the time. It used a $1,000 processor and a $600 video adapter, for example. This time, we decided to set our sights a bit lower, for two reasons.

First, many of our readers expressed their desire for a configuration that could be built on a reasonable budget and still provide decent gaming performance. Getting that last few percent of performance isn't cheap, and many people will never notice the difference. Fanatic gamers for whom cost is no object will still want expensive options like dual video adapters (along with the costly extras they require, such as SLI-certified power supplies and extreme cooling solutions). But for most of us, a solid gaming system that can be built on a reasonable budget is a more realistic option.

Second, the price of performance has dropped remarkably in the last couple of years. Certainly, you can still spend $1,000 for a processor or $600 for a video adapter, but you probably don't need to. Today's $175 processor is faster than last year's $1,000 processor, and fast enough is fast enough.

That's also true when it comes to video. For example, we actually recycled an older video adapter for our own gaming PC. That video adapter was a $600 card little more than a year before we built this system, but comparable video adapters are now available for under $125. No, that older video adapter won't provide the fastest frame rates with the newest, most intense games, but who cares? It's playable even for the most demanding current games, and it's as fast as ever on less demanding titles. Nowadays, all but the most rabid gamers will be quite happy with the performance of a $200 video adapter, and many will be content with a $100 model.

Manufacturer hype aside, the truth is that serious gaming is now accessible for those on mainstream budgets. So we set out to design a gaming PC on that basis, and what we came up with is, for us at least, the perfect gaming PC.


Section 5.1. Determining Functional Requirements

5.1. Determining Functional Requirements

We sat down to think through the project. Here's the list of functional requirements we came up with:

Gaming utility

Most important, this system must have all of the resources necessary to be a good gaming platform. It must be fast enough to handle any current game at least reasonably well, have enough ports (and conveniently located) to handle any combination of game controllers, and so on. It must have audio and video support suitable for any game we decide to play on it.

General utility

This system must have all of the resources necessary for use as a general purpose system. No one who builds this system for gaming should have to own a second system for other purposes. That means, for example, that the system must have a FireWire port for downloading DV video from a camcorder (and sufficient disk space to edit that video). It must have a display and other external peripherals that are suitable for general use, as opposed to only peripherals optimized for gaming. This system must be capable of handling all but the most specialized tasks with aplomb. Two plombs, even.

Portability

Although portability is a secondary issue, it remains important for the gaming PC to be easily portable. Size and weight are both considerations. We set our upper size limit at a standard mini-tower case, which is small enough to be easily portable but large enough to contain several drives and whatever other components we might wish to add later and with enough volume to eliminate any problems with ventilation and cooling. We set our upper weight limit at 30 pounds, give or take, for the system unit, which is light enough for Barbara to pick up with one hand.


Section 5.2. Hardware Design Criteria

5.2. Hardware Design Criteria

With the functional requirements determined, the next step was to establish design criteria for the gaming PC hardware. Here are the relative priorities we assigned for the gaming PC.

DESIGN PRIORITIES

Price

Reliability

Size

Noise level

Expandability

Processor performance

Video performance

Disk capacity/performance

Here's the breakdown:

Price

Price is moderately important for this system. Our goal is to spend as little as possible above the cost of a general purpose system to create a system that's suitable for gaming. Reasonable gaming performance is now available for not much more than mainstream performance, so we'll keep a close eye on the prices of the processor, video adapter, and other components. We'll use only top-notch components in this system, particularly those that most affect gaming performance, but we'll use integrated components when they're capable of doing the job.

Reliability

Reliability is very important for this system, and we're willing to spend a bit extra to make the system as reliable as possible within reason. That means, for example, using a premium power supply and premium memory, and using cool-running components wherever possible.

Size

Size is relatively unimportant. Ultimately, what matters is that the gaming PC be easy to move from one location to another, and that it be large enough to facilitate ventilation and cooling.

Noise level

Noise level is very important. Although this system will go on the road with us periodically, it will spend most of its time at home. Quiet operation is a nonissue at a LAN party, but critical for residential use. We won't use radical quiet PC techniques like water cooling or added insulation, but we will use the quietest mainstream components available. To some extent, the goal of having a quiet system is at odds with portability. For example, it's impossible to use elastic suspension to mount the hard drives in a portable system.

Expandability

Expandability is relatively unimportant relative to other factors. We may upgrade our gaming PC from time to time, but those upgrades are likely to be things like a faster processor or video adapter, a high-capacity optical drive (if Blu-Ray or HD-DVD ever becomes affordable), larger hard drives, or more memory. Any of those upgrades simply replaces a component already installed or uses an otherwise vacant bay or slot. The one exception is dual video adapters. We decided not to use dual video adapters initially, but we also decided to choose an SLI motherboard (one with dual video slots) to leave that option open for the future.

Processor performance

In one sense, processor performance is very important to any gaming PC. Even with a fast video adapter, most games play poorly on a system with a slow processor. Fortunately, Intel's July 2006 introduction of their new Core 2 Duo processor family and AMD's dramatic price cuts on their Athlon 64 X2 dual-core processors have pretty much rendered the issue of processor horsepower moot. In the new world order, very fast processors now sell for mainstream prices, and the fastest (and most expensive) models are no longer needed even for extreme gaming. Unless your budget is unlimited, there's no longer any point to spending more than $175 to $250 for a processor, particularly if you are willing to overclock less expensive processors, as many gamers are.

Video performance

Again, although video performance is very important for a gaming PC, even midrange video adapters are now fast enough to deal with all but the most demanding 3D games played at high resolutions with all the eye candy enabled. A current $200 video adapter is faster than last year's $600 model, and even a $100 model compares favorably with the top-of-the-line model from 18 months prior. Video adapter makers have been on a 6-month refresh schedule for years. In general the current Better model matches the Best model from six months previous, and the current Good model matches the Best year-old model. What all that means is that most gamers will be happy with a $100 video adapter and delighted with a $200 model. Once again, the price of performance has fallen dramatically, and only the most devoted gamers will find it worth spending more than $200 to $250 on a video adapter.

Disk capacity/performance

We assigned moderate importance to this factor because our friends who are serious gamers tell us that drive performance matters in gaming, both for hard drives and optical drives. So, apparently, does disk capacity, as many serious gamers copy entire CDs and DVDs to their hard drives for faster access while gaming. Accordingly, we'll aim for fast performance from our hard drives and optical drives, and high disk capacity. All keeping within a reasonable budget, of course.

TECH HELP
SLI and CrossFire

nVIDIA developed SLI (Scalable Link Interface) to allow two video adapters to function as one. ATi soon followed with its similar but incompatible CrossFire system. (In dual mode, an SLI motherboard accepts only nVIDIA SLI-compatible video cards; a CrossFire motherboard accepts only ATi CrossFire-compatible video adapters. Either type of motherboard can use a single video adapter from either company.)

In theory, you can install two identical $150 video adapters in an SLI-compatible or CrossFire system and have noticeably higher video performance than a single $300 video adapter would provide.

In practice, the cost advantage is diminished by the need for a relatively expensive SLI motherboard and a high-wattage SLI-compliant power supply, and the performance gain is not always as great as expected. Unstable and buggy drivers have also been a problem for dual-adapter systems, although those problems have become less severe recently as ATi and nVIDIA continue to polish their dual-adapter drivers.

The real cost benefit with dual video adapters occurs only when you install two midrange or better adapters that cost enough to offset the extra $100 to $150 cost of building a dual-capable system. For example, installing two $200 adapters totals $400 for the adapters and, say, a $125 incremental cost for the SLI motherboard and power supply, for a total of $525. That combination may outperform a single $700 adapter. Similarly, dual adapters are useful when even the fastest single model isn't fast enough. Instead of using one $700 adapter, you use two. (Yes, some gamers are both rich and foolish enough to do this.)

For our Gaming PC, we decided to leave the door open for SLI, but not to implement it initially. We chose a top-of-the-line SLI-compatible motherboard, but installed just one video adapter (in our case, a year-old nVIDIA 6800 Ultra that was still fast enough to do the job for us.) That motherboard cost about $50 more than a comparable non-SLI motherboard, which we considered a reasonable insurance premium. Six months or a year from now, when it's time to replace the 6800 Ultra, we'll consider the options. It's quite possible that we'll decide to install two low-end or midrange adapters in SLI mode.


Section 5.3. Component Considerations

5.3. Component Considerations

With our design criteria in mind, we set out to choose the best components for the gaming PC system. We took advice from our readers, because Barbara doesn't game at all and Tux Racer is Robert's idea of a challenging game. The following sections describe the components we chose, and why we chose them.

Advice from Jim Cooley

Cases made more cheaply than Antec are liable to use thinner steel or aluminum in the frame and side panels, so if portability is an issue double-check the case integrity. I've seen cases mangled and bent out of shape from a drop of less than two feet, something that wouldn't happen with an Antec.

5.3.1. Case

Antec P150 (http://www.antec.com)

We could have built the gaming PC in just about any case. For the LAN party PC we built for the previous edition of this book, we chose the aluminum Antec Super LANBOY for portability.

But portability turned out to be less important than we'd thought. When we went on a road trip to visit friends over the Labor Day weekend, Robert didn't think about the LAN party system. He took along his primary office desktop system instead. That system was a loaded mid-tower box, with a dual-core processor, 2 GB of memory, dual optical drives, and a 2.5 TB of hard disk space. It was much more capable than the LAN party PC, and, as it turned out, just as portable. So we decided to build our gaming PC in a standard mini- or mid-tower case, confident that it would be as easily portable as a system built in a special LAN party case.

With a blank sheet of paper, so to speak, we set out to choose the perfect case for our gaming PC. We wanted a case that was attractive, provided excellent cooling, and was as quiet as possible. After considering numerous alternatives, we settled on the Antec P150. The P150 uses a gloss white and brushed aluminum color scheme that looks good anywhere. Mike Chin of Silent PC Review (http://www.silentpcreview.com) helped Antec design the P150, so we were confident that it would provide excellent cooling at a very low noise level.

ALTERNATIVES: CASE

Nearly any mini- or mid-tower case. If the case includes a power supply, make sure that it is ATX v2.x-compliant and of sufficient wattage to support your configuration. If you plan to use dual video adapters, make sure the power supply is SLI-certified. If the case does not include a power supply, purchase a high-quality unit such as the Antec NeoHE separately. For SLI systems, we recommend the Antec NeoHE 550.

The P150 includes an Antec NeoHE 430 power supply, which is a premium unit. The only downside to the P150 is that the NeoHE 430 is not SLI-certified for use with dual video adapters. That wasn't a problem for us, because we don't intend to use dual video adapters, and the NeoHE 430 is otherwise a superb choice. If you plan to use SLI (or CrossFire), choose a case that doesn't include a power supply or one that includes an SLI-certified power supply. Otherwise, we think you'll also be delighted with the P150.

5.3.2. Processor

AMD Athlon 64 X2 4200+ (http://www.amd.com)

Intel's July 2006 introduction of its new-generation Core 2 Duo processor line wreaked havoc with processor pricing. To make room in the price list for the Core 2 Duo models, Intel took a meat-ax to the prices of their older Pentium D dual-core processors. Literally overnight, the price of performance was cut in half. AMD had no choice but to respond with similar price cuts, chopping the price of some of their Athlon 64 models by more than 60%.

In the past, a serious gaming system typically used a processor that cost $350 to $1,000, versus the $150 to $225 cost of mainstream processors. The most rabid gamers happily coughed up $1,000 for "extreme" processors like Athlon FX-series models. Happily, the processor price war kicked off by Intel means that even a serious gaming system can now use a $200 processor.

We considered three processor families for our gaming system, the Intel Pentium D, the Intel Core 2 Duo, and the AMD Athlon 64 X2. All of these are dual-core processors. Although dual core is of limited benefit for most games, there's really no alternative. Nowadays, only "value" processors are single core. Here are the issues we considered.

Intel Pentium D

The Intel Pentium D doesn't get much respect as a gaming processor, but that has more to do with pricing than any real problems with the processor itself. Intel had priced the Pentium D against the AMD Athlon 64 X2 for comparable general performance at a comparable price. But the Athlon 64 X2 architecture is more efficient for gaming. That meant that, for similar gaming performance, a less expensive Athlon 64 X2 matched a significantly more expensive Pentium D. Gamers abandoned Intel in droves. When Intel cut Pentium D prices dramatically, the equation shifted in favor of the Pentium D, dollar for dollar. Even AMD's July 2006 price cuts on the Athlon 64 X2 didn't completely close the gap, so the Pentium D suddenly became an excellent choice for a gaming system, particularly for a gamer on a tight budget.

Intel Core 2 Duo

The first benchmark tests on the Core 2 Duo made it clear that this new processor family simply blew the doors off the older Pentium D and Athlon 64 X2. That might not have mattered if Intel had priced the Core 2 Duo models as premium products, but they didn't. Intel wanted to transition to the Core 2 Duo as quickly as possible, so they priced the Core 2 Duo models extremely aggressively. How aggressively? At introduction, the $316 Core 2 Duo E6600 matched or beat the overall performance of the $1,000+ AMD Athlon 64 FX-62, and even the entry-level $224 Core 2 Duo E6300 outpaced all but the fastest AMD processors. The Core 2 Duo also shifted the playing field in terms of gaming performance, with benchmark tests showing that Core 2 Duo was at least on a par with AMD's best. Core 2 Duo is a superb choice for a gaming system. But not the only superb choice, as we found.

AMD Athlon 64 X2

The introduction of the Intel Core 2 Duo knocked AMD down, but not out. At the very highest reaches of gaming performance, the AMD Athlon 64 X2 was no longer competitive with Intel Core 2 Duo, but very few systems, even dedicated gaming systems, use extreme processors. In the sweet spot for gaming processors, AMD could again be competitive with Intel simply by reducing its prices for the Athlon 64 X2, and that is exactly what they did. Suddenly, a fast X2, which not long before had sold for $400, now cost $200, and AMD was right back in the ballgame.

Athlon 64 X2 Power Consumption

AMD produces several Athlon 64 X2 models in two variants. The model designations are identical, but the more expensive variants use noticeably less power and produce less heat. At the time we built this system, the low-power version of the Athlon 64 X2 4200+ sold at a $60 premium. We didn't consider the benefit worth the cost, so we used the standard version. As time passes, we expect that AMD will improve its production processes and eventually begin producing only the low-power variants.

We were faced with making the choice among three excellent processor families. Talk about an embarrassment of riches. For $125, we could have chosen a Pentium D that offered sufficient performance for a mainstream gaming system. For $50 or so more, we could choose a Core 2 Duo or a fast Athlon 64 X2, either of which had noticeably better gaming performance.

If we had been on a tight budget, we wouldn't have hesitated to use the Pentium D, despite its somewhat lower performance and higher heat. We might have chosen the Core 2 Duo for our gaming PC except that availability was tightly constrained soon after its introduction, with Intel shipping every available Core 2 Duo processor to Dell and other large OEMs. Fortunately, the AMD Athlon 64 X2 was widely available, and provided excellent bang for the buck.

For our gaming PC, we chose the AMD Athlon 64 X2 4200+ in the new Socket AM2, which at the time was selling for about $185. Admittedly, it seemed odd to pay only a mainstream price for a high-performance processor like the 4200+, but we could get used to that. The simple truth is that any but the most extreme gaming PC no longer needs a $350+ processor. The Athlon 64 X2 4200+ is just as fast priced at $185 as it was when it sold for twice that much, and fast enough is fast enough.

We chose a retail-boxed Athlon 64 X2 4200+, which includes a decent CPU cooler. The stock AMD cooler appears to be an AVC Z7U7414001 heatpipe model, which is reasonably efficient and quiet. If you prefer to use a quieter or more efficient cooler, consider premium models from Thermalright (Ultra-90/K8, XP-90, or XP-120) or Zalman (CNPS7xxx- or 9xxx-series). Socket AM2 uses the same mounting arrangements for the CPU cooler as Socket 939, so nearly any Socket 939 cooler that fits your motherboard and case should work properly with a Socket AM2 processor.

5.3.3. Motherboard

ASUS M2N32-SLI Deluxe (http://www.asus.com)

Like Intel, AMD made a major change to its processor line in mid-2006 by introducing a new socket that will eventually replace Socket 754 and Socket 939. The announcement of Socket AM2 also presaged AMD's shift from DDR memory to DDR2 memory. Unlike Intel's shift from Netburst architecture to Core 2 architecture, AMD's shift from Socket 939 to Socket AM2 had little impact on performance. A Socket AM2 Athlon 64 processor with DDR2 memory is little or no faster than the same model for Socket 939 with DDR memory, and AMD makes no claims of increased performance.

But the processor and memory are not the sole determinants of performance. The motherboard and, more particularly, the chipset, can have a dramatic impact on system performance. Years ago, it was common for benchmark tests for a particular processor model to differ widely depending on the motherboard and chipset used for testing. Around the time Intel introduced the 440BX chipset for the Pentium III, those differences began to disappear. In recent years, the performance differences between motherboards and chipsets had become relatively minor, at most a few percent either way.

ALTERNATIVES: MOTHERBOARD

For an Intel Pentium D processor, choose any compatible Intel or ASUS motherboard based on an Intel 946-, 963-, 965-, or 975X-series chipset that provides a PCI Express video adapter slot. For an Intel Core 2 Duo processor, choose any compatible Intel or ASUS motherboard based on a 946-, 963-, 965-, or 975X-series chipset that provides a PCI Express video adapter slot. For a less expensive alternative to the ASUS M2N32-SLI for a Socket AM2 Athlon 64 X2 processor, choose the ASUS M2N-E or M2N-SLI Deluxe. Based on our performance testing, we do not recommend using a Socket 939 processor.

nVIDIA changed that when they introduced the nForce 590 SLI chipset. nVIDIA nForce chipsets had always been the premium choice for AMD processors, offering top-notch performance and stability. We expected nVIDIA's chipset for Socket AM2 to be more of the samefast and reliable, and little different from their nForce 4 series chipsets for Socket 939. Boy, were we wrong.

We benchmarked AMD Athlon 64 X2 4200+ processors in Socket 939 and Socket AM2 on similar nForce motherboards, expecting similar results. We were surprised to find that the Socket AM2 processor on an nForce 590 motherboard was faster than the Socket 939 processor on an nForce 4 motherboard. And not just a little faster. In some benchmarks, the nForce 590 SLI motherboard was as much as 30% faster, which is an incredible difference for a chipset to make. To put this in perspective, the $175 Athlon 64 X2 4200+ in an nForce 590 SLI motherboard gave faster performance benchmarks than we'd expect to see from an Athlon 64 FX-62 processor in an nForce 4 motherboard. nVIDIA really hit a home run with the nForce 590 SLI chipset.

Perhaps that performance difference isn't all attributable to the chipset. The motherboard itself may have something to do with it. At the time we built our gaming PC, Socket AM2 motherboards were still pretty thin on the ground. We were fortunate enough to get our hands on an ASUS M2N32-SLI Deluxe motherboard, which is what we used for benchmark-testing the Socket AM2 processor. We've always sworn by ASUS motherboards for their quality, performance, and reliability, so on that basis we chose the top-of-the-line ASUS M2N32-SLI Deluxe motherboard as the foundation of our gaming PC.

5.3.4. Memory

Kingston KVR667D2N5K2/2G PC2 5300 DDR2-SDRAM (1 GB x 2) (http://www.kingston.com)

If you want a stable system, install a premium power supply and top-quality memory. Using cheap memory almost guarantees frequent system crashes. We've used premium, name-brand memory in all of our systems for more than 20 years, and it has seldom let us down.

When determining memory requirements, it's important to remember that a dual-core processor like our AMD Athlon 64 X2 4200+ is effectively two processors. Each of those processors needs as much memory as a single-core processor does. We consider 1 GB the sweet spot for gaming on a single-core processor, so we decided to install 2 GB of memory in our dual-core gaming PC. Because the AMD Athlon 64 X2 4200+ has a dual-channel DDR2 memory controller, we decided to install two 1 GB memory modules.

As we always do when we're configuring a new system, we visited the Kingston and Crucial web sites and used their configurators to display lists of memory modules compatible with our ASUS M2N32-SLI Deluxe motherboard. As it happened, Kingston memory was a bit less expensive than comparable Crucial memory that day, so we opted for the Kingston modules.

ALTERNATIVES: MEMORY

Any compatible premium memory modules. We recommend a minimum of 2 GB of memory for a Gaming PC, and we recommend using only Kingston or Crucial modules.

Kingston listed three compatible 2 GB memory kits, each of which contained two matched 1 GB modules. The only differences in those kits were the speed and CAS latency (CL) of the modules and their price. At the time we built this system, a PC2 5300 CL5 memory kit sold for $161. We could instead have chosen a PC2 4200 CL4 kit that had slower access time but faster latency for about $190. That kit would have offered somewhat faster random memory access at the expense of slower sequential memory access, so we ruled out the CL4 kit. The third alternative was a 2 GB PC2 6400 CL5 kit for $346. That kit would have offered faster sequential memory access than the PC2 5300 kit, but at more than twice the cost. The PC2 6400 kit would have boosted performance by at most a few percent. That gain wouldn't be perceptible other than when running memory benchmark tests, so we decided to use the less expensive PC2 5300 kit.

TECH HELP
Why "Performance" Memory Usually Isn't Worth Paying Extra For

Companies like Corsair and Mushkin sell "high-performance" memory to the enthusiast market. We're sometimes asked if it's worth paying more for such memory rather than using standard Kingston or Crucial modules. The short answer is that it's usually not.

Even nominally identical memory chips vary from one to the next. Some are faster than others, and performance memory packagers take advantage of that fact. They order large numbers of memory chips and use a process called binning to hand-select the fastest chips from that batch. After they've cherry-picked the fastest 5% or 10%, they resell the remaining chips to other memory packagers. They assemble those hand-picked chips into high-performance modules and test the finished modules to verify that they function at higher speeds and tighter memory timings than standard memory.

Many gamers happily pay substantial premiums for such memory, on the assumption that faster memory must translate to faster system performance. Alas, that's not necessarily true. If one type of memory is fast enough to keep up with the processor, or nearly so, substituting faster memory has very little effect on overall system performance.

Some might object that the benchmarks show the difference. Sure they do, when they test memory subsystem performance in isolation. But memory performance is only one aspect of overall system performance, and using faster memory helps only if memory speed is the bottleneck. For most gaming systems, it is not.

The one exception is overclocked systems. If you boost the bus speed to run your CPU at higher than nominal speed, which we do not recommend, you're also pushing other system components, including the memory, to speeds they were not designed to support. In such cases, it's a good idea to use hand-picked performance memory rather than depend on the tolerances built into standard memory modules.

5.3.5. Video Adapter

Pick one (or two)

Choosing a video adapter (or adapters) for a gaming system is the most complex decision you'll have to make. You have to weigh your budget against the minimum level of 3D graphics performance that is acceptable to you. You have to take into account the specific games you play, because some games are faster on nVIDIA adapters and others on ATi adapters. You have to decide whether it's better to install one expensive adapter or two midrange adapters. You have to weigh the advantages and drawbacks of buying an expensive adapter now and using it for a year versus installing a less expensive adapter now and upgrading every six months.

For our own configuration, we had no need of a new video adapter. Instead, we migrated a year-old nVIDIA GeForce 6800 Ultra from an older system to our new gaming PC. That formerly high-end card is now midrange in terms of performance against current models, but it's still more than fast enough for the games we play. We could have matched its performance with a current model that sold for $125, but there was no point to doing that. Instead, we'll wait until we actually need a faster graphics adapter, and then upgrade to what by then will probably be a midrange model.

When you choose a graphics adapter for your own gaming PC, we suggest using the following guidelines:

  • Video adapters change in Internet time. Get the latest information and benchmarks from enthusiast sites such as AnandTech (http://www.anandtech.com), Sharky Extreme (http://www.sharkyextreme.com), and Tom's Hardware (http://www.tomshardware.com).

  • ATi versus nVIDIA is a religious issue. Both companies produce excellent video chipsets, and overall performance is comparable between similarly priced adapters that use either company's chipsets. That said, we prefer to use nVIDIA adapters on motherboards that use nVIDIA system chipsets. Because we prefer nVIDIA-based motherboards for AMD systems, we generally use nVIDIA-based video adapters in AMD systems. For Intel-based systems, we've historically used mostly ATi adapters, although nVIDIA adapters work just as well. With AMD's buyout of ATi and the introduction of Intel's new-generation Core 2 Duo processors and new chipsets to support them, the graphics landscape will change significantly in late 2006 and into 2007. Only experience will tell which combinations are optimum in this new environment.

  • Make sure the adapter you choose has sufficient onboard memory for the games you play. For casual gaming, particularly with older titles, 128 MB may suffice. A mainstream gaming adapter should have 256 MB, and if you play the latest, most intense games, you'll want 512 MB or more.

  • Pay close attention to performance with the specific games you play. Some games play better on nVIDIA adapters, and others on ATi adapters. In the most extreme cases, a particular game may be faster on a midrange adapter from nVIDIA than on a high-end adapter from ATi, or vice versa.

  • Unless your budget is effectively unlimited, give careful thought to your upgrade strategy. Quite often, you're better off upgrading every six months to the latest mid-range adapter than spending a lot of money on a high-end adapter initially and having to use it for a year or more.

  • No matter which card or cards you install, play close attention to driver updates. ATi and nVIDIA both release driver updates frequently. Those updates may fix bugs, but often they are primarily performance tweaks for the most recent games. The performance delta between the current driver and an old version can be extraordinary.

  • Consider carefully before you buy into the dual adapter concept. In theory, nVIDIA's SLI (Scalable Link Interface) and ATi's CrossFire are very attractive. You can install two less expensive adapters instead of one more expensive adapter, and get higher performance for less money. In practice, dual adapters may not work particularly well. Driver problems are common, and performance is not always as high as expected. If you do decide to use dual adapters, verify everything carefully. In particular, make absolutely certain that your motherboard is compatible with the adapters you choose and that the power supply you use is SLI-certified and can provide the required current to both adapters.

  • Decide what is reasonable to spend, and then limit yourself to that amount. If you set a $150 budget, don't let the marketing hype convince you to walk out of the store with a $300 adapter. The 80/20 Rule definitely applies to graphics adapters. A $150 adapter provides 80% of the performance of a $750 model, give or take, and all but the most avid gamers will probably be happy with the performance of that $150 adapter.

  • If you do decide to buy a high-end adapter, be aware that at the very high end the 80/20 Rule is replaced by the Law of Diminishing Returns. For example, a $750 adapter costs 50% more than a $500 adapter, but may be only 10% (or less) faster. Super-premium adapters are more often bought for bragging rights than for any perceptible performance benefit.

5.3.6. Sound Adapter

Integrated

When we sat down to design this system, we fully intended to install a standalone sound adapter. Then we started reading reviews of the ASUS M2N32-SLI Deluxe motherboard and its integrated ADI SoundMax HD Audio, and decided just to use the integrated audio.

Gamers install standalone sound adapters for two reasons. First, integrated audio can put a heavy burden on the main system processor, resulting in lower frame rates. Second, integrated audio typically lacks hardware acceleration for positional audio.

The integrated ADI codec answers the first objection easily. Frame rates with ADI audio enabled are only 2% to 3% lower than frame rates with ADI audio disabled (versus a 25% to 33% drop with many integrated audio solutions) and the audio quality is excellent. Unfortunately, ADI accomplished this feat by not including support for Creative's EAX positional audio. We don't care about EAX support, so the integrated audio is sufficient for us.

ALTERNATIVES: SOUND ADAPTER

If you need EAX support, the obvious choices are a Creative Labs Audigy 2 ZS, Audigy 4, or X-Fi sound card, and all of those are popular choices among gamers. Less obvious choices are the M-AUDIO Revolution 5.1 or 7.1. The Creative cards have somewhat superior gaming support, but at the expense of generally lower sound quality and more frequent driver problems. The M-AUDIO cards have decent gaming support, better audio quality, and generally fewer driver problems. If we wanted a standalone sound card, we'd install one of the M-AUDIO cards.

5.3.7. Hard Disk Drive

Seagate 7200.9 Barracuda SATA (500 GB x 2) (http://www.seagate.com)

We've used and recommended Seagate hard drives for many years, and have never had cause to regret it. Seagate Barracuda-series drives are fast, extremely reliable, quiet, and reasonably priced. So, when we configured our gaming PC, the only real decisions were which model of Barracuda drive to install, and how many.

Several of our gaming friends convinced us to try a RAID 0 once again, swearing that RAID 0 provided better gaming performance. We didn't really believe that. We've tested RAID 0 (and the similar RAID 0+1) many times over the years. While RAID 0/0+1 indeed boosts disk performance on a heavily loaded server, we've never seen much performance benefit on desktop systems. Weighed against the riskone drive failing in a RAID 0 causes all data on both drives to be lostusing RAID 0 on our gaming PC seemed like a sucker bet. Still, why not? It was worth testing again, and if the tests turned out as we expected, we could simply pull the second drive and use it in another system.

ALTERNATIVES: HARD DISK DRIVE

We chose the 500 GB Barracuda. That may be overkill for you, depending on your practices. (Many gamers fill their hard drives with rips of numerous DVD video and game discs.) If you don't need that much disk space, use a Barracuda of smaller capacity.

ADVICE FROM BRIAN BILBREY

In transitioning from one texture map to another, load times are significant. I might expect to see much better performance from hardware RAID 0 than from a JBOD configuration. Software RAID, not so much.

RIGHT AGAIN

The tests turned out just as we expected. By choosing benchmarks that exercised the disk subsystem heavily, we could "prove" that RAID 0 gave better performance than a single drive. But those benchmarks hammered the drives with access patterns typical for a file server, not for a single-user desktop system. For real-world single-user use, including gaming, RAID 0 offered very little performance benefit. So, although we illustrate the build process using two drives, you can safely install just one drive in your own gaming PC.

The same objection holds true for using faster drives. We tried a Western Digital Raptor 10,000 RPM ATA drive and Seagate Cheetah 15,000 RPM SCSI drives, alone and in a RAID 0. While the faster drives made program loading faster and heavy disk operations noticeably snappier, they had little perceptible effect on game play once the game was loaded.

5.3.8. Optical Drive

BenQ DW1650 DVD writer (http://www.benq.us)

Many gamers install two optical drives in their systemsa DVD writer for general use and a DVD-ROM drive for faster read access to game DVDs. Fast DVD writers, such as the BenQ DW1650 model we chose for our gaming PC, make this strategy obsolete. In our testing, the BenQ DW1650 proved to have true random access times as fast as or faster than the several DVD-ROM models we also tested.

WHEN SLOWER IS FASTER

Take published random access times with a grain of salt. There are many ways to test random access time, and they are not standardized. A drive with a published 120 ms random access time may actually be faster than another drive that claims 85 ms random access. Other than testing specific drives with a utility like Nero CD-DVD Speed, there's no way to tell which claims are conservative and which are exaggerated.

For example, we tested the NEC ND-3550A (rated at 140 ms random access) and indeed found it to be slightly slower than the BenQ DW1650 (120 ms). However, the Plextor PX-740A and PX-716AL, both rated at 150 ms, were faster than the BenQ DW1650. We tested several DVD-ROM drives, with rated access times ranging from 85 ms to 120 ms, and found no correlation between rated access times and actual performance. One of the DVD-ROM models listed at 85 ms was the slowest drive we tested, and the 150 ms Plextor DVD writers were among the fastest.

ALTERNATIVES: OPTICAL DRIVE

Any DVD writer from BenQ, Lite-On, NEC, Pioneer, or Plextor. If you use DVD-RAM discs, make sure to choose a model with DVD-RAM support. If you decide to install a DVD-ROM drive in addition to or instead of a DVD writer, choose a current model from ASUS, Lite-On, Pioneer, Samsung, or Teac.

Advice from Brian Bilbrey

DVD for faster read access...I don't agree. I always load the whole game onto disk. The only need for the DVD is to validate that I am allowed to run the game.

5.3.9. Mouse and Keyboard

If you plan to take your gaming PC on the road, you'll probably want two mice and two keyboards, one set for home and one for away.

5.3.9.1. Home mouse and keyboard

Logitech cordless mouse/corded keyboard (http://www.logitech.com)

At home, we use cordless mice and corded keyboards on most systems. We have tested numerous cordless mice from Logitech and Microsoft. We much prefer the design and feel of the Logitech models, particularly those that include a receiver that doubles as a recharging cradle. Logitech cordless keyboards have reasonably long battery life, but we use them only when cordlessness is really important, because swapping cordless keyboard batteries is a pain in the begonia.

We particularly dislike recent Microsoft cordless mice, whose scroll wheels make it too easy to click accidentally while scrolling. Also, although battery life in the recent Microsoft cordless mice we have used is reasonably good, keyboard battery life is terrible. (In one test, we exhausted a fresh set of three AA heavy-duty alkaline batteries in less than one day of constant use.)

As to a corded keyboard, choose whichever model feels best to you. Again, we generally prefer the design and feel of the Logitech models, but Microsoft also offers several very good corded keyboards.

5.3.9.2. Away mouse and keyboard

Logitech MX-series corded optical mouse (http://www.logitech.com) Zippy EL-715 illuminated keyboard (http://www.zippy.com.tw)

We love the freedom of a cordless mouse for home use, but for away use corded devices are almost mandatory. Cordless keyboards and mice use radio frequency (RF) communications. Some provide an A-B switch to prevent conflicts by using different frequencies, but a choice of only two frequencies is wholly inadequate at a crowded LAN party. If you doubt that, just wait until the first time you watch the cursor moving across your screen in response to someone else's mouse movements. Until someone comes up with frequency-agile, stealthed cordless input devices, corded it is.

For a corded mouse, we prefer a Logitech MX-series optical mouse. The $25 six-button MX 310 can be used with either hand, and is precise enough for most gamers. The $35 eight-button MX 518 offers higher tracking resolution and is specifically designed for gaming (although it's also excellent for general use). The MX 518 is available only for right-handers.

Although your regular corded keyboard may serve for away use, it's worth considering a specialty keyboard designed for use on the road, particularly at LAN parties. Our favorite travel keyboard is the Zippy EL-715. The EL-715 is a medium-size, notebook-style, 105-key keyboard with electroluminescent backlighting that is quite useful at dimly-lit LAN parties. At just over a pound and about 0.75" thick, the EL-715 is extremely portable. We find it a bit too cramped to use as our primary keyboard, but it's unsurpassed as a portable LAN party keyboard. The blue backlighting is bright enough to see what you're doing, but not so bright that it becomes intrusive in a dimly lit environment.

ALTERNATIVES: MOUSE AND KEYBOARD

Thousands. Well, hundreds anyway. Personal preference is the most important factor in choosing a keyboard, mouse, game controller, display, or other I/O peripheral. What we hate you may love, and vice versa. For a cordless or corded mouse or keyboard, we suggest you try a Logitech model first. If you don't like it, exchange it for a similar model from Microsoft. If you want the best gaming mouse and are willing to pay a premium price, the $45 Logitech G5 Laser Mouse is the best choice we know of.

5.3.10. Game Controllers

Choose your own

As with keyboards and mice, personal preference is the most important factor in selecting the best game controllers for your own needs. Cordless controllers are very nice for use at home or small LAN parties, but if you attend large LAN parties corded is the only way to go.

MAY THE FORCE BE WITH YOU

One downside to cordless models is that none we know of incorporates full force feedback, which apparently requires too much juice to run from batteries. The best cordless controllers can provide is limited vibration feedback. Full force feedback uses small motors within the game controller to provide tactile response to gaming actions. For example, as you maneuver your F-16 Falcon onto the six of a MiG-29 Fulcrum and begin hosing him down with your Vulcan rotary cannon, a force feedback joystick jitters and jerks to simulate recoil. Games that implement force feedback well are much more immersive than games that do not.

The first step is to decide which type or types of game controller you need, which is determined by the types of games you play. For example, we play mostly flight simulation and air combat games, so our primary controller is a joystick. For first-person shooter (FPS) games, most people consider a gamepad to be the optimum controller. For racing games, you'll want a wheel game controller. Although different types of controllers can substitute for each other to some extent, using an inappropriate game controller can put you at a severe disadvantage relative to players who are using controllers better suited to the type of game being played.

ALTERNATIVES: GAME CONTROLLERS

Many, some of which you'll love and some you'll hate. The trick is to figure out which is which before you pay for them. If you have no idea which controller(s) to buy, buy something inexpensive to start with and then try as many midrange and high-end controllers as you can get your hands on.

Once you determine which types of game controller you need, decide how to allocate your budget among them. If you regularly play games that require all three types of game controller, allocate your budget evenhandedly among them. That doesn't mean spending a third of your budget on each, because different types of controllers have different price points. It does mean you should buy all three high-end, all three midrange, or all three low-end, depending on your budget. When you play a racing game, for example, a $70 wheel controller is better than a $250 joystick. On the other hand, if you spend most of your time playing flight sims, play FPS games occasionally, and never play racing games, put most of your budget into the joystick, and spend whatever is left on a decent gamepad. And so on.

Before you buy a game controller, see if you can play with someone else's for at least a short session. If you ask nicely, most gamers are happy to let you try their rigs. Of course, the flipside is that if you do buy that $250 joystick, you can expect to be very popular at LAN parties.

ALTERNATIVES: SPEAKERS/HEADPHONES

If the $275 Z-5500 speaker set is a bit rich for your taste, consider the $125 Logitech Z-5300e 5.1 set. The Z-5300e has a combined RMS output of "only" 280W, but the sound quality is comparable to its more expensive sibling. If the Z-5300e is still beyond your budget, consider the $50 Logitech X-530 5.1 set. The combined output is a modest 70W RMS, and the sound quality is noticeably inferior to the better Logitech sets, but still reasonably good. (Ordinarily, we don't recommend inexpensive 5.1 speaker sets, but for gaming, support for surround sound deserves priority even at the expense of sound quality.)

We've found nothing we like nearly as much as Zalman ZM-RSF6F headphones for gaming. The bad news is that these are not general-purpose headphones. The bass is weak, although for gaming that is more than made up for by the excellent 3D imaging. Used for music and other stereo sources or for DVDs, the Zalman headphones boom and echo pretty badly. For general-purpose listening, buy a decent set of Grado or Sennheiser headphones.

5.3.11. Speakers and Headphones

Logitech Z-5500 5.1 speaker system (http://www.logitech.com): Zalman ZM-RS6F 5.1 surround headphones (http://www.zalman.co.kr)

A gaming system needs good, high-power speakers, and the Logitech Z-5500 5.1 speaker system is the best we know of for the purpose. With four 62W RMS satellite speakers, a 69W center-channel speaker, and a 188W subwoofer, the Z-5500 produces a wall-rattling 505W RMS. You don't just hear the bass, you feel the bass vibrating your internal organs. Nor is the Z-680 limited to gaming. At lower volume, it's also excellent for anything from listening to background music to playing DVDs.

As nice as the Logitech Z-5500 is, it's overkill for a road trip, not to mention for playing games at home while the spousal unit is trying to sleep. For those situations, you need headphones, and the Zalman ZM-RSF6F 5.1 surround headphones are the best we know of for gaming. They're light, durable enough to stand up to LAN party use, fold up into a self-contained unit, and their 3-meter cord gives you plenty of slack to move around.

The Zalman headphones use three separate drivers per ear to produce a surround sound field comparable to that provided by a 5.1 speaker system. The importance of positional audio may not be apparent at first glance, but it can mean the difference between winning and losing. When you play an FPS, knowing where your opponents are is critical. Stereo headphones just don't cut it. By the time you figure out where shots are coming from, you're dead meat. The Zalman headphones make it easy to discriminate not just left and right but front and rear. The difference is amazing.

5.3.12. Display

Samsung 930BF 19" FPD (http://www.samsung.com)

In the first edition of this book, we specified two displays. For road trips, a CRT monitor was simply too bulky and heavy to take along. On the other hand, the flat-panel LCD displays of the time were too slow for gaming. So we compromised, specifying a good CRT for use at home and a light, easily portable LCD display to take on the road.

Nowadays, although CRT monitors still have a few advantagesprimarily low price and off-axis color fidelitythere's no real reason not to use an LCD display as the only display for a gaming system. Slow LCD display response time and the associated ghosting were the main problem with early LCD displays. Many current LCD display models are more than fast enough to use for gaming. Robert uses a 19" Samsung 930BF on his own system.

ALTERNATIVES: DISPLAY

Any 17" or larger LCD display from NEC, Samsung, or ViewSonic that has response time fast enough to suit you. For most gaming, a 12ms BWB response time is adequate, and 8ms or faster ideal. For a 17" model, either VGA (analog) or DVI/HDMI (digital) input is sufficient. For 19" and larger models, we recommend digital input. (Make sure your video adapter provides an output that's compatible with the display you choose.)

Some models are available with built-in speakers. Although their sound quality isn't as good as standalone speakers, many LAN partiers choose one of these models to eliminate the need to carry separate speakers. You can always use the built-in speakers on the road and a better set of speakers at home. We prefer to use standalone speakers at home and headphones on the road.

Table 5-1 summarizes our component choices for the gaming PC.

Table 5-1. Bill of materials for gaming PC

Component

Product

Case

Antec P150

Power supply

Antec NeoHE 430 (bundled with case)

Motherboard

ASUS M2N32-SLI Deluxe

Processor

AMD Athlon 64 X2 4200+

CPU cooler

AMD (bundled with processor)

Memory

Kingston KVR667D2N5K2/2G (two 1 GB PC2 5300 DDR2 DIMMs)

Video adapter

(See text)

Sound adapter

(Integrated)

Hard drive

Seagate Barracuda SATA 7200.9 (two 500 GB in RAID 0)

Optical drive

BenQ DW1650 DVD writer

Home mouse and keyboard

Logitech cordless mouse/corded keyboard

Away mouse

Logitech MX-series corded optical mouse

Away keyboard

Zippy EL-715 illuminated keyboard

Game controller(s)

(See text)

Speakers

Logitech Z-5500 5.1 speaker system

Headphones

Zalman ZM-RS6F surround headphones

Display

Samsung 930BF 19" LCD


Section 5.4. Building the Gaming PC

5.4. Building the Gaming PC

Figure 5-1 shows the major components of the gaming PC. The Antec P150 case is flanked on the left by the nVIDIA video adapter, and on the right by the ASUS motherboard. In front, left to right, are the two 500 GB Seagate hard drives, the BenQ optical drive, the AMD CPU cooler, and the Kingston DDR2 memory modules. The Samsung display, Logitech speakers, and the other external peripherals are not shown.

Figure 5-1. Gaming PC components, awaiting construction

Before you start building the system, verify that all components are present and accounted for. We always remind readers to do that, but for some reason we often forget to do it ourselves.

5.4.1. Preparing the Case

To begin preparing the case, place the Antec P150 upright on the work surface and loosen the captive thumbscrews that secure the left side panel, as shown in Figure 5-2.

Figure 5-2. Loosen the thumbscrews that secure the left side panel

Warning: Before you do anything else, check the back of the power supply to see if it has an input voltage switch. Auto-sensing power supplies (like the Antec NeoHE 430 we used) automatically detect the input voltage and set themselves for 120V or 240V operation. Other power supplies must be set manually for the correct input voltage. If you see a voltage switch, make sure it's set for the correct voltage.If you connect a power supply set for 240V to a 120V receptacle, no harm is done. The PC components receive half the voltage they require, and the system won't boot. But if you connect a power supply set for 120V to a 240V receptacle, the PC components receive twice the voltage they're designed to use. If you power up the system, that overvoltage destroys the system instantly in clouds of smoke and showers of sparks.

Sequencing the Build

Although by necessity we describe building the system in a particular order, you don't need to follow that exact sequence when you build your own system. Some stepsfor example, installing the processor and memory before installing the motherboard in the caseshould be taken in the sequence we describe, because doing otherwise makes the task more difficult or risks damaging a component. Other steps, such as installing the video adapter after you install the motherboard in the case, must be taken in the order we describe, because completing one step is a prerequisite for completing another. But the exact sequence doesn't matter for most steps. As you build your system, it will be obvious when sequence matters.

Swing the rear of the panel away from the case, as shown in Figure 5-3, and lift it free. Place the side panel aside, where it won't be scratched.

Figure 5-3. Remove the left side panel and set it aside

You'll see a large plastic bag in the drive bay. This bag contains various cables and small parts. Antec apparently wants to make very sure that bag stays in place during shipping, because they secure it with a plastic cable tie. Use your diagonal cutters or a sharp knife to sever the cable tie, as shown in Figure 5-4. Remove the plastic bag from the drive bay and unseal it. Some of the parts you'll need right away. Others you'll need later, or not at all.

Figure 5-4. Snip the cable tie that secures the plastic parts bag

The front bezel of the case is held in place by three plastic tabs along the inside left-front edge of the chassis. Press each one of these tabs toward the outside of the case to unlatch the bezel, as shown in Figure 5-5.

Figure 5-5. Press the three locking tabs to unlatch the front bezel

With all three plastic tabs unlatched, the bezel is free to rotate. Swing the left side of the bezel away from the case until it is at about a 45° angle, as shown in Figure 5-6. Then lift the right side of the bezel straight up about an inch, as shown in Figure 5-7, and pull the bezel free from the case.

Figure 5-6. Swing the left side of the front bezel away from the chassis

Figure 5-7. Lift the right side of the bezel up about an inch and then remove it

ADVICE FROM JIM COOLEY

DO NOT FORCE plastic bezels during removal because it's all too easy to break a latch or hinge mount. They are designed to be removed with a minimum of force, IF you are doing it correctly. If you have trouble, take a deep breath and examine the case more closely.

The NeoHE 430 power supply arrives installed in the P150 case. The NeoHE 430 uses Antec's patented cable management system. Only the main ATX power cable and the ATX12V power cable are permanently attached to the power supply. All other cables are optional, so you can install only the cables you need.

The optional power cables plug into one of the five proprietary 6-pin sockets on the power supply, as shown in Figure 5-8. Any of the optional cables can be connected to any of the sockets. Antec supplies three types of optional cables, which are stored in the large plastic bag you removed earlier:

  1. Two cables with a 6-pin power supply plug on one end and two S-ATA power connectors on the other.

  2. Two cables with a 6-pin power supply plug on one end and three Molex power connectors on the other.

  3. One cable with a 6-pin power supply plug on one end and a 6-pin PCI Express power connector on the other.

Figure 5-8. Connect the optional cables to the power supply

Antec also provides a short Y-adapter cable that connects to a Molex (hard drive) power connector on one end and provides two Berg (floppy drive) power connectors on the other. We had no need of that adapter, because we didn't install a floppy drive or any other component that uses the Berg connector in our gaming PC.

Our system requires one of each type of cable. The two S-ATA Seagate hard drives will receive power from one of the optional S-ATA power cables. The optical drive and rear case fan will receive power from one of the optional Molex power cables. The video adapter requires supplemental power, which it receives from the optional PCI Express power cable. We connected those three cables, as shown in Figure 5-8, leaving two of the proprietary 6-pin power supply connectors unused.

ADVICE FROM JIM COOLEY

Always get a couple spare cables (they're cheap) and leave one in the case if there's any chance you'll add another HD at some point down the road. Ditto for SATA adapter cables. There's nothing more infuriating than getting a new drive and not being able to install it at 11 P.M. on a Saturday night.

Like nearly all cases, the Antec P150 comes with a generic back-panel I/O template installed. As usual, this generic template doesn't match the back-panel I/O ports on the motherboard, so the next step is to remove that template. The template installed in our case was wedged in very tightly. We eventually were able to pop it out using a screwdriver handle. Start in one corner, and be careful not to hurt yourself if the template suddenly pops free. The template is thin metal and has sharp edges.

We didn't bend the template, but it was a near thing. Of course, it's not really the generic template we're concerned about. We have stacks of generic templates in a box in our workroom. (Robert never throws anything out.) But that template was well and truly stuck, and we were worried that we might bend the edge of the template cutout in the case. Fortunately, with a bit of patience we were able to remove the generic template without damaging the case.

With the original template removed, the next step is to install the custom back-panel I/O template that's supplied with the motherboard. Before you do that, verify that the holes in the custom template match the ports on the motherboard I/O panel. Although it's rare, we have seen custom templates that don't match the motherboard they were supplied with. Once you've verified that you have the correct I/O template, install it in the template cutout in the case, working from inside the case. Align the template with the cutout and use a screwdriver handle to press gently along the edges and corners until it snaps into place, as shown in Figure 5-9.

Figure 5-9. Align the back-panel I/O template and press gently until it snaps into place

More Cables

If we add one or two hard drives later, we'll install the second S-ATA power cable, which gives us two more S-ATA power connectors. Antec sells these optional power cables separately, so we could install as many as six S-ATA hard drives in this system if we ordered a third S-ATA power cable. Actually, we could install as many as eight hard drives by using the 3-connector Molex cables with Molex-to-SATA adapters.

Also, although Antec doesn't claim SLI compatibility for the NeoHE 430 power supply, we might use it to power two PCI Express video adapters by buying a second PCI Express power cable. If we did that, we'd have to be very careful to choose a pair of video cards that had relatively low current draw to keep within the current limits of the NeoHE 430.

The next step is to install brass standoffs in the case to support the motherboard once it is installed. Examine the motherboard to locate all of the mounting holes. It's easy to miss a mounting hole or two in all the clutter on a typical motherboard, so we generally hold the motherboard up to a bright light, which makes the mounting holes stand out.

Once you've located all the mounting holes (the ASUS M2N32-SLI Deluxe motherboard has nine), you need to make sure that standoffs are installed in each corresponding position on the motherboard tray. The easiest way to check this is to hold the motherboard in position above the case, as shown in Figure 5-10, and look straight down through each mounting hole to determine which motherboard screw holes should receive standoffs.

Figure 5-10. Hold the motherboard above the case to determine where standoffs should be installed

What's All That Copper?

That structure of copper pipes and fins that extends from near the rear I/O panel around the processor socket and toward the front edge of the motherboard is the ASUS Stack Cool 2, their unique solution to cooling the chipset and other heat-generating motherboard components. Unlike most high-end motherboards, which use active cooling (noisy fans), ASUS designed a completely passive cooling solution using heatpipes and copper radiators.

This passive cooling solution is very effective, and of course completely silent. It's also reliable, in the sense that there are no moving parts to fail. More than one owner of a motherboard with chipset cooling fans has had to replace that motherboard because a fan failed and the chipset burnt itself to a crisp. That's not possible with this passive cooling system.

The Antec P150 case comes with four standoffs installed, all of which correspond to mounting holes in the ASUS M2N32-SLI Deluxe motherboard. That means we need to install five more standoffs in the vacant positions that match the mounting holes in the motherboard.

Locate the plastic parts bag that contained the power supply cables you installed earlier. You'll find a small plastic bag with screws, standoffs, and other small parts. Set aside the five standoffs you'll need to install. While you're at it, locate nine motherboard mounting screws and set them aside as well. (You can verify you have the right screws by temporarily inserting one into a standoff.)

Install the five additional standoffs into the positions you determined earlier. You can use your fingers to install the standoffs, but using a 5mm nutdriver as shown in Figure 5-11 makes the job much easier. If you do use a nutdriver, be careful not to apply too much torque. The standoffs are made of soft brass that is easily stripped. Tighten the standoffs only finger-tight.

Figure 5-11. Install standoffs in each mounting position required by the motherboard

After you've installed the standoffs, temporarily slide the motherboard into position, as shown in Figure 5-12. Make sure that there's a standoff visible under each mounting hole, and that no extra standoffs are installed. After you've done that, remove the motherboard and set it on your work surface.

Figure 5-12. Verify that every mounting hole has a standoff and that no extra standoffs are installed

ADVICE FROM JIM COOLEY

Make sure the standoffs are tight enough that you won't unscrew them along with the motherboard screws if you ever remove the motherboard.

5.4.2. Populating the Motherboard

It is always easier to populate the motherboardinstall the processor and memorywhile the motherboard is outside the case. In fact, you must do so with some systems, because installing the heatsink/fan unit requires access to both sides of the motherboard. Even if it is possible to populate the motherboard while it is installed in the case, we always recommend doing so with the motherboard outside the case and lying flat on the work surface. More than once, we've tried to save a few minutes by replacing the processor without removing the motherboard. Too often, the result has been bent pins and a destroyed processor.

5.4.2.1. Installing the processor

To install the Athlon 64 X2 processor, lift the ZIF (zero insertion force) lever until it reaches vertical. With the arm vertical, there is no clamping force on the socket holes, which allows the processor to drop into place without requiring any pressure.

Pin 1 is indicated on the processor and socket by small triangles. With the socket lever vertical, align pin 1 of the processor with pin 1 of the socket and drop the processor into place, as shown in Figure 5-13. The processor should seat flush with the socket just from the force of gravity, or perhaps with very gentle pressure. If the processor resists being seated, something is misaligned. Remove the processor and verify that it is aligned properly and that the pattern of pins on the processor corresponds to the pattern of holes on the socket. Never force the processor to seat. You'll bend one or more pins, destroying the processor.

Figure 5-13. Drop the processor into the socket

With the processor in place and seated flush with the socket, press the lever arm down and snap it into place, as shown in Figure 5-14. You may have to press the lever arm slightly away from the socket to allow it to snap into a locked position.

Figure 5-14. Press the ZIF lever down until in snaps into place

When Pressure Is Good

Sometimes closing the ZIF lever lifts the processor slightly out of the socket. It does no harm (once the processor is already fully seated) to use gentle pressure to keep it in place as you close the ZIF lever.

5.4.2.2. Installing the CPU cooler

Current processors draw from 30 W to 130 W of power. Our Athlon 64 X2 4200+ processor is just below the middle of that range, so it produces about as much heat as a 60W incandescent light bulb. The processor must dissipate that heat over the surface of its heat spreader, which is about the size of a large postage stamp. Without a good CPU cooler, the processor would almost instantaneously shut itself down to prevent damage from overheating.

We used the stock AMD cooler included with the retail-boxed Athlon 64 processor, which is reasonably efficient and as quiet as any but the best aftermarket coolers. If you install a third-party cooler, make absolutely certain it is rated for the exact processor model you use and follow the installation instructions included with the cooler.

To install the stock AMD CPU cooler, begin by removing the plastic cover from the base of the heatsink, as shown in Figure 5-15. (We verified that it is possible to install the CPU cooler with the plastic cover still in place, but of course it won't function properly that way.)

Figure 5-15. Remove the plastic cover from the heatsink base

Polish the heat spreader surface on top of the processor with a paper towel or soft cloth, as shown in Figure 5-16. The goal is to remove any grease, grit, or other material that might prevent the heatsink from making intimate contact with the processor surface.

Figure 5-16. Polish the CPU heat spreader to remove skin oil and other foreign material

Warning: If you're using a third-party CPU cooler, also check the base of the heatsink. If the heatsink base is bare, that means it's intended to be used with thermal compound, usually called "thermal goop." In that case, also polish the heatsink base. Some heatsinks, including our stock AMD model, have a square pad made of a phase-change medium, which is a fancy term for a material that melts as the CPU heats and resolidifies as the CPU cools. This liquid/solid cycle ensures that the processor die maintains good thermal contact with the heatsink If your heatsink includes such a pad you needn't polish the base of the heatsink. (Heatsinks use either a thermal pad or thermal goop, not both.)

The CPU cooler secures to the socket by two spring steel retention brackets, one on either side of the heatsink. One of those brackets floats freely, and the other is linked to a camming lever that is used to lock the CPU cooler in place.

Backward Compatibility

The new AM2 socket uses the same retention-clip CPU cooler mounting arrangement as the older Socket 939, so nearly any third-party retention-clip CPU cooler designed for Socket 939 can also be installed on a Socket AM2 motherboard.

That's not true of Socket 939 coolers that mount with screws rather than the retention clips. Socket 939 uses a two-screw retention bracket versus the four-screw arrangement used for Socket AM2, so a Socket 939 screw-mount CPU cooler won't fit a Socket AM2 motherboard.

Position the free-floating retention bracket over the plastic nub on one side of the black plastic retention module base, as shown in Figure 5-17. (The CPU cooler can be mounted in either direction. We generally connect the free-floating bracket to the side of the retention module base nearer the center of the motherboard, which is usually more cramped for space.)

Figure 5-17. Position the free-floating retention bracket over the plastic nub on the retention module base

With the first retention bracket in position, make sure the cammed locking lever on the other bracket is in the fully open position shown in Figure 5-18 (rotated fully counterclockwise as you face it). Press the second bracket into position over the plastic nub on the retention module base. You may have to press down on the CPU cooler with one hand while guiding the bracket into position with the other.

Figure 5-18. Position the latching retention bracket over the plastic nub on the retention module base

Verify that both sides of the retention bracket are in position, and then pivot the cammed locking lever fully clockwise into the locked position, as shown in Figure 5-19. It takes significant pressure to lock this lever, so be prepared to press firmly if necessary.

Figure 5-19. Rotate the latching lever and press down firmly until it locks into place

The thermal mass of the heatsink draws heat away from the CPU, but the heat must be dissipated to prevent the CPU from eventually overheating as the heatsink warms up. To dispose of excess heat as it is transferred to the heatsink, most CPU coolers, including this one, use a fan to continuously draw air through the fins of the heatsink. Some CPU fans use a drive power connector, but most are designed to attach to a dedicated CPU fan connector on the motherboard. Using a motherboard fan power connector allows the motherboard to control the CPU fan, reducing speed for quieter operation when the processor is running under light load and not generating much heat, and increasing fan speed when the processor is running under heavy load and generating more heat. The motherboard can also monitor fan speed, which allows it to send an alert to the user if the fan fails or begins running sporadically.

To connect the CPU fan, locate the 4-pin header connector on the motherboard labeled CPU Fan, and plug the keyed 3-pin cable from the CPU fan into that connector, as shown in Figure 5-20. (The newer-style 4-pin CPU fan connector on the ASUS motherboard is backward compatible in pin assignments and keying with 3-pin fans.)

Figure 5-20. Connect the CPU fan power lead to the CPU fan power header on the motherboard

Warning: If you ever remove the CPU cooler, don't reuse the old thermal compound or pad when you reinstall it. Remove all remnants of the old thermal compound or pad, using a hair dryer or solvent if necessary, and reapply new thermal compound before you reinstall the heatsink.
5.4.2.3. Installing memory

The Athlon 64 X2 processor includes an embedded dual-channel memory controller that provides better memory performance than a single-channel controller. You must take care when installing memory, though. The system defaults to single-channel memory operation unless you install memory modules in pairs in the proper slots.

The ASUS M2N32-SLI Deluxe motherboard makes it hard to go wrong. The motherboard has four DDR2 memory slots in two color-coded pairs. If you're installing one matched pair of DIMMs, as we are, they both go in the yellow memory slots. If you add memory later, install another matched pair of DIMMs (which may differ in speed or capacity from the first pair) in the black memory slots.

To install a DIMM, pivot the locking tabs on both sides of the DIMM socket outward. Align the DIMM, as shown in Figure 5-21, making sure that the keying notch in the DIMM is oriented properly with the keying tab in the slot.

Figure 5-21. Align the keying notch and slide the first memory module into the slot

Once the DIMM is aligned and vertical relative to the slot, use both thumbs to press down firmly until the DIMM seats, as shown in Figure 5-22. When the DIMM seats, both locking tabs should automatically pivot back into the locked position, engaging the notches in the side of the DIMM. If the tabs don't fully engage the notches, press the tabs into place manually. Install the second DIMM in the other yellow slot in the same manner.

Figure 5-22. Press down firmly with both thumbs until the memory module seats completely

It may take significant pressure to seat a DIMM, depending on the combination of the particular modules you install and the slot. The combination of the ASUS M2N32-SLI Deluxe motherboard and the Kingston DDR2 memory modules proved to be a very tight fit.

When you seat the memory modules, make certain you are pressing straight down on them. Any sideways force may damage the module or the socket. DIMMs that are difficult to seat are one reason we always install memory with the motherboard outside the case and resting on a firm, flat surface. We have seen more than one motherboard cracked when a technician who was in too much of a hurry to remove the motherboard attempted to install memory modules with the motherboard still in the case.

It's very important to make absolutely sure that the memory modules are fully seated. If necessary, use a strong light and a magnifier to examine the junction between the module and the slot to verify that the module is fully and evenly seated. Partially seated memory modules can cause very subtle problems that are difficult to troubleshoot. Also, although we have never seen it ourselves, we have read credible reports of motherboards being damaged when they were powered on with a memory module only partially seated.

ADVICE FROM JIM COOLEY

I still prefer to make certain I have the notch lined up, then partially insert one side and then the other, then seat the whole module by firmly pressing down on both ends simultaneously. It's often a really tight fit, and this method avoids using too much pressure, which can be considerable if you do the whole module at once.

5.4.3. Installing the Motherboard

Installing the motherboard is the most time-consuming step in building the system because there are so many cables to connect. It's important to get all of them connected right, so take your time and verify each connection before and after you make it.

5.4.3.1. Seating and securing the motherboard

To begin, slide the motherboard into the case, as shown in Figure 5-23. Carefully align the back-panel I/O connectors with the corresponding holes in the I/O template, and slide the motherboard toward the rear of the case until the motherboard mounting holes line up with the standoffs you installed earlier.

Figure 5-23. Slide the motherboard into position

It's helpful to keep the front edge of the motherboard slightly raised as you slide the motherboard into position. As the back-panel I/O connectors on the motherboard come into contact with the back-panel I/O template, lower the front edge of the motherboard until the motherboard is level and then press gently to seat the back-panel ports in the template. In theory, at least, this prevents the metal grounding tabs on the I/O template from intruding into the ports.

Before you secure the motherboard, verify that the back-panel I/O connectors mate properly with the I/O template. Make sure none of the grounding tabs intrude into a port connector. An errant tab at best blocks the port, rendering it unusable, and at worst may short out the motherboard.

After you position the motherboard and verify that the back-panel I/O connectors mate cleanly with the I/O template, insert a screw through one mounting hole into the corresponding standoff. You may need to apply pressure to keep the motherboard positioned properly until you have inserted two or three screws.

If you have trouble getting all the holes and standoffs aligned, insert two screws but don't tighten them completely. Use one hand to press the motherboard into alignment, with all holes matching the standoffs. Then insert one or two more screws and tighten them completely. Finish mounting the motherboard by inserting screws into all standoffs and tightening them, as shown in Figure 5-24.

Figure 5-24. Install screws in all nine mounting holes to secure the motherboard

Chicken and Egg

It may be easier to connect the front-panel switch/indicator and port cables before you install the motherboard in the case. The trade-off is that if you install the motherboard first, you have plenty of cable length, but the pins you must connect those cables to are deep in the case and hard to get to. If you install the cables first, the pins are more easily accessible, but you have very little cable slack to work with, both when you connect the cables and when you slide the motherboard into the case. We generally install the motherboard first and worry later about getting all the cables connected.

Warning: When you install motherboard mounting screws, you're also putting torque on the standoffs. Tighten the motherboard screws gently, using a standard screwdriver. When you feel tension, stop turning the driver. If you overtorque the mounting screws, you're also overtorquing the standoffs, which may strip. Don't even think about using a power screwdriver with an aluminum case.

Before we installed the motherboard screws, we took a quick glance at the rear I/O panel, shown in Figure 5-25, to make sure that none of the metal ground tabs were protruding into ports. At first glance, everything looked fine, so we installed all nine motherboard screws.

Figure 5-25. Everything looked fine at first glance...

After we finished securing the motherboard, we planned to shoot an image of the rear I/O panel to show that none of the grounding tabs were obstructing ports. Ruh-roh. When we got down to shoot a close-up, we were surprised to see that both Gigabit Ethernet ports were obstructed, as shown in Figure 5-26. Although the grounding tabs weren't contacting any of the pins in the ports and so wouldn't cause a short circuit, the tabs made it impossible to connect a cable to either Ethernet port.

Figure 5-26. ...but two ports were fouled by grounding tabs...

If we'd been building this system for someone else (or if we weren't on a short deadline), we'd have removed the nine motherboard screws, pulled the motherboard, and started over. But this system was for us, and we had only a few days left until deadline, so we decided to use the quick-and-dirty method shown in Figure 5-27. Barbara carefully inserted a small flat-blade screwdriver under each of the problem grounding tabs, and bent them outward to clear the ports.

Figure 5-27. ...so we used a small flat-blade screwdriver carefully to bend the grounding tabs out of the way

5.4.3.2. Connecting front-panel switch and indicator cables

Once the motherboard is secured, the next step is to connect the front-panel switch and indicator cables to the motherboard. Before you begin connecting front-panel cables, examine the cables. Each is labeled descriptively, such as "Power SW" and "Reset SW" on the connector body. Match the descriptions with the front-panel connector pins on the motherboard to make sure you connect the correct cable to the appropriate pins. Figure 5-28 shows the pin assignments for the ASUS M32N32-SLI Deluxe motherboard front-panel switch/indicator connector, which is located on the left-rfront corner of the motherboard.

Figure 5-28. M2N32-SLI Deluxe front-panel connector pin assignments (graphic courtesy ASUSTeK Computer, Inc.)

  • The power switch (PWRSW) and reset switch (RESET) connectors are not polarized, and can be connected in either orientation.

  • The hard drive activity LED (IDE_LED) is polarized, and should be connected with the ground (white) wire to the pin labeled IDE_LED on the connector.

    BLACK AND WHITE

    Conventionally, the ground/common connection uses a black wire. For some reason, Antec uses a white wire for ground/common (-) and a colored wire for the signal (+) lead.

  • The power LED (PLED) connector uses two contacts in a 3-pin connector. Insert this cable with the white wire on the pin labeled PLED on the motherboard.

Once you determine the proper orientation for each cable, connect the power switch, reset switch, power LED, hard drive activity LED, and speaker cables, as shown in Figure 5-29. When you're connecting front panel cables, try to get it right the first time, but don't worry too much about getting it wrong. Other than the power switch cable, which must be connected properly for the system to start, none of the other front-panel switch and indicator cables is essential, and connecting them wrong won't damage the system. LED cables may or may not be polarized, but if you connect a polarized LED cable backward the worst that happens is that the LED won't light.

Figure 5-29. Connect the front-panel switch and indicator cables

ASUS Q-Connector

Retail versions of the ASUS M2N32-SLI Deluxe motherboard include ASUS Q-Connector blocks for the front-panel switch/indicator, USB, and FireWire cables. These blocks are small color-coded plastic devices that on one side have pins to accept the individual 2- and 3-pin connectors for the front-panel switches, indicators, and ports. The opposite side of the Q-Connector blocks have holes that match the appropriate sets of header pins on the ASUS motherboard. The Q-Connector converts the many individual front-panel connectors into one monolithic connector block. We used an engineering sample motherboard for this system, which did not include the Q-Connector blocks.

We regretted the lack of Q-Connector blocks only while we were installing the front-panel switch/indicator cables, for which the Antec P150 case provides individual 2- and 3-pin connectors. The Antec P150 case provides Intel-standard monolithic connector blocks for the front-panel USB, FireWire, and Audio cables. The ASUS motherboard uses the same Intel-standard pin assignments and keying for those cables.

TRANSGENDERED CONNECTORS

The usual practice is to refer to the connector on the end of a cable as a plug, and the connector on a motherboard or device as a jack. Historically, plugs have been male (such as the plug on the end of a lamp cord) and jacks have been female (such as a standard electrical receptacle). Some computer connectors ignore that convention, instead using female plugs and male jacks. Alternatively, you can think of it as placing the jack on the cable and the plug on the device.

5.4.3.3. Connecting the front-panel USB ports

The Antec P150 case provides two front-panel USB ports. Both of those ports share one cable, which terminates in an Intel-standard 10-pin USB dual-port connector. The ASUS M2N32-SLI Deluxe motherboard provides three sets of USB dual-port connector pins, for a total of six USB ports in addition to the four USB ports on the back-panel I/O connector. (The motherboard we used for this system is the M2N32-SLI Deluxe Standard Edition; the M2N32-SLI Deluxe Wireless Edition has only two sets of dual USB connectors.)

To enable the front-panel USB ports, locate the cable coming from the front panel that terminates in a black 10-pin 5X2 connector labeled USB. Plug that cable into either of the shrouded blue plastic USB connectors near the left-rear edge of the motherboard, as shown in Figure 5-30. The connection is keyed with a blocked hole on the cable and a missing pin on the motherboard connector, so be careful to orient the connectors properly before applying pressure.

Warning: The USB and FireWire connectors on the ASUS M2N32-SLI Deluxe motherboard are shrouded and keyed. Some cases and port extender cables have oversize keyed connectors, which shrouded motherboard connectors must be large enough to accept. (If the motherboard uses bare header pins, any connector will fit as long as the pin keying is correct). Antec uses simple block connectors for its front-panel USB and FireWire cables, which means there's extra space in the shrouded motherboard connectors, as shown in Figures 5-30 and 5-32. When you connect the front-panel USB and FireWire cables, be careful to orient the cable connector correctly and not to offset the connector by one set of pins.

Figure 5-30. Plug the front-panel USB cable into a motherboard USB jack

Advice from Jim Cooley

If your case has individual wires, bundling them with a cable tie to combine them into one connector block makes it much easier to get all of the wires connected.

The front-panel USB ports use one of the three available sets of internal USB dual-port connectors, leaving two of those connectors free for other purposes, such as connecting a card reader or USB floppy drive. ASUS provides a dual-port USB port extender, shown in Figure 5-31, which you can use to extend one dual USB port to an expansion slot cover on the back panel. To install the port extender, simply remove an expansion slot cover and connect the cliffhanger bracket as you would a standard expansion card, then connect the cable to one of the motherboard USB connectors.

Figure 5-31. The USB port extender (note blocked hole at lower left of blue connector)

You can purchase a second USB port extender from ASUS or another supplier to reach a total of ten USB ports, eight rear and two front. We decided that the standard four rear USB ports and two front USB ports were sufficient for our purposes, so we left two of the dual-USB internal connectors free for future use.

Warning: The Antec P150 case provides pin-keyed monolithic connector blocks, visible in Figure 5-31, for the front-panel USB and IEEE-1394 (FireWire) ports. The keying makes it more difficult to connect the wrong cable to a port (although it is still possible to connect a cable to the wrong connector if you accidentally offset the pins). If you are using a case that provides individual wires for the USB and/or FireWire ports, be extremely careful not to connect the USB cable to the FireWire port or vice versa. Doing so can destroy the motherboard and any connected devices.
5.4.3.4. Connecting the front-panel IEEE-1394a (FireWire) port

The Antec P150 case provides one front-panel IEEE-1394a port, with a cable that terminates in an Intel-standard 10-pin IEEE-1394a connector block. The ASUS M2N32-SLI Deluxe motherboard provides one IEEE1394a connector on the rear I/O panel and an internal FireWire connector that can be routed to the front or rear panel.

To enable the front-panel FireWire port, locate the cable coming from the front panel that terminates in a black 10-pin 5X2 connector labeled IEEE-1394. Plug that cable into the shrouded red plastic IEEE-1394 connector near the left-rear edge of the motherboard, as shown in Figure 5-32. The connection is keyed with a blocked hole on the cable and a missing pin on the motherboard connector, so be careful to orient the connectors properly before applying pressure.

Figure 5-32. Plug the front-panel FireWire cable into the motherboard FireWire jack

If you'd rather route the second FireWire port to the rear of the case, use the FireWire port extender that is included with the motherboard, shown in Figure 5-33. To install the port extender, remove an expansion slot cover and connect the cliffhanger bracket as you would a standard expansion card, then connect the cable to the motherboard FireWire connector.

Figure 5-33. The FireWire port extender

5.4.3.5. Connecting the front-panel audio ports

The Antec P150 case provides front-panel audio-in and audio-out connectors, with a cable that terminates in an Intel-standard 10-pin audio connector block. The ASUS M2N32-SLI Deluxe motherboard provides a full set of audio connectors on the back panel and an internal audio connector that can be routed to the front panel.

To enable the front-panel audio ports, locate the cable coming from the front panel that terminates in a black 10-pin 5X2 connector labeled Audio. Plug that cable into the black front-panel audio connector near the center PCI expansion slot, as shown in Figure 5-34. The connection is keyed with a blocked hole on the cable and a missing pin on the motherboard connector, so be careful to orient the connectors properly before applying pressure.

Figure 5-34. Plug the front-panel audio cable into the motherboard audio jack

AC97 Versus HD Audio

The front-panel audio connector on the ASUS M2N32-SLI Deluxe motherboard can be configured in BIOS to function as an AC97 audio connector or an HD audio connector. (The pin assignments are different.) By default, front-panel audio is configured as AC97. To change this, run BIOS Setup and change the settings to HD Audio. See the motherboard manual for details.

5.4.4. Installing the Optical Drive

The next step is to install the optical drive. The upper two 5.25" drive bays in the Antec P150 case include a universal drive door that conceals the front bezel of the optical drive. That means you can use any color of optical drive without the mismatch being visible. That's fortunate, because the gloss-white surface of the P150 bezel is very difficult to match with an off-the-shelf optical drive. We used a standard black optical drive for our system.

To begin installing the optical drive, locate a pair of the drive rails shown in Figure 5-35. If you are installing the optical drive in one of the bays with a universal drive door, use the rear set of screw holes. If you are installing the drive in a lower bay, use the front set of screw holes. (Using the rear set recesses the drive slightly, making room for the universal drive door; using the front set puts the drive flush with the front bezel of the P150.)

Figure 5-35. Install drive rails on the optical drive

Although there are four screw holes available for each drive rail, using two screws per rail is sufficient. We generally insert the front screw in the lower hole and the rear screw in the upper hole, but any arrangement with one screw in a front hole and one in a back hole works as well.

The screw holes in the drive rails are slightly oblong, providing a couple millimeters of slack. This is done to allow you to adjust the drive seating depth slightly to make sure that the pass-through button on the universal drive door can successfully operate the eject button on the actual drive bezel. We centered the screws in the screw holes, and found that they work fine with the BenQ DW1650 optical drive. If you use a different optical drive, you may have to play with the seating depth a bit to get the eject button to work properly.

With the drive rails mounted, slide the drive at least partway into the bay to verify that the rails are installed properly for correct vertical alignment of the drive in the bay. The next step is to install the ATA cable. ASUS supplies an 80-wire UltraATA cable intended for use with a hard drive. Our hard drives are both Serial ATA, so we used this cable for our optical drive. (A 40-wire ATA cable is sufficient for an optical drive, but it does no harm to use the 80-wire cable.)

Align the keying tab on the cable with the keying notch on the drive, and press firmly to seat the cable in the connector on the drive (Figure 5-36). If you are using an unkeyed ATA cable, make sure that pin 1 on the cable connector, indicated by a color stripe on the cable, is aligned with Pin 1 on the drive connector, which is nearly always toward the power connector on the drive.

Figure 5-36. Connect the ATA cable to the optical drive

To install the drive in the case, feed the loose end of the ATA cable into the drive bay and then slide the drive partially into the bay, making sure that both drive rails are aligned with the matching slots in the case body. Place your thumbs on either side of the drive bezel and press firmly until the drive slides fully into the bay, as shown in Figure 5-37. When the drive seats, the drive rails snap into the locked position.

Figure 5-37. Slide the drive into the bay and press firmly to snap the drive rails into the locked position

Feed the loose end of the ATA cable down toward the front edge of the motherboard. Keeping it clear of other cables will make your job easier during the final assembly steps when you neaten up the cables. Align the cable connector with the shrouded ATA connector on the motherboard, making sure that the keying tab on the cable connector is oriented properly with the keying notch on the motherboard connector. Press the ATA cable firmly into place, as shown in Figure 5-38, until it fully seats in the motherboard connector.

Figure 5-38. Seat the ATA cable in the motherboard ATA connector

Master and Slave

With standard (parallel) ATA devices, it's necessary to set a jumper to configure the device as the master (first) or slave (second) device on the channel. If only one device is connected to the cable, it should be set as master. The optical drive is the only ATA device in our gaming PC, so we'll make sure it's configured as the master device.

Some optical drives are set by default as master, and others as slave. As it happens, our BenQ DW1650 optical drive arrived from the factory jumpered as master, so we didn't need to change the setting. If you use a different model of optical drive, verify that it is set as master before you install it. If it is set as slave, simply move the jumper to the master position. Most optical drives have a figure illustrating the positions for master and slave settings printed on the drive label or stamped into the metal body of the drive itself.

Locate the Molex power cable you installed earlier on the power supply. Again, make sure you route that cable to avoid other cables as much as possible, and then press one of the Molex connectors into the power connector on the back of the optical drive, as shown in Figure 5-39. The Molex connector is keyed with two beveled corners on one side of the connector. Those beveled edges match similar bevels on the upper side of the drive power connector. Once you're sure the connectors are aligned properly, press firmly to seat the power cable in the drive connector.

Figure 5-39. Connect power to the optical drive

5.4.5. Connecting the ATX Power Cables

Ordinarily, we connect the two ATX power cables to the motherboard as one of the final assembly steps. With this motherboard and case, it's easier to make those connections before the hard drives or video adapter is installed.

The ASUS M2N32-SLI Deluxe motherboard has what we consider to be an almost ideal component layout. All of the connectors are well-placed and easily accessible, with one exception. The ATX12V supplemental power connector, shown in Figure 5-40, is so close to the blue PCI Express video card slot that it's very difficult to install the ATX12V cable with a video card already installed.

Figure 5-40. Connect the ATX12V power cable

Locate the ATX12V cable, which is one of the two cables that are permanently attached to the power supply. The ATX12V cable connector and the corresponding motherboard jack are keyed using square and beveled holes. Orient the cable connector properly against the ATX12V socket, as shown in Figure 5-40, and press the cable connector firmly until it seats completely in the socket. When the cable is fully seated, the latch visible in Figure 5-40 snaps over a projection on the socket, locking the cable in place.

The next step is to connect the 24-pin main ATX power cable, as shown in Figure 5-41. Align the cable connector with the socket, making sure that the latch on the cable connector is toward the front of the system. Press down firmly until the cable connector seats fully in the socket and the latch snaps into place. Make sure to complete this step before you install the hard drives, which obstruct access to the main ATX power socket.

Figure 5-41. Connect the main ATX power cable

5.4.6. Installing the Hard Drives

We're in the home stretch now. All that remains is to install the hard drives and video adapter and do a bit of cleanup. The first step in installing the hard drives is to loosen the two front-panel thumbscrews that secure the door that covers the hard drive bays, as shown in Figure 5-42.

Figure 5-42. Loosen the two thumbscrews that secure the hard drive bay door

Swing the hard drive bay door open, as shown in Figure 5-43. With the door open, the mounting arrangements are clearly visible. The Antec P150 provides two methods for mounting hard drives. (Antec cautions to use one or the other, but not both.)

Figure 5-43. Swing open the hard drive bay door

Four drive trays are visible, each secured by a pair of drive rails similar to those used to mount the optical drive. The first, and more traditional, mounting method is to secure the hard drives to those trays using screws. Antec provides soft silicone shock-mount pads, visible as the small circular white items in Figure 5-43, that isolate the drive physically from the case structure, minimizing the transfer of vibration and sound from the drive to the case.

The second mounting method, popular among quiet PC enthusiasts, is to use suspension mounting. Antec provides elastic bands, visible just below the front edge of each of the top three drive trays, for those who want to use this method. (If you use suspension mounting, you can install only three hard drives instead of four.)

The advantage of suspension mounting is that it is the best way to minimize hard drive noise. The disadvantage is that the hard drives are not securely connected to the case. If the system is moved, the drives may escape their mountings and rattle around inside the case, damaging the drives and other system components.

BELT AND SUSPENDERS

Our friend and colleague Jerry Pournelle built a similar system in an Antec P150 case, which he carries to and from his beach house. Jerry opted for suspension mounting despite the fact that he hauls this system around in the back of his SUV. His solution is to open the case each time he transports the system and stuff the drive bays full of bubble-wrap packaging, which protects the drives during transport. Needless to say, forgetting to install the bubble wrap might have catastrophic consequences, as might forgetting to remove it when he reaches his destination. Still, he seems happy with the arrangement.

With the drive bay door open fully, lift it slightly to disengage it from its hinges and lay it flat in front of the case, as shown in Figure 5-44. Note the cable that joins the door to the case, and be careful not to put any stress on it.

Figure 5-44. Remove the hard drive bay door

ON THE RAILS

The three plastic items visible at the bottom of the case in Figures 5-43 and 5-44 are spare drive rails for the external 5.25" drive bays. Three more rails are located inside the case. When we first opened the Antec P150 case, we were puzzled to find only three drive rails in a holder that was clearly designed for four. We were further puzzled because there should have been six rails available for the three external 5.25" drive bays. When we opened the hard drive bay cover, we realized that Antec had supplied six rails, but split three and three between two storage locations.

Our system will be portable, and we're not as brave as Pournelle, so we decided to screw-mount our hard drives. To begin, remove a drive tray, as shown in Figure 5-45. To do so, press inward on both drive rails to disengage the latches, and slide the hard drive tray out of the case.

Figure 5-45. Remove a hard drive tray

Secure the drive with four screws driven through the bottom of the drive tray and into the drive, as shown in Figure 5-46. Antec supplies special screws for this purpose, with wide heads and shafts that are only partially threaded. Place the drive upside down on the work surface, with the inverted drive tray over it. Align the screw holes and install the four screws finger-tight. Do not overtorque the mounting screws. You want them to apply some pressure to the silicone shock-mount pads, but not enough to deform them.

Figure 5-46. Insert four screws to secure the drive

With the drive secured to the tray, slide the tray into the drive bay until it latches, as shown in Figure 5-47. It doesn't matter greatly which bays you use. We were installing only two drives in the four-drive bay, so we decided to use the top and bottom drive bays to keep the drives as far apart as possible for better air flow and cooling.

Figure 5-47. Slide the mounted drive into the drive bay until it latches

With both drives installed in the hard drive bay, reinstall the hard drive bay cover, as shown in Figure 5-48. Align the pins on the cover with the corresponding holes in the hinges on the case body, and slide the cover down into place. Then close the cover and retighten the thumbscrews, as shown in Figure 5-49.

Figure 5-48. Reinstall the hard drive bay cover

Figure 5-49. Tighten the thumbscrews to secure the hard drive bay cover

FRONT FANS

The hard drive bay cover has mounting positions for two optional 92mm fans. If you're going to install one or two front fans, now is the time to do so. Install them as intake (blowing in) fans and route their power cables to the case interior before you reinstall the hard drive bay cover.

Locate the S-ATA power cable you connected to the power supply. Route that cable down to the back of the hard drives, again making sure to keep it clear of other cables to simplify things when you bundle and tie off the cables later. The S-ATA power connector uses an L-shaped connector body to ensure that it can't be connected backward. Orient the cable connector properly relative to the drive connector and then press the cable connector firmly until it slides completely onto the drive connector, as shown in Figure 5-50.

Figure 5-50. Connect the S-ATA power cables to the hard drives

ADVICE FROM JIM COOLEY

Use a white-out pen to paint a swath across the data and power cable and drive connectors to make re-attaching the S-ATA cables easier in the future, especially when you might not have ideal lighting.

With power connected to both hard drives, the next step is to connect the data cables. Like S-ATA power cables, S-ATA data cables use an L-shaped connector body to prevent installing them backward. Align the cable connector with the drive connector, and press firmly until the cable connector slides into place, as shown in Figure 5-51.

Figure 5-51. Connect the S-ATA data cables to the hard drives

Warning: S-ATA power connectors and data connectors are quite fragile. When you insert or remove an S-ATA connector, avoid putting any sideways pressure or torque on the connector. Slide the connector straight in to insert it, and pull it straight out to remove it.

Route the S-ATA data cables to the front edge of the motherboard, again avoiding entangling the cables with other cables. The ASUS M2N32-SLI Deluxe motherboard provides six S-ATA data connectors, labeled SATA-1 through SATA-6. Connect the primary hard drive to SATA-1 and the secondary drive to SATA-2, as shown in Figure 5-52.

Figure 5-52. Connect the S-ATA data cables to the motherboard S-ATA interfaces

On systems with several S-ATA hard drives, we generally label both ends of each S-ATA cable to make it easier to determine which drive is connected to which interface. In this case, with only two hard drives, we didn't bother to label the cables. Our standard practice is to install the first hard drive in the top position with the secondary hard drive below it. We followed that practice here, which makes labeling the cables unnecessary.

S-ATA RAID

In addition to the six S-ATA ports shown in Figure 5-52, the ASUS M2N32-SLI Deluxe motherboard provides an External S-ATA (eSATA) connector on the back panel and a seventh S-ATA connector near the right rear corner of the motherboard.

The six standard ports are provided by the nVIDIA nForce 590 SLI chipset, and support RAID 0, RAID 1, RAID 0+1, RAID 5, and JBOD configurations. The two rear SATA ports are provided by a separate Silicon Image Sil3132 SATA controller chip. The external port includes a port multiplier function (SATA-On-The-Go). Both rear ports support RAID 0, RAID 1, and JBOD configurations. We elected to use two of the standard S-ATA ports, leaving the Sil3132 ports available for future use.

5.4.7. Installing the Video Adapter

As an SLI motherboard, the ASUS M2N32-SLI Deluxe provides two PCI Express x16 slots for video adapters. If you're installing only one video adapter, as we are, you can install it in either slot.

Warning: If you're installing two video adapters, read the motherboard and video adapter manuals carefully to learn how to configure them properly. Also remember to connect the SLI Bridge cable to the golden fingers connectors on both video adapters. An SLI Bridge cable is supplied with the motherboard, and with most SLI-capable video adapters. You can use either SLI Bridge cable.

To begin installing the video adapter, temporarily slide it into position above the video adapter slot to determine which slot cover you need to remove. (We used the blue PCIe slot for our system.) Remove the screw that secures the expansion slot cover, as shown in Figure 5-53, and set it aside. Remove the slot cover and discard or store it.

Figure 5-53. Remove the screw that secures the slot cover

There's not much clearance once the video adapter is installed in its slot, so we recommend connecting the PCIe power cable before you install the video adapter. Not all PCI Express video adapters require supplemental power, but if yours does it's very important to remember to connect the supplemental power cable. If you forget, best case, the video adapter simply won't work. Worst case, the video adapter and motherboard may be damaged.

Many older PCI Express video adapters and a few current models have a Molex (hard drive) power connector on the card. If your video adapter provides a Molex socket, connect a Molex power supply cable to it (don't use a connector labeled "fan only," as it won't supply enough power). Most PCI Express video adapters use the special 6-pin PCI Express power connector, shown in Figure 5-54. If your video adapter provides this socket, connect the PCI Express power cable you attached to the power supply earlier.

Figure 5-54. Attach the PCIe power cable to the video adapter

Slide the video adapter into position above the PCI Express slot, making sure the rear bracket is aligned properly with the open expansion slot cover. Once you're sure everything is properly aligned, press down on the video card with both thumbs, as shown in Figure 5-55, until the card seats firmly in the slot. Verify visually that the video card is fully seated. You may feel or hear the card snap into place, but that is no guarantee that it is fully seated. Make sure that the card is flush with the slot and level, and that the retention mechanism on the front edge of the PCIe slot is fully engaged with the matching cutout on the base of the video adapter.

Figure 5-55. Align the video adapter with the slot and press firmly to seat it

Once the video adapter is seated properly, reinsert the screw to secure the card, as shown in Figure 5-56. Make sure that tightening the screw doesn't torque the far end of the video card contacts out of the video card slot. If that happens, you may need to bend the video card bracket slightly to release the pressure that causes it to torque out of the slot.

Figure 5-56. Insert the screw to secure the video adapter

5.4.8. Finishing Up

It's all over but the shouting now. All we need to do is connect power to the rear case fan and do some tidying up of the cables. The rear case fan is an Antec 120mm TriCool, so called because it can be set to run at low, medium, or high speed. The speed control switch is a small white box at the end of a short, stiff cable.

By default, the TriCool is set to run at low speed, which moves the least air but is also produces the least noise. For most systems, including this one, the low setting moves enough air to keep the system cool. Set the TriCool to medium or high speed only if the processor or motherboard temperature sensors report unacceptably high temperatures.

To enable the TriCool rear case fan, connect its power lead to a standard Molex power connector, as shown in Figure 5-57. The fan draws very little current, even at high speed, so it's safe to use the same Molex cable that you use to power the optical drive or ATA hard drives.

Figure 5-57. Connect power to the rear case fan

Warning: Some power supplies, including many Antec units, provide "Fan-Only" Molex connectors. If you power the TriCool fan with such a connector, we recommend setting the fan speed to high. Otherwise, the reduced voltage available on the Fan-Only Molex connector may be insufficient to start the fan spinning.

The final step in building a PC is always to dress the cables, which simply means organizing, bundling, and tying them off so that they don't clutter up the case interior, impeding air flow and possibly fouling a fan. The P150 case has built-in cable organizers for just this purpose. To reveal them, remove the right side panel from the case.

Gently feed the excess cable lengths through to the right side of the case and wrap them around the cable organizer hooks, as shown in Figure 5-58. Be careful not to pull too hard on the cables. Leave just a bit of slack to avoid putting undue stress on the connections.

Figure 5-58. Use the cable organizer hooks to bundle and tie off excess cable lengths

Advice from Brian Bilbrey

Most twist-ties are paper-over-thin-wire, and not suitable for system internal use, in my opinion. Of course, I buy cable-ties by the 200500 count, so... But even a small pack at any home center shouldn't be too expensive, and it's worth it in reliability and suitability for the job at hand.

In addition to using the cable organizer, look for opportunities to tuck and bundle the ATA data cable and the cables coming from the power supply. The drive bay immediately beneath the optical drive provides a convenient niche for tucking cables into. Don't forget to dress the ATX12V cable and the rear fan power cable. Use cable ties or plastic twist-ties to secure the cable bundles to the chassis frame or other convenient tie points. Don't hesitate to disconnect cables temporarily if you need to disentangle them from other cables or to route them around parts of the case structure.

Figure 5-59 shows the case interior immediately after we finished building the system. Figure 5-60 shows the case interior after we spent five minutes dressing the cables. Your goal should be a system that looks at least as well organized as Figure 5-60. Actually, because we built this system for ourselves, we spent less time dressing the cables. If we'd been building it for someone else, we'd have spent a few more minutes to make things even neater; for example, by bundling the cables visible near the front of the system and by tying off the gray front-panel cables to the frame at the upper right of the image.

Figure 5-59. The case interior before dressing the cables

Figure 5-60. The case interior after dressing the cables

5.4.9. The Smoke Test

After you finish building the system, take a few minutes to double-check everything. Verify that all cables are connected properly, that all drives are secured, and that there's nothing loose inside the case. Check one last time to verify the power supply is set for the correct input voltage, if applicable. It's a good idea to pick up the system and tilt it gently from side to side to make sure there are no loose screws or other items that could cause a short. Use the checklist:

  • Power supply set to proper input voltage (the Antec NeoHE 430 is auto-sensing)

  • No loose tools or screws (shake the case gently)

  • Heatsink/fan unit properly mounted; CPU fan connected

  • Memory modules fully seated and latched

  • Front-panel switch and indicator cables connected properly

  • Front-panel I/O cables connected properly

  • Hard drive data cable connected to drive and motherboard

  • Hard drive power cable connected

  • Optical drive data cable connected to drive and motherboard

  • Optical drive power cable connected

  • Optical drive audio cable(s) connected, if applicable

  • Front-panel voltage/fan controller connected (if applicable)

  • Floppy drive data and power cables connected (if applicable)

  • All drives secured to drive bay or chassis, as applicable

  • Expansion cards fully seated and secured to the chassis

  • Video adapter power connected (if applicable)

  • Main ATX power cable and ATX12V power cable connected

  • Front and rear case fans installed and connected (if applicable)

  • All cables dressed and tucked

Once you're certain that all is as it should be, it's time for the smoke test. Leave the cover off for now. Connect the power cable to the wall receptacle and then to the system unit. Unlike many power supplies, the Antec NeoHE 430 has a separate rocker switch on the back that controls power to the power supply. By default, it's in the "0" or off position, which means the power supply is not receiving power from the wall receptacle. Move that switch to the "1" or on position. Press the main power button on the front of the case, and the system should start up. Check to make sure that the power supply fan, CPU fan, and case fan are spinning. You should also hear the hard drive spin up and the happy beep that tells you the system is starting normally. At that point, everything should be working properly.

Only the Good Die Young

When you turn on the rear power switch, the system will come to life momentarily and then die. That's perfectly normal behavior. When the power supply receives power, it begins to start up. It quickly notices that the motherboard hasn't told it to start, and so it shuts down again. All you need to do is press the front-panel power switch and the system will start normally.

Once the system passes the smoke test, connect your keyboard, mouse, display, and any other external peripherals. Start the system and run BIOS Setup. Read the ASUS motherboard manual carefully, and follow the directions for initial system configuration exactly. Once you have completed BIOS Setup configuration, save your changes, shut the system down, and restart it with the operating system distribution disc in the optical drive. Install the OS, updated drivers, and your applications software, and you're ready to roll. Oh, and don't forget to replace the side panel.

BIOS Updates

Our ASUS M2N32-SLI Deluxe motherboard arrived with the latest BIOS version already installed. When you first boot your system, check the installed BIOS version. Visit the ASUS web site to see if there's a later version available. If so, install it, following the instructions supplied with the updated BIOS file.


Section 5.5. Final Words

5.5. Final Words

This system went together easily. Actual construction took about 90 minutes, spread out over several days (as usual in our case) as we photographed each step. If this is the first time you've built a system, leave yourself a full weekend to build it, install software, and so on.

We're quite pleased with the performance of this system. It's noticeably faster than our old LAN party PC, which used a Pentium 4 Extreme Edition 3.4 GHz processor. Our new gaming PC is small enough and light enough to make it easy to transport.

The system is a bit louder than we hoped, but is still much quieter than typical gaming systems with similar performance. Nearly all of the noise is produced by the stock AMD CPU cooler and the fan on the nVIDIA GeForce 6800 Ultra video adapter.

We could make this system nearly inaudible with only two changes, one minor and one major. Replacing the stock AMD CPU cooler with a Zalman or Thermalright cooler would cost $30 to $75, and would greatly reduce or eliminate CPU cooler fan noise. Replacing the noisy, actively cooled GeForce 6800 Ultra video adapter with a modern fanless video adapter (or two) would eliminate the high-pitched drone of the video card fan while maintaining or increasing video performance. With both of these upgrades, the gaming PC would be quiet enough to use even in the den or living rooma mild-mannered general purpose PC by day, and a kick-ass gaming PC by night.

Robert was thinking about putting the gaming PC in his office as his new primary system. Unfortunately, while he was thinking about it, Barbara grabbed the gaming PC. It now sits in her office as her primary desktop system. Oh, well.

For updated component recommendations, commentary, and other new material, visit http://www.hardwareguys.com/guides/gaming-pc.html.

TECH HELP
Lugging All This Stuff

The gaming PC is easily luggable, but that raises the question, "What about all my other stuff?" You need a lot of accessories when you attend a LAN party, and it makes sense to organize them in one place. The best solution we know ofalbeit an expensive oneis to use a deep, oversize aluminum case with cut-to-fit foam liners, such as those available from Zero Halliburton. You can arrange the interior so that every accessory has its own place, making it evident at a glance if something is missing. Such cases are expensive, particularly in large sizes, so those on a budget may have to compromise on a large nylon backpack, such as those available from L.L. Bean and Lands' End. (You can also buy purpose-built LAN Party accessory cases from many online vendors. Google for "LAN party accessories" and you'll turn up a bunch of hits. We have no experience with any of those, so we can't comment.)

As to what to carry, here's our list:

  • Flat-panel display (wrapped in foam unless you use a rigid case)

  • Display cable (and a spare)

  • Keyboard and mouse (with spare batteries, if applicable)

  • Wrist rest, mouse pad, and any other ergonomic accessories you use

  • Headphones and/or speakers

  • Category 6 Ethernet drop cable, 10-foot (and a spare)

  • Extra USB cables (standard, 4-pin mini, and 5-pin mini) and FireWire cables

  • Power cables for the PC and display (and spares). An outlet-strip surge protector is also handy. There are seldom enough electrical receptacles.

  • Cable ties to keep everything neat. The last thing you want is someone tripping over your power cable.

  • Copies of all the games you plan to play, including any that you haven't installed on the hard drive. The best way to carry CDs and DVDs is in a zippered nylon audio CD case, available at Best Buy and similar retailers. Make sure you also have patches, cheat sheets, and similar items, either on the hard drive or on CD.

  • A minimal toolkit. Include at least a #2 Phillips screwdriver, needle-nose pliers, a flashlight with batteries, and spare screws and other small connectors. It's also a good idea to include a small first-aid kit, with adhesive bandages, disinfectant, and so on.

  • Spare glasses or contact lenses, medications, etc.

  • Emergency stock of munchies and caffeinated beverages.

That's a lot of stuff, including some things you may never need, but Murphy's Law says whatever you leave at home will turn out to be what you need at the LAN party.


Chapter 6. Building a Media Center PC

We admit it. We're audio/video Luddites. Our home audio system is a dozen years old. The receiver has Dolby Pro Logic, but we've never gotten around to hooking more than two speakers to it. We use it only for playing CDs and occasionally an elderly cassette tape. We have a standard 27" Panasonic television, analog cable, no premium channels, no satellite receiver, and we didn't buy our first DVD player until 2005. TiVo? We've heard of it.

The only movies we watch are DVDs we rent from Netflix or borrow from the library or friends. We sometimes watch "Mystery!", "Masterpiece Theatre," or other PBS programs. Other than infrequent viewing of local news, sports, and weather, that's about it. We often go for literally months on end without watching a network television program or seeing a television commercial. And we like it that way.

For nearly 20 years, we've made it a practice never to watch television in real time if we can avoid it. We record everything, including commercial-free programs, and watch them later at our convenience. That way, we can watch multipart programs without waiting a week between episodes, and if the phone rings we can simply pause the program. The only change we've made over the years was to replace our VCRs as they died with inexpensive DVD recorders, which simply substitute inexpensive, convenient, reliable optical discs for bulky, inconvenient, unreliable VHS tapes.

Despite the very limited amount of time we devote to watching television, it sometimes happens that two programs we want to record are on simultaneously or that we want to watch a recorded program at the same time another program needs to be recorded. To avoid such conflicts, we have DVD recorders all over the house. One in the den. One in the master bedroom. One in the guest suite downstairs.

So why do we need a media center PC? We don't, really. In fact, we built a very capable home theater PC for the first edition of this book. After we verified that everything worked as it should, we found that we never used the system. We turned it off. It gathered dust, and eventually we salvaged its parts for other systems. There was nothing wrong with that system, mind you. It worked perfectly. We simply had no need for its capabilities.

But we freely admit that our television viewing habits (or lack thereof) are far outside the norm. Most people watch several hours of television every day, and have access to scores or hundreds of channels. If you're in that group (it's OK; you can admit it...), building a media center PC makes a lot of sense. It's not necessarily the easiest or least expensive alternative, but rolling your own media center PC offers a lot of advantages. Consider the alternatives:

Commercial Windows Media Center Edition (MCE) PC

Dell, HP, Gateway, Sony, and others offer purpose-built media center PCs that run Microsoft Windows Media Center Edition (MCE). The lure of these systems is that the integration work has been done for you and that everything is supposed to just work, more or less.

But there are many downsides to buying an MCE system. Although some MCE systems are advertised in the sub-$1000 range, these systems are minimally configured and often lack even such basic functions as the ability to record TV programs. Reasonably equipped MCE systems sell in the $1,200 to $1,500 range and up, and fully equipped systems may cost $2,500 or more. Even expensive models may have limited expandability. Windows MCE itself is problematic. It is crash-prone, even when running on fully certified equipment, and is unreliable. For example, many of our readers have reported such problems as MCE inexplicably failing to record a scheduled program or crashing reproducibly while playing back a recorded program. Finally, MCE is loaded with DRM (Digital Restrictions Management), which limits your freedom to use your recorded audio and video data as you wish.

TiVo

TiVo remains very popular, although we don't understand why. Perhaps it's because TiVo is simple and reliable. It's easy to specify the programs you want to record, and TiVo always works as expected. The TiVo interface is attractive and functional. So why don't we like TiVo? First, it's expensive. A basic TiVo unit with dual tuners costs about $1,000 over five years after you factor in the monthly service charge. TiVo uses high compression with correspondingly low video quality. TiVo panders to the movie studios, networks, and advertisers, for example, by displaying special commercials when you fast-forward to avoid other commercials. Finally, TiVo also enforces DRM measures that make it difficult to view your recorded programs on other devices.

Cable/satellite PVR

Many cable and satellite providers rent basic set-top PVR systems, sometimes for as little as $5/month. The lure of these set-top PVR boxes is their low cost and tight integration with the cable or satellite feed. These devices offer little functionality, less flexibility, and poor reliability, but may suffice if your needs are limited and you don't want to archive recorded programs or view them on other devices.

DVD recorder

The VHS VCR is dead, replaced by inexpensive devices that record to optical discs instead of tapes. Basic DVD recorders cost less than $100. (We paid $78 for our CyberHome DVR-1600 unit.) Recording time on a $0.25 DVD+R disc or $1.00 DVD+RW disc typically varies from one hour (better than DVD quality) to six or eight hours (VHS quality). DVD recorders with built-in hard drives range in price from $275 to $1,000+, and typically store from 20 to 50 hours of DVD-quality recordings, which can easily be written out to DVD recordable discs. Current models enforce no DRM, although that may change as the movie studios and television networks continue to push for legislation such as the Broadcast Flag that mandates DRM in consumer recording equipment.

If your only requirement is to record television programs for later viewing, a basic optical-only DVD recorder or one of the less expensive hard disk models is the best choice. These units don't have an Electronic Program Guide (EPG), so you have to program recording times and channels yourself, but that is not unduly burdensome for most people.

Other than Windows MCE systems, which have problems of their own, none of these options offers anything more than basic television recording functions. If you need (or want) more, it's time for Plan B: rolling your own media center PC.


Section 6.1. Determining Functional Requirements

6.1. Determining Functional Requirements

We started our design of the media center PC by pretending that we were heavy consumers of audio and video media and deciding which functions were essential or desirable. Our goal was to design a media center PC that we could build for about the same price as a commercial Windows MCE PC, but with additional features and functionality.

Here's the list of functional requirements we came up with:

Analog cable-ready, 125-channel tuners

Our cable TV service is standard analog that uses no channels above 99, but our televisions can tune channels through 125. Because our cable company sometimes adds channelsand sometimes adds higher-numbered channels while leaving lower channels unusedwe need tuners that support analog cable channels at least through Channel 125.

Digital OTA tuner

Although we don't yet own an HDTV, that could change at any time. We want our media center PC to record OTA (over-the-air) digital broadcasts, which requires a digital tuner. Also, with Broadcast Flag legislation looming, we wanted to acquire a DRM-free digital tuner card while they were still available. Most digital tuner cards can also tune digital cable signals, but only those that use unencrypted QAM-64 or QAM-256, which is usually limited to local channels, if that.

Time-shifted video recording

We use our DVD recorders primarily for time shifting. Other than sporting events, news, weather, and similar live programming, we haven't watched a program in real time for 15 years or more. We record everything and zap the commercials, if any. It is essential that the media center PC provide similar functionality, including commercial zapping.

Video recording quality

We record everything in DVD-quality mode unless we're recording a movie that requires higher compression to fit on one disc. Accordingly, although lower-quality recording modes are desirable for additional flexibility, DVD-quality mode is essential.

Capacity

We tend to accumulate recorded programs and watch them in batches. For example, if "Masterpiece Theatre" is running a four-part series, we don't begin watching the series until we've recorded all four episodes. Sometimes we don't watch a series until months after we recorded it. We decided we needed an absolute minimum of 100 hours of DVD-quality video storage, and 250 hours or more would be better.

Watch-while-record

The system must allow us to watch one live analog program while recording another analog and/or digital program.

Record multiple programs simultaneously

The system must allow us to record two analog programs simultaneously. We decided to settle for the ability to record only one digital program at a time, because to do otherwise would require additional digital tuners. That would be overkill for our system, but perhaps not for yours.

Live-pause and real-time commercial zapping

The system must allow us to "live-pause" a program while it is being recorded. That is, if we begin watching a program in real time, the system must allow us to press a pause button when the phone rings and continue recording the program. When we have dealt with the interruption, the system must allow us to resume watching the program at the point we paused it. Because live-pause buffers video for later viewing, this feature also allows us to zap commercials in a live program by waiting several minutes after the program starts to begin watching it.

Online program guide

The system must feature a free, interactive program guide, customized to the channels provided by our cable system. Selecting a program to be recorded should be a simple matter of pointing to that program on the guide menu and pressing a button. Ideally, the program guide should be customizable to hide channels we never watch.

Video archiving

The media center PC must make provision for archiving recorded programs to writable DVD discs that can later be played back in the media center PC or on an ordinary DVD player.

Standard file formats

The media center PC must record video data as standard file formats without DRM copy protection or other impediments to copying and editing those recordings. Ideally, the media center PC would also be able to translate various standard file formats to other file formats.

CD and DVD player

The media center PC must function as a standard CD player and DVD player, capable of playing CD-DA audio discs and DVD-Video discs. Ideally, the media center PC should also be capable of ripping the content of CD and DVD discs to its hard drive.

Media library and audio/video server

The media center PC should provide a media library management function, allowing us to store, organize, and play back video and audio data, including the MP3, OGG, FLAC, and WAV audio file formats, as well as digital camera images in JPEG and RAW formats and DV camcorder video. The media center PC should also function as a multimedia server for other systems throughout the house, by allowing those other systems to access stored audio/video via a network share.

Gaming console replacement

The media center PC should function as a gaming PC, within the limitations of using a standard television for display. We're only casual gamers, so even an entry-level 3D graphics card suffices for our needs. Dedicated gamers can install the latest fire-breathing gaming video card instead.

Casual PC replacement

The media center PC should be usable for casual PC functions such as checking email or browsing the Web, again within the limitations of using a television as a display device. Don't overestimate the abilities of a standard-definition TV. Our 27" CRT standard-definition TV supports 640 x 480 resolution at best, which makes it marginally usable for web browsing and email. When we replace that old 27" Panasonic, we'll choose a 32" or 35" LCD model that supports at least 720p, if not 1080p. Such a display has sufficient resolution to use for any PC function, including gaming.

Extensibility

As we thought about the functions a media center PC could provide, we realized that it could support other unrelated functions in the future. For example, we may eventually use the media center PC to control a home weather station or provide automated attendant and voice mail functions for our home telephone system. Because the media center PC is a standard PC, making provision for these possible future functions is a simple matter of making sure that the media center PC has plenty of processor, memory, hard drive capacity, USB ports, and so on.

Ease of use

Although the media center PC is a PC and will sometimes be used as such, ease-of-use is a major consideration for the core multimedia functions. For example, scheduling a program to be recorded or playing a DVD should be a matter of punching a few buttons on a remote control rather than navigating menus with keyboard and mouse.

Upgradable to HD-DVD and/or Blu-Ray

Consumers initially ignored the rollout of high-definition video discs based on the competing HD-DVD and Blu-Ray standards, and rightly so. The first players were slow, crash-prone, and overpriced by an order of magnitude. Only a handful of titles were available, and they sold at a 50% to 100% premium over standard DVDs. Still, those initial teething pains will eventually be dealt with, and either HD-DVD or Blu-Ray (not both) will become the new standard. We wanted our media center PC to be easily upgradable to support whichever HD standard eventually wins.

At first glance, it might seem that adding high-definition support would be as easy as replacing the existing optical drive with an HD-DVD or Blu-Ray model. There's more to it than that, though. HD playback requires a lot of processing power, memory, and video bandwidth, which is why early Blu-Ray players were essentially thinly disguised Pentium 4 PCs. We'll design our media center PC to have sufficient resources to be easily upgradable to support high-definition optical discs. At most, we'll need to upgrade the optical drive and video adapter.

That laundry list is a lot to ask of a system, but even at that one of our original wish-list items didn't make the final cut:

Streaming video/RF-out

We originally intended to design a media center PC capable of outputting an RF signal that could be received by any television in the house. We concluded that, although it was possible to do that, it would require significant cost and effort for little return. As an alternative, we decided it would be easy enough to burn any programs we wanted to watch elsewhere to a DVD and watch them on a standard DVD player.


Section 6.2. Hardware Design Criteria

6.2. Hardware Design Criteria

With the functional requirements determined, the next step was to establish design criteria for the media center PC hardware. The table to the right shows the priorities we assigned for the media center PC.

DESIGN PRIORITIES

Price

Reliability

Size

Noise level

Expandability

Processor performance

Video performance

Disk capacity/performance

Here's the breakdown:

Price

Price is an issue in that we'd like the total price of the system to be lower than that of a commercial Windows MCE system with similar functionality, or, alternatively, that the price be the same but the functionality of our system be higher. Accordingly, we'll use only first-rate components in this system, and if spending a few extra dollars buys us additional performance, reliability, or functionality, we'll spend the extra money.

Reliability

Reliability is important for this system. Not, perhaps, in the same sense that reliability is critical for a departmental file server, but Robert never wants to have to explain to Barbara why our fancy new media center PC failed to record a program she was looking forward to watching. We won't use RAID disk storage, ECC memory, and other server technologies for cost, space, and other reasons, but we will attempt to design as reliable a system as possible within those constraints by using top-notch components, emphasizing cooling even at the expense of noise level, using an oversize power supply, and so on.

Running Your Own TV Station

If you want to distribute RF throughout your home, you can do so by using an RF modulator. In theory it is possible to distribute that signal on the existing cable by filtering the channel used by the RF modulator at the cable demarc, but in practice attempting to do so risks poor image quality and interference on that channel, not just for you, but for your neighbors. If that happens, expect a visit from an angry cable company employee.

The alternative, which we would choose, is to run a separate coax cable to each TV and provide some means of switching between the two RF inputs. We decided that wasn't worth the trouble. It's easier just to transfer video files, either on a DVD or across the network to a set-top PC connected to the remote TV.

Size

Size is relatively unimportant for our media center PC, but we would like it to resemble a standard home-audio component in size, shape, and appearance. Accordingly, rather than simply using the smallest available case, we evaluated cases that were designed for use as media center PCs.

DEPTH MATTERS

Many media center PCs have been built in standard mini-tower cases, and we've even seen one or two in full-tower cases standing beside the television. If your media center PC is to reside in an entertainment center, make sure that the case you use fits. In particular, if your entertainment center has an enclosed back, make sure the case is not too deep to fit.

Ron Morse adds that in addition to case dimensions, you need to allow for the big, fat, long video connector and its thick cable, and the AC power cord, too. Also, many media center PC cases exhaust warm air through side or top vents, so to prevent overheating it's important to maintain an inch or more of clearance near those vents.

Noise level

Perhaps surprisingly, noise level is only moderately important for our media center PC. That's true because this system is destined to reside in an entertainment center across the room from the sofa. When the system is being used to view a movie or listen to music, even moderately loud system noise is swamped by the sound coming from the speakers. Of course, the system is not always active, so it must be reasonably quiet to avoid interfering with other uses of the room. Achieving low noise levels always involves trade-offs among cost, performance, cooling, and reliability. All other things being equal, a quiet system costs more, is slower, runs hotter, or is less reliable (or all of those.) Accordingly, we decided to compromise by using quiet standard components, but not by using radical quiet-PC technologies such as a very slow processor, an insulated enclosure, fanless coolers, water cooling, and so on.

Expandability

Expandability is moderately important, but only in the sense that we want our system to be easily upgradable to newer technologies like HD-DVD or Blu-Ray. Any new component we install will likely replace an old component, so we have no real need for many spare drive bays, expansion slots, and so on. We want provision for one optical drive and at least two hard drives. We'll choose a motherboard with integrated everything except video, so the only expansion slots we'll need are one PCIe slot for the video adapter and two or three PCI slots for the tuners. We do want to make provision for adding unrelated functions to the system, such as controlling a home weather station or functioning as an automated attendant and voice mail controller for our telephone system, but we can accommodate that requirement by having one or two spare expansion slots.

Processor performance

Processor performance is moderately important. Simple functions such as playing a CD or DVD or playing recorded video are undemanding; the slowest mainstream processor is more than sufficient for such functions. Recording video is a different matter, because real-time video compression is extremely CPU intensiveparticularly HD videobut we intend to use analog tuners with hardware compression support and a digital tuner that offloads compression duties to the video adapter GPU. But we still need a capable processor because the media center PC will at times function as a normal PCfor gaming, web browsing, and so onand we want to build the system initially with enough processor horsepower to handle an HD-DVD or Blu-Ray optical drive, either of which places heavy burdens on the main system processor.

TECH HELP
Older Standards Make Life Easier

Sometimes the old ways are the good ways, and this is certainly true for someone who wants to build a media center PC. Broadly speaking, there are two types of television signaling protocols and two delivery methods.

The current standard-definition television signaling protocols are NTSC (National Television System Committee), which is used in North America and Japan, and PAL (Phase Alternating Line), which is used in most of Europe, China, and Africa. NTSC and PAL are analog protocols. They may be transmitted over-the-air or via cable using analog transmission or via cable or satellite using digital transmission. The second type of signaling protocol used in the United States is called ATSC (Advanced Television Systems Committee). ATSC is comparable to the DVB (Digital Video Broadcasting) standard used in Europe and the ISDB (Integrated Services Digital Broadcasting) standard used in Japan. ATSC is purely digital and may be transmitted over-the-air or via cable or satellite, using digital transmission methods. Although Digital Television (DTV) and HDTV (High-Definition Television) are inextricably linked in the public mind, ATSC standards also define standard-definition DTV modes.

There are several other standards in limited use. France uses SECAM (a French acronym for Sequential Color with Memory). Brazil uses a hybrid of NTSC and PAL called M-PAL. Argentina, Paraguay, and Uruguay use a lower bandwidth version of PAL called N-PAL. Many former Soviet-bloc and Middle Eastern countries use a variant of SECAM called MESECAM. But if you're reading the English-language version of this book, you're almost certainly using NTSC or PAL, and most capture cards are available in versions for either of those standards.

Although digital transmission and HDTV have real advantages in terms of bandwidth and image quality, both have severe drawbacks for anyone contemplating building a media center PC. A standard NTSC signal delivered by analog cable is easy for a media center PC to deal with. You can simply connect the cable to the tuner card and allow the PC to change channels as needed.

Using digital cable or satellite as a program source makes matters more complex. Although digital tuner cards for PCs exist, various laws and differing cable/satellite standards limit their utility. A digital tuner card can freely tune OTA digital broadcasts (standard-definition or high-definition), but probably cannot tune digital signals supplied by cable or satellite, unless those signals are unencrypted (rare) and use a standard modulation method such as QAM-64 or QAM-256.

In practical terms, if your signal source is digital cable or satellite, you will probably be limited to using the satellite receiver or digital cable box to tune the signal. To record programs on different channels, you must change channels on the satellite box or digital cable receiver rather than on the media center PC. That makes it difficult, although not impossible, to select the channel to be recorded under programmatic control.

Some satellite receivers and digital cable boxes are programmable to change channels at specific times. If you have such a box, programming recordings becomes a two-step process: program the cable/satellite box to tune the proper channel at the proper time, and program the media center PC to begin recording at that time on the output channel of the cable/satellite box. If you don't have a programmable cable/satellite box, the best solutions to the digital tuning problem are Rube Goldberg arrangements.

One solution is a programmable remote control for your satellite receiver or digital cable box. To record a program, you set the remote control to change to the proper channel at the proper time and leave it pointed at the satellite receiver or digital cable box. You also set the media center PC to begin recording at the proper time. The media center PC records whatever signal the satellite box or digital cable box happens to be delivering, so if someone moves the remote or the dog walks in front of it at just the wrong time, you may end up recording something other than what you intended.

Another solution is to equip the media center PC with an IR emitter that can mimic the remote control for your satellite receiver or digital cable box. The IR emitter works under control of a scheduling program running on the media center PC. When it's time to record a program, the media center PC sends a series of commands to the IR emitter, which turns on the satellite receiver or digital cable box and tunes it to the correct channel.

Either of these methods is awkward at best, but some solutions, such as the IR Blaster described later in this chapter, are reported to work well enough to get the job done.

Video performance

Video performance is moderately important overall, but there are several aspects of video performance in a media center PC that must be considered individually. Video capture quality is critical, so it's important to choose tuner/capture cards with excellent native video quality. Video playback quality is also critical, but any decent video adapter can easily handle video playback. When the media center PC is being used as a PCas for browsing the Web or checking email2D display quality is important, particularly because even high-definition televisions are not designed to be used as computer displays. Fortunately, the nVIDIA video adapters that are required to assist the HDTV tuner card in compressing the video stream also have excellent image quality when a television is used as the display. The final aspect of video performance is 3D acceleration for gaming. Our media center PC will be used for only casual gaming, so very high 3D graphics performance is unnecessary.

Disk capacity/performance

Disk capacity and performance are moderately important. Years ago, we'd have ranked these aspects as critically important, because hard drives of the time were smaller and slower than today's models. Fortunately, current hard drives have huge capacities and even mainstream models are fast enough to keep up with the demands of a media center PC. At first glance, capacity might seem more important than performance, but in fact both are equally important. On a lightly loaded media center PC, even a slow, 5,400 RPM "near-line" drive might be fast enough. But our system is designed to support many activities concurrently, all of which require disk access. For example, our system might have to play back one analog stream while it records a second stream on the second analog tuner while it records a third stream on the digital tuner while it streams audio to Barbara's office. To make sure the drive can keep up without dropping any frames, we'll choose a 7,200 RPM S-ATA drive that supports NCQ (Native Command Queuing) and has a large buffer.


Section 6.3. Choosing Software

6.3. Choosing Software

The traditional advice is to choose software before choosing the hardware to run it, and that holds true in spades for a media center PC. The PVR and related software applications that will run on the media center PC are fundamental. So, before we made specific hardware selections, we had to decide which PVR software to use. That in turn requires deciding which operating system to run. There are three practical choices:

  • Microsoft Windows Media Center Edition (MCE)

  • Microsoft Windows XP or Vista with a third-party PVR application

  • Linux with MythTV or another Linux-based PVR application

We examine each of these three options in the following sections.

6.3.1. Microsoft Windows Media Center Edition 2005

At first, Microsoft MCE 2005 seemed the leading candidate. MCE is pretty, provides all the basic functions we want, has an excellent integrated electronic program guide (EPG), and has one of the best "10-foot interfaces" available. MCE also supports Studio RGB, which defines white as 235, 235, 235 and black as 16, 16, 16. Most third-party PVR applications use Computer RGB, which defines white as 255, 255, 255 and black as 0, 0, 0. That difference means that for recorded video MCE provides more accurate color rendering, particularly in the dimmest and brightest parts of the image.

Measure Twice, Cut Once

If you decide to use Microsoft Windows MCE (or a version of Vista with MCE features), be very careful when you select hardware. MCE has very specific hardware requirements. Attempting to use unsupported hardware components can cause various problems, from minor glitches to MCE refusing to load, record programs, or play them back. Also pay close attention to the revision levels of device drivers and other supporting software. (We had already ruled out MCE when we designed our system, so we made no attempt to verify compatibility of the components we selected with the MCE approved-hardware list.)

Of course, hardware and driver compatibility is an issue for any PVR application, but Windows MCE has tighter requirements than most. Before you order components for a Windows MCE system, verify that each component is certified for use with MCE. We don't include a URL because Microsoft reorganizes its web site frequently, but a Google search of microsoft.com for "Media Center edition" and "hardware compatibility" should return the pages you need.

Despite all of these advantages, we decided not to use MCE 2005, for the following reasons:

  • Although it is possible to buy an OEM copy of MCE 2005 for $125 or so, Microsoft doesn't position MCE as a consumer product. Instead, they target MCE at OEMs that use it as the basis of a turnkey media center system. Accordingly, Microsoft does not offer direct support for MCE, which is a significant drawback for people who want to roll their own PVR systems.

  • Microsoft plans to discontinue MCE as a separate product, instead bundling MCE features with Windows Vista Home Premium and Vista Ultimate, which were unavailable when this book went to press. We tested Vista Beta 2, but found the MCE functions to be unusable.

  • MCE provides few customization choices other than basic setup options. With MCE, what you see is what you get.

  • MCE records video in the proprietary DVR-MS format rather than an industry-standard format such as MPEG.

  • MCE incorporates entirely too many DRM (Digital Restrictions Management) features for our taste. We want PVR software that does what we want it to do, not PVR software that does only what Microsoft decides to allow us to do. For example, MCE honors the proposed broadcast flag (which as we write this has not yet been approved or implemented, but appears to be inevitable). If the broadcast flag is set to prohibit copying, MCE allows you to view the programs you record only on the computer that originally recorded them. Similarly, if your video adapter has component output connectors, MCE restricts viewing of DVDs to 480p by prohibiting upscaling to native HDTV resolutions.

So, although we really wanted to like MCEusing it would certainly have made things easierwe reluctantly concluded that MCE wasn't the best choice for us. That doesn't mean MCE isn't the best choice for you, if you don't consider any of the objections we list as showstoppers. MCE is probably the most popular choice among those who build their own media center PCs, and for good reason. There's a lot to like about MCE, if you can get past its significant drawbacks.

6.3.2. Third-Party Windows PVR Applications

When we looked at third-party PVR applications for the first edition of this book in 2004, there weren't any ideal choices. We looked at half a dozen competing PVR apps, every one of which had significant drawbacks. We ended up using the PVR application that ATi bundled with its All-In-Wonder series cards. Although we weren't completely happy with it, it did the job.

Nowadays, it's a different story. There are many competing third-party PVR applications, most of which are quite polished, and many of which compare favorably with Microsoft Windows MCE. There are still differences, of course, in terms of feature sets, hardware requirements, and other factors. We won't presume to recommend a specific PVR application, because each of them has strengths and weaknesses. But if you want your media center PC to run Windows, one of these applications will almost certainly fulfill most or all of your requirements.

Beyond TV

Beyond TV 4 (http://www.snapstream.com) is the latest in a long series of PVR applications from SnapStream. BT4 supports unlimited analog tuners, and can record over-the-air HDTV if you install a supported digital tuner. BT4 supports a wide variety of tuner cards, including the popular Hauppauge models (but not ATi All-In-Wonder models.) You can store recorded video in MPEG-2 format (which can be burned directly to DVD), in the space-efficient DIVX format, or in WMV format for transfer to a Pocket PC or other other device that supports Windows Media. The optional Beyond TV Link software allows you to stream recorded video to other PCs on your network. The EPG (Electronic Program Guide), formerly weak, is greatly improved, although searching is still weaker than with some competing products. Intelligent conflict resolution minimizes recording conflicts. For example, if two programs are scheduled to record at the same time, BT4 records the higher-priority program, automatically searches for a later airing of the lower-priority program, and sets that program to record later. You can download a time-limited, full-function demo from the SnapStream web site to test the product before you buy it.

GB-PVR

GB-PVR (http://www.gbpvr.com) is a reasonably full-featured PVR application that's free for the download. GB-PVR supports multiple tuners from a wide range of compatible models. The core application provides basic PVR functions, which can be supplemented by numerous available plug-ins that support extended features such as weather forecasts, RSS feeds, theater listings, video transcoding, and so on. Although GB-PVR doesn't offer all the bells and whistles available with competing commercial applications, it's all many people will need.

SageTV

SageTV (http://www.sagetv.com) is another full-featured commercial PVR application that's been around for years and is now a mature, polished product. SageTV supports multiple tuners from a broad list of analog and over-the-air HDTV models. SageTV records natively in MPEG-2 format, which can be written directly to a DVD, and can also be configured to use MPEG-4 or DivX formats to minimize the size of recordings. The EPG is attractive and makes it easy to locate programs and schedule them to be recorded. Its intelligent recording and scheduling feature works much like the TiVo recommended viewing option. You can download a time-limited trial version from the web site.

We recommend that you begin by checking the feature sets of all of these products. Spend some time on the web sites of the various products, comparing features and looking at the screenshots until you have narrowed the field to two or three products that appear to be the best fit for your personal needs. Download the manuals if you need more detail. If one or two of these products look suitable, download the demo versions and try them out.

Meedio RIP?

Of all the PVR applications we looked at, Meedio (http://www.meedio.com) came closest to being an exact clone of Microsoft Windows MCE. In fact, it's hard to tell the difference at first glance when Meedio uses default settings. Once you start configuring Meedio, though, the differences become clear. In contrast to the "have-it-our-way" approach of MCE, Meedio offers almost complete flexibility in configuring the appearance and functioning of the application to suit your own preferences. The basic package, Meedio TV, provides standard PVR functions and has one of the most comprehensive feature sets available. Meedio Pro bundles Meedio TV with Meedio Essentials to provide full media center functionality. If Meedio has a weakness, it's the search function, which is limited by the remote-centric design of the software. Alas, the future of Meedio is uncertain. In April 2006, Yahoo! bought Meedio and discontinued the Meedio products and EPG service. We hope that Yahoo! will decide to offer Meedio again under its own brand. It would be a shame to lose such a good product.

6.3.3. Linux PVR Applications

The two best-known Linux-based PVR applications, MythTV (http://www.mythtv.org) and Freevo (http://freevo.sourceforge.net), are, like most Linux applications, works in progress. When we reviewed them in mid-2004 for the first edition of this book, we concluded that, although both were impressive, neither was ready for primetime.

Things have changed a lot in two years. MythTV and Freevo have both improved dramatically since 2004, and Linux itself is now much more new-user friendly than it was back then. Linux, and Linux-based PVR applications, are now reasonable candidates for our media center system.

We spent some time looking at the features and capabilities of MythTV and Freevo, and concluded that MythTV had every feature we wanted, not to mention several features we hadn't even thought about wanting. Some MythTV features, such as its fully automatic commercial detection and skipping, are ones you'll never see on Windows MCE, let alone TiVo. (ReplayTV tried that and got sued out of business.) Even the third-party Windows PVR application companies tread lightly to avoid the attack-lawyers of the MPAA, television networks, and advertisers. Not so MythTV. Its feature set is designed to appeal to users, not to movie studios and television networks. There's no DRM, and no attempt to restrict what you can do with the programs that you record.

MythTV is more complicated to install and configure than the Windows-based alternatives, but we think it's worth trying even if you eventually settle on another PVR application. After all, Linux and MythTV can both be downloaded at no cost, and you may find they do the job as well as or better than competing Windows PVR applications.

If you decide to try MythTV, you'll find that much of the work has already been done for you by others. Search Google for the name of your preferred Linux distribution and MythTV. For example, we searched for Ubuntu and MythTV, and found several sites that provided detailed step-by-step instructions for installing and configuring MythTV under Ubuntu. But be prepared to do some research and a lot of tweaking before you have MythTV working to your satisfaction.

Dual Booting

There's no law that says you can have only one operating system installed on your media center PC. Many media center PC owners dual-boot Linux and Windows (which our Technical Reviewer Brian Bilbrey calls "Gaming OS.") Linux runs by default, and handles the PVR and other main system functions. When you want to play a game on the media center PC, reboot it into Windows. When you're finished gaming, reboot the system into Linux and it's immediately ready to record programs, serve audio streams, and perform its other primary functions.


Section 6.4. Component Considerations

6.4. Component Considerations

With our design criteria in mind, we set out to choose the best components for the media center PC system. The following sections describe the components we chose, and why we chose them.

6.4.1. Case and Power Supply

Antec Fusion or Antec NSK2400 (http://www.antec.com)

You can, of course, build a media center PC in a standard mini-tower case. But the critical Spousal-Unit Approval (SUA) criterion (otherwise known as, "You're not putting that in my den!") demands a case that matches standard home-audio components in size and appearance as closely as possible. Barbara has a sense of humor about these things. Many spouses do not, so it's worth checking before you purchase a case. As we learned, there are a lot of media center PC cases available, but most have one or more drawbacks.

Silverstone (http://www.silverstonetek.com) is perhaps the best-known maker of media center cases. We looked at several of their LaScala-series media center cases, but found none that we considered ideal for our media center PC. Some were too cramped, others too expensive, and still others had inadequate power supplies or insufficient cooling.

We also looked at media center cases from Cooler Master and several other manufacturers. Some were very nice cases, but all had one or more drawbacks. We found several models we'd love to have useduntil we saw the price tag. Budget was not a high priority for this system, but we had no intention of paying several hundred dollars for just the case and power supply.

As usual, Antec came to the rescue. We initially considered two Antec cases, the Fusion and Overture II models, both of which Antec positions as media center cases. Fortunately, as we were browsing the Antec site, we happened across their NSK2400 case. Antec classifies the NSK2400 as a desktop case, but its appearance and features make it an obvious choice for a media center PC.

We soon eliminated the Overture II from consideration. Although it's an attractive, reasonably-priced case, its only real advantage relative to the Fusion and NSK2400 is that it accepts full-size ATX motherboards. Two or three years ago, that would have been a key consideration. The selection of microATX motherboards was quite limited, and they often lacked important features that were present on full-size ATX models. Nowadays, many microATX motherboards are functionally identical to their larger cousins, differing only in having two or three fewer expansion slots.

That left us with the Fusion, shown in Figure 6-1, and the NSK2400, both of which incorporate design suggestions from Mike Chin of silentpcreview.com. Either is an excellent choice for a Media PC case, but there are differences. The $100 NSK2400 is an entry-level case. Although its fit and finish are up to Antec's usual high standards, few costly features are present. The $219 Fusion is a premium case, and it shows. The fit and finish are as good as we've seen with any case, including models that sell for much more. The included 430W power supply is a good step up in capacity and quality from the 380W unit included with the NSK2400. The Fusion also includes a large volume control knob and an expensive VFD (Vacuum Fluorescent Display) that is compatible with Windows MCE and some other PVR applications. If you're on a tight budget, choose the NSK2400. But if you have a bit more to spend, the Fusion won't disappoint you.

Figure 6-1. The Antec Fusion media center case

6.4.2. Processor

Intel Core 2 Duo E6400 (http://www.intel.com)

Dedicated PVRs like the TiVo or the set-top PVRs rented by cable companies use very slow processors. Playback (real-time video decoding) places little burden on the processor. Recording (real-time video encoding) requires substantial processing power, but a dedicated PVR offloads that task to a specialized co-processor that is optimized for video compression. As a result, dedicated PVRs consume little power, generate little heat, and require few or no fans.

Dedicated PVRs also have very limited functionality; for example, being limited to recording one SDTV stream. Our media center PC is different. We expect it to juggle many tasks, to handle difficult tasks like encoding HDTV or playing and recording multiple streams simultaneously, and to do all that without ever dropping the ball even momentarily.

Drive It Until It Drops

A subtle point is that a media center PC is likely to be upgraded much less frequently than a desktop PC. Once a media center PC system is built, configured, connected, and tested, it should reasonably be expected to live quietly in the home-audio rack for several years between upgrades. Accordingly, when the choice is between "just enough" and "more than I'll ever need," we suggest you choose the latter.

That means our media center PC needs a serious processor, one with horsepower to spare. Because heavy multitasking is common on a media center PC, we need a dual-core processor with excellent support for multimedia functions. Our media center PC is an appliance that sits in our entertainment center, so we'd like the processor to consume little power and generate little heat.

Based on those requirements, one desktop processor immediately comes to mind. The dual-core Intel Core 2 Duo is fast, has excellent multimedia support, and has low power consumption. Even the entry-level Core 2 Duo E6300 is more than fast enough to handle all of the demands of the media center PC, but we decided to do a little "future proofing." On that basis, we chose the Core 2 Duo E6400 for our media center PC.

ALTERNATIVES: PROCESSOR

We think the Intel Core 2 Duo is the standout choice for a media center PC. If you prefer to use an AMD processor, we recommend the Athlon 64 X2 4200+ or faster. AMD offers low-power variants of some X2 models that consume much less power than the standard models. Although they are more costly than the standard models of the same speed, we recommend using the low-power variants in a media center PC.

6.4.3. Motherboard

Intel D946GZIS (http://www.intel.com)

Our choice of the Antec Fusion case dictates a microATX motherboard. Core 2 Duo is a Socket 775 processor, but not all Socket 775 motherboards are compatible with Core 2 Duo. At the time we built this system, microATX motherboards with Core 2 Duo support were thin on the ground. Fortunately, Intel offered a microATX Core 2 Duo motherboard that was nearly perfect for our purposes, the D946GZIS Isleton. The D946GZIS supports up to 4 GB of DDR2 memory in two slots. It includes embedded GMA3000 video, but also provides a standard x16 PCI Express video adapter slot. The integrated 5.1 audio and 10/100 Ethernet are sufficient for our purposes.

The only minor drawbacks of this motherboard are its lack of integrated IEEE-1394 (FireWire) and that it provides only two PCI expansion slots. The lack of FireWire isn't a major issue. If we want to watch raw camcorder video, we can plug the camcorder into one of our DVD recorders or PCs. We're unlikely to want to edit video on the media center PC. Having only two PCI expansion slots was more problematic. We originally planned to install three tuner/capture cards in this system, one HDTV and two SDTV. As it turned out, that problem was easily solved. We simply installed one dual-tuner SDTV card instead of two single-tuner cards.

6.4.4. Memory

Kingston KHX6400D2LLK2/2G 2GB PC6400 DDR2 Memory Kit (1 GBx 2) (http://www.kingston.com)

The Intel D946GZIS has two DDR2 memory slots and supports dual-channel memory operation with PC2-4200, PC2-5300, or PC2-6400 modules in capacities up to 2 GB. When we built this system, PC2-6400 modules were selling for far more than PC2-4200 or PC2-5300 modules. We decided to use the faster memory anyway, mainly because we were concerned about the demands that HDTV recording and playback will place on the system.

ALTERNATIVES: MOTHERBOARD

For a microATX Core 2 Duo system, there were no other motherboard choices when we built this system. By the time this book reaches print, there will likely be numerous choices. Any microATX motherboard made by Intel or ASUS with a suitable feature set should work fine. For a microATX Socket AM2 Athlon 64 X2 system, choose any compatible ASUS motherboard based on an nVIDIA chipset.

If you build your media center PC in a full ATX case, your motherboard options are much broader. For a Core 2 Duo or other Intel processor, choose any compatible motherboard made by Intel or ASUS with the feature set you need. For a Socket AM2 Athlon 64 X2 system, choose any compatible ASUS motherboard with the feature set you need.

Obviously, we wanted to populate both slots for better memory performance, so we checked the prices of paired PC2-6400 memory modules. We didn't attempt to analyze the actual memory requirements of the media center PC. A pair of 512 MB DIMMs "felt" too small. Even with a dual-core processor, the media center PC would certainly have been fully functional with 1 GB of total memory, but that would have left little spare memory for running games and other secondary functions. As much as we'd have liked to install 4 GB of memory, at the time we built this system, a pair of 2 GB modules cost $1,600, and they were available only in PC2-3200 speed. A pair of 1 GB PC2-6400 modules cost only $325, so that's what we chose.

6.4.5. Media Center Video Components

A media center PC system requires four separate video functions:

Display

The media center PC must display computer output on a television. That requires a standard PCIe or AGP video adapter or a motherboard with embedded graphics that is capable of outputting a video signal that can be displayed by a television set (rather than a computer monitor). Depending on the type of connector used by the television set, you will need one of the following output connectors on the video adapter, listed in order of increasing video quality:

ALTERNATIVES: MEMORY

Any compatible name-brand memory modules. Memory from different companies can vary dramatically in quality and reliability. For 20 years, we've depended on memory from Kingston and Crucial, and have never had cause to regret that decision.

RF

Older televisions and inexpensive current models may provide only an RF input, the familiar F-connector to which you connect the cable TV feed. If your television has only an RF connector, you will need to use a video adapter that provides an RF-out connector. Such connectors can generally be configured to output on TV channel 3 or 4. To receive the signal from the adapter, you tune the television to whatever channel the adapter is configured to use. If you want to watch TV from both the cable and the PC, you'll need a splitter to allow the TV to accept RF input from both sources. Note that many RF splitters, particularly amplified models, are designed to accept one RF input and split it to two or more devices, and do not necessarily work "backward" to allow two sources to be delivered to one device.

Composite

A composite video-out connector supplies an analog video signal and connects to the television using a standard RCA cable. All video data is transferred on a single cable. Conventionally, a yellow cable is used for video. Most analog television setsat least those that are likely to be used in a home theater setupinclude an analog video-in connector. (You can use a set that does not provide analog video-in by connecting the video-out connector on the PC to an RF modulator and thence to the RF-in connector on the television.) Some PC video adapters provide an RCA video-out connector or a VIVO (Video-In Video-Out) connector. You'll need one of those if you intend to connect your media center PC to an analog television that has only a composite video input.

S-Video

An S-Video-out connector (Separate Video) supplies an analog video signal, and connects to the television using an S-Video cable. S-Video devotes separate wires to luminance (brightness) and chroma (color), and so offers better video quality than a composite video connection. Use a video adapter that provides an S-Video output if your television has an S-Video input. S-Video connectors are notoriously fragile. If you use S-Video on your media center PC, be very careful not to put any undue pressure on the connectors.

DVI

A DVI (Digital Visual Interface) connector supplies a digital video signal, and connects to the television using a standard DVI cable. Most older digital television sets and some current models provide a DVI connector. Many current PCIe and AGP video adapters provide a DVI connector, which is used by many digital flat-panel computer displays. You'll need a video adapter with DVI output if you intend to connect your media center PC to a digital television, either an EDTV or HDTV model.

HDMI

The HDMI (High-Definition Multimedia Interface) connector is the latest standard for connecting a digital signal to a digital television. HDMI is essentially DVI with the addition of HDCP (High-Bandwidth Digital Content Protection) DRM. For unprotected content, HDMI works just like DVI, with which it is backward compatible. For protected content, at the option of the content owner, HDMI can enforce a protected signal path. If the HDMI source is connected to a DVI display that does not support HDCP, the HDMI source may refuse to display the content or display it at low resolution. At the time we built our media center PC, there were no PC video adapters available that supported HDMI output with HDCP.

TV tuning

A television signal can originate from many sources. The original signal may be analog or digital. It may arrive at the media center PC as an over-the-air (OTA) broadcast signal, analog or digital, or via cable or satellite. The original signal typeanalog or digitaldoes not determine the signal type you receive. For example, we have analog cable television service. Some of the channels we receive originate as analog signals; others originate as digital signals, but are converted by our cable television company to analog before it retransmits those signals to us. A satellite receiver receives all digital signals, but may provide an analog output, a digital output, or both for your television.

The type of signals you receive determine the type of tuner card you need. If your signal is delivered via satellite or digital cable, your options are very limited. There's no convenient way for a PC to tune the raw signals provided by these types of services, so the only alternative is to use the cable or satellite box to choose the channel you want to record. Fortunately, that process can be automated by using an IR Blaster or similar device to change channels on the cable/satellite box under the control of the media center PC. Conversely, for OTA (analog and/or digital) or analog cable, tuner cards are available to process these types of signals, which means the media center PC itself can change channels directly as needed to record the programs you specify.

"HDMI-Ready" Does Not Guarantee HDCP Support

In 2005, some video adapter manufacturers began advertising their video adapters as "HDMI-ready" or "HDMI-capable" or "HDMI-compatible." Those adapters were in fact HDMI-ready, but only in the sense of being physically and electronically compatible with HDMI televisions. These adapters do not support HDCP, and cannot be upgraded to support it, short of being returned to the manufacturer and having new chips soldered onto them.

Needless to say, many of the people who bought these video adapters with the understanding that they would be capable of displaying HDCP-protected content at full resolution were not amused to learn that these adapters could not and never would be able to display HDCP-protected content. ATI in particular earned the ire of many customers, who believed it had misrepresented its products. nVIDIA never claimed that its chipsets offered full support for HDMI/HDCP, although some nVIDIA OEMs did make such claims. The result has become a gigantic mess, and we expect class action lawsuits to result from it.

At this point, it is unclear to us whether PC video adapters with full HDMI/HDCP support will ever be available. The movie studios intensely distrust PC technology, and it is possible they will block any attempt to bring full HDMI/HDCP support to the PC platform.

Video capture

Television video uses standards and protocols that differ from those used by PC video. The media center PC must have the ability to capture a television video stream and process it into a form that can be stored and played back by the PC.

Video encoding/decoding

A raw, uncompressed video stream would fill even the largest hard disk very quickly. All practical video storage methods use some form of compression, such as MPEG-1, MPEG-2, or MPEG-4, to reduce the size of stored video data. In order to make playback practical in devices with limited processing power, such as DVD players, MPEG compression algorithms place the processing burden on compression (encoding), while making decompression (decoding) as easy as possible. So, although even a slow processor can decode and play video without straining, the process of capturing, encoding, and storing video requires a lot of CPU ticks.

Some adapters simply deliver a raw video stream to the main system processor, which must compress the data itself. Because real-time video compression is extremely demanding, using such an adapter means the media center PC must have a very fast CPU, and even the fastest CPU may drop frames during real-time encoding. Other adapters include special MPEG compression hardware that delivers a precompressed video stream to the media center PC for storage. Still other adapters use the video GPU to encode the video stream. Adapters with MPEG compression in hardware place very little burden on the main system CPU, which allows you to use a slower, cooler, quieter CPU for the media center PC.

Adapters may provide any combination of these functions. For example, some adapters provide video capture and TV tuning functions, but require a separate graphics card to display the video. Other adapters provide display and capture functions, but have no tuner, and so are useful only for capturing direct video signals such as the output from a camcorder. Still other adapters may provide display, tuning, and capture functions, but offload encoding functions to the main system processor. Choosing the proper adapter(s) is a major consideration for any media center PC.

6.4.5.1. TV tuner/capture card

Hauppauge WinTV-PVR-150 analog tuner (http://www.hauppauge.com): pcHDTV HD-5500 Hi Definition Television digital tuner (http://www.pchdtv.com)

We want our media center PC to handle two signal sources, analog cable and OTA digital. We decided that the ability to record one digital channel at a time was sufficient, but wanted the option to record two analog channels simultaneously, or to watch one analog channel using "live pause" while recording another analog channel. That means we need three tuners, two analog and one digital.

For the analog tuners, we initially decided to use a pair of Hauppauge WinTV-PVR-150 cards, shown in Figure 6-2. The PVR-150 offers the best video quality available, has excellent hardware-based MPEG encoding, and is supported by nearly every PVR application. The retail-boxed PVR-150 includes an IR remote control with receiver and an IR Blaster (transmitter) that can be used to control a satellite or digital cable box. (We don't need to do that right now, but that may change shortly, and it's always best to be prepared.) With two PVR-150s, we have a remote control for each of us, which is no small aid to domestic tranquility.

Analog TV tuner cards have been available for years, but digital TV tuner cards are a relatively new product category. HDTV tuners are available from several companies, including ATI and AVerMedia, but most have only Windows drivers, and some work only under Windows MCE. We consider Windows a poor choice of operating system for a media center PC, so we continued our search for a Linux-based HDTV tuner card. On the recommendation of our technical reviewer Brian Bilbrey, we chose the pcHDTV HD-5500 Hi Definition Television digital tuner card, which offers full Linux support.

The HD-5500 supports all 18 ATSC-compliant digital formats. It also supports unencrypted QAM 64 and QAM 256 cable signals; that is of little use to us, because we plan to capture only OTA HDTV signals. The HD-5500 also supports capturing NTSC (analog) television signals. We won't use that capability, because our HD-5500 card will connect only to an OTA HDTV antenna.

The HD-5500 does not have onboard compression hardware, but it can offload compression tasks to an nVIDIA video adapter. For that reason, we'll install an nVIDIA video adapter in our media center PC.

As you might have noticed, we had a slight problem. We planned to install three PCI tuner/capture cards in our media center PC, but it has only two PCI slots. Hmmmm.

Figure 6-2. The Hauppauge WInTV-PVR-150 tuner/capture card

Instead of using the WinTV-PVR-150 single-tuner card, we could use the similar Hauppauge WinTV-PVR-500 dual-tuner card. With two PCI slots available, we could use any one of the tuner/capture card configurations shown in Table 6-1.

Table 6-1. Possible tuner/capture card configurations

Total tuners

Analog tuners

Digital tuners

Hauppauge PVR-150

Hauppauge PVR-500

pcHDTV HD-5500

1

1

-

1

-

-

1

-

1

-

-

1

2

1

1

1

-

1

2

2

-

2

-

-

2

2

-

-

1

-

2

-

2

-

-

2

3

2

1

-

1

1

3

3

-

1

1

-

4

4

-

-

2

-

Remote Controls and IR Blasters

Hauppauge sells their tuner/capture cards in various bundles. Some include only the bare card and drivers. Others include a remote control and receiver, some also an IR Blaster. The IR Blaster connects to the media center PC, and can output infrared signals that mimic those produced by a remote control. By pointing the output of the IR Blaster toward the remote receiver on a set-top box or similar device, the media center PC can send commands to that device.

For example, if you receive your television signal via a cable or satellite system that requires selecting the channel via a set-top box, you can point the IR Blaster at the set-top box. To schedule and record a program, you set the media center PC to record whatever signal is present on the wire at the required time. Under programmatic control, the IR Blaster sends a signal to the set-top box at the appropriate time to turn it on and change to the proper channel. It's a kludge, but it generally works pretty well, or so we're told. We have analog cable, so our analog tuner cards can select the proper channel directly. Similarly, we use OTA for digital reception, so all available digital channels are on the wire simultaneously, and can be tuned directly by the pcHDTV tuner card.

We decided to install one Hauppauge WinTV-PVR-500 tuner/capture card to provide two analog tuners, and one pcHDTV HD-5500 tuner/capture card to provide one HDTV tuner.

6.4.5.2. Video adapter and capture/tuner Card

Gigabyte GV-NX73G128D-RH (http://www.giga-byte.com)

Although we list the Gigabyte GV-NX73G128D-RH video adapter we used, we won't recommend a specific video adapter for your system, because so much depends on your own situation and needs. Consider the following factors when you choose a video adapter:

Internal interface

The first consideration is the internal interface. If your motherboard has an AGP slot, you need an AGP video adapter. If your motherboard provides a PCI Express slot, you need a PCIe video adapter. We chose a PCIe model for compatibility with the motherboard we selected.

External interface

Make sure the video adapter you choose provides external interface(s) that match your television. Video adapters are readily available with a DVI connector, composite video connector, S-Video connector, or some combination. We chose an adapter that provides DVI and S-Video outputs.

Performance

For simple TV playback and basic computer functions, any current video adapter is sufficient. If you plan to use your media center PC for serious gaming, you'll need a fast video adapter. We don't plan to use our media center PC for gaming, so we chose an inexpensive PCIe video adapter.

Noise level

Many low-end video adapters use passive cooling. Most midrange and high-performance video adapters use cooling fans, which may be too loud for a media center PC. If you install a fast video adapter for gaming, give preference to one of the fanless models.

Compatibility with tuner card(s)

Nearly any video adapter is compatible with nearly any tuner card, in the sense that the two do not conflict. However, some tuner cards (such as the pcHDTV model we are using for HDTV support) do not have on-board hardware video acceleration, but instead depend on the video adapter GPU to accelerate the video stream. If your card is one of those, make sure that the video adapter you choose can provide hardware acceleration support to your tuner card.

We chose the Gigabyte GV-NX73G128D-RH video adapterwe'll call it the GV-RH for shortfor the following reasons.

  • Obviously, we needed a PCI Express model to fit the PCIe slot in our Intel D946GZIS motherboard.

  • We needed a video adapter that provided connections for video-out and HDTV-out, which the GV-RH does.

  • We wanted a passively cooled video adapter, both to avoid the noise of a video adapter fan and to increase reliability. When a video adapter fan fails, the results are not pretty. Realistically, a media center PC stuffed into an entertainment center is unlikely to get much in the way of periodic maintenance or cleaning, which makes a fan failure more likely.

  • The pcHDTV HD-5500 Hi Definition Television digital tuner can use an nVIDIA video adapter as a co-processor to accelerate HDTV streams.

  • We wanted a video adapter with enough graphics processing power to support Vista and for casual gaming. The GV-RH uses the nVIDIA GeForce 7300 GS chipset, which, although it is no speed demon, is perfectly adequate for Vista and light gaming.

  • We wanted to keep the price below $100, and ideally below $50.

We chose the Gigabyte GV-RH based on those criteria. (Note that the RH on the end of the product number is significant; Gigabyte also sells a GV-NX73 model without the RH postfix that lacks HDTV support.) Your priorities may differ from ours. Choose accordingly.

6.4.6. Hard Disk Drive

Seagate Barracuda 7200.10 ST3750640AS 750GB (two) (http://www.seagate.com)

Hard drive capacity, performance, noise level, and reliability are critical for a media center PC system.

Capacity

The most obvious consideration is capacity. Depending on the characteristics of the video stream and the compression type used, standard-definition video eats disk space at a rate of 700 MB to 5 GB per hour. At the low end, 700 MB/hour stores only VHS-quality video. We'll probably want to store most of what we record at DVD quality, which means we have to plan for the 2.5 to 5 GB/hour rate that typical DVD-quality SD video streams require. That means 100 GB of disk space translates to only 20 to 40 hours of video storage. Recording HDTV is even more demanding. Depending on capture resolution and compression method, one hour of HDTV may consume up to 30 GB of disk space.

We also need to store more than just video. The media center PC will also store and serve CD audio discs ripped and compressed in OGG or MP3 format at a high-quality setting or FLAC (Free Lossless Audio Codec). OGG and MP3 use variable bit-rate compression, but it's safe to assume that an average audio CD will require at least 150 MB of storage space when compressed at a quality level acceptable to us, and FLAC requires even more disk space. Barbara has several hundred CDs she'll want to rip, which may require another 100 GB or more of storage space.

Performance

Hard drive performance is another important criterion. The media center PC will spend much of its time idling, but at times it may need to do many things simultaneously, such as record one video stream while playing back another while also serving an audio stream. Accordingly, large cache and fast rotation rate are important. On that basis, we concluded that we needed a 7,200 RPM hard drive with an 8 MB or larger buffer.

SLOW AND STEADY

Dedicated PVRs like the TiVo often use 5,400 RPM drives with small buffers, but they're able to use such slow drives only because they are doing a limited number of things simultaneously.

Noise level

Modern 7,200 RPM hard drives differ greatly in noise level. Seagate Barracuda models are the quietest drives available that have acceptable performance.

Reliability

Seagate drives are extremely reliable, but even so we were concerned about the possibility of drive failure. As Barbara sometimes points out, Robert has to sleep sometime, and the thought of losing a week's or a month's worth of stored programs to a drive failure was not a pleasant one. Our first thought was to install two Serial ATA drives and mirror them using RAID 1. The obvious downside to that is that mirroring cuts drive capacity in half, and we need all the capacity we can get.

Then we realized we already had a solution. The media center PC system will be connected to our internal network and, via our firewall, to the Internet. It has to be connected so that it can download program guide updates, periodically reset its clock against an SNTP time server, and so on. We have literally terabytes of disk spinning elsewhere on our network, so it'd be easy enough to set up a cron job to periodically check the media center PC hard drives and copy any new files to a hard drive elsewhere on the network. Problem solved.

ALTERNATIVES: HARD DISK DRIVE

None, really. The Seagate 750 GB drives are huge, fast, quiet, and extremely reliable. At the time we built this system, there were no other drives available that came even close to matching the combination of desirable characteristics of the Seagate Barracuda drives.

We concluded that we wanted at least 1000 GB (1 TB) of available drive space on the media center PC system, and more would be better. The Antec Fusion case we chose has two hard drive bays, so the obvious decision was to install two of the largest high-performance hard drives available. On that basis, we chose two Seagate Barracuda SATA 750 GB drives.

RAID 0

With two hard drives, we have the option of using RAID 0 striping for increased disk performance. We don't expect to need it, but many commercial Windows MCE PCs use RAID 0, presumably for good reason. Our testing has shown the RAID 0 has little or no real performance benefit on typical desktop systems, but is useful on servers that experience heavy disk access. In some respects, the disk access patterns of a media center PC more resemble a server than a desktop PC, so we'll leave the RAID 0 option open.

At first glance, it might appear that we can't use RAID on this system. The Intel D946GZIS motherboard does not include Intel Matrix RAID, and we have no free slots to add a RAID controller. Fortunately, both Windows and Linux provide software RAID 0 support. Software RAID is a bit slower than Intel Matrix RAID or RAID implemented with a dedicated RAID controller, but it should be more than fast enough for our purposes.

6.4.7. Optical Drive

NEC ND-3550A DVD writer (http://www.necam.com)

At $35 or so, DVD writers are so inexpensive nowadays that it's senseless to install any other type of optical drive. The optical drive in the media center PC is used for everything from loading software to watching DVDs to writing recorded programs to a burnable DVD for archiving, so it's important to choose a reliable model that supports all of the types of media you want to read and write.

We chose the NEC ND-3550A DVD writer for the media center PC, but any similar model from BenQ, Lite-On, NEC, Pioneer, or Plextor would serve as well. The Antec Fusion case has a universal optical drive door that hides the front bezel of the optical drive, so there's no need to match the color of the optical drive to the case.

WHAT ABOUT HD-DVD OR BLU-RAY?

We considered installing a high-capacity HD-DVD or Blu-Ray optical drive in the media center PC, but decided to bide our time. This system has the bandwidth and processor power to handle these new-generation drives, but the drives are still extremely expensive and there are few titles available on HD-DVD or Blu-Ray discs. Also, there's the small matter that when HD-DVD or Blu-Ray wins the war, the other will be orphaned. We have no intention of spending $1,000 on an optical drive that may become useless in a year or two.

Also, it's unclear to us at this point exactly what DRM hardware would be required to allow a PC-based media center system to play high-capacity discs, if indeed that is possible at all. Presumably, a PC-based media center system would require at least full HDMI/HDCP support, which is not yet available on the PC platform. It may also require Trusted Platform Module (TPM) support "married" to the optical drive and video subsystem.

So we decided to ignore high-capacity DVD for now. Eventually, the price of HD-DVD and Blu-Ray optical drives will fall into the $50 range and blank discs to $0.50 apiece, by which time "DVD Jon" Johansen will have cracked the encryption used by HD-DVD and Blu-Ray discs. We'll wait until those things happen before we install any type of high-capacity optical drive in this system.

6.4.8. Keyboard and Mouse

Logitech diNovo Media Desktop (http://www.logitech.com)

The type of keyboard and mouse you need for a media center PC depends on how you use the system. If you don't intend to use it as a standard PCfor example, for checking email, browsing the Web, or playing gamesyou need a keyboard and mouse only for initial system configuration and infrequent changes to the system. All other functions are handled with the remote control via the "10-foot interface" of MythTV or whatever PVR application you're running.

Out of Sight, Out of Mind

Many media center PC owners leave an inexpensive wired mouse and keyboard connected to the system, stored on top of or behind the case. Alternatively, you can temporarily connect a keyboard and mouse to front-panel USB ports when you need them, and store them elsewhere when you don't.

Although we won't do much serious gaming on our media center PC, we do intend to use it for browsing the Web, checking email, and similar tasks. That meant we needed a cordless keyboard and mouse that would work reliably at across-the-room distances. Most cordless keyboards and mice have very short range, a meter or so at most. There are some long-range keyboard/mouse combos available, intended for corporate presentations and similar functions, but those we looked at cost several hundred dollars.

The best option we found was the Logitech diNovo Media Desktop. At $140 or so street price, this isn't an inexpensive desktop combo, but it is ideal for a media center PC. Logitech claims a range of up to 60 feet. We didn't test at anything like that distance, but the diNovo Media Desktop does work reliably at the 10- to 15-foot ranges typically needed for a media center PC.

6.4.9. Speakers

Home audio speakers: Logitech Z-5500 speaker system (http://www.logitech.com)

Most people who build a media center PC install it in their home entertainment center and connect the PC audio outputs to their receiver or amplifier. Obviously, if you already have a good receiver and speakers, you might as well use them.

Of course, not everyone has a suitable receiver and speaker set. When we built the Home Theater PC system for the first edition of this book, we'd decided to move our elderly JVC receiver and speakers to the downstairs guest suite and replace them with a high-power PC speaker system. At that time, the best PC speaker set available was the Logitech Z-680 5.1 speaker system, which we used.

Logitech has since replaced the Z-680 with the Z-5500, which has similar specifications and equal sound quality. The street price of the Z-5500 is $260 or so, about half the price of a traditional home audio receivers and speakers with comparable power and sound quality. The Z-5500 incorporates four satellite speakers for left/right and front/rear audio, a center-channel speaker, and an LFE (low-frequency emitter) subwoofer. The satellite speakers are rated at 62W RMS each, the center-channel speaker at 69W RMS, and the LFE at a massive 188W RMS, for a total RMS output of 505W.

PEAK VERSUS RMS

Two methods are commonly used to specify the output power of amplifiers. Peak Power is often specified for computer speakers, particularly inexpensive ones, but is essentially meaningless. Peak Power specifies maximum instantaneous power an amplifier can deliver, but says nothing about how much power it can deliver continuously. The RMS (Root Mean Square) Power rating is more useful because it specifies how much power the amplifier can deliver continuously.

The Z-5500 speaker system includes Dolby Digital and DTS hardware decoding and is THX certified. We confess that we don't understand what all that means, but our audiophile friends tell us those are Good Things. And, although admitting it may label us as audio barbarians, we have to say that the audio from our older Z-680 speaker system sounds as good to us as anything else we've listened to, and the Z-5500 audio quality is just as good. If the Z-5500 speaker set is a bit expensive for your budget, consider the Z-5300e, which costs less than half as much, provides 280W RMS total power, and has very good sound quality.

YOUR MILEAGE MAY VARY

One of our technical reviewers makes a good point. He writes:

"Speakers are probably the most subjective elements of the system. While I certainly have no argument with your selection there are many fine alternatives in the same price range. It's also an area where more dollars doesn't always mean better performance or better sound. I think it appropriate to urge readers to make the effort to personally audition speakers where possible rather than rely solely on reviews and recommendations... and given that room interactions play such a major role in speaker performance they should buy from an outlet with a liberal return policy."

Table 6-2 summarizes our component choices for the media center PC system.

Table 6-2. Bill of materials for media center PC

Component

Product

Case

Antec Fusion

Power supply

Antec 430W (included)

Processor

Intel Core 2 Duo E6400

Motherboard

Intel D946GZIS

Memory

Kingston KHX6400D2LLK2/2G 2GB PC6400 DDR2 Memory Kit (1 GB x 2)

Video adapter

Gigabyte GV-NX73G128D-RH GeForce 7300GS

SDTV tuner card

Hauppauge WinTV-PVR-500 (dual tuner)

HDTV tuner card

pcHDTV HD-5500

Hard drives

Seagate ST3750640AS Barracuda 7200.10 750 GB Serial ATA (two)

Optical drive

NEC ND-3550A DVD+R/RW writer

Keyboard and mouse

Logitech diNovo Media Desktop

Speakers

Home audio speakers or Logitech Z-5500 speaker system

When we built this system in August 2006, the total component cost was under $2,000, excluding speakers. Every commercial Windows MCE system we looked at in the $2,800 range had specifications that were noticeably inferior to our configuration.

A typical $2,800 commercial MCE system used a Pentium D processor rather than a Core 2 Duo, had half as much and slower memory, and only a fifth to a third as much disk space. Most $2,800 MCE systems had dual tuners, usually two analog models, but sometimes one analog and one digital. Eyeballing it, we concluded that we could have effectively matched the performance and functionality of a typical $2,800 commercial MCE system for about $1,400. Clearly, MCE systems are high-margin products.

Those systems did, of course, come with Windows MCE preinstalled and pre-configured. For someone who wants a turnkey system, it may be worth paying the 50% to 100% price premium for a commercial MCE system. But if you're willing to get your hands dirty, you can build your own media center PC for a lot less money, and end up with a better, more flexible, and much more reliable system.


Section 6.5. Building the Media Center PC

6.5. Building the Media Center PC

Figure 6-3 shows the major components of the media center PC. The Logitech diNovo keyboard and mouse are on top of the Antec Fusion case at the rear, with the NEC ND-3550A and the Seagate Barracuda hard drives at the left front, and the Gigabyte video adapter at the right front. The Intel D946GZIS motherboard is in front of the Antec Fusion case, surrounded by the Intel Core 2 Duo processor and CPU cooler to the left, the Kingston HyperX memory modules in front, and the Hauppauge WinTV-PVR-500 and pcHDTV HD-5500 tuner cards to the right.

Figure 6-3. Media center PC components, awaiting construction

Before you proceed, verify that you have all of the necessary components. Open each box and confirm that all items on the packing list are present.

SEQUENCING THE BUILD

You needn't follow the exact sequence we describe when building your own system. For example, some people prefer to install the drives before installing the motherboard while others prefer the converse. The best sequence may depend on the case you use and the components you are installing. For example, some case and motherboard combinations make it difficult or impossible to connect the ATX power cable after drives have been installed. Use your best judgment while building the system and you won't go far wrong.

Choosing a Work Surface

We build systems on the kitchen table because it provides plenty of work room, easy access from front and rear, and plenty of light, all of which are important. Barbara isn't happy about having her kitchen table thus occupied, but when Robert explained that the alternative was using her antique dining room table, she grudgingly agreed that the kitchen table was the better choice. Whatever location you choose to build your system, make sure it provides sufficient workspace, easy access, and good lighting. Spousal approval is optional, but highly recommended.

6.5.1. Preparing the Case

The Antec Fusion case is extremely quiet and well ventilated, but with those virtues come more complexity than is usual for a PC case. The Antec Fusion divides the components into three chambers. The motherboard resides in the largest of these chambers, with the hard drives in another and the power supply and optical drive in the third. This means, as we found by experience, that it pays to think through what you're doing before you do it.

For example, Antec uses a sliding door pass-through to route cables from the power supply chamber to the motherboard chamber. Once you install expansion cards in the motherboard, access to that pass-through is constricted. We actually installed the expansion cards twice before we got it right. The first time, we forgot to pass through a Molex power cable, thinking that the only component that required a Molex connector was the optical drive, which is in the same chamber as the power supply. Alas, we'd forgotten the case fans in the motherboard chamber, which also require a Molex power cable. So we had to uninstall all the expansion cards, route the Molex cable into the motherboard chamber, and reinstall all of the expansion cards.

Avoid Fireworks

Before you do anything else, make sure that the power supply is set to the correct input voltage. Some power supplies, including the unit bundled with the Antec Fusion case, autodetect input voltage and set themselves automatically. Other power supplies require moving a slide switch to indicate the correct input voltage.

If your mains voltage is 115V and the power supply is set for 230V, no damage occurs. The system simply won't start. However, if your mains voltage is 230V and the power supply expects 115V, you will see a very short and expensive fireworks show the first time you plug the system in. The motherboard, processor, memory, expansion cards, and drives will all be burnt to a crisp within a fraction of a second.

To begin preparing the Antec Fusion case, place it on a flat surface and remove the single thumbscrew at the top rear, as shown in Figure 6-4, and then slide the top panel to the rear and lift it off, as shown in Figure 6-5.

Figure 6-4. Remove the thumbscrew that secures the top panel

Figure 6-5. Slide the top panel to the rear and lift it off

Like most cases, the Antec Fusion comes with a generic rear-panel I/O template. Generic templates never fit any motherboard we've ever used, so we're not sure why case makers bother to include them. Removing the generic template simply adds one more task.

To remove the generic template, press gently inward on it with a screwdriver handle, as shown in Figure 6-6. Don't worry about bending the template, because you'll discard it anyway. Do take care not to bend the cutout area of the case, which would make it very difficult to install the proper template. Support the edge of the cutout area with your fingers, and press on the generic template until it snaps out.

Figure 6-6. Press gently on the generic I/O template until it snaps out

Every motherboard comes with a custom I/O template that matches the ports on its rear I/O panels. The included template is nearly always correct, but we have infrequently received a motherboard with an incorrect template. Before you install the custom I/O template supplied with the motherboard, compare it against the motherboard I/O panel, as shown in Figure 6-7. If you received the wrong template, contact the motherboard manufacturer to request a replacement.

Figure 6-7. Compare the custom I/O template with the I/O panel of the motherboard

To install the custom I/O template, first make sure that it's oriented properly relative to the motherboard ports. Working from inside the case, align the template with the cutout. Using a screwdriver handle, start at one corner, as shown in Figure 6-8, and press gently until the template snaps into place. Run the screwdriver handle around the edges and corners of the template to ensure that it's fully seated.

Figure 6-8. Press gently to seat the custom I/O template

After seating the I/O template, hold the motherboard aligned in position directly over the case, as shown in Figure 6-9. Compare the positions of the motherboard mounting holes with the standoff mounting positions in the case.

Figure 6-9. Determine which positions require standoffs

The Intel D946GZIS has eight mounting holes. The Antec Fusion case has six standoffs preinstalled, all of which correspond to mounting hole positions in the motherboard. Locate and note the two positions that require standoffs to be installed.

Install a brass standoff in each required position, and then use the motherboard again to verify that a standoff is installed at each of the required eight positions. Although you can screw in the standoffs using just your fingers, it's much easier and faster to use a 5mm nut driver, as shown in Figure 6-10.

Figure 6-10. Install a standoff in each position that corresponds to a motherboard mounting hole

Be careful not to overtorque the standoffs as you install them. The standoffs are made of soft brass, and the motherboard tray, although steel, is relatively thin. Applying too much torque can strip the standoff or the screw hole. Finger-tight is good enough.

Warning: Make absolutely sure that every standoff installed corresponds to a motherboard mounting hole. An extra standoff can contact the bottom of the motherboard, causing it to short and possibly damaging or destroying the motherboard and other components.

6.5.2. Populating the Motherboard

It is always easier to populate the motherboardinstall the processor and memorywhile the motherboard is outside the case. In fact, you must do so with some systems, because installing the CPU cooler requires access to both sides of the motherboard. Even if it is possible to populate the motherboard while it is installed in the case, we always recommend doing so with the motherboard outside the case and lying flat on the work surface.

When the motherboard is flat on a firm surface, it's completely supported. When it is installed in the case, it's supported only by the standoffs. Installing a CPU cooler or memory may require significant pressure, which runs the risk of cracking an installed motherboard. Play it smart and populate your motherboard before you install it in the case.

Warning: Each time you handle the processor, memory, or other static-sensitive components, first touch the power supply to ground yourself. The power supply needn't be connected to a receptacle for this to be effective. The power supply itself has sufficient mass to serve as a sink for static charges.
6.5.2.1. Installing the processor

To install the Intel Core 2 Duo E6400 processor, begin by unlatching and lifting the socket arm, as shown in Figure 6-11. Swing the socket arm past vertical until it reaches the end of its travel.

Figure 6-11. Lift the socket lever to prepare the socket to receive the processor

With the socket lever open, the retention plate is unlatched and can be lifted upward, away from the socket, as shown in Figure 6-12. The retention plate has a black plastic cover that protects the delicate contacts inside the socket when no processor is installed.

Figure 6-12. Lift the retention plate away from the socket

Snap this protective plastic cover off, as shown in Figure 6-13, and store it in a safe place. If you ever remove the processor from the motherboard, reinstall the cover to protect the socket until you install another processor.

Figure 6-13. Remove the protective plastic cover

Figure 6-14 shows the LGA775 socket prepared to receive the processor. In this state, the delicate contacts of the socket are fully exposed, and the socket is easily damaged. Take care to avoid touching the contacts or dropping anything on the exposed socket. If the socket is damaged, the only alternative is to replace the motherboard.

Figure 6-14. The socket prepared to receive the processor

The processor is also protected by a plastic snap-on cover. When you are ready to install the processor in its socket, remove the plastic cover, as shown in Figure 6-15. Handle the processor only by its edges, and make sure the contact surface of the processor does not touch anything except the socket. If you ever remove the processor from the socket, reinstall the protective cover before you store the processor.

Figure 6-15. Remove the protective plastic cover from the processor

Pin 1 is indicated on the processor by a small golden triangle and on the socket by a beveled corner, both visible at the lower-right corner of the socket in Figure 6-16. The processor also has two keying notches that correspond with two nubs in the socket, both of which are also visible in Figure 6-16.

Figure 6-16. Align the processor with the socket and drop it into place

Hold the processor by its edges, align pin 1 of the processor with pin 1 of the socket and drop the processor into place, as shown in Figure 6-16. The processor should seat flush with the socket without any pressure being applied to it. If seating the processor requires more than a gentle nudge, the processor is not aligned properly with the socket. Remove the processor, align it properly, and drop it back into the socket.

After the processor is seated, lower the retention plate into place, as shown in Figure 6-17. Note the lip on the retention plate and the matching cammed section of the socket lever. As you press the socket lever down to latch it in place, make sure that the cammed section engages the lip on the retention plate and presses it firmly into position, as shown in Figure 6-18.

Figure 6-17. Lower the retention plate into position

Figure 6-18. Make sure the cam on the socket lever engages the lip on the retention plate

Processor Markings

In case you're wondering, normal Core 2 Duo processors aren't labeled with a felt-tip pen. The processor shown in Figure 6-16 is an early Engineering Sample provided to us by Intel before the Core 2 Duo processors were officially released. Ordinarily, it's possible to identify an Intel processor by the S-Spec number on it. However, at the time we received this processor, Intel hadn't yet published S-Specs for the Core 2 Duo. Our contact at Intel kindly hand-labeled the processor before sending it to us.

With the retention plate closed, press down firmly on the socket lever and snap it into the latched position, as shown in Figure 6-19. Once the socket lever is latched, the processor is secured in the socket and protected by the metal socket body.

Figure 6-19. Close the socket lever and snap it into the latched position

6.5.2.2. Installing the CPU cooler

The Intel Core 2 Duo is a low-current processor, but low current is a relative term. Under heavy load, the Intel Core 2 Duo consumes about as much power as a 60W light bulb and turns that power into waste heatabout as much heat as a 60W light bulb produces. To prevent the processor from overheating and shutting down, that waste heat must be removed by a CPU cooler. Intel supplies a good CPU cooler with the retail-boxed Core 2 Duo processor. The bundled cooler isn't quite as efficient or quiet as the best after-market coolers, but it's not far behind. We received a stock Intel CPU cooler with the processor, so we decided to use it. If we later decide we want a better CPU cooler, we can always buy and install one.

Polish the CPU heat spreader to remove any foreign material. If there is no thermal pad installed on the heatsink base, polish it as well and apply thermal compound to the CPU heat spreader. Orient the CPU cooler above the processor, as shown in Figure 6-20. The cooler base has four expanding posts for which the motherboard has four corresponding mounting holes. Position the CPU cooler so that the posts are aligned with the mounting holes. You can orient the CPU cooler in any position that matches the square mounting hole pattern.

Figure 6-20. Align the CPU cooler over the four mounting holes

We recommend positioning the CPU cooler to minimize the amount of slack in the fan power lead. With the expanding posts aligned with the motherboard mounting holes, press down each post, as shown in Figure 6-21, until it snaps into the locked position.

Figure 6-21. Press down each locking post until it snaps into place

Don't Forget Thermal Compound

The stock Intel CPU cooler comes with a thermal pad already installed. If you use a CPU cooler that does not include a thermal pad, apply thermal compound before you install the CPU cooler. Follow the instructions supplied with the thermal compound. A CPU cooler used without a thermal pad or thermal compound cannot cool the processor properly.

Warning: Intel recommends installing the CPU cooler after the motherboard is installed in the case, but more than one person has cracked a motherboard by following that advice. Usually, the expanding posts seat and lock easily, but at times it requires significant pressure to get them seated and locked.For that reason, we prefer to install Socket 775 CPU coolers with the motherboard outside the case. With other sockets, we prefer to install the cooler with the motherboard on a flat, firm surface, but it's not possible to do that with Socket 775 coolers because the expanding posts protrude through the motherboard. The safest way to install a Socket 775 cooler is shown in Figure 6-21. Support the underside of the motherboard with your fingers as you press each expanding post through the motherboard.

Don't forget to connect the fan power lead to the fan power header pins on the motherboard, as shown in Figure 6-22. (We did forget until after we installed the memory, which is why you can see one corner of a Kingston HyperX memory module peeking out at the upper-left corner of the image.) If there's excessive slack in the CPU fan power cable, secure it to make sure it can't foul the CPU fan.

Figure 6-22. Connect the CPU fan cable to the CPU fan connector

Warning: If you remove the CPU cooler, you must use new thermal compound or a new thermal pad when you reinstall it. Before you install new thermal compound, remove all vestiges of the old thermal compound or pad, using friction from the ball of your thumb or another means. Follow the directions supplied with the new thermal compound precisely when you install it.
6.5.2.3. Installing memory

Installing memory in the Intel D946GZIS motherboard is easy. There are two memory modules to be installed, and two memory slots available. Pivot the white plastic locking tabs on both sides of both DIMM sockets outward to prepare the slots to receive DIMMs. Orient each DIMM with the notch in the contact area of the DIMM aligned with the raised plastic tab in the slot and slide the DIMM into place, as shown in Figure 6-23.

Figure 6-23. Orient the DIMM with the notch aligned properly with the socket

With the DIMM properly aligned with the slot and oriented vertically relative to the slot, use both thumbs to press down on the DIMM until it snaps into place. The locking tabs should automatically pivot back up into the locked position, as shown in Figure 6-24, when the DIMM snaps into place. If they don't, close them manually to lock the DIMM into the socket.

Figure 6-24. Seat the DIMM by pressing straight down with both thumbs until it snaps into place

With the processor and memory installed, you're almost ready to install the motherboard in the case. Before you do that, check the motherboard documentation to determine if any configuration jumpers need to be set. The Intel D946GZIS has only one jumper, which sets operating mode. On our motherboard, that jumper was set correctly by default, so we proceeded to the next step.

6.5.3. Installing the Motherboard

Installing the motherboard may take as long as all other assembly steps combined, because there are so many cables to connect. It's important to get all of them connected right, so take your time and verify each connection before and after you make it.

6.5.3.1. Seating and securing the motherboard

To begin, slide the motherboard into the case, as shown in Figure 6-25. Carefully align the back panel I/O connectors with the corresponding holes in the I/O template, and slide the motherboard toward the rear of the case until the motherboard mounting holes line up with the standoffs you installed earlier.

Figure 6-25. Slide the motherboard into position

The I/O template has metal grounding tabs that make contact with various back-panel I/O connectors. Make certain that the tabs are positioned correctly and do not intrude into one or more of the port connectors. More than once, we've mounted a motherboard, inserted all the screws, and connected all the cables before we noticed that there was a metal tab sticking into one of our USB or LAN ports. Before you secure the motherboard in place, verify that the back-panel I/O connectors are mated properly with the I/O template, as shown in Figure 6-26.

Figure 6-26. Back panel connectors should mate cleanly with the I/O template

Once the motherboard is positioned properly and you have verified that the back-panel I/O port connectors are mated cleanly with the I/O template, insert a screw through each motherboard mounting hole into the corresponding standoff, as shown in Figure 6-27. For the first two or three screws, you may have to apply pressure with one hand to keep the holes and standoffs aligned while driving the screw with the other.

Figure 6-27. Securing the motherboard

At times it's difficult to get all the holes and standoffs aligned. If that occurs, insert two screws into easily accessible positions but don't tighten the screws completely. You should then be able to force the motherboard into complete alignment, with all holes matching the standoffs. At that point, insert one or two more screws into less-accessible standoffs and tighten them completely. Finish mounting the motherboard by inserting screws into all standoffs and tightening them. Don't put excessive force on the screws, or you may crack the motherboard. Finger-tight is plenty.

SCREWED

With cheap motherboards and cases, it's sometimes impossible to get all of the mounting holes aligned with the standoffs. With high-quality products like the Antec case and Intel motherboard, everything usually lines up perfectly. But if you find yourself unable to insert all of the motherboard mounting screws, don't despair. We like to get all the screws installed, both for physical support and to make sure all of the grounding points on the motherboard are grounded, but getting most of the screws installedsay six or seven of the eightis normally good enough.

If you are unable to install all of the screws, take the time to remove the brass standoffs where no screw will be installed. A misaligned standoff may short something out. In positions where you cannot use brass standoffs because of alignment problems, you can substitute white nylon standoffs, a few of which are usually included in the parts package. (If not, you can get them at most computer stores.) You may have to trim the nylon standoffs to length to make them fit. Jim Cooley suggests using double chopsticks, which are the right thickness to support the motherboard and are made of nonconducting wood.

It's particularly important to provide some support for the motherboard near the expansion slots, where significant pressure may be applied when installing cards. If the motherboard is unsupported, pressing down may crack it.

6.5.3.2. Connecting the front-panel switch and indicator cables

Once the motherboard is secured, the next step is to connect the front panel switch and indicator cables to the motherboard, as shown in Figure 6-28. Although Intel has defined a standard front panel connector block and uses that standard on its own motherboards, few other motherboard makers adhere to that standard. Accordingly, rather than provide an Intel-standard monolithic connector block that would be useless for motherboards that do not follow the Intel standard, most case makers provide individual two- or three-pin connectors for each switch and indicator.

The only essential front-panel connector is the power switch, which must be connected for you to be able to start the system. You'll probably also want to connect the reset switch and the hard disk activity LED (shown in Figure 6-28). Your case may have front-panel cables for which no corresponding pins exist on the motherboard. For example, many cases include a speaker cable, but most motherboards have embedded speakers and so may not include pins to connect to the case speaker. Conversely, your motherboard may have pins for which the case has no corresponding cable. For example, the Intel D946GZIS motherboard has pins for a Power LED, which the Antec Fusion case does not provide a cable for. (Instead of using a traditional power LED powered by the motherboard, the Antec Fusion uses front-panel illumination powered directly by the power supply. When the system is turned on, the front panel is illuminated.)

Figure 6-28. Connect the front-panel switch and indicator cables

Before you begin connecting front-panel cables, examine the cables. Each should be labeled descriptively, e.g., "Power SW," "Reset SW," and "H.D.D. LED." Match those descriptions with the front-panel connector pins on the motherboard to make sure you connect the correct cable to the appropriate pins. Switch cablespower and resetare not polarized. You can connect them in either orientation, without worrying about which pin is signal and which ground. LED cables may or may not be polarized, but if you connect a polarized LED cable backward the worst that happens is that the LED won't light. Antec cases use white wires for ground and colored wires for signal. Most cases use a black ground wires, and few use green.

When you're connecting front-panel cables, try to get it right the first time, but don't worry too much about getting it wrong. Other than the power switch cable, which must be connected properly for the system to start, none of the other front-panel switch and indicator cables is essential, and connecting them wrong won't damage the system.

6.5.3.3. Connecting the front-panel USB ports

The Antec Fusion case provides two front-panel USB ports with cables that terminate in one Intel-standard dual-USB connector. Locate that cable, which is labeled USB, and connect it to one of the dual-USB motherboard connectors located near the left-front edge of the motherboard, as shown in Figure 6-29. The motherboard connector is keyed with a missing pin that corresponds to a blocked hole on the cable connector, so it's difficult to connect the cable incorrectly. Note, however, that it is possible to offset the cable connector against the motherboard connector and still seat the connector.

Figure 6-29. Connect the front-panel USB cable to a motherboard dual-USB connector

6.5.3.4. Connecting the vacuum fluorescent display and volume control

The Antec Fusion case provides a vacuum fluorescent display (VFD) and a volume control knob that work with Windows Media Center and (we hope) other media center applications. The VFD/volume cable terminates in a standard external USB connector. Antec supplies an adapter to convert the external USB connector to an internal 4-pin single USB connector. (The adapter is visible as the large black item at the bottom of Figure 6-30.)

Figure 6-30. Connect the VFD/Volume cable to a motherboard USB connector

Where's the FireWire?

The Antec Fusion case provides a front-panel FireWire port, but the Intel D946GZIS motherboard does not provide a FireWire interface. Tie off the FireWire cable neatly and tuck it out of the way. Alternatively, if you have a free expansion slot and want FireWire support, install a FireWire expansion card. All such cards provide one or more FireWire ports on the back panel, but many also include an internal FireWire port, which can be connected to the Fusion front-panel FireWire cable.

Unfortunately, in our configuration we have no available PCI slots. We do have an unused PCI Express x1 slot, but weren't able to locate a FireWire adapter that would fit that slot. Perhaps that will have changed by the time you build your media center PC.

The VFD/Volume connector is a 4-pin single-USB connector that can be connected to any available motherboard USB connector. Note that the 4-pin connector is not keyed, so it's easy to connect it incorrectly. Orient the cable connector as shown in Figure 6-30, with the GND pin nearest the missing pin on the motherboard connector, and press it into place.

6.5.3.5. Connecting the front-panel audio ports

The Antec Fusion case provides two front-panel audio ports with a cable that terminates in an Intel-standard front-panel audio connector. Locate that cable, which is labeled Audio, and connect it to the yellow FP Audio motherboard connector located near the left-rear corner of the motherboard, as shown in Figure 6-31. The motherboard FP Audio connector is keyed with a missing pin that corresponds to a blocked hole on the cable connector, so align the cable connector and motherboard connector properly before you press the cable connector into place.

Figure 6-31. Connect the front-panel audio cable to the motherboard FP Audio connector

In addition to the Intel-standard monolithic front-panel audio connector block, the Antec Fusion front-panel audio cable provides seven individual signal wires that match the signals on the connector block. You can use these individual wires to connect the front-panel audio if your motherboard provides a front-panel audio connector block that does not conform to the Intel standard.

If you don't need these individual wires, we recommend taping them off to the cable. We neglected to do that initially, and those tiny wires made things very difficult when we installed expansion cards.

6.5.3.6. Connecting the serial ATA data cables

As long as we're connecting cables to the motherboard, we might as well connect the Serial ATA data cables for the hard drives. The Intel D946GZIS motherboard provides four S-ATA data connectors, which are located on the left-front corner of the motherboard. Intel properly labels these connectors SATA 0 through SATA 3. (Some motherboards begin numbering at SATA 1.)

Locate two S-ATA data cables, which may be supplied with the motherboard, the hard drives, or both. Connect two of those S-ATA data cables to the first two motherboard S-ATA ports (SATA 0 and SATA 1), as shown in Figure 6-32. Align the cable connector with the motherboard connector, making sure that the L-shaped keys on both connectors are oriented properly, and then press the cable connector straight down until it seats in the motherboard connector.

Figure 6-32. Connect the Serial ATA data cables to the motherboard ports

Warning: Both ends of an S-ATA cable are identical in terms of pin assignments and keying, so it usually doesn't matter which end you connect to the motherboard and which to the drive. Many S-ATA cables have simple plastic connectors on both ends, but some, including those supplied with the Intel motherboard, have metal latching connectors on one or both ends (visible in Figure 6-32) that are designed to lock the cable to the connector.If you subsequently remove such a cable, make sure to press the latch to disconnect it before you pull the cable or you may damage the motherboard connector and/or the cable. Back in the days when latching S-ATA connectors were still very uncommon, we once pulled an S-ATA cable from a motherboard without watching what we were doing. We heard a loud cracking noise. Fortunately, it was the cable we damaged rather than the motherboard, but it might easily have been otherwise.

6.5.4. Route and Connect Power to the Motherboard

The next step is to route the necessary power cables from the power supply chamber to the motherboard chamber and connect those cables. Locate the sliding access panel between the power supply chamber and the motherboard chamber. Loosen the screw that secures it, as shown in Figure 6-33, and slide the panel all the way toward the rear of the case.

Figure 6-33. Loosen the screw that secures the access panel

You'll need to route most or all of the following cables through the access panel:

  • Main ATX power cable (always needed)

  • ATX12V power cable (needed for most modern motherboards)

  • Serial ATA power cable (always needed)

  • Molex (hard drive) power cable with Berg (floppy drive) connector (always needed)

  • PCI Express power cable (needed if your video adapter requires it)

Unfortunately, we spent too much time doing and too little time thinking, and it cost us. It took several iterations until we got the correct group of cables routed through the access panel.

The first time, we didn't route a Molex cable to the motherboard chamber because the optical drive is located in the same chamber as the power supply. We forgot we'd need a Molex cable in the motherboard chamber for the fans.

The second time, we routed a Molex cable to the motherboard chamber, but we chose the longer Molex cable, which doesn't include a Berg (floppy drive) connector. We later realized we needed a Berg connector for the front-panel illumination.

The third time, we finally got it right. Unfortunately, each time we'd already installed all of the expansion cards, and we had to pull every card to get to the access panel. Arrrrghhh.

Once you've routed the proper power cables through the access panel, slide the door closed and tighten the screw, as shown in Figure 6-34. If you forget a cable, don't say we didn't warn you.

Figure 6-34. Route the necessary cables from the power supply chamber and resecure the access panel

If you're paying close attention, you may have noticed that we forgot yet one more cable. Yep. The ATA ribbon cable has to be routed from the optical drive in the power supply chamber to the ATA motherboard connector in the motherboard chamber.

We'll confess that we actually did forget about the ATA data cable, but we couldn't face ripping out the expansion cards for a fourth attempt. Once is unfortunate. Twice is coincidence. Three times is enemy action. Four times begins to look like rank stupidity. Fortunately, we're very good at rationalizing.

If we'd had a round ATA cable, we probably would have bit the bullet and pulled all the expansion cards again (although we were beginning to wonder how many insertions their connectors were rated for...) But we had a flat ATA ribbon cable, and it seemed a bad idea to route it through that roundish hole in the access panel. As a matter of good practice, we try to avoid folding or crimping ribbon cables, and getting a flat ATA cable through that access panel would require crushing it severely. So we decided just to route the ATA ribbon cable over the top edge of the divider that separates the chambers. Once the side panel is reinstalled the ATA cable will be wedged between the divider and the side panel, but that will do it no harm.

Once you have the cables routed from the power supply chamber to the motherboard chamber, the next step is to connect the main ATX power cable, as shown in Figure 6-35. Align the cable with the motherboard connector and press down firmly until it snaps into place. Examine the connection visually to verify that the connectors are fully mated. A partially seated Main ATX power connector can cause subtle problems that are very difficult to troubleshoot.

Figure 6-35. Connect the main ATX power cable

The next step is to connect the ATX12V power cable, as shown in Figure 6-36. The ATX12V motherboard connector is located between the CPU socket and the rear I/O panel. Orient the ATX12V cable properly, and press down firmly until it snaps into place. Examine the connection to make sure that the latch is engaged.

Figure 6-36. Connect the ATX12V power cable

6.5.5. Installing the Expansion Cards

The next step is to install the expansion cards and video adapter. We're installing the pcHDTV HDTV tuner and the Hauppauge dual analog tuner, each of which uses a PCI slot, and the Gigabyte video adapter, which uses the PCI Express x16 slot. To begin, remove the screws that secure the three slot covers, as shown in Figure 6-37.

Figure 6-37. Remove the screws that secure the expansion slot covers

Align each expansion card carefully with its corresponding slot. Press down firmly with both thumbs, as shown in Figure 6-38, until the card seats completely in the slot. Verify visually that each card is fully seated. Video adapters are particularly problematic. The video adapter may appear to seat. You may even feel it snap into place. That doesn't guarantee that it's completely seated. Always verify visually that the video adapter is fully seated and level in the slot, with the top edge of the video adapter contacts flush with the top edge of the slot.

Figure 6-38. Align each expansion card with the slot and press firmly until it seats

Warning: PCI Express video adapters (and the earlier AGP models) use a plastic retention mechanism to secure the video adapter in the slot. When you install a video adapter, make sure the retention mechanism latches. When you remove a video adapter, make sure to unlatch the retention mechanism before you attempt to remove the card from the slot.

After you seat each expansion card, reinsert the screw to secure the bracket to the chassis, as shown in Figure 6-39. After you've screwed in the retaining bracket, double-check to make sure the card is fully and completely seated in its slot. (Sometimes, driving the screw into the bracket can twist the card up and out of the slot slightly.)

Figure 6-39. Reinstall the screw to secure the expansion card to the chassis

With both tuner cards and the video adapter installed, the back panel of the media center PC is quite crowded, as shown in Figure 6-40. Also, this image doesn't show the break-out "octopus" box that we'll later connect to the analog tuner card to split out the audio/video I/O ports.

Figure 6-40. The back panel of the Media Center PC

6.5.6. Installing the Optical Drive

The next step is to install the optical drive. The Antec Fusion case provides a dedicated optical drive bay with a universal drive door that conceals the bezel of the optical drive itself, so you can use any color of optical drive without concern for matching the front bezel of the case. To begin installing the optical drive, pivot the drive bay upward, as shown in Figure 6-41, and then lift it free of the case.

Figure 6-41. Remove the optical drive bay

Warning: Although the optical drive bay apparently has room for two optical drives, you can install only one drive, in the lower position. The upper position is unusable because the VFD protrudes back into the drive bay assembly. Note that at least early revisions of the Antec Fusion manual correctly said to mount the optical drive in the lower bay, but used an illustration that incorrectly showed the drive being mounted in the upper bay.

Slide the optical drive into the bottom opening of the drive bay. Align the drive screw holes with the rear set of screw holes in the drive bay, as shown in Figure 6-42. Once the drive is aligned properly, secure it to the drive bay with four screws, as shown in Figure 6-43.

Figure 6-42. Align the drive screw holes with the rear set of screws holes in the bay

Figure 6-43. Secure the optical drive with four screws

The next step is to connect the cables to the optical drive. Before you proceed, check the jumper on the back of the optical drive to make sure it's configured properly. This is the only parallel ATA device in the system, so it should be jumpered as master. Our NEC ND-3550A optical drive was set as master by default, but some optical drives are set as slave by default. Check the jumper and change it if necessary to make the drive master.

Once you've verified that the drive is configured correctly, connect the ATA data cable to the drive, as shown in Figure 6-44. We used the 80-wire UltraATA cable supplied with the motherboard, which works properly but is a better cable than the drive actually requires. A standard 40-wire ATA cable is sufficient for an optical drive, so don't hesitate to use a 40-wire cable if that's what you have. Before you seat the cable, make sure that pin 1 on the cable (indicated by a color stripe) is aligned with pin 1 on the drive (usually toward the power connector, and always labeled). Once the cable is aligned properly with the drive socket, press firmly to seat it completely.

Figure 6-44. Connect the ATA data cable to the optical drive

Locate a Molex (hard drive) power cable, and connect it to the optical drive, as shown in Figure 6-45. Molex connectors are keyed with beveled corners on the plug and socket. Align the plug with the socket and press firmly to seat the connector, which may require significant pressure.

Figure 6-45. Connect a Molex power cable to the optical drive

After you've connected the data and power cables to the optical drive, replace the drive bay in the chassis, as shown in Figure 6-46. Align the front posts on each side of the drive bay with the corresponding notches on the chassis, and pivot the drive down into the latched position, with the rear posts fully seated in the chassis cutouts.

Figure 6-46. Reinstall the optical drive bay in the case

The next step is to install the hard drives. The Antec Fusion case uses a unique method for mounting the hard drives. Hard drives are usually mounted rigidly, secured by screws on both sides or on the bottom. The Fusion case instead allows the hard drives to "float" by suspending them from only one side.

Please Be Seated

Make sure the optical drive bay seats completely. When we first assembled our media center PC, we were unable to reinstall the top panel. As we tried to figure out the problem, we finally noticed that the optical drive bay was protruding just a couple millimeters too high to allow the top panel to slide into place. With the drive bay reseated properly, the top panel slid easily into place.

To begin installing the hard drives, remove the four screws that secure the hard drive mounting plate, as shown in Figure 6-47.

Figure 6-47. Remove the four screws that secure the hard drive mounting plate

With the screws removed, pivot the hard drive mounting plate upward, as shown in Figure 6-48, and pull it free from the case. Note the soft silicone grommets, visible as small white doughnuts in Figure 6-48. The four grommets on top of the hard drive mounting plate isolate the hard drives from the mounting plate, preventing hard drive vibrations from being transferred to the chassis structure. There are four corresponding grommets at the bottom of the drive bay, two of which are visible in the image. The hard drives are not screwed to these bottom grommets, but rest freely against them.

Figure 6-48. Pivot the hard drive mounting plate upward and pull it free of the case

Bass Ackward

Note the orientation of the hard drive mounting plate relative to the chassis. The hard drive mounting plate appears to be symmetric, but it's not. The position of the screw holes for mounting the hard drive makes the mounting plate chiral, like a glove. If you reverse the mounting plate, the hard drives will not fit properly. When properly oriented, the hard drive screw holes are offset toward the front of the case, as shown in Figure 6-48.

Locate the special hard drive mounting screws in the parts bag supplied with the Fusion case. These screws have a very wide flange that bears against the silicone shock-mounting grommets. Align the drives with their connectors facing left when the mounting plate is oriented normally relative to the case. Secure each drive with two of the special hard drive mounting screws, as shown in Figure 6-49.

Figure 6-49. Secure each hard drive to the mounting plate with two screws

With the hard drives not yet installed in the case, now is a good time to connect power to the VFD. (The VFD is controlled by its USB connection but does not receive power from it.) Locate the short cable coming from the front panel that has a Berg (floppy drive) power connector. Route the power supply cable that has a Berg connector through the access hole to the hard drive bay area and connect power to the VFD cable, as shown in Figure 6-50.

Figure 6-50. Connect power to the VFD

The next step is to connect the data and power cables to the hard drives. Antec recommends connecting these cables after the hard drives are installed in the case, but we found it easier to connect them first. (Make sure to route the data and power cables through the access hole to the hard drive chamber before you connect the cables to the drives.)

Align the data cable with the hard drive connector, making sure the L-shaped keying notches match, and then press the cable connector firmly until it seats on the hard drive connector, as shown in Figure 6-51. Repeat this process to connect the power cables to the hard drives, as shown in Figure 6-52, again making sure that the keys are aligned properly before you seat the cables.

Figure 6-51. Connect the Serial ATA data cables to the hard drives

Figure 6-52. Connect the Serial ATA power cable to the hard drives

The final step in installing the hard drives is to reinstall the mounting plate, as shown in Figure 6-53. Make sure that all four tabs on the mounting plate seat in the corresponding cutouts in the chassis, and then secure the mounting plate with the four screws you removed earlier. When the mounting plate is correctly installed, the drives should be vertical, as shown in the illustration, with their lower sides resting on the silicone grommets at the bottom of the hard drive chamber. (If the hard drives are tilted, you've installed them backward on the mounting plate. Remove it and start over.)

Figure 6-53. Reinstall the hard drive mounting plate and secure it with four screws

6.5.7. Finishing Up

Only a few steps remain to complete your media center PC assembly. We haven't yet connected the optical drive data cable to the motherboard interface, so do that now. Align pin 1 on the cable (the side with the color stripe) with pin 1 on the motherboard interface, and press the cable connector firmly into place until it fully seats in the motherboard socket, as shown in Figure 6-54.

Figure 6-54. Connect the optical drive data cable to the motherboard ATA interface

Locate the Molex cable with the blue and white wires coming from the front-panel area. This connector supplies power to the front-panel LED. Connect this cable, as shown in Figure 6-55, to one of the Molex connectors on the cable coming from the power supply.

Figure 6-55. Connect power to the front-panel LED

Finally, connect the two side fans to the power supply Molex cable, as shown in Figure 6-56. Each of these fans has a selector switch on the end of a short white cable. By default, the switch is set to run the fan at low speed, which should suffice. For better airflow, you can move the switch on one or both fans to the medium or high setting. On low speed, the fans are nearly inaudible. At medium speed, they move considerably more air, but produce noticeable (although not intrusive) sound. At high speed, they move still more air, but produce more noise than most people will find acceptable.

Figure 6-56. Connect power to the two side fans

BAFFLING

The Antec Fusion case includes a black plastic air baffle, visible in Figure 6-25, near the rear I/O panel that is designed to direct air across the CPU cooler. That baffle as supplied worked fine in our system, and will probably work well in most systems that use different components.

We could have installed the baffle extensions provided with the case to route more air directly to the CPU cooler, but doing that would have reduced the air flow around the expansion cards, which are very tightly grouped. The Core 2 Duo processor is a low-current, cool-running processor anyway, so we elected not to extend the baffle.

All that remains is to dress the cables, configure BIOS Setup, and reinstall the top panel. Once you have the cables dressed, take a few minutes to double-check everything one last time before you apply power to the system. Use the following checklist:

  • No loose tools or screws (shake the case gently)

  • CPU cooler properly mounted; CPU fan connected

  • Memory modules fully seated and latched

  • Front-panel switch and indicator cables connected properly

  • Front-panel cables connected properly

  • Hard drive data cables connected to drive and motherboard

  • Hard drive power cables connected

  • Optical drive data cable connected to drive and motherboard

  • Optical drive power cable connected

  • All drives secured to drive bay or chassis, as applicable

  • Expansion cards fully seated and secured to the chassis

  • Main ATX power cable and ATX12V power cable connected

  • All cables dressed and tucked

Once you're certain that all is as it should be, it's time for the smoke test. Leave the cover off for now. Connect the power cable to the wall receptacle and then to the system unit. Press the main power button on the front of the case, and the system should start up. Check to make sure that the power supply fan and CPU fan are spinning. You should also hear the hard drive spin up and the happy beep that tells you the system is starting normally. At that point, everything should be working properly.

Only the Good Die Young

When you turn on the rear power switch, the system will come to life momentarily and then die. That's perfectly normal behavior. When the power supply receives power, it begins to start up. It quickly notices that the motherboard hasn't told it to start, and so it shuts down again. All you need to do is press the front-panel power switch and the system will start normally.

Turn off the system, disconnect the power cord, and take these final steps to prepare the system for use:

Set the Setup BIOS Configuration jumper to Configure mode

The BIOS Setup Configuration jumper block on the Intel D946GZIS motherboard is used to set the operation mode. This jumper is located near the center of the left edge of the motherboard, near the front edge of the expansion slots. By default, the jumper is in the 12 or "normal" position. Move the jumper block to the 23 or "configure" position.

Reconnect the power cord and restart the system

When the configuration jumper is set to configure mode, starting the system automatically runs BIOS Setup and puts the system in maintenance mode. This step allows the motherboard to detect the type of processor installed and configure it automatically. When the BIOS Setup screen appears, choose the menu option to clear all BIOS data and then reset the system clock. Save your changes and exit. The system automatically shuts down. Disconnect the power cord.

Set the BIOS Setup Configuration jumper to Normal mode

With the power cord disconnected, move the BIOS Setup Configuration jumper block from 23 (Configure mode) to 12 (Normal mode).

Replace the side panel and reconnect power

With the jumper set for Normal operation, replace the side panel and reconnect the power cord. Your system is now completely assembled and ready for use.


Section 6.6. Final Words

6.6. Final Words

We finished building the Media Center PC with the book deadline approaching like an oncoming train. We'd already tested and compared various PVR applications on other hardware, so we were pretty sure we wanted to run MythTV on our Media Center PC. We downloaded and installed Ubuntu 6.06 LTS Linux (http://www.ubuntu.com), updated it to the SMP kernel, and then downloaded and installed MythTV (http://www.mythtv.org) with all of its optional packages and plug-ins.

As the book went to press, we were still playing with the software. Everything lights up and all of the hardware is recognized. But MythTV, while much more polished than the version we looked at two years ago, is still rough. (As Barbara observed while we were struggling to configure MythTV, "Well, here's another nice mess you've gotten us into.")

We'll continue fighting with MythTV for a while, but if it beats us there are several fall-back alternatives. First, of course, our hardware is completely compatible with Windows XP and Windows Vista. (Even the pcHDTV card has Windows drivers.) If worse comes to horrible, we can always install Windows and one of the Windows-based PVR apps. But it probably won't come to that.

SageTV (http://www.sagetv.com), which produces one of the finest Windows-based PVR applications available, also offers a Linux-based version of that software. Installing the SageTV Linux software on an existing system appears to be quite complex, although perhaps not as difficult as installing MythTV. Fortunately, SageTV also offers a turnkey version of their software based on Gentoo Linux. By all reports, installing this version is a simple matter of booting the distribution CD and following the prompts. Can it really be as easy as that? We don't know, but we intend to find out.

For updated component recommendations, commentary, and other new material, visit http://www.hardwareguys.com/guides/media-center.html.


Chapter 7. Building a Small Form Factor (SFF) PC

When the discussion turns to Small Form Factor (SFF) PCs, the first question that comes to our minds is how the term is being used. SFF means different things to different people. For some, it's any PC smaller than the norm. For others, it's specifically the "shoebox" form factorthe so-called "cube" systemspioneered by Shuttle. (In fact, Shuttle says SFF means Shuttle Form Factor.) Still others consider any PC built around a microATX motherboard and case to be an SFF system. Some True Believers claim that only systems based on Mini-ITX motherboardswhich are so small they can be built into a teddy bear or cigar humidorqualify as SFF PCs.

We think the best way to define SFF is by case volume. The cubic capacity of standard mini/mid-tower ATX cases ranges from 30 to 50 liters. Typical microATX cases range from 10 to 20 liters. The small Shuttle SFF case is 200mm x 300mm x 185mm, or just under 8" x 8" X 12", and has a volume of about 11 liters. Cases designed for Mini-ITX motherboards are smaller still, from 6 to 9 liters. Most people perceive a 20-liter or smaller case as "small" and a 10-liter or smaller case as "tiny." Any case with a volume of 20 liters or less fits our definition of SFF.

SMALL, SMALLER, SMALLEST

To provide an idea of scale, a cube that contains 20 liters is about 27 cm (10.7") on a side. A cube that contains 6 liters is about 18 cm (7.2") on a side. An NBA basketball has a volume of just under 7.5 liters.

Although Shuttle introduced the "shoebox" form factor, it was by no means the first company to produce SFF computers. Soon after Intel introduced the ATX form factor in the mid-'90s, they recognized the need for smaller systems. ATX was soon followed by smaller variantsMini-ATX, microATX, and finally FlexATX. Although Intel produced some Mini-ATX and FlexATX motherboards, those form factors were generally ignored by third-party manufacturers, leaving ATX as Intel's answer for standard-size systems and microATX for small systems.

Believe It or Not...

Intel heavily promoted at least two FlexATX computers, although they probably now wish they hadn't. An arrangement with Mattel resulted in the Hot Wheels PC and the Barbie PC, neither of which set any sales records.

Shuttle's first shoebox PC immediately struck a chord with gamers, hobbyists, and other PC enthusiasts. It was expensive, ran hot, didn't have much room for drives or expansion cards, and was noisy. But it was small.

Shuttle followed that first SFF system with a continuing stream of new SFF systems based on various proprietary motherboards for the Athlon XP, Pentium 4, Athlon 64, and, most recently, the Core 2 Duo. Shuttle devotes significant engineering and design resources to their SFF systems, and it shows. Until recently, Shuttle SFF systems were the standard by which all other SFF systems were judged.

In the last few years, many manufacturers have jumped on the SFF bandwagon, trying to horn in on the market niche that Shuttle developed. Until recently, most of these clones were pale imitations of the original product. Recently, several of these other makers, including ASUS, Biostar, and EPoX, have begun shipping SFF systems comparable in quality and features to those made by Shuttle. Shuttle no longer has the SFF market to itself.

A lot of people love Shuttle SFF PCs and their clones. We don't, for several reasons. Most of them use proprietary (or at least semiproprietary) components, including the motherboard and power supply. If you want to upgrade your motherboard or power supply, tough luck. You're stuck with whatever the system manufacturer offers in the way of upgrade options, which often isn't much. We might have been able to live with that, but what we couldn't live with was the very high cost of proprietary SFF "bare-bones" systems. SFF systems typically sell for a 50% to 100% premium over the price of an industry-standard motherboard, case, and power supply of comparable quality.

But merely because we don't much like Shuttle SFF bare-bones systems and their clones doesn't mean we think there is no place for small systems. On the contrary, small systems are perfect for many situations, namely anywhere you need a PC that a standard mini-tower system won't fit or would be intrusive. An SFF system is an ideal candidate for a dorm room, a bedroom set-top box, a home theater system, or a portable LAN party system. For that matter, many people prefer to use an SFF PC as a primary desktop system.

In this chapter, we'll design and build the perfect SFF PC.


Section 7.1. Determining Functional Requirements

7.1. Determining Functional Requirements

The problem with determining functional requirements for an SFF PC is that the SFF umbrella covers a broad range of systems. An SFF PC can be anything from an inexpensive "appliance" PC with a slow processor and embedded video to a fire-breathing gaming systemor anything in between. The only thing these systems have in common is small size.

Accordingly, although we had to choose one SFF PC configuration to build for ourselves and to illustrate this chapter, we specify numerous alternative choices in components that we might have used if we had been designing the SFF PC for a different purpose. When we sat down to think through our own requirements for an SFF PC, here's what we came up with:

Size

Well, that's the whole point, isn't it? A large SFF PC is an oxymoron. Still, although we wanted a small system, we didn't want to make too many compromises in features, performance, cooling, or reliability. We decided that we'd settle for "medium-small."

Reliability

One of our concerns about SFF PCs is that the small case volume makes it difficult to cool the system properly. Running components at high temperatures reduces their service life and makes them less reliable and more crash-prone. The keys to building a reliable system are to choose top-quality componentsparticularly motherboard, memory, hard drive, and power supplyand to keep them cool. In the interests of keeping the system as cool and therefore as reliable as possible, we considered the thermal characteristics of the various components, and chose accordingly.

Performance

We wanted our SFF PC to be small, but not slow. High performance goes hand in hand with higher temperatures, of course, so we had to strike a balance between performance and cooling/reliability. Fortunately, new-generation processors draw as little as half the current of preceding models, which makes it easier to use a high-performance processor while keeping the system cool and reliable. We decided that 3D graphics performance was unimportant for our particular SFF PC, so we elected to use integrated graphics. We did, however, want a system that would support a fast 3D graphics card (if we decide to install one later), which meant the case must accept full-size cards and have sufficient cooling to run at reasonable temperatures with a hot-running graphics adapter installed.

Noise level

SFF PCs are popular because they are unobtrusive. But unobtrusiveness requires more than small size. A tiny PC that sounds like a leaf blower fails the unobtrusiveness test. The SFF PC must be quiet as well as small. Unfortunately, that introduces yet another trade-off. Quiet PCs are quiet because they minimize fan noise, which impedes cooling, or because they use insulation to deaden sound, which also impedes cooling. Once again, we'll need to strike a balance between sound level, performance, and cooling/reliability. We decided that it was a reasonable goal to build a system that was quiet (but not inaudible) while providing midrange or better performance and reasonable temperature levels.

This is a very demanding set of requirements, and one we weren't sure we'd be able to meet. Small, fast, cool, quiet, and reliable. Pick any four. Achieving all five in one system wouldn't be easy.


Section 7.2. Hardware Design Criteria

7.2. Hardware Design Criteria

With the functional requirements determined, the next step was to establish design criteria for the SFF PC hardware. Here are the relative priorities we assigned for our SFF PC. Your priorities may, of course, differ.

DESIGN PRIORITIES

Price

Reliability

Size

Noise level

Expandability

Processor performance

Video performance

Disk capacity/performance

Our SFF PC configuration is a well-balanced system. Other than expandability and video performance, which are unimportant to us for this system, all of the other criteria are of similar priority. Here's the breakdown:

Price

Price is moderately important for this system, but value is more so. We won't try to match the price of mass-market consumer-grade systems, but we won't spend money needlessly, either. If spending a bit more noticeably improves performance, reliability, or cooling, we won't begrudge the extra few dollars.

Reliability

Reliability ties for top importance with size. We'll make compromises in cost, performance, noise level, or any other criterion to make this system as reliable as it is possible to make an SFF PC. The case volume of an SFF PC makes it difficult to achieve reliability comparable to a larger system using similar components, but we'll do everything possible to build the most reliable system we can within the inherent limits of the small case.

Size

Size is matched in importance only by reliability. If it isn't small, the whole exercise is rather pointless. Still, we didn't award this category the absolute highest possible priority, because there are some compromises we simply won't make. Bare-bones "shoebox" PCs are available that have literally half the case volume of the SFF system we eventually decided to build, but those tiny systems simply give up too much in return for saving a few inches.

Noise level

Noise level is moderately important for an SFF PC. Our goal is a system that is unobtrusive in both size and noise level. Accordingly, we'll choose the quietest available mainstream components that otherwise meet our requirements for performance, thermal characteristics, and reliability.

Expandability

Expandability is unimportant for our SFF PC. We may at some point want to make minor system upgrades, such as adding a PCI Express video adapter, an expansion card or two, more memory, and perhaps a second hard drive. To the extent that we can provide for such future expansion without compromising higher-priority considerations, we'll do so. But we consider expandability dead last in priority.

Processor performance

Processor performance is moderately important for our SFF PC. Our goal was performance indistinguishable from a similarly-priced desktop system, which meant we needed a dual-core processor with mainstream performance. Ventilation and cooling considerations limited our processor choices to one of the new-generation low-current processorsan Intel Core 2 Duo or a low-current AMD Athlon 64 X2 model.

Video performance

3D video performance is relatively unimportant for our SFF PC because we do not intend to use it for gaming. We want enough graphics horsepower to run the Windows Vista Aero Glass user interface effects smoothly, but no more. The most recent Intel, ATI, and nVIDIA integrated video chipsets are sufficient for our purposes, and produce much less heat than a high-performance video adapter.

We recognize, though, that many people may decide to build an SFF gaming system, so we tested various video configurations, from integrated video to a midrange nVIDIA 7600 GT. Although it is possible to install a high-end video adapter in an SFF case, a fast video adapter generates too much heat for the SFF case and draws more current than the typical SFF power supply can provide. We concluded that the realistic top-end for a video adapter in an SFF case is a midrange model, ideally one that is passively cooled.

Disk capacity/performance

Disk capacity and performance are moderately important for a SFF PC. This is an easy criterion to meet, because current Serial ATA hard drives are huge, fast, cheap, and reliable. Fortunately, the best models are also relatively quiet and produce little heat.


Section 7.3. Component Considerations

7.3. Component Considerations

With our design criteria in mind, we set out to choose the best components for the SFF PC. The following sections describe the components we chose and why we chose them. For the SFF PC, we had to reverse our usual practice of choosing the components and then building the system. As strange as it sounds, we had to build the SFF PC and then choose the components.

By that, we mean that component choice is constrained when you build a small system. With a standard system, you needn't worry about components fitting the case. With an SFF PC, component size is a constant concern. For example, the CPU cooler you really want to use may be too tall to fit between the motherboard and drive bay; the optical drive you really want to use may be half an inch too deep to seat fully in the drive bay; or the fan on your video adapter may intrude on the PCI slot, making it unusable.

For example, Figure 7-1 shows two optical drives, an NEC ND-3550A DVD writer on the bottom and a Lite-On DVD-ROM drive on top. In a standard case, the half inch or so difference in depth is immaterial. In an SFF case, that extra half inch may mean the larger drive won't fit the case. (As it happened, we were able to use the NEC ND-3550A DVD writer, but it was a tight fit.)

Figure 7-1. NEC ND-3550A DVD writer (bottom) and Lite-On DVD-ROM drive

Such factors as motherboard layout and cable flexibility may also come into play. For example, the motherboard you want to use may have the front-panel connectors in an inaccessible location, or the S-ATA connectors may have insufficient clearance to allow the S-ATA cable to be seated without breaking off the connector.

Measure First, Buy Later

If you use components other than those we specify, you may encounter problems with fit or function. To minimize potential problems, buy the case before you buy other components. Measure the available space, and compare your measurements carefully against the component sizes listed on their web sites. Note that the sizes given for components are usually accurate, but may not include protruding connectors and do not include clearances required for cables. With the case in front of you, you can also get a reasonably good idea of layout issues, component clearance issues, and so on. Without the case, you'll find it's impossible to make even reasonable guesses about whether particular components will fit.

Configuring any PC involves trade-offs, but this is doubly true when you configure an SFF PC. The small case volume makes cooling more difficult and component dimensions critical, and the smaller power supply limits your choices for high-current devices like fast video adapters. Any PC requires compromises between performance and noise, but this is even more apparent with an SFF PC. Many "quiet PC" technologiessuch as using large passive heatsinks and multiple large, slow fanssimply cannot be used with an SFF PC because there isn't room for them. If you want a fast SFF PC, it's going to be loud. If you want a quiet SFF PC, you'll have to make compromises.

Warning: Although we tested the configuration we used to build our own SFF PC, we did not test permutations with the listed alternatives. Those alternatives are simply the components we would have considered using if our requirements were different. We would still have had to verify fit and function and perhaps would have been forced to substitute other components. We can't guarantee that these alternative components will fit or function reliably, individually or together.

7.3.1. Case and Power Supply

Antec NSK1300 microATX case (http://www.antec.com)

The SFF PC we built for the first edition of this book used an Antec Aria case. We liked the Aria case enough that we planned to use it again for our new SFF PC configuration. Alas, as we were choosing components for this system, we found that Antec had discontinued the Aria. Fortunately, as we browsed the Antec site, we found the NSK1300 case, shown in Figure 7-2. We think of it as the "Aria II."

Figure 7-2. Antec NSK1300 microATX case

At first glance, it's difficult to tell them apart. The only discernible differences we found were that the NSK1300 has round power and reset buttons instead of square ones, adds a top vent for the power supply, and doesn't include the card reader that was bundled with the Aria. Oh, and the NSK1300 sells for $20 or so less than the Aria did.

We actually had a new Aria in the stock room, and intended to use it for our new SFF PC. Then we realized that all of the motherboards we were considering using required a 24-pin ATX 2.2 main ATX power connector, but the Aria had the older-style 20-pin main ATX power connector. That sent us off to the Antec web site in search of an updated Aria with a 24-pin power supply, where we eventually discovered that the NSK1300 had replaced the older Aria.

Although we considered other microATX cases, we pretty much knew ahead of time that we were likely to go with the NSK1300, based on our experiences with the Aria. The NSK1300 accepts any microATX motherboard and full-height expansion cards. It has a robust 300W ATX 2.2 power supply rather than the marginal 160W to 220W power supplies provided with most bare-bones "shoebox" SFF systems. The Antec Aria is one of the quietest cases we have ever used, and yet it provides cooling sufficient to run midrange components at reasonable temperatures. We expected no less from the NSK1300. Finally, the NSK1300's reasonable price meant we could build an SFF system without breaking the bank on an overpriced proprietary SFF bare-bones system.

The NSK1300 is by no means the only microATX case available, but most microATX cases use the slimline "pizza-box" form factor rather than the "cube" form factor of the NSK1300. Slimline cases are useful for some "appliance" applications, but have too many limitations for a general-purpose system. For example, many of them accept only one optical drive and one hard drive, have proprietary (expensive) low-wattage power supplies, accept only two or three half-height expansion cards, and so on. The NSK1300 addresses all of those issues, with its four drive bays, 300W power supply, and ability to accept four full-height expansion cards.

The NSK1300 is roughly the same height and depth as a typical "shoebox" SFF PCwithin half an inch or so either way. The real difference is width. The NSK1300 is a couple inches wider than most SFF PCs, but don't blame Antec. The additional width is needed to accommodate a microATX motherboard, with its full complement of expansion slots. The relatively small increase in width also pays off in case volume. The volume of the Antec NSK1300 is about 18 liters, 20% or so larger than the largest shoebox models and nearly twice the 11-liter volume of smaller SFF cases. That additional volume makes the NSK1300 easier to work on, and contributes to more efficient cooling and a lower noise level.

Table 7-1 compares the Antec NSK1300 with the Shuttle SN27P2, a typical "large" bare-bones SFF system for Socket AM2 AMD processors.

Table 7-1. Antec NSK1300 case versus Shuttle SN27P2

Antec NSK1300

Shuttle SN27P2

Height

7.9" / 200mm

8.3" / 210mm

Width

10.6" / 269mm

8.7" / 220mm

Depth

13.2" / 335mm

12.8" / 325mm

Case volume (liters/cubic inches)

18.1 / 1,105

15.1 / 924

External drive bays (5.25"/3.5")

1 / 0

1 / 1

Internal drive bays (5.25"/3.5")

0 / 3

0 / 2

Expansion slots

1 PCIe x16 + 3 PCI

1 PCIe x16 + 1 PCI

Motherboard included

None

Proprietary nForce 570 Ultra

Other motherboards accepted

Any microATX

none

Power supply

300W PFC

400W PFC

Street price (with motherboard)

$175 (typical)

$375

The Antec NSK1300 wins the comparison easily. The NSK1300 is a bit larger than the SN27P2, but uses industry-standard components and has three PCI expansion slots versus one. The Shuttle has a 400W power supply, but, frankly, we don't think it's a good idea to cram enough components into an SFF PC to require that larger power supply. The real killer is price. The Shuttle SN27P2 SFF case with motherboard sells for about $375. The Antec NSK1300 with a typical motherboard sells for about $175, or less than half the price.

Most SFF bare-bones systems we've seen use thin aluminum panels, which weigh little and help cooling, but do nothing to reduce sound emissions. In fact, most of them seem to resonate with a high-pitched buzz or whine that originates in the power supply fan and CPU fan. The NSK1300 is different. Its side panels use composite construction, with two thin aluminum plates sandwiching a central plastic layer. The top panel is similar, but uses one aluminum plate facing the inside of the system, with an exposed corrugated plastic layer on the outside.

ALTERNATIVES: CASE/POWER SUPPLY

When we checked NewEgg, we found 799 cases listed. More than 100 of those were microATX cases of one form or another, so you should be able to find an SFF case that's suitable for your needs. We ruled out the pizza-box and micro-tower form factors for our system, but one of those may be suitable for yours. Of the "cube"-style cases, we liked the Antec NSK1300 best, but there are numerous alternatives, including the Chenming 118, the JPAC 901, the Apevia (Aspire) X-QPACK models, and the Lian Li PC-V300 models. We haven't used any of those alternatives, so we can't comment on their quality or usability, but all are popular with SFF builders.

Although Antec gave up the minor cooling advantage of using thin single aluminum panels, their composite panels are acoustically inert. When we tapped on them, all we heard was a dull thud rather than the metallic sound generated by simple aluminum panels. We suspect that these composite panels contribute a great deal to the low noise level of the NSK1300.

Although the Antec NSK1300 isn't perfect, it does a excellent job of balancing size, accessibility, cooling efficiency, noise level, and price. For our purposes, the NSK1300 was the ideal SFF case.

7.3.2. Processor

Intel Core 2 Duo E6300 (http://www.intel.com)

Although our SFF PC is physically small, we want it to be fast. The small case and 300W power supply put some real limitations on processor choice. An older-generation, high-current processor would overload the power supply and make it very difficult to cool the system. Short of using a mobile processorwhich introduces problems of its own, not least motherboard availabilitythat effectively limits our choices to a modern low-current desktop processor like the Intel Core 2 Duo or one of the special energy-efficient AMD Athlon 64 X2 models, either of which draws only 65W.

At the time we built this system, the Intel Core 2 Duo was the hands-down winner in both absolute performance and price/performance ratio. The so-called "entry-level" Core 2 Duo E6300 offers extremely high performance at a very reasonable price, so we chose that model for our SFF PC.

ALTERNATIVES: PROCESSOR

We think the Intel Core 2 Duo is the standout choice for the SFF PC. If you prefer AMD, we recommend an Athlon 64 X2 4200+ or faster. AMD offers low-power variants of some X2 models that consume much less power than the standard models. Although they are more costly than the standard models of the same speed, the low-power variants are much better suited for an SFF PC.

7.3.3. Motherboard

Intel D946GZIS (http://www.intel.com)

Our choice of the Antec NSK1300 case dictates a microATX motherboard. Core 2 Duo is a Socket 775 processor, but most Socket 775 motherboards are not compatible with Core 2 Duo. At the time we built this system, the Intel D946GZIS was the only microATX motherboard available that supported Core 2 Duo, so that's what we chose.

Fortunately, the D946GZIS suits our requirements perfectly. It supports up to 4 GB of DDR2 memory in two slots. It includes integrated GMA3000 video, which is fast enough to run the Windows Vista Aero Glass user interface effects, but also provides a standard x16 PCI Express video adapter slot. The integrated 5.1 audio and 10/100 Ethernet are sufficient for our purposes. The board layout is clean, and is as easy to work with as we could hope, given the constrained spaces of an SFF case.

7.3.4. Memory

Kingston 2GB PC5300 DDR2 Memory Kit (1 GBx 2) (http://www.kingston.com)

The Intel D946GZIS has two DDR2 memory slots and supports dual-channel memory operation with PC2-4200, PC2-5300, or PC2-6400 modules in capacities up to 2 GB. At the time we built this system, PC2-4200 modules sold for about the same price as PC2-5300 modules, but PC2-6400 modules sold at a 50% premium. We'd have liked to use PC2-6400 memory, but the slight performance bump wasn't worth the additional cost.

ALTERNATIVES: MOTHERBOARD

For a microATX Core 2 Duo system, there were no other motherboard choices when we built this system. By the time this book reaches print, there will likely be numerous choices. Any microATX motherboard made by Intel or ASUS with a suitable feature set should work fine. For a microATX Socket AM2 Athlon 64 X2 system, choose any compatible ASUS motherboard based on an nVIDIA chipset.

We consider 2 GB of memory about right for any but budget or high-end configurations. That's 1 GB per processor, and our dual-core Intel Core 2 Duo is effectively two processors. Accordingly, we checked the price of 1 GB memory modules on the Crucial and Kingston web sites, intending to install a pair of 1 GB modules for better memory performance. Kingston happened to have a better price that day than Crucial, so we ordered two 1 GB PC2-5300 Kingston modules.

ALTERNATIVES: MEMORY

Any compatible name-brand memory modules. Memory from different companies can vary dramatically in quality and reliability. For 20 years, we've depended on memory from Kingston and Crucial, and have never had cause to regret that decision.

7.3.5. Video Adapter

Integrated video

The Intel D946GZIS motherboard includes excellent integrated Graphics Media Accelerator 3000 (GMA 3000) video. Although serious gamers sniff at the 3D graphics performance of GMA 3000 video, it is more than sufficient for undemanding 3D video applications such as the Windows Vista Aero Glass effects and light gaming. Integrated video adds little to the heat burden inside the SFF case, and is perfectly adequate for anything we plan to do with this system.

ALTERNATIVES: VIDEO ADAPTER

The D946GZIS motherboard provides a standard x16 PCI Express slot for a graphics card, so it's possible to add some serious 3D graphics horsepower to the SFF PC, if you are so inclined. If you choose to install a standalone video adapter, keep in mind two limitations of the NSK1300.

  • The small volume of any SFF case, including the NSK1300, makes it difficult to cool a hot-running video adapter, so installing a high-end video card is likely to cause cooling problems.

  • The 300W power supply of the NSK1300 puts an upper limit on the current available to the video adapter. Make sure any video adapter you install in the NSK1300 case is within the ability of the 300W power supply to support. If you intend to install a high-end gaming video adapter, choose a case that provides a power supply capable of delivering the current that video adapter requires.

Note that the D946GZIS provides only analog VGA video output. If you need DVI digital output, install an inexpensive PCIe video adapter that provides DVI output.

7.3.6. Hard Disk Drive

Seagate ST3250620AS Barracuda 7200.10 (250GB) (http://www.seagate.com)

An SFF PC needs a quiet, cool-running hard drive with mainstream performance. We've come to depend on Seagate Barracuda SATA drives based on years of good experiences with them. We chose a 250 GB 7200.10 model with 16 MB of cache for this system because it happened to be on sale at the time for $70. The similar ST3250820AS model with half as much cache sold for the same price. We could have saved $18 by using an 80 GB 7200.9 model, but three times the storage space for $18 more was too good a deal to pass up.

ALTERNATIVES: HARD DISK DRIVE

Any Seagate Barracuda 7200.9 or 7200.10 SATA drive, in any capacity. Choose a model with 16 MB of cache rather than 8 MB if the price difference is small.

7.3.7. Optical Drive

NEC ND-3550A DVD writer (http://www.necam.com)

With DVD writers selling for $35 or so, there's no point to installing a less capable optical drive. We chose the NEC ND-3550A DVD writer for the SFF PC, but any similar model from BenQ, Lite-On, NEC, Pioneer, or Plextor would also be a good choice, as long as it is not too deep for the case. The Antec NSK1300 case has a universal optical drive door that hides the front bezel of the optical drive, so there's no need to match the color of the optical drive to the case.

7.3.8. External Peripherals

We're going to wimp out here. Rather than make specific recommendations for keyboard, mouse, speakers, display, and other external peripherals, we'll refer you to the other project system chapters in this book and to the web site (http://www.hardwareguys.com).

It's not that we don't want to provide a list of recommended external peripherals for the SFF PC. It's that we can't, because an SFF PC can be built as anything from a $500 appliance system to a $1,000 mainstream system to an $1,800 gaming system. Accordingly, all we can recommend is that you choose external peripherals according to your budget and the purpose of the system.

Table 7-2 summarizes our component choices for the core SFF PC system.

Table 7-2. Bill of materials for SFF PC

Component

Product

Case

Antec NSK1300 microATX case (300W power supply included)

Motherboard

Intel D946GZIS

Processor

Intel Core 2 Duo E6300

CPU Cooler

(Bundled with retail-boxed CPU)

Memory

Kingston PC2-5300 DDR2-SDRAM (2 GB kit)

Video adapter

(Integrated)

Hard disk drive

Seagate ST3250620AS Barracuda 7200.10 (250GB)

Optical drive

NEC ND-3550A DVD writer


Section 7.4. Building the SFF PC

7.4. Building the SFF PC

Figure 7-3 shows the major internal components of the SFF PC. The Antec NSK1300 case is flanked on the left by the Seagate 7200.10 Barracuda SATA hard drive and the NEC ND-3550A DVD writer, and on the right by the Intel D946GZIS motherboard, with the Crucial DDR2 memory, the Intel Core 2 Duo processor, and the Intel CPU cooler already installed. Yep, that's everything. Not many components, but that's all it takes to build an SFF PC with some serious power.

Figure 7-3. SFF PC components, awaiting construction

Before you proceed, make sure you have everything you need. Open each box and verify the contents against the packing list. Make sure all driver discs, cables, screws, and other small components are present.

7.4.1. Preparing the Case

The first step in building any system is always to make sure that the power supply is set to the correct input voltage. Some power supplies, including the unit supplied with the Antec NSK1300, set themselves automatically. Others must be set manually using a slide switch to select the proper input voltage. If your case uses such a power supply, make sure that it's set to the proper input voltage before you proceed.

Warning: If you connect a PC set for 230V to a 115V receptacle, nothing is damaged. The PC components receive half the voltage they require, and the system won't boot. But if you connect a power supply set for 115V to a 230V receptacle, the PC components receive twice the voltage they're designed to use. If you power up the system, that overvoltage destroys the system instantly in clouds of smoke and showers of sparks.

Order Is Important

When you build a standard PC, the exact component installation sequence usually doesn't matter much. With an SFF PC, that's often not true. The small case means there's little room to work. One component may be inaccessible after you install another component. If you forget to connect a cable to the motherboard, for example, you may later have to partially disassemble the system to get to it.

The Antec NSK1300 case is much better than most SFF cases in this respect. The top panel and both side panels are removable, which means the interior is quite accessible, albeit a bit cramped. The disadvantage of the NSK1300 is that it doesn't include custom-length cables preinstalled and routed, as is the case with most "bare-bones" SFF systems. That means you need to take particular care to route and dress the cables appropriately to avoid restricting air flow or fouling a fan.

To begin preparing the Antec NSK1300 case, remove the thumbscrew that secures the top panel, as shown in Figure 7-4.

Figure 7-4. Remove the thumbscrew that secures the top panel

After you remove the thumbscrew, slide the top panel back slightly until the hooks that secure it disengage, and then lift the panel off, as shown in Figure 7-5.

Figure 7-5. Slide the top panel back slightly and lift it off

The side panels of the NSK1300 are secured by plastic latches at the rear center edges of the panels. To remove the side panels, press the plastic latch, as shown in Figure 7-6, to unlock the panel. Slide the panel slightly toward the front of the case and lift it off, as shown in Figure 7-7.

Figure 7-6. Squeeze the latch at the center rear of the side panel to release it

Figure 7-7. While squeezing the latch, slide the side panel forward slightly and then pull it away from the case

The Antec NSK1300 uses a swing-up removable drive bay that secures to the chassis using four posts on the drive bay that mate with corresponding notches in the chassis. To remove the drive bay, pivot the rear end upwards, as shown in Figure 7-8, until the two rear posts come free and then lift the drive bay straight up, sliding the front two posts out of the matching slots in the chassis.

Figure 7-8. Pivot the drive bay upward and lift it free of the chassis

With the drive bay removed, the inside of the case is visible. The brown cardboard box contains mounting screws and other hardware. The white box contains the Cyclone Blower, a supplementary cooling fan that mounts in place of a PCI expansion card.

Nearly every case we've used, including the Antec NSK1300, comes with a generic I/O template. Every motherboard comes with a custom I/O template designed to fit its rear I/O panel. The generic I/O template supplied with the case never seems to fit the I/O panel of the motherboard, so you need to remove the stock I/O template and replace it with the one supplied with the motherboard. To remove the generic I/O template, use a tool handle to press against its corners and edges, as shown in Figure 7-9, until it snaps out.

Figure 7-9. Remove the I/O template supplied with the case

Before you install the custom I/O template, compare it to the motherboard I/O panel to make sure the holes in the template correspond to the connectors on the motherboard. The inside of the template has several grounding tabs that project toward the inside of the case. We found by experience that because of the tight quarters inside the NSK1300 case, it is impossible to seat the Intel D946GZIS motherboard unless you first bend the grounding tab of the Ethernet port slightly upward. (We ended up doing this after the template was installed by using a long flat-blade screwdriver, but it's easier to do it before you install the template.)

Once you've done that, press the custom I/O template into place. Working from inside the case, align the bottom, right, and left edges of the I/O template with the matching case cutout. When the I/O template is positioned properly, begin on one corner and press gently along the edges to seat it in the cutout, as shown in Figure 7-10. It should snap into place, although getting it to seat properly sometimes requires several attempts. As you apply pressure from inside the case against the template, use your finger to apply offsetting pressure on the outside of the template to avoid bending it.

Figure 7-10. Snap the custom I/O template into place

Warning: Be careful not to bend the I/O template when you seat the template. The template holes need to line up with the external port connectors on the motherboard I/O panel. If the template is bent even slightly it may be difficult to seat the motherboard properly. Except, of course, for the grounding tab for the Ethernet port, which must be bent slightly upward to provide room to seat the motherboard.

See the Light

If you simply look at the motherboard, it's easy to miss one of the mounting holes in all the clutter. We generally hold the motherboard up to a light, which makes the mounting holes stand out distinctly.

If your case comes with preinstalled standoffs, make absolutely certain that each standoff matches a motherboard mounting hole. If you find one that doesn't, remove it. Leaving an "extra" standoff in place may cause a short circuit that could damage the motherboard and/or other components.

After you install the I/O template, place the motherboard atop the case, as shown in Figure 7-11, aligned and positioned as it will be when it is installed in the case. Look down through each motherboard mounting hole to locate the mounting positions on the base of the case. The goals are to make sure that there is a standoff installed that corresponds to each motherboard mounting hole, and that no extra standoffs are installed.

Figure 7-11. Look down through the motherboard mounting holes to verify standoff mounting positions

The Intel D946GZIS motherboard has eight mounting holes. The Antec NSK1300, like many cases, is shipped with several standoffs preinstalled. All six of the standoffs preinstalled in the NSK1300 corresponded with motherboard mounting holes, so we needed to install only two standoffs.

The Antec NSK1300 uses a mixture of standard brass standoffs and chrome-plated steel motherboard clips, shown in Figure 7-12. The top of each clip has a small, bent, protruding nipple that is small enough to pass through a motherboard mounting hole. Once the motherboard is dropped into place over these clips, sliding the motherboard slightly toward the back of the case causes the clips to clamp down on the top surface of the motherboard, securing it in place.

Figure 7-12. Insert a motherboard mounting clip in each position that corresponds to a motherboard mounting hole

As the NSK1300 is shipped, there are brass standoffs in two positions and motherboard clips in four positions. For the two remaining required standoffs, we decided to use motherboard clips. They appear to secure the motherboard quite well, and we decided two screws were sufficient to lock the motherboard into place against the clips. If you're uncomfortable depending on the clipsfor example, if this is to be a portable systemyou can replace the motherboard clips with standard brass standoffs, which are provided in the parts bag.

To install the clips, press gently on the sides of the clip and slide it into the mounting position. Make sure that the bent nipple on the clip faces the same direction as the nipples on the clips that are already installed. Robert was able to insert the clips using only finger pressure to compress them, but Barbara found it easier to compress the clips with needle-nose pliers. Whichever method you use, make sure each clip snaps securely into the motherboard tray.

Once you've installed all the standoffs and motherboard clips, do a final check to verify that (a) each motherboard mounting hole has a corresponding standoff or clip, and (b) that no standoffs or clips are installed that don't correspond to a motherboard mounting hole. If you've removed the power supply, you can, as a final check, hold the motherboard in position above the case and look down through each motherboard mounting hole to make sure there's a standoff installed below it.

7.4.2. Installing the Processor and Memory

Even for a full-size system, it's easier to install the processor and memory while the motherboard is outside the case. An SFF system has so little working room that it's almost mandatory to do so.

Warning: Each time you handle the processor, memory, or other static-sensitive components, first touch the power supply to ground yourself.
7.4.2.1. Installing the processor

To install the Core 2 Duo processor, place the motherboard on a flat surface. Lift the socket lever, as shown in Figure 7-13, until it swings past vertical and reaches the end of its travel.

Figure 7-13. Lift the socket lever to prepare the socket to receive the processor

With the socket lever open, the retention plate is unlatched and can be lifted upward, away from the socket, as shown in Figure 7-14. The retention plate has a black plastic cover that protects the delicate contacts inside the socket when no processor is installed. Snap this protective plastic cover off, as shown in Figure 7-15, and store it in a safe place. If you ever remove the processor from the motherboard, reinstall the cover to protect the socket until you install another processor.

Figure 7-14. Lift the retention plate away from the socket

Figure 7-15. Remove the protective plastic cover

Figure 7-16 shows the LGA775 socket prepared to receive the processor, with its delicate contacts exposed. The socket is easily damaged when it is in this state, so take care to avoid touching the contacts or dropping anything on the exposed socket. If the socket is damaged, the motherboard is scrap.

Figure 7-16. The socket prepared to receive the processor

The processor also has a plastic snap-on cover that protects its contacts when it is not installed in a motherboard. When you are ready to install the processor in its socket, remove the plastic cover, as shown in Figure 7-17. Handle the processor only by its edges, and make sure the contact surface of the processor does not touch anything except the socket.

Figure 7-17. Remove the protective plastic cover from the processor

Pin 1 is indicated on the processor by a small golden triangle and on the socket by a beveled corner, both visible at the lower-right corner of the socket in Figure 7-18. The processor also has two keying notches that correspond with two nubs in the socket, both of which are also visible in Figure 7-18.

Figure 7-18. Align the processor with the socket and drop it into place

Holding the processor only by its edges, align pin 1 of the processor with pin 1 of the socket and drop the processor into place, as shown in Figure 7-18. The processor should seat flush with the socket just from the force of gravity. If seating the processor requires pressure more than a very gentle nudge, something is misaligned. Remove the processor and verify that it is aligned properly and that the pattern of holes on the processor corresponds to the pattern of pins on the socket.

With the processor seated flush with the socket, lower the retention plate into place, as shown in Figure 7-19. Note the projecting lip on the retention plate and the corresponding cammed section of the socket lever. As you press the socket lever down to latch it in place, that cammed section engages the lip on the retention plate and presses it firmly into position.

Figure 7-19. Lower the retention plate into position

With the retention plate in its closed position, press down firmly on the socket lever and snap it into the latched position, as shown in Figure 7-20. Once the socket lever is latched, the processor is secured in the socket and protected by the metal framework of the socket body.

Figure 7-20. Close the socket lever and snap it into the latched position

7.4.2.2. Installing the CPU cooler

The Intel Core 2 Duo is a very cool-running processor, but it still consumes up to 65W of electrical power when it is running under heavy load. That power ends up as waste heat, which must be dissipated to prevent the processor from overheating. Intel supplies a decent CPU cooler with the retail-boxed Core 2 Duo processor, which is what we used.

Thermal Compound Is Required

The stock Intel CPU cooler comes with a preinstalled thermal pad on the base of the heatsink. As the processor heats up, that thermal pad melts, ensuring good thermal transfer between the processor and the heatsink base. If you use a different CPU cooler, one that does not include a thermal pad, make sure to apply thermal compound before you install the CPU cooler. Follow the instructions supplied with the thermal compound. (We use Antec Silver thermal compound, which is as good as anything and less expensive than many "premium" thermal compounds.)

Polish the CPU heat spreader to remove any foreign material. If there is no thermal pad installed on the heatsink base, polish it as well and apply thermal compound to the CPU heat spreader. Orient the CPU cooler above the processor, as shown in Figure 7-21. The cooler base has four posts that correspond to four mounting holes in the motherboard. Align those posts with the mounting holes. (It doesn't matter how you orient the CPU cooler, because the four motherboard mounting holes form a square. We generally orient the CPU cooler so that the fan power lead has as little slack as possible once it's connected to the motherboard fan power header pins.)

Figure 7-21. Align the CPU cooler over the processor

The CPU cooler is secured to the motherboard by four expanding posts that protrude through the motherboard. Align the posts with the motherboard mounting holes and then press down each post, as shown in Figure 7-22, until it snaps into the locked position.

Figure 7-22. Press down on all four locking posts to secure the CPU cooler

Intel recommends installing the CPU cooler after the motherboard is installed in the case, but we prefer to install the CPU cooler with the motherboard still outside the case. If you do the same, note that you can't install the CPU cooler if the motherboard is lying flat on a firm surface because the mounting posts must protrude through the bottom of the motherboard in order to lock into place. Barbara solved that problem simply by raising one edge of the motherboard as she snapped the locking posts into place.

The final step in installing the CPU cooler is to connect the fan power lead to the fan power header pins on the motherboard, as shown in Figure 7-23. If there's excessive slack in the CPU fan power cable, secure it to make sure it can't foul the CPU fan.

Figure 7-23. Connect the CPU fan cable to the CPU fan connector

Warning: If you remove the heatsink, you must replace the thermal compound or pad when you reinstall it. Before you reinstall, remove all remnants of the old thermal pad or compound. That can be difficult, particularly for a thermal pad, which can be very tenacious. We use an ordinary hair dryer to warm the thermal material enough to make it easy to remove. Sometimes the best way is to warm up the compound and rub it off with your thumb. (Use rubber gloves or a plastic bag to keep the gunk off your skin.) To protect the processor, keep it in the socket while you're removing remnants of the thermal compound or pad.Alternatively, one of our technical reviewers says that rubbing gently with #0000 steel wool works wonders in removing the gunk, and is fine enough not to damage the surface. Another of our technical reviewers tells us that he uses Goof-Off or isopropyl alcohol to remove the remnants of the thermal goop or thermal pad. Whatever works for you is fine. Just make sure to remove the old thermal compound and replace it with new compound each time you remove and reinstall the processor.When we replace a heatsink, we use Antec Silver Thermal Compound, which is widely available, inexpensive, and works well. Don't pay extra for "premium" brand names like Arctic Silver. They cost more than the Antec product and our testing shows little or no difference in cooling efficiency.

As Simple As 3, 2, 1

Readers with sharp eyes may have noticed the edge of a memory module visible at the upper-left corner of Figure 7-23, which is odd because we haven't installed the memory yet. That's because the first images we shot of connecting the CPU fan power cable were blurred, so we came back and reshot this one later and forgot to remove the memory module when we reshot the image. Oh, well.

7.4.2.3. Installing memory

Installing memory in the Intel D946GZIS motherboard is straightforward. We have two memory modules to be installed, and two memory slots available. Pivot the white plastic locking tabs on both sides of both DIMM sockets outward to prepare the slots to receive DIMMs. Orient each DIMM with the notch in the contact area of the DIMM aligned with the raised plastic tab in slot and slide the DIMM into place, as shown in Figure 7-24.

Figure 7-24. Orient the DIMM with the notch aligned properly with the socket

With the DIMM properly aligned with the slot and oriented vertically relative to the slot, use both thumbs to press down on the DIMM until it snaps into place. The locking tabs should automatically pivot back up into the locked position, as shown in Figure 7-25, when the DIMM snaps into place. If they don't, close them manually to lock the DIMM into the socket.

Figure 7-25. Seat the DIMM by pressing firmly until it snaps into place

With the processor and memory installed, you're almost ready to install the motherboard in the case. Before you do that, check the motherboard documentation to determine if any configuration jumpers need to be set. The Intel D946GZIS has only one jumper, which sets operating mode. On our motherboard, that jumper was set correctly by default, so we proceeded to the next step.

7.4.3. Installing the Motherboard

Installing the motherboard is the most time-consuming step in building the system because there are so many cables to connect. It's important to get all of them connected right, so take your time and verify each connection before and after you make it.

Warning: Before you install the motherboard, tie off the front-panel and other cables to keep them out of the way. The limited working space inside an SFF case makes it easy to lose track of a cable and later find that it's caught underneath the mounted motherboard and can't be pulled free because the connector jams it in place.
7.4.3.1. Seating and securing the motherboard

Before you do anything else, locate the ATX12V power cable from the power supply and connect it to the motherboard. We forgot to do this before we installed the motherboard in the NSK1300 case. Doing it afterward was a royal pain in the petunia because there was almost no clearance. Figure 7-26 shows the ATX12V cable seated and latched (finally). Robert was able to guide it into position with his needle-nose pliers and press the cable into the connector with a flat-blade screwdriver. Next time, he'll remember to seat the ATX12V cable before he installs the motherboard.

Figure 7-26. The ATX12V cable seated in its connector

Once you've connected the ATX12V cable, slide the motherboard into the case, as shown in Figure 7-27, carefully aligning the back-panel I/O connectors with the corresponding holes in the I/O template. As the motherboard I/O connectors seat, the protruding nipples on the motherboard clips should grasp the motherboard. Once the motherboard is in position, examine the rear I/O panel carefully to make sure that none of the grounding tabs are protruding into ports.

Figure 7-27. Slide the motherboard into position

SOMETIMES YOU NEED A SHOEHORN

As we mentioned earlier in this chapter, we had to bend the grounding tab for the Ethernet port slightly upward to allow the motherboard to seat. There is very little working room inside an SFF case, so you may have to take similar steps if you use a different motherboard. The important thing to remember is to check the rear I/O panel before you start driving screws to secure the motherboard. If a port is fouled, pull the motherboard out, fix the problem with the I/O template, and slide the motherboard back into position.

Keep pressure on the motherboard to align the two brass standoffs with the corresponding mounting holes, and drive screws into those two standoffs to secure the motherboard in place, as shown in Figure 7-28. After you secure the motherboard, verify once again that the back-panel I/O connectors mate properly with the I/O template and that the motherboard clips are correctly positioned to secure the motherboard.

Figure 7-28. Secure the motherboard by driving screws into the brass standoffs

7.4.3.2. Connecting motherboard cables

The final steps required to install the motherboard are to connect the various signal, data, and power cables. It doesn't much matter in what order you connect these cables, but make sure to get all of them connected.

To begin, locate the main ATX power connector near the front edge of the motherboard. The Antec NSK1300 power supply has a dual-purpose main power cable connector that can be configured as a 20-pin or 24-pin connector. By default, the main ATX power connector is configured as a 24-pin connector, which is used by most recent motherboards. If you're using a motherboard that is socketed for the older 20-pin main ATX power connector, examine the Antec power cable connector. You'll find that it has two segments, one with 20 pins and one with 4 pins, that can be separated. If you're using a 20-pin motherboard, remove the 4-pin segment from the main body of the connector.

Align the main ATX power cable connector as shown in Figure 7-29. Press it firmly into place until the latch on the cable connector snaps into place over the lip on the motherboard jack.

Figure 7-29. Align the main ATX power connector and press it firmly into place

The ATA (IDE) motherboard interface connector is located on the front edge of the motherboard, adjacent to the main ATX power connector. Antec includes a round ATA cable with the NSK1300 case. Ordinarily, we prefer standard flat ATA ribbon cables to the round versions, but for a small form factor system the round cables are unarguably better at fitting in the cramped internal spaces and not blocking air flow.

Align the ATA cable with the motherboard connector, as shown in Figure 7-30, and press the connector firmly until it seats completely. Make certain the connectors are oriented properly. Most ATA cables and sockets are keyed in either or both of two ways: with a missing pin in the socket and a blocked hole in the cable connector, or with a cutout on the socket and a corresponding nub on the cable connector. The ATA cable supplied by Antec is keyed in both ways, as is the socket on the Intel motherboard. If you use a different motherboard or cable, be aware that not all cables or motherboard sockets are keyed. If that's true of your components, make sure pin 1 on the cable is aligned with pin 1 on the socket before you seat the cable.

Figure 7-30. Align the ATA cable with the motherboard socket and press firmly to seat it

The next step is to connect the front-panel switch and indicator cables, as shown in Figure 7-31. The power switch and reset switch connectors are unpolarized, and so may be connected in either orientation, as long as you connect the cable to the correct pair of pins. The HDD activity LED cable is polarized, and should be connected with correct polarity. (If you get it wrong, though, the worst that happens is that the LED fails to illuminate.)

Figure 7-31. Connect the front-panel switch and indicator cables

Each of the front-panel switch and indicator cables is labeled descriptively, e.g., "Power," "Reset," and "HDD LED." Match those descriptions with the front panel connector pins on the motherboard to make sure you connect the correct cable to the appropriate pins. The motherboard header pins are color-coded. Figure 7-32 shows the pin assignments for the Hard Drive Activity LED (yellow), Reset Switch (purple), Power LED (green), and Power Switch (red) connectors.

Figure 7-32. D946GZIS front-panel switch and indicator pin assignments (graphic courtesy of Intel Corporation)

The Intel D946GZIS provides four Serial ATA interfaces, which are located in the extreme front left corner of the motherboard, adjacent to the front-panel connectors. Align the S-ATA data cable with the first S-ATA interface, and press it into place until it locks, as shown in Figure 7-33.

Figure 7-33. Insert the S-ATA data cable

Intel begins numbering the S-ATA interfaces at 0. Some motherboards number the S-ATA interfaces beginning with 1. In either case, connect the S-ATA data cable to the lowest-numbered S-ATA interface connector on the motherboard.

The next step is to connect the front-panel USB ports to the motherboard. Most recent Antec cases provide a monolithic 10-pin (5x2) dual-port USB connector that matches the standard Intel USB pin assignments. The NSK1300 instead provides two single-port 5-pin (5x1) USB connectors on the dual front-panel USB cables. We decided to connect both of these cables to one of the dual-port motherboard USB connectors.

The Intel connector block is keyed with a missing pin on one end. The Antec cable connectors have all five pins open, which means it's possible to connect the cable backward. To avoid doing so, note which end of the motherboard connector has a missing pin. Connect the Antec cable with the two black ground wires toward that missing pin (toward the front of the case) as shown in Figure 7-34. If your case uses front-panel USB cables with individual connectors for each wire, refer to the pin assignment shown in Figure 7-35 to get those individual wires connected correctly.

Figure 7-34. Connect the front-panel USB cables to a motherboard USB interface

Figure 7-35. D946GZIS front-panel USB pin assignments (graphic courtesy of Intel Corporation)

The final step in installing the motherboard is to connect the front-panel audio cable to the audio header pins, which are located at the left rear of the motherboard, behind the expansion slots. The NSK1300 case provides a monolithic front-panel audio cable that is keyed with a blocked hole that corresponds with a missing pin on the motherboard connector. Align the cable connector as shown in Figure 7-36, and press firmly to seat it.

Figure 7-36. Connect the front-panel audio cable to the front-panel audio connector pins

NEATNESS COUNTS

In addition to the monolithic connector block, the Antec front-panel audio cable provides individual wires for use with motherboards that don't use the Intel-standard audio connector. If you don't need these individual wires for your motherboard, we recommend taping them off along the body of the cable. Otherwise, they simply flop around loose in the close vicinity of the expansion slots. The wires are quite thin, and if they were left loose one might easily foul an expansion slot.

7.4.4. Installing the Low-Speed Cyclone Blower (Optional)

Antec bundles the Low-Speed Cyclone Blower with the NSK1300 case. ("Low-Speed Cyclone" sounds like an oxymoron to us, but there it is...) The Cyclone Blower occupies an expansion slot, exhausting warm air through the slot cover. It uses a low-speed fan that is so quiet it is difficult to hear it running even with your ear right up against the unit.

Installing the Cyclone Blower is optional. Antec provides it for configurations that require more cooling than the power supply fan can provide. We decided not to install it, because our final system configuration uses a low-current processor and integrated video and we wanted to see how well the system was cooled without the extra ventilation. If you decide to install the Cyclone Blower, Antec recommends the following placement:

  • If no video card is installed, install the Cyclone Blower in the first slot (the slot that would otherwise be occupied by the video card).

  • If a video card is installed but no other expansion card is installed, install the Cyclone Blower in the third slot, leaving one slot open between the video card and the Cyclone Blower.

  • If a video card and one other expansion card are installed, install the Cyclone Blower in the third slot and the other expansion card in the fourth (last) slot.

  • If a video card and two other expansion cards are installed, install the Cyclone Blower in the second slot, adjacent to the video card, and install the two other expansion cards in the third and fourth slots.

To install the Cyclone Blower, use the same procedure you would use to install an expansion card. Remove the two screws that secure the expansion slot cover bracket and the four screws that secure the four expansion slot covers and then pull the expansion slot cover bracket free. Remove the slot cover for the slot you select, and slide the Cyclone Blower into place. Reinstall the expansion slot cover bracket, and connect power to the Cyclone Blower.

7.4.5. Installing Drives

The Antec NSK1300 has one external 5.25" drive bay and three internal 3.5" drive bays. The external bay is for an optical drive, and the three internal 3.5" bays can each hold one hard drive.

To install the optical drive, align it with the guide slots inside the bay and slide it into place, as shown in Figure 7-37. If you are using the universal drive cover, slide the drive into the bay until the drive bezel is flush with the front of the drive bay. This seats the drive deeply enough to provide clearance for the "flapper" cover of the universal drive cover. If you are mounting the optical drive normally, with its front bezel flush with the front bezel of the case, seat the drive only until it protrudes half an inch or so beyond the face of the drive bay.

Figure 7-37. Slide the optical drive into the drive bay

Align the drive screw holes with those in the drive bay. If you are using the universal drive cover, use the rear set of screw holes. If you want to mount the optical drive bezel flush with the front case bezel, use the front set of screw holes. Once you have the screw holes aligned, drive four screws to secure the drive, as shown in Figure 7-38. Insert two screws on each side of the drive, front and back. It doesn't matter if you use the top or bottom set of screw holes. We generally mix them up, using the front bottom screw holes and the rear top ones.

Figure 7-38. Secure the optical drive to the drive bay, using four screws

After you secure the optical drive, mount the hard drive. The Antec NSK1300 provides three hard drive bays, one horizontal underneath the optical drive bay, and one vertical on either side of it. We're installing only one hard drive in this system, so we took Antec's advice and mounted it in the horizontal hard drive bay.

To mount the hard drive, place the drive bay upside down on your work surface. Slide the hard driveagain, upside down, and with the drive power and data connectors toward the back (open) side of the bayinto the drive bay and align the screw holes in the bay and drive. Locate four of the special hard drive mounting screws with black rubber grommets, and use them to secure the hard drive to the bay, as shown in Figure 7-39.

Figure 7-39. Secure the hard drive to the drive bay, using four screws

The final assembly step is to reinsert the drive bay in the chassis and connect the drive cables. To begin, locate the four cables you'll need to connect:

  • Hard drive power cable

  • Hard drive data cable

  • Optical drive power cable

  • Optical drive data cable

Pull these cables toward the upper rear of the system, near the power supply, and leave them dangling outside the case. The goal is to make sure the cables are accessible once you've reinstalled the drive bay. Slide the drive bay into the chassis, as shown in Figure 7-40, but don't seat it completely. Instead, leave it propped slightly open.

Figure 7-40. Slide the drive bay into the chassis

Connect the S-ATA data cable to the hard drive first, as shown in Figure 7-41. That cable has plenty of slack, but the drive connector will soon be obstructed by the optical drive cables, so we want to get it connected first. Connect the optical drive ATA data cable next, as shown in Figure 7-42, and then the optical drive power cable, as shown in Figure 7-43.

Figure 7-41. Connect the S-ATA data cable

Figure 7-42. Connect the optical drive ATA data cable

Figure 7-43. Connect power to the optical drive

The last cable is also the toughest. The S-ATA power cable has almost no slack to work with. To get it connected, first examine the back of the hard drive to determine the orientation of the short segment of the S-ATA power connector key. (With our drive, it was downward and to the right.) Do the same for the S-ATA power cable, and remember the relative orientations, or paint a stripe on both connectors with a Wite-out pen.

Pivot the drive bay assembly downward but not fully into place, until there is enough slack in the S-ATA power cable to reach the drive connector. Orient the cable connector key properly relative to the drive connector key and press the cable connector straight in until it seats, as shown in Figure 7-44.

Figure 7-44. Connect the S-ATA power cable to the hard drive

With all four drive cables connected, seat the drive bay completely, as shown in Figure 7-45. Make sure that all four of the support pins are fully seated in the corresponding notches in the chassis frame, and slide the drive bay into position. Make sure that the drive bay is level and flush with the top of the chassis frame.

Figure 7-45. Seat the drive bay completely

7.4.6. Final Assembly Steps

The NSK1300 case doesn't use a traditional power LED. As a power indicator, it instead uses two blue LEDs that softly illuminate the front panel. These LEDs are powered directly by the power supply rather than from the motherboard Power LED connector. To enable them, locate the Molex connector with a white and a blue wire and connect it to a Molex power supply cable, as shown in Figure 7-46.

Figure 7-46. Connect the front-panel LED power cable

Before you reinstall the side and top panels, we highly recommend putting a warning label on the top of the drive bay assembly, as shown in Figure 7-47. We learned this lesson by hard experience with the Aria SFF system we built for the first edition of this book.

Figure 7-47. Label the top of the drive bay as a warning to yourself and others

A year or so after we built that system, we moved it to our workbench, intending to swap video adapters. We removed the top panel and side panels and lifted the drive bay assembly, intending to remove it. We heard something snap, and realized an instant too late what we'd done. With a sinking feeling, we examined the rear of the drives, hoping that what we'd heard snap was the S-ATA power cable ($50 for a power supply replacement) rather than the S-ATA power connector on the hard drive ($150 to replace the drive). Of course, it was the drive that was damaged, so we learned an expensive lesson: put a warning label on the drive bay or pay the price.

Congratulations! You're almost finished building the system. About all that remains is to dress the cables, configure BIOS Setup, and reinstall the top and side panels.

It's very difficult to dress the cables in an SFF system because there's so little room to work. Do the best you can, bundling and tying off excess cable lengths, tucking things into various nooks and crannies, and so on. The most important thing is to make sure that none of the cables can foul the CPU cooler fan. Once you have the cables dressed, take a few minutes to double-check everything one last time before you apply power to the system. Use the following checklist:

  • No loose tools or screws (shake the case gently)

  • Heatsink/fan unit properly mounted; CPU fan connected

  • Memory modules fully seated and latched

  • Front-panel switch and indicator cables connected properly

  • Front-panel I/O cables connected properly

  • Hard drive data cable connected to drive and motherboard

  • Hard drive power cable connected

  • Optical drive data cable connected to drive and motherboard

  • Optical drive power cable connected

  • Optical drive audio cable(s) connected, if applicable

  • All drives secured to drive bay or chassis, as applicable

  • Expansion cards fully seated and secured to the chassis

  • Main ATX power cable and ATX12V power cable connected

  • All cables dressed and tucked, if you choose to do that

Once you're certain that all is as it should be, it's time for the smoke test. Leave the cover off for now. Connect the power cable to the wall receptacle (or, better still, a UPS) and then to the system unit. Press the main power button on the front of the case, and the system should start up. Check to make sure that the power supply fan and CPU fan are spinning. You should also hear the hard drive spin up and the happy beep that tells you the system is starting normally. At that point, everything should be working properly.

Premature Death

When you turn on the rear power switch, the system will come to life momentarily and then die. That's perfectly normal behavior. When the power supply receives power, it begins to start up. It quickly notices that the motherboard hasn't told it to start, and so it shuts down again. All you need to do is press the front-panel power switch and the system will start normally.

Turn off the system, disconnect the power cord, and take these final steps to prepare the system for use:

Set the BIOS Setup Configuration jumper to Configure mode

The BIOS Setup Configuration jumper block on the Intel D946GZIS motherboard is used to set the operation mode. This jumper is located near the center of the left edge of the motherboard, near the front edge of the expansion slots. By default, the jumper is in the 12 or "normal" position. Move the jumper block to the 23 or "configure" position.

Reconnect the power cord and restart the system

When the configuration jumper is set to Configure mode, starting the system automatically runs BIOS Setup and puts the system in maintenance mode. This step allows the motherboard to detect the type of processor installed and configure it automatically. When the BIOS Setup screen appears, choose the menu option to clear all BIOS data and then reset the system clock. Save your changes and exit. The system automatically shuts down. Disconnect the power cord.

Set the BIOS Setup Configuration jumper to Normal mode

With the power cord disconnected, move the BIOS Setup Configuration jumper block from 23 (Configure mode) to 12 (Normal mode).

Replace the side panel and reconnect power

With the jumper set for Normal operation, replace the side panel and reconnect the power cord. Your system is now completely assembled and ready for use.


Section 7.5. Final Words

7.5. Final Words

We built this system as a "pocket battleship"small, but with more power than many systems twice its size. Even the entry-level Core 2 Duo processor we used is faster than about 99% of the processors that were sold at the time we built this system. The integrated GMA 3000 graphics adapter provides excellent display quality and sufficient 3D graphics power for Windows Vista and many games. With 2 GB of memory, this system handles everything we throw at it with a whole bunch of plombs.

Still, there are some upgrades we'd consider making. None are essential, but all would be useful.

First, although the integrated graphics are more than good enough for most purposes, we could easily upgrade this system to support moderately intense 3D games by adding a midrange PCI Express video adapter. We'd choose a passively cooled video card (for low noise) that drew as little current as possible (to stay within the limits of the 300W NSK1300 power supply). If we installed a video card, we'd also install the Cyclone Blower to provide additional air flow.

Second, as we've begun working more with camcorder video, we've come to appreciate the presence of a FireWire port. The Intel D946GZIS does not provide FireWire, but it would be easy enough to install a $15 FireWire card. If we did that, we might also upgrade the hard drive from 250 GB to 500 or 750 GB to provide more space for editing video footage.

Advice from Jim Cooley

I have had so much trouble installing drivers for cheap no-name FireWire cards that I now use Adaptec FireWire cards exclusively. They cost more, but the savings in time and frustration is worth it.

Third, cooling. Like most SFF systems, this one runs 10°C to 15°C warmer than a typical desktop system with similar components. The stock Intel CPU cooler is reasonably efficient and quiet. At idle, it runs at 1,860 RPM. At that speed, although it is the loudest system component, it is still nearly inaudible. Under load, the CPU temperature increases, as does the CPU cooler fan speed. Under heavy load, the fan runs as fast as 3,360 RPM, which is fast enough to produce a noticeable whine.

One possible solution might be to install a premium third-party CPU cooler, such as a Thermalright or Zalman unit. Either of those might reduce the CPU temperature by as much as 5°C and would also be quieter than the stock Intel CPU cooler. The problem is that these third-party CPU coolers are typically quite large. As Figure 7-48 shows, there is very little room in the NSK1300 case for an oversize CPU cooler.

Figure 7-48. Clearance between the top of the CPU cooler and the bottom of the power supply

Antec provides another possible solution. The NSK1300 includes a bracket that allows you to mount a standard case fan on the side of the power supply. (Two of the four mounting holes are visible at the right-front edge of the power supply in Figure 7-48, with a third partially visible at the rear.) Substituting a large, quiet case fan for the stock CPU fan allows you to move lots of air at a relatively low fan speed, which reduces the noise level and improves cooling.

With or without these upgrades, we think the SFF PC is an excellent choice if you need a compact system that can fit just about anywhere. It's attractive, fast, reasonably quiet, and provides the same level of functionality as a typical mini-tower desktop system. It's an ideal system for a dorm room, the kids' bedroom, or as a secondary system. For that matter, many people would find it ideal as a primary system. With two PCI and one PCIe expansion slots as well as a video card slot, this system could easily be upgraded to function as a media center system. Finally, its compactness and portability make it a good "luggable" system for times when a notebook just isn't enough computer.

More Info

For updated component recommendations, commentary, and other new material, visit http://www.hardwareguys.com/guides/sff-pc.html.


Chapter 8. Building a Budget PC

Inexpensive doesn't have to mean cheap. The myth persists that you can't save money building your own PC, particularly a budget system. In fact, it's easy to match the price of a mass-market commercial system with a home-built system that uses higher-quality components. Of course, you could instead match the quality level of a mass-market commercial system by buying the cheapest components available and save a few bucks by doing so, but we don't recommend doing that. We think there are good reasons to build inexpensive systems, but no reason at all to build cheap systems.

We define a budget PC as one that seeks the maximum bang for the minimum buck, consonant with good component quality, reasonable performance, and high reliability. A budget PC uses good-quality components throughout, but those components fall on the low end of the performance range. They may even be a generation or two out of date. That's not necessarily a bad thing, though. Last year's models are are every bit as good this year as they were 12 months ago, and you can save a lot of money if you don't insist on the very latest components.

In pursuit of low prices, we don't hesitate to buy components that are discontinued and on sale. There are few disadvantages to doing that. Discontinued products nearly always carry the full manufacturer warranty, and function as well as they did when they were the latest and greatest products available. Judicious shopping can easily knock $50 or more off the total cost of a budget system. That's nothing to sneeze at when your total budget is only a few hundred dollars.

In this chapter, we'll design and build the perfect budget PC.


Section 8.1. Determining Functional Requirements

8.1. Determining Functional Requirements

We sat down to think through our own requirements for a budget PC. Here's the list of functional requirements we came up with:

Reliability

Reliability is important for a budget PC, just as it is for any computer. Although our limited budget may force us to make minor compromises in reliabilitysuch as using a lower-capacity power supply than we might otherwise choosewe'll still keep reliability firmly in mind as we select components. When we're forced to chooseas we inevitably will bebetween performance, capacity, or features versus reliability, we'll always favor the latter.

Adequate performance

In order to be useful, a budget PC must have adequate performance. Cheap consumer-grade PCs are often obsolete the day they're unpacked. Most of them have slow processors, insufficient memory, small 5,400 RPM hard drives, and very poor integrated video. That's simply not good enough. For our budget PC, we aim for a performance level equal to what defined a mainstream or performance PC a year to 18 months prior. That means we need a processor in the 3 GHz class, 512 MB of memory, a 7,200 RPM hard drive, and either fast integrated video or an inexpensive standalone video adapter.

Usable peripherals

Cheap consumer-grade PCs always scrimp on peripherals. A typical cheap mass-market system is bundled with a $2 mouse, a $3 keyboard, a $3 set of speakers, a $12 CD-ROM drive, and a $65 17" monitor, none of which are good for anything but the trash bin. We can do better than that, even within the constraints of our tight budget. We'll have to spend an extra $5 here and $20 there, but we'll end up with solid, usable peripherals that are likely to last the life of the system.

Vista compatibility

Vista compatibility is a moving target, and means different things to different people. Technically, many current consumer-grade systems are Vista-compatible in the sense that Vista is likely to load and run on them. But there are different levels of Vista, and cheap systems are likely to support only the basic Vista feature setno advanced graphics nor many of the other features that differentiate Vista from Windows XP. Although Vista hardware requirements had not yet been finalized when we designed this system, we made some assumptions based upon the best information then available with the goal of designing a budget system that would be able to run a full-feature Vista configuration with few or no hardware upgrades.

Noise level

There's little room in the budget for special quiet components, but that doesn't mean a budget PC must necessarily be noisy. We'll choose the quietest components available in our price range, always giving price and reliability high priority, but keeping noise level in mind as well. For example, two hard drives may be priced identically, but one may be literally twice as loud as the other. The same is true of other components such as cases, power supplies, and CPU coolers. By choosing carefully, we can build a budget PC that is much quieter than a similar but noisier configuration that costs the same.


Section 8.2. Hardware Design Criteria

8.2. Hardware Design Criteria

With the functional requirements determined, the next step was to establish design criteria for the budget PC hardware. Here are the relative priorities we assigned for our budget PC. Your priorities may of course differ.

DESIGN PRIORITIES

Price

Reliability

Size

Noise level

Expandability

Processor performance

Video performance

Disk capacity/performance

As you can see, this is a well-balanced system. Price and reliability are our top concerns, with everything else secondary. Here's the breakdown:

Price

Price is the 900-pound gorilla for a budget system. We set our target price for this system at $350 excluding external peripherals ($500 with keyboard, mouse, speakers, and display), and tried very hard to stay within that budget. That meant making many trade-offs and giving up some "nice to have" features, but we were able to configure a solid system at that price.

Reliability

Reliability is as important as price. A unreliable budget system is not worth having. To get that reliability, we used good brand-name components throughout.

Size

Size is unimportant, so we paid it no mind. As it turned out, the best case for our purposes was a standard mini-tower unit.

Noise level

We'd like a quiet system, but had no extra money for noise reduction. We decided to do what we could to choose the quietest possible inexpensive components, but otherwise to let the chips fall where they may.

Expandability

Expandability is unimportant, except in terms of making the system upgradable to be compatible with Vista. In essence, that meant making sure that at least one slot was available for memory expansion and that there was a video slot available in case we needed to install a standalone video adapter later. Otherwise, this system will never be expanded or upgraded.

Processor performance

Processor performance is moderately important for our budget PC, both initially and to ensure that the system will have enough horsepower to run Vista without requiring a processor upgrade. We'd love to use a dual-core processor in this system, but there's simply no room in the budget. We can afford to spend perhaps $85 on the processor, which limited our choices to the AMD Sempron or the Intel Celeron.

Video performance

2D video quality is important for our budget PC, because it determines display clarity and sharpness for browsers, office suites, and similar applications that this system will run. A budget PC is not intended for serious gaming, so 3D video performance is a non-issue except to the extent that we need adequate 3D performance to run at least the Vista Aero interface, and preferably with Vista's Glass effects. That means we'll need either an inexpensive standalone video adapter or the latest and fastest integrated video, such as Intel GMA 950 or nVIDIA 6100/6150. If we opt for integrated video, we'll make sure to choose a motherboard that provides a PCI Express x16 video slot, just in case we need to upgrade the video later.

Disk capacity/performance

Disk capacity and performance are relatively unimportant for the budget system. We won't use one of the small 5,400 RPM drives typically found in cheap consumer-grade systems, but we won't break the bank, either. The smallest mainstream 7,200 RPM drives available store 80 GB, which is sufficient for our budget system.


Section 8.3. Component Considerations

8.3. Component Considerations

With our design criteria in mind, we set out to choose the best components for the budget PC system. The following sections describe the components we chose, and why we chose them.

Your Mileage May Vary

Although we tested the configuration we used to build our own budget PC, we did not test permutations with the listed alternatives. Those alternatives are simply the components we would have chosen had our requirements been different. That said, we know of no reason the alternatives we list should not work perfectly.

8.3.1. Case and Power Supply

Antec SLK-1650B Mini-Tower Case (http://www.antec.com)

It's easy to spend too little on the case and power supply for a budget system. We've seen cases with 350W power supplies advertised for as little as $25, but we wouldn't even consider using such shoddy products. Cheap cases are bad enough. Things don't fit properly, and they're full of burrs and sharp edges that make working on them dangerous. But cheap power supplies are worse. It's simply not possible to build a reliable system using a cheap power supply.

Plan to spend at least $65 or so on a decent case and power supply for a budget system. (Most of that cost is in the power supply.) We looked at budget cases from several manufacturers, but as usual we found that Antec had the best product for the money. We chose the Antec SLK-1650B mini-tower case, which includes a good 350W ATX 2.0 power supply.

ALTERNATIVES: CASE/POWER SUPPLY

There are many competing cases in the same price range, but most of them include power supplies that are mediocre at best. Of those few inexpensive cases that include solid power supplies, our next choice after the Antec SLK/NSK models would be the Enermax Pandora CA3030.

We knew that Antec was about to discontinue the Solution Series SLK-1650B case in favor of the New Solution Series NSK4400 model, but we chose the SLK-1650B anyway. We think the SLK-1650B is a very attractive case, although the NSK4400 is prettier and includes a 380W power supply (versus 350W in the SLK-1650B). But we were able to find the SLK-1650B on sale for $62, about $10 less than the NSK4400. The 350W power supply in the SLK-1650B is perfectly adequate for the modest hardware configuration we planned to use, and the case features are otherwise suitable, so we decided to save the $10 for use elsewhere.

8.3.2. Motherboard

ASRock K8NF4G-SATA2 (http://www.asrock.com)

As always, the first decision to make in choosing a motherboard is which processor you intend to use. Our budget was $85 for the processor, which limited us to an AMD Sempron or Intel Celeron model. Dollar for dollar, the Sempron outperforms the Celeron significantly, so we decided to buy the fastest Sempron we could find for $85. That meant we needed a Socket 754 motherboard.

ALTERNATIVES: MOTHERBOARD

If you build a Celeron system, any Intel or ASUS Socket 775 motherboard with integrated GMA 950 graphics. In Socket 939, any of the following GeForce 6100 motherboards: ASRock 939NF4G-SATA2; ASUS A8N-VM; EPoX EP-9GF6100-M; Gigabyte GA-K8N51GMF-9; MSI K8NGM2-L (6100), -FID (6150), or -NBP (6150). GeForce 6150 graphics should be slightly faster than GeForce 6100 graphics, but testing shows no real difference. The 6150-based motherboards typically cost $10 to $15 more than similar 6100-based models, so we recommend choosing one of the latter.

Although AMD has de-emphasized Socket 754 in favor of Socket 939 and the new Socket AM-2, there were still many Socket 754 motherboards to choose among. Our requirement for integrated video fast enough to support Vista narrowed our choices down to motherboards that provided nVIDIA 6100 or 6150 integrated video. Among those, the ASRock K8NF4G-SATA2 was the standout choice.

ASRock is the value brand of ASUS, whose motherboards we've used for years and come to depend on. We had no experience with ASRock products, so we did a great deal of research before deciding to use this motherboard. We found that ASRock products were generally well thought of among their users, and that relatively few problems had been reported. Based on our confidence in ASUS, we decided to give the ASRock board a try. (Our subsequent torture-testing on three samples proved the ASRock board was indeed very stable.)

Although the ASRock K8NF4G-SATA2 motherboard lacks many of the features popular among performance enthusiasts and gamers, it has exactly the feature set we were looking for: nVIDIA GeForce 6100 integrated video with support for DX9 and Pixel Shader 3.0, a PCI Express x16 slot for future video upgrades, two SATA ports with RAID 0/1 support, good multichannel audio, an integrated 100BaseT network adapter, four USB 2.0 ports, etc. At about $60, it was a perfect fit for our needs and budget.

8.3.3. Processor

AMD Sempron 3100+ (http://www.amd.com)

With $85 allocated to the processor, our choices are limited to single-core "value" processors. Intel sells several Celeron models in that price range, but Celeron processors simply can't compete with comparably priced AMD Sempron processors. Semprons are noticeably faster than Celerons for most tasks, consume less power, and run cooler.

ALTERNATIVES: PROCESSOR

No good ones. The Sempron processor is really the only game in town for a budget system. If we could afford to spend $125 for the processor, we'd choose a low-end dual-core Intel Pentium D model, but doing that would take us well beyond our $350 base budget for this system.

AMD produces two classes of Sempron processors. The so-called K7 Semprons are really just rebadged Athlon XP processors. They use the obsolete Socket A (462), and are a poor choice for a new system (although they are excellent upgrade processors for older systems). Conversely, K8 Semprons are essentially Athlon 64 processors with smaller L2 caches, and are an excellent choice for a new budget system.

8.3.4. CPU Cooler

Spire SP792B12-U KestrelKing V (http://www.spirecoolers.com)

The Spire SP792B12-U KestrelKing V is the CPU cooler you want for this project. Unfortunately, it's not the CPU cooler we ended up using. We originally intended to order the retail-boxed version of the Sempron processor, which includes a bundled CPU cooler. But, while the bundled CPU cooler is reasonably effective at cooling the processor, there are third-party coolers available that are much quieter and cool more efficiently than the stock unit.

We'd used the Arctic Cooling ACS64U Silencer 64 Ultra successfully on other Sempron systems. When we checked prices, we found that the ACS64U with an OEM Sempron processor together cost only $4 more than a retail-boxed Sempron. We decided that better cooling and quieter operation was worth the $4 difference, so we ordered the ACS64U and thought nothing more about it.

Until, that is, it was time to build the system. As we installed the processor and cooler, we found another motherboard component was so close to the processor socket that the ACS64U wouldn't fit. Ordinarily, we'd simply have ordered a replacement heatsink, such as the Spire SP792B12-U KestrelKing V. But this time we were stuck. We desperately needed a Windows box to run some Windows-only software that was required for another book project. Deadlines were looming. It was Sunday afternoon, and our editor was expecting a chapter from us the next day.

We decided to do the best we could with what we had to work with. We were able to make the Arctic Cooling ACS64U fit, but only by doing some minor surgery on the motherboard. We ended up with a functional system, although there was no way to hide the surgery we'd done. We almost didn't bother to shoot images of the build, because Robert intended to order a new motherboard and rebuild the budget system from scratch. Then, as Robert started hacking on the motherboard, Barbara starting shooting images. When Robert asked why she was bothering to shoot images of a project we wouldn't be using in the book, Barbara replied that she thought we should show the project, warts and all. "Nothing wrong with letting people know that we sometimes screw up, too."

So we decided not to gloss over the ugly parts, and to show our readers what we really did. And it turned out well, too. The CPU temperature at idle is only 5°C over ambient, and the system runs cool even under heavy load. It's also very quiet, barely audible from less than a meter away in a quiet room. Even so, we don't recommend you do what we did. Building the system is much simpler if you use the Spire cooler.

8.3.5. Memory

Crucial PC3200 DDR-SDRAM (http://www.crucial.com)

Although many low-end mass-market systems are equipped with only 256 MB of RAM, that's insufficient even for a budget system. You can load and run Windows XP and one or two applications in 256 MB, but having so little memory noticeably hampers performance and reduces stability. Doubling the memory to 512 MB pays big dividends for little additional cost.

ALTERNATIVES: MEMORY

For a budget system, Kingston ValueRAM is the only other memory we'd consider using.

Unlike Intel processors, which really need dual-channel memory to provide their best performance, the AMD Sempron is quite happy with single-channel PC3200 DDR-SDRAM. Like the Athlon 64, the Sempron has a built-in memory controller, but the Sempron memory control is single-channel (versus dual-channel for the Athlon 64). That means there's no advantage to installing memory modules in pairs in a Sempron system. That's fortunate, because the motherboard we chose has only two memory slots, and we'd like to leave one of them open for future expansion.

So we decided to install one 512 MB PC3200 DDR-SDRAM DIMM in our budget system. If we install Windows Vista on this system later, we can fill the second memory slot with another 512 MB DIMMa total of 1 GBto accommodate the higher memory requirements of Vista.

Crucial memory is fast, reliable, inexpensive, and readily available. We've used Crucial memory for more than a decade in hundreds of systems, and it's never let us down. Accordingly, we chose one Crucial CT6464Z40B PC3200 512 MB DIMM for this system.

8.3.6. Video Adapter

Integrated nVIDIA GeForce 6100

The nVIDIA GeForce 6100 video integrated on the ASRock motherboard provides excellent 2D display quality and reasonably good 3D performance for casual gaming and similar tasks. The ASRock motherboard includes a PCI Express x16 video adapter slot, so if necessary we can upgrade the video down the road by installing an inexpensive PCIe video adapter. We don't expect that to be necessary, even if we decide at some point to replace Windows XP with Vista. But if it does turn out that Vista requires more horsepower than the GeForce 6100 video provides, even a $30 standalone video adapter is likely to be more than sufficient.

8.3.7. Hard Disk Drive

Seagate Barracuda 7200.9 SATA 80 GB (http://www.seagate.com)

Many inexpensive consumer-grade systems use 5,400 RPM hard drives, which are noticeably slower than mainstream 7,200 RPM units. If we were attempting to cut costs to the bone, we might have chosen something like a 20 GB Seagate ST320014A U Series X drive for $30 or so.

ALTERNATIVES: HARD DISK DRIVE

Various models from Maxtor, Samsung, and Western Digital. But our advice is to buy the Seagate Barracuda, in whatever capacity is appropriate for your needs. Our readers and tech reviewers have rarely had a Seagate drive fail, which can't be said for other brands.

We decided it was sensible to spend an extra $20 to get a 7,200 RPM 80 GB Seagate Barracuda 7200.9 SATA drive. That $20 is significant on a system with a base budget of $350, but the extra $20 buys us four times as much disk space and about twice the speed. It would be foolish to cripple system performance to save so little money.

8.3.8. Optical Drive

NEC ND-3550A DVD writer (http://www.nec.com)

DVD burners are so inexpensive nowadays that it seldom makes sense to install a less capable optical drive, even in a budget system. Among the many inexpensive DVD writers available, we chose the NEC ND-3550A for its combination of features, performance, reliability, and price.

ALTERNATIVES: OPTICAL DRIVE

The BenQ DW1650 is an excellent alternative to the NEC ND-3550A, comparable in features, performance, reliability, and price. The BenQ DQ60 is a similar model that sells for about the same price and adds support for DVD-RAM, but is somewhat slower than the DW1650 or ND-3550A.

If you don't need a DVD writer, install a $20 LITE-ON SOHD-16P9S DVD-ROM drive.

8.3.9. Keyboard and Mouse

Logitech Internet Pro Desktop (http://www.logitech.com)

Personal preference outweighs all else when choosing a keyboard and mouse. No one can choose the "best" keyboard and mouse for someone else. That said, we had to pick a "budget" keyboard and mouse for our budget PC. We wanted something in the sub-$20 range that included a decent keyboard and a reliable optical mouse. Our favorite among inexpensive keyboard/mouse combos is the Logitech Internet Pro Desktop, for which we paid $17. If you prefer a cordless keyboard/mouse combo, buy the Logitech Cordless Internet Pro Desktop, which costs $25 or so.

ADVICE FROM JIM COOLEY

Don't pass up thrift stores or garage sales. Quite often a brand-new keyboard which someone else doesn't like will be perfect for you and can be got for just a couple bucks.

ALTERNATIVES: KEYBOARD AND MOUSE

Many. Decide which features and layout you want, and then choose the appropriate Logitech model. If Logitech doesn't offer a model that meets your needs, look next to one of the many models sold by Microsoft.

8.3.10. Speakers

Logitech S-100 2.0 speaker system (http://www.logitech.com)

Even a budget PC needs a decent set of speakers, but we can realistically spend no more than $10 or $12 on speakers. In that price range, the Logitech S-100 2.0 speaker set has the best sound quality we've heard.

ALTERNATIVES: SPEAKERS

The Creative Labs SBS240 and the Altec-Lansing 120i 2.0 speaker sets are priced similarly to the Logitech S-100 set and have similar sound quality.

8.3.11. Display

NEC AS700 17" CRT (http://www.necmitsubishi.com) Samsung 793DF 17" CRT (http://www.samsung.com) ViewSonic E70 17" CRT (http://www.viewsonic.com)

As much as we'd love to have a 19" LCD display, budget limits us to a 17" CRT monitor. We allocated $120 to the display, and there are three standout choices in that price range. The NEC AS700, Samsung 793DF, and ViewSonic E70 all provide excellent display quality and (something rare with inexpensive displays) a 3-year warranty on the tube, parts, and labor. All three of these models are excellent. They're comparable in features and performance, so choose whichever is most easily available or least expensive.

ALTERNATIVES: DISPLAY

None we'd recommend, other than similar NEC, Samsung, and ViewSonic models.

Table 8-1 summarizes our component choices for the budget PC system.

Table 8-1. Bill of materials for budget PC

Component

Product

Case

Antec SLK1650B Mini-Tower Case

Power supply

Antec SmartPower 2.0 350W (bundled)

Motherboard

ASRock K8NF4G-SATA2

Processor

AMD Sempron 3100+

CPU cooler

Spire SP792B12-U KestrelKing V

Memory

Crucial PC3200 DDR-SDRAM (one 512 MB DIMM)

Video adapter

(Integrated nVIDIA GeForce 6100 IGP)

Hard disk drive

Seagate Barracuda 7200.9 SATA (80 GB)

Optical drive

NEC ND-3550A DVD writer

Keyboard and mouse

Logitech Internet Pro Desktop

Speakers

Logitech S-100 2.0 speaker set

Display

NEC AS700, Samsung 793DF, or ViewSonic E70 17" CRT monitor


Section 8.4. Building the Budget PC

8.4. Building the Budget PC

Figure 8-1 shows the components of the budget PC. The ASRock K8NF4G-SATA2 motherboard is at the left front, with the Seagate Barracuda 7200.9 hard drive and the NEC ND-3550A DVD writer front and center. At the right are the AMD Sempron 3100+ processor, the Crucial 512 MB DIMM, and the Arctic Cooling Silencer 64 Ultra CPU cooler, with the Antec SLK1650B case backing everything up.

Figure 8-1. Budget PC components, awaiting construction

Before you proceed, make sure you have everything you need. Open each box and verify the contents against the packing list. Once you're sure everything is present and accounted for, it's time to get started.

8.4.1. Preparing the Case

Antec must get a lot of support calls from people wondering why the SLK1650B rear fan isn't running. They stuck a warning label on the back of the power supply, shown in Figure 8-2, to tell people that the fan runs only when necessary. Unfortunately, they applied that label before they installed the power supply in the case, leaving part of the label clamped into place by the power supply. For the time being, just rip the label off. We'll remove the remnants of paper later.

Figure 8-2. Antec warning that the rear case fan runs only when needed

It's As Easy As 2, 1, 3

Although by necessity we describe building the system in a particular order, you don't need to follow that exact sequence when you build your own system. Some stepsfor example, installing the processor and memory before installing the motherboard in the caseshould be taken in the sequence we describe, because doing otherwise makes the task more difficult or risks damaging a component. But the exact sequence doesn't matter for most steps. As you build your system, it will be obvious when sequence matters.

The first step in building any system is always to make sure that the power supply is set to the correct input voltage. Some power supplies set themselves automatically. Others, including the Antec SmartPower 2.0 power supply in this system, must be set manually using a slide switch to select the proper input voltage, as shown in Figure 8-3. Bundled power supplies are nearly always set properly by default, but there are rare exceptions, so it's always a good idea to verify the input voltage setting before you proceed.

Figure 8-3. Verify that the power supply is set for the proper input voltage

AVOID FIREWORKS

If you connect a power supply set for 230V to a 115V receptacle, there's no harm done. The PC components receive half the voltage they require, and the system won't boot. But if you connect a power supply set for 115V to a 230V receptacle, the PC components receive twice the voltage they're designed to use. If you plug in the system, that overvoltage destroys the system instantly in clouds of smoke and showers of sparks.

After you've verified that the power supply is set correctly, remove the two thumbscrews that secure the top panel, as shown in Figure 8-4.

Figure 8-4. Remove the thumbscrews that secure the top panel

After you remove the thumbscrews, slide the top panel slightly toward the rear, as shown in Figure 8-5, and then lift it off, as shown in Figure 8-6.

Figure 8-5. Slide the top panel to the rear to release it

Figure 8-6. Lift the top panel off

With the top panel removed, tilt the left side panel down and remove it, as shown in Figure 8-7. Be careful not to damage the TAC shroud, which is the black plastic duct attached to the side panel. Remove the right side panel in the same manner. Put the top and side panels safely aside, where they won't be scratched while you are building the system.

Figure 8-7. Remove the side panels and set them safely aside

With the power supply exposed, it's time to remove the remnants of the Antec warning label we mentioned earlier, shown in Figure 8-8. To do so, remove the four screws that secure the power supply, and slide the power supply slightly forward. Remove the paper scraps, slide the power supply back into position, and reinsert the four screws to secure it.

Figure 8-8. Remove the remnants of the Antec warning label

Every case we've ever seen, including the Antec SLK1650B, comes with an I/O template. So does every motherboard. The generic I/O template supplied with the case never seems to fit the I/O panel of the motherboard, so you need to remove the stock I/O template and replace it with the one supplied with the motherboard.

I/O templates are made of thin metal that is easily bent. The best way to remove an I/O template without damaging it, as shown in Figure 8-9, is to use a tool handle to press gently against the panel from outside the case, while using your fingers to support the panel from inside the case. (We don't know why we care about damaging the generic I/O template supplied with the case. We have a stack of them sitting around, and have never needed one.)

Figure 8-9. Remove the I/O template supplied with the case

Most motherboards, including the ASRock K8NF4G-SATA2, come with a custom ATX I/O template designed to match the motherboard I/O panel. Before you install the custom I/O template, compare it to the motherboard I/O panel to make sure the holes in the template correspond to the connectors on the motherboard.

Once you've done that, press the custom I/O template into place. Working from inside the case, align the bottom, right, and left edges of the I/O template with the matching case cutout. When the I/O template is positioned properly, press gently along the edges to seat it in the cutout, as shown in Figure 8-10. It should snap into place, although getting it to seat properly sometimes requires several attempts. It's often helpful to press gently against the edge of the template with the handle of a screwdriver or nutdriver.

Figure 8-10. Snap the custom I/O template into place

Avoid Brute Force

Be careful not to bend the I/O template while seating it. The template holes need to line up with the external port connectors on the motherboard I/O panel. If the template is even slightly bent it may be difficult to seat the motherboard properly.

After you install the I/O template, carefully slide the motherboard into place, making sure that the back-panel connectors on the motherboard are firmly in contact with the corresponding holes on the I/O template. Compare the positions of the motherboard mounting holes with the standoff mounting positions in the case. One easy method is to place the motherboard in position and insert a felt-tip pen through each motherboard mounting hole to mark the corresponding standoff position beneath it.

Seeing the Light

If you simply look at the motherboard, it's easy to miss one of the mounting holes in all the clutter. We generally hold the motherboard up to a light, which makes the mounting holes stand out distinctly.

The ASRock K8NF4G-SATA2 motherboard has six mounting holes. Many cases are shipped with several standoffs already installed. The Antec SLK1650B has only one standoff preinstalled, which happens to be in one of the positions required by the ASRock K8NF4G-SATA2 motherboard. That means we needed to install standoffs in the five remaining positions required by the motherboard.

Install additional brass standoffs until each motherboard mounting hole has a corresponding standoff. Although you can screw in the standoffs using your fingers or needle-nose pliers, it's much easier and faster to use a 5mm nutdriver, as shown in Figure 8-11. Tighten the standoffs finger-tight, but do not overtighten them. It's easy to strip the threads by applying too much torque with a nutdriver.

Figure 8-11. Install a brass standoff in each mounting position

Once you've installed all the standoffs, do a final check to verify that (a) each motherboard mounting hole has a corresponding standoff, and (b) that no standoffs are installed that don't correspond to a motherboard mounting hole. As a final check, we usually hold the motherboard in position above the case, as shown in Figure 8-12, and look down through each motherboard mounting hole to make sure there's a standoff installed below it.

Figure 8-12. Verify that a standoff is installed for each motherboard mounting hole and that no extra standoffs are installed

Avoid Grounding Problems

If your case comes with preinstalled brass standoffs, make absolutely certain that each standoff matches a motherboard mounting hole. If you find one that doesn't, remove it. Leaving an "extra" standoff in place may cause a short circuit that may damage the motherboard and/or other components, or at least cause a boot failure.

Also, if you use a case that uses stamped raised areas in the motherboard tray instead of standoffs, be aware that some motherboards, including this ASRock model, may fail to boot in such cases because the raised areas ground parts of the motherboard that were not intended to be grounded.

Pen and Paper

Another method we've used to verify that all standoffs are properly installed is to place the motherboard flat on a large piece of paper and use a felt-tip pen to mark all motherboard mounting holes on the paper. We then line one of the marks up with the corresponding standoff and press down until the standoff punctures the paper. We do the same with a second standoff to align the paper, and then press the paper flat around each standoff. If we've installed the standoffs properly, every mark will be punctured, and there will be no punctures where there are no marks.

8.4.2. Preparing and Populating the Motherboard

It is always easier to prepare and populate the motherboardinstall the processor and memorywhile the motherboard is outside the case. In fact, you must do so with some systems, because installing the heatsink/fan unit requires access to both sides of the motherboard. Even if it is possible to populate the motherboard while it is installed in the case, we always recommend doing so with the motherboard outside the case and lying flat on the work surface. More than once, we've tried to save a few minutes by replacing the processor without removing the motherboard. Too often, the result has been bent pins and a destroyed processor.

Ground Yourself

Each time you handle the processor, memory, or other static-sensitive components, first touch the power supply to ground yourself.

8.4.2.1. Preparing the motherboard

We decided to install an inexpensive third-party CPU cooler, because we wanted a cooler that was quieter and more efficient than the stock AMD cooler. We'd used the $13 Arctic Cooling Silencer 64 Ultra, shown in Figure 8-13, on several earlier systems, and were pleased with its noise level and cooling performance. We also considered using the Arctic Cooling Silencer 64 UltraTC, which has a temperature-controlled variable-speed fan, but at $20 it was a bit much for our budget. So, without thinking much about it, we ordered an Arctic Cooling Silencer 64 Ultra for this system.

Figure 8-13. The Arctic Cooling Silencer 64 Ultra CPU cooler

That turned out to be a mistake, because fitting that CPU cooler to the motherboard required some minor surgery. Our first inclination was simply to order a different CPU cooler and let our readers remain ignorant of our mistake. But mistakes can be instructive, so we decided to go ahead and build the system with the Arctic Cooling Silencer 64 Ultra CPU cooler. It wasn't the first time we'd had to do minor surgery on a motherboard to fit a CPU cooler to it, and it won't be the last. But you can avoid all of the hassle simply by choosing a compatible CPU cooler, such as the Spire model we recommended earlier in this chapter.

The ASRock motherboard comes with a CPU cooler retaining bracket installed. Presumably, that bracket fits many standard CPU coolers, but it did not fit any of the AMD CPU coolers we had available, including one retail-boxed AMD cooler. The problem was the protruding vertical posts visible in Figure 8-14.

Figure 8-14. Lift the white plastic posts to release the standard bracket

Like many aftermarket CPU coolers, the Arctic Cooling Silencer 64 Ultra comes with its own retaining bracket. To install the Arctic Cooling bracket, you must first remove the bracket supplied with the ASRock motherboard. To do so, use a small flat-blade screwdriver to lift the four white posts, as shown in Figure 8-14. Lifting the posts releases the pressure on the plastic expansion clamps on the underside of the motherboard. After you lift all four posts, pull the retaining bracket straight up to remove it, as shown in Figure 8-15. If the bracket does not pull free easily, use the flat part of the screwdriver blade to press gently on the expansion clamps on the bottom side of the motherboard until they release.

Figure 8-15. Lift the retaining bracket straight up to remove it

With the standard retaining bracket removed, the four retaining bracket mounting holes are visible, as shown in Figure 8-16, at the four corners of the processor socket.

Figure 8-16. With the standard bracket removed, the four mounting holes are visible

The Arctic Cooling CPU cooler comes with a two-part custom retaining bracket made of heavy plastic. One part is installed on the top of the motherboard, where the heatsink can be clamped to it. The second part is installed beneath the motherboard, to distribute the weight of the heatsink over the processor socket area of the motherboard, rather than putting all of that weight on a couple of screw holes. To begin installing the bracket, remove the two screws that secure the two parts, as shown in Figure 8-17.

Figure 8-17. Disassemble the retaining bracket

Align the four posts on the bottom of the top portion of the retaining bracket with the corresponding holes in the motherboard, and drop the retaining bracket into place. Align the bottom portion of the retaining bracket under the motherboard, with the screw holes lining up with the corresponding holes in the motherboard. Partially drive one screw, as shown in Figure 8-18, to secure the two parts of the retaining bracket together loosely.

Figure 8-18. Partially drive one screw to loosely connect the two parts of the retaining bracket

Tilt the motherboard upward, as shown in Figure 8-19, and align the second screw hole in the bottom part of the retaining bracket. Drive the second screw in to align the two parts of the bracket completely, and then finish driving both screws to clamp the bracket tightly into position. Drive both screws in completely, but do not overtighten them. Finger-tight is sufficient.

Figure 8-19. Align the bottom portion of the bracket and drive a second screw to secure it

8.4.2.2. Installing the processor

To install the AMD Sempron processor, lift the arm of the ZIF (zero insertion force) socket, as shown in Figure 8-20, until it reaches vertical. With the arm vertical, there is no clamping force on the socket holes, which allows the processor to drop into place without requiring any pressure.

Figure 8-20. Lift the socket lever to prepare the socket to receive the processor

Pin 1 is indicated on the processor and socket by a small triangle. With the socket lever vertical, align pin 1 of the processor with pin 1 of the socket and drop the processor into place, as shown in Figure 8-21. The processor should seat flush with the socket just from the force of gravity, or at most with the slightest fingertip pressure. If the processor doesn't seat easily, something is misaligned. Remove the processor and verify that it is aligned properly and that the pattern of pins on the processor corresponds to the pattern of holes on the socket. Never apply any significant pressure to the processor. You'll bend one or more pins, destroying the processor.

Figure 8-21. Dropping the processor into place

With the processor in place and seated flush with the socket, press the lever arm down and snap it into place, as shown in Figure 8-22. You may have to press the lever arm slightly away from the socket to allow it to snap into a locked position. Closing the ZIF lever may cause the processor to lift slightly out of its socket. Once you are sure the processor is fully seated, it's safe to maintain gentle finger pressure on the processor if necessary to keep it fully seated as you close the ZIF lever.

Figure 8-22. Locking the processor into the socket

8.4.2.3. Installing the CPU cooler

Modern processors draw as much as 130W of power and must dissipate that power as heat over the surface of their heat spreaders, which are about the size of a large postage stamp. Without a good CPU cooler, also called a heatsink/fan (HSF) unit, the processor would immediately shut itself down to prevent damage from overheating. Our Sempron 3100+ has a design thermal power of only 62W, but even that relatively low wattage produces considerable waste heat.

Like all microATX motherboards, the ASRock K8NF4G-SATA2 crams in many components with very little clearance. The small size of microATX motherboards means they have to make a lot of compromises in where to position components, and it's often problematic to mount the CPU cooler, particularly if it's a third-party model.

In this case, the problem was severe, as shown in Figure 8-23. The clamping bracket on the CPU cooler intruded into the space used by the northbridge heatsink, visible at the lower right of the image as a finned aluminum assembly. Some CPU coolers use a cammed clamping lever on only one side of the cooler, with a simple metal bracket on the other side. The Arctic Cooling CPU cooler uses two clamping levers, one on either side of the cooler, so we couldn't simply reverse the cooler to avoid the problem.

Figure 8-23. The CPU cooler cannot be seated fully because the northbridge heatsink interferes

Make Sure Your CPU Cooler Is Good Enough

Using a proper CPU cooler is critical. Retail-boxed AMD and Intel processors include a CPU cooler that is adequate for the task. If you buy an OEM processor, it's up to you to install a CPU cooler that is sufficient to keep the processor operating within the design temperature range. Just because a CPU cooler fits the doesn't guarantee it's adequate to cool the processor properly. Faster processors consume more power and generate more heat. A CPU cooler designed and rated for a slower processor may be woefully inadequate for a faster version of that processor.

An Easier Way

The Spire SP792B12-U CPU cooler we recommend doesn't use cammed clamping levers. Instead, it uses a one-piece slotted metal bracket that fits over the three protruding nubs on the plastic base. You secure the cooler by pulling up on the metal bracket and pressing it toward the heatsink, where a protruding metal tab engages one of the slots in the bracket. If you use the Spire cooler or a similar model, you can avoid performing surgery on your motherboard.

Donning our kamikaze headband, we began by removing the northbridge heatsink. To do that, we used our needle-nose pliers to release the two expanding clamping posts that secure the northbridge heatsink to the motherboard, as shown in Figure 8-24.

Figure 8-24. Release the northbridge heatsink clamping posts

As you squeeze the posts gently, press them toward the motherboard until they pop free. At that point, the northbridge heatsink is still loosely connected to the northbridge chip by thermal compound. Pull up gently on the heatsink until it comes free. The northbridge chip is exposed, as shown in Figure 8-25, and there is now enough clearance to install the CPU cooler.

Figure 8-25. The exposed northbridge chip

Voiding Your Warranty

Obviously, removing the northbridge heatsink voids the warranty on the motherboard. We decided to take that chance, because we had the Arctic Cooling CPU cooler in hand and didn't want to wait for a replacement.

If you decide to modify your motherboard and end up breaking it, don't blame us. After any such modification, there's always a chance the motherboard will no longer work. If that happens, you're out of luck.

We're now ready to install the CPU cooler. To begin, use a paper towel or soft cloth to polish the CPU heat spreader, as shown in Figure 8-26. The goal is to remove any grease, grit, or other material that might prevent the heatsink from making intimate contact with the processor surface.

Figure 8-26. Polish the CPU heat spreader to remove any foreign material

After you polish the CPU, check the surface of the heatsink. If the heatsink base is bare, as is true of the Arctic Cooler model we used, that means it's intended to be used with thermal compound, sometimes called "thermal goop." In that case, also polish the heatsink base, as shown in Figure 8-27. Some heatsinks have a square or rectangular pad made of a phase-change medium, which is a fancy term for a material that melts as the CPU heats and resolidifies as the CPU cools. This liquid/solid cycle ensures that the processor die maintains good thermal contact with the heatsink. If your heatsink includes such a pad you needn't polish the base of the heatsink. (Heatsinks use either a thermal pad or thermal goop, not both.)

Figure 8-27. Polish the base of the CPU cooler heatsink

Don't Recycle Thermal Compound

If you ever remove the heatsink, you must replace the thermal compound or pad when you reinstall it. Before you reinstall, remove all remnants of the old thermal pad or compound. That can be difficult, particularly for a thermal pad, which can be very tenacious. We use an ordinary hair dryer to warm the thermal material enough to make it easy to remove. Sometimes the best way is to warm up the compound and rub it off with your thumb.

Alternatively, one of our technical reviewers says that rubbing gently with #0000 steel wool works wonders in removing the gunk, and is fine enough not to damage the surface. Another of our technical reviewers tells us that he uses Goof-Off or isopropyl alcohol to remove the remnants of the thermal goop or thermal pad. Whatever works for you is fine. Just make sure to remove the old thermal compound and replace it with new compound each time you remove and reinstall the processor.

When we replace a heatsink, we use Antec Silver Thermal Compound, which is widely available, inexpensive, and works well. Don't pay extra for "premium" brand names like Arctic Silver. They cost more than the Antec product and our testing shows little or no difference in cooling efficiency.

At this point during our actual build, we made a mistake. We used the syringe of thermal compound supplied with the Arctic Cooling CPU cooler (visible in Figure 8-13). That thermal compound turned out to be the most obnoxious we'd ever used. It was dry, excessively tacky, and refused to spread evenly. After making a mess with it, we ended up cleaning it all off, repolishing the CPU heat spreader and heatsink, and doing what we should have done originally. We went to our workbench, retrieved our tube of Antec Silver Thermal Compound (shown in Figure 8-28), and applied a small amount to the heat spreader.

Figure 8-28. Applying Antec Silver Thermal Compound

Use your finger to spread the thermal compound evenly over the surface of the heat spreader, as shown in Figure 8-29. (We've always found thermal compound to be harmless, but if you're nervous about it, you can use a talc-free rubber glove or plastic wrap between your finger and the compound.) The goal is to use just enough thermal compound to provide a thin, even layer over the entire surface of the heat spreader. Remove any excess compound before you proceed to the next step.

Figure 8-29. Spread the thermal compound evenly over the surface of the heat spreader

Orient the CPU cooler above the processor, as shown in Figure 8-30, keeping it as close to horizontal as possible. Slide the CPU cooler down into the retaining bracket. Press down gently and use a small circular motion to spread the thermal goop evenly over the surface of the processor.

Figure 8-30. Insert the CPU cooler into the retaining bracket

Advice from Ron Morse

There is more goop on that CPU than I've used in my entire lifetime! I use an amount about equal to a half-grain of rice.

I'd consider using Zalman ZM-STG1 thermal compound (http://www.zalmanusa.com). It applies like contact cement or nail polish, with the small included brush. Just paint the goop on both the CPU and heatsink mating surfaces and assemble. I haven't tested it yet, so I don't have the slightest idea if it is any good as a thermal compoundbut Zalman stuff is usually pretty good, and the concept sure looks promising!

With the CPU cooler resting loosely in place, the next step is to clamp it tightly against the processor to ensure good thermal transfer between the CPU and heatsink. To do so, hold the metal retaining bracket in place, as shown in Figure 8-31, while you press down the cammed locking lever with the other hand until the clamp locks into place. Make sure that all three of the plastic protrusions have engaged the holes in the bracket. Repeat this step for the second locking lever. With both levers locked, the CPU cooler is secured firmly and clamped into tight contact with the processor.

Figure 8-31. Clamp the CPU cooler into firm contact with the processor

The next step is to reinstall the northbridge heatsink. We had hoped to be able to do that without modifying the heatsink, but that turned out to be impossible. In order to clear the locking lever on the CPU cooler, we had to bend some of the northbridge heatsink fins, as shown in Figure 8-32. Fortunately, the fins are made of soft aluminum, which is quite easy to bend with your needle-nose pliers.

Figure 8-32. Modify the northbridge heatsink to fit by bending one set of fins

Before you reinstall the northbridge heatsink, you must remove the old thermal pad from the heatsink base and from the northbridge chip itself. Do that by rubbing gently with your thumb to remove the bulk of the thermal pad, and then polishing gently with a paper towel. If the thermal pad material is difficult to remove, use your fingernail to peel it off the surface of the heatsink and northbridge chip. Apply a thin layer of thermal compound to the northbridge chip and spread it evenly. Place the northbridge heatsink in position, as shown in Figure 8-33, rotate it slightly to spread the thermal compound evenly, and then press the two locking posts back into place to secure the heatsink.

Figure 8-33. Replace the northbridge heatsink

Figure 8-34 shows the northbridge heatsink reinstalled, with the bent fins clearing the CPU cooler clamping lever. The northbridge heatsink has six rows of fins, so we'd have reduced its cooling efficiency by about 16% if we'd removed one row of fins entirely rather than simply bending them. As modified, we estimate the northbridge cooling efficiency has been reduced by no more than 5%, if that. The fins are still well exposed to the air flow from the rear chassis fan. (When the system is running, the northbridge heatsink fins become noticeably warm to the touch, indicating that they are doing their job well.)

Figure 8-34. The modified northbridge heatsink

The thermal mass of the CPU cooler heatsink draws heat away from the CPU, but the heat must be dissipated to prevent the CPU from eventually overheating as the heatsink warms up. To dispose of excess heat as it is transferred to the heatsink, most CPU coolers use a fan to continuously draw or push air through the fins of the heatsink. Some CPU fans use a drive power connector, but most are designed to attach to dedicated CPU fan connector on the motherboard. Using a motherboard fan power connector allows the motherboard to control the CPU fan, reducing speed for quieter operation when the processor is running under light load and not generating much heat, and increasing fan speed when the processor is running under heavy load and generating more heat. The motherboard can also monitor fan speed, which allows it to send an alert to the user if the fan fails or begins running sporadically.

To connect the CPU fan, locate the 3-pin header connector on the motherboard labeled CPU Fan, and plug the keyed cable from the CPU fan into that connector, as shown in Figure 8-35.

Figure 8-35. Connect the CPU fan cable to the CPU fan connector

8.4.2.4. Installing memory

Installing memory takes only a few seconds. The ASRock motherboard provides two memory slots, but we're installing only one Crucial 512 MB DIMM, leaving the second slot free for later memory expansion.

To begin installing the memory, pivot the locking tabs on both sides of both DIMM sockets outward, as shown in Figure 8-36. (We're installing memory in only one socket, but having both sets of locking tabs open makes it easier to ensure that the one DIMM we're installing is properly seated.)

Figure 8-36. Pivot the locking tabs on both sides of both DIMM sockets outward

We'll install our DIMM in the first memory slot, which is the one nearer the processor. To install the DIMM, orient it with the notch in the contact area of the DIMM aligned with the raised plastic tab in the slot and slide the DIMM into place, as shown in Figure 8-37, making sure that both ends of the DIMM slide straight into the slots on the locking tab brackets.

Figure 8-37. Orient the DIMM with the notch aligned properly with the socket

With the DIMM properly aligned with the slot and oriented vertically relative to the slot, use both thumbs to press down on the DIMM until it snaps into place, as shown in Figure 8-38. The locking tabs should automatically pivot back up into the locked position when the DIMM snaps into place. If they don't, make absolutely certain that the DIMM is well seated and then close the locking tabs manually to lock the DIMM into the socket.

Figure 8-38. Seat the DIMM by pressing firmly until it snaps into place

When the DIMM is fully seated, the locking tabs should mate fully with the notches on the DIMM, as shown in Figure 8-39.

Figure 8-39. Make sure that the locking tabs on the bracket fully engage the cutouts on the DIMM

With the processor and memory installed, you're almost ready to install the motherboard in the case. Before you do that, check the motherboard documentation to determine if any configuration jumpers need to be set. The ASRock motherboard requires no additional configuration, so we proceeded to the next step.

8.4.3. Installing the Motherboard

Installing the motherboard is the most time-consuming step in building the system because there are so many cables to connect. It's important to get all of them connected right, so take your time and verify each connection before and after you make it.

8.4.3.1. Seating and securing the motherboard

To begin, slide the motherboard into the case, as shown in Figure 8-40. Carefully align the back-panel I/O connectors with the corresponding holes in the I/O template, and slide the motherboard toward the rear of the case until the motherboard mounting holes line up with the standoffs you installed earlier.

Figure 8-40. Slide the motherboard into position

Before you secure the motherboard, verify that the back-panel I/O connectors mate properly with the I/O template, as shown in Figure 8-41. The I/O template has metal tabs that ground the back-panel I/O connectors. Make sure none of these tabs intrude into a port connector. An errant tab at best blocks the port, rendering it unusable, and at worst may short out the motherboard.

Figure 8-41. Verify that the back-panel connectors mate cleanly with the I/O template

Final Check

Check one last time to make sure that there's a brass standoff installed for each mounting hole, and that no brass standoff is installed where there is no mounting hole. One of our technical reviewers suggests installing white nylon standoffs, trimmed to length, in all unused standoff positions covered by the motherboard, particularly those near the expansion slots. Doing so provides more support to the motherboard, making it less likely that you'll crack the motherboard when you are seating a recalcitrant expansion card.

After you position the motherboard and verify that the back-panel I/O connectors mate cleanly with the I/O template, insert a screw through one mounting hole into the corresponding standoff, as shown in Figure 8-42. You may need to apply pressure to keep the motherboard positioned properly until you have inserted two or three screws.

Figure 8-42. Install screws in all mounting holes to secure the motherboard

If you have trouble getting all the holes and standoffs aligned, insert two screws in opposite corners but don't tighten them completely. Use one hand to press the motherboard into alignment, with all holes matching the standoffs. Then insert one or two more screws and tighten them completely. Finish mounting the motherboard by inserting screws into all standoffs and tightening them.

With first-rate products like the Antec SLK1650B case and the ASRock K8NF4G-SATA2 motherboard, all the holes usually line up perfectly. With cheap products, that's often not true. At times, we've been forced to use only a few screws to secure the motherboard. We prefer to use all of them, both to physically support the motherboard and to make sure all of the grounding points are in fact grounded, but if you can't get all of the holes lined up, simply install as many screws as you can.

8.4.3.2. Connecting front-panel switch and indicator cables

Once the motherboard is secured, the next step is to connect the front panel switch and indicator cables to the motherboard. Before you begin connecting front panel cables, examine the cables. Each is labeled descriptively, e.g., "POWER SW" and "H.D.D. LED." Match those descriptions with the front panel connector pins on the motherboard to make sure you connect the correct cable to the appropriate pins. Once you determine the proper orientation for each cable, connect it as shown in Figure 8-43.

Figure 8-43. Connect the front-panel switch and indicator cables

Less Power

People sometimes ask us why we don't use power screwdrivers. Because they're large, clumsy, and the batteries are always dead when we want to use the driver. Worse still, we once watched someone crack a motherboard by overtorquing the mounting screws with a power screwdriver. A clutched driver eliminates that objection, but we still find power screwdrivers too clumsy to use, even when we've built many identical systems on an ad hoc production line.

Keep these guidelines in mind as you connect the front-panel cables:

  • Although Intel has defined a standard front-panel connector block and uses that standard for its own motherboards, few other motherboard makers adhere to that standard. Accordingly, rather than provide an Intel-standard monolithic connector block that would be useless for motherboards that do not follow the Intel standard, most case makers, including Antec, provide individual one-, two-, or three-pin connectors for each switch and indicator.

  • Not all cases have cables for every connector on the motherboard, and not all motherboards have connectors for all cables provided by the case. For example, the ASRock K8NF4G-SATA2 motherboard provides connectors for front-panel audio and an infrared module, neither of which is provided by the Antec SLK1650B case. Conversely, the Antec SLK1650B case provides cables for secondary and tertiary hard drive activity LEDs, neither of which is supported by the ASRock K8NF4G-SATA2 motherboard.

  • The power switch and reset switch connectors are not polarized, and can be connected in either orientation.

  • LED connectors are usually polarized, and should be connected with the ground wire and the signal wire oriented correctly. Most cases use a common wire colorusually black, although sometimes white or greenfor ground, and a colored wire for signal.

  • The Power LED connector is often problematic, as it is for this system. There are two types of Power LED connector. The first has two pins. The second has three pins, but only two wires, with the middle pin unused. A motherboard may provide either or both types of Power LED connector, and a case may provide either or both types of Power LED cable. The ASRock K8NF4G-SATA2 motherboard provides only a two-pin Power LED connector, although solder patches for a three-pin Power LED connector are visible in Figure 8-43 just to the right of the upper red SATA connector. The Antec SLK1650B case provides only a three-pin Power LED cable. That leaves us with two options. We took the easy way by simply leaving the Power LED disconnected. If you want your Power LED to function, use a sharp knife or diagonal cutters carefully to cut the Power LED cable connector lengthwise, dividing it into two single-wire connectors. Connect each of those separately to the two Power LED pins on the motherboard.

  • The Power LED connectors on some motherboards are dual-polarized, and can support a single-color (usually green) Power LED or a dual-color (usually green/yellow) LED. The Antec SLK1650B case and the ASRock K8NF4G-SATA2 motherboard both support only a single-color Power LED. If you are using a different case and motherboard that support a dual-color Power LED, check the case and motherboard documentation to determine where and how to connect the Power LED cable.

Advice from Brian Bilbrey

I prefer to use a knife tip to gently release (not break off) the plastic tab holding one of the end pins in the cable connector body in place, slide that pin out, and move it to the center location. Then I can install the connector onto the header with the empty location hanging out in space.

When you're connecting front-panel cables, try to get it right the first time, but don't worry too much about getting it wrong. Other than the power switch cable, which must be connected properly for the system to start, none of the other front-panel switch and indicator cables is essential, and connecting them wrong won't damage the system.

8.4.3.3. Connecting front-panel switch and indicator cables

After you connect the front-panel switch and indicator cables to the motherboard, connect the speaker cable, as shown in Figure 8-44. Connect the cable with the signal wire (in this case, red) on pin 1 and the ground wire (black) opposite. If you use a motherboard that has a built-in speaker, there may be no speaker header pins on the motherboard. If so, just leave this cable disconnected. If the motherboard has both a built-in speaker and speaker header pins, we generally connect this cable because the case speaker usually provides better volume than a surface-mounted motherboard speaker.

Figure 8-44. Connect the speaker cable

8.4.3.4. Connecting front-panel USB ports

The ASRock K8NF4G-SATA2 motherboard provides four internal USB 2.0 connectors, in two sets of two header pin groups. The Antec SLK1650B case provides two front-panel USB 2.0 ports, which terminate in a single 10-pin USB connector cable. Connect this cable to one of the motherboard USB header pin sets, as shown in Figure 8-45.

Figure 8-45. Connect the front-panel USB cable to a USB header pin set on the motherboard

8.4.4. Installing the Hard Drive

The Antec SLK1650B has three external 5.25" drive bays, two external 3.5" drive bays, and three internal 3.5" drive bays. The external bays are for devices like optical drives and floppy disk drives that use removable media, and can also be used for internal hard drives. The three internal 3.5" bays can each hold one hard drive. To begin installing the hard drive, remove the three screws that secure the internal drive bay, as shown in Figure 8-46.

Figure 8-46. Remove the screws that secure the internal drive bay

After you remove the three screws, lift the drive bay free of the chassis, as shown in Figure 8-47.

Figure 8-47. Lift the internal drive bay free of the chassis

Advice from Brian Bilbrey (and Ron Morse)

If you have the option, choose the best position to install the hard drive. All other factors being equal, I prefer to make sure that the drive doesn't protrude out over the memory (first), and cable connection points (second). With only one drive being installed, and three install positions, one is bound to be a better choice than the others for any given case/motherboard combination.

Before you install the hard drive in the drive bay, verify that the drive is configured properly. We are using a Serial ATA hard drive in this system. Serial ATA drives do not require configuration because each S-ATA drive connects to a dedicated interface. If we had used a parallel ATA (P-ATA) hard drive, we'd have checked the jumpers on the drive to verify it was set as Master.

The Antec drive bay uses rubber shock-mounting pads to isolate the drive, which reduces the amount of vibration and noise transferred from the hard drive to the chassis. Several of these pads are visible in Figure 8-48, including one under the screw being driven. Secure the drive to the bay by installing four of the provided screws with oversize heads. Drive the screws finger-tight, but do not overtorque them.

Figure 8-48. Secure the hard drive to the bay using four of the provided large-head screws

With the hard drive secured in the bay, the next step is to reinstall the bay in the chassis, as shown in Figure 8-49. To do so, align the notches in the drive bay with the chassis tabs and slide the drive bay into the chassis.

Figure 8-49. Slide the drive bay into the chassis, aligning the slots in the bay with the tabs on the chassis

With the drive bay fully seated, reinstall the three screws you removed earlier to secure the drive bay in the chassis, as shown in Figure 8-50.

Figure 8-50. Reinstall the three screws you removed earlier to secure the drive bay to the chassis

With the drive bay reinstalled, the next step is to connect power to the hard drive. To do so, examine the various cables coming out of the power supply to locate a Serial ATA power cable. The Serial ATA power connector is keyed similarly to the Serial ATA data cable, using a slot and tab arrangement. Align the keying slot on the cable with the keying tab on the drive and slide the power cable into place, as shown in Figure 8-51.

Figure 8-51. Connect the Serial ATA power cable to the hard drive

The next step is to connect the Serial ATA data cable to the drive. It doesn't matter which end of the Serial ATA cable you connect to the drive. The two ends are interchangeable. The Serial ATA data cable is keyed with a notch at one end that slides over a corresponding tab on the drive connector. Align the cable connector to the drive connector and press firmly until the cable connector slides into place, as shown in Figure 8-52.

Figure 8-52. Connect the Serial ATA data cable to the hard drive

What, No Floppy Drive?

We decided against installing a floppy disk drive (FDD) in this system, although we may come to regret it. We didn't skip the FDD to save moneythey only cost $8 or sobut to avoid having one more dust collector and one more ribbon cable to block air flow.

Some years ago, Intel and Microsoft started telling everyone that the humble FDD was a "legacy" device. We doubted the wisdom of that statement at the time, and over the years we've frequently had cause to regret not installing an FDD. More than once, we've had to open up a system and install an FDD to load a driver that wouldn't load from CD or to update the BIOS.

But things have changed, and we now consider the FDD passé for new systems. Even if you don't have a network, it's easy to move files around on writable CDs, DVDs, or a USB 2.0 flash memory stick. ASRock provides a Windows-based BIOS updater utility, which eliminates the main reason for installing an FDD. And, although installing Windows XP Gold (the original release) on some early S-ATA motherboards requires a driver floppy, the ASRock motherboard supports pre-SP1 Windows XP directly.

So, although we won't install an FDD in our budget PC, we won't give you a hard time if you decide to install one in yours.

The final step is to connect the Serial ATA data cable to the motherboard Serial ATA interface. The motherboard provides two Serial ATA interfaces, labeled SATA1 and SATA2. Although the drive functions properly connected to either interface, best practice is to connect the primary hard drive to the first interface, which is SATA1. The motherboard SATA connector is keyed in the same fashion as the hard drive SATA connector. Orient the Serial ATA data cable so that its keying slot corresponds to the keying tab on the motherboard connector, and press the cable into place, as shown in Figure 8-53.

Figure 8-53. Connect the Serial ATA data cable to the motherboard interface

8.4.5. Installing the Optical Drive

Before you install the optical drive, verify the jumper settings. The NEC ND-3550A DVD writer ships with a jumper installed in the rightmost position, as shown in Figure 8-54. This default jumper setting configures the drive as master. We plan to use the optical drive as the master on the primary ATA channel, so the default jumper setting is correct.

Figure 8-54. Verify that the optical drive jumper is set to master

Advice from Jim Cooley

If you are unsure, check the master/slave jumper setting against the legend usually imprinted in the metal on the top of the optical drive.

It's usually easier to connect the ATA cable to the drive before you install the drive in the case. The ASRock K8NF4G-SATA2 motherboard comes with an 80-wire Ultra ATA cable, which we used. Because optical drives have relatively slow transfer rates, they can use the older 40-wire ATA cable rather than the 80-wire Ultra-ATA cable used for ATA hard drives. (An 80-wire cable works fine if that's all you have, but it's not necessary.)

To connect the cable, locate pin 1 on the drive connector, which is usually nearest the power connector. The pin 1 side of the cable is indicated by a red stripe. Align the cable connector with the drive connector, making sure the red stripe is on the pin 1 side of the drive connector, and press the cable into place, as shown in Figure 8-55.

Figure 8-55. Connect the ATA data cable to the optical drive, making sure pin 1 is oriented correctly

The Antec SLK1650B case provides three external 5.25" bays, each of which is covered by a snap-in plastic bezel. Before installing the drive you have to remove the bezel for the selected drive bay. The easiest way to do that on the Antec case is to press the bezel from behind, as shown in Figure 8-56, until it pops out. The two lower external 5.25" bays have metal RF shields installed, but the upper bay lacks that shield. For simplicity, we decided to leave the metal shields in place in the lower bays and install the NEC ND-3550A DVD writer in the upper bay.

Figure 8-56. Pop the plastic bezel and remove it

Unlike some cases, the Antec SLK1650B self-aligns the optical drive both vertically and horizontally. To mount the drive in the case, feed the loose end of the ATA cable through the drive bay from the front, and feed the cable down into the case. Align the drive with the mounting rails inside the bay, and slide the drive into the case, as shown in Figure 8-57. Seat the front of the drive bezel flush with the case bezel, and install four screwsleft and right, front and backto secure the drive.

Figure 8-57. Slide the optical drive into the bay and set it flush

Ebony or Ivory?

Why use a beige drive in a black case? We admit that it looks strange, but we did it intentionally. For years, we installed beige drives in beige cases, black drives in black cases, and silver drives in silver cases. Then one day, Robert, who keeps his office quite dark, was fumbling around the front of one of his mini-tower units, trying to find the eject button on the optical drive. Robert had an AHA! moment, and began installing beige or white drives in his black mini-tower systems, which makes the drives much easier to locate in the dark. Barbara points out that she calls Robert's office the Black Hole of Calcutta for more than one reason, and that if he'd use something brighter than his single 15W desk lamp he wouldn't have these problems.

We want to connect the NEC ND-3550A optical drive as the master device on the primary ATA channel. In the past, we left the primary ATA channel unused in systems with S-ATA hard drives, because Windows sometimes became confused if the master device on the primary ATA channel was an optical drive. With recent motherboards, that problem is much less likely, so we now connect the optical drive to the primary ATA channel.

The blue primary ATA interface and the black secondary ATA interface are located near the right-front edge of the motherboard near the DIMM slots. Locate pin 1 on the primary ATA interface, align the ATA cable with its red stripe toward pin 1 on the interface, and press the connector into place, as shown in Figure 8-58.

Figure 8-58. Connect the optical drive ATA cable to the primary ATA interface

The final step in installing the optical driveone we forget more often than we shouldis to connect power to the drive. Choose one of the power cables coming from the power supply and press the Molex connector onto the drive power connector, as shown in Figure 8-59. It may require significant pressure to get the power connector to seat, so use care to avoid hurting your fingers if the connector seats suddenly. The Molex power connector is keyed, so verify that it is oriented properly before you apply pressure to seat the power cable.

Figure 8-59. Connect the power cable to the optical drive

Neatness Counts

After you connect the ATA cable, don't just leave it flopping around loose. That not only looks amateurish, but can impede air flow and cause overheating. Tuck the cable neatly out of the way, using tape, cable ties, or tie-wraps to secure it to the case. If necessary, temporarily disconnect the cable to route it around other cables and obstructions, and reconnect it once you have it positioned properly.

8.4.6. Connecting the ATX Power Connectors

The next step in assembling the system is to connect the two ATX power connectors from the power supply to the motherboard. The main ATX power connector supplies most of the power required by the motherboard. The ATX12V power connector provides supplemental (but required) power.

WHAT ABOUT THE AUDIO CABLE?

Speaking of forgetting to connect cables, for the last edition of this book one of our technical reviewers pointed out that we'd forgotten to connect the audio cable to the optical drive in all of the project systems. We hadn't forgotten. We just don't do it any more.

Years ago, connecting an audio cable from the optical drive to the motherboard audio connector or sound card was an essential step, because systems used the analog audio delivered from the optical drive by that cable. If you didn't connect that cable, you didn't get audio from the drive. All recent optical drives and motherboards support digital audio, which is delivered across the bus rather than via a dedicated audio cable. Few optical drives or motherboards include an analog audio cable nowadays, because one is seldom needed.

To verify the setting for digital audio, which is ordinarily enabled by default, use Windows XP Device Manager to display the Device Properties sheet for the optical drive. The Enable digital CD audio... checkbox should be marked. If it is not, mark the checkbox to enable digital audio. If the checkbox is grayed out, does not appear, or if the checkbox refuses to stay checked after a reboot, that means your optical drive and/or your motherboard do not support digital audio. In that case, you'll need to use an MPC analog audio to connect the drive to the CD-ROM audio connector on the motherboard or your sound card. Also, some older audio applications do not support digital audio, and so require that an analog audio cable be installed even if the system supports digital audio.

The NEC ND-3550A DVD writer, like many modern optical drives, provides two audio connectors. In addition to the 4-pin MPC analog audio connector, the ND-3550A includes a 2-pin digital audio connector that you can connect to a Sony Philips Digital Interface (SP/DIF) audio connector or a digital-in audio connector on your motherboard or sound card.

We suggest you install an audio cable only if needed. Otherwise, you can do without.

Broadly speaking, there are two types of main ATX power connector. Until recently, most ATX motherboards used the original 20-pin main ATX power connector. The higher current requirements of modern processors led Intel to revise the ATX standard to use a 24-pin main ATX power connector, with the extra four pins carrying additional current at standard voltages.

The 24-pin connector is a superset of the older 20-pin connector. The first 20 pins on a 24-pin connector use the same voltages and have the same keying as the 20 pins of the original connector. The extra four pins were simply added onto the end of the old connector. This similarity in layout confers a surprising degree of compatibility between 20-pin power supplies and 24-pin motherboards and vice versa.

Current (ATX12V 2.01 and higher) power supplies use the 24-pin connector, as do many (but not all) current motherboards. Most 24-pin motherboards can use a 20-pin power supply if you supplement that power by plugging a standard Molex (hard drive) power connector into a socket on the motherboard. Conversely, most 24-pin power supplies can be used with a 20-pin motherboard by using one of the following workarounds:

  • Some 24-pin power supplies include a 24-to-20-pin adapter cable. Such adapter cables are also available from many online vendors.

  • Some power supplies, including the Antec SmartPower 2.0 unit supplied with the SLK1650B case, provide a connector that can be configured as 24-pin or 20-pin by adding or removing a supplemental 4-pin section to the main 20-pin connector.

  • Some 20-pin motherboards, including the ASRock K8NF4G-SATA2, have sufficient room around the 20-pin connector to allow a 24-pin cable to be connected, with the extra four pins simply left hanging off the end. This is the option we chose, even though the Antec power supply provides a detachable 4-pin section. Leaving the extra 4-pin section in place harms nothing, and avoids having yet another loose wire floating around inside the case. Those extra four pins are visible in Figure 8-60 between the white ATX power socket and the CPU cooler.

Figure 8-60. Connect the Main ATX Power Connector

The main ATX power connector is located between the northbridge heatsink and the rear I/O panel. The main ATX power connector is keyed, so verify that it is aligned properly before you attempt to seat it.

Once everything is aligned, press down firmly until the connector seats. Figure 8-60 shows the connector in the process of being inserted, just before the black plastic latch on the cable connector snaps into place on the white socket body. It may take significant pressure to seat the connector. Make sure the plug mates completely with the socket, and that the latch snaps into place. A partially seated main ATX power connector may cause subtle problems that are very difficult to troubleshoot.

Early Pentium 4 systems required more power to the motherboard than the standard 20-pin ATX main power connector supplied. As a stopgap measure, before they extended the ATX specification to use a 24-pin connector, Intel developed a supplementary connector, called the ATX12V connector. This 4-pin connector routes additional +12V current directly to the VRM (voltage regulator module) that powers the processor.

Nowadays, most motherboardsincluding 24-pin models for both Intel and AMD processorsrequire the additional current provided by the ATX12V connector. If you forget to connect the ATX12V cable, the system simply won't boot.

On most motherboards, including the ASRock K8NF4G-SATA2, the ATX12V connector is located near the processor socket. Unfortunately, the ASRock motherboard places this connector in a very inaccessible location, at the rear edge of the motherboard near the power supply, leaving almost no room to work. We had a difficult time connecting the ATX12V cable, let alone shooting an image of it. Barbara was finally able to get the connector oriented properly and seat it with one finger, as shown in Figure 8-61. When you seat this connector, make sure the locking tab snaps into place.

Figure 8-61. Connect the ATX12V power connector

8.4.7. Final Assembly Steps

Congratulations! You're almost finished building the system. Only a few final steps remain to be done, and those won't take long.

Connect the supplemental case fan

The Antec SLK1650B has one rear-mounted 120mm supplemental fan. To enable it, connect a four-pin Molex connector from the power supply to the connector on the fan, as shown in Figure 8-62.

Dress the cables

The final step in assembling the system is to dress the cables. That simply means routing the cables away from the motherboard and other components and tying them off so they don't flop around inside the case. Chances are that no one but you will ever see the inside of your system, but dressing the cables has several advantages other than making the system appear neater. First and foremost, it improves cooling by keeping the cables from impeding air flow. It can also improve system reliability. More than once, we've seen a system overheat and crash because a loose cable jammed the CPU fan or case fan.

Figure 8-62. Connect power to the rear case fan

After you've completed these steps, take a few minutes to double-check everything. Verify that all cables are connected properly, that all drives are secured, and that there's nothing loose inside the case. Check one last time to verify the power supply is set for the correct input voltage. It's a good idea to pick up the system and tilt it gently from side to side to make sure there are no loose screws or other items that could cause a short. Use the following checklist:

  • Power supply set to proper input voltage

  • No loose tools or screws (tilt and shake the case gently)

  • Heatsink/fan unit properly mounted; CPU fan connected

  • Memory module(s) full seated and latched

  • Front-panel switch and indicator cables connected properly

  • Front-panel USB cable connected properly

  • Hard drive data cable connected to drive and motherboard

  • Hard drive power cable connected

  • Optical drive data cable connected to drive and motherboard

  • Optical drive power cable connected

  • Optical drive audio cable(s) connected, if applicable

  • Floppy drive data and power cables connected (if applicable)

  • All drives secured to drive bay or chassis, as applicable

  • Expansion cards (if any) fully seated and secured to the chassis

  • Main ATX power cable and ATX12V power cable connected

  • Front and rear case fans installed and connected (if applicable)

  • All cables dressed and tucked

Now it's time for the smoke test. Leave the cover off for now. Connect the power cable to the wall receptacle and then to the system unit. Unlike many power supplies, the Antec SmartPower 2.0 has a separate rocker switch on the back that controls power to the power supply. By default, it's in the "0" or off position, which means the power supply is not receiving power from the wall receptacle. Move that switch to the "1" or on position. Press the main power button on the front of the case, and the system should start up. Check to make sure that the power supply fan, CPU fan, and case fan are spinning. (Remember that the case fan spins only when needed, so it may not be spinning when you first power up the system.) You should also hear the hard drive spin up and the happy beep that tells you the system is starting normally. At that point, everything should be working properly.


Section 8.5. Final Words

8.5. Final Words

Except for the CPU cooler problem, this system assembled easily. It took us about half an hour to build, or two days, depending on how you look at it. Counting only actual construction time, it took about 30 minutes from start to finish. Counting the time to shoot images, reshoot images, re-reshoot images, tear down for reshoots and re-reshoots, rebuild and re-rebuild after the re-shoots and re-reshoots, and so on, it took two days. A first-time system builder should be able to assemble this system in an evening with luck, and certainly over a weekend.

False Starts

When you turn on the rear power switch, the system will come to life momentarily and then die. That's perfectly normal behavior. When the power supply receives power, it begins to start up. It quickly notices that the motherboard hasn't told it to start, and so it shuts down again. All you need to do is press the front-panel power switch and the system will start normally.

8.5.1. Installing Software

Microsoft declined our request for a beta copy of Windows Vistawe suspect we're on their Enemies List because we're vocal Linux advocatesso we installed Windows XP instead. We installed Windows XP uneventfully from a distribution disc that included SP2.

Hasta La Vista, Baby

We actually weren't disappointed, when Microsoft refused to send us a Vista beta, because Vista has been gutted to the point that it is little more than a Windows XP service pack anyway. After we wrote this chapter, we downloaded a copy of Windows Vista Beta 2 during the public preview. Vista Beta 2 loads and runs fine on this system. Well, as fine as it runs on anything, which isn't very fine at all.

The next step was to install and update drivers. Like most motherboard makers, ASRock includes a driver CD that automates the process. Running the Drivers CD displays the dialog shown in Figure 8-63. We installed all of the drivers in the order shown.

Figure 8-63. The ASRock Drivers CD main menu

After the Drivers CD installs the ASRock-provided drivers and utilities, install any necessary third-party drivers. For this system, no third-party drivers were needed. With all of the drivers installed, we restarted the system and installed our standard suite of applications, including Firefox and OpenOffice.org.

8.5.2. Updating the BIOS

"If it ain't broke, don't fix it" is a good rule when it comes to updating the main system BIOS. We generally don't update the main system BIOS unless the later BIOS fixes a problem that actually affects us. The most recent BIOS available for the ASRock motherboard was only one version more recent than the one supplied with the motherboard, and included only a few minor fixes, none of which pertained to us. Still, for illustrative purposes, we decided to update our main system BIOS.

Optional Drivers

Some components include what we call "optional drivers." For example, there are drivers available for the Logitech keyboard and mouse. We generally don't install these drivers, although they are required to support enhanced functions such as programming the keyboard. We seldom use those enhanced functions, so we just use the default Microsoft drivers. If you want to enable those enhanced functions on your system, install the drivers.

But, as Jim Cooley notes, "beware, they often require significant memory and CPU resources with little apparent benefit except in specialized cases. The only exception to manufacturers' utilities that is of any real benefit is the Hardware Monitoring software, which can alert you should the system overheat in the event of a fan failure."

ADVICE FROM JIM COOLEY

That being said, readers of this book may, more often than not, want to tweak and update their system to include all the latest drivers and updates. I recommend updating the BIOS using the boot floppy method before installing an operating system because Windows, in particular, will force a reinstall (albeit mostly automatic) of every single device on the system when it detects a new BIOS and that introduces the chance for Murphy's Law to prove itself, often with spectacular results.

Like most motherboard makers, ASRock provides two methods to update the BIOS. The first is the traditional boot floppy method. You download the BIOS update as a binary file and copy it and the updater program to a floppy disk. Booting that floppy disk transfers the updated BIOS code to the system. The boot floppy method works on any systemat least any system that has a floppy drivewhether it runs Windows or some other operating system (or no operating system at all.) Most people use the second method, shown in Figure 8-64, which uses a Windows executable to update the BIOS. To update the BIOS using this method, you simply double-click the updater program icon and follow the prompts.

Figure 8-64. The ASRock Windows BIOS updater

DON'T KILL YOUR MOTHERBOARD

Never interrupt the system while a BIOS update is in progress. If you turn off the system (or the power fails) during a BIOS update, the motherboard may be left in an unbootable state. For that reason, we recommend connecting the system to a UPS when you update the BIOS.

8.5.3. End Result

We're extremely happy with this system, particularly for the price. It sits under Robert's desk, and has the distinction of being the only computer in the house that runs Windows. (We have anything from half a dozen to a dozen other systemsthe exact number varies from day to daybut all of them run Linux.)

We built this system because Robert needed a Windows system to run some Windows-only astronomy software he was using to generate charts for an astronomy book we were writing. We didn't want to spend much money on it, because it was needed only for as long as it took to complete the book. Once we finish that book, we'll donate this system to a local nonprofit and again have our home as a Microsoft-free zone.

Still, although it cost only $350 excluding external peripherals, many people would be happy with this system as their only system. It's slower than the fastest current systems, but it's more than fast enough for casual use, including even light gaming. It's also quiet enough that we wouldn't hesitate to use it in our den, living room, or bedroom.

All in all, this is the perfect budget PC for us.

For updated component recommendations, commentary, and other new material, visit http://www.hardwareguys.com/guides/budget-pc.html.


About the Authors

About the Authors

Robert Bruce Thompson is the author or co-author of numerous on-line training courses and computer books. Robert built his first computer in 1976 from discrete chips. It had 256 bytes of memory, used toggle switches and LEDs for I/O, ran at less than 1 MHz, and had no operating system. Since then, he has bought, built, upgraded, and repaired hundreds of PCs for himself, employers, customers, friends, and clients. Robert reads mysteries and non-fiction for relaxation, but only on cloudy nights. He spends most clear, moonless nights outdoors with his 10" Dobsonian reflector telescope, hunting down faint fuzzies, and is currently designing a larger truss-tube Dobsonian (computerized, of course) that he plans to build.

Barbara Fritchman Thompson worked for 20 years as a librarian before starting her own home-based consulting practice, Research Solutions (http://www.researchsolutions.net), and is also a researcher for the law firm Womble Carlyle Sandridge & Rice, PLLC. Barbara, who has been a PC power user for more than 15 years, researched and tested much of the hardware reviewed for this book. During her leisure hours, Barbara reads, works out, plays golf, and, like Robert, is an avid amateur astronomer.


Colophon

Colophon

Our look is the result of reader comments, our own experimentation, and feedback from distribution channels. Distinctive covers complement our distinctive approach to technical topics, breathing personality and life into potentially dry subjects.

Philip Dangler was the production editor and copyeditor for Building the Perfect PC, Second Edition. Sada Preisch was the proofreader. Jimmie Young wrote the index.

Karen Montgomery designed the cover of this book using InDesign CS2. The cover image is a photograph by David Reavis. Emma Colby produced the cover layout with QuarkXPress 4.1 using Adobe's Formata Condensed font.

The series design is by David Futato. This book was converted from Microsoft Word to InDesign CS by Abby Fox. The text and heading fonts are Linotype Birka and Adobe Formata Condensed, and the code font is TheSans Mono Condensed from LucasFont. The illustrations and screenshots that appear in the book were produced by Robert Romano and Jessamyn Read using Macromedia Freehand MX and Adobe Photoshop CS.


Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]


SYMBOL

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

350W ATX 2.0 power supply
3D video performance
802.108g wireless network adapters
802.11 wireless network adapters
802.11a wireless network adapters
802.11b wireless network adapters
802.11g wireless network adapters


A

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

AC97 audio connector versus HD Audio
access points (AP)
advice for first-time system builders
boot up, first time
cases
components, shake/tilt for loose
computer set up, verify
force, use cautiously
new system, patch before internet connection
packing list, verify before building
parts, missing
PC, prevent damage of
PCs, shipping
receipts, saving
smoke test, applying power to the PC
advice from Brian Bilbrey
cable ties, use of
DVD for faster read access
floppy disk drives
hard disk drive position
hardware RAID 0
keyboards, cordless
workstations as shared servers
advice from Brian Jepson
AGP support
hard disk drive enclosures
advice from Jerry Pournelle
Falcon Electric UPS
mounting, suspended
advice from Jim Cooley
bezels, saving
BIOS, updating
cables, reconnecting technique
case integrity, checking
connector block wire
connectors, re-attaching
CPU cooler
drivers, optional choices
FireWire cards
hard drive cage, locking down
I/O template installation
jumper settings for optical drives
keyboards, buy from garage sales
pin 1
S-ATA cable attachment
SATA and ATA cables, identifying
standoffs
TV capture cards
video, integrated
advice from Ron Morse
Creative Labs Audigy X-Fi series, problems with
hard disk drive failures
hard disk drive position
Hauppauge Win-PVR-U5B2 model
workstations and shared printers
Zalman ZM-STG1 thermal compound
advice from Scott Kitterman RAID support
AGP video slots
AMD coolers
AMD/ATi Crossfire configuration
analog VGA video output
Antec
120mm TriCool
cable connectors
Fusion or Antec NSK2400
NeoHE 2nd
NSK1300
P150
P180 Advanced Super Mid Tower Case
Phantom 350 power supply
power cable connector
Silver Thermal Compound 2nd 3rd 4th
SLK-1650B Mini-Tower Case
SmartPower 2.0 unit
Titan550 cases
TruePower 2nd
applications discs
Arctic Cooling Silencer 64 Ultra
ASRock K8NF4G-SATA2
ASUS M2N32-SLI Deluxe motherboard
ASUS Q-Connector
ASUS Stack Cool 2
ATA (IDE) motherboard interface connector
ATA data cables 2nd 3rd
ATA hard drives
10,000 RPM ATA
5,400 RPM ATA, avoid using
7,200 RPM ATA
highest possible disk performance
Serial ATA
ATA ribbon cables 2nd
ATA sockets
ATAPI audio cable
Athlon 64 X2 processor
Atlas server cases
ATX power cables 2nd 3rd
ATX power connectors 2nd 3rd
ATX12V power cable 2nd 3rd
ATX12V power connectors 2nd
audio adapters
ADI codec
Creative Labs Audigy
Creative Labs Audigy2 ZS/X-Fi
external audio
features, buying unneeded
gaming support
guidelines
hardware-accelerated sound cards
Intel D945GCZ
M-AUDIO Revolution 2nd
recommended choices


B

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

benchmarks, buying components based on
Berg (floppy drive) power connector
BIOS Setup Configuration jumper 2nd 3rd 4th
beep codes for troubleshooting
boot text displayed but system doesn't boot
monitor CPU temperature
set to Configure mode
set to Normal mode
Small Form Factor (SFF) PCs
updates for budget PCs
brand names
BTX Cooler Types
budget PCs
audio cable
analog audio cable
CD-ROM audio connector
digital audio
building
case, preparing
grounding problem
I/O template
motherboard I/O panel
mounting holes
panels
receptacle overvoltage
standoff mounting
templates, easily damaged
thumbscrews
verify the packing list
component recommendations
CPU cooler installation
buying a proper CPU
clamping bracket
clamping lever
fan connection
heat spreader, polishing
locking lever
northbridge heatsink 2nd
oriententation of
retaining bracket
thermal compound
thermal pad
warranty, voiding of
definition
drivers, install and update
final assembly steps
connect the supplemental case fan
dress the cables
final verification checklist
optional drivers
power shut down on first start up
smoke test
functional requirements
hardware design criteria
memory controller
memory installation
motherboard installation
cables, verify each connection
drive bays
floppy disk drive (FDD)
front panel switch 2nd
front-panel USB ports, connecting
grounding
I/O connectors
I/O template
indicator cables, connecting 2nd
keying tabs/slots
mounting pads
power screwdrivers, use of
power supply, connecting
seating and securing the board
standoffs, final check of
motherboard, preparing
CPU cooler, compatibility
grounding
memory
processors
retaining brackets
optical drive installation
ATA interfaces
audio cable
bezel
cables, securing to the case
jumper settings
locate in the dark
pin 1 2nd
power cables
power connector, seating of
primary ATA channel
RF shields
seating
power supply
processor installation
pin 1
seating of
sockets
ZIF lever
Vista compatibility
burn-in utility software
BurnInTest from PassMark Software
buying guidelines for components
800 number orders
buying better quality and reliability
buying with a credit card
compare manufacturer model number
components performance specifications
credit card charge-back
defective products
equivalent substitute for ordered product
Estimated Selling Price (ESP)
local retailers
on-line resellers
order by phone
packing list
price, actual versus advertised price
product ship date, checking
restocking fees 2nd
retail-boxed versus OEM forms
return opened products, how to
sales and use tax
save order information
shipping, cost of
Suggested Retail Price (SRP)
surcharges
sweet spot
vendor reviews
verbal promises
verify packing contents
warranties
web-only vendors


C

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

cables
IDE
LED cables
ribbon cable problems
UltraATA cable
VFD/Volume cable 2nd
cases 2nd 3rd 4th
alternatives
aluminum 2nd
Antec BK640B 2nd
Antec New Solution Series NSK3300 micro-tower
Antec NSK1300 2nd
Antec P150 2nd
Antec Super LANBOY cases
Apevia (Aspire) X-QPACK
ATX form factors 2nd
BK640B
BTX (Balanced Technology eXtended)
BTX SRM (Support and Retention Module)
case fans
Chenming 2nd
cube cases
Intel TAC (Thermally-Advantaged Chassis)
JPAC 901
leave cover off until tested
Lian Li PC-V300
microATX cases
motherboards for small cases
preparing the case
proper size
purpose of
slimline cases 2nd
supplemental cooling fans
Support and Retention Module (SRM)
CD-ROM drives
CD-Rs
Chassis Intrusion Connector
Chin, Mike
Client Access Licenses (CALs)
CMOS Setup 2nd 3rd 4th
CMS Bounceback Express
components
benchmarks, buying based on
buy locally 2nd
choosing based on expandability
integrated (or embedded)
packing list, verify before building
CoolerMaster CB5-NPFSA-02-GP
Creative Labs
Creative Labs Audigy X-Fi series
Creative Labs Audigy2 ZS cards
Creative Labs X-Fi cards
Crucial 512 MB DIMM
Crucial, memory manufacturers
Cyclone Blower


D

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

D-Link DGE-560T PCI-Express Gigabit Network Adapter
D-Link, access point manufacturer
Dantz Retrospect
data cables
design issues
balanced design
bottlenecks
bundled software
component quality
compromises in expandability
design incompatibilities
design priority
disk capacity/performance
expandability
experience for resolving problems
flexible design
lower cost
noise level 2nd
options
power supply
price
processor performance
reliability
size
upgradability
video performance
warranty
Device Properties sheet
Digital In audio connector
DiscWizard installation software
display monitors
added color cast
analog-only LCD
CRT guidelines
defective pixels 2nd
displayed image, buying based on
entry-level LCD model
first-tier CRT
grade of models
image persistence (ghost images)
Intel Active Monitor
LCD guidelines
LCDs 2nd
limited viewing angle
name brands 2nd
NEC AS700 17" CRT
NEC-Mitsubishi 2nd
OptiQuest
panel size and resolution
power consumption
Pro Series monitor
reserve brightness
Samsung 2nd
Samsung 793DF 17" CRT
Samsung 930BF
Samsung SyncMaster 997MB CRT
service contracts
size
Sony
test before purchase 2nd
ViewSonic 2nd
ViewSonic E70 17" CRT
ViewSonic G90FB CRT
warranty 2nd
Zero Bright Pixel Defect Warranty
distribution discs
Driver CDs
bundled drivers
Drivers CD, budget PCs
installation
storage
updates
DVD writers
DVD-RAM discs
DVD-ROM drives
Lite-On
Mitsumi
NEC
Samsung
Toshiba
DVD-ROM/CD writers
DVI digital output
DVI video


E

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

e.SATA external drive
Enable digital CD audio... checkbox
Endpcnoise.com
Enermax NoiseTaker series
Enermax Pandora CA3030
Ethernet adapters
Ethernet controller chip


F

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

Falcon Electric UPS
Fan Only Molex connectors
firewalls/routers
FireWire
cables
controller
FireWire 400
FireWire, mainstream PCs
FireWire, media PCs
port
Firmware Hub (FWH)
floppy disk drive (FDD) 2nd
disk drive installation
save drive bay space
Front-Panel IEEE-1394a (FireWire) Port connection
FrozenCPU, resistor kits


G

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

gaming PCs
ATX Power Cables
backpacks for
building
cases
aluminum
screwdrivers use, warning
CPU coolers
connectors
heatsink base, checking
retention brackets
sockets, compatibility
thermal compounds
CrossFire systems
display monitors
fanless video adapters
final steps
functional requirements
game controllers
alternatives to
cordless models, downsides of
personal preference
ground/common connection wires
hard disk drive installation
hardware design criteria
headphones, alternatives for
list of items for traveling
memory installation
mice
alternatives for
Logitech cordless mouse
Logitech MX-series corded optical mouse
Microsoft cordless mice, problems with
motherboard installation
ASUS M2N32-SLI Deluxe
front panel switch connection
front-panel audio ports connection
front-panel IEEE-1394a (FireWire) Port connection
front-panel USB ports connection
indicator cables connection
seating and securing
slave (second) devices
noise reduction
optical drive
alternative drives
BenQ DW1650 DVD writer
testing random access time
optical drive installation
populate the motherboard
processor installation
populating the motherboard
preparing the case
processors
AMD Athlon 64 X2
Installation
Intel Core 2 Duo
Intel Pentium D
retail-boxed processors
purpose-built LAN Party accessory cases
slaves (second) devices
SLI (Scalable Link Interface)
smoke test
sound adapters
EAX support
integrated audio
standalone
speakers
alternatives for
Logitech Z-5500 5.1 speaker system
transporting systems
backpacks, use of
list of packing supplies
Zero Halliburton cases, use of
video adapter installation
Gentoo Linux
GMA 950 integrated video
Graphics Media Accelerator 3000 (GMA 3000)
grounding


H

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

hand tools/supply list
hard disk drives
500 GB Barracuda
alternative models
ATA (Parallel ATA or PATA)
ATA/SATA drive
Barracuda 7200.9
BenQ DW-1650
buffer/cache
data loss, protect against 2nd
diagnostics
drive failure, protect against
guidelines
high-capacity drives
IDE hard drive
installation
installation/diagnostic utility
RAID 1
recommended
SATA drives
Seagate Barracuda 7200.9 SATA 2nd 3rd 4th
Seagate Cheetah
Seagate ST320014A U Series X
Seagate ST3250620AS Barracuda 7200.10
Serial ATA (SATA) interface
Smart Drive Enclosure
Zalman Hard Drive Heatpipe
hard drive activity LED (IDE_LED)
Hard Drive Activity LED (yellow) connectors
Hard Drive Failure error message
hardware design criteria
2D video quality
3D video performance
disk capacity/performance
disk performance
expandability
noise level
price
processor performance
reliability
size
video performance
Hauppauge dual analog tuner
Hauppauge WinTV-PVR-150 tuner card
HDD activity LED cable
headphones, alternatives for
HSFs (heatsink/fan units)
and motherboard compatibility
choosing a quiet cooler
cooling fans
emergency fans
Resistor kits (voltage or fan speed controllers)
retail-boxed BTX processor
third-party CPU cooler
Type I BTX Thermal Module
Type I cooler
Type II cooler


I

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

I/O panel
ICH (I/O Controller Hub)
Intel CPU cooler
Intel D945GCZLR
Intel High Definition Audio
Intel USB pin assignments


K

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

keyboards
alphanumeric keys
Bluetooth wireless connectivity
dedicated and/or programmable function keys
Dvorak layout
IR (infrared) keyboards
Logitech
Logitech Media Elite
Microsoft
programmable function keys
PS/2 keyboard
PS/2 keyboard port
recommended
RF (radio frequency) keyboards
styles
USB keyboards
wireless keyboard
Kingston 2GB PC5300 DDR2 Memory Kit
KingWin TL-35CS Night Hawk
Knoppix Live Linux CD


L

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

LAMP (Linux, Apache, MySQL, PHP/Perl/Python) server
LAN (Local Area Network)
LAN (Local Area Network) adapter
LED lights
blue LED
Hard Drive Activity LED (yellow)
HDD LED
Power LED (green)
red LED
Line Out audio ports
Linux
distribution CD 2nd
running from a CD
versus Windows
locked OEM versions
Logitech LX7 Cordless Optical Mouse
Logitech Media Elite
low-power processor
low-speed Cyclone Blower installation


M

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

M-Audio audio adapter
M-AUDIO Revolution 7.1
magnetized tools, warnings
Main ATX power cable 2nd 3rd
Main ATX Power Connector
mainstream PCs
boot failure 2nd
BTX SRM (Support and Retention Module)
building
case, preparing the
components recommended
Device Properties sheet
false power starts
final assembly steps
floppy disk drive
functional requirements
grounding
hard disk drive installation
hard disk drives
Hard Drive Activity LED
hardware design criteria
heatsink/fan units (CPU coolers) 2nd
keyboard
memory installation
mice
motherboard
installation
prepare and populate the
network adapter
optical drives 2nd 3rd
PC test run
pen and paper method for standoff verification
processor installation
smoke test
socket latching lever
software installation
speakers 2nd
thermal pad
tuner card installation
use of light for assembly
video adapter 2nd
video capture adapter 2nd
manuals
mass-market PCs
MaxBlast installation software
Maxtor hard drives
MCH (Memory Controller Hub)
media center PCs
cable/satellite PVR
cases
Antec Fusion 2nd
Antec NSK2400
Cooler Master, case manufacturer
preparing
Silverstone, case manufacturer
Commercial Windows Media Center Edition (MCE) PC
CPU cooler installation
DVD recorder
expansion cards installation
final steps
functional requirements
hard disk drives
capacity
installation
noise level
performance
PVRs, dedicated
RAID 0
reliability
Seagate Barracuda 7200.10 ST3750640AS
hardware design criteria
keyboards
Linux PVR Applications
Logitech diNovo Media Desktop
memory
alternative recommendations for
Intel D946GZIS
PC6400 DDR2, memory kit
mice
Microsoft Windows Media Center Edition 2005
motherboards
alternative recommendations for
CPU cooler installation
front panel switch
front-panel audio ports connection
front-panel USB ports connection
indicator cables
installing
Intel D946GZIS
memory installation
populating
power, routing and connecting
processor installation
seating and securing
Serial ATA data cables connection
Socket 775
vacuum fluorescent display
volume control
operating systems
dual-boot Linux and Windows
optical drives
alternative models
Antec Fusion cases
Blu-Ray
HD-DVD
installing
NEC ND-3550A DVD writer
storage
power supply
routing and connecting
verify input voltage
processors
Athlon 64 X2 4200+
dedicated PVRs
dual-core Intel Core 2 Duo
recommended products
software choices
Beyond TV 4
Freevo, Linux PVR application
GB-PVR
hardware selection and
Linux-based PVR applications
Meedio, for PVR application
Microsoft Windows Media Center Edition 2005
MythTV, Linux PVR application
SageTV, PVR application
Studio RGB, support
third-party Windows PVR Applications
speakers
Logitech Z-5500 speaker system
output power of amplifiers, specification of
Peak Power rating
price versus performance
return policy
RMS (root mean square) Power rating
Third-Party Windows PVR Applications
TiVo
TV standards
ATSC (Advanced Television Systems Committee) protocols
ATSC (Advanced Television Systems Committee), U.S. protocol
digital cable source
Digital Television (DTV)
M-PAL, Brazilian protocol
MESECAM, Soviet-bloc and Middle Eastern protocol
N-PAL, Argentina, Paraguay, and Argentina protocol
NTSC (National Television System Committee), North America, Japan protocol
PAL (Phase Alternating Line) Europe, China, and Africa protocol
programmable recordings
satellite signal source
SECAM (Sequential Color with Memory), French protocol
television signaling protocols
TV station, running your own
TV tuner cards
analog tuners
ATI, HDTV tuner source
AVerMedia, HDTV tuner source
Hauppauge WinTV-PVR-150 analog tuner
HDTV tuners
IR Blasters
pcHDTV HD-5500 Hi Definition Television digital tuner
remote controls
verify components
video adapters
external interfaces
Gigabyte GV-NX73G128D-RH
Gigabyte GV-NX73G128D-RH adapter
internal interfaces
noise level
performance
timer cards, compatibility
video components
composite video-out connector
display monitors
DVI (Digital Visual Interface) connector
HDCP support
HDMI (High-Definition Multimedia Interface) connector
RF output connectors
S-Video out connector (Separate Video)
TV tuning
video capture
video encoding/decoding
work surface, choosing
memory modules (DIMMs)
ATI All-In-Wonder
ATI TV Wonder
CAS latency timing support
Corsair 2nd
Crucial 2nd 3rd
Crucial PC3200 DDR-SDRAM
DDR2 memory 2nd
dual-channel memory 2nd
ECC memory
for budget systems
Hauppauge WinTV-PVR-150
Intel D945GCZLR motherboard
Kingston KVR667D2N5K2/2G
Kingston ValueRAM
memory diagnostic
Mushkin 2nd
non-parity memory modules
on-line memory Configurators
PC2 5300
PC2 variants
recommended
Mersenne Prime client, temperature monitor
mice
choices
cordless mouse
hand size
Legacy PS/2 mouse
Logitech LX7 Cordless Optical
Logitech MX-series optical mouse
Microsoft Explorer 5-button mouse
Microsoft IntelliMouse Explorer
Microsoft optical mouse
mouse cord
NiMH rechargeable batteries
optical mouse
recommended
shape
size
standard two-button
touchpad
trackball
two-button mice
wheel mouse
microATX PC
Microsoft DirectX
Microsoft Small Business Server (SBS)
Mini-ITX PC
Mitsumi FA404M
Molex (hard drive) power cables 2nd 3rd
Molex (hard drive) power connector 2nd 3rd 4th 5th 6th 7th
monitor CPU temperature
motherboard setup
back panel connectors
grounding tabs 2nd
Intel D945GCZLR
removal of smudges or skin oil from
seating and securing of
standoff installation
use of power screwdrivers
motherboards
ASRock 939NF4G-SATA2
ASRock K8NF4G-SATA2
ASUS
ASUS A8N-VM
ASUS M2N32-SLI Deluxe motherboard
ATX
battery
BIOS updates
Channel A memory slots
Channel B memory slots
chipset block diagram
connectors
Molex
documentation, checking
driver updates
EPoX EP-9GF6100-M
expansion slots
GeForce 6100 motherboards
Gigabyte GA-K8N51GMF-9
heatsink
Intel D945GNT motherboard
Intel D946GZIS
memory support
microATX 2nd
MSI K8NGM2-L models
NEC ND-3550A DVD writer
passive heatsink
populating
ports
processor socket
processor support
recommended
reference label
Socket 775 (Socket T)
Socket AM2
supplemental I/O controller chip
variants of
wired connectivity
MPC analog audio
MythTV


N

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

NAT/router between PC and modem
NEC ND-3550A DVD writer 2nd 3rd
NeoHE 430 power supply
NeoHE 550
NetGear, AP manufacturer
network adapters 2nd
New Solution Series NSK4400
NewEgg for reviews
NIC (Network Interface Card)
No Boot Device error message
noise reduction
Thermalright cooler
Zalman cooler
notebook computers
NSK1300, video adapters
nVIDIA 6150 integrated video
nVIDIA and Intel chipsets
nVIDIA SLI (Scalable Link Interface)


O

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

OEM components
Office Pro 2003
operating system distribution discs
optical drives
BenQ DW1650
DVD writer 2nd
DVD-ROM drives
LightScribe support
LITE-ON SOHD-16P9S DVD-ROM
NEC ND-3550A DVD writer 2nd
NEC ND-3550A optical drive
NEC ND-3550A optical drives
PATA optical drives
Plextor optical drives 2nd
recommended drives
SATA optical drives
torture test for drives
write to DVD-RAM discs


P

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

P-ATA data cables
P180 case, color suggestion
pcHDTV HDTV tuner
PCI
PCI expansion cards
PCI Express (PCIe) video slots
PCI Express power cables
PCI Express video adapter
PCI gigabit adapter
PCI Gigabit Ethernet adapter
PCIe power cable connection
PCIe power cables
PCIe video adapters
Pentium D BTX cooler
Phantom 500
Plextor PX-755SA
ports
9-pin serial port
digital audio out ports
Mic In audio ports
parallel (LPT) port
S-ATA ports
POST (Power-On Self-Test)
power cables
power supplies/connectors
Antec Phantom 350
Antec Phantom 500
power LEDs 2nd 3rd
power supply efficiency
Power Switch
power switch (PWRSW) connectors
Power Switch (red) connectors
problems with
Silverstone ST30NF
size
price/performance ratio, "sweet spot" 2nd
processors
AMD
AMD Athlon
AMD Athlon 64 X2 2nd 3rd
AMD Athlon X2 processor
AMD Sempron 2nd 3rd 4th
Athlon 64 X2 2nd
ATX AMD Athlon 64 X2 system
Celerons
Core Duo processors
Core 2 Duo (Conroe)
Core 2 Duo E6300
Core 2 Duo Extreme Editions
dual-core processor
high-end ($250+)
Intel
Intel Celeron 2nd
Intel Core 2 Duo 2nd 3rd 4th
Intel Pentium D 2nd 3rd
K7 Sempron
low-end (under $150)
midrange ($150 to $250)
office productivity applications
Prescott-core Pentium 4
recommended
retail-boxed BTX processor
Socket 754
Socket 775 2nd 3rd 4th 5th
Socket 939 2nd
Socket AM2
Thermalright
Zalman
product recommendations
audio adapters
cases, choosing
components 2nd 3rd 4th
components for gaming PCs
components, for media center PCs
diplay monitors
hard disk drives
keyboards
Meedio, for PVR applications
memory modules
mice
motherboards
http://www.hardwareguys.com/picks/motherboards.html
processors
relabeled product brands
Spire SP792B12-U CPU cooler
video adapters
Promise IDE RAID controller


Q

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

quiet PCs, designing
Antec NeoHE power supply
deadening mat
efficient power supply
Enermax NoiseTaker power supply
low-power processors
motherboard with a passive heatsink
PC Power & Cooling Silencer
PC sound deadening mat
quiet case fans
quiet cases
quiet CPU coolers
quiet hard drive
quiet power supply
QuietPC USA
Seagate Barracuda hard drive
Silent PC Review
Smart Drive Enclosure
Thermalright unit
video card with a passive heatsink
Zalman Hard Drive Heatpipe
Zalman unit
QuietPC USA, resistor kits


R

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

RAID (Redundant Array of Inexpensive Disks)
Capacity field, changing disk space
Configuration Utility
configuring 2nd 3rd
Hardware RAID
Hybrid RAID
Intel Matrix RAID support
Intel Matrix Storage Manager
options
RAID 0 2nd
RAID 1 2nd
RAID 3
RAID 5
S-ATA RAID
software RAID
stacked RAID
storage
recommended products
available configurations
cases
BTX cases
choosing
components 2nd
ExtremeTech's ten failed tech trends
Intel Core 2 Duo processor
Intel GMA 950 video
mini-towers
Antec New Solution Series NSK3300 micro-tower
NSK4400 mini-tower
motherboards
Intel 946-/965-series
Intel D945GCZLR
power supplies
ATX power supply form factors
ATX-family power supplies
ATX12V v2.0 380W power supply
product choice table
recommended sources
Antec
Enermax
L. L. Bean
Lands' End
PC Power & Cooling
Seasonic
Reset Switch 2nd 3rd


S

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

S-ATA interfaces
S-ATA power and data cable 2nd 3rd 4th
SageTV, PVR application manufacturer
SATA (Serial ATA) drives
SATA optical drive
SCSI hard disk drives
Seagate Barracuda hard drives
Seagate Barracuda 7200.9 SATA
Seasonic S12 series power supply
Seasonic S12-500 (500W)
Seasonic S12-600 (600W) units
Sempron 3100+
Serial ATA data cables 2nd
Serial ATA hard drives
Serial ATA interface 2nd
service packs and critical updates
SETI@home client, temperature monitor
Sharky Extreme, information site
Shuttle SN27P2
Shuttle, SFF manufacturer
Silent PC Reviews
Silverstone ST30NF power supply
Skype
Small Form Factor (SFF) PCs
cases, preparing
drive bays
final checks
grounding tabs
I/O templates
latches
motherboard clips
mounting holes, viewing
power supply connection
sequential installation, importance of
side panels
standoffs, installation
thumbscrews
components
choices for 2nd 3rd
CPU cooler installation
before motherboard installation
fan power, connection
heatsink removal
mounting holes
orientation of
posts, alignment
securing
thermal pads 2nd
definition of
dress the cables
external peripherals, recommendations
final assembly steps
functional requirements
hard disk drive installation
cables, connection
drive bay 2nd
final assembly step
hard disk drive
hardware design criteria
memory
alternatives for
grounding
locking tabs
memory modules
motherboards
alternative choices
audio header pins
cables, connecting
cables, keeping track of
dual-port USB connector
front-panel audio cable
front-panel switch
front-panel USB ports
grounding tabs
I/O connectors
I/O template
Intel connector block
pin 1
Reset cables
seating of
standoffs
wires, tying back loose
optical drives
processor installation
grounding
pin 1
protective cover
retention plates 2nd
seating of
socket lever 2nd
Shuttle SFF PCs
smoke test
upgrades, useful
verify packing list contents
video adapters
standalone video adapters
video card, passively-cooled
small PCs, designing
LAN Party PC
microATX PC
Mini-ITX PC
Small Form Factor (SFF) PC
Smart Drive Enclosure
software tools
BRU Backup Servers
burn-in utilities 2nd
Configuration Utility
diagnostic utilities
DiscWizard installation utility
Driver CDs
hard disk drive installation/diagnostic utility
Hardware Monitoring software
Hauppauge utilities
Intel Espress BIOS Update utility
Knoppix Live Linux CD utility
major applications discs
MaxBlast installation software
MEMTEST86 memory diagnostic utility
Microsoft Small Business Server (SBS
Norton Ghost utility
OEM software
operating system distribution discs
Passmark BurnInTest utility
Powermax diagnostic utilities
Scalix groupware servers
SeaTools diagnostic software
service packs and critical updates
temperature monitor utility
Ubuntu Serve
Ubuntu/Kubuntu
utilities CD
Windows XP SP2 distribution disc
WinTV-Editor utility
WinTV-Scheduler utility
Xandros 4
Xandros Server
SOHO (Small Office/Home Office) servers
applications, choice of vary with user type
audio CD, backing up
BIOS Setup Configuration jumper
bottlenecks, avoiding
building
cables connections
cases
preparing
components
CPU Cooler installation
dedicated versus shared desktop servers
DV tapes, backing up
external drive bays
external hard drives building
final assembly steps
FLAC files
functional requirements
data safety
expandability
flexibility
massive storage capacity
reliability
television capture
grounding
hard disk drives
identify failed
installation
RAID
Seagate Barracuda 7200.9 Serial ATA
Seagate Barracuda S-ATA
hardware design criteria
disk capacity/performance
expandability
noise level
price
processor performance
reliability
size
video performance
I/O Template
keyboard/mouse
Linux operating system 2nd
lossy compression formats
memory
bottlenecks, avoidance of
Crucial CT6464AA40E PC3200 DDR2 DIMMs
Crucial memory modules
installation
Kingston DDR2 memory modules
motherboards
BIOS, verify support of
cables
compatibility list
front panel switch connection
front-panel audio ports connection
front-panel IEEE-1394a (FireWire) Ports connections
front-panel USB ports connection
installation
Intel D945PVSLKR
Intel-branded motherboard
preparing and populating
seating and securing
standard front panel connector block
optical drives
brand names
installation
NEC ND-3550A DVD writer
power cables
power supply
assembling and installing
failure of
installation
processors
installation
project system
PVR functionality
RAID
software installation
standoffs
tuner card
TV tuner
uncompressed WAV files
UPS
verify packing contents
VGA ventilation duct
warranties on hard drives
workstation/shared server instability
Sony Philips Digital Interface (SP/DIF) audio connector
sources recommended
Best Buy 2nd
CompUSA
GB-PVR, for PVR applications
NewEgg reviews
Office Depot
OfficeMax
SageTV, for PVR applications
SnapStream, for PVR applications
Target
Wal-Mart
speakers
Altec-Lansing 120i 2.0
Creative Labs SBS240
Klipsch ProMedia Ultra 2.0
Logitech S-100 2.0 speaker system
speaker out/subwoofer 2nd
THX-certified Z-2300
Spire SP792B12-U CPU cooler
Spire SP792B12-U KestrelKing
static guard
StorCase, (frame-carrier system)
Suggested Retail Price (SRP)
systems, dust removal


T

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

thermal compounds 2nd
Thermalright
cooler manufacturer
Thermalright unit
Thermaltake CL-P0030
TiVo
Tom's Hardware, information site
Toshiba
TriCool case fans
troubleshooting
audio CDs won't play
BIOS beep codes
cable problems 2nd
configuration errors
CPUs
dead-on-arrival components
display remains black
error messages
flashlights/magnifiers for spotting components
hard drive failure
high-pitch screech or warble
memory modules
Missing Operating System message
No Boot Device message
no speaker sound
offset ribbon connector problems
power supply problems
power shuts off
SATA (Serial ATA) drive recognition
shipping, contents settling
system doesn't boot up
system failure
system refuses to boot from a CD
use of thermal compound
TruePower power supplies
Trusted Platform Module (TPM) chip
Turtle Beach audio adapter
TV tuners
Hauppauge WinTV-PVR-500 2nd
Hauppauge WinTV-PVR-500MCE
MythTV
Windows Media Center Edition (MCE)
WinTV-PVR-150 single-channel
WinTV-PVR-500 dual-channel
TX1088AMG SOHO tower case


U

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

Ubuntu 6.06 LTS (Long Term Support) 2nd
Ubuntu Linux
Ubuntu Server 2nd
Ultra-ATA cable
UPS
APC Back-UPS Pro, for tight budgets
APC Smart-UPS
Falcon Electric SG Series 1 kVA On-Line UPS
USB
USB 2.0 connectors 2nd
USB 2.0 external drive
USB and FireWire cable warning
USB cables
USB connectors
USB dual-port connector pins
USB interface
USB ports


V

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

Vacuum Fluorescent Display (VFD)
vendor pricing services
http://www.froogle.com
http://www.pricegrabber.com
http://www.pricescan.com
http://www.pricewatch.com
VFD/Volume connector
VIA Technologies
video adapters
3D graphics performance
Aero Glass interface
AMD/ATi CrossFire configuration
AnandTech, information site
ASUS M2N32-SLI Deluxe
ATi versus nVIDIA
drivers
dual displays
guidelines
Integrated nVIDIA GeForce 6100
integrated video adapters 2nd
interface for
NewEgg for user reviews
nVIDIA or ATI PCI Express video
PCI Express (PCIe) interface
PCI Express video adapter
PCI Express x16 video adapter slot
video adapter CD
video output connector
Windows Vista
video capture adapters
Hauppauge Win-PVR-USB2
WinTV-Editor utilities
WinTV-Scheduler
video cards
integrated video
passive heatsink
video-out connectors
ViewSonic monitors
VRM (Voltage Regulator Module)


W

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

Western Digital hard drives
Western Digital Raptor
whiteout pen, to identify connectors
Windows
distribution CDs
floppy disk set up
Windows NT/2000/XP
Windows Setup
Windows system stability
Windows XP 2nd
Windows XP Device Manager 2nd
Windows XP Home
Windows XP Pro
Windows XP SP2 distribution disc
wireless access points (WAP)
WLAN (wireless LAN) cards


X

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

Xandros 4 Home Edition Premium
Xandros Management Console
Xandros Server 2nd


Z

Index

[SYMBOL] [A] [B] [C] [D] [E] [F] [G] [H] [I] [K] [L] [M] [N] [O] [P] [Q] [R] [S] [T] [U] [V] [W] [X] [Z]

Zalman Hard Drive Heatpipe
Zalman Motherboard Heatsink
Zalman unit 2nd
Zalman Video Heatpipe
Zero Halliburton, foam liners
ZIF (zero insertion force) lever
ZIF (zero insertion force) socket